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Set up URS Strategy for Queuing

Set up URS Strategy for Queuing

Enable HTTP Interfaces in URS

Create a Listening HTTP Port in URS

URS will listen on this port for incoming HTTP requests. Basically, this steps turns URS into an HTTP
server.

Routing Parameters Reports Administration Centralized Logs Web Engagement ?

Configuration

Home > Applications > Applications > Universal_Routing_Server Properties

|E2 Clone I Delete I Move To

General

Ports Add

Connections

ID & Port & Connection 2 HA S
Ports

default 7202
Tenants

http 5590 http
Options
Permissions
Dependencies %

Application Options

Cancel

In Genesys Administrator Extension, edit your URS application.

Add an HTTP listening port with a port ID http in the Ports tab. Make a note of this port number as
you will need it later when configuring GMS and ORS-based services.
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Configuration

Home > Applications > Applications > Universal_Routing_Server Properties 1 clone 1 Delete Il Move To
General
Application Options Q, Quick Filter Add %X More
Connections
Key El value El
Ports
» default H ! . H
= Do not configure this port in the http section
Tenants
: v e if you already added it to the Ports tab!
Options
_verbose 3
Permissions
log_file C:\legs\Universal_Routing_Server\UR_Server HTTP.log
Dependencies
= http_port 5530
Application Options {b
¥ log
alarm
all C:\logs\Universal_Routing

You can also do this by creating the http port option in the http section of your Application
Options tab.

Warning

This HTTP port needs to be created in one place only.

Enable Web HTTP Replies in URS

URS uses the httpbridge module to send target information back to GMS. To make this possible,
create a web HTTP port that will be used to reply. URS will be able to perform external HTTP requests,
for example, to submit timetodial events to GMS, and so on.

The listening http port created in the previous section and the web port defined
below MUST have different values.
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T Delete I Move To

Home = Applications = Applications > Universal_Routing_Server Properties & Clone

General

Ports Add

Connections

h} B Port B Connection B HA Sync 5 Listening Mode
Ports

default 7202 Unsecured
Tenants

http 5540 http Unsecured
Options

web 5580 http Unsecured
Permissions

Dependencies

Application Options

In Genesys Administrator Extension, edit your URS application. Add an HTTP port with a port ID web in
the Ports tab.
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Configuration

Routing Parameters

Centralize

Home > Applications > Applications > Universal_Routing_Server Properties Clone ﬁ Delete I Move To
General
Application Options Q Quick Filter Add  £X More
Connections
Key & Value =
Ports
> . . ,
Tenants ttp Do not configure this port in the web
Options > log section if you already added it to the
Ports tab!
Permissions ¥ web
Dependencies _verbose 3
Application Options enable_web_access true
http_log_buffering false
http_log_file Ci\logs\Universal_Routing_Server\UR_Server_...
http_port 5580
wfm_polling_interval 1
»
Cancel

You can also do this by creating the http port option in the web section of your Application
Options tab.

e http _port = 5580 (or some other port, used internally)

Warning

This HTTP port needs to be created in one place only.
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Configure URS Delay Strategies

You must deploy URS delay strategies. This step is required because when a service request is
received by GMS, the request is sent to ORS for execution. ORS then sends a request to URS to create
a virtual interaction and to place it in the specified virtual queue. When an agent is available, URS
sends an asynchronous response containing the selected target information to GMS, via a URL
specified at the time of the creation of the virtual interaction. For samples, you will create a new
virtual queue in which to place the interactions, however, for a real-world scenario, the virtual queue
must be selected appropriately.

To deploy URS delay strategies, open Genesys Administrator Extension.
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Create a dedicated Virtual Queue

Home = DNs = Switches = SIP_Switch = DN = Virtual. .. &3 clone ﬁ Delete | Move To
General
Number * Type*
Default DNs GMS_VQ Virtual Queue v
Options Switch*
SIP_Switch
Permissions
Association Register *
Dependencies True v
Alias Route Type *
GMS_vQ_SIP_Switct] Default [s v
DN Group
|
Override

v Use Override

Login ID Switch-specific Type
1
Number Of Trunks
0
Cost Contract Site
Im |
Tenant

. +| State Enabled
Environment

Navigate to Switching > DNs > Switches > SIP_Switch > DN > Virtual Queue and create a virtual
queue GMS _VQ. Save and configure the alias GMS_VQ SIP Switch. You will need this alias when you
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will configure the urs virtual queue option of your Callback service.

Enable ORS to pull interactions and URS to receive routing

requests.

Configuration

Home = Applications = Applications = Universal_Routing_Server Properties 18 Clone T Delete I Move To
General
Application Options Q. Quick Filter Add XX More
Connections
Key E Value E
Ports
¥ default -
Tenants
use_ivr_info true
Options
use_agent_capacity true
Permissions
automatic_attach true
Dependencies
compat_treatments true
Application Options
call_tracking true
report_targets true
route_consult_call true
#event_arrive {b ringing
targets_order random
strategy ORS

Edit the Universal Routing Server Application and select the Options tab. Enable ORS to pull
interactions by setting the strategy option to ORS in the default section.

Now, you can download the URS Strategies and import them into IRD. See the download section
below to manage the downloadable files.

Configure Multiple Targets

The option _target in the URS Queuing section of your callback service allows you to configure one or
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more URS targets (as detailed in the option's description).

To configure multiple targets, you must create a JSON array of targets (maximum 15) and for each
target, you provide a statistic condition that the system will check. This condition specifies when to
switch to the next target. If the condition is not matched, the interaction will be queued. Otherwise,

the system will test the condition of the next target,

Start Queueing
Process

Timeout
L 3 ¥
Cancael Select Flrst Target
r
' . Yes Is last Mo
Queue.Submlt target?
Routed To Agent
(] T
Stat
Queue Submit  ~ N° Cond
hatch?
Timeout
Yes
L
Mext Target

as detailed in the diagram below.

Stat
Cond Mo
Specified
?
Yes
]
5et Stat Check to
NO agents logged in

The condition is defined by the parameters stat to check, stat operator (< or >) and

stat value.
For example, if you set:

{
"target": "GMS AG Kilfoil@Stat Server.GA",
"timeout": "15",
"clear": false,
"stat to check":
"stat operator":
"stat value": "1"

"StatAgentsAvailable",

< ’

¢ The system will change to the next target in the list if StatAgentsAvailable < 1 (no agentis

available).

e The system will queue the interaction to the target GMS_AG_Kilfoil@Stat Server.GA only if
StatAgentsAvailable >= 1 (which means that at least one agent is available). If the duration
specified in the target timeout has passed, and if the agent is not selected, then the statistic condition
for the next target is checked before queuing the interaction for the next target. You can also expand to

the next target if clear = false.
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If you do not set a condition by using stat to check, stat operator, and

stat value, then the tested condition is set by default to no logged in agents.
That means that the interaction is queued to a target only if at least one agent
belonging to the target is logged in.

The stat _to_ check property can be set to any of the values supported by the Statistics parameter
passed to the IRD function SData(Target, Statistics), unless target is a skill expression. If
target is a skill expression, you must choose one of the following values:

e RStatAgentsReadyvoice—agents ready for voice media.
e RStatAgentsReady—agents ready for any media.
* RStatAgentsTotal—agents logged in

The JSON code below is a sample of value for the target option and includes 5 different targets.

[

{
"target": "GMS AG Kilfoil@Stat Server.GA",
"timeout": "15",
"clear": false,
"stat to check": "StatAgentsAvailable",
"stat operator": "<",
"stat value": "1"

}I

{
"target": "GMS AG Milburn@Stat Server.GA",
"timeout": "10",
"clear": false,
"stat to check": "StatAgentsAvailable",
"stat operator": "<",
"stat value": "1"

}I

{
"target": "GMS AG Monique@Stat Server.GA",
"timeout": "30",
"clear": false,
"stat to check": "StatAgentsAvailable",
"stat operator": "<",
"stat value": "1"

}I

{
"target": "GMS AG Oladipo@Stat Server.GA",
"timeout": "15",
"clear": false,
"stat to check": "StatAgentsAvailable",
"stat operator": "<",
"stat value": "1"

b

{

"target": "GMS AG Sippola@Stat Server.GA",
"timeout": "15",

"clear": false,

"stat to check": "StatAgentsAvailable",

"stat operator": "<",
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"stat value": "1"

Use of EWT VQ TARGET in the WaitForTarget IRD Strategy

In Estimated Wait Time scenarios, you can use the EWT VQ_TARGET variable to peg a non-
configured Virtual Queue (VQ) to access the URS LVQ function for this VQ from your inbound routing
application.

The EWT _VQ_TARGET parameter is a copy of the _urs_ewt virtual queue that you can configure in
this purpose.

Since the VQ is not configured, it is internal to URS, no EventQueued or
EventDiverted events will be issued.

To peg the VQ, proceed to the following changes:

1. Configure the _urs_ewt_virtual_queue option with a non-configured virtual queue name.

2. Download the GMS Callback WaitForTarget strategy available in the URS Strategies for Download section
below.

3. Open Interaction Routing Designer (IRD), select the Routing Design / Strategies tab, then load and
compile the GMS Callback WaitForTarget strategy.

4. Add a function block to the WaitForTarget workflow as following:
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[*% Routing Design - WaitForTarget_lvg test

JJ File Edit View Tools Help

ELERIEE R L] |

[BQaé o BEEDe.s = |mra| [|rwesex
LIIIIIIID Log Version 2.72 Lo
N, | Prerequisites: R,
:::::::::::::::::@. oo IRD 8.1.400.26 Sl
S| | URs 8140047 SEEEEEEN
oo e - GMS 8.5.201.04 S
ol R ) SERREREEEE
B R N HHEHE I
| extension aftrbutes .?P##%@I.D@I.e.::::::::::::::::::::::::::
e ey
N _eadyroutabla Mark non routable - - -

5. Edit the function block:
e Under Select expression, enter a new expression name.
* Under Data > Name, select SelectDN.
* In the parameters' table, configure:
e Virtual Queue Name = EWT _VQ TARGET
e Priority =0
¢ SelectionFlag = StatSelectMin

e Target = LOSTFOREVER@.Q
Note: In this example, LOST FOREVER is the name of the non-configured VQ.
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&5 Function properties

General |
— Expression
~|[= [selectDN
[ EWT_VQ_TARGET.D." StatSelectMin,LOST_FORE
VER@.Q7]
—Data
Type Mame
RouteCall a Add |
Calllnfo Routed
Corfiguration Options RouteDelay Veerify |
Data Manipulation Router
Date/Time RwgData
Force SData
List Manipulation SDatalnTenant
Miscelaneous v i Varables |
i o
Parameter Value
Yirtual Queue Name _EWT WO TARGET
Priority 0
Statistics
Selection Flag StatSelectMin
Target LOST_FOREVER®@.O

Retum value type: STRING farget). This function comespands to the initial steps of the A
operation of @ Target-Select object: creating an intemal router queue as a part of a
prescribed virtual queue, inguiring from Stat Server on the availability of any of the listed

L

o< |

Cancel

Help

* Save and compile the block. The WaitForTarget block is now available and ready in the Strategies

tab.

Of course, if you do not use the block, it does not affect the existing WaitForTarget strategy.

¢ These changes can be lost when you upgrade GMS to a newer version. You will have to
redo the steps above if you install a new version of the URS WaitForTarget strategy.

* You can also rename your modified URS strategy and use the _urs_prioritization_strategy
callback service option to select your URS strategy name instead of using the

WaitForTarget default one.

Callback User's Guide
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EWT Usage

This configuration ensures that you can use the lvq URS HTTP request using the connid parameter of
your callback as max to get the URS calculation results for the Estimated Waiting Time and the
position in the Virtual Queue.

curl -v http://<URS_host>:<URS http port>/urs/call/max/lvqg?<parameters>

To get detailed information about this query, check the following URL:
http://<URS_host>:<URS_http_port>/urs/help/call/lvq

URS Strategies for Download

When you upgrade GMS, you need to import the Callback Template from your GMS
installation directory. Start the Service Management Ul, upload the <GMS
Installation Directory>/service templates/callback.zip file, and restart ORS.

GMS version ZIP Instructions

8.5.200.09 and higher GMS_URS_Strategy 85200 v2.64.1.zip 1. Download and unzip the zip

file containing the URS

8.5.207.05 and higher GMS_URS_Strategy_85200_v2.66.zip LB S,

2. Open Interaction Routing

. Designer (IRD).
8.5.208.09 and higher GMS_URS_Strategy 85208 v2.72.zip

3. Import the strategy
WaitForTarget.zcf, and
subroutine
SetRouteDelay.zcf, using
File > Import From File on the

. , respective tabs.
8.5.230.06 and higher GMS_URS_Strategy 85230 v2.73.zip

4. Open the strategy and
subroutine.

5. Compile and save.

e Starting in 8.5.109.08, the URS Dial Success Rate is set to 85% when new callbacks are created to
improve the callback performance.

e Starting in 2.64.1, the DialOutSuccessRate function of the WaitForTarget strategy is no longer
invoked to allow the enhanced VCB algorithm within Universal Routing Server to work properly. If your
application requires the legacy VCB algorithm to work, change the strategy to invoke the
DialOutSuccessRate function as in earlier versions of the strategy.
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You do not need to load the strategy in ORS because ORS will request it when needed.
See the Interaction Routing Designer help file for information about using IRD.

Additional Deployment Steps
Prerequisites:

If you are upgrading Callback from GMS 8.5.004.xx and earlier, make sure that you have the following
components and versions installed:

e Interaction Routing Designer (IRD) 8.1.400.26

¢ Universal Routing Server (URS) 8.1.400.39

Deployment Changes

. Uninstall your existing IRD.

. Install IRD 8.1.400.26.

. Delete the existing WaitForTarget strategy.

. Delete the existing SetRouteDelay subroutine.

. Download the strategies for GMS versions 8.5.114.09 and higher.
. Import into IRD.

. Compile both strategy and subroutine.

. Uninstall your existing URS.

. Install URS 8.1.400.39.

© 00 N O U B~ W N -

Do not skip step 7. This step is mandatory to ensure that the strategy and subroutine
are properly saved and loaded into IRD.
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