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Business Edition Premise Provider's Guide
Business Edition Premise is an all-in-one pre-installed packaging of Genesys technology onto a set of
virtual machines, typically run on a single hypervisor server. It includes SIP Inbound, Outbound, Chat,
and Email solutions, as well as real-time and historical reporting for up to 300 contact center agents.

Business Edition Premise installation and initial configuration requires some knowledge of Genesys
software. The Business Edition Premise Guide documents the procedures needed to configure and
maintain an existing Business Edition Premise environment.

The "If you are new to Genesys software…" section below clarifies the expected roles of providers
and customers.

If you are new to Genesys software…
Business Edition Premise enables you to use the Genesys Administrator Extension interface to set
options (parameters) that tailor routing operations. Some of these options, such as declaring an
emergency or changing open hours, are easily set even if you have no prior experience configuring
Genesys software. Other options, such as auto-attendant (IVR) menus and business targets, are tied
to more complex features that must be synchronized with settings in other Genesys applications.

We suggest that customers rely on their Business Edition Premise provider to set up these features
for them. The provider can then show the customer what options they have customized, such as
business reporting categories (Service, Segment, and Department, for example) and announcements.
The Business Edition Premise Guide specifies the tasks that customers can complete without
assistance from their provider.

Business Edition Premise Provider's Guide
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Architecture

Business Edition Premise overview

Overview

The Business Edition Premise platform consists of a set of three virtual machines (VMs), installed on a
single Dell R430 server running VMware ESXi 6.0. The platform includes the following features and
components:

• Genesys software components, such as Framework, 3rd party Components (Apache Tomcat), eServices,
Routing, and SIP Server, and the PostgreSQL configuration database

• Database features, including MS SQL Server, Genesys DB Servers, Genesys InfoMart, and RAA
• Genesys Voice Platform features, including Voice Platform components such as Media Control Platform

and Resource Manager
• User interfaces, such as Genesys Administrator and Genesys Administrator Extension, Workspace

Desktop Edition (WDE), Pulse, and GI2

After installation and initial configuration, customers can extend the Business Edition Premise server
with additional Genesys applications and functionality.

User interfaces

The table lists the key components used to control settings and reports. The component name links
to its documentation home page.

Architecture
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Component Role

Genesys Administrator User and extension configuration, Outbound
management

Genesys Administrator Extension
Web-based product that simplifies operation
management with the ability to provision, deploy,
and monitor all Genesys applications

Workspace Desktop Edition UI for agents and supervisors
Universal Contact Server Manager Email contact management

Composer Email deployment (and potential customization of
voice and email routing)

Knowledge Manager Email configuration
Genesys Interactive Insights Historical reporting
Pulse Real-time reporting

Architecture
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Pre-installed software components
The table below lists the pre-installed software components (or included IP Packages) that contribute
to the Business Edition Premise solution.

Important
To view the supported version numbers (available after the virtual machine is
deployed and tuned up), open a browser to http://core VM name or IP address.

Component Name Release Note
eServices Chat Server Chat Server 8.5.x Release Note
eServices Classification Server Classification Server 8.5.x Release Note
eServices E-Mail Server Java E-Mail Server Java 8.5.x Release Note

eServices GAX Deployment SPD
Restricted release; the release documentation is
available from the installation package or through
FTP.

eServices Interaction Concentrator eServices Interaction Concentrator 8.1.x Release
Note

eServices Interaction Server Interaction Server 8.5.x Release Note
Genesys Mobile Services Genesys Mobile Services 8.5.x Release Note
Genesys Administrator Genesys Administrator 8.1.x Release Note

Genesys Administrator Extension (GAX) Genesys Administrator Extension 8.5.x Release
Note

Genesys Composer Genesys Composer 8.1.x Release Note
Genesys Configuration Conversion Wizard Framework 8.1.x Wizard Advisory Release Note
Genesys Configuration Server MT Configuration Server 8.5.x Release Note
Genesys DB Server DB Server 8.1.x Release Note Release Note
Genesys Info Mart Genesys Genesys Info Mart 8.5.x Release Note

Genesys Info Mart Administration Console Genesys Info Mart Administration Console 8.1.x
Release Note

Genesys Interaction Concentrator Interaction Concentrator 8.1.x Release Note
Genesys Interactive Insights (GI2) Genesys Interactive Insights 8.5.x Release Note
Genesys Local Control Agent Local Control Agent 8.1.x Release Note
Genesys Deployment Agent Genesys Deployment Agent 8.5.x Release Note
Genesys License Manager (Flex LM)

Genesys Voice Platform Media Control Platform Genesys Voice Platform Media Control Platform
8.5.x Release Note

Genesys Message Server Message Server 8.5.x Release Note

Architecture Pre-installed software components
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Genesys Orchestration Server Orchestration Server 8.1.x Release Note
Genesys Outbound Contact Server Outbound Contact Server 8.1.x Release Note
Genesys Pulse Genesys Pulse 8.5.x Release Note Release Note
Genesys Pulse Collector Genesys Pulse Collector 8.5.x Release Note

Genesys Reporting and Analytics Aggregates Reporting and Analytics Aggregates 8.5.x Release
Note

Genesys Voice Platform Resource Manager Genesys Voice Platform Resource Manager 8.5.x
Release Note

Genesys SIP Server SIP Server 8.1.x Release Note
Genesys SNMP Master Agent SNMP Master Agent 8.5.x Release Note
Genesys Solution Control Server Solution Control Server 8.5.x Release Note
Genesys Stat Server Stat Server 8.5.x Release Note
Genesys Universal Contact Server Universal Contact Server 8.5.x Release Note

Genesys Universal Contact Server Manager Universal Contact Server Manager 8.5.x Release
Note

Genesys Universal Routing Server Universal Routing Server 8.1.x Release Note
Genesys Knowledge Manager Knowledge Manager 8.5.x Release Note
Genesys Workspace Desktop Edition Workspace Desktop Edition 8.5.x Release Note

Genesys Workspace Desktop Edition SIP Endpoint Interaction Workspace SIP Endpoint 8.5.x Release
Note

Business Edition Premise and its components use these third-party components:

• 7-Zip (x64 edition)
• Apache Tomcat
• Business Objects
• Eclipse Jetty Web Server
• Eclipse Mars 2 IDE for Java Developers 64-bit
• Java JDK x64
• Java JRE x64
• PostgreSQL
• Python (32-bit edition)
• SoX

In addition, BEP 8.5.000 uses these third-party components:

• Apache Cassandra
• Apache Tomcat Commons Daemon
• MS SQL Server 2012
• MS SQL Server JDBC Driver

Architecture Pre-installed software components
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• VMware vSphere

For information about updating components, see the Genesys Migration Guide

Architecture Pre-installed software components

Business Edition Premise Provider's Guide 8



Sizing and performance assumptions
This page describes the sizing and performance assumptions for each of the Business Edition Premise
routing applications.

Voice input assumptions
Input Assumptions BEP 50 BEP 100 BEP 300
Agents per system (90%
of customers) 50 100 300

Worst-case agents per
system 50 100 300

Agent utilization 80% 80% 80%
Call qualification time 60s 60s 60s
Queue time 120s 120s 120s
Talk time 180s 180s 180s
Calculated worst-case values
Calls/Agent/Hour 16 16 16
Concurrent active calls 50 100 300
Peak CAPS (Call Arrivals
per Second) 0.4 0.8 2.2

Busy hour calls 1 440 2 880 7 920
Calls per day 6 840 13 680 41 040
Calls per month 150 480 300 960 902 880
Additional assumptions
Percentage of hold time 30% 30% 30%
Percentage of
transferred calls 30% 30% 30%

Percentage of
conference calls 10% 10% 10%

Percentage of monitored
calls 5% 5% 5%

Average attached data
size 512 bytes 512 bytes 512 bytes

Attached data requests
per call 5 5 5

Retention period for
historical data 13 months 13 months 13 months

UCS data retention 3 months 3 months 3 months

Architecture Sizing and performance assumptions
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Input Assumptions BEP 50 BEP 100 BEP 300
ICON data retention 7 days 7 days 7 days

Email input assumptions
Input Assumptions 50 Agent 100 Agent 300 Agent
Agents per system (90%
of customers) 12 25 75

Worst-case agents per
system 12 25 75

Agent utilization 80% 80% 80%
Queue time 1-2 days 1-2 days 1-2 days
Processing time 6m 6m 6m
Calculated worst-case values
Emails/Agent/Hour 10 10 10
Concurrent active
emails being processed 12 25 75

Peak EAPS (Email
Arrivals per Second) 0.2 0.4 1.25

Busy hour emails 720 1 440 4 500
Emails per day 1 512 3 420 10 260
Emails per month 33 264 75 240 225 720
Additional assumptions
Average email size 50 K 50 K 50 K
Average attached data
size 512 bytes 512 bytes 512 bytes

Attached data requests
per email 5 5 5

Chat input assumptions
Input Assumptions 50 Agent 100 Agent 300 Agent
Agents per system (90%
of customers) 12 25 75

Worst-case agents per
system 12 25 75

Agent utilization 80% 80% 80%
Queue time 120s 120s 120s
Processing time 8m 8m 8m

Architecture Sizing and performance assumptions
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Input Assumptions 50 Agent 100 Agent 300 Agent
Calculated worst-case values
Chats/Agent/Hour 16 16 16
Concurrent active chats
being processed by an
agent

3 3 3

Peak chats per second 0.15 0.3 1
Busy hour chats 540 1 080 3 600
Chats per day 2 988 6 120 18 000
Chats per month 66 000 132 000 396 000

Outbound input assumptions
Input Assumptions 50 Agent 100 Agent 300 Agent
Agents per system (90%
of customers) 10 20 60

Outbound voice
percentage of total
interactions

20% 20% 20%

Worst case agents per
system 10 20 60

Agent utilization 80% 80% 80%
Talk time 180s 180s 180s
Calculated worst-case values
Outbound interactions
per day 1 368 2 736 8 208

Outbound voice peak
IPS 0.4 0.8 2.2

Inbound + outbound
peak IPS 0.8 1.6 4.4

Peak Outbound CPH per
System 160 320 960

Avg Talk Time (includes
ACW) 20s 20s 20s

Outbound campaigns
per system 5 5 10

Bytes per Outbound
calling record 600 600 600

Outbound customer
calls (% answered) 33% 33% 33%

Outbound customer
calls (% busy) 33% 33% 33%

Architecture Sizing and performance assumptions
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Input Assumptions 50 Agent 100 Agent 300 Agent
Outbound customer
calls (% no answer) 33% 33% 33%

Architecture Sizing and performance assumptions
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Known Issues and Corrections
<tabber>

General=

This tab includes known issues found in or affecting all versions of Business Edition Premise 8.5.0.

To view known issues in BEP components, click the links in the Release Note column of the
Components topic.

Interaction Server crashes when started using the Management Layer

When Interaction Server is started from the Management Layer, it crashes, but automatically
restarts. This issue has no impact to the Production environment. (ERS-11863)

Genesys Administrator does not display correctly in Microsoft Internet Explorer 11

When using Genesys Administrator with Microsoft Internet Explorer 11 browser, some of the user
interface elements do not display correctly (for example, text overlaps with check boxes).
(GENONE-1729)

Workaround: Use another supported browser, or use Internet Explorer 11 in compatibility mode, as
follows:

• Open the browser and press the ALT key to display the Internet Explorer menu bar.
• Go to Tools > Compatibility View settings and select Add this website.
• Enter the URL for Genesys Administrator and click Add.

eServices component shutdown through the eServices Solution can cause voice call
routing to stop

If you have deployed the email option in Business Edition Premise, any subsequent stoppage of
eServices using the eServices solution shuts down call routing due to the presence of shared
components in eServices and voice solutions. (ESHDP-153)

Workaround: Do not use the eServices solution to shut down eServices while voice call routing is
ongoing. To shut down eServices, shut down the individual eServices applications.

|-| All Locales=

Latest version: 8.5.001.01

This tab includes known issues found in or affecting localized versions of BEP. All issues under the
General tab also affect each locale.

To view known issues in BEP components, click the links in the Release Note column of the

Known Issues and Corrections Sizing and performance assumptions
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Components topic.

GI2 reports are not displayed in the local language

By default, the Administrator account in SAP Business Intelligence uses en_US for the Product
Locale and Preferred Viewing Locale. When creating new users, if you want them to see reports
in a local language, change these two settings to the locale you want to use.

For example, to view GI2 reports in French, log in to the SAP Management Console and click
Preferences. Under CMC Preferences, select French for both the Product Locale and Preferred
Viewing Locale.

GAX Solution Definitions are not displayed in the local language

In localized versions of BEP, some of the GAX Solution Definitions (such as the solutions for chat and
outbound) are displayed in English while others are displayed in the localized language.

If a Solution Definition is displayed in English, it is because there is currently no localization support
for that definition.

Known Issues and Corrections Sizing and performance assumptions
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Installing Business Edition Premise
The Business Edition Premise installation consists of an off-site and on-site portion. The off-site
installation steps are performed before the server is delivered to the Premise (or customer) site and
the on-site installation steps are performed after the server is delivered to the Premise site.

Although Business Edition Premise typically comes pre-installed on a server, you can also procure the
required server and install Business Edition Premise on it yourself, as detailed in these instructions.

Start here

Part I: Off-site installation

Tip
If you have received your server with the VMs already deployed, you can skip Part I:
Off-site installation and proceed directly to Part II: On-site installation.

Installing Business Edition Premise Sizing and performance assumptions
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Part I: Off-site installation
These steps describe how to prepare the server for delivery to the premise site. You must complete
these steps in order, and before the server is taken to the premise site for the next phase of BEP
installation.

Procure the required hardware
Requirement Minimum configuration

Server type Dell PowerEdge R430
Processor Intel Xeon E5-2630 (2.40 GHz, 20 M Cache)
Additional processor Intel Xeon E5-2630 (2.40 GHz, 20 M Cache)
Memory (RAM) 48 GB
Controller PERC H730 1 GB RAID Controller

Hard drives 7x300GB 15 K SAS disks: 6 disks for RAID5 + 1 hot
spare; 2.5 inch drive chassis

Guest Operating System Microsoft Windows 2012 Server R2 Standard
Hypervisor Operating System ESXi 6.0

Provision the network

Provision the network to include:

• One IP address within a management control subnet for Dell iDRAC setup and configuration.
• One IP address within the same subnet and available on a Windows domain running DNS/DHCP services

for ESXi 6.0 server.

Set up the server hardware and iDRAC

WATCH: Business Edition Premise: Setting up the iDRAC Interface:

Link to video

Perform the initial hardware setup and configure the iDRAC management board.

1. Perform the initial hardware setup of the server:
• Connect a network cable to the iDRAC internal management board.

Installing Business Edition Premise Part I: Off-site installation
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• Connect a network cable to port 1 of the main Ethernet board (integrated with the motherboard).
• Connect the power cable.
• Directly attach a monitor, keyboard, and mouse.

2. Power-on the server by pressing the power button on the front of the console.
3. After the Dell Lifecycle Controller completes the system inventory and displays the Settings –

Language and Keyboard screen, do the following:
• Select Next to accept the defaults for Language and Keyboard Type (English/United States).
• On the Network Settings screen, select DHCP from the IP Address Source drop-down list and

click Finish.

4. Configure the server for remote access using the iDRAC management board:
• Go to Hardware Configuration > Configuration Wizards > iDRAC settings > Network.
• Record the MAC Address displayed under Network Settings (this is required for an upcoming

step).
• In the IPV4 Settings section, set Enable DHCP and Use DHCP to obtain DNS server

addresses to Enabled.
• In the IPMI Settings section, set Enable IPMI Over LAN to Enabled.
• Click Back.
• Click Finish and select Yes to save the changes.
• Click System Time and Date Configuration.
• Set Time to the current local time.
• Click Finish and then click Back to exit the Configuration Wizard.
• Go to System Setup > Advanced Hardware Configuration > System BIOS > System Profile

Settings.
• From the System Profile drop-down menu, select Performance.
• Click Back.
• Click Finish and select Yes to save the changes.

5. Update DHCP and DNS for the iDRAC management board:
• Enter the MAC address you recorded earlier into the DHCP server configuration and restart the DHCP

service.
• Update the DNS server with the iDRAC hostname and IP address.
• You can access the system using iDRAC by entering the following URL into a browser:

https://<hostname or ip address>/login.html

Obtain the required licenses

Obtain the following licenses:

Installing Business Edition Premise Part I: Off-site installation
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• One embedded Microsoft SQL Server 2012 R2 64-bit license, required for internal access of server
components.

Important: This license to be applied on the Premise site.

• Two embedded Microsoft Windows Server 2012 R2 64-bit licenses.
Important: These licenses to be applied on the Premise site.

• Two VMware vSphere Standard Server ESXi 6.0 license for 2 physical CPUs (unlimited cores per CPU).
• Alternatively, you can purchase the BEP Operations pack from Genesys, which contains appropriate

licenses from Microsoft without the need for client access licenses.
• Genesys software license for 50, 100, or 300 agents.

Important: The MAC address information required for this license is obtained from the VM during
server configuration.

Configure the server

These steps describe how to configure the server storage as a RAID-5 disk group containing two
virtual disks. Virtual Disk 1 is used for the installation of the ESXi operating system and Virtual Disk 2
is used for the virtual machine VMFS5 datastore.

WATCH: How to configure the server storage (for 100 to 300 agents) as a RAID-5 disk group
containing two virtual disks:

Link to video

Important
The creation of a root password for the ESXi server and the configuration of additional
user accounts is at the discretion of the person performing the installation.

1. Login to iDRAC and launch the Virtual Console, and then power on the server.
2. Configure disk group 0 and Virtual Disk 1:

a. Press <CTRL> + <R> during POST to enter the RAID Configuration Utility.
b. Configure the server as RAID-5 with a single hot spare drive. Under Physical Disks, select Disk IDs

*:00 through *:05.
c. Under Basic Settings, change the VD Size to 10 GB and type ESXi as the VD Name.
d. Enable the Advanced Settings option and select Initialize (reply OK to the warning) and

Configure Hot Spare.
e. In the Dedicated Hotspare for Disk Group 0 window, select the first Disk ID and select OK.

3. Configure virtual disk two:
• From the Virtual Disk Management screen, select Disk Group and then Add New VD.
• For the VD Name, type VM Storage.
• Enable Advanced Settings and confirm that the Read Policy is Adaptive Read-Ahead and the

Installing Business Edition Premise Part I: Off-site installation
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Write Policy is Write Back.
• Select Initialize (reply OK to the warning).
• Exit and reboot the server.

4. Modify the boot sequence for the server:
• Press F2 during POST to enter the system BIOS.
• From the BIOS menu, navigate to System Setup Main Menu > System BIOS > Boot Settings >

Bios Boot Settings > Hard-Disk Drive Sequence.
• Move the Integrated RAID Controller (H710P or H730) to the top of the list.
• Exit and reboot the server.

Install the VMware vSphere ESXi Server and Client

WATCH: ESXi Server installation:

Link to video

1. Install VMware vSphere 6.0 Standard ESXi Server on the 20 GB Virtual Disk 1 (configured in the previous
step), using the license you procured. Give the server a unique name such as bep_location.

For more information about VMware vSphere 6.0 Standard ESXi Server, see the VMware vSphere
ESXi and vCenter Server 6.0 Documentation (opens in a new window or tab).

• After installing, navigate to Configure Management Network > IPv6 Configuration and disable
IPv6 support.

2. If you are installing the VM off-site, you must perform the following steps, which you will need to repeat
at the customer site (see On-site installation):
• Power on the ESXi server and retrieve its MAC address (for setup in a DHCP server to assign an IP

address and in a DNS server so the host name of the ESXi server can be associated to the assigned
IP address when first connected to the network):
• Open the ESXi console for your ESXi server and go to <F2> Customize System/View Logs >

Configure Management Network > Network Adapters/<D> View Details.
• Copy the MAC address.
• Log into the DHCP server.
• In the Command window, configure the MAC address with the assigned IP address for the ESXi

server.
• Restart the DHCP server.

3. Install the VMware vSphere 6.0 Client on any Windows workstation that has network connectivity to the
ESXi Server:

IMPORTANT: The ESXi server must be powered on.

• Open a browser and enter the IP address assigned to the ESXi server.
• On the VMware ESXi Welcome page, click the download link for the VMware vSphere 6.0 Client

and follow the prompts to install. For more information, see the VMware vSphere ESXi and vCenter
Server 6.0 Documentation (opens in a new window or tab).

Installing Business Edition Premise Part I: Off-site installation
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Configure the VM storage requirements

WATCH: Virtual storage configuration:

Link to video

1. Log in to the vSphere Client workstation as a user with ESXi administrator rights and select the
Configuration tab.

2. In the Hardware section, click Storage, and then select Add Storage.
3. Accept the default settings by clicking Next for each configuration screen, and give the datastore a

name (for example, VM Storage).
4. For the Capacity, accept the default selection of Maximum available space.
5. Click Finish.

Deploy the VM platform

Obtain the OVA VM template and deploy the VMs.

1. Obtain the OVA VM template:
• Log into the vSphere Client as a user with ESXi administrator rights.
• Select File > Deploy OVF Template
• Save the BEP OVA VM template to a network drive on the same subnet as the ESXi Server or to a

Genesys-supplied hard drive.

2. Launch the file and deploy the VMs:
• The VM names must be in the following format:

VM role-platform-product version-language code.

Example: g1-core-p-win2012r2std-8500005-enus.ova

file:bep_vm_deployment.png

Important
Do not change the VM naming format!

• Genesys recommends that you keep the default settings during deployment.

Important
When selecting storage for the OVA file, a minimum of 800 GB of available storage is required.

Installing Business Edition Premise Part I: Off-site installation
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Enable VM restoration

To enable VM restoration, take a snapshot of a VM in its current state.

1. Right-click on the VM and select Snapshot.
2. From the Snapshot menu, select Take Snapshot.
3. In the Take Virtual Machine Snapshot window, enter a name and description for the snapshot.
4. Click Ok.

For more information about snapshots, see Using Snapshots To Manage Virtual Machines in the
VMware in VMware vSphere ESXi and vCenter Server 6.0 Documentation (opens in a new window or
tab).

Confirm that the VM starts

Power on the VM and confirm that it starts by opening its Console window and verifying that the Set
Up Windows screen is visible. Once confirmed, power off the VM.

Important: Do not proceed with the Set Up Windows steps unless the server is located at the
Premise site.

Tip
Although the tune-up script starts automatically on the VM after you log in, you can
select to postpone the tune-up procedure until the next restart of the VM. To do so,
select No when the script asks "Would you like to do the tune-up now?" The script
automatically starts when the VM restarts at the customer site, and continues to run
during each restart until it completes successfully.

Off-site verification checklist

These steps confirm that the off-site portion of the installation is complete and that the server is
ready for delivery to the Premise site.

1. Log in to iDRAC and confirm the following:
• The server configuration is RAID-5.
• The storage controller card model is H730 for R430 models (or H710P for all other models).
• Disk sizes are 600 GB, 15K, SAS.

2. Connect to the ESXi server with a vSphere client and confirm the following:
• The VM is deployed and able to start.

Installing Business Edition Premise Part I: Off-site installation
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• The ESXi server has all CPUs (>= 16 CPUs) and RAM (48 GB).
• The VM is present, with a snapshot taken.
• You can locate the MAC address for the VM, as this is needed when ordering appropriate Genesys

licenses.
• Ensure that you have adjusted the memory and CPU values of the VM as required for your

deployment.

Installing Business Edition Premise Part I: Off-site installation

Business Edition Premise Provider's Guide 22



Part II: On-site installation
These steps describe how to finalize the server installation and configuration at the premise site.

Important
Perform these steps only after the off-site portion of the installation is complete and
the server is delivered to the premise site.

The steps are divided into several subsections and must be completed in the order described.

Before you begin

Confirm that you have the required licenses

Important
You require the following licenses before installing Business Edition Premise. If you do
not have all required licenses, do not proceed with the installation steps.

• One Windows Server 2012 license key for activating Windows when starting the VMs.
• One Genesys software license for the required number of agents.
• One Business Objects Enterprise (BOE) version 4.1.x license key.
• One Microsoft SQL Server 2012 R2 64-bit license.

Provision the network
Provision the network to include:

• Three IP addresses within a single subnet and available on the Windows domain running DNS/DHCP
services for the Virtual Machines (VMs); you also need to assign a hostname for each VM for entry into
a DNS server

• One IP address within a management control subnet for Dell iDRAC configuration, to enable hardware
alarming using email (the address must be able to access the customer corporate email server)

• One IP address within the same subnet and available on a Windows domain running DNS/DHCP services
for ESXi server.
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Hardware configuration

Set up hardware monitoring
Your Dell server includes an Integrated Dell Remote Access Controller (iDRAC) that monitors the
server hardware and can send email notifications to help you avoid the data loss that will occur if two
drives in the RAID array fail.

Warning
Failure to monitor the health of your RAID array can result in loss of data.
Ensure that you set up Dell hardware monitoring with email notification.

1. Use a browser to log into the Dell iDRAC at https://IP address/login.html, where IP address is the
management interface IP address or DNS entry name. Enter the username and password that you
specified when configuring the iDRAC.

2. Navigate to Alerts > Alerts Filter.
• Ensure that only System Health, Storage, Warning, and Critical are checked.
• Uncheck the other five items.
• Click Apply.

3. Under Alerts and Remote System Log Configuration, check the Email box in the heading for each
of the 8 pages.

4. Select the SNMP and E-Mail Settings tab.
• Under Destination E-mail Addresses, add up to four addresses to receive alert emails.
• Check State for each address.
• Click Apply.

5. Under SMTP (E-Mail) Server Address Settings:
• Enter the IP address or FQDN/DNS name of the corporate email server (authentication is optional).
• Click Apply.

6. Under Destination E-mail Addresses:
• Click Send to send an email alert to each of the configured accounts.
• Verify that each account received the test email.

7. Return to the Alerts tab. Enable alerts and click Apply.

Configure Time Zone and Network Time Protocol (NTP)

1. Navigate to Overview > iDRAC Settings > Properties > Settings. The Time Zone and NTP page
appears.
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2. From the Time Zone drop-down menu, select the required time zone and click Apply.
3. Enable NTP, enter the NTP server addresses, and click Apply.

DHCP and DNS server assignment

Update DHCP and DNS servers for ESXi
Power on the ESXi server (if needed) and retrieve its MAC address (for setup in a DHCP server to
assign an IP address and in a DNS server so the host name of the ESXi server can be associated to
the assigned IP address when first connected to the network).

1. Open the ESXi console for your ESXi server and do the following:
• Go to <F2> Customize System/View Logs > Configure Management Network > Network

Adapters/<D> View Details.
• Copy the MAC address.

2. Log into the customer DHCP server.
• In the Command window, replace the existing MAC address for the ESXi server with the one you

copied.

3. Restart the DHCP server.
4. Update the customer DNS server with new host name of the ESXi server and the IP address assigned

from the customer pool of addresses and given out by their DHCP server.
5. Open a DOS prompt and confirm the DNS association by doing a Forward and Reverse nslookup, as

follows:
• nslookup <IP_address>
• nslookup <hostname>

Update DHCP and DNS servers for the VMs
Before you power on the VMs, retrieve their MAC addresses (from VM properties) to populate the
DHCP server and update the DNS server.

1. In the vSphere Client inventory, right-click each VM and select Edit Settings > Network adapter 1 to
view its MAC address. Copy each address.

2. Log into the DHCP server. In the Command window, replace the existing MAC address for each VM.
3. Restart the DHCP server.
4. Update the customer DNS server with the new host name of the VM server and the IP address assigned

from the customer pool of addresses and given out by their DHCP server.
5. Open a DOS prompt and confirm the DNS association by doing a Forward and Reverse nslookup, as

follows:
• nslookup <IP_address>
• nslookup <hostname>
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Configure NTP on the ESXi server

Configure an NTP (network time) daemon to synchronize the VM.

1. In the vSphere Client, select the ESXi server, and then select the Configuration tab.
2. From the Software menu, click Time Configuration and select Properties.
3. Select NTP Client Enabled and then click Options. The NTP Daemon (ntpd) Options window

opens.
4. In the NTP Daemon Options window, do the following:

• Under General, select Start and stop with host.
• Click OK.

Important
You must be back in the Time Configuration screen to do the next step.

• In the Time Configuration window, click Options.
• Under NTP Settings, add an NTP Server in the customer time zone (the NTP Server website lists

available NTP servers) and select Restart NTP service to apply changes.
• Click OK.

5. Select Options and verify that the General settings are as follows:
• Status = Running.
• Startup Policy = Start and Stop with Host.
• The Start button appears in the Service Commands section.

6. Click OK to close the NTP Daemon Options and Time Configuration windows.

Configure the VMs

These sections describe how to set up and configure the VMs, configure the BOE tuneup script, and
apply the Microsoft and Genesys application licenses and configuration changes.

Important
The VMs must be configured in the order shown, starting with the core, then the db,
and finally, the ui VM.
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Configure the core VM
Important: This VM must be configured first.

1. Power on the core VM and open Console.
2. In Windows setup, enter the locale and product key, accept the license terms, and assign a password for

the Administrator account.
3. Log in as Administrator. The Windows desktop loads and the tune-up script automatically runs.

Tip
If you enter incorrect information during the tune-up script configuration, simply
redeploy the VM and begin the tuneup script configuration again. If you made a
snapshot of the VM prior to entering any data for the tune-up configuration script,
you can revert to that snapshot.

When prompted:

For the Host naming scheme:

• Select 1 to use default host names (g1-core-p, g1-db-p, g1-ui-p). Use this option for environments
that you do not plan to extend and if the default naming convention suits your needs.

• Select 2 to use default host names with custom suffixes (such as g1-core-p-env1). The script prompts
you for the suffix. Use this option if default names with suffixes agree with your host naming
convention.

Important
The suffix can contain no more than 4 characters.

• Select 3 to use custom names for each host (such as newyork-core and newyork-ui). The script
prompts you for each name, which should identify the role of the host (core, ui, or db). Use this option
if you need to conform to a customer naming convention.

Important
Each host name can contain no more than 15 characters.

For the Domain configuration:
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Tip
This setting defines how the FQDN of the hosts is presented in Genesys Configuration.
Genesys software uses these names when establishing network connections.

• Select 1 to have the tune-up script use the domain name that it detects automatically.
• Select 2 (Other domain name) to enter the domain name manually. When prompted, enter the domain

name.

• When prompted, specify the gateway-ip-address and gateway-port as required for your VoIP media
gateway (source and destination of VoIP traffic) configuration.

• Reply yes to rename and reboot the VM.

Important
Ensure that the VM fully restarts before continuing to the next step, but do not log on.

Configure the db VM
Next, power on and configure the db VM.

1. Power on the db VM and open Console.

Important
For localized versions, you must first select a language before proceeding with Windows setup.

2. In Windows setup, set the locale, enter the product key, accept the license terms, and assign a
password for the Administrator account.

3. Log in as Administrator. The Windows desktop loads and the tune-up script automatically runs. When
prompted:
• Enter the Primary Core Host IP address (do not use the host name).

4. The time zone is configured as part of the tune-up script (this only applies to the db VM).
• Set the time zone for GIM in the format Continent/City or Region. (For a list of time zones, see the TZ

column in List of tz database time zones.)

5. Enter Yes to rename and restart the VM.

Important
Ensure that the VM fully restarts before continuing.
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Run the core VM tune-up script
This is the second phase of the core VM tune-up script.

1. Log into the core VM. The core VM tune-up script starts automatically.
2. When prompted, confirm that the db VM was restarted.
3. When the script finishes, press any key to continue.

Configure the ui VM
Configure this VM last, after the core and db VMs are configured.

1. Power on the ui VM and open Console.

Important
For localized versions, you must first select a language before proceeding with Windows setup.

2. In Windows setup, set the locale, enter the product key, accept the license terms, and assign a
password for the Administrator account.

3. Log in as Administrator. The Windows desktop loads and the tune-up script automatically runs. When
prompted:
• Enter the Primary Core Host IP address.
• Enter Yes to rename and restart the VM. Ensure that the ui VM fully restarts before you proceed.

Configure the BOE tune-up script
The tuneup_boe.bat script runs automatically during ui VM startup.

1. Enter the BOE license code.
2. Wait for the BOE tune-up script to finish and close.

Important
It is normal to experience a delay during this step as the script can take 30 minutes or more to complete. The
progress bar will automatically refresh itself every 20 seconds.

3. Restart the VM.

Apply licenses and configuration changes
Apply the Microsoft and Genesys application licenses and configuration changes.
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Important
Make sure the BOE configuration script has already run before completing this step.

1. To change the Time Zones on all VMs, go to Server Manager > Local Server > Time Zone, and set
the time zone in the format Continent/City or Region. (For a list of time zones, see the TZ column in List
of tz database time zones.)

2. Set up Genesys License Manager by placing the Flex LM license file (acquired earlier) in the GCTI\flexlm
folder on the g1-core VM.

Important
Altering the Windows Operating System Regional settings (other than time zone) may result in a failure when
attempting to apply the MS SQL Server 2012 license key at the completion of the BEP installation.

3. Next, on the db VM host, add the Microsoft SQL Server 2012 R2 64-bit license:
• Launch SQL Server Installation Center (64-bit) and select Maintenance.
• Select Edition Upgrade, and click OK to begin the setup.
• Click Next through the Setup Support Rules.
• Enter the Product Key, and click Next.
• Accept the license terms, and click Next.
• Select the Instance, and click Next.
• Click Upgrade.

WATCH: A quick video showing the Microsoft SQL Server 2012 license application.

Link to video

4. If your environment uses a domain, you can add it by going to Server Manager > Local Server >
Computer Name. (Requires VM restart.)

5. Restart the VMs.

Verify the status of Genesys services
1. Enter Services in the Search programs and files dialog box.
2. Select Services and locate groups of services with names starting with Genesys in the list of local

services.
3. Confirm that all Genesys services have a status of Started with a startup type of Automatic, with the

following exceptions:
• Genesys Outbound Contact Server (g1-core) [OCS] (not started, Manual)
• GDA (not started, Disabled)
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Configure Genesys Interactive Insights
Important: Don't skip this step. You must configure Genesys Interactive Insights (GI2) on the host where the SAP Business Intelligence
reporting platform is installed.

WATCH: A short demonstration of GI2 configuration.

Link to video

1. Go to the Windows Apps screen. In the SAP Business Intelligence section, select the Information
Design Tool.

2. In the Repository Resources section, click (+) to insert a new session. Use the following details:
• System=[hostname where SAP Business Intelligence is installed]
• User Name: Administrator
• Password: G3n35y5

3. Expand Repository Resources, then expand Connections and double-click GI2_GIM_DB.
4. Select Change Driver.
5. Go to Microsoft > MS SQL Server 2012, and select JDBC Drivers.
6. Click OK.
7. Fill out the Edit Relational Connection details as follows:

• Authentication Mode: Use specified user name and password
• User Name: genesys_gim
• Password: Genesy$_0_gim
• Server: [MS SQL server hostname]:1433
• Database: gim_etl

8. Click Test Connection, and then save your changes.

Backup the VMs
Genesys recommends that you backup the VMs by exporting them to an external location or device. For each VM, do the following:

1. Open the vSphere Client.
2. Power off the VM.
3. In the vSphere client, highlight the target VM and select File > Export > Export OVF Template.
4. For the file format, select Single File (OVA).
5. Specify the output file name and location.
6. Export the file.
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Voice routing application

Overview

Inbound routing

The voice routing application is deployed automatically during BEP installation and provides essential
inbound call center functions using built-in strategies:

• Entry handling based on contact center status
• Auto-attendant (Interactive Voice Response) menus
• Call distribution based on agent availability and call priority

Entry handling
The application receives the incoming call, retrieves the dialed number (DNIS), and applies status
conditions to the call. Is the contact center closed, and if so, why?

• Is it a holiday? If so, the caller hears the Special Day announcement.
• Did the call come in outside of normal operating hours? If so, the caller hears the Closed

announcement.
• Is an emergency underway? If so, the caller hears the Emergency announcement.
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If the contact center is open, the caller hears an announcement or the auto-attendant menu (if one
exists), or the call passes directly to an agent.

Auto-attendant menus
If you have given the caller a menu of options (“Press 1 for Sales,” and so on), the call passes to the
Auto-attendant menu (DTMF) workflow, which specifies the action to be taken depending on the
caller’s menu choice. The Auto-attendant flow can cycle up to three times, to accommodate three
layers of routing. The Auto-Attendant Menus (DTMF) workflow, diagrammed below, acts as an
Interactive Voice Response tree to the customer. It plays a menu announcement configured in the
Inbound Template, and assigns a Distribution Parameter Group or an Inbound Parameter Group based
on the digit (touch tones) collected. For example: The announcement gives the customer three
choices (Press 1 for Customer Service, 2 for Sales, and 3 for Technical Support):

• Touch tone 1 = Customer Service (Distribution Template)
• Touch tone 2 = Sales (Distribution Template)
• Touch tone 3 = Tech Support at Route Point 6001 (the Inbound Template that matches the DNIS for the

Technical Support Route Point)

The auto-attendant flow can accommodate up to three cycles during a call. In the example above,
Touch tone 2 (Sales) might give the caller a second set of options: for Product A, press 1; for product
B, press 2, and so on. To learn how to build your menus, see the Configuration tab.

Call distribution
The Distribution call flow distributes the call to an agent:

1. It collects statistics to determine what agents are logged in and available to take the call.
2. It routes the call to an agent from a target agent group: it first tries an agent from Target 1, then, in

sequence, tries Targets 2, 3, and 4 if it does not find an agent within the timeout set for that target.
Finally, if it does not find an agent from Targets 1-4 within the allotted time, it sends the call to the
overflow target, which can be a standard telephone number (such as 415-555-1212) or a routing point
(such as 6001). Note that Targets 2-4 are optional; routing skips any undefined targets.

The application plays queue music in a loop until the call is distributed to an agent or abandoned.

Redirect On No Answer (RONA): if the call has already been distributed to an agent who does not
answer, the Distribution flow distributes the call as if it had not been previously distributed, and sets
to Not Ready the status of the agent who did not answer.

Configuration

Business Edition Premise routing configuration occurs at two levels:

• Initial configuration, which involves the automated setup of auto-attendant menus, business rules, and
other configuration objects. The voice routing solution is automatically deployed and installed as part of
the BEP software installation, with default initial configuration settings. These settings are usually
sufficient for most site requirements and do not need to be changed.
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• Administrative configuration, such as setting open hours and switching among auto-attendant menu
trees, is a subset of the initial configuration tasks and takes place entirely within Genesys Administrator
Extension (GAX). It requires no advanced knowledge of Genesys software.

Important
To use Internet Explorer 10 to access Genesys Administrator Extension or Genesys
Administrator, you must add your VM domain to the IE Trusted Sites.

You can configure different values for a number of routing parameters, such as open hours and call
priority. To handle different call flow and email scenarios, you use GAX to create parameter groups
based on the default parameter group templates supplied in Business Edition Premise.

Voice solution definitions (SPDs)

When solution definitions (SPDs) are installed, they automatically create several objects. If you install
a new SPD, Configuration Server objects created by previous voice or email installations are not
overwritten.

The Voice SPD creates these objects:

• Default personality
• Audio resources
• Parameters
• Parameter group templates
• Parameter groups

The Voice SPD also creates these samples (object name in parentheses):

• ACD Queues (9000)
• Action codes (Admin Work, Locked, Lunch, Meeting, Pause, RONA, Training)
• Agent groups (AG_Voice_Sample, AG_Voice_Skill_Sample)
• Agent Logins (1000)
• Business attributes
• DN Groups (All_ACDQueues, All_RoutePoints, All_VirtualQueues)
• Extensions (8000)
• Place Groups (All_Places)
• Places (Place_SIP_8000)
• Route Point (selected during SPD installation)
• Skill (Skill_Sample)
• Virtual queue (VQ_Default_sample)
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Initial configuration
Initial configuration of the voice routing application is done automatically during the BEP software
installation. Typically, the defaults supplied in the solution definition are sufficient for most customer
requirements. Changing these settings requires some knowledge of Genesys software.

You can adjust voice routing parameters in either of two ways:

• To set new default values to be used in all new parameter groups that use the parameter, open Genesys
Administrator Extension, navigate to Routing Parameters > Parameters, and adjust values as
desired. Do not change Key Names.

• To set a new value that applies only to a specific parameter group, open Genesys Administrator
Extension, navigate to Routing Parameters > Parameter groups, and adjust values as desired.

Administrative configuration
You can use the following procedures to change the administrative configuration settings of your
voice routing solution:

Define the auto-attendant menus

You can use parameter groups to build multiple sets of up to three cascading auto-attendant menus.
Keep in mind that you must record corresponding Auto attendant menu announcements for each set
you build.

To create a single set of three cascading menus:

1. Plan your menu set, because it is most efficient to begin by creating the third tier and its touch-
tone selections, then the second tier, then the first. Your plan will look something like the following
(the parameter group type is in parentheses):

8000 (Inbound)
1: Customer Service (Distribution)

1: Wondrous Product Line (Distribution)
2: Stupendous Product Line (Distribution)

2: Sales (Distribution)
1: North America (Distribution)
2: EMEA (Distribution)

3: Technical Support at routing point 6001 (Inbound)
1: Printers (Distribution)
2: Monitors (Distribution)
3: Mice (Distribution)

A customer having difficulty with their mouse calls the number that corresponds to routing point
8000, then presses 3 for Technical Support and 3 again for Mice. In this example, you create 11
parameter groups: 2 Inbound and 9 Distribution.

2. Deploy the third-tier parameter groups (in the example, Wondrous Product Line, Mice, and the
other 5). See below for help in setting the individual parameters.

3. Deploy the second-tier parameter groups. Add the third-tier groups as values for the Touch tone
parameters. In the example, you deploy the Sales parameter group, then assign the North America
group to Touch tone 1, and EMEA to Touch tone 2.
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Important
When you create an Inbound parameter group, the name of the parameter group
must be the same as the routing point that you want to handle these incoming calls
(in the example, the Technical Support group must be named 6001).

4. Deploy a parameter group based on the Inbound parameter group template. Add the second-tier
groups as values for the Touch tone parameters. In the example, you deploy the 8000 parameter
group, then assign the Customer Service group to Touch tone 1, Sales to Touch tone 2, and 6001 to
Touch tone 3.

Upload audio resources

In GAX, for each audio resource, upload the corresponding audio (WAV) files:

Resource name Description
Announcement-Auto attendant menu Played when the auto attendant is enabled
Announcement-Closed Played when the service is closed
Announcement-Emergency Played when Emergency declared is activated
Announcement-Greeting 1 Played when Greeting 1 is enabled
Announcement-Greeting 2 Played after Greeting 1 when Greeting 2 is enabled
Announcement-Special day Played for a Special day
Music File Music played while the caller is in the queue

Customize business attributes

Your customer might require different Disposition Codes, which are the codes agents can select to
specify the outcome of an interaction. The default disposition codes are:

• Cross Sell
• Not Right Skill
• Terminated
• Transferred
• Up Sell

To modify these samples or create your own codes, in GAX, navigate to Configuration > Routing /
eServices > Business Attributes, and open the existing Disposition Code Business Attribute.

Your customer might also require different reporting categories. The five default business parameters
(Service, Segment, Product, Department, and Flow) represent reporting categories and are
completely customizable to your business model. You can assign different combinations of these
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parameters to each of your Inbound and Distribution parameter groups, to distinguish them in
reporting and enable you to identify the unique properties of the parameter group.

Set open hours and special days

The parameter Open hours sets the standard hours that your office is open during the week. Use
the Special day parameter to set:

• The dates or days of the week on which your office is closed for the entire day.
• The dates or days of the week on which your office is closed for only part of the day. In these cases, you

use the Time Ranges field in GAX to set the hours that you will be open on that date.

Specific dates set in Open hours are treated as special days. Hours set for the same date in Special
day override those set in Open hours; for example, if Open hours specifies that you are open from
9AM to noon on December 31, and Special day sets the hours of 11AM-2PM for the same date,
callers who call at 10AM on that date hear the Closed announcement. Similarly, in both parameters,
date patterns higher in the list take precedence over those lower in the list.

Set targets and target timeouts

Assign at least one target agent group for each parameter group. Change the timeout for each group
as needed (default is 300 seconds, or 5 minutes). You should also assign a Target overflow, which
serves as the "last resort" number to which a call is transferred when none of the other target agent
groups answers within their timeout.

Tune priorities

You can adjust the priority of calls using the four priority tuning options. Over time, unanswered calls
receive higher and higher priority, ensuring that calls do not remain in the queue for excessive
lengths of time.

• Priority start sets the initial call priority; you typically have little reason to change the default of 1.
• Priority interval sets the number of seconds between priority increments. If you set the priority

interval to 60 seconds, for example, and the priority increment is 1, then after 5 minutes of wait time,
the call would have a priority level of 6, pushing it ahead of calls with priority values of 1-5.

• Priority Increment sets the number to add to the priority value each time the priority interval is
exceeded. As the priority levels are relative, a setting of 1 typically works.

• Priority limit sets the upper limit for priority increments; all calls at the maximum priority level receive
equal treatment.

Voice routing application Part II: On-site installation

Business Edition Premise Provider's Guide 37



Configure UCS database pruning (recommended)

Genesys recommends that you configure automatic pruning of the Universal Contact Server (UCS)
database to prevent it from growing too large in size.

Important
Changes made to the UCS database maintenance settings will apply to all deployed
media strategies (Voice, Email, Chat, and Outbound).

1. On the core VM host, log in to Universal Contact Server Manager:
• Username : default
• Password: password
• Application: UCS_Manager

2. Select the Scheduled task on Main DB tab.
3. Configure the Main DB maintenance settings as desired.
4. Click Save.

Verification of voice call routing and reporting

You can use the following procedures to verify that your BEP system is correctly receiving and routing
calls and that the call reporting functionality is working.

Verify call routing
To verify that Business Edition Premise is correctly receiving and routing calls, make a test call to an
agent.

First, ensure that you have:

• A soft phone, such as SJPhone
• A sound-enabled Windows PC that can connect to the Core server

1. In GAX, go to Configuration > Environment > Applications > SIPS > Application Options and set
the SIPS TServer option enable-unknown-gateway to true.

Important: After completing the verification process, restore this value to false.

2. In GAX, go to Configuration > Accounts > Agent Groups > Genesys One Voice >
AG_Voice_Sample Properties, and assign user TestAgent to the AG_Voice_Sample agent group.

3. In GAX, go to Routing Parameters > Parameter Groups, and for parameter group 6000 ensure that:
• Greetings activated is True.
• Target 1 is AG_Voice_Sample.
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• Open Hours includes the current time (or the call will not route to the agent).

4. Install the Workspace Desktop Edition (WDE) client by navigating to http://VM name or IP
address/WDE/publish.htm and selecting Install or Launch.

5. Open WDE and log in using these credentials:
• User name: TestAgent
• Password: (none)
• Place: Place_1000
• Queue: 1004@SIP_Switch

Ensure that the agent can log in and set their status to ready.

6. Open a soft phone as any user. For Domain, enter the FQDN of the SIP Server. Uncheck Register with
domain.

7. Dial 6000. If the installation was successful, the call appears in WDE.

Verify call reporting
To verify reporting, run a report in Interactive Insights (GI2).

WATCH: A short demonstration of running a report. (Steps are below the video.)

Link to video

1. In a browser, log into GI2 at http://ui VM name or IP address:9080/BOE/CmcApp/logon.faces.
• User: administrator
• Password: G3n35y5

2. Go to Folders > Interactive Insights > 8.5.0 > Agents.
3. Run the report Agent Group Interaction Handling Report.
4. In the report list, click Refresh until status = success.
5. Open the report and click Instance Time. If the installation was successful, the call appears in the

report.
6. In GAX, go to Configuration > Environment > Applications > SIPS > Application Options and set

the SIPS TServer option enable-unknown-gateway to false.

Operational Parameters

For each parameter group, enter a description in the Description field. For instructions on setting
these parameters, see Configuration.

Audio and Announcements
[+] Show parameters.

Voice routing application Part II: On-site installation

Business Edition Premise Provider's Guide 39

https://player.vimeo.com/video/180962797?title=0&byline=0&portrait=0
https://docs.genesys.com/Documentation/IW/8.5.0/Dep/voiceroutover#Configuration


Parameter Values (default in
bold) Mandatory? Description

Announcement-Closed Closed Annc, any valid
audio resource Yes

Audio Resource played
when the service is
closed

Announcement-Auto
attendant menu

Auto-attendant Menu
1, any valid audio
resource

Yes
Audio Resource played
when the auto
attendant is enabled

Announcement-
Emergency

Emergency Annc, any
valid audio resource Yes

Audio Resource played
when Emergency
declared is True

Announcement-Greeting
1

Greeting 1, any valid
audio resource Yes

Audio Resource played
when Greeting 1 is
enabled

Announcement-Greeting
2

Greeting 2, any valid
audio resource No

Audio Resource played
after Greeting 1 when
Greeting 2 is enabled

Announcement-Special
day

Special Day Annc, any
valid audio resource Yes Audio Resource played

for a special day

Greetings activated False, True Yes
Activates the Greeting 1
and, if enabled,
Greeting 2
announcements

Music File Music In Queue, any
valid audio resource Yes

Audio Resource for
music played while the
caller is in the queue

Personality
Default Personality,
other personality
defined in GAX

Yes The voice used in the
announcements

Auto-attendant menus
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Auto attendant menu
activated False, True Yes

Activates an auto-
attendant menu (such
as Press 1 for Sales) for
this parameter group

Touch tone 0 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 0

Touch tone 1 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 1

Touch tone 2 [none], target No Distribution or Inbound
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Parameter Values (default in
bold) Mandatory? Description

parameter group
parameter group
selected when the caller
selects 2

Touch tone 3 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 3

Touch tone 4 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 4

Touch tone 5 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 5

Touch tone 6 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 6

Touch tone 7 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 7

Touch tone 8 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 8

Touch tone 9 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 9

Business (reporting)
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Department
[none], an item from
the Department custom
list for the parameter
group

No
A business organization
used as a category in
reporting

Flow
[none], an item from
the Flow custom list for
the parameter group

No A business flow used as
a category in reporting

Product
[none], an item from
the Product custom list
for the parameter group

No
A product or product
group used as a
category for reporting
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Parameter Values (default in
bold) Mandatory? Description

Segment
[none], an item from
the Segment custom list
for the parameter group

No
A customer category
used as a category for
reporting

Service
[none], an item from
the Service custom list
for the parameter group

No
Business categories
typically used as the top
level of the auto-
attendant menu choices

Target virtual queue [none], a target virtual
queue set in GA No

A reporting entity set up
in Genesys
Administrator

Contact center status
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Emergency declared False, True Yes

Activates the
emergency
announcement,
overriding any other
announcement

Open Hours

From Monday to
Friday, 0800-2000,
closed Saturday and
Sunday, value set for
parameter group

Yes

Sets the hours that you
are open and accepting
calls; to specify open
hours on specific dates,
you must place the date
above all day-of-week
entries

Special day December 25,
January 1, any dates No

A list of exceptions to
the regular open hours,
for a holiday or other
reason.

Distribution
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Default distribution
parameter group

[none], parameter
group No

The distribution
parameter group that
provides the default and
overflow target for this
parameter group; if you
do not set this
parameter, the call flow
uses the originally
defined list of targets
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Parameter Values (default in
bold) Mandatory? Description

and timeouts

Target 1 [none], agent group No The first agent group to
which the call is routed

Target 2 [none], agent group No
The second agent group
to which the call is
routed

Target 3 [none], agent group No The third agent group to
which the call is routed

Target 4 [none], agent group No
The fourth agent group
to which the call is
routed

Target 1 timeout 300, integer between 0
and 99999 No

The timeout, in seconds,
after which the call is
routed to the next
target agent group

Target 2 timeout 1, integer between 0
and 99999 No

The timeout, in seconds,
after which the call is
routed to the next
target agent group

Target 3 timeout 1, integer between 0
and 99999 No

The timeout, in seconds,
after which the call is
routed to the next
target agent group

Target 4 timeout 1, integer between 0
and 99999 No

The timeout, in seconds,
after which the call is
routed to the next
target agent group

Target overflow
[none], a standard
telephone number, such
as 8005551212

No

The phone number to
which a call is routed if
the final Target timeout
is exceeded or if no
target agent group is
specified. Important:
you cannot use a
routing point as this
number.

Priority tuning
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Priority Increment 0, integer between 0
and 99999 No

Sets the number to add
to the priority value
each time the priority
interval is exceeded

Priority Interval 0, integer between 0 No The time interval (in
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Parameter Values (default in
bold) Mandatory? Description

and 99999 seconds) between
priority increments

Priority Limit 0, integer between 0
and 99999 No

Sets the upper limit for
priority increments; all
calls at the maximum
priority level receive
equal treatment

Priority Start 1, integer between 1
and 99999 Yes

The initial priority
assigned to each
incoming call
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eServices application

Overview

The Business Edition Premise eServices application allows you to install and configure the optional
Email and Chat routing solutions. If you are not installing Email or Chat, you can ignore these steps.

Important
You cannot install Chat as a standalone application. You can only install Chat if you
have also installed and activated the Email routing application.

For more information about eServices, see the eServices documentation page.

Important
Genesys Mobile Services (GMS) is installed during eServices deployment in a "chat-
only" mode and does not use any Cassandra functionality, embedded or external. If
you want complete GMS functionality, you must install and configure the full version
of GMS, along with a compatible version of Cassandra.

Before you start

The Genesys Deployment Agent (GDA) service must be manually enabled on the core and db VMs
before you deploy the eServices application.

To do this:

• Find the GDA service in your list of Windows services. (It should be in a not started/disabled state.)
• In the Properties, change the startup type to Manual.
• Start the GDA service.

Do this for both the core and db VMs. The eServices deployment process will stop and disable the
GDA service on both VMs after it is successfully deployed.
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Deployment

The following steps describe how to deploy the eServices application. Note that the deployment
process can take up to ten minutes to complete.

WATCH: This video shows the eServices application deployment for BEP 8.5.000:

Link to video

1. In GAX, go to Administration > Solution Definitions and select Genesys eServices Single Host
Deployment.

2. Click Related (it's the gear icon) and select Install.
3. Use the default values, except for the following:

• Check or uncheck Activate chat-media support, depending on whether or not you want to
activate chat.

• Database Administrator Name: sa
• Database Administrator Password: G3n35y5!

For BEP 8.5.000: You also need to enter the following (otherwise, skip to the next step):

• Interaction Server Database User Name: genesys_ixn
• Interaction Server Database Password: Genesy$_0_ixn
• ICON Database User Name: genesys_icon_mm
• ICON Database User Password: Genesy$_0_icon_mm

4. You will also need to set the POP Account Parameters. (You can add up to 20 POP accounts.)

Important
For BEP 8.5.000: The eServices application deployment requires separate user names and passwords for
the Interaction Server and ICON databases. While you can choose to use any existing user names, the
passwords for those accounts will be overwritten by the ones entered during deployment. Keep this in mind,
as any differences in the passwords could impact an existing configuration.

Next Steps: After eServices is installed, you can deploy the Business Edition Premise Email and Chat routing applications.
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Email routing application

Overview

The Business Edition Premise email routing application can:

• Screen incoming email subject lines for recognized terms
• Distribute the email to a target agent group
• Send an acknowledgement based on contact center status

Important
Agents can send replies to incoming emails, but the routing strategy does not support
the sending of unsolicited outbound emails.

Distribution
The screening rule determines the target and overflow agent groups. If the email is not handled by an
agent from the Email target agent group within the Email target timeout (default is one hour), the
email is routed to the Email overflow target agent group.
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If the email is not handled by an agent from the overflow target agent group within the Email
overflow target timeout (default is one day), the email returns either to the target agent group or to
the overflow agent group, at a higher priority.

Acknowledgements
Like the voice routing application, the email application can send a different acknowledgement email
based on the status of the contact center: open, closed, or special day.

Deployment

To deploy the Business Edition Premise routing applications, you deploy the solution definition in
Genesys Administrator Extension (GAX). Solution definitions are also known as solution package
definitions, or SPDs.

The email routing application also requires you to deploy eServices applications, import Knowledge
Manager templates, and deploy the email strategy.

This section describes how to deploy the email routing application. Email deployment is optional; if
you are not installing the email option, you can skip these steps.

Install the email solution definition
WATCH: A short demonstration of the email solution definition installation.

Link to video

1. In GAX, go to Administration > Solution Definitions and select Genesys One OPM Email
Parameters.

2. Click Related (it's the gear icon) and select Install.
3. Complete the wizard, using default values except for:

• GAX host: VM host name
• Switch: eServices_Switch
• Email address: the Do Not Reply address that you select for the customer mail server
• Email Sample Configuration: True

Install Knowledge Manager
You need to install Knowledge Manager so you can import the Knowledge Manager templates in the
next step.

1. Go to http://core VM host name or IP address/ips and copy the kmgr_version folder to the host
where you want to install KM.

2. On the local host, unzip the file you copied.
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3. Go to the Installation Package and install Knowledge Manager.
4. In GAX, go to Environment > Application Templates, and select New.
5. Click Import Application Template.
6. Browse for the KnowledgeManager_851.apd template, and then click Save.
7. In GAX, go to Environment > Application, and select New.
8. For Name, enter eServices_KnowledgeManager.
9. Select the Knowledge Manager template you created earlier and click Apply.

10. Go to the Application Options tab and under Security, set the disable-rbac option to true.
11. Go to the Connection tab and click Add.
12. Browse for UCS and click OK.

Import the Knowledge Manager templates
WATCH: A short demonstration of how to import the Knowledge Manager templates

Link to video

Important
Localized versions of the templates do not include the required categories, so even for
localized environments you must import the
GenesysOne_KnowledgeManager_Rules_Responses_ENU.kme file.

1. In Genesys Administrator, ensure that the eServices solution is started.
2. Go to: http://VM host name or IP address/ips and locate and download

email_strategy_ext_version.zip.
3. Unzip the file.
4. Browse to email_strategy_ext\KNOWLEDGE and copy the

GenesysOne_KnowledgeManager_Rules_Responses_ENU.kme file to a temp folder on the local
disk.

5. Under Genesys Solutions\eServicesxxx\Knowledge Manager, start Knowledge Manager.
• Username: default
• Password: password
• Application: eServices_KnowledgeManager
• Host: VM name

6. Go to File > Import and select the kme file from the temp folder.
Important:

• Uncheck Preserve uniqueness of objects
• Check Update screening rules.
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Click OK and ignore the 5 warnings.

7. If you are localizing your environment, and only after first importing the English kme file, you can import
the localized kme files, one at a time (the example below uses the French version,
GenesysOne_KnowledgeManager_Rules_Responses_FRA.kme):
• On the VM host, copy the GenesysOne_KnowledgeManager_Rules_Responses_FRA.kme file

(from the unzipped email_strategy_ext_version.zip file) to a temp folder on the local disk.
• Start Knowledge Manager

• Application: eServices_KnowledgeManager
• Host: your VM name

• Go to File > Import and select the kme file from the temp folder.
Important:

• Uncheck Preserve uniqueness of objects
• Check Update screening rules.

Click OK and ignore the 5 warnings.

8. If you are using Special Day Auto Responses in Email, you must manually change the Time Zones for
AutoResponse:
• Start Knowledge Manager.
• Click AutoResponse, and then double-click Special Day.
• Locate the two instances of TimeZone and replace them with the correct time zone IDs.

Important: You must use time zone database IDs to indicate time zones. For a list of time zone
database IDs, see http://en.wikipedia.org/wiki/List_of_tz_database_time_zones.

• Click Check field Codes to view the Special Day Auto Response with the field codes rendered.
• Click OK.

Deploy the email strategy (BEP version 8.5.000)
Download and deploy the email strategy. (For BEP versions 8.5.001 and higher, refer to this
procedure.)

WATCH: A short demonstration of the email strategy deployment.

Link to video

1. In a browser, go to http://core VM name or IP address/ips. Locate, download, and extract the
following zip files:
• email_strategy_version.zip

• composer_version_enus.zip

2. Install Composer 8.1.4 on a Windows system that is not a VM and is not already running Apache Tomcat
(to avoid port conflicts). Follow the installation instructions in the Composer 8.1 Deployment Guide.

Note that Composer 8.1.4 is an Eclipse plugin that requires JDK 1.7 and a supported version of
Eclipse. Composer installs its own Apache Tomcat server.

3. Copy the GenesysOne_Email folder (from the email_strategy_ext_version zip that you just
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extracted) to a temp folder on the Composer system.
4. Open Composer and go to File > Import > General > Existing Projects into Workspace.
5. Choose Select root directory and then select the email strategy you copied from the VM.

Important: Select the project from the newly populated list, ensuring Copy projects into
workspace is enabled, and click Finish.

6. Verify that the local Tomcat server details are correct for your Composer installation:
• Go to Window > Preferences > Composer > Tomcat.
• Enter the Port, Login (admin), and Password (admin).
• Check the Tomcat Location to confirm that it is on the local disk (for example, c:\Program Files

(x86)\GCTI\Composer 8.1\tomcat).

7. In Composer Package Explorer, expand the GenesysOne_Email package, right-click Interaction
Processes > Email ixnprocess, and select Publish to Configuration Server (you might first need
to connect to Configuration Server from the Composer menu bar).

8. Right-click the package name and select Properties. Deploy the project.
9. Create a WAR file:

• Right-click the package name and select Export > Composer > Java Composer Project as WAR
file.

10. In the Export window, select Export Composer WAR file to a location. (You can ignore any warning
messages that are generated.)

11. Copy the WAR file to \\VM host\c$\GCTI\apache-tomcat\webapps. The WAR file automatically
extracts to a new GenesysOne_Email folder.

12. Point the new scripts to the correct server:
• Open GA and go to Provisioning > Routing/eServices > Orchestration, which includes nine

enhanced routing scripts.
• Double-click GenesysOne_Email.Email.Entered.Routing and change the Orchestration URI to

include the correct VM server name; for example, http://g1-sngl-p:8380/GenesysOne_Email/
IPD_Email_Entered.scxml.

• Repeat for each of the other scripts.

Deploy the email strategy (BEP version 8.5.001)
Download and deploy the email strategy.

1. In a browser, go to http://core VM name or IP address/ips. Locate, download, and extract the
following zip file:
• email_strategy_version.zip

2. Open Composer and go to File > Import > General > Existing Projects into Workspace.
3. Choose Select root directory and then select the folder for the GenesysOne_Email email strategy

you extracted earlier.
Important: Select the project from the newly populated list, ensuring Copy projects into
workspace is enabled, and click Finish.
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4. Verify that the local Tomcat server details are correct for your Composer installation:
• Go to Window > Preferences > Composer > Tomcat.
• Enter the Port, Login (admin), and Password (admin).
• Check the Tomcat Location to confirm that it is on the local disk (for example, c:\Program Files

(x86)\GCTI\Composer 8.1\tomcat).

5. Start Tomcat.
6. Right-click the package name and select Properties. Deploy the project.
7. In Composer Package Explorer, expand the GenesysOne_Email package, right-click Interaction

Processes > Email ixnprocess, and select Publish to Configuration Server (you might first need
to connect to Configuration Server from the Composer menu bar).

8. Create a WAR file:
• Right-click the package name and select Export > Composer > Java Composer Project as WAR

file.

9. In the Export window, select Export Composer WAR file to a location. (You can ignore any warning
messages that are generated.)

10. Copy the WAR file to \\VM host\c$\GCTI\apache-tomcat\webapps. The WAR file automatically
extracts to a new GenesysOne_Email folder.

11. Point the new scripts to the correct server:
• Open GA and go to Provisioning > Routing/eServices > Orchestration, which includes nine

enhanced routing scripts.
• Double-click GenesysOne_Email.Email.Entered.Routing and change the Orchestration URI to

include the correct VM server name; for example, http://g1-sngl-p:8380/GenesysOne_Email/
IPD_Email_Entered.scxml.

• Repeat for each of the other scripts.

Configuration

Business Edition Premise routing configuration occurs at two levels:

• Initial configuration, which involves the setup of auto-attendant menus, business rules, and other
configuration objects, requires a basic understanding of Genesys software, particularly Genesys
Administrator, SIP Server, and, for email, eServices Knowledge Manager.

• Administrative configuration, such as setting open hours and switching among auto-attendant menu
trees, is a subset of the initial configuration tasks and takes place entirely within Genesys Administrator
Extension (GAX). It requires no advanced knowledge of Genesys software.

You can configure different values for a number of routing parameters, such as open hours and call
priority. To handle different call flow and email scenarios, you use GAX to create parameter groups
based on the default parameter group templates supplied in Business Edition Premise.

Email solution definitions (SPDs)

Installation of the solution definitions (SPDs) automatically creates several objects. Configuration
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Server objects created by previous voice or email installations are not overwritten.

The Email SPD creates these objects:

• Parameters
• Parameter group templates
• Parameter groups
• Transaction (Technical, Email Default)

The Email SPD creates these additional samples (object name in parentheses):

• Agent groups (AG_Email_Sample, AG_Email_Overflow_Sample, Email Supervisors)
• Business attributes (Disposition Code (Attributes), iWS_ToastUserData, iWS_UserData)
• Capacity Rule (GenesysOne_1Voice_1Email)
• Persons (AgentSample, SupervisorSample)
• SIP Switch Virtual queue (VQ_Default_email)
• Transactions (Category1OverrideIWS, Category2OverrideIWS, Category3OverrideIWS,

Category4OverrideIWS, Category5OverrideIWS)

Initial configuration
Initial configuration of the email routing application depends on the needs of the customer. In many
cases, the defaults supplied in the solution definition will be sufficient.

You can adjust email routing parameters in either of two ways:

• To set new default values to be used in all new parameter groups that use the parameter, open Genesys
Administrator Extension, navigate to Routing Parameters > Parameters, and adjust values as
desired. Do not change Key Names.

• To set a new value that applies only to a specific parameter group, open Genesys Administrator
Extension, navigate to Routing Parameters > Parameter groups, and adjust values as desired.

1. Configure screening rules

You can use the eServices Knowledge Manager application to customize the screening rules used to
route email to any of the five Category parameter groups.

"Content screening", in the Overview section, explains how screening works in Business Edition
Premise.

"Screening Rules" in the eServices 8.1 User's Guide explains how to use the Screening Rule Editor
and details how the rules work.
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2. Configure email acknowledgements

You can also use the eServices Knowledge Manager application to customize the text of the
acknowledgement emails: Email acknowledgement body open hours, Email
acknowledgement body closed hours, and Email acknowledgement body special days, as
well as the opening (salutation), closing, and time zone.

"Using Categories and Standard Responses" in the eServices 8.1 User's Guide explains how to edit
the acknowledgement content.

3. Configure distribution

After you customize the screening rules, you can adjust their associated parameter groups to
distribute emails to the correct targets. If you added the term "sales" to the Category 3 screening
rule, for example, you can route emails with "sales" in their subject lines to a particular target agent
group by setting the Category 3 parameter group Email target value to the Sales agent group.

You can also enable or disable supervisor review, and change the percentage of emails subject to
review.

4. Set open hours and special days

The parameter Email open hours sets the standard hours that your office is open during the week.
Use the Email special day parameter to set:

• The dates or days of the week on which your office is closed for the entire day.
• The dates or days of the week on which your office is closed for only part of the day. In these cases, you

use the Time Ranges field in GAX to set the hours that you will be open on that date.

Specific dates set in Email open hours are treated as special days. Hours set for the same date or
day of the week in Email special day override those set in Email open hours; for example, if
Email open hours specifies that you are open from 9AM to noon on December 31, and Email
special day sets the hours of 11AM-2PM for the same date, people who send an email at 10AM on
that date receive the special day acknowledgement.

Similarly, in both parameters, date patterns higher in the list take precedence over those lower in the
list.

5. Tune priorities

You can adjust the priority of emails using the two priority tuning parameters:

• Email priority sets the initial email priority; you typically have little reason to change the default of
100.

• Email overflow priority sets the priority of emails that exceed the Email target timeout. The
default value is also 100, which means that emails that have already passed the overflow timeout will
be re-queued based solely on their age, ensuring that the oldest emails will appear in the queue first.

6. Send a test email

To verify that Business Edition Premise is correctly receiving and routing emails, send a test email:
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1. Install an email client and ensure that it connects to your email server.
2. Send an email to the address specified during the eServices SPD deployment.
3. In GAX, add the Agents Access Group to the AgentSample user account.
4. Ensure that you have installed an Workspace Desktop Edition (WDE) client (you did this when you were

making a test call during the voice routing configuration). Launch WDE and log in using these
credentials:
• User Name: AgentSample
• Password: AgentSample

5. If Business Edition Premise is successfully installed, a WDE interaction window containing the email
appears when the email arrives.

7. Configure UCS database pruning

Genesys recommends that you configure automatic pruning of the Universal Contact Server (UCS)
database to prevent it from growing too large in size.

Important
Changes made to the UCS database maintenance settings will apply to all deployed
media strategies (Voice, Email, Chat, and Outbound).

1. On the VM host, log in to Universal Contact Server Manager.
2. Select the Scheduled task on Main DB tab.
3. Configure the Main DB maintenance settings as desired.
4. Click Save.

Operational Parameters

This section describes the operational parameters that are available for the email routing application.
For instructions on setting these parameters, see Configuration.

Acknowledgements
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Email acknowledgement True, False Yes

Sends customer an
acknowledgement
email, content
depending on whether
you are open, closed, or
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Parameter Values (default in
bold) Mandatory? Description

on a special day

Email acknowledgement
body open hours

Thank you for your
email. We will get
back to you as soon
as possible., text
string entered in Value
field

Yes
The body text used for
acknowledgements sent
during regular hours

Email acknowledgement
body closed hours

Thank you for your
email. We are
currently closed and
will get back to you
as soon as possible.
Our office hours are:,
text string entered in
Value field

Yes
The body text used for
acknowledgements sent
during closed hours

Email acknowledgement
body special days

Thank you for your
email. We are
currently closed and
will get back to you
as soon as possible.
Our office reopens on
date, text string
entered in Value field

Yes
The body text used for
acknowledgements sent
during special days

Email acknowledgement
opening

Dear Customer name,
text string entered in
Value field

Yes
The greeting to the
customer at the
beginning of the
acknowledgement

Email acknowledgement
closing

Regards, text string
entered in Value field Yes

The closing term to the
customer at the end of
the acknowledgement

Email acknowledgement
time zone

[none], free-form text
such as Central Time
or GMT

No
The time zone text that
you want to include in
your email
acknowledgements.

Email from [none], email address No
The email address
(typically DoNotReply)
used in sending email
responses to customers

Contact center status
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Email open hours
From Monday to
Friday, 0800-2000,
closed Saturday and
Sunday, any value set

Yes
Sets the hours that you
are open and accepting
emails; to specify open
hours on specific dates,
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Parameter Values (default in
bold) Mandatory? Description

in the Value > Date
Pattern field

you must place the date
above all day-of-week
entries

Email special day
December 25,
January 1, any value
set in the Value > Date
Pattern field

No
A list of exceptions to
the regular open hours,
for a holiday or other
reason.

Distribution
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Email screening True, False Yes Enables email screening
rules

Email target [none], agent group Yes The agent group that
first receives all emails

Email overflow target [none], agent group No
The agent group that
receives all emails that
exceed the overflow
target timeout

Email target timeout 3600, integer between
1 and 99999 No

The length of time (in
seconds) that an email
can go unattended
before being passed to
the overflow agent
group

Email overflow target
timeout

86400 (24 hours),
integer between 1 and
99999

No

The length of time (in
seconds) that an email
can go unattended
before being passed to
the first available agent
group (either target or
overflow)

Email supervisor review False, True Yes Enables supervisor
review.

Email supervisor review
percentage

100, integer between 0
and 100 Yes

The percentage of
emails routed to
supervisors for review

Email supervisor agent
group [none], agent group No

The supervisor agent
group that receives the
emails when supervisor
review is enabled

Email default virtual
queue

VQ_Default_email, a
target virtual queue set
in GA

Yes
The default virtual
queue to which all
emails are routed, for
reporting
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Priority tuning
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Email priority 100, integer between 1
and 99999 Yes

The initial priority
assigned to each
incoming email

Email overflow priority 100, integer between 1
and 99999 Yes

The priority assigned to
all emails that exceed
the overflow target
timeout
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Chat routing application

Warning
The chat and outbound routing strategies that are included with the Business Edition
Premise image are for testing purposes only and are not to be used in production
environments. Customers must develop their own chat and outbound routing
strategies for use in production environments.

Overview

The Business Edition Premise chat routing application delivers chat interactions to the
AG_Voice_Sample Agent Group.

Important
You cannot install chat as a standalone application. Chat can only be activated if you
have first deployed, installed, and activated the email routing application.

Acknowledgements
The chat application sends acknowledgements to customers, informing them that:

• They are queuing.
• Their chat interaction has been delivered, along with the name of the receiving agent.

The AG_Voice_Sample Agent Group is a system-defined destination and cannot be changed. To
configure a different destination for chat interactions, you must modify the chat strategy in
Composer. For more information about configuring the chat strategy, refer to the Composer
documentation.

Deployment

This section describes how to activate, install, and deploy the chat routing strategy.
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Activate the chat option
You can activate the chat option when first deploying the email routing application or when modifying
an existing email routing application deployment.

Activating chat when deploying the email routing application

To deploy chat with email, follow the instructions described in Deploying the email routing
application, but select Activate chat-media support when choosing the eServices applications to
install.

Activating chat by modifying an existing email routing application deployment

You can also activate chat by modifying an existing email deployment.

1. In GAX, go to Administration > Solution Definitions and select Genesys eServices Single Host
Deployment.

2. Click the operations icon (gear) and select Upgrade.
3. Click Next to check the availability of required Installation Packages.
4. Select eServices Solution and check Activate chat-media support, and then click Next.
5. Click Finish to start the deployment.

Install the chat solution definition
WATCH: A short demonstration of the chat solution installation.

Link to video

1. In GAX, go to Administration > Solution Definitions and select Genesys One OPM Chat
Parameters [ENU].

2. Click Related (it's the gear icon) and select Install.
3. Keep all default options, except for the following, which are specific to your site:

• GAX host
• GAX user
• GAX password
• Application Server host

Deploy the chat strategy
WATCH: A short video showing the chat strategy deployment, as performed on a system running BEP
8.5.000.

Link to video

1. In a browser, go to http://''<core VM name or IP address>''/ips. Locate, download, and extract
the following zip file:
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• chat_strategy_version.zip

2. Complete this step only if you are using BEP 8.5.000: You must download and install Composer (it
is installed automatically in BEP versions 8.5.001 and later). From the same location in step 1,
download and extract the following zip file:
• composer_version_enus.zip

Install Composer 8.1.4 on a Windows system that is not a VM and is not already running Apache
Tomcat (to avoid port conflicts). To do this, follow the installation instructions in the Composer 8.1
Deployment Guide.

Important: Composer 8.1.4 is an Eclipse plugin that requires JDK 1.7 and a supported version of
Eclipse. Composer installs its own Apache Tomcat server. (See the Release Note.)

3. Open Composer and go to File > Import > General > Existing Projects into Workspace.
4. Choose Select root directory and then select the GenesysOne_Chat folder that you extracted

earlier.
Important: Select the project from the newly populated list, ensuring Copy projects into
workspace is enabled, and click Finish.

5. Create a WAR file:
• Right-click the package name and select Export > Composer > Java Composer Project as WAR

file.

6. In the Export window, select Export Composer WAR file to a location. (You can ignore any warnings
that are generated.)

7. Copy the WAR file to \\<VM name or IP address>\c$\GCTI\apache-tomcat\webapps. The WAR file
automatically extracts to a new GenesysOne_Chat folder.

Important
If this folder is not automatically generated, a restart of the Apache/Tomcat service
may be required. To do this, use GA to restart the apache-tomcat_ors application.

Verify that chat is deployed successfully
Log into Workspace Desktop Edition (WDE) as an agent and confirm that:

• Chat is listed in the Media column with a Ready status.
• The Agent Group is AG_Voice_Sample.

Next, go to the widgets page on the core VM (http://<core VM name or IP address>:8380/
widgets/launcher.html) and do the following:

• Check the Webchat box.
• In the URL field, enter the following address:

http://<core VM name or IP address>:8090/genesys/2/chat/customer-support

• Click Launch, then click Chat.
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• When the Live Chat window opens, click Start Chat.

Configuration

There are no specific Business Edition Premise configuration requirements for chat. However,
Genesys recommends that you configure automatic pruning of the Universal Contact Server (UCS)
database to prevent it from growing too large in size.

Important
Changes made to the UCS database maintenance settings will apply to all deployed
media strategies (voice, email, chat, and outbound).

To configure automatic pruning of the UCS database, do the following:

1. On the VM host, log in to Universal Contact Server Manager.
2. Select the Scheduled task on Main DB tab.
3. Configure the Main DB maintenance settings as desired.
4. Click Save.
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Outbound routing application

Warning
The chat and outbound routing strategies that are included with the Business Edition
Premise image are for testing purposes only and are not to be used in production
environments. Customers must develop their own chat and outbound routing
strategies for use in production environments.

Overview

The Business Edition Premise Outbound solution is an Outbound VoIP deployment that allows for the
following types of dialing modes:

• Predictive: This dialing mode predicts agent availability when it dials calls from a calling list and is
recommended for high-volume, low-value campaigns.

• Progressive: This dialing mode dials calls from a calling list when an agent is actually available and is
recommended for low-volume, high-value campaigns.

• Preview: This dialing mode allows an agent to request one or several records from Outbound Contact
Server (OCS), preview each record, and decide whether to dial a call.

For more information about dialing modes, see Dialing Modes in the Outbound documentation.

Outbound routing
The Outbound routing strategy directs the outbound call to an agent group according to the options
configured in the Outbound Parameter Group. For more information about Outbound routing, see the
Outbound documentation.

Deployment

This section describes how to deploy the outbound routing application.

Important
You must obtain and install a valid license for outbound before deploying the
application.
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1. Log into the core VM host and launch Activate Outbound Contact Server.
Important: Confirm that the appropriate Outbound license is installed before proceeding.

2. Click Yes to start the deployment.
3. After the deployment completes, verify that it was successful.

a. In GA, confirm that Outbound Contact Server (OCS) is started.
b. In GA, load and start the sample campaign:

• Go to Operations > Outbound Contact > Dialing Sessions.
• For Campaign ID, select Test > TestCampaign and for Outbound Contact Server, select

OCS.
• Click Load, and then click Start.

c. Log into Workspace Desktop Edition (WDE) using the TestAgent ID:
• Navigate to http://VM name or IP address/InteractionWorkspace/publish.htm and select Launch.

d. Add a record to be dialed:
• Go to Operations > Outbound Contact > Calling Lists.
• Select Calling Lists: Test > TestCallingList.
• Select Insert record.
• Enter the details for a valid destination, changing contact_info to the telephone number to be

dialed by SIPS.
• Select OK.

Important: You might need to adjust the following options, depending on the time of day and
your timezone:
daily_from — The time you want calling to start
daily_till — The time you want calling to cease.
tz_dbid — Your timezone.

4. When the outbound call is established, TestAgent receives a call using WDE.

Configuration
There are no specific Business Edition Premise configuration requirements for the outbound routing application. By default, the
Outbound Parameter Group is loaded against Routing Point 7000. To edit the Outbound Parameter Groups, login to GAX and go to
Routing Parameters > Parameter Groups.

Tip
The default Agent Group is TestAgentGroup. If you want to use a different one, create the Campaign Group
using the new Agent Group. Then load and start the campaign for the new Campaign Group.

Also, Genesys recommends that you configure automatic pruning of the Universal Contact Server (UCS) database to prevent it
from growing too large in size. To configure automatic pruning of the UCS database, do the following:
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Important
Changes made to the UCS database maintenance settings will apply to all deployed media strategies (voice,
email, chat, and outbound).

1. On the VM, log in to Universal Contact Server Manager.
2. Select the Scheduled task on Main DB tab.
3. Configure the Main DB maintenance settings as desired.
4. Click Save.

Operational Parameters
To edit the Outbound Parameter Groups, log in to GAX and under Routing Parameters, select Parameter Groups.

Outbound Parameter Group

Parameter Values (default in
bold) Mandatory? Description

Voice Target TestAgentGroup,
agent group Yes

The Agent Group to
which the call is
routed. The Campaign
Group should be
created with the same
Agent Group.

Voice Target Timeout 2, integer between 1
and 99999 Yes

The timeout (in
seconds) after which
the call is routed to the
overflow target.

Overflow Voice Target (none) No

The number to which
the call is routed if no
target is specified or if
the target timeout is
exceeded.
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Frequently Asked Questions
This page provides answers to common questions that IT personnel might have when planning or
considering the addition of a Business Edition Premise system to their site. The information on this
page applies to 8.5.x versions of Business Edition Premise.

The questions are grouped by Hardware, Software, and Networking.

Hardware
[+] Can I deploy Business Edition Premise in a High Availability (HA)
configuration?
Yes, please contact Genesys Professional Services for more information.

[+] What type of disk configuration is used?
Business Edition Premise uses a RAID-5 disk configuration.

[+] Is the storage disk or data encrypted?
No, the storage disk or data is not encrypted, although some of the logs do have masking ability.

[+] Which system components do I need to monitor (for example,
uptime, disks, ports)?
The Dell iDRAC system management tool is built-into the system board and can be configured to
provide all required hardware and system monitoring.

[+] How do I get replacement parts? What is the warranty and service
arrangement?
This depends on your agreed maintenance contract. If you are experiencing hardware issues, contact
your BEP provider for diagnostics and replacement of failed components.

[+] My servers are utilizing the iDRAC7 controller, but I am unable to
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access or login after several days of continuous use.
For best performance, make sure the iDRAC firmware is version 1.57.57 or higher. For workarounds
and additional information, visit Dell support.

[+] What are the memory requirements for Business Edition Premise
8.5.x?
The Business Edition Premise 8.5.x VM image is assigned with 32 GB memory. In addition, the ESXi
6.0 operating system requires a minimum of 4 GB memory (8 GB is required for full functionality).
The Business Edition Premise server (Dell PowerEdge) has dual CPUs, which use dual memory banks
that must contain the same amount of memory in each bank.

To ensure maximum system performance, a total of 48 GB memory is recommended.

Software
[+] Which operating systems does BEP use?
Business Edition Premise uses the following operating systems:

• ESXi 6.0
• Microsoft Windows 2012 Server R2 Standard

[+] Does the system include a database?
Yes, Business Edition Premise uses the following database types:

• Postgre SQL (Configuration Server)
• MS SQL Server 2012 R2 (all other Genesys servers)
• Apache Cassandra (ORS) (BEP 8.5.000 only)

[+] Can MS SQL Server be used instead of Postgre SQL?
Yes, if you prefer to use MS SQL Server, you can remove Postgre SQL. After your Business Edition
Premise solution is fully tuned-up, contact Professional Services and ask them to migrate your
Configuration Manager database from Postgre SQL to MS SQL Server.
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[+] Does the system have a built-in antivirus or anti-malware package?
No, customers are responsible for their own antivirus and anti-malware monitoring.

[+] Which types of authentication methods are used (for example,
Kerberos, RADIUS, or LDAP)? Will it work with Active Directory?
For details on the authentication methods used and for Active Directory compatibility, refer to the
following VMware document: vsphere-esxi-vcenter-server-60-security-guide.pdf.

[+] Does the system store any personally-identifiable information (PII)
or protocol-control information (PCI)?
Yes, during the course of normal operations the Universal Contact Server (UCS) database does store
some caller information.

[+] How do I back up the critical system files and configuration files?
The VM Snapshots utility (included as part of the VMware server software) allows you to capture the
VM images in their present state and, if required, instantly restore the system to a known good earlier
state.

Genesys recommends that you create snapshots of each VM before performing the tune-up
procedures, as well as when performing important deployments and configuration modifications.
Note that the VM Snapshots are stored on the ESXi server, so you will need to monitor the hard disk
space being used for the backups.

For more information, refer to the following document: Best practices for virtual machine snapshots in
the VMware environment (1025279).

[+] What kind of routine maintenance procedures are required?
The Genesys component software in Business Edition Premise requires limited maintenance. Any
required maintenance is described in the documentation for each component.

[+] How do I update the operating systems for security and critical
fixes?
You can update the operating systems using the following methods:

• For Windows, use the Windows 2012 Server Download and Install Updates function on the VM. (If
your Business Edition Premise installation does not have internet access, you can update Windows
offline. Contact Genesys Professional Services for more information.)
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• For VMware, use the VMware vSphere Update Manager.

[+] For a multi-VM deployment, is there a specific order in which the
Virtual Machines must be powered-on or off?
Yes, the VMs must be powered-on in the following order:

1. core
2. db
3. ui

There is no specific order in which the VMs must be powered-off.

[+] Are any routing applications deployed automatically during BEP
installation?
Yes, the voice routing application is deployed automatically during BEP installation.

[+] Where do I get the required licenses?
For information about requesting licenses, contact your Genesys representative or visit this page.

[+] While executing the tuneup_boe script on the ui VM (for a multi-VM
deployment), I received a CMS error. What might be the cause?
The db VM hostname must be resolvable in DNS or the BOE installation will fail. Check the network
configuration by performing an nslookup command (both forward and reverse) for all VMs. For
example:

nslookup <FQDN version of VM hostname>

nslookup <IP version of VM hostname>

Do this for each VM in your system. Each should return a successful result.

[+] During tuneup, I entered incorrect information. What do I do?
If you enter incorrect information during the tuneup script configuration, Genesys recommends that
you redeploy the VM and begin the tuneup script configuration again. If you made a snapshot of the
VM prior to entering any data for the tuneup configuration script, you can revert to that snapshot. In
a multi-VM environment, you would redeploy the core VM or revert to a snapshot. But note that if you
redeploy the core VM (or revert to a snapshot), you must also redeploy the other VMs.
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[+] I am receiving calls from gateways that are not represented as
Trunk DNs in my environment. How do I fix this?
Go to the SIP Server application in Configuration Manager. Under the T-Server option, make sure that
the value of the enable-unknown-gateway option is false. This secures the SIP Server so that it
only accepts calls from configured Trunk DNs within the configuration environment.

[+] I want to install chat but I am not using the email application. Can I
do this?
No, you cannot install chat as a standalone application. It can only be used if the email application is
also installed and activated.

[+] I have deployed my email (or chat) strategy but they are not
routing. What could be wrong?
After you exported the .war file in Composer, did you copy it to the \\g1-core-p\c$\GCTI\apache-
tomcat\webapps folder? Once copied, the .WAR file will automatically extract itself to a new
GensysOne_xx folder and the routing should work correctly. (If this folder is not automatically
generated, a restart of the Apache/Tomcat service may be required. To do this, use Genesys
Administrator to restart the apache-tomcat_ors application.)

[+] How do I optimize my Universal Contact Server database so that it
does not use too much disk space?
Genesys recommends that you configure automatic pruning of the Universal Contact Server (UCS)
database to prevent it from growing too large in size. You can do this by modifying the main database
maintenance settings in Universal Contact Server Manager.

[+] How do I check the software version of the pre-installed
components?
To view the supported version numbers (available after the virtual machine(s) are deployed and
tuned up), go to http://core VM name or IP address.

[+] I’m making changes to the configuration sever settings. What is the
[chef] section used for?
This section is used by Genesys during the deployment of your software and can be ignored. It has no
impact on Genesys servers or services.
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[+] Our installation is in a Middle Eastern time zone. Why do our reports
not show the correct local time?
If your system is in a Middle Eastern time zone, you should select NET for your local time zone.

Networking
[+] How many IP addresses are required?
Business Edition Premise requires the following IP addresses to prepare the server for delivery and to
finalize the server installation and configuration at the Premise site:

• The Dell iDRAC configuration requires one IP address that is within a management control subnet to
allow hardware alarms to be sent using email (the email address used to receive alarms must have
access to the email server at the site).

• The ESXi server requires one IP address that is within the same subnet and is available on a Windows
domain running DNS/DHCP services.

• Each of the virtual machines (VM) requires an IP address that is within a single subnet and is available
on the Windows domain running DNS/DHCP services. You will also need to assign hostnames for the
VMs for entry into a DNS server.

[+] Do external vendors require remote access?
No.

[+] Does the server need access to the internet?
Internet access is not required; however, if you choose to deploy optional eServices features, such as
Chat or Email, the virtual machine(s) will require internet access.

[+] Does the system have a built-in firewall?
The Virtual Machine(s) use the Windows operating system, which has a built-in firewall that is
disabled by default. If desired, you can enable and configure this firewall.

[+] What are the network speeds, and can I configure network load
balancing or link aggregation?

Frequently Asked Questions Part II: On-site installation

Business Edition Premise Provider's Guide 71



Business Edition Premise uses 1 GbE (Gigabit Ethernet) networking and is compatible with network
load balancing configurations.

You might also be interested in...

• Installing Business Edition Premise
• BEP System Maintenance
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Requesting licenses
To request Genesys and VMware licenses for Business Edition Premise, complete the following steps:

1. Prepare an email request containing the following details:
• Your software order number or purchase order number.
• The Core VM NIC MAC address (this is for the Genesys software license). If you do not know the MAC

address, and your server was provided by Genesys, you can find it on the label of the box in which
your server was shipped. Otherwise, contact your Genesys Partner.

• For existing deployments, include a copy of your existing license file.
• For non-revenue orders, you should request licenses only if you are upgrading to a major version

release (for example, if you are upgrading version 7.x to 8.x).

2. Send the email request to the appropriate Genesys contact for your geographical region:
• Americas / APAC
• EMEA
• Japan

The response time for license requests is typically 2-3 days.

For more information about licenses, refer to the Genesys Licensing Guide.

Important
The BEP VM image is only available to Genesys BEP Partners (Genesys Partners who
have signed the BEP Partnership Addendum), who will use the image to stage a
complete system for delivery to customers.
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