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Task Summaries and Procedures
Task Summary: Configuring the RM in HA Active Standby Mode (Windows)

Objective Related Procedures and Actions

1. Configure NLB on the Resource
Manager hosts.

See Procedure: Configuring Resource Manager HA (Windows
2008).

2. Configure the member IDs and NLB
script path in the Resource Manager
Applications.

See Procedure: Configuring the Resource Manager HA-Pair.

3. Configure the virtual IP address of
the HA-pair in the INIT and NLB script
files.

See Procedure: Configuring the INIT and NLB Script Files
(Windows).

4. Specify the NICs that require
monitoring (optional).

See Procedure: Specifying the NICs to Monitor (Windows).
Note: In Windows environments, NICs monitoring is optional. If there are only
two NICs installed on the host, omit this procedure. For more information
about monitoring the NICs, see Monitoring the NICs.

5. If you are installing Resource
Manager HA on Windows 2008,
configure a network account with
Administrator privileges.

See Procedure: Configuring the Resource Manager Service
(Windows).
Note: Windows 2008 does not support the NLB command /PASSW argument
for remote procedure calls. Therefore, the Resource Manager Service must
run as a network account that has Administrator privileges.
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Objective Related Procedures and Actions

6. Complete finals steps before starting
the Resource Manager HA-pair in
NLB mode.

See Start Resource Manager HA-pair in NLB mode.

Task Summary: Configuring the RM in HA Active Active Mode (Windows)
Objective Related Procedures and Actions

1. Configure the member IDs in the
Resource Manager Applications. See Procedure: Configuring the Resource Manager HA-Pair.

2. Configure the virtual IP in the Media
Control Platform, Call Control
Platform, and CTI Connector
Applications.

See Procedure: Integrating Application Objects with Resource
Manager and Procedure: Configuring the Call Control Platform.
Note: When you use these procedures to configure active active HA mode,
the virtual IP is used as the Resource Manager IP.

3. Configure the external load balancer. See the vendor documentation for the type of load balancer
you are using (for example, F5 or Radware).

You can configure the Resource Manager in HA active standby mode by using the Windows NLB
service. Use the procedures in this section to configure the Resource Manager HA-pair on Windows
2008.

Procedure: Configuring Resource Manager HA (Windows 2008)
To set up NLB by configuring Windows 2008, perform this procedure on each of the Resource
Manager hosts in the NLB cluster, specifying a unique ID for each host.

1. Verify that the Resource Manager hosts must conform to the prerequisites for Windows. See
Prerequisites.

2. From the Windows Start menu, select Administrative Tools > Server Manager.
3. In the Feature Summary section, click Add Features.

The Add Features Wizard appears.
4. Click the check box beside Windows Network Load Balancing.
5. Click Install.

Network Load Balancing is installed on Windows.

Configuring the Cluster

6. In Administrative Tools, select Network Load Balancing Manager.
7. Right-click Network Load Balancing Clusters, and click New Cluster.
8. In the Host field, enter the name of the Resource Manager host that you are adding to the cluster for

example, ResMgr1.
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9. Click Connect.
10. Select the interface that will host the HA-pair's virtual IP address, and click Next. The interface selected

cannot be used for the private communication between the Resource Manager nodes (for example, the
IP address that is associated with this NIC cannot be used in the [cluster] member.[n] configuration
parameter). This interface hosts the virtual IP address, which receives and load-balances the client
traffic.

11. Enter the information on the Host Parameters and Cluster Parameters section, as shown in the table
below:

Table: Properties of NLB Service
Section Field Description

Host parameters
Priority
(unique host identifier)

Enter 1 for the first Resource
Manager host in the cluster.

Enter 2 for the second Resource Manager
host in the cluster.

This parameter specifies a unique ID for
each host.

Cluster IP Address

Click Add to enter the IP address
that is shared by the hosts in the
HA-pair.

The shared IP address for the HA-pair must
be static. NLB disables DHCP on every
interface that it configures, as it does not
support DHCP.

Cluster parameters IP Address Enter the virtual IP address of this
cluster.

Subnet mask
Enter the subnet mask for your
network. (The subnet mask is not
required for IPv6 addresses.)

Cluster operation mode Unicast

Enable this radio button.
In Unicast mode, the MAC address of the
cluster is assigned to the network adapter
for the computer, and the built-in MAC
address of the network adapter is not used.

12. In the Port Rules section, click Edit.
13. Configure the port rules as shown in the table below:

Table: Port Rules Configuration
Section Field Value and Description

Port range
From Accept the default value, 0.
To Accept the default value, 65535.

Protocols Select Both (TCP & UDP).

Filtering Mode
Multiple hosts Enable this radio button.
Affinity Set to None.

14. Click Finish.
To add another host to the cluster, right-click the new cluster, click Add Host to Cluster, and repeat

Resource Manager HA (Windows)

GVP Deployment Guide 4



Steps 9 to 15.
15. Next, configure the Resource Manager Applications for HA. See Procedure: Configuring the Resource

Manager HA-Pair.

Tip
The following information applies to NLB configuration on Windows 2008:
In active standby mode, when the active Resource Manager nodes NLB-dedicated NIC cannot be reached
(due to an unplugged cable, a disabled NIC, or a shutdown host), it can take several seconds to several
minutes before the traffic is re-routed to the standby Resource Manager node.

When the active Resource Manager node cannot be reached, the standby node issues the wlbs command
(see Procedure: Configuring the INIT and NLB Script Files (Windows)) as part of the failover sequence. If the
dedicated NLB NIC of the currently active Resource Manager node cannot be reached, then the wlbs
command can hang for several seconds and cause the failover to be delayed.

In addition, if the failover occurred because the Resource Manager machine was shut down, the previously
active Resource Manager might temporarily take over the traffic when the machine reboots. To resolve this
issue:

1. In the Network Load Balancing Properties on both of the Resource Manager hosts in the
cluster, go to the Host Parameters section.

2. In the Initial host state section, select Stopped from the Default state drop-down menu.

Procedure: Configuring the Resource Manager HA-Pair
Complete this procedure for each Resource Manager HA Application in the HA-pair. You will configure
the member IDs and NLB script path in the Resource Manager HA Applications for active standby
mode.

1. For active standby mode only, ensure NLB clustering is set up on each Resource Manager host in the
cluster. See Procedure: Configuring Resource Manager HA (Windows 2008), or Procedure: Configuring
Simple Virtual IP Failover, or Procedure: Configuring Bonding Driver Failover.

2. Log in to Genesys Administrator.
3. On the Provisioning tab, select Environment > Applications.
4. Select the Resource Manager HA Application you want to configure.

The Configuration tab appears.
5. On the Options tab, enter the mandatory information in the Cluster section as shown in the table below:

Table: Options Tab Cluster Section
Option Name Value

members Retain the default value of 1 2.

member.1

Enter <localhost_IP_add_1>:9801
...where <localhost_IP_add_1> is the private IP address of the first Resource Manager host,
which corresponds to the IP address of the network interface that does not have the virtual
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Option Name Value

IP address assigned (not the IP address that is associated with the NLB cluster).

member.2

Enter <localhost_IP_add_2>:9801
...where <localhost_IP_add_2> is the private IP address of the second Resource Manager
host, which corresponds to the IP address of the network interface that does not have the
virtual IP address assigned (not the IP address that is associated with the NLB cluster).

hotstandby Enter true.

mymemberid

• For the Resource Manager HA Application that represents the first
Resource Manager host in the HA-pair, enter 1.

• For the Resource Manager HA Application that represents the second
Resource Manager host in the HA-pair, enter 2.

The first and second Resource Manager hosts must correspond to the first and second
Resource Manager hosts that you specified in Step 5 or the table Properties of NLB Service
in Procedure: Configuring the INIT and NLB Script Files (Linux). Also, if both Resource
Manager instances are running, memberid 2 will be the active one.

virtual-ip

Enter <virtual_IP_add>,
where <virtual_IP_add> is the designated Virtual IP address that is shared by all of the
Resource Manager hosts in the HA-pair.

virtual-ip-in-via Retain the default value of true.
electiontimer Retain the default value of 3000.

FailOverScript

Retain the default value, <Installation Directory>\bin\NLB.bat
where <Installation Directory> is the directory where the NLB.bat file is installed.

Tip
Configuration of this option is not required for active active HA mode.

heartbeattimer Set to 2000.
ha-mode Enter active-active or active-standby

Tip
Many other options can be configured for the Resource Manager HA-pair. For a complete list of the available
options, and descriptions of them, see the GVP 8.5 User's Guide.

6. Click Save.
7. Repeat Steps 3 to 5 for each Resource Manager HA Application in the HA-pair.
8. If you have not already done so, configure a connection to the Message Server in each Resource

Manager Application in the HA-pair. See Procedure: Creating a Connection to a Server.
9. Specify the NICs you want to monitor (optional). See Procedure: Specifying the NICs to Monitor

(Windows).

Resource Manager HA (Windows)

GVP Deployment Guide 6



Procedure: Specifying the NICs to Monitor (Windows)
Specify the NICs that you want the Resource Manager to monitor. If the GVP section in the Resource
Manager HA Application is not configured, all of the NICs installed on the host are monitored for
network errors.

1. More than two NICs are configured on the same host and are fully functional.
2. Two NICs are configured as part of an HA-pair. See Procedure: Configuring Resource Manager HA

(Windows 2008) and Procedure: Configuring the Resource Manager HA-Pair.
3. Log in to Genesys Administrator.
4. On the Provisioning tab, select Environment > Applications.
5. Select the Resource Manager HA Application that you want to configure.
6. On the Options tab, scroll to the GVP section.
7. For the nic.eth0 option, in the Value field, enter the MAC address of the first NIC that you want to

monitor. For example: nic.eth0 = 00-0F-1F-6D-EB-CA (this example assumes chosen network
interfaces numbered 0 and 1).
This value must be provided for IP takeover, even if when a single NIC is used.
• Repeat this step, to add nic.eth1 and the MAC address of the second NIC that you want to monitor.

For example: nic.eth1 = 00-0F-1F-6D-EB-CA (this example assumes chosen network interfaces
numbered 0 and 1).

• NICs must be configured with a value of 0 (zero) for IP takeover, even though a single NIC is used.
• If more than two NICs exist, configure the nics option value to 0 1.

8. Click Save.
9. To confirm that you have configured the NICs correctly, use the ipconfig/all command to query the MAC

addresses of the NICs.
10. Configure the INIT.bat and NLB.bat script files. See Procedure: Configuring the INIT and NLB Script Files

(Windows).

Procedure: Configuring the INIT and NLB Script Files (Windows)
Configure the INIT.bat and NLB.bat files on each Resource Manager host in the HA-pair.

1. Verify that NLB clustering has been set up on the hosts. See Procedure: Configuring Resource Manager
HA (Windows 2008).

Configure the INIT.bat file

2. Open the INIT.bat file in a text editor.
The INIT.bat file is located in <Res_Mgr_Install_Dir>\bin directory.

3. Follow the directions in the script file to change the virtual IP address and the IP address for members 1
and 2 of the HA-pair.

4. Click File > Save.
Configure the NLB.bat file
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5. Open the NLB.bat file in a text editor. The NLB.bat file is located in the <RM_Install_Dir>\bin
directory.

6. Follow the directions in the script file to change the virtual IP address and the IP address for members 1
and 2 of the HA-pair. The private_ip_member1 and private_ip_member2 parameters represent the
interfaces that are associated with the NLB interface.

7. Save the changes.
8. Execute the INIT.bat script on each host to disable NLB functionality on both hosts, enter INIT.bat.
9. Execute the NLB.bat script to re-enable NLB functionality on the host that will act as the master, enter

NLB.bat enable X
...where X is the member ID of the host on which the virtual IP will accept traffic.
Enter 1 or 2 for the value in the NLB.bat enable command, based on the member ID of the Resource
Manager instance on that host.
After NLB.bat script execution, the virtual IP will be active on the host that is identified as
private_ip_member1 in the NLB.bat file. Confirm this by attempting to Remote Desktop into the virtual
IP address, and once logged in, check the hostname to confirm it is the correct system.

10. If you are installing the cluster on Windows 2008, configure the Resource Manager Service. See
Procedure: Configuring the Resource Manager Service (Windows).

11. If you are installing the cluster on Windows 2003, execute NLB cluster mode. See Start Resource
Manager HA-pair in NLB mode.

Procedure: Configuring the Resource Manager Service (Windows)
Modify the Resource Manager Service in Window 2008 to run as a network account.
Complete this procedure on both servers (primary and backup) in the HA-pair.

1. At the Start menu, select Control Panel > Administrative Tools > Services.
2. Right-click the Genesys VP Resource Manager Service.
3. When the Genesys VP Resource Manager Service Properties dialog box opens, click the Log On tab.
4. Enable the This account radio button, and enter .\Administrator .
5. In the Password and Confirm Password fields, enter the Administrator's password.
6. Click the Enable button.
7. Click OK.
8. Start Resource Manager HA-pair in NLB mode (below).

Procedure: Starting Resource Manager HA-pair in NLB mode

1. Execute the INIT.bat file.
When you execute this file, load balancing is disabled on both members in the HA-pair. Executing in
NLB mode, the Resource Manager checks the status of other Resource Manager instance before it
assumes Active Standby status.

2. Start both Resource Manager instances, running as a High Availability pair.
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Resource Manager HA IP Address Takeover for Windows

Beginning with release 8.1.6, Resource Manager supports IP Address Takeover for Windows.

Resource Manager (RM) is used with SIP Server for Media Server applications, and with GVP for
VoiceXML applications. Resource Manager provides an essential intelligence for GVP and media policy
management, resource management and reporting. Resource Manager monitors the availability of
media servers and directs SIP Server to connect sessions to the most suitable media server.

Resource Manager High Availability means that the RM function can be deployed as a pair of RM
processes. You can configure RM pairs to send updates to each other regarding the status of requests
and system states. RM pairs can be deployed in Active-Standby or Active-Active modes.

If SIP Server is sending requests to an RM Active-Active configuration, it requires that a load balancer
be placed between SIP Server and the Resource Manager Pairs. F5, NLB, and Radware are examples
of third party load balancers that can perform these functions. Active-Active designs require load
balancing to maintain stickiness of the session between SIP Server and the RM selected.

If SIP Server is sending requests to an RM pair configured in Active-Standby, then SIP Server is
directing requests only to the active RM, using a Virtual IP. The RMs have an internal selection
mechanism to determine which node should be the active one. The standby RM is used to take over
the role of the Primary only when the current active RM process fails. There are two ways to
accomplish the takeover: you can use Windows NLB for monitoring and switching.

Or, you can use the Genesys Solution Control Server (SCS) to monitor alarms sent to it for RM; if the
active RM goes down, then SCS can execute scripts that change the Virtual IP addressing between SIP
Server to the formerly-standby-now-active RM. The RM also has its internal mechanism of performing
failover using heartbeat monitoring between the pair. The active standby configuration does not
require a load balancer, but does need an effective script solution.

Table: IP Address Takeover vs. Load Balancing A Comparison
RM Configuration RM Scripts RM Load Balancing Pro Con

Active-Standby
(Load Balancing) — Windows NLB

Comes with
the product,
slightly easier
config;
supports
Windows.

—

Active-Standby
(IP Address Takeover)

IP-Takeover
Patch with
Scripts

—

Comes with
the product,
slightly easier
configuration;
supports
Windows &
Linux.

Still less
reliable than
NLB in this
configuration
for switchover
timing; see
the Resource
Manager
Release Note.

Active-Active
(IP Address Takeover) — F5, NLB Fast takeover.

Complex
Config, 3rd
Party sw, NLB
is windows
only.
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RM Configuration RM Scripts RM Load Balancing Pro Con

Active-Active
(Load Balancing) — Genesys SIP Server with

internal load balancing

Comes with
the product,
easy
configuration,
baked-in
function.

—

Procedure: Configure Resource Manager High Availability Using Virtual
IP Address Takeover for Windows

1. New script files were added to the Resource Manager IP. Verify that the following four files are present in
the installation-bin folder:
• INIT_IPTakeOver.bat

• IPTakeOver.bat

• Ping.vbs

• Check_Ip.vbs

2. Follow the instructions inside INIT_IPTakeOver.bat to set the parameters VirtualIP and
VirtualInterface.

3. Follow the instructions inside IPTakeOver.bat to set the parameters VirtualIP, VirtualInterface,
GatewayIP, mymemberid and InterfaceForARPing (Requires a Physical Device Identifier. See
Procedure: Search the Windows Registry for a Physical Device Identifier).

Tip
IPTakeOver.bat also contains instructions that you should follow, for using the arping utility and other
functions.

Line 82 in IPTakeOver.bat should be commented out for Installations on Windows 2008 SP1 with the Hot fix installed.
http://support.microsoft.com/kb/2811463/en-us:

REM @arping.exe -c 3 -i %InterfaceForArping% -S %VirtualIP% %GatewayIP% >> IPTakeOver.log

4. In the RM's [cluster] section, set the failoverscript parameter to $InstallationRoot$/bin/
IPTakeOver.bat.

5. Create alarm-based reaction scripts to execute the failover script which would disable VIP in case of RM
crash or shutdown. To create these scripts, follow these steps:
a. Create a new Third Party Server template.
b. Create two Reaction Applications.
c. Create and configure two Alarm Reaction scripts.
d. Create two Alarm Conditions, one for each RM in RM HA configurations (Active-Active and Active-

Standby), to send an alarm when either instance of RM is stopped intentionally.
e. Create two Alarm Conditions, one for each RM in RM HA configurations (Active-Active and Active-

Standby), to send an alarm when either instance of RM stops unexpectedly.
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6. (Optional) Execute INIT_IPTakeOver.bat manually before starting RM in both HA nodes.

Tip
In some systems, the default heartbeat interval between the two RM nodes (2000 msec) is not suitable for the
IP Takeover mechanism. To compensate, Genesys recommends setting the configuration option
cluster.heartbeattimer to 8000.

NOTE: Virtual IP (VIP) Address Takeover for Windows is less reliable than a Windows NLB
cluster configuration
Adding or removing an IP address using VIP Address Takeover is more complicated than enabling or disabling a port in the Windows
NLB configuration. VIP Address Takeover fails when either command on the backup or the primary fails. By comparison, in the
Windows NLB configuration there is no dependency on a backup command to succeed for most of the failover scenarios.

Netsh (the Microsoft utility used for IP Address Takeover) takes longer to modify the network configuration than it does to enable or
disable a port in the NLB configuration. Also, the time may depend upon a particular NIC and its configuration. Normally,
modification takes less than 15 seconds to execute, but in this situation it can take as long as 30-45 seconds.

In addition, the Netsh command can fail if the NIC configuration is already being accessed through the Network Properties User
Interface.

Procedure: Search the Windows Registry for a Physical Device Identifier
The InterfaceForArping requires you to specify the correct device for the virtual interface. Use this
procedure to get this information from the Windows registry.

1. Start Regedit and go to the directory HKLM\SYSTEM\CurrentControlSet\Control\Network\.
2. Identify the Key with the value {Default}, and the data Network Adapters.

If the virtual interface is set for a Local Area Connection, then search the listed adapter (in the registry)
for the value name that contains the data for the Local Area Connection. The Key that contains the
Local Area Connection is the reference to the physical device identifier.

3. Pre-append \Device\NPF_ to the Key and set this value for InterfaceForArping.

Example:

\Device\NPF_{85FEBE1C-9EEF-4E61-974B-1158DB270F6E}

From this key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E9 72-E325-11CE-
BFC1-08002BE10318}\{85FEBE1C-9EEF-4E61-974B-1158DB270F 6E}

Use the device specification that this procedure acquires when you run the InterfaceForArping.

Virtual IP Interface Takeover Scripts
Find these scripts on your Installation CD or in the IP package that you downloaded over the internet:

• Ping.vbs—Pings the host and returns 1 if the ping successful, 0 if not, -1 if the target is not specified.
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• Check_ip.vbs—Checks if the IP address (arg0) can be found on the host (arg1) and returns 1 if found, 0
if not, -1 if the address and the host are not specified.

• INIT_IPTakeOver.bat—Optional. Disables the Virtual IP interface in the Resource Manager box before
starting the RM process. You can manually execute this batch script.

• IPTakeOver.bat—Enables or disables the Virtual IP interface in the RM box, during RM's own internal
election process or when a failover event occurs.

For steps that configure the Resource Manager application, go to Procedure: Configuring the Resource
Manager HA-Pair.
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