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Configuring GVP Components 2
Perform these advanced configuration procedures after installation and basic configuration.

• Integrating
Application Objects

• Creating a
Connection to a
Server

• Provisioning the
Speech Resources

• Provisioning the
MRCP Proxy

• Configuring the CTI Connector
for Cisco ICM

• Provisioning the PSTN
Connector

• Provisioning the
Supplementary Services
Gateway

• Preparing the Call Control
Platform for Outbound Calling

• Using Resource Groups
• Creating IVR Profiles and DID Groups
• Assigning Default Tenants and Creating

Default Profiles
• Integrating the Reporting Server User

Interface with GVP
• Configuring the Reporting Server Locale

Configuring the CTI Connector for Cisco ICM

When you install the CTI Connector, you can select the CTI Framework that is appropriate for your
environment Genesys CTI or Cisco ICM. Use the procedure in this section to configure the CTI
Connector if you selected Cisco ICM.

• Procedure: Configuring the CTI Connector for Cisco ICM Integration

Procedure: Configuring the CTI Connector for Cisco ICM Integration

1. Log in to Genesys Administrator.
2. On the Provisioning tab, select Environment > Applications.
3. Double-click the CTI Connector Application that you want to configure.

The Configuration tab appears.
4. Click the Options tab.
5. If you want to use the Call Routing Interface (CRI), in the icmc section:

• Configure the ICMInterface option with the CRI value.

Tip
During installation, when you select Cisco ICM, the Service Control Interface is initialize by default.
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• Configure the TrunkGroupID option with an applicable value.
For Single Tenant Environments:

6. In the Tenant1 section:
• Enter the tenant name in the TenantName configuration option value field.
• Change the value of the Ports configuration option, as required. For example, 8000 (or retain the

default, 9000).
For Multi-Tenant Environments:

7. Copy the Tenant1 section and rename it for each additional tenant. For example: Tenant2, Tenant3,
Tenant4.

8. For each newly created tenant:
• Enter the tenant name in the TenantName configuration option value field.
• Change the value of the Ports configuration option, as required. For example, 8000 (or retain the

default, 9000). Ensure that there are no duplicate ports configured across all tenants.

Tip
You can specify a comma-separated list of listener ports for a single tenant, one for each VRU-PG. For
example, 8000, 9000, 10000.

9. Save the changes.
10. Configure an IVR Profile to support ICM call flows, see Chapter 6 in the Genesys Voice Platform 8.5 User

s Guide.

Provisioning the PSTN Connector

The procedures in this section describe how to configure the mandatory parameters for the Public
Switched Telephone Network (PSTN) Connector Application object and the how to integrate the PSTN
Connector with SIP Server. There are many more configurable parameters for the PSTN Connector, all
of which are optional. For a complete list and description of configuration options, see the Genesys
Voice Platform 8.5 User's Guide.

The PSTN Connector component is required if you are planning to migrate from GVP 7.x Voice
Communication Server (VCS), or a VoiceGenie (VG) TDM interface to GVP 8.1.2 or later.

• Procedure: Configuring the PSTN Connector
• Procedure: Configuring a Trunk DN for the PSTN Connector

Procedure: Configuring the PSTN Connector
Prepare the PSTN Connector to manage inbound and outbound calls for GVP.
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1. Verify that:
• All of the GVP components are installed. See Procedure: Using the Deployment Wizard to Install GVP,

on page 221.
• The connections to Message Server, SIP Server, and the SNMP Master Agent are configured in the

PSTN Connector Application object. See Procedure: Creating a Connection to a Server, on page 243.
• SIP Server is installed. See the Voice Platform Solution 8.1 Integration Guide.

2. Log in to Genesys Administrator.
3. On the Provisioning tab, select Environment > Applications.
4. Select the PSTN Connector Application object that you want to configure.

The Configuration tab appears.
5. Click the Options tab, and from the View drop-down list, select the Mandatory Options view.
6. In the DialogicManager_Route1 and GatewayManager sections, enter the values for the mandatory

options as shown in the table below.
Table: PSTN Connector Mandatory Parameters

Section Option Value

DialogicManager_Route1 RouteType

Specify one of three route types
or call directions for this route,
enter:
• 0 for Inbound
• 1 for outbound
• 2 for In/Out

(See Note below, in this table.)

Signaling Type

Specify one of five signaling
types, enter:
• 0 for T1-ISDN (PRI)
• 1 for Analog
• 2 for E1-ISDN (PRI)
• 3 for T1-RobbedBit
• 4 for E1-CAS

Channels

Specify the ports for this route
by using the format,
[<Card>:<PortRange>,<Card>:<PortRange>].

You can provision more than one board
in a route and a partial range of ports in
a board for example:

• 1:1-23
• 1:1-23,2:1-23
• 1:1-30,2:1-30
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Section Option Value

• 1:1-12,2:1-15

GatewayManager SIP Destination IP Address

Enter the SIP endpoint IP
address that will receive SIP
calls from the PSTN Connector.
(This is the IP address for SIP
Server or the

Resource Manager, depending on your
configuration.)

SIP Destination Port Number
Enter the SIP endpoint port
number of the server that is
configured in SIP Destination IP
Address.

MediaManager Supported Local Codec Type

Enter the audio format that is in
use on the TDM trunk:
• 0 - Mulaw
• 8 - ALaw

Notes
• The Inbound & Outbound route type is supported only on ISDN (PRI) lines. If you select one of

these route types, ensure that you use a compatible signaling type.
• If you are using a T1-Robbed Bit or E1-CAS interface, options in the T1rb options group must be

configured, specifically the T1rbProtocolFile option, see the component metadata.
• For JCT boards only, a separate span is required to support ASR or recorded VoiceXML applications

in T1-ISDN, E1-ISDN, or E1-CAS environments. The MediaVoxResourceBoard option must be
configured with route number that is used for CSP.

• When JCT boards are used with the PSTN Connector, and the VoiceXML application uses ASR or
recording media, not all the spans can be used for call handling. For each span that is configured
to take calls, there must be another dedicated span for streaming echo cancelled audio to the
Media Control Platform. Therefore, if Route1 is configured to handle calls on span1 (for example,
ports=1:1-23), the MediaVoxResourceBoard option under the DialogicManagerRoute1 section
should be set to 2. Repeat the same steps if you have configured a DialogicManager_Route2
section.

This restriction does not apply in the following scenarios:

• The VoiceXML application is a pure DTMF application (does not use ASR or recording media).
• The VoiceXML application uses ASR but the JCT board is configured with the T1-Robbed Bit

protocol.

7. Create additional DialogicManager_Route<N> sections as required (for example, you may want to
create a section for inbound ports and one for outbound ports):
a. From the View drop-down list, select either Advanced View (Options) or Advanced View (Annex).
b. Right-click on the Section column heading and select New.
c. Enter DialogicManager_Route2 for the Section name, Description for the Option name, and Route2
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Information for the Value.
d. Click OK.
e. Copy and paste all of the options from the DialogicManager_Route1 and DialogicManager_Route2

sections, modifying the mandatory values as required.
f. Repeat these steps as required.

Tip
Dialogic Circular Buffer Size
When you configure the PSTN Connector application, set the value for [DialogicManager]
DialogicTransferBufferSize to 2048. This specifies the size of the Dialogic Circular buffer which is used for
transferring data to the Dialogic firmware. The default value of this parameter on Windows is different, but
must be set to 2048 for Linux. If not, the Dialogic may return LOW_WATER_MARK warnings during initial play
of the media, which interferes with normal audio play and may result in the prompt being cut off.

8. Save the configuration.
9. Configure the Trunk and Trunk Group DNs for the PSTN Connector. See Procedure: Configuring a Trunk

DN for the PSTN Connector.

Procedure: Configuring a Trunk DN for the PSTN Connector
Configure SIP Server with a Trunk DN that points to the PSTN Connector Application object, to ensure
that outbound calls can be routed to a specific PSTN Connector instance.

You can deploy multiple PSTN Connectors, however, you must ensure that SIP Server routes the
outbound call to the same PSTN Connector instance as the inbound call. This procedure includes
configuration options to enable this functionality.

1. Verify that the PSTN Connector is installed and configured. See Procedure: Configuring the PSTN
Connector.

2. Log in to Genesys Administrator.
3. On the Provisioning tab, select Environment > Switching > Switches.
4. Double-click the switch that you want to configure.

The Configuration tab appears.
5. On the DNs tab, select New.
6. In the General section, enter values for the mandatory fields, selecting Trunk from the Type drop-down

list.
7. In the Switch pane, double-click the Trunk DN you created in Step 4.
8. On the Options tab, select Advanced View (Annex) from the View drop-down list.
9. Right-click on the Section column, and select New.

10. In the New Option dialog:
• In the Section field, enter TServer.
• In the Name field, enter contact.
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• In the Value field, enter the IP address and port number of the PSTN Connector separated by a colon
for example, 10.10.10.101:5060

11. In the DNs pane, click New.
12. In the TServer section, add the following options and values:

• prefix = <xyzz> where <xyzz> represents a number which, if present in the dial string of the
outbound call, enables the SIP Server to route the call to the PSTN Connector instance that is
configured with this prefix.

• replace-prefix = <empty String) where <empty String) represents an empty string to ensure
that the prefix added by Resource Manager to the destination number string is removed by the SIP
Server before the call is forwarded to the same PSTN Connector instance.

13. Save the configuration. For information about how the PSTN Connector fits into a common VPS
deployment architecture, see the Supported Architecture chapter in the Voice Platform Solution 8.1
Integration Guide.

14. If required, complete the post-installation activities for the Supplementary Services Gateway. See
Provisioning the Supplementary Services Gateway.

Provisioning the Supplementary Services Gateway

The following procedures describe how to configure the mandatory parameters for the
Supplementary Services Gateway Application object and the how to integrate the Supplementary
Services Gateway with SIP Server. There are many more configurable parameters for the
Supplementary Services Gateway, all of which are optional. For a complete list and description of
configuration options, see the GVP 8.5 User's Guide.

The Supplementary Services Gateway is an optional component and is required only if you intend to
support outbound call campaigns in your deployment.

Tip
Multiple instances of the Supplementary Services Gateway can be installed on the
same host; however, the HTTPPort and HTTPSPort parameters must have unique
values and cannot be the same for more than one instance.

This section contains the following procedures:

• Configuring the Supplementary Services Gateway
• Configuring DNs for the Supplementary Services Gateway
• Configuring a Routing Point DN
• Configuring a Voice Over IP Service DN
• Configuring a Voice Treatment Ports DN
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Procedure: Configuring the Supplementary Services Gateway
Prepare the Supplementary Services Gateway to receive and respond to outbound call initiation
requests from TAs.

1. Verify that:
• All other GVP components are installed. See Procedure: Using the Deployment Wizard to Install GVP,

on page 221.
• The connections to Message Server, SIP Server, and the SNMP Master Agent are configured in the

Supplementary Services Gateway Application object. See Procedure: Creating a Connection to a
Server.

• SIP Server is installed. See the Voice Platform Solution 8.1 Integration Guide.

2. Log in to Genesys Administrator.
3. On the Provisioning tab, select Environment > Applications.
4. Select the Supplementary Services Gateway Application object that you want to configure.

The Configuration tab appears.
5. Click the Options tab, and select Advanced View (Options) from the View drop-down list.
6. In the Tenant1 section, enter Environment in the Value field of the TGDN option. (The value that is

configured in the TGDN parameter is used as the tenant name.)
7. Create additional Tenant<n> sections, as required—for example: Tenant2, Tenant3, and so on. To create

new sections by copying and pasting options, see Step 6 in Procedure: Configuring the PSTN Connector.
8. Save the configuration.
9. Configure the Trunk and Trunk Group DNs to route for Resource Manager and external numbers. See

Procedure: Configuring DNs for the Supplementary Services Gateway.

Procedure: Configuring DNs for the Supplementary Services Gateway
Configure SIP Server with a Trunk Group DN that points to the Resource Manager Application object,
and a Trunk DN that is used to route calls to external numbers.

The Trunk Group DN must have the same name as the tenant for which the Supplementary Services
Gateway will make calls. This configuration enables the SUBSCRIBE and NOTIFY messages between
SIP Server and the Resource Manager.

1. Verify that the Supplementary Services Gateway is installed and configured. See Procedure: Provisioning
the Supplementary Services Gateway.

2. Log in to Genesys Administrator.
3. On the Provisioning tab, select Environment > Applications.
4. Select the SIP Server Application object you want to configure. The Configuration tab appears.
5. On the Options tab, in the View drop-down list, select Advanced View (Options).
6. In the TServer section, change the value of the following Options:

• am-detected = connect
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• fax-detected = connect

• cpd-info-timeout = 7

• sip-invite-treatment-timeout = 30

7. Configure a DN on the SIP switch of type Trunk Group, and, for the DN name, enter the name of the
tenant for example, Tenant1.

8. Configure a DN on the SIP switch of type Trunk as the endpoint. The endpoint is the destination of the
outbound call for example, a softphone.
Configure Trunk Group DN

9. After the <TenantName> Trunk Group DN is configured, enter the values for the following parameters in
the TServer section of the Annex, as shown in the figure below.
• subscription-id = <TenantName> Must be the name of the tenant that is associated with the

Resource Manager. (The DN, tenant, and subscription-id must all have the same name:
<TenantName>.

Tip
Tenant names are case sensitive and must be used consistently, especially in outbound scenarios. For
example, if you create the tenant names, tenant1 and Tenant1, they are treated as two separate tenants.
The value that is configured in the TGDN parameter is used as the tenant name.

• contact = sip:172.24.133.50:5060 The IP address and port number of the Resource Manager.
(The value shown here for contact is only an example.)

• cpd-capability = mediaserver This configuration designates the Media Server module of the
Media Control Platform as the CPD provider.

• request-uri = sip:msml@172.24.133.50:5060;gvp-tenant-id=TenantName The value of this
parameter should point to the Resource Manager, and the user part must contain msml.

• userdata-map-format = sip-headers-encoded

• make-call-rfc3725-flow = 1

• refer-enabled = false

• ring-tone-on-makecall = false

Configure Trunk DN

10. After the Trunk DN is configured, enter the value for the following parameter in the TServer section of
the of the Advanced View (Annex):
• contact = sip:172.21.193.61:10000 The IP address and port number of the external party. (The

value shown here for contact is only an example).

Tip
If CPD is enabled at Media Gateway, configure CPD at the Trunk. If CPD is enabled at both Trunk and Trunk
Group, CPD enabled on the media gateway takes precedence by default.

For information about how to configure the Supplementary Service Gateway within the VPS, see the VP Solution 8.1 Integration
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Guide.

11. (Optional) Configure a Routing Point DN. See Configuring a Routing Point DN.
12. Complete the post-installation activities for the Call Control Platform if you intend to use it for outbound

calling. See Procedure: Configuring the Call Control Platform.

Procedure: Configuring a Routing Point DN
Create a Routing Point DN to use for outbound calls with the legacy GVPi.

Use this procedure if you want to support your outbound solution by making outbound calls through a
Routing Point DN (instead of a Trunk Group DN) by using the legacy GVPi and CTI functionality. Create
a Routing Point DN for each tenant in your environment.

1. Verifythat a Trunk DN exists on the SIP switch for outbound calls. See the VP Solution 8.1 Integration
Guide.

Configure the Routing Point DN
2. Log in to Genesys Administrator.
3. On the Provisioning tab, select Switching > Switches.
4. Double-click the SIP Server Switch object you want to configure.

The Configuration tab appears.
5. Click the DNs tab and select New.
6. On the DN Configuration tab:

a. In the Number field, enter valid Route Point DN number. (Ensure there is no conflict with the Trunk
Group DN that was created for receiving port details.)

b. In the Type field, select Routing Point from the drop-down list.

7. On the Options tab, click New.
8. In the New Option dialog box:

a. In the Section field, enter TServer.
b. In the Name field, enter partition-id.
c. In the Value field, enter the name of the tenant (for which this Route Point DN is configured). This

configuration enables SIP Server to select an MSML service with the same partition-id.
Configure the SSG Application

9. On the Provisioning tab, select Environment > Applications.
10. Select the Supplementary Services Gateway Application object that you want to configure.

The Configuration tab appears.
11. Click the Options tab, and select Advanced View (Options) from the View drop-down list.
12. In the Tenant1 section:

a. For the RPDN option, enter a value that matches the RPDN. For example, RP 2000.
b. For the TGDN option in the Value field, enter the tenant name. The value that is configured in the

TGDN parameter is used as the tenant name.
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13. If you want to send outbound calls for multiple tenants, create additional Tenant <N> sections
configured with the RPDN option, as required for example, Tenant2, Tenant3, and so on. To create new
sections by copying and pasting options, see Step 6 in Procedure: Configuring the PSTN Connector.

14. Save the configuration.
15. Configure a VoIP Service DN. See Procedure: Configuring a Voice Over IP Service DN, below:

Procedure: Configuring a Voice Over IP Service DN
Create and configure a VoIP Service DN that is used by SIP Server to initiate MSML dialogs (to obtain
CPD) when a request is received on the Routing Point DN.

The VoIP Service DN works in conjunction with the Routing Point DN. For outbound calls, SIP Server
selects the MSML service type with the value that is configured in the partition-id option (either no
partition-id or the partition-id that is configured in the SIP Server application).

1. Verify that a Routing Point DN has been configured. See Configuring a Routing Point DN.

Configure the Voice Over IP Service DN
2. Log in to Genesys Administrator.
3. On the Provisioning tab, select Switching > Switches.
4. Double-click the SIP Server Switch object you want to configure.

The Configuration tab appears.
5. Click the DNs tab and select New.
6. On the DN Configuration tab:

a. In the Number field, provide a unique, valid number for the DN.
b. In the Type field, select Voice Over IP Service from the drop-down list.

7. On the Options tab, click New.
8. In the New Option dialog box:

a. In the Section field, enter TServer.
b. In the Name field, enter contact.
c. In the Value field, enter the IP address and port number of the Resource Manager, for example,

sip:172.24.133.50:5060.

9. Repeat the two previous steps to add the following options and values:
• cpd-capability = mediaserver

• partition-id = <tenant_name>

• service-type = msml

• subscription-id = <tenant_name>

10. Click Save and Close.
11. Repeat Steps 4 to 9 to create a second VoIP Service DN to play Treatments (service-type =

treatment).
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12. (Optional) Configure VTP Ports. See Procedure: Configuring a Voice Treatment Port's DN, below:

Procedure: Configuring a Voice Treatment Ports DN
Create and configure a Voice Treatment Ports (VTP) DN to play IVR Profile VoiceXML dialogs. You can
create any number of VTP DNs to control the number of simultaneous outbound requests that can be
placed on the route point.

1. Log in to Genesys Administrator.
2. On the Provisioning tab, select Switching > Switches.
3. Select the SIP Server Switch object you want to configure.

The Configuration tab appears.
4. Click the DNs tab and select New.
5. On the DN Configuration tab:

a. In the Number field, enter a valid Voice Treatment Port as the number.
b. In the Type field, select Voice Treatment Port from the drop-down list.

6. On the Options tab, click New.
7. In the New Option dialog box:

a. In the Section field, enter TServer.
b. In the Name field, enter contact.
c. In the Value field, enter the IP address and port number of the Resource Manager, for example,

sip:172.24.133.50:5060.

8. Repeat Steps 6 and 7 to add the following options and values:
• prefix = mediaserver

• request-uri = sip:<vtp DN name>@<RM contact>gvp-tenant-id=<tenantName>

• event-ringing-on-100trying = true (when CTI Connector is used on the call, otherwise, false)
• cpd-capability = mediaserver (the Media Control Platform performs CPD)
• userdata-map-filter = constant string "gsw-ivr-profile-name,gsw-session-dbid,

OutboundData,AnswerClass,outbound-ivr-call"

Where:
• OutboundData is the filter that is provided to pass user data from the Supplementary Services

Gateway to the IVR Application. For information about attaching user data to outbound calls, see
the Voice Platform Solution 8.1 Integration Guide.

• outbound-ivr-call must be passed to the Resource Manager to ensure the media service call is
not dropped until the route is used when a temporary double-counting of IVR Profile usage can
happen when the IVR VoiceXML call leg is placed.

• AnswerClass is required if the CPD result must be passed to VoiceXML application. Add the GVP-
IVRPort parameter if the Supplementary Services Gateway is integrated with the PSTN Connector
and the GVP-PSTNC-DBID parameter if the Supplementary Services Gateway is integrated with the
CTI Connector, for example: userdata-map-filter = constant string "gsw-ivr-profile-
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name,GSW_SESSION_DBID,gsw-session-dbid,OutboundData,AnswerClass,GVP-IVRPort,GVP-
PSTNC-DBID"

Tip
Genesys recommends that you create a strategy to select a available VTP DN (from the set of VTP DNs
that you created) to load on the Routing Point DN. For more information about routing strategies, see
Chapter 11 of the Voice Platform Solution 8.1 Integration Guide.

Preparing the Call Control Platform for Outbound Calling

This section describes how to prepare the Call Control Platform to make outbound calls. The Call
Control Platform is an optional component.

Procedure: Configuring the Call Control Platform
Configure the Call Control Platform Application object to make outbound calls.

1. Verify that:
• All of the GVP components are installed. See Procedure: Using the Deployment Wizard to Install GVP.
• The Call Control Platform is integrated with the Resource Manager. See Procedure: Integrating

Application Objects with Resource Manager.
• A Call Control Platform connection to the Message Server is created. See Procedure: Creating a

Connection to a Server.

2. Log in to Genesys Administrator.
3. On the Provisioning tab, select Environment > Applications.
4. Select the Call Control Platform Application.
5. Click the Options tab, and scroll to the mediacontroller section.
6. Click the Value field of the sipproxy option, and then enter <IP_RM>:<SIPPort_RM>

Where IP_RM is the IP address of the Resource Manager, and SIPPort_RM is the SIP port of the Resource
Manager.

7. Click the Value field of the bridge_server, and then enter <IP_RM>:<SIPPort_RM>
Where IP_RM is the IP address of the Resource Manager, and SIPPort_RM is the SIP port of the Resource
Manager (5060 is the default).

8. Click Apply.
9. Save the configuration.

10. Complete the post-installation activities for the Resource Manager. See the next section, Using Resource
Groups.
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