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Configuring GVP Components 3
Perform these advanced configuration procedures after installation and basic configuration.

• Integrating
Application Objects

• Creating a
Connection to a
Server

• Provisioning the
Speech Resources

• Provisioning the
MRCP Proxy

• Configuring the CTI Connector
for Cisco ICM

• Provisioning the PSTN
Connector

• Provisioning the
Supplementary Services
Gateway

• Preparing the Call Control
Platform for Outbound Calling

• Using Resource Groups
• Creating IVR Profiles and DID Groups
• Assigning Default Tenants and Creating

Default Profiles
• Integrating the Reporting Server User

Interface with GVP
• Configuring the Reporting Server Locale

Using Resource Groups

To enable ease of management, common GVP resources can be grouped into Logical Resource
Groups (LRGs). When multiple instances of a resource, such as, the Media Control Platform, Call
Control Platform, or CTI Connector, are assigned to a resource group, the Resource Manager can
easily manage and provide load balancing for the resources within the group. In addition, connections
are created to enable the physical resources to communicate with the Resource Manager so that they
can be assigned to fulfill requests for services. To create the connections, see Procedure: Creating a
Connection to a Server.

Important
Configuring a gateway resource group for SIP Server is mandatory; not doing so may
cause Resource Manager to generate unexpected errors.

The AOR configured in the Gateway Group should match the AOR in the 'via' header of
the SIP INVITE message presented to RM.

Procedure: Creating a Resource Group
Group resources that use common services and provide load balancing.

The MCPGroup created in this procedure provides load balancing for the resources within it that are
using VoiceXML services. If you have one or more Call Control Platforms installed in your deployment,
create a resource group that includes resources that use CCXML services. You can also create a group
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to manage resources that use the gateway, CTI, conference services, or recording servers.

1. Verify that all of the GVP components are installed. See Procedure: Using the Deployment Wizard to
Install GVP.

2. Log in to Genesys Administrator.
3. On the Provisioning tab, click Voice Platform > Resource Groups.
4. On the Details pane toolbar, click New.

The Resource Group Wizard opens to the Welcome page.
5. On the Resource Manager Selection page, select the Resource Manager Application object for which you

want to create the group. On the Group Name and Type page:
6. Enter a group name; for example, MCPGroup.
7. Select one of five group types:

• Media Control Platform
• Call Control Platform
• Gateway
• CTI Connector
• Recording Server

Tip
When creating resource groups in multi-tenant environments, ensure that only one CTI Connector resource
group is configure for the entire hierarchy.

A short video on how to create an MCP resource group: Link to video A short video on how to create a Gateway resource group:
Link to video

8. On the Tenant Assignments page, select the child tenant to which the resource group will be assigned.
9. On the Group Properties page, enter the information from the table below for each resource group that

you are configuring.

Tip
For the Media Control Platform group, the Max.Conference Size and Max.Conference Count, and Geo-location
options are optional; therefore, they are not included in thus table. For a complete list of resource-group
options and their descriptions, see the GVP 8.5 User's Guide.

Table: Group Properties Resource Groups Wizard
Field name Value

Media Control Platform
Monitoring Method Retain the default value: SIP OPTIONS.
Load Balance Scheme Select least percent.
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Field name Value
Call Control Platform

Monitoring Method Retain the default value: none.
Load Balance Scheme Select least percent.

Gateway
Monitoring-Method Retain the default value: none.
Load Balance Scheme Select least percent.

CTI Usage Select Always off, Always on, or Based on DN
lookup.

CTI Connector
Monitoring-Method Retain the default value: none.
Load Balance Scheme Retain the default value: round-robin.

Recording Server
Monitoring-Method Retain the default value: SIP Options.
Load Balance Scheme Retain the default value: round-robin.

10. On the Resource Assignment page:
a. Select the checkbox beside each resource you want to assign to this group.
b. In the SIP Port column, click in the column to select a port number from the drop-down list.
c. In the SIPS Port column, click in the column to select a port number from the drop-down list.

Tip
When you are creating Gateway resource groups: there is only the SIP Port column, and you must enter
the port number (there is no drop-down list of ports).

d. In the Max Ports column, enter a number that represents the maximum number of requests this
resource is capable of handling.

e. In the Redundancy column, click in the column to choose active or passive from the drop-down list.
The Resource Assignment list is compiled depending on the type of group that you are creating; for
example, if you are creating a Media Control Platform group, only Media Control Platform servers
appear in the list.
The Resource Manager (RM) supports physical resources as active or passive inside a Logical
Resource Group. Configure each resource with the option redundancy-type. The default value is
active.
If redundancy-type is not specified for a resource, then RM considers it as active.
Normally, RM load-balances the active resources. When one or more active resources go down, the
passive resources activate to replace them. RM load-balances the remaining active resources and
passive resources.
When all active resources become available again, RM returns to using only the active
ones—although existing sessions on the passive resources are allowed to complete.

11. On the Confirmation page, click Finish.
12. Continue with the post installation activities for the Resource Manager. See Procedure: Creating IVR

Profiles.
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Creating IVR Profiles and DID Groups

GVP uses IVR Profiles, which are VoiceXML, CCXML, Announcement, and Conference applications, to
control interactions that require the use of Direct Inward Dialing (DID) numbers and provides service
for the resources that use them.

Tip
IDs were formerly referred to as Dialed Numbers (DN) in GVP releases prior to GVP
8.1.2.

You can create as many IVR Profiles as you need and any number of DIDs or DID ranges. DIDs are
grouped into DID Groups for ease of assignment and administration. DIDs are obtained from the
Dialed Number Identification Service (DNIS). The Resource Manager can be configured to obtain DNIS
information from SIP Server.

If GVP is configured to map DIDs to IVR Profiles or a tenant, the Resource Manager uses DNIS to
determine which IVR Profile to invoke for the session. If GVP is not configured in this way, the
Resource Manager uses a default IVR Profile that is specified for the Environment (or default) tenant.

This section contains the following procedures:

• Procedure: Creating IVR Profiles
• Procedure: Adding a Context Services base URL to an IVR Profile
• Procedure: Creating DID Groups

Procedure: Creating IVR Profiles
Create IVR Profiles that use DIDs to provide service for the resources that use them.

1. Log in to Genesys Administrator.
2. On the Provisioning tab, select Voice Platform > IVR Profiles.
3. In the Tasks panel, click Define New IVR Profile.

The IVR Profile Wizard opens to the Welcome page.
4. On the Service Type page:

a. Enter a name for the IVR Profile for example, VPS_IVRProfile.
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Tip
The IVR Profile name is case-sensitive and can be up to 255 characters in length. For information about
naming IVR Profiles, see Genesys Administrator 8.1 Help.

b. From the drop-down list, select one of four service types:
• VoiceXML
• CCXML
• Conference
• Announcement

5. On the Service Properties page, enter the mandatory values from Table: IVR Profile Wizard Service
Properties for the service type that you selected in the previous step. This table includes only those
options that are mandatory to create an IVR Profile. For a complete list of the options used to configure
IVR Profiles and their descriptions, see the GVP 8.5 User's Guide.

Table: IVR Profile Wizard Service Properties
Service Type Field Value

VoiceXML Initial Page URL

Enter the Universal Resource
Locator (URL) to your VoiceXML
page for example,
http://samples/hello.vxml
or file:///C:/GVP/VP_MCP/
samples/helloaudio.vxml

CCXML Initial-Page-URL

Enter the URL to your CCXML
page for example,
http://samples/hello.vxml
or file:///C:/GVP/VP_CCP/
samples/helloaudio.ccxml

Conference Conference-ID
Enter a value that starts with a
letter, number, or underscore
(cannot exceed 255
characters), for example: 3332.

Announcement Play

Enter the URL that points to the
announcement you want to
play for example,
http://samples/hello.vxml
or
C:/GVP/VP_CCP/samples/
announcements.

Note that the URLs in this table are examples. When you create your IVR Profiles, enter the URLs that
point to the actual VoiceXML, CCXML, Conference, or Announcement applications in your
environment. The small icon to the right of the URL field in the wizard, is used to load the URL into a
pop-up web page, verify the accuracy, and confirm that an application actually exists at that
location.
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Tip
After the Service Properties are entered, you have the option of clicking Finish and a basic IVR Profile is
created. However, if you want to customize the profile, you can continue on through the Usage Limits, IVR
Capabilities, CTI Parameters, and Dialing Rules pages which contain optional configuration parameters. For
more information about these configuration parameters, see the GVP 8.5 User's Guide.

6. On the Usage Limits page, in the Maximum Concurrent Sessions field, enter a number to define the
maximum number of concurrent sessions that can be used by the IVR Profile.

7. On the IVR Capabilities page, configure the parameters in the table below as required for your IVR
Profiles. The IVR Capabilities page appears only if you have selected the VoiceXML or CCXML service
types in Step 4.

IVR Capabilities Page IVR Profile Wizard
Option Description

Allow Outbound Calls

Insert a check mark to enable (or leave blank to
disable).

Sets the value of the outbound-call-allowed parameter (for
bridge or consultation transfers, as well as for outbound
calls), in the gvp.policy configuration section. By default,
INVITE transfers are enabled

Allows Transfers

Insert a check mark to enable (or leave blank to
disable).

Sets the value of the transfer-allowed parameter (for blind or
consultation transfers), in the gvp.policy configuration
section. By default, REFER transfers are enabled.

Gateway Selection

Select one of three options:
• Always use the same gateway
• Use same gateway if possible
• Use any available gateway

8. On the CTI Parameters pane, configure the parameters as described in the table below. The CTI
Parameters page appears only if you have selected the VoiceXML service type earlier in this procedure.

Table: CTI Parameters Pane IVR Profile Wizard
Option Description

Require CTI Interaction

Insert a check mark to enable (or leave blank to
disable).

Sets the value of the cti-allowed parameter, in the gvp.policy
configuration section. By default, the CTIC is not required.

Transfer on CTI

Insert a check mark to enable (or leave blank to
disable).

Sets the values of the cti.transferoncti and cti.defaultagent,
respectively, in the gvp.service-parameters configuration
section.
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Option Description

Default Agent The default agent to whom transfers will fall back
if the original transfer fails.

9. On the Dialing Rules page:
• In the Action field, retain the default value Accept.
• In the Regular Expression field, enter the expression in the form of a URL. The Dialing Rules page

appears only if you have selected the VoiceXML or CCXML service type in step 4 of Procedure:
Creating IVR Profiles.

10. On the Policies page, in the SQ Notification Threshold (%) field, enter a number between 1 and 100.
11. On the Confirmation page, if the configuration is correct, click Next.
12. Click Finish.
13. (Optional) Manually add a Context Services base URL to an IVR Profile. See Procedure: Adding a Context

Services base URL to an IVR Profile.
14. Create the DID Groups. See Procedure: Creating DID Groups.

Procedure: Adding a Context Services base URL to an IVR Profile
Universal Contact Server (UCS) interfaces use a database that stores contact (customer) data. Classic
UCS works with Genesys eServices (Multimedia). By using Context Services, which is an optional set
of additional capabilities, UCS can work with other Genesys products and solutions, such as Genesys
Voice Platform and Conversation Manager. This procedure is optional.

1. Log in to Genesys Administrator.
2. On the Provisioning tab, select Voice Platform > IVR Profiles.
3. Select the newly created IVR Profile.
4. To add a new option, click New:

a. In the Section field, enter gvp.service-parameters.
b. In the Name field, enter voicexml.cs_base_url.
c. In the Value field, enter fixed, <the base HTTP URL of the context services>.

Important
The voicexml.cs_base_url value can also contain the username and password if it is required by the
context services. If the username and password is required, use this syntax:

http://<username>:<password>@<host>:<port>
If the username and password is not required, use this syntax:
http://<host>:<port>

5. Click OK.
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Procedure: Creating DID Groups
Create DID Groups that contain DIDs to assign to IVR Profiles and tenants. DID Groups enable ease of
management and assignment. The groups can contain a single DID, a range of DIDs, or no DIDs.
Empty DID Groups can be created initially as placeholders until you are ready to populate them.

1. Log in to Genesys Administrator.
2. On the Provisioning tab, select Voice Platform > DID Groups.
3. Select New.
4. In the Name field, enter the name of the DID Group.
5. In the IVR Profile field, click the browse icon to find the IVR Profile or tenant that you want to associate

with this DID Group.
6. In the DIDs field, click Add.
7. In the DID dialog box, enter a DID, a range of DIDs or a number prefix for example: 1234

4567-8901
456*

8. In the DID Group Property panel, click Save or click Save & New to create another DID Group.
9. Configure the Environment (default) Tenant and default IVR Profile. See Assigning Default Tenants and

Creating Default Profiles

Assigning Default Tenants and Creating Default Profiles

In multi-tenant environments, the default tenant and IVR Profile are used for those calls that are not
validated or cannot be associated with a specific tenant or profile. To properly configure the default
objects, a specific Resource Manager instance must be configured to manage the default tenant, the
tenant data must be configured, and a default IVR Profile must be created.

Important
Mandatory for any tenant that is managed by Resource Manager:

1. You must create a default IVR-Profile object under that tenant. For simplicity, in the IVR-
Profile's Annex tab, the parameter service-type under gvp.general section may point to
voicexml.

2. In that tenant's Annex tab, the parameter default-application under gvp.general section
must point to that profile object.

Use the following procedures to complete the task in this section:

• Procedure: Adding the Environment Tenant to the Resource Manager
• Procedure: Creating a Default Profile for the Default Tenant
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• Procedure: Updating the Tenant Data

Procedure: Adding the Environment Tenant to the Resource Manager
Add the Environment Tenant to the Resource Manager Application that is used to create a default IVR
application.

This procedure describes the steps to add the Environment tenant to the Resource Manager
Application when GVP is deployed in a multi-tenant environment. If your environment is single-
tenant, the default tenant is named Resources and not Environment.

1. Verify that all of the GVP components are installed. See Procedure: Using the Deployment Wizard to
Install GVP.

2. Log in to Genesys Administrator.
3. On the Provisioning tab, select Environment > Applications.
4. Click the Resource Manager Application object you want to configure.

The Configuration tab appears.
5. In the Server Info section, in the Tenants field, click Add.

A Browse dialog box appears.
6. Select Environment, and then click OK.

The Environment Tenant object appears in the Tenants field.
7. Save the configuration.
8. Create a default IVR Profile for the Environment Tenant. See Procedure: Creating a Default Profile for the

Default Tenant

Procedure: Creating a Default Profile for the Default Tenant
Create a default IVR Profile that can be used to accept calls other than those specified in the dialing
plans.

1. Log in to Genesys Administrator.
2. On the Provisioning tab, select Voice Platform > IVR Profiles.
3. In the Tasks panel, click Define New IVR Profile.

The IVR Profile Wizard opens to the Welcome page.
4. On the Service Type page:

a. Enter the name of the default IVR Profile, IVRAppDefault.
b. Select VoiceXML from the drop-down list.

5. On the Service Properties page, enter http://samples/hello.vxml.
6. Click Finish.
7. Update the Environment tenant data. See Procedure: Updating the Tenant Data.
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Procedure: Updating the Tenant Data
Configure the tenant to look for the default IVR Profile application, so that calls other than those
specified in the dialing plans are accepted.

1. All of the GVP components are installed. See Procedure: Using the Deployment Wizard to Install GVP.
2. A default IVR Profile has been created, named, IVRAppDefault. See Procedure: Creating a Default Profile

for the Default Tenant.
3. Log in to Genesys Administrator.
4. On the Provisioning tab, select Environment > Tenants.
5. Click the Environment tenant or, if you are configuring a single-tenant environment, click Resources.
6. On the Options tab, create a new section named gvp.general.
7. In the gvp.general section, create a new option named default-application.
8. For the default-application option, enter the value IVRAppDefault.
9. Enter the values for the remaining options in the gvp.general, gvp.policy section, and gvp.dnis-

range sections as shown in the table below.
The default-application option is mandatory for a tenant.

Sections, Names, and Values GVP Options
Section Name Value

gvp.general default-application IVRAppDefault
sip.sessiontimer 1800

gvp.policy usage-limits 100

The values for the gvp.dnis-range configuration option are added automatically by the DID wizard.

The IVR Profile and Environment tenant configuration sections, gvp.log, gvp.log.policy, and gvp.policy.dialing-rules can be further
defined with many more supported options. For a complete list of these options, go to the Options tab of the Application object
template.

10. Save the configuration.
11. Complete the post-installation activities for the Reporting Server. See Integrating the Reporting Server

User Interface with GVP, below:

Integrating the Reporting Server User Interface with GVP

The Reporting Server User Interface (RPTUI) is installed when Genesys Administrator is installed,
however, you can customize your environment by using the default Application object (or
Configuration Server object) to configure port numbers, authentication, and HTTP settings.

In addition, you must create a connection to Reporting Server in the default Application object to
ensure that the RPTUI functions properly. The RPTUI discovers the Reporting Server host based on
this connection. Furthermore, the RPTUI reads and enforces the data reporting limits that are
configured in the Reporting Server Application object (in the reporting section).
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Finally, you must configure the Reporting Server logging and messaging parameters so that the
monitoring and reporting functionality perform as intended.

Tip
During the installation of the Reporting Server, the RPTUI and the logging and
messaging parameters are configured with default values. Therefore, unless your
environment is better served by manually changing the configuration, the only
requirement is to create the connection to Reporting Server in the default Application
object. See Procedure: Creating a Connection to a Server.

Procedure: Configuring the Reporting Server User Interfaces
Configure the default Application object to ensure that the Reporting Server user interfaces are
exposed and to create the connection to the Reporting Server.

1. Verify that:
• Genesys Administrator is installed and fully functional. See the Framework 8.1 Deployment Guide.
• All of the GVP components are installed and started. See Procedure: Using the Deployment Wizard

to Install GVP.

2. Log in to Genesys Administrator.
3. On the Provisioning tab, select Environment > Applications.
4. Click the default Application object.
5. In the Connections section, click Add.

The Connection Info dialog box appears.
6. In the Server field, click the Browse icon.
7. Select the Reporting Server to which you want to create a connection.
8. Click OK.

The Reporting Server you selected appears in the Connection section.
9. On the Options tab, select GVP Reporting from the View drop-down list.

The Options list is filtered, and all of the rptui section options appear.

Tip
If you do not see GVP Reporting, select Show options in groups from the View drop-down list. The list changes,
and GVP Reporting is available for selection.

10. Retain or modify the values for the options in the rptui section, as shown in the table below.
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Table: default Application Object Options Tab
Option Value

enablehttps Retain the default value, false.

httpport Retain the default port value, 8080, or enter a
port number from 1030 to 65535.

httptimeout Retain the timeout value, 30, or enter any value
greater than 0.

username
Enter a user name to enable the web server for
authentication. (Must match the password that is
configured in the Reporting Server Application.)

password
Enter a password. (Must match the password that
is configured in the Reporting Server
Application.)

tzoffset
Retain the default time zone offset value, -08:00,
or enter a value in the format shh:mm, where s
is either a plus (+) or minus (-), hh represents
hours, and mm represents minutes.

dsthours
Retain the default value 01:00, or enter a value
in the format shh;mm, where s is either a plus
(+) or minus sign (-), hh represents hour, and mm
represents minutes.

localtimeformat
Retain the default value true to display the
datetime fields in local time format, or enter
false to display the datetime fields in Universal
Time Coordinated (UTC).

Tip
Click on any option on the Options tab for a detailed description and the default value.

11. Save the configuration.
12. In the default Application object, create a connection to the Reporting Server. See Procedure: Creating a

Connection to a Server.
13. Create a database for the Reporting Server. See Reporting Server Database.

Configuring the Reporting Server Locale

If the Reporting Server is installed on a host that is configured with a locale other than English
(default), you must complete the procedure in this section to achieve full functionality of the
Reporting Server.
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Procedure: Configuring the Reporting Server Locale
Configure the Reporting Server with a locale that is not the default (English).

1. In the Reporting Server installation directory, locate the JavaServerStarter.ini file.
2. In the [JavaArgs] section, add the line Duser.language=en, for example:

[JavaArgs]
-Xmx1536M
-Duser.language=en

3. Open the Java Control Panel and on the Java tab, click View.
4. On the User tab, in the Runtime Parameters field, change the language setting.

This configuration affects all JVM default locales.
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