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Deploying ICON
This section explains how to deploy as many instances of Interaction Concentrator as you need on
either a UNIX or a Windows operating system.

Important
Interaction Concentrator supports silent installation on Windows and Unix platforms.
Also known as a silent setup, it enables you to install Interaction Concentrator without
having to monitor the setup or provide input via dialog boxes or the command line.
For instructions, see Silent Setup in the Framework 8.1 Deployment Guide.

Environment Assumptions
The instructions in this section assume that you are creating new Application objects under the
Environment folder, in either a single-tenant or multi-tenant configuration environment. To create
Application objects under a particular Tenant folder in a multi-tenant configuration environment,
replace the word Environment with the name of your Tenant folder in the configuration instructions.

To deploy the ICON server, perform the following procedures:

1. Import the Application Template
2. Create an ICON Application Object
3. Configure the General tab
4. Configure the Server Info tab
5. Configure the Start Info tab
6. Configure the Options tab
7. Configure the Tenants tab
8. Configure the Connections tab
9. Perform the Installation

Import the Application Template

Before you can configure an Application object for Interaction Concentrator, you must import its
Application template. The Application template provides a majority of the configuration options,
as well as the default values for them. You can use this Application template to create as many
Application objects of the same type as you need.
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Important
For an explanation of how to use Genesys Administrator Extension to import the
Application template and to create a new Application object, see the Genesys
Administrator Extension Help file, which is directly available from Genesys
Administrator Extension user interface, as well as from the link given here.

1. Open the Configuration Manager main window in Genesys Administrator Extension.
2. Select the Environment > Application Templates folder.
3. From the File menu, select Import Application Template.
4. In the Look In box, click the down arrow.
5. Locate the Interaction Concentrator 8.1 product CD, and open the TEMPLATES folder.
6. Select the template file for Interaction Concentrator; it is called Interaction_Concentrator_81x.apd.
7. Click Open to open the Properties dialog box for the template.
8. Make any changes that you require.
9. Click OK to save the template and close the Properties dialog box.

The next step is to configure an Interaction Concentrator Application object.

Create an ICON Application Object

After you import the application template, you can create and configure an Application object for your
Interaction Concentrator by using Configuration Manager.

1. Open the Configuration Manager main window.
2. Select the Environment > Applications folder.
3. From the File menu, select New > Application.
4. From the available application templates in the Browse dialog box, select the template that you

imported for Interaction Concentrator.
5. On each of the Application tabs, enter the settings appropriate for your environment, as explained in

detail in the section that follow.
6. Click OK to save your changes, then close the Properties dialog box.

Configure the General tab

In the Properties dialog box, click the General tab, and then enter a name for this application.
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Tip
The application template provides information about the application type and version.
Interaction Concentrator uses the Call Concentrator application type for its
Application object in the Configuration Layer.

Configure the Server Info tab

Click the Server Info tab, and then specify the following properties:

• Host—Enter the name or IP address of the computer on which you want to install and/or run this server.
• Communication Port—Enter a numeric value for a port that is not used by another application. Valid

values are in the range of 1–65,535. ICON uses this value as the default listening port for the web
interface connection.

Important
In IPv6 deployments, you cannot set the IP address of the host—only IPv4 addresses
can be set for the host. Therefore, enter the name of the host instead.

Configure the Start Info tab

Tip
The properties you define here are updated automatically during the installation
procedure.

Click the Start Info tab, and then specify the following properties:

• Working Directory—Enter the full path to the directory from which the application starts.
• Command Line—Enter the command line that is used to start the application.
• Command Line Arguments—Enter any additional command-line parameters that are used to start the

application. For information about command-line parameters, see Command-Line Parameters on the
Starting and Stopping page.
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Configure the Options tab

Click the Options tab, and then specify or change the values of the configuration options, as suitable
for your deployment.

• For information about specific configuration requirements to enable ICON to capture and store various
types of data (such as voice, multimedia, Outbound, and so on), see Special Configuration
Requirements.

• For information about the entire set of ICON configuration options, see the Options Reference.

Role Option

• If you have already deployed another ICON instance that writes to the same IDB, make sure that only
one of the ICON applications is configured to store configuration data and the history of configuration
changes. For all other instances, deactivate the configuration data storage by configuring one of the
following values for the role option in the [callconcentrator] section:
• Explicitly specify one or more values other than cfg.
• Exclude the cfg value by using the tilde symbol (~) (that is, set the role option to ~cfg).

• For more information about the role option, see description on the role configuration option and in the
video below. For more information about role assignments and restrictions for the cfg role, see
"Recommended Role Assignments" on the ICON Roles page.

Link to video

Log Options

• Configure both ICON-specific log options and common log options in the log-related configuration
sections. For option descriptions, see the log Section of the Interaction Concentrator Options Reference
and the Framework Configuration Options Reference Manual.

Important
If the Interaction Concentrator working directory differs from the directory where the
application is installed, configure an option named messagefile in the [log] section.
As the value of this option, specify the full path to the application-specific log
messages file (icon.lms). Otherwise, ICON will be unable to generate its specific log
events.

Running Multiple ICON Applications from the Same Directory
You can run multiple ICON Applications from the same directory using the same executable. To do so,
each ICON Application should have a different value for the three following options: pq-dbname,
cfg-dbname, and agent-pstorage-name. If the ICON Applications are configured to write log data to
a file or files, these filenames should also be different.
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HTTP Listener

Important
Support for use of the HTTP Listener to monitor and report on Interaction Concentrator
performance has been discontinued in release 8.1.512.08 and higher.

• Configure an HTTP listener by creating a [listeners] section and specifying the appropriate option. For
option descriptions, see the listeners Section of the Interaction Concentrator Options Reference.

Configure the Tenants tab

Tip
The Tenants tab is displayed only in a multi-tenant environment.

• Click the Tenants tab, and then click Add to add all tenants that this ICON application will serve. It is
important to add all tenants from whose resources (switches, DNs, agents, and, if applicable, Outbound
Contact objects) ICON will collect data.

• If this ICON instance is required to monitor the objects that are configured under the Environment
folder, assign the Environment tenant among the other tenants.

Configure the Connections tab

Click the Connections tab, and then add the following connections:

• T-Server
• Interaction Server
• Outbound Contact Server
• Configuration Server
• Message Server
• DAP
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Important
If you make any dynamic changes to the Interaction Server or Outbound Contact
Server applications listed on the Interaction Concentrator Application Connections
tab, restart ICON to ensure that the changes take effect.

ADDP

For any connections between the ICON instance and its data sources, you can configure the
connection to use Advanced Disconnect Detection Protocol (ADDP). To enable ADDP for a connection,
specify addp as the Connection Protocol when you configure the connection between the
Applications, and set the values for the Local Timeout, Remote Timeout, and Trace Mode
properties. For more information, see see Advanced Disconnect Detection Protocol in the
Management Framework Deployment Guide.

T-Server

If this ICON instance is configured to process CTI-related data, add a connection to T-Server. Note the
following special requirements:

• If you have a simple multi-site topology that includes one ICON instance and multiple T-Servers, add a
connection to each T-Server. Each T-Server Application object must have a Switch object assigned to
it.

• In a deployment with Network T-Server, add a connection to the Network T-Server. The Network T-Server
Application object must have a network Switch object assigned to it.

• In a deployment in which the Network T-Servers function in load-balancing mode, add a connection to
each Network T-Server. For more information, see "Multiple Network T-Servers per Switch (Load-
Balancing Configuration)" on the Supported Deployment Scenarios page.

Important
Starting in release 8.1.4, if host or port information changes for any T-Server listed on
the Connections tab, Interaction Concentrator dynamically reconnects using the new
connection parameters. While ICON disconnects from the prior host/port and connects
to the new one, there might be a brief gap in data received from the T-Server.
In releases 8.1.0 and 8.1.1, you must restart ICON for updates to listed T-Servers to
take effect.

Interaction Server

If this ICON instance is configured to process multimedia interactions reported by Interaction Server,
add a connection to Interaction Server.

• Restart ICON after adding or removing Interaction Server applications from the ICON Connections tab.
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Important
If you are installing ICON in a deployment that will use Genesys Info Mart to report on
both voice and multimedia interactions, Genesys strongly recommends that you
create separate ICON instances and separate IDBs for the voice and multimedia data.
See Do you need separate IDBs for voice and multimedia data? for more information.

Outbound Contact Server

If this ICON instance is configured to process outbound data in an environment with Genesys
Outbound Contact, add a connection to one or more Outbound Contact Server Applications. See
Integrating with Outbound Contact in the Interaction Concentrator User's Guide for in-depth
configuration information.

• Restart ICON after adding or removing Outbound Contact Server applications from the ICON
Connections tab.

Configuration Server

Add a connection to the Configuration Server application (named confserv). You can enable ADDP
for connections to Configuration Server in the same way as for other connections.

Genesys recommends that, at a minimum, you add a connection to Configuration Server in the ICON
instance that is configured to process configuration data (cfg role). However, to minimize the number
of unidentified call segments that might occur as a result of missing configuration data, Genesys
recommends that you configure an ADDP connection to Configuration Server in each ICON
Application in your deployment, regardless of the role of the ICON Application.

Message Server

If you installed the Management Layer, add a connection to Message Server, in order to provide
alarm signaling and centralized logging capabilities. You can add a connection to Message Server for
all or a set of Application objects after you configure them.

To launch a wizard that configures connections for multiple Application objects, select two or more
Application objects, right-click, and then select Manage Connections from the shortcut menu. For
more information, see the Framework Configuration Manager Help.

DAP

After you configure one or more DAP Application objects, add any DAP Application objects
through which this ICON instance will access IDBs to the ICON Connections tab.

High Availability

In high availability (HA) environments using primary and backup pairs of servers, the servers listed on
the Connections tab are handled as primary. To specify the backup servers for any primary servers,
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open the Application object for the primary server and add the backup server on the primary
server’s Server Info tab.

Perform the Installation

You can install ICON on either a Windows or a Unix-based system.

Prerequisites

• You have created and configured an Interaction Concentrator Application object in the interface you
use for configuration, as described above.

Installing on Windows
To install, perform the following steps:

1. Insert the Interaction Concentrator CD into the CD-ROM drive of the machine on which you want to
install Interaction Concentrator; or, download the Interaction Concentrator IP to the desired location on
the target machine.

2. Navigate to, and open, the .../windows directory.
3. Double-click the setup.exe file, and then follow the directions in the installation wizard.

Installing on UNIX
To install, perform the following steps:

1. Insert the Interaction Concentrator CD into the CD-ROM drive of the machine on which you want to
install Interaction Concentrator; or, download the Interaction Concentrator IP to the desired location on
the target machine.

2. Locate the correct installation directory for your platform — for example, .../solaris.
3. Save the contents of this directory to a local folder.
4. Locate and run the install.sh shell script. Enter requested information when you are prompted to do so.
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