About This File

Reporting 7.6 Data Modeling Assistant Help

Copyright © 1998–2010 Genesys Telecommunications Laboratories, Inc. All rights reserved.
rt_dma-help_05-2010_v7.6.001.00

The information contained herein is proprietary and confidential and cannot be disclosed or duplicated without the prior written consent of Genesys Telecommunications Laboratories, Inc.

About Genesys

Genesys Telecommunications Laboratories, Inc., a subsidiary of Alcatel-Lucent, is 100% focused on software for call centers. Genesys recognizes that better interactions drive better business and build company reputations. Customer service solutions from Genesys deliver on this promise for Global 2000 enterprises, government organizations, and telecommunications service providers across 80 countries, directing more than 100 million customer interactions every day. Sophisticated routing and reporting across voice, e-mail, and Web channels ensure that customers are quickly connected to the best available resource—the first time. Genesys offers solutions for customer service, help desks, order desks, collections, outbound telesales and service, and workforce management. Visit www.genesyslab.com for more information.

Each product has its own documentation for online viewing on the Genesys Technical Support website. You can also find product documentation on the Genesys Documentation Library DVD (all non-developer documentation for releases 7.0 through 8.0), or the Genesys Developer Documentation CD (developer documentation for releases 7.0 through 8.0). The Documentation Library DVD and Developer Documentation CD are available from Genesys upon request. For more information, contact your sales representative.

Notice

Although reasonable effort is made to ensure that the information in this document is complete and accurate at the time of release, Genesys Telecommunications Laboratories, Inc., cannot assume responsibility for any existing errors. Changes and/or corrections to the information contained in this document may be incorporated in future versions.

Your Responsibility for Your System’s Security

You are responsible for the security of your system. Product administration to prevent unauthorized use is your responsibility. Your system administrator should read all documents provided with this product to fully understand the features available that reduce your risk of incurring charges for unlicensed use of Genesys products.

Trademarks

Genesys and the Genesys logo are registered trademarks of Genesys Telecommunications Laboratories, Inc., in the USA and/or other countries. All other trademarks and trade names referred to in this document are the property of other companies.

Technical Support from VARs

If you have purchased this software from a value-added reseller (VAR), please contact the VAR for technical support.

Technical Support from Genesys

If you have purchased support directly from Genesys, please contact Genesys Technical Support at the following regional numbers:

North America and Latin America | 888-369-5555 (toll free) or 506-674-6767 | support@genesyslab.com
Europe, Middle East, and Africa | +44-(0)-1276-45-7002 | support@genesyslab.co.uk
Asia Pacific | +61-7-3368-6868 | support@genesyslab.com.au
Malaysia | 1-800-814-472 or +61-7-3368-6868 | support@genesyslab.com.au
India | 000-800-100-7136 (toll-free) or +91-(022)-3918-0537 | support@genesyslab.com.au
Japan | +81-3-6361-8950 | support@genesyslab.co.jp

Before contacting technical support, please refer to the Genesys Technical Support Guide for complete contact information and procedures.

Ordering Information

For complete information on ordering Genesys products, please see the Genesys Licensing Guide.

Released by

Genesys Telecommunications Laboratories, Inc.
www.genesyslab.com


Overview

Data Modeling Assistant, or DMA for short, is the GUI component of the Data Collection Services enabling viewing, addition of, and removal of metadata from the Operational Data Storage (ODS)—the temporary repository for historical data. Using report layouts, DMA defines both the statistics to be requested from Stat Server and their time profile, which specifies how often statistics are sent to ODS. Data Sourcer issues the requests and then sends the data to ODS for temporary storage until ETL Runtime transforms and aggregates the data into the Data Mart. As a report designer, you create report layouts in DMA using the provided layout templates from your Genesys solution or from custom templates that you create.

DMA includes the following new features:

  • The ability to Add New Statistics to layout templates and report layouts, even if the data transformation for these layouts has already been started.

  • The ability to Delete Statistics from layout templates and report layouts, with some limitations. (You cannot delete out-of-box statistics from Genesys Pre-defined templates, and deleted statistics still remain in the historical database)

This Help file provides information on the following DMA topics:

  • DMA User Interface

  • Importing and Exporting Layout Templates

  • Creating New Layout Templates

  • Managing Report Layouts

  • Modifying Templates and Layouts

  • Managing Statistical Parameters

  • Synchronizing Statistical Parameters

  • Statistic Wizard

  • DMA Log File

DMA 7.6 is part of the Reporting 8.0 release. Refer to the Reporting 8.0 Deployment Guide for information on how DMA relates to other Reporting components.


Printing This Help File

You can print a single topic (page) or all the topics (pages) within a single book. You cannot, however, print the entire Help file at once.

On the Table of Contents, select a topic or book and then do the following:

  1. Select the Print button.

  2. In the Print Topics dialog box, select either:

    • Print the selected topic

    • Print the selected heading and all subtopics

  3. Select OK.


User Interface

DMA User Interface

User Interface Overview

In the DMA main window, a document window is created for every open connection to an ODS. This document window is named after its corresponding Data Sourcer application. A document window may be maximized, minimized, resized, and repositioned within the main window using standard graphical user interface commands.

Click any of the hot spots on the image below to view information on that part of the DMA user interface.

Once connected to ODS, DMA reads and displays information about existing layout templates and report layouts for all tenants with proper permissions. These components are displayed in a three-level tree view in the middle pane of the image above. If new tenants are added to the Configuration Server while DMA is active, the document window must be closed and reopened to display information about them.


DMA Menus

DMA User Interface > DMA Menus

DMA Menu Overview

The DMA menu bar is comprised of the five menus shown in the image below. Click any of the menus in this image to view a brief description of each DMA menu item.

You can access these menus and corresponding menu items from the DMA main window or by using Keyboard Shortcuts.


DMA User Interface > DMA Menus

Keyboard Shortcuts

In addition to Microsoft Windows standard keyboard shortcuts (involving pressing the ALT key and then the highlighted letter of a menu or menu item), you can use DMA hot keys to perform work without a mouse. Hot keys are displayed to the right of a menu item when a menu is open and when a hot key is available.

DMA provides two hot keys:

CTRL+O | Opens the Select Data Sourcer Application dialog box—this is the same action as selecting Open from the File menu.
Delete | Marks the selected layout template, report layout, or statistical parameter as deleted in ODS—this is the same action as selecting Delete from the Edit menu.
F1 | Invokes this Help file.


DMA User Interface > DMA Menus

File Menu

The File menu offers the following menu items, each of which is described below:

Open

Opens the Select Data Sourcer Application dialog box, which opens a connection to ODS. Selecting this menu item performs the same action as selecting Open from the Toolbar.

Close

Closes the current connection to ODS and is only available if at least one ODS connection is open. All other connections remain active.

Import

Imports a layout template from a specified location. Selecting this menu item performs the same action as selecting Import from the toolbar. DMA imports layout templates saved in XML format. See Importing Templates for more information.

Export

Exports the selected layout template using XML format to a file in the designated location. Selecting this menu item performs the same action as selecting Export from the Toolbar. See Exporting Templates for more information.

Synchronize

Synchronizes Stat Server's (and backup Stat Server's) statistical parameters with those stored in ODS. Selecting this menu item performs the same action as selecting Synchronize from the Toolbar.

Exit

Closes all connections to ODS and exits DMA.


DMA User Interface > DMA Menus

Edit Menu

The Edit menu offers the following menu items:

(A similar Context Menu appears when you right-click within any of DMA's panes.)

Each menu item is described below.

New

Selecting New when a base-level category is selected in the folder list invokes the:

  • Template Creation Wizard if you select the Layout Templates category in the folder list.

  • Layout Creation Wizard if you select a Tenant category in the folder list.

  • Filter Constructor Dialog Box if you select the Filters category in the folder list.

  • StatType Constructor Dialog Box if you select the Statistical Types category in the folder list.

  • Time Profile Constructor Dialog Box if you select the Time Profile category in the folder list.

  • Time Range Constructor Dialog Box if you select the Time Range category in the folder list.

Selecting New after you select any statistic in the right pane of a custom layout template invokes the Statistic Wizard.

Selecting this menu item performs the same action as selecting New from the Toolbar.

Delete

Marks the selected layout template, report layout, or statistical parameter as deleted in ODS. Only available if a successor category is selected in the Folder List.

Statistics in custom templates are also available for deletion if selected in the right pane.

Activate/Deactivate

This toggle is only available if a report layout is selected in the Folder List. Selecting this menu item performs the same action as selecting Activate/Deactivate from the toolbar.

DMA notifies Data Sourcer when a report layout is deactivated or activated. This notification sets in motion the sequence of events that stop collection of statistical data for the report layout. When Data Sourcer updates ODS and sends requests to Stat Server (or backup Stat Server) to open statistics, report activation results. DMA deactivates a report layout by noting the current date and time in the STOP_TIME column of the OL_SCHEDULE table for the appropriate report layout. DMA activates a report layout by changing this value to NULL.

Refer also to the Activating/Deactivating Report Layouts topic in this help file and the chapter about configuration options in the Reporting 7.6 Data Sourcer User's Guide for more information. The latter reference introduces the activate-new-layouts configuration option.


DMA User Interface > DMA Menus

View Menu

The View menu offers the following menu items:

Brief descriptions for each menu item follow.

DMA Bar

A toggle that displays or hides the DMA bar in the leftmost pane of the DMA application. This bar provides shortcuts to layout templates, report layouts, and statistical parameters. Performs the same action as selecting DMA Bar from the toolbar.

Folder List

A toggle that displays or hides the Folder List in either the center pane (if the DMA Bar is displayed) or the left pane of the DMA application (if the DMA Bar is not displayed). Performs the same action as selecting Folder List from the toolbar.

Toolbar

A toggle that displays or hides the toolbar under the DMA menu bar.

Status Bar

A toggle that displays or hides the status bar along the bottom edge of the DMA window.

Options

A command to display the Options dialog box where you can set the View and Thresholds options of your DMA application.

View Tab

Mark the Enable colors check box to apply background colors to DMA’s window panes and list views. In the Tree view color frame, click the color swatch to choose a color other than the default beige. In the List view colors frame, click one or both of the color swatches to change the color of rows in the application’s various list views. Selected colors display in every other row of all list views. Click Default to reset the color back to the default beige.

When the Enable colors check box is cleared, the application’s background color is white.

Thresholds Tab

Defines High level and Critical level threshold limits for the number of statistical requests demanded of Stat Server (or backup Stat Server). DMA displays a yellow or red circle in the Status Bar to denote when it has exceeded these limits. When below either threshold, DMA displays a green circle in the status bar. The High level default is 100,000 statistical requests; the Critical level default is 200,000 requests.

To ensure that the critical-level threshold exceeds the high-level threshold, DMA validates the values you specify when you click the OK or Apply buttons.


DMA User Interface > DMA Menus

Window Menu

The Window menu offers the following menu items:

Brief menu item descriptions follow:

Cascade

Arranges all open, nonminimized document windows in a diagonal overlapping sequence with the current window on top.

Tile

Arranges all open, nonminimized document windows so that their edges meet but do not overlap.

Arrange Icons

Arranges the icons of all minimized open database windows at the bottom of the main window

Open Data Sourcer Application

Opens the specified Data Sourcer application. A check mark precedes the name of the current application.


DMA User Interface > DMA Menus

Help Menu

The Help menu offers the following menu items:

Help Topics

Opens this help file.

About Data Modeling Assistant

Displays version number and copyright information about the active DMA application. Selecting this menu item performs the same action as selecting About from the toolbar.


DMA User Interface > DMA Menus

Context Menus

The Context menu is the floating drop-down list that displays when you right-click elements from the DMA Bar, Folder List or Right Pane. All commands from the Edit menu are accessible from the Context menu.

When invoked over a layout template, the Context menu offers two additional commands—Import and Export—which are unavailable from the Edit menu. You can use these commands to back up the layout templates in the current ODS or to transfer layout templates to another ODS. DMA uses XML format to store exported and imported data.

When invoked over a report layout, the Context Menu offers the same commands as are available from the Edit menu. The third menu item reads either Activate or Deactivate depending on whether the report layout from which you invoked the context menu is inactive or active, respectively.

When invoked over the DMA Bar, the Context Menu offers two menu items to control the display of the shortcut icons in this bar: Large Icon and Small Icon. These commands are not available from the Edit menu.

When invoked over a statistical parameter in the right pane, the Context Menu offers three additional commands which are not available from the Edit menu: Properties, New From This, and Dependent Objects. The first two open the Stat Type Constructor dialog box where you can create, modify, or view a stat type's definition. The last opens the Dependent Objects Tree where you can view the complete set of statistics that employ the parameter.

DMA grays any command which is not applicable.


DMA User Interface

DMA Bar

The DMA Bar (shown in the left pane of the document window) is displayed in two sections: Templates and Layouts and Statistical Parameters. When a shortcut is selected from either section, the right pane displays a list view of all successor categories along with additional information. This information varies depending on which shortcut is selected.

Click any of the shortcuts in the images below to view right-pane contents for that shortcut.


DMA User Interface

Toolbar

When displayed, the DMA Toolbar lies under the DMA Menu Bar and contains shortcuts to commonly used commands. Click any of the buttons in the following image to read a brief description.

To display or hide the toolbar, select the Toolbar toggle from the View menu.

You can reposition the toolbar, as you can with many other Microsoft Windows-based programs, along the left side of the DMA main frame. Or, you can “float” it over a designated area by left-clicking and dragging it. Hover your cursor over a button to see its description in a tool tip as illustrated below:


DMA User Interface

Status Bar

When displayed, the status bar appears along the bottom edge of the main DMA window and displays high-level information about application status. To display or hide the status bar, select the Status Bar toggle from the View menu.

Note: The number of requests for a selected but inactive report layout reads 0. You must activate the report layout to see how many Stat Server (or backup Stat Server) requests will be made by a selected report layout.

Application Status

When displayed, the application status area shows one of two states:

  • StatServer Application is attached

  • StatServer Application is detached

You can operate DMA when Stat Server (or backup Stat Server) is detached from the underlying Data Sourcer application; however, you will be unable to perform certain actions requiring Stat Server (or backup Stat Server) interaction.

Threshold Status

The following drop-down list appears when you click the Threshold Status circle in the status bar:

Selecting Thresholds from this menu opens the Thresholds tab of the Options dialog box where you can define two limits to indicate when the number of statistical requests Data Sourcer makes against Stat Server (or backup Stat Server) has been reached.

Selecting Refresh from this menu updates the number of statistics requested by the selected report layout. DMA automatically updates this number whenever you add or remove a statistic from a report layout or whenever you add, remove, activate, or deactivate a report layout. Selecting this menu item performs the same action as selecting Refresh from the toolbar.


DMA User Interface

Folder List

When selected, the Folder List appears in the left pane when the DMA Bar is not displayed. When the DMA Bar is displayed, the folder list appears in the middle pane.

When a base-level category is selected in the folder list, the right pane displays a list of all successors along with additional information. This information varies depending on which base-level category is selected.

Click any of the elements in the image below to view right-pane contents for the area selected.

In a single-tenant environment, the base level of the folder list contains three categories:

  • Layout Templates—its successors are layout templates residing within ODS.

  • Report Layouts—“Resources” is its only successor; report layouts ascribed to the tenant appear under this level.

  • Statistical Parameters—its successors are filters, statistical types, time profiles, and time ranges.

In a multi-tenant environment, the report layouts base level contains a folder for:

  • The Environment—successors are tenant report layouts as well as other report layouts and other tenants.

  • Each Tenant—successors include report layouts ascribed to that tenant.

Note: DMA shows only those tenants that were assigned to the selected Data Sourcer application.

See also View Menu: Folder List.


Right Pane

DMA User Interface > Right Pane

Right-Pane Overview

The right pane of a DMA document window displays information about items selected in the Folder List. Click any of the categories in the image below to view right-pane contents for that category.


DMA User Interface > Right Pane

Right-Pane Contents for Layout Templates

DMA polls ODS for a listing of layout templates defined therein. When you select Layout Templates in the Folder List, the right pane of the DMA window displays a list of layout templates with the following columns:

Brief descriptions for each column follow.

Name Field

Alphanumeric text representing the name of the layout template.

Custom Field

Indicates whether the template is custom or canned (predefined).

Solution Type Field

Text depicting one of the following solution types:

  • Enterprise Routing

  • Network Routing

  • Outbound Dialing

  • Internet Contact Center

  • Multimedia

You can assign and deploy a specific layout template for only one solution.

Object Type Field

The type of objects for which report layouts, based on this layout template, are to collect statistics.

Time Profile Field

The time profile for collecting statistics used by report layouts based on this layout template.

Description Field

Text description of the layout template.


Right Pane Contents for Report Layouts

DMA User Interface > Right Pane

Right-Pane Contents for Report Layouts

DMA polls ODS for a listing of report layouts defined therein. In a multi-tenant environment, when you select Report Layouts in the Folder List, the right pane displays an Environment folder and folders for each tenant along with a brief description. When you select a Tenant folder in the folder list, the right pane displays a list view of the following columns:

In a single-tenant environment, selecting the Report Layouts base-level category from the folder list directly displays a list view of all report layouts for the single tenant in the right pane with the column heads shown above.

If you double-click a report layout from the right pane, the pane displays information about that particular report layout. See Right-Pane Contents for Selected Report Layouts for more information.

Brief descriptions for each column follow.

Name Field

Alphanumeric text representing the name of the report layout.

Activated Field

Indicates whether the report layout has been activated for collecting statistics.

Object Type Field

The type of objects for which the report layout collects statistics.

Template Name Field

Alphanumeric text representing the name of the layout template from which the report layout was created. This field is blank if a layout template was not used to create the report layout.

Time Profile Field

The time profile that the report layout uses for collecting statistics.

Description Field

Text description of the report layout.


DMA User Interface > Right Pane

Right-Pane Contents for Statistical Parameters

When you select Statistical Parameters in the Folder List, the right pane displays four successor categories (Filters, Statistical Types, Time Profiles, Time Ranges) and a brief description. When you select a successor category in the folder list, the right pane displays a list view of that category’s elements along with additional information. This information varies depending on which successor category you selected.

Click any of the elements in the image below to view its right-pane contents.


DMA User Interface > Right Pane

Right-Pane Contents for Filters

DMA polls ODS for a listing of filters defined therein. When you select Filters in the Folder List, the right pane displays a list view with the following columns:

Column Descriptions

Name Field

Alphanumeric text representing the name of the filter.

Definition Field

The qualifying conditions specified to limit the attributes returned of a particular statistical type.

Description Field

Optional text description of the filter.

Menu Items of the Context Menu

You can right-click any filter to display a context menu with five commands:

  • New—Opens the Filter Constructor dialog box where you can define a new filter.

  • New From This—Opens the Filter Constructor dialog box in edit mode with the definition of the selected filter displayed.

  • Properties—Opens the Filter Constructor dialog box with the definition of the selected filter displayed.

  • Delete —Deletes the selected filter, upon confirmation, if connected to Configuration Server.

  • Dependent Objects—Opens the Dependent Objects Tree.


DMA User Interface > Right Pane

Right-Pane Contents for Statistical Types

DMA polls ODS for all statistical types defined therein. When you select Statistical Types in the Folder List, the right pane displays a list view with the following columns:

Column Descriptions

Name Field

Alphanumeric text representing the name of the statistic.

Category Field

Alphanumeric text representing the statistic’s category.

Java Field

Indicates that the selected statistical type is both unknown to Stat Server (or backup Stat Server) and created using the Java language.

Historical Field

Indicates whether or not the selected statistical type collects historical statistics.

Time Range Applicable Field

Indicates whether or not the selected statistical type has a time range defined.

Object Types Field

Lists all object types that apply to the statistical type's definition.

Description Field

Text description of the statistical type.

Menu Items of the Context Menu

You can right-click any stat type to display a context menu with five commands:

  • New—Opens the StatType Constructor dialog box where you can define a new stattype.

  • New From This—Opens the StatType Constructor dialog box in edit mode with the definition of the selected stattype displayed.

  • Properties—Opens the StatType Constructor dialog box with the definition of the selected stattype displayed.

  • Delete —Deletes the selected stattype, upon confirmation, if connected to Configuration Server.

  • Dependent Objects—Opens the Dependent Objects Tree.


DMA User Interface > Right Pane

Right-Pane Contents for Time Profiles

DMA polls ODS for all time profiles defined therein. When you select Time Profiles from the Folder List, the right pane displays a list with the following columns:

Column Descriptions

Name Field

Alphanumeric text representing the name of the time profile.

Definition Field

The formula, consisting of relative start time and time increment, used to define the time profile. The image above, for example, illustrates three growing interval time profiles. Refer to the section about TimeProfiles in the Framework 8.0 Stat Server User's Guide for more information about defining time profiles.

Description Field

Optional text description of the time profile.

Menu Items of the Context Menu

You can right-click any filter to display a context menu with five commands:

  • New—Opens the Time Profile Constructor dialog box where you can define a new time profile.

  • New From This—Opens the Time Profile Constructor dialog box in edit mode with the definition of the selected time profile displayed.

  • Properties—Opens the Time Profile Constructor dialog box with the definition of the selected time profile displayed.

  • Delete —Deletes the selected time profile, upon confirmation, if connected to Configuration Server.

  • Dependent Objects—Opens the Dependent Objects Tree.


DMA User Interface > Right Pane

Right-Pane Contents for Time Ranges

DMA polls ODS for all time ranges defined therein. When you select Time Ranges in the Folder List, the right pane displays a list view with the following columns:

Column Descriptions

Name Field

Alphanumeric text representing the name of the time range.

Definition Field

The time interval in seconds for which a statistic using this time range collects data. The image above, for example, illustrates two time ranges. Refer to the section about TimeRanges in the Framework 8.0 Stat Server User's Guide for more information about time ranges.

Description Field

Optional text description of the time range.

Menu Items of the Context Menu

You can right-click any filter to display a context menu with five commands:

  • New—Opens the Time Range Constructor dialog box where you can define a new time range.

  • New From This—Opens the Time Range Constructor dialog box in edit mode with the definition of the selected time range displayed.

  • Properties—Opens the Time Range Constructor dialog box with the definition of the selected time range displayed.

  • Delete —Deletes the selected time range, upon confirmation, if connected to Configuration Server.

  • Dependent Objects—Opens the Dependent Objects Tree.


Right-Pane Contents for Selected Individual Templates

DMA User Interface > Right Pane > Right-Pane Contents for Selected Individual Templates

Right-Pane Contents for Selected Individual Templates Overview

When you select a template category in the Folder List, the right pane displays information about the template. This information is divided into two parts:

  • General Description (upper part)

  • Statistics List View (lower part)


DMA User Interface > Right Pane > Right-Pane Contents for Selected Individual Templates

General Description

The upper portion of the right pane provides a general description of the selected layout template. You can edit the Layout Name, Time Profile, and Description text fields. (Double-click them to edit.) You can also edit the Active check box using a single mouse click. All other fields are read only.

Brief field descriptions follow.

Template Name Field

Alphanumeric text ten characters in length representing the name of the template.

Layout Name Field

The name assigned to all report layouts created for every new tenant on the basis of this template. Double-clicking this field displays a drop-down list where the Layout Name can be edited.

Object Type Field

The type of objects for which data is collected by report layouts.

Time Profile Field

The name of the time profile used for report layouts created on the basis of the template for every new tenant. Double-clicking this field displays a window where you can select a different time profile.

Description Field

Text description of the report layout. Double-clicking this field displays a window where you can edit the description.

Solution Type Field

Text depicting one of the following solution types:

  • Enterprise Routing

  • Network Routing

  • Outbound Dialing

  • Internet Contact Center

  • Multimedia

Active

Indicates whether Data Sourcer is to use this layout template for automatic report layout creation when a new tenant is created. Both this check box must be marked and the Data Sourcer activate-new-layouts configuration option must be set to true for automatic report layout creation to take place.

Custom

Indicates whether the template is custom or canned (predefined). Modification of canned templates is somewhat limited.


DMA User Interface > Right Pane > Right-Pane Contents for Selected Individual Templates

Statistics List View

The lower portion of the right pane for a selected layout template shows the Statistics tab with a list view of statistics to be collected. From here you can change the set of statistics in a layout template.

Brief column descriptions follow.

Column Name Field

The name of the statistic in ODS.

StatType Name Field

The statistical type on which the statistic is based.

Time Range Field

The calculated time range for the statistic if its category is TotalNumberInTimeRange or TotalTimeInTimeRange; otherwise, this field is empty.

Filter Field

The filter, if any, applied to the statistic.

Description Field

Text description of the statistic.


Changing the Set of Statistics in a Template

DMA User Interface > Right Pane > Right-Pane Contents for Selected Individual Templates

Changing the Set of Statistics in a Layout Template

Right-clicking a statistic from the Statistics list for custom layout templates displays the following Context Menu:

Properties

Invokes the Statistic Wizard where you can modify properties of statistics already in the template. You cannot, however, modify the column name.

Delete

Removes the selected statistic(s) from a template.

New

Invokes the Statistic Wizard so that you can create new statistics for the template. See Modifying Templates and Layouts for more information.

New From This

Copies the existing statistic and adds it to the layout template.

Note: These menu items are no longer grayed out for custom statistics from canned (Genesys Pre-defined) templates.


Right-Pane Contents for Selected Report Layouts

DMA User Interface > Right Pane > Right-Pane Contents for Selected Report Layouts

Right-Pane Contents for Selected Report Layouts Overview

When a specific report layout is selected in the Folder List, the right pane displays information about the report layout. This information is divided into four parts:

  • General Description

  • Statistics Tab

  • Objects Tab

  • Data Tab


General DescriptionRL

DMA User Interface > Right Pane > Right-Pane Contents for Selected Report Layouts

General Description

The upper portion of the right pane provides a general description of the selected report layout. From this area, you can only edit the Layout Name, Metagroup, and Description text fields. To edit them, double-click the field. All other fields are read-only.

Brief field descriptions follow.

Layout Name Field

Displays the name of the report layout as listed in the Folder List. Double-clicking this field opens a window where you can edit the report layout's name.

Object Type Field

Displays the object type for which the report layout collects statistics. A particular report layout collects data for one object type only. Once you specify object types, you cannot change them.

Metagroup Field

Displays the metagroup of objects to which the report layout applies. Double-clicking this field opens the Report Layout Object Editor where you can change the metagroup or select individual objects from it.

Template Name Field

Displays the template name from which the report layout was created. If the report layout was not created from a template, this field remains empty.

Created Field

Displays the date and time the report layout was created.

Description Field

Displays the report layout description. Double-clicking this field opens a window where you can edit the description.

Time Profile Field

Displays the name of the time profile used for requesting statistics for the report layout from Stat Server (or backup Stat Server).

Activated Field

Displays the date and time that collection was last resumed for the report layout.

Deactivated Field

Displays the date and time for which data collection was last suspended for the report layout. This field is empty if the report layout is active.

Note: Data Sourcer identifies a report layout as either activated or deactivated even if the report layout may have never been manually activated (as is the case with newly created report layouts). Data Sourcer collects statistics only for activated report layouts.


DMA User Interface > Right Pane > Right-Pane Contents for Selected Report Layouts

Statistics Tab

The lower portion of the right pane provides three information tabs for the report layout selected in the Folder List. The Statistics tab displays a list of statistics to be collected. For deactivated report layouts where ETL Runtime has not transformed data for the report layout, you can double-click a row to display a window where you can edit the selected statistic’s description and add, remove, or modify any custom statistic on a report layout. See Modifying Templates and Layouts for more information.

Click any of the columns or tabs on the image above to read a brief column description.

Column Name Field

The name of the statistic in ODS.

StatType Name Field

The statistical type on which the statistic is based.

Time Range Field

The calculated time range for the statistic if its category is TotalNumberInTimeRange or TotalTimeInTimeRange; otherwise, this field is empty.

Filter Field

The filter, if any, applied to the statistic.

Description Field

Text description of the statistic.


DMA User Interface > Right Pane > Right-Pane Contents for Selected Report Layouts

Objects Tab

The lower portion of the right pane provides three information tabs, Statistics, Objects and Data, for the report layout selected in the Folder List. The Objects tab lists either:

  • All objects currently belonging to the report layout’s metagroup.

  • A subset of objects individually selected from the report layout’s metagroup.

The list view changes depending on how you select objects—either by metagroup or individually—and on the report layout’s object type.

The example above shows the Objects list view for a Queue report layout where object selection is by metagroup. As objects are added to or deleted from the metagroup in the Configuration Manager, they automatically appear in (or disappear from) the list. The example below shows the Objects list view for an Agent report layout where objects are selected individually within the metagroup. Data Sourcer only collects data for those objects whose check boxes are marked.

Double-clicking any row opens the Report Layout Object Editor where you can change the metagroup of objects for the report layout or where you can select objects individually.

For agent report layouts only, you can reposition the First Name and Last Name columns by clicking either column name and dragging and dropping it to the beginning of the opposite column. This does not alter how Data Sourcer writes information to ODS but rather only affects the presentation of agent information in the DMA GUI.


DMA User Interface > Right Pane > Right-Pane Contents for Selected Report Layouts

Report Layout Object Editor

The Report Layout Object Editor is invoked when you double-click either:

  • A particular object from the Objects tab of a specific report layout.

  • The Metagroup field from the general description of the report layout.

The Report Layout Object Editor enables you to select the metagroup about which the report layout is to collect data. You can choose all objects belonging to the metagroup, as depicted in the following image:

Or you can select a subset, as this cutaway portrays:

The Tenants/Metagroups frame lists all tenants in the contact center environment containing objects of the type originally specified at the Common Info Dialog Box during report layout creation. This frame also lists the default metagroup to which those objects belong. You can double-click a tenant record in this frame to change metagroups.

The Object Type frame lists the individual objects comprising the selected metagroup. The Select All and Deselect All buttons below the frame apply to selections in this frame.


DMA User Interface > Right Pane > Right-Pane Contents for Selected Report Layouts

Data Tab

The lower portion of the right pane provides three information tabs, Statistics, Objects, and Data, for the Report Layout selected in the Folder List. The Data tab contains a calendar element, buttons, and a list view element. Click any of the elements in the image below to read a brief description.

Calendar Element

You can display the calendar element by clicking the down arrow to the right of the date field. You can also access calendar dates by pressing the Up or Down arrow keys directly over existing date values or by typing appropriate values over the date and year in the date field.

The calendar element allows you to select the date for the elementary data-fragment information to be displayed in the Data List View. You can change the month and year in the calendar’s blue title field in one of two fashions:

  • By clicking the left and right arrow buttons.

  • By clicking the month and/or year directly.

Clicking the month displays a drop-down list of the 12 months where you can select one. Clicking the year will reveal a combo box field where you can type a valid year or use the up and down arrows to advance/regress the year one year at a time. The days of the selected month are displayed in the calendar, and any of them can be selected.

The current date is marked with a red circle and spelled out in the footer of the calendar. A selected date is highlighted with reverse print against a dark-blue-filled oval and displayed in the date field above the calendar. This calendar shows March 13, 2007 as both the current date and the selected date.

Buttons

Navigational buttons lie to the right of the calendar.

The Present Date button makes today the selected date.

The Increment Date button makes the next day the selected date.

The Decrement Date button makes the previous day the selected date.

The Refresh Chunks button refreshes the data collected for the selected date and report layout. Though similar in appearance, the actions performed by clicking this button differ from those performed when the Refresh button in the Toolbar is pressed.

The Up button is activated when a row from the list view is double-clicked to display the respective statistical data for the time frame indicated. Click Up to return to the original list view.

List View Element

The list view element displays information on all elementary fragments for the selected date. Click any of the columns in the image below for a brief description.

Double-clicking any row of this list view displays yet another list view (pictured below) containing statistical data for that row.

Double-clicking the first row of this subsequent view restores the original list view. All remaining rows of this view correspond to objects currently belonging to the metagroup of the report layout. The remaining columns of this view correspond to statistics collected for the layout for this particular chunk interval.

Values that Stat Server (or backup Stat Server) reported as invalid are preceded by a tilde (~) in the list view.

Below are brief column descriptions for the Data Tab list view.

Id Field

The value of the LOG_ID column in the current record of the OL_CHUNK_LOG table in ODS.

Begin Time Field

The beginning of the time interval for which statistics are to be collected.

Update Time Field

The end of the interval for statistics that were computed for the current primitive fragment.

Table Name Field

The name of the ODS table where statistical values are stored for the current primitive fragment.

Receive Time Field

The time when Data Sourcer received statistics from Stat Server (or backup Stat Server) for the current elementary data fragment.

Transfer Time Field

If not null, this is the time when ETL Runtime transferred the current elementary data fragment.

Delete Time Field

If not null, this is the time when ETL Runtime deleted the OL_DATAn table storing statistical values for the current elementary data fragment.


Importing and Exporting Templates

Importing and Exporting Layout Templates

Importing and Exporting Layout Templates Overview

When you manually create a Data Sourcer application (that is, without using the Historical Reporting Wizard), the application contains no layout templates. If you choose to use Genesys’ predefined layout templates for Outbound Contact, Enterprise Routing, Workforce Management, Genesys Voice Portal, Internet Contact (ICS), or Voice Callback (VCB), you must import them using DMA.

Refer to the Reporting Technical Reference Guide for more information about Genesys-provided templates.

If you used the Historical Reporting Wizard to configure your Data Sourcer application, the Wizard automatically loads your solution's layout templates and report layouts into your ODS. (The Wizard also loads your solution's statistical parameters into Configuration Server under the Options section of your Stat Server [and backup Stat Server] application.)

This section provides procedures for:

  • Importing Layout Templates

  • Exporting Layout Templates


Importing and Exporting Layout Templates

Importing Layout Templates

  1. You can import layout templates by performing any of the three actions:

  • Click Import from the Toolbar.

  • Select Import from the File menu.

  • Right-click the Layout Templates folder in the Folder List or any element within this folder and select Import from the Context menu that appears.

The Open dialog box appears.

  2. Navigate to where the layout templates are stored, select the desired file, then click Open. (The file format for layout templates is XML.)

  3. If the layout template name is not unique, DMA requests that you provide unique names. (The default names DMA suggests are unique.)

  4. If any of the statistical parameters (stattype, filter, time range, or time profile) being imported are already present in ODS but have different definitions, a dialog window appears for you to resolve the inconsistencies.

    In this window, attributes presented in red and green colors are the ones that differ.

    CREATE Statistical Parameter with name—This option enables you to assign a unique name to the statistical parameter being imported and being used with the imported layout template.

    USE existing Statistical Parameter with the same definition as the imported one—This option enables you to select another statistical parameter having a different name but the exact same definition of an existing statistical parameter. (Statistical parameter descriptions can vary.)

Use existing Statistical Parameter with the same name as imported one—This option enables you to use the existing statistical parameter if it is compatible with the imported statistical parameter.

    UPDATE existing Statistical Parameter definition—This option updates the existing statistical parameter with the definition of the parameter used in the imported layout template.

    Note: There may be instances when some of these options are not available. For example, if the imported statistical parameter and the existing one have the same name but different and incompatible definitions (for stat types that occur when the Category or Object attributes are different), the USE existing Statistical Parameter and/or the UPDATE existing Statistical Parameter options will not be available.

Repeat this process for each template you import.

This function can be used with the Export function to transfer layout templates to another ODS or to back up the layout templates in the current ODS.


Exporting Templates

Importing and Exporting Layout Templates

Exporting Layout Templates

  1. You can export layout templates by performing any of the three actions:

  • Click Export from the Toolbar.

  • Select Export from the File menu.

  • Right-click a particular layout template in the Layout Templates folder of the Folder List and select Export from the context menu that appears.

The Open dialog box appears.

  2. Navigate to where you want to export the layout templates, then click Open.

Repeat this process for each layout template you want to export.

This function can be used in conjunction with the Import function to transfer layout templates to another ODS or to back up the layout templates in the current ODS. DMA exports layout templates in XML format.


Creating New Layout Templates

Creating New Layout Templates Overview

Use the Template Creation Wizard in DMA to create new layout templates within ODS. When you select a layout template from the Folder List, you can invoke the Template Creation Wizard by:

  • Selecting New from the Edit Menu.

  • Selecting New from the Context Menu.

  • Clicking New from the DMA main Toolbar.

To create layout templates, your Data Sourcer application must have a Stat Server application attached.

The Template Creation Wizard contains the following dialog boxes:

  • Layout Template—Common Info

  • Layout Template—Statistics

  • Layout Template—Time Profile

The new layout templates are written to ODS only after you have exited the Template Creation Wizard. Once created, you are able to add, remove and modify statistics from templates. (Refer to the Modifying Templates and Layouts topic for more information.)

New layout templates are automatically active upon creation. This means that when you add tenant objects to the Data Sourcer Application object following the creation of layout templates, Data Sourcer automatically creates report layouts based on the active templates. To suppress this action, you must clear the Active checkbox when you have completed creating the layout template.

And if you set the activate-new-layouts Data Sourcer configuration option to true, Data Sourcer activates these report layouts and starts collecting data for them. You can set the value of this option either during the configuration of the Data Sourcer Application using the Historical Reporting Wizard or manually within the Configuration Manager.

For information about performing these tasks, refer to the chapters about configuring historical Reporting in the Reporting 8.0 Deployment Guide and about configuring options in the Reporting 7.6 Data Sourcer User's Guide.

Note: If you manually install Data Sourcer, ODS initialization does not include canned (predefined) layout templates and report layouts. To use them, you must import them manually from your Reporting Templates CD. See Importing and Exporting Templates for a description of how to perform this operation.


Layout Template - Common Info Dialog Box

Creating New Layout Templates

Layout Template—Common Info Dialog Box

Use this dialog box to specify basic information about a layout template by entering values in the four fields provided.

Note: The Next button becomes active only after all mandatory fields contain valid values. Click Next to proceed to the Layout Template—Statistics Dialog Box.

Brief field descriptions follow.

Object Type Field

Specifies the type of objects for which any report layout based on this template collects data. Here are valid values:

  • Agent

  • Calling List

  • Campaign

  • CampaignCallingList

  • CampaignGroup

  • Group of Agents

  • Group of Places

  • Group of Queues

  • Normal DN

  • Place

  • Queue

  • Route Point

  • Routing Strategy

  • Staging Area

  • Tenant

Template Name Field

Specifies the name for the new template. You must use the following naming conventions:

  • Ten-character limitation.

  • Unique.

  • First character must be a letter.

  • Permissible characters include uppercased Latin letters, numbers, and the underscore (_).

  • No spaces permitted.

  • Cannot coincide with the following reserved names:

    AGENT
    C_CATEGORY
    C_CONTACT
    C_MATCH_AD
    C_STANDARD
    CALL_LS
    CC_AG
    CC_DAILY

    CC_GRAG
    CC_GRQ
    CC_HOURLY
    CC_MADR_D
    CC_MADR_H
    CC_Q
    CC_RP
    CC_STDR_D

    CC_STDR_H
    CMP
    CMP_CALL_L
    CMP_GR
    GROFAGS
    GROFPLS
    GROFQUEUES
    O_AGENT

    O_AGENT_GR
    PLACE
    QUEUE
    ROUTEPOINT
    SWITCH
    TENANT

  • In addition to these reserved names, Genesys recommends that you not use any of the following as column names:

CC_CATEG_D
CC_CATEG_H
EMAIL_Q
M_EMAIL_Q_MAX
M_EMAIL_Q_MIN
T_EMAIL_ACCEPTED
T_EMAIL_INB_TERM
T_EMAIL_INB_TRANS
T_EMAIL_INT_INI
T_EMAIL_OFFERED
T_EMAIL_OUT_INI
T_EMAIL_PULLED
T_EMAIL_Q_ENTERED
T_EMAIL_Q_MOVED_O

T_EMAIL_Q_STOPPED
T_EMAIL_REJECTED
T_EMAIL_TEN_AURSPN
T_EMAIL_TEN_ENTR
T_EMAIL_TEN_FRWD
T_EMAIL_TEN_INT
T_EMAIL_TEN_OUTB
T_EMAIL_TEN_REDIR
T_EMAIL_TEN_RSPND
T_EMAIL_TEN_TERM
T_EMAIL_TEN_TRNSF
T_EMAIL_TIMED_OUT
VCB_ABANDON
VCB_ASAP_CB

VCB_ATT_MADE
VCB_ATT_SUCCES
VCB_CB_DISPOS_EWT
VCB_CB_DISTR
VCB_CB_ENTER
VCB_CB_EWT
VCB_CB_FAILED
VCB_CB_RESCHED
VCB_CB_SUCCES
VCB_EV_ABAN_TR
VCB_EV_ABAND
VCB_EV_DISP_EWT
VCB_EV_DISTRIB
VCB_EV_ENTERED

VCB_EV_EWT
VCB_EV_TIME_ABAN
VCB_EV_TIME_DIST
VCB_EV_WITHIN_SL
VCB_LIVE_DISP_EWT
VCB_LIVE_DISTR
VCB_LIVE_ENTER
VCB_LIVE_EWT
VCB_NOT_RESCHED
VCB_REQ_ATTMPT
VCB_SCHED_CB
VCB_TI_DISTR_CB
VCB_TI_DISTR_LIVE
VCB_TIME_ABANDON

Layout Name Field

Specifies the unique alphanumeric name assigned to new report layouts based on this layout template. When you select an object type in the Object Type field, the wizard automatically supplies a unique default name.

Description Field

Describes the new layout template. When you select an object type, the wizard automatically supplies a default description. Filling in this field is optional.


Layout Template - Statistics Dialog Box

Creating New Layout Templates

Layout Template—Statistics Dialog Box

Use this dialog box to define the set of statistics that report layouts based on that layout template collect. You can create template statistics directly by invoking the Statistic Wizard or by importing them from existing templates or layouts by pressing the Import button. You can also change imported statistics within the Statistic Wizard.

The Layout Template-Statistics dialog box contains a list displaying all candidate statistics. Four icons above the list provide added functionality for defining statistics to the template.

Note: If the database does not contain any candidate statistics for the chosen type of template or report layout, the list view is empty in the Statistic Wizard—Stat Types dialog box. You will have to create a new statistic.

The Next button becomes active after you define one or more statistics to the template. Click Next to add these statistics to the template’s record in ODS and proceed to the Layout Template—Time Profile Dialog Box. Click Back to return to the Layout Template—Common Info Dialog Box.

Brief column descriptions follow.

Column Name Field

The name of the statistic in ODS. This name uniquely identifies a metric for a selected object type. ETL Runtime uses this column name to create a column of the same name in the Data Mart.

StatType Name Field

The statistical type on which the statistic is based.

Time Range Field

The calculated time range for the statistic if its category is TotalNumberInTimeRange or TotalTimeInTimeRange; otherwise, this field is empty.

Filter Field

The filter applied to the statistic.

Description Field

A mandatory text description of the statistic.

Use the four icons above the list to modify the list of candidate statistics. See Modifying Templates and Layouts for more information.

New

Invokes the Statistic Wizard for the creation of a new statistic candidate.

Delete

Removes the selected statistic from the list.

Properties

Invokes the Statistic Wizard for modifying a selected candidate statistic.

Import

Displays a dialog box for selecting statistics to import from an existing template or layout.


Layout Template - Time Profile Dialog Box

Creating New Layout Templates

Layout Template—Time Profile Dialog Box

Use the last dialog box of the Template Creation Wizard, Layout Template—Time Profile, to select a time profile for your layout template. Time profiles designate how frequently Data Sourcer collects data from Stat Server (or backup Stat Server). Select a time profile, and then click Finish, which closes the Template Creation Wizard and writes your layout template to ODS.

From this dialog box, you can also edit certain fields of the profile&emdash;including its description and time increment&emdash;by double-clicking a specific time profile to display the Time Profile Constructor Dialog Box.

Brief column descriptions follow.

Name Field

Name of the time profile

Definition Field

The formula, consisting of a relative start time and time increment, used to define the time profile

Description Field

Text description of the time profile

Use the three icons above the list to modify the list of candidate time profiles.

New

Invokes the Time Profile Constructor Dialog Box where you can create a new time profile

New From This

Invokes and populates the Time Profile Constructor Dialog Box with values to create a new time profile based on the properties of the selected time profile

Properties

Invokes the Time Profile Constructor Dialog Box, which displays the properties of the selected time profile. You can edit these properties if you wish.


Managing Report Layouts

Managing Report Layouts Overview

Use the Layout Creation Wizard in DMA to create a report layout either based on a layout template or a free form report layout. Your Data Sourcer application must have a Stat Server application attached to start this wizard. Data Sourcer writes the report layout to ODS only upon wizard completion. Once created, you can add, modify and remove statistics from the report layouts. (Refer to Modifying Templates and Layouts for more information.)

To activate data collection for the statistics you have specified, you must next activate the report layout. Data Sourcer collects data only for activated report layouts.

The action of deleting a report layout in DMA actually marks the corresponding record in ODS for deletion. ETL Runtime permanently removes data related to marked-for-deleted report layouts only after certain conditions have been met.


Creating New Report Layouts

Managing Report Layouts > Creating New Report Layouts

Creating New Report Layouts Overview

When you select a tenant category or report layout category in the Folder List, you can invoke the Layout Creation Wizard by:

  • Selecting New from the Edit Menu

  • Selecting New from the Context Menu

  • Clicking the New toolbar button

The Layout Creation Wizard displays the following dialog boxes:

  • Report Layout–Creation Manner

  • Report Layout–Common Info

  • Report Layout–Objects

  • Report Layout–Statistics

  • Report Layout–Time Profile


Report Layout - Creation Manner Dialog Box

Managing Report Layouts > Creating New Report Layouts

Report Layout—Creation Manner Dialog Box

This dialog box allows you to create report layouts from custom templates, from canned (predefined) templates, or from scratch. A report layout based on an existing template inherits the template’s object type and all of the template’s statistical sets, none of which can be edited. Likewise, the report layout's template name assumes the existing template’s name and cannot be edited.

To create a new Report Layout from this dialog box, select the appropriate radio button, select the base template (if applicable), then click Next to proceed to the Report Layout—Common Info Dialog Box. The Next button becomes active only after you make a selection.


Report Layout - Common Info Dialog Box

Managing Report Layouts > Creating New Report Layouts

Report Layout—Common Info Dialog Box

From this dialog box, specify basic information about a report layout by entering values in the four fields of this dialog box.

The Next button becomes active only after all mandatory fields contain valid values. Click Next to proceed to the Report Layout—Objects Dialog Box or click Back to return to the Creation Manner Dialog Box.

Brief field descriptions follow.

Tenants Field

Lists all available tenants and Environment (for multi-tenant environments only). To specify tenants, mark the appropriate check boxes for those tenants for which the report layout is to collect statistics, or mark the Environment check box only to collect tenant-level statistics.

In single tenant environments, only the tenant name appears in this list box.

Object Type Field

The type of objects for which the report layout collects data. If field is available if the report layout is not based on a layout template. Otherwise, this field assumes the object type specified by the template and is uneditable. If other than Environment was selected in the Tenants list box and the report layout is not based on a layout template, then all of the following object types are available except Tenant:

  • Agent

  • Calling List

  • Campaign

  • CampaignCallingList

  • CampaignGroup

  • Group of Agents

  • Group of Places

  • Group of Queues

  • Normal DN

  • Place

  • Queue

  • Route Point

  • Routing Strategy

  • Staging Area

  • Tenant

Note: To create a report layout using the Tenant object type, the Environment tenant must have been previously assigned to and configured for the Data Sourcer application. This is accomplished through the Configuration Manager.

Refer to the Framework 8.0 Configuration Manager Help for more information about the Environment tenant.

Layout Name Field

The unique alphanumeric name of the new report layout. When you select an object type, the wizard automatically supplies a unique default name. Report layout names are case sensitive and must be specified using Latin characters, numbers, spaces, or underscores.

Description Field

Text description of the report layout. When you select an object type, the wizard automatically supplies a default description. Filling in this field is optional.


Report Layout - Objects Dialog Box

Managing Report Layouts > Creating New Report Layouts

Report Layout—Objects Dialog Box

This dialog box defines the objects for which the report layout collects statistics. You can specify that all objects from a particular metagroup be assigned to the report layout or you can choose a subset of objects belonging to a particular metagroup.

To specify objects:

  1. Indicate object selection (all objects or individual objects) using the radio buttons.

  2. From the Tenants/Metagroup pane, select a tenant.

    From your object-type specification at the Common Info dialog box, DMA assigns a default metagroup to the report layout and displays all objects of that type belonging to the default metagroup in the Object Type list box to the right, as the following graphic illustrates.

  3. To change the metagroup, double-click a tenant record from the Tenants/Metagroup list and select a different item from the Metagroup Name list. You can only change metagroups if you selected the top radio button in Step 1.

    Note:     You cannot create metagroups within DMA. To create a new metagroup and have it available within DMA, use Configuration Manager.

  4. If you selected the bottom radio button, mark the desired objects in the Object Type list. Use the Select All or Deselect All buttons as appropriate to aid in object selection. You cannot edit the list of individual objects if you selected the top radio button.

    The following image, for example, shows three objects selected from the Sable tenant. When the finished report layout is activated, Data Sourcer will collect statistics on the contact center activities of these three groups of agents.

  5. When done, click Next to proceed to the Report Layout—Statistics Dialog Box or click Back to return to the Report Layout—Common Info Dialog Box.

Note: If your metagroup contains a large number of objects, report layout creation may take several minutes because DMA must load each object. DMA displays a warning message whenever the metagroup you select contains over 1,000 objects. This warning message provides you the option of having DMA either:

  • Load the objects so that DMA can display them in the GUI or

  • Not load the objects, in which case DMA will not display metagroup members.


Report Layout - Statistics Dialog Box

Managing Report Layouts > Creating New Report Layouts

Report Layout—Statistics Dialog Box

Use this dialog box to define the set of statistics for the new report layout. You can create statistics directly by invoking the Statistic Wizard or by importing them from existing templates or layouts. You can also change imported statistics using the Statistic Wizard.

The Report Layout—Statistics dialog box contains a list of all candidate statistics. Four icons above the list provide added functionality for defining statistics to the report layout.

Note: If you create the new Report Layout based on a template in the Report Layout—Creation Manner dialog box, you cannot select these icons or modify the statistics. Once the report layout has been created, you have the ability to go back to the report layout and add, remove or modify statistics. See Modifying Templates and Layouts for more information.

The Next button becomes active after you define one or more statistics to the report layout. Click Next to proceed to the Report Layout—Time Profile dialog box or Back to return to the Report Layout—Objects dialog box.

Brief column descriptions follow.

Column Name Field

The name of the column written to ODS. Column names cannot begin with a digit.

StatType Name Field

The name of the statistical type on which the statistic is based.

Time Range Field

The time range applied to the statistic (only present in statistics having a TotalNumberInTimeRange or TotalTimeInTimeRange statistical category).

Filter Field

The filter applied to the statistic.

Description Field

Optional description for the statistic.

Use the four icons above the list to modify the list of candidate statistics.

New

Invokes the Statistic Wizard for the creation of a new statistic candidate.

Delete

Removes the selected statistic from the list.

Properties

Invokes the Statistic Wizard for modifying a selected candidate statistic.

Import

Displays a dialog box for selecting statistics to import from an existing template or layout.


Report Layout - Time Profile Dialog Box

Managing Report Layouts > Creating New Report Layouts

Report Layout—Time Profile Dialog Box

The last dialog box of the Layout Creation Wizard is Report Layout—Time Profile which displays a list of all candidate time profiles, one of which you must select for your report layout. Time profiles designate how frequently Data Sourcer collects data from Stat Server (or backup Stat Server). The four icons above the list provide added functionality for assigning a time profile for your report layout.

Select a time profile from the list, then click Finish, which terminates the Layout Creation Wizard and writes your report layout to ODS.

Remember, you must activate the Report Layout to begin data collection for the statistics you have specified.

From the Time Profile dialog box, you can also edit certain fields of the profile—including its description and time increment—by double-clicking a specific time profile to display the Time Profile Constructor Dialog Box or by clicking the Properties icon.

Brief column descriptions follow.

Name Field

Name of the time profile

Definition Field

The formula, consisting of a relative start time and time increment, used to define the time profile

Description Field

Optional text description of the time profile

Use the four icons above the list to modify the list of candidate time profiles.

New

Invokes the Time Profile Constructor Dialog Box to create a new time profile

New From This

Invokes and prepopulates the Time Profile Constructor Dialog Box with values to create a new time profile based on properties of the selected time profile

Properties

Invokes the Time Profile Constructor Dialog Box to display properties of the selected time profile. You can edit properties of the time profile at this dialog box if desired.

Delete

Deletes the selected time profile, with confirmation.


Activating Report Layouts

Managing Report Layouts

Activating/Deactivating Report Layouts

After creating new report layouts, you must activate them for Data Sourcer to begin data collection. To do so:

  1. Right-click the desired deactivated (or not yet activated) report layout from the folder list.

  2. Select Activate from the context menu.

To deactivate a report layout:

  1. Right-click the desired activated report layout from the folder list.

  2. Select Deactivate from the context menu.

Once deactivated, Data Sourcer ceases collecting data for the report layout. And, this data becomes invisible to CCPulse+ when configured with Historical Reporting.

The icons preceding activated report layout appear in color in the folder list; icons for deactivated report layout are grayed.

You can also activate (or deactivate) a report layout by selecting Activate (or Deactivate) from the Edit menu or by selecting the Activate/Deactivate toggle from the tool bar.


Managing Report Layouts

Deleting Report Layouts

You do not need to deactivate report layouts before deleting them. To delete a report layout, select it from the Folder List or from the right pane and then do any of the following:

  • Click Delete from the toolbar.

  • Select Delete from the Edit menu.

  • Select Delete from the context menu.

Deleting a report layout marks the record for deletion in ODS and stops data collection for the report layout.

Note: To permanently remove the report layout from ODS, you must wait until ETL Runtime has transferred all related data to the Data Mart, has aggregated the data, and has purged the data from the Data Mart. You should also have ETL Runtime configured to drop transferred tables (using the dropTransferredTables configuration option) for permanent removal from ODS to take place.

For more information on this subject, refer to discussions of the dropTransferredTables configuration option in the Reporting 7.6 ETL Runtime User's Guide and the "Removing Report Folder and Report Views" topic in the Reporting 7.6 ETL Assistant Help file.


Modifying Templates and Layouts

Modifying Templates and Layouts Overview

Once created, you can make certain changes to your layout templates and report layouts. You can edit some fields, but not all. You can add, remove and modify existing statistics from the definition in your report layouts and layout templates.

Before planning any changes to your layout templates and report layouts, keep in mind that making modifications may result in a heavy load on the Data Mart. Care should be taken not to overload the system.

Modifying Layout Templates

You can modify layout templates in the following ways:

  • Making changes to the Editable Fields.

  • Adding New Statistics to layout templates.

  • Deleting Existing Statistics from layout templates.

  • Modifying Existing Statistics in your layout templates.

Modifying Report Layouts

  • Making changes to the Editable Fields.

  • Adding New Statistics to report layouts.

  • Deleting Existing Statistics from report layouts.

  • Modifying Existing Statistics in your report layouts.

Each time you make a modification and update your layout templates and report layouts, there are Log Messages written to the DMA Log File.


Modifying Templates--Editable Fields

Modifying Templates and Layouts

Modifying Templates—Editable Fields

Once created, only certain fields in your layout templates can be edited. You do have the ability to add, remove and modify existing statistics from the definition of your layout template. Keep in mind that making modifications may result in a heavy load on the Data Mart Server. Care should be taken not to overload the system.

You can edit the following fields of an existing layout template:

  • Layout Name

  • Time Profile

  • Template Description

  • Active

  • Column Name

  • Time Range, if applicable

  • Filter

  • Statistic Description

These fields correspond to the brown highlighted fields in the following image.

Double- or right-click a statistic in the list view to invoke the Statistic Wizard where you can modify a statistic's definition. Your statistic modifications affect the current template and all corresponding report layouts.


Modifying Templates--Adding New Statistics

Modifying Templates and Layouts

Modifying Templates—Adding New Statistics

You can add a new statistic to both an existing custom layout template as well as the Genesys Pre-defined or canned templates.

Genesys Pre-defined Templates

Note: Pre-defined or canned templates do have limitations on adding, deleting and modifying statistics. For migration purposes, the Genesys-provided templates only allow the modification or deletion of custom statistics suffixed with "_" or "_N" (where N is some numeric value). You will notice when you add a statistic to a pre-defined or canned template, DMA will automatically add this suffix to the statistic name. This suffix cannot be removed from the statistic name.

  1. Highlight the template in the Folder List.

  2. Right-click a statistic from the Statistics list for layout templates. The following Context Menu is displayed

:

  3. From the Context Menu, select New.

  4. If there are no layouts based on this template, you will receive no warning messages. If there are multiple layouts based on this template, the new statistic is added to all of the corresponding layouts. DMA will display a warning message to let you know how this change could impact Data Mart performance. A sample warning message is shown below:

  5. Choose Yes.

  6. This invokes the Statistic Wizard so that you can select a statistic and apply statistical parameters.

  7. Complete the steps of the Statistic Wizard.

If the statistic you are attempting to add has been used in the past in this ODS database, DMA may display the following warning message:

  8. Click OK. The new statistic is added to the template and all report layouts based on this template. The report layouts are automatically reactivated.

Note: Only previously active report layouts will be reactivated.

Custom Created Templates

  1. Highlight the template in the Folder List.

  2. Right-click a statistic from the Statistics list for layout templates. The following Context Menu is displayed:

  3. From the Context Menu, select New.

  4. If there are no layouts based on this template, you will receive no warning messages. If there are multiple layouts based on this template, the new statistic is added to all of the corresponding layouts. DMA warns you that this change might impact Data Mart performance

:

  5. Choose Yes. All layouts based on this template are deactivated.

  6. This invokes the Statistic Wizard so that you can select a statistic and apply statistical parameters.

  7. Complete the steps of the Statistic Wizard.

If the statistic you are attempting to add has been used in the past in this ODS, DMA may display the following warning message:

  8. Click OK. The new statistic is added to the template and all report layouts based on this template. The report layouts are automatically reactivated.

Note: Only previously active report layouts will be reactivated.


Modifying Templates--Modifying Existing Statistics

Modifying Templates and Layouts

Modifying Templates—Modifying Existing Statistics

You can modify a statistic from an existing Layout Template, but only if there are no report layouts based on this template that are already frozen. In this case, you can modify the properties of the statistic, but the column name is not editable.

Genesys Pre-defined Templates

The same limitations exist for modifying a statistic on a Genesys Pre-defined for canned template, as it does for adding a new statistic. You will only be able to modify statistics that end with the suffix "_".

  1. Highlight the layout template in the Folder List.

  2. Right-click the statistic you wish to modify from the Statistics list for layout templates. The following Context Menu is displayed:

  3. From the context menu, select Properties. This option is available only for custom statistics. DMA may display a warning message, informing you that changing the template might affect corresponding layouts. A sample message is shown below:

  4. Choose Yes. This invokes the Statistic Wizard where you can redefine the elements of the statistics already in the layout template.

  5. Follow the wizard's steps through to the finish screen.

The changes to the statistic will be added to the template, and any report layouts based on this template.

Custom Created Templates

The only limitation that affects custom created templates, is if there are report layouts based on this template that are already frozen. In this case, you can modify the properties of the statistic, but the column name is not editable.

  1. Highlight the layout template in the Folder List.

  2. Right-click the statistic you wish to modify from the Statistics list for layout templates. The following Context Menu is displayed:

  3. From the context menu, select Properties. DMA may display a warning message, telling you that changing the template may affect corresponding layouts. A sample message is shown below:

  4. Choose Yes. This invokes the Statistic Wizard where you can redefine the elements of the statistics already in the layout template.

  5. Follow the wizard's steps through to the finish screen.

The changes to the statistic will be added to the template, and any report layouts based on this template.


Modifying Templates--Deleting Statistics

Modifying Templates and Layouts

Modifying Templates—Deleting Statistics

You can delete a statistic from both an existing custom Layout Template as well as the Genesys Pre-defined or canned templates.

Genesys Pre-defined Templates

Note: Pre-defined or canned templates do have limitations on adding, deleting and modifying statistics. For migration purposes, the Genesys-provided templates only allow the addition and deletion of statistics that end with the suffix "_" or "_N" (N being a numeric value). You will notice when you add a statistic to a pre-defined or canned template, DMA will automatically add this suffix to the statistic name. This suffix can not be removed from the statistic name. You will only be able to delete statistics with this suffix from a pre-defined or canned template.

  1. Highlight the template in the Folder List.

  2. Right-click a statistic from the Statistics list for layout templates. The following Context Menu is displayed:

  3. From the context menu, select Delete. This option will be not be available unless the statistic you are trying to delete ends in the suffix "_" or "_N" (where N is a numeric value). DMA displays the following warning message, letting you know that the column name will permanently remain in the Data Mart, and only the data collection will stop:

  4. Choose Yes and the statistic is marked as deleted in all of the corresponding report layouts and is completely removed from the template.

Custom Created Templates

There are no limitations for deleting statistics from custom created templates.

  1. Highlight the template in the Folder List.

  2. Right-click a statistic from the Statistics list for layout templates. The following Context Menu is displayed:

  3. From the context menu, select Delete. DMA displays the following warning message, letting you know that the column name will permanently remain in the Data Mart, and only the data collection will stop:

  4. Choose Yes and the statistic is marked as deleted in all of the corresponding report layouts and is completely removed from the template.


Modifying Layouts--Editable Fields

Modifying Templates and Layouts

Modifying Layouts—Editable Fields

Once created, you can not change the object type. Some fields can be edited after creation and these are discussed below. You can also add, remove and modify statistics from the definition of the report layout.

Note: Making modifications may result in a heavy load on the Data Mart server. Care should be taken not to overload the system.

While a particular report layout is activated, you can modify the following fields:

  • Report Layout Name

  • Metagroup (Objects)

  • Description

Changing the Metagroup automatically changes the objects displayed in the Objects tab and vice versa.

These fields correspond to the brown highlighted fields in the following image.

You can also indirectly modify the Activated and Deactivated date fields by activating or deactivating the report layout.

Double-clicking the Metagroup field invokes the Report Layout Object Editor where you can select a different group of objects on which to collect statistics.


Modifying Layouts--Adding New Statistics

Modifying Templates and Layouts

Modifying Layouts—Adding New Statistics

Before adding a new statistic to an existing Report Layout, you have to deactivate the layout. Doing so allows the new statistic to be added to layouts, even if they have been transferred to Data Mart. If you are adding a statistic with a name that was previously used and marked as deleted from the database, DMA allows the statistic column name to be reused, but it could result in new data being aggregated with old values, producing incorrect yearly/quarterly/monthly reports.

Caution should be taken when adding new statistics to report layouts instead of to layout templates. Metadata is normally determined by the template, not the layout. Data Mart merges layouts based on the same template into one single view. This view could be inconsistent if the statistic is added to only one of the layouts based on a template.

Note: Adding a new statistic to an existing report layout is a costly operation for Data Mart. Genesys recommends that you add the new statistic to a layout template rather than to a report layout to maintain Data Mart consistency.

Layouts Based on Genesys Pre-defined Templates

The same rules are enforced when adding a new statistic to a report layout based on a Genesys pre-defined layout template, as they are for adding a new statistic to the pre-defined layout template itself. You will notice when you add a statistic to the report layout, DMA will automatically add the suffix "_" to the statistic name. This suffix can not be removed from the statistic name.

  1. Highlight the report layout in the Folder List.

  2. Deactivate the report layout. (See Activating/Deactivating Report Layouts topic for more information.)

  3. Right-click a statistic from the Statistics list for layout templates. The following Context Menu is displayed:

  4. From the context menu, select New. Since this report layout is based on a layout template, DMA informs you in order to maintain Data Mart consistency, it is recommended that instead you add new statistics to the layout template, rather than to the report layout. DMA also warns you that such a change might impact Data Mart performance:

  5. Choose Yes. This invokes the Statistic Wizard so that you can select a statistic and apply statistical parameters.

  6. Complete the steps of the Statistic Wizard.

If the new statistic name had been previously used in the report layout, DMA may display a warning message to let you know that this column name has been used in the past. A sample warning message is shown below:

  7. Choose Yes, and the new statistic is added to the report layout.

  8. Reactivate the report layout. All of the requested changes take affect only after you have reactivated the layout.

Layouts Based on Custom Created Templates or Layouts Not Based on Any Templates

There are no limitations to adding new statistics to layouts based on custom created layout templates or report layouts that are not based on any layout template.

  1. Highlight the report layout in the Folder List.

  2. Deactivate the report layout. (See Activating/Deactivating Report Layouts topic for more information.)

  3. Right-click a statistic from the Statistics list. The following Context Menu is displayed:

  4. From the context menu, select New. DMA warns you that such a change could impact Data Mart performance:

  5. Choose Yes. This invokes the Statistic Wizard so that you can select a statistic and apply statistical parameters.

  6. Complete the steps of the Statistic Wizard.

If the new statistic name had been previously used in the report layout, DMA may display a warning message to let you know that this column name has been used in the past. A sample warning message is shown below:

  7. Choose Yes, and the new statistic is added to the report layout.

  8. Reactivate the report layout. All of the requested changes take affect only after you have reactivated the layout.


Modifying Layouts-Modifying Existing Statistics

Modifying Templates and Layouts

Modifying Layouts—Modifying Existing Statistics

Before you can modify a statistic from an existing report layout, you have to deactivate the layout.

Note: It is recommended that you modify a statistic from the layout template rather than from a report layout to maintain Data Mart consistency.

Layouts Based on Genesys Pre-defined Templates

The same rules are enforced when modifying a statistic from a report layout based on a Genesys pre-defined layout template, as they are for modifying a statistic from the pre-defined template itself. You will only be able to modify a statistic that ends with the suffix "_" or "_N" (where N is a numeric value). You can edit the column name as long as the report layout is not currently frozen. If the report layout is frozen, the column name is not editable.

  1. Highlight the report layout in the Folder List.

  2. Deactivate the report layout. (See Activating/Deactivating Report Layouts topic for more information.)

  3. Right-click the statistic you wish to modify from the Statistics list for layout templates. The following Context Menu is displayed:

  4. From the context menu, select Properties. This option will not be available unless the statistic you are trying to modify ends in the suffix "_" or "_N" (N being a numeric value) and the layout has been deactivated. DMA displays a warning message, letting you know that statistics should be added to templates to maintain Data Mart consistency. A sample warning message is shown below:

  5. Choose Yes. This invokes the Statistic Wizard where you can redefine the elements of the statistics already in the report layout.

  6. Follow the wizard's steps through to the finish screen.

  7. Reactivate the report layout. The requested changes are not performed until the report layout is reactivated.

Layouts Based on Custom Created Templates or Layouts Not Based on Any Templates

  1. Highlight the report layout in the Folder List.

  2. Deactivate the report layout. (See Activating/Deactivating Report Layouts topic for more information.)

  3. Right-click the statistic you wish to modify from the Statistics list for layout templates. The following Context Menu is displayed:

  4. From the context menu, select Properties. This option will be not be available unless the statistic you are trying to modify has been deactivated. DMA displays the following warning message, letting you know that statistics should be added to templates to maintain Data Mart consistency. A sample warning message is shown below:

  5. Choose Yes. This invokes the Statistic Wizard where you can redefine the elements of the statistics already in the report layout.

  6. Follow the wizard's steps through to the finish screen.

  7. Reactivate the report layout. The requested changes are not performed until the report layout is reactivated.


Modifying Layouts--Deleting Statistics

Modifying Templates and Layouts

Modifying Layouts—Deleting Statistics

Before you can delete a statistic from an existing report layout, you have to deactivate the layout.

Note: It is recommended that you delete a statistic from the layout template rather than from a report layout to maintain Data Mart consistency.

Layouts Based on Genesys Pre-defined Templates

The same rules are enforced when deleting a statistic from a report layout based on a Genesys pre-defined template, as they are for deleting a statistic from the pre-defined template itself. You will only be able to delete a statistic that ends with the suffix "_" or "_N" (where N is a numeric value).

  1. Highlight the report layout in the Folder List.

  2. Deactivate the report layout. (See Activating/Deactivating Report Layouts topic for more information.)

  3. Right-click a statistic from the Statistics list for layout templates. The following Context Menu is displayed:

  4. From the context menu, select Delete. This option will not be available unless the statistic you are trying to delete ends in the suffix "_" or "_N" (where N is a numeric value). DMA displays the following warning message letting you know that the column name remains in the Data Mart and only collection of the data stops. Also, to maintain Data Mart consistency, it is recommended that you delete statistics from layout templates, rather than report layouts:

  5. Choose Yes and the statistic is marked as deleted. The column name remains in the Data Mart tables permanently and only the data collection stops.

  6. Reactivate your report layout.

Layouts Based on Custom Created Templates or Layouts Not Based on Any Templates

There are no limitations on deleting a statistic from a layout based on a custom created layout template or a report layout that is not based on any layout template.

  1. Highlight the report layout in the Folder List.

  2. Deactivate the report layout. (See Activating/Deactivating Report Layouts topic for more information.)

  3. Right-click a statistic from the Statistics list for layout templates. The following Context Menu is displayed:

  4. From the context menu, select Delete. DMA displays the following warning message letting you know that the column name remains in the Data Mart and only collection of the data stops. Also, to maintain Data mart consistency, it is recommended that you delete statistics from layout templates, rather than report layouts:

  5. Choose Yes and the statistic is marked as deleted. The column name remains in the Data Mart tables permanently and only the data collection stops.

  6. Reactivate your report layout.


DMA Log Messages

Modifying Templates and Layouts

Modifying Templates and Layouts—DMA Log Messages

After you perform an update to an existing layout template, report layout, or both, DMA log messages are written to a DMA Log File. Along with the usual log file information that is collected, updating a layout template, report layout or both, will log:

  • The update action that occurred.

  • The statistic that was modified.

  • Whether the update took place in a layout template or report layout.


Managing Statistical Parameters

Managing Statistical Parameters Overview

Use the following constructor dialog boxes in DMA to create, modify, or delete statistical parameters:

  • Filter Constructor Dialog Box

  • StatType Constructor Dialog Box

  • Time Profile Constructor Dialog Box

  • Time Range Constructor Dialog Box


Managing Statistical Parameters

Creating Statistical Parameters

You can create statistical parameters by selecting the desired parameter type in the Folder List and then selecting one of the following:

  • New from the Context Menu

  • New from the Edit Menu

  • New from the Toolbar

DMA opens one of the following four constructor dialog boxes which enable you to specify the definition for a filter, stattype, time profile, or time range:

  • Filter Constructor Dialog Box

  • StatType Constructor Dialog Box

  • Time Profile Constructor Dialog Box

  • Time Range Constructor Dialog Box

You can also create statistical parameters from the listing in the right pane by right-clicking a specific statistical parameter and selecting either New or New From This from the Context Menu that appears. Likewise, you can create statistical parameters during the creation of layout templates or report layouts as well.

To create a statistical parameter, your Stat Server application must be attached to Data Sourcer. Data Sourcer writes the definition of the new parameter to ODS as well as to Stat Server.


Managing Statistical Parameters

Modifying Statistical Parameters

You can modify existing statistical parameters by either double-clicking the desired parameter in the right pane or selecting the desired parameter from the right pane and then choosing Properties from the Context Menu. DMA opens one of the following four constructor dialog boxes which enable you to view or modify the definition for your selected filter, stattype, time profile, or time range:

  • Filter Constructor Dialog Box

  • StatType Constructor Dialog Box

  • Time Profile Constructor Dialog Box

  • Time Range Constructor Dialog Box

In addition, you can modify statistical parameters during the creation of layout templates or report layouts.

When modifying statistical parameters, you should first assess the complete set of statistics that employ the parameter to determine the impact of the proposed modification. For instance, if you modify the definition of a time range so that it is more restrictive, reports spanning the period prior to and following your modification may yield results which are difficult to interpret. DMA's Dependent Objects Tree provides a listing of statistics that will be affected by modifications.

To modify a statistical parameter, your Stat Server application must be attached to Data Sourcer. Data Sourcer writes the definition of the modified parameter to ODS as well as to Stat Server.


Managing Statistical Parameters

Deleting Statistical Parameters

When you opt to delete a statistical parameter, DMA first checks that no other report layout or layout template uses that parameter. If so, DMA prevents its deletion and displays the Dependent Objects Tree.

The delete operation permanently removes related information from ODS as well as from Stat Server (and backup Stat Server), if Stat Server is attached to your Data Sourcer application. If Stat Server is not attached, Data Sourcer only deletes the parameter from ODS.

You delete a specific statistical parameter by selecting it in the right pane and then issuing one of the following commands:

  • Delete from the Edit menu

  • Delete button from the Toolbar

  • Delete from the Context Menu

  • Delete key on your keyboard

You can delete more than one statistical parameter at a time by selecting each parameter before deletion. The image below, for example, shows three filters selected.

DMA confirms the deletion of each selected and eligible parameter with the following message box:

If the parameter is ineligible for deletion, DMA displays the Dependent Objects Tree.


Filter Constructor Dialog Box

Managing Statistical Parameters > Filter Constructor Dialog Box

Filter Constructor Dialog Box Overview

This dialog box enables you to define new filters in the configuration of Stat Server (and backup Stat Server) and in ODS and ensures that the filter’s definition is syntactically correct.

You must type a unique name for the filter in the Name field without using multibyte symbols. The name you provide becomes the name of the new corresponding configuration option in the Filters section of the Stat Server (and backup Stat Server) application. Filling in the last field, Description, is optional. If you do so, use an alphanumeric text string.

Note: Do not use single or double quotes in the name (even though Configuration Manager may allow names with such characters).

The rest of the dialog box has a structure similar to that of the Custom Formula Constructor dialog box. The filter definition you create becomes the value of the new option in Stat Server (and backup Stat Server) configuration.

To create the filter definition, follow these steps:

  1. Create an Atomic Logical Expression.

  2. Create a Complex Expression.

  3. Designate the Filter Definition.


Managing Statistical Parameters > Filter Constructor Dialog Box

Create an Atomic Logical Expression

An atomic logical expression is either:

  • A comparison between two expressions (specified at the Logical expression tab) or

  • The boolean PairExists function evaluated on a string constant argument (the key in a key-value list) and a string or integer constant argument (the value in a key-value list). This boolean function is specified at the KV pair tab.

Logical Expression Tab

When creating a comparison using the Filter Constructor Dialog Box, select the Logical expression tab and supply values for the three parts: the left side of the comparison, the comparison operator, and the right side.

Left Side

The values that you can select for the left side of your logical expression are bound in a list and limited to the following:

  • ANI

  • DNIS

  • CustomerID

  • Treatment

  • MediaType

  • ThisQueue

  • Reason

  • User defined properties

Comparison Operator

For all values except "User defined properties", you can select one of two comparison operators in the center section for your logical expression: = or !=.

You have a greater selection of comparison operators available to you for user-defined properties: =, !=, >, <, >=, or <=. Before selecting an operand, however, DMA first displays the Compound Operand dialog box.

Right Side

The permissible values for the right side are also dependent on the selection you make at the left side. The values are summarized as follows:

Keyword Selected

Valid Right Side Value

ANI, DNIS, CustomerID, ThisQueue, or Reason

A string constant (typed in without quotation marks) or an evaluation of the GetString function

Treatment

One treatment type selected from the list box.

MediaType

  • An unsigned number (integer or fixed-point decimal)

  • One of the keywords corresponding to media types selected from the list box or

  • An evaluation of one of the functions GetNumber, GetMax, GetMin, GetSum, and GetAver.

Compound Operand Dialog Box

The Compound Operand Dialog Box appears when you select User-defined properties from either the left- or right-hand list boxes in the Logical Expression frame.

In this dialog box:

  1. Select a function in the first list box and a string argument of the function in the second field (without quotation marks).

  • If you select GetNumber from the first field, a third field appears on the rightmost side where you must select a number between 1 and 100 or the word Last (for -1) as a second argument.

  • Clicking OK closes the Compound Operand dialog box and copies the evaluation expression into the corresponding comparable field (the Expression Stack).

All other comparables are either typed in (string or numeric constants) or selected from the corresponding drop-down list (keywords and named constants).

  2. Select a comparison operator from the drop-down list between the two comparables. The symbols =, !=, <, >, <=, and >= are permitted for numeric comparables, = and != &emdash; for string ones.

  3. After you select both the comparables and the comparison operator, click the check-mark button to enter the comparison to the bottom of the expression stack.

KV Pair Tab

When creating an evaluation of the Boolean PairExists function, select the tab KV pair in the Filter Constructor dialog box.

The value you provide in the Key field must be a string constant without quotation marks. Value must be:

  • One of the following keywords ANI, DNIS, CustomerID, ThisQueue, or Reason

  • A string constant typed inside quotation marks or

  • An integer, fixed-point decimal, or floating-point decimal constant.

Click the check-mark button to enter the evaluation of the PairExists function on the specified arguments on the bottom of the Expression Stack.


Managing Statistical Parameters > Filter Constructor Dialog Box

Treatment Types

Some examples of the treatment types available from the Logical expression list box are shown below. The actual list depends on your Configuration Server version:

  • Unknown

  • IVR

  • Music

  • Ringback

  • Silence

  • Busy

  • CollectDigits

  • PlayAnnouncement

  • PlayAnnouncementAndDigits

  • VerifyDigits

  • RecordUserAnnouncement

  • DeleteUserAnnouncement

  • CancelCall

  • PlayApplication

  • SetDefaultRoute

  • TextToSpeech

  • TextToSpeechAndDigits

  • FastBusy

  • RAN

  • IDMAX

  • User defined properties

Refer to the Genesys 7 Events and Models Reference Manual for a definition and description of these treatment types.


Managing Statistical Parameters > Filter Constructor Dialog Box

Mediatype Types

Select a pre-defined media type from the list or enter a custom-defined media type.

Note: The media type must match the media type name exactly, as it is defined in Configuration Server (in the Business Attributes section); DMA does not verify if they match.

  • alert

  • appsharing

  • busevent

  • callback

  • chat

  • cobrowsing

  • Custom

  • email

  • fax

  • imchat

  • smail

  • sms

  • video

  • vmail

  • voice

  • voip

  • webform

  • whiteboard

  • workitem

Refer to the Genesys 7 Events and Models Reference Manual for more information about these media types.

Note: Some of these media types may not be supported across the Genesys suite.


Managing Statistical Parameters > Filter Constructor Dialog Box

Create a Complex Expression

You can create a complex expression in one of two ways.

  • Select an expression in the expression stack and click the ~ button. The negation of the selected expression is entered on the bottom of the Expression Stack.

  • Select two or more expressions in the Expression Stack and click either & or | button underneath. The new expression consists of the selected expression connected by the chosen connective in the order in which they are presented in the operand pool. This order need never be changed, because both connectives are commutative.

Every expression in the scope of a logical connective is supplied with a pair of enclosing parentheses.

You can delete any number of selected expressions from the Expression Stack by clicking the Delete button.


Managing Statistical Parameters > Filter Constructor Dialog Box

Designate the Filter Definition

You designate the filter definition by selecting an expression in the Expression Stack and clicking the check-mark button under the Expression Stack (active when one, and only one expression, is selected in the stack). DMA copies the selected expression into the Definition field.

Until OK is clicked, you can create new expressions and change the designated filter definition.

When you click OK, the filter confirmation dialog box appears if no filter under the same name exists in Stat Server (and backup Stat Server) and no record of a filter of the same name exists in the OL_STAT_PARAM table of ODS (that is, no record in which the column PARAMETER_KEY equals Filter, and the column PARAMETER_NAME equals the selected name that exists in the table).

After clicking Yes, the newly described Filter Name and Definition are entered into the Filters section of the Stat Server (and backup Stat Server) application.


StatType Constructor Dialog Box

Managing Statistical Parameters > StatType Constructor Dialog Box

StatType Constructor Dialog Box Overview

Invoke the StatType Constructor dialog box (see following graphic) to create, view, or modify a statistical type. You can open the StatType Constructor dialog box by:

  • Selecting New or Properties from the Context Menu invoked over the list of statistical types in the Statistic Wizard—StatTypes dialog box

  • Selecting New, New from This, or Properties from the context menu invoked over a statistical type in the right pane.

  • Selecting New from the Edit menu with the Statistical Types folder selected in the Folder List or a specific statistical type selected in the right pane.

  • Clicking the New button from the Toolbar with the Statistical Types folder selected in the Folder List or a specific statistical type selected in the right pane.

If you choose New from This, DMA prepopulates the StatType Constructor dialog box with the same information as the selected statistical type provided the stat type is not based on a Java statistical category, such as javaTotal, javaMax, and javaMin. You cannot use DMA to create, modify, view, or delete Java stat types.

Refer to the Reporting Technical Reference Guide for a detailed discussion about stat types and their components.

Brief field descriptions follow.

Name Field

You must enter the unique alphanumeric name of the new statistical type here. You cannot use multibyte symbols, single quotes, or double quotes (even though Configuration Manager allows names with such characters).

Category Field

The category on which the statistical type is based. Listed are the valid statistical categories:

  • AverageOfCurrentNumber

  • AverageOfCurrentTime

  • MaxCustomValue

  • MaxNumber

  • MaxTime

  • MinCustomValue

  • MinNumber

  • MinTime

  • TotalAdjustedNumber

  • TotalAdjustedTime

  • TotalCustomValue

  • TotalNumber

  • TotalNumberErrors

  • TotalNumberInTimeRange

  • TotalTime

  • TotalTimeInTimeRange

Formula Field

Displays the statistical type’s custom formula. This field is active only for the following statistical categories: TotalCustomValue, MaxCustomValue, and MinCustomValue. For new stat types, this field remains blank until you provide a formula using the Custom Formula Constructor. Once constructed, the formula displays in this field.

Summation Button ( )

Calls the Custom Formula Constructor Dialog Box for custom formula creation. This field is active only for the following statistical categories: TotalCustomValue, MaxCustomValue, and MinCustomValue.

Subject Field

The subject of calculation for statistics based on the new statistical type. Here are the valid subjects:

  • Action

  • AgentStatus

  • CampaignAction

  • DNAction

  • DNStatus

  • PlaceStatus

  • GroupStatus

  • Status

Objects Field

Lists the three compatibility groups: Agent, Queue, and Campaign. Below the drop-down list box a list of all objects belonging to the selected compatibility group. Where applicable, choose one or more of these objects by selecting the preceding check box.

Distinct by ConnID

Specifies that the statistics gathered should be distinct by connection ID. Distinguish by ConnID is a qualifier applied to statistical type formulas.

Actions Field

Below the drop-down list box is a list of all Stat Server actions or statuses applicable to the Subject specified and to the selected object type’s compatibility group. (A compatibility group is the maximal set of object types for which the same statistics can be collected.) Choose any number of these actions or statuses (subject to limitations) by marking the preceding check box. You must select at least one action.

Note: For some actions, DMA automatically selects a second action which serves as the action's alias. In these situations, even though you select only one action, two are actually selected.

Tip: If you hover over any action in the Actions listing, DMA displays a tool tip listing all selected actions.

You must specify actions for Main mask. Specifying a relative mask is optional and useful for calculating composite statistics such as averages and percentages for custom statistics. None of the statistics in Genesys-provided templates use a relative mask.

Reverse Selection

Indicates that all selected actions be excluded from the statistical type definition and that cleared actions be included.

Description Field

Mandatory text description of the statistical type.


Managing Statistical Parameters > StatType Constructor Dialog Box

StatType Action Limitations

The main mask actions specified when defining a statistical type at the StatType Constructor Dialog Box are concatenated to comprise one string that is sent to ODS. This string is subject to a 255-character limitation which is imposed by Configuration Server. When marking more than one main mask from the Actions list view, keep this limitation in mind. The examples below illustrate how the length of the Actions string is calculated.

Example 1

The image below marks four main masks.

The length of the Actions string sent to ODS upon pressing the OK button (not pictured above) is:

len(ActionString) = len("CallAbandonedFromDialingInbound") +

len(", ") + len("CallAbandonedFromDialingInternal") +

len(", ") + len("CallAbandonedFromDialingOutbound") +

len(", ") + len("CallAbandonedFromDialingUnknown") =

31 + 2 + 32 + 2 + 32 + 2 + 31 = 132

Example 2

The image below marks the same main masks as Example 1. The Reverse Selection check box, however, is marked as well indicating ~CallAbandonedFromDialingInbound, ~CallAbandonedFromDialingInternal, ~CallAbandonedFromDialingOutbound, and ~CallAbandonedFromDialingUnknown should be submitted. The length of the Actions string using these selections is 132 as in Example 1 plus 4 not signs (~) for a total of 136.


Managing Statistical Parameters > StatType Constructor Dialog Box

StatType Aliases

In this release, DMA supports aliases for actions that were previously call-centric. So if, for instance, you select the CallInternal action at the Stat Type Constructor dialog box, DMA automatically selects its alias, HandlingInternal, as well to enable support for noncall-centric interactions, such as e-mail and chat sessions. Likewise, if you select the HandlingInternal action, DMA selects the CallInternal action as well. Be sure you account for this additional mask assignment in the computation of the action string sent to ODS.

Note: Do not use media-independent masks for Queue, QueueGroup, or Routepoint objects because Stat Server cannot interpret this construction. For instance, instead of specifying the Accepted action for a queue object, specify CallAnswered.

Under certain circumstances, DMA substitutes aliases for some of the actions in the templates you import from XML files. If, for instance, you import a template that uses the InteractionDelivering action in a main mask (or relative mask) specification for a particular stat type, DMA substitutes the comparable "Delivering, CallRinging" actions when you visit the StatType Constructor dialog box and click OK.

Here is an abbreviated listing of some DN actions and their corresponding media aliases.

DN Action Name | Media Action Name
CallRinging | Delivering
CallAnswered | Accepted
CallInternal | HandlingInternal
CallInbound | HandlingInbound
CallOutbound | HandlingOutbound
CallTransferTaken | TransferTaken
CallTransferMade | TransferMade
CallConferenceMade | ConferenceMade
CallConferenceJoined | ConferenceJoined

Refer to the Reporting Technical Reference Guide for a complete mapping of multimedia aliases to the former call-centric actions and the Framework 8.0 Stat Server User's Guide for a description of each action.


Custom Formula Constructor Dialog Box

M anaging Statistical Parameters > StatType Constructor Dialog Box > Custom Formula Constructor Dialog Box

Custom Formula Constructor Dialog Box Overview

From the StatType Constructor Dialog Box, open the Custom Formula Constructor dialog box to create a simple or complex custom formula. The steps you take begin at the bottom of the window and move up, namely:

  1. Create an Atomic Operand.

  2. Create a Complex Operand.

  3. Designate the Custom Formula.

Note: Custom formula creation is only available for stat types based on the TotalCustomValue, MaxCustomValue, and MinCustomValue statistical categories.


Create an Atomic Operand

An atomic operand is a positive, numeric constant. To create an atomic operand:

  1. Type a whole number or fixed-point decimal in the Operand field.

  2. Click the Operand Check button to add your numeric expression to the Operands' Pool.

To create an evaluation operand, click the Operand summation button [image] . The Compound Operand dialog box, pictured below, opens. From the first list box, select one of five functions applied to string constant arguments:

    • Four unary functions: GetMax, GetMin, GetSum, and GetAver

    • One binary function: GetNumber

The function’s string argument must be typed in the second field without quotation marks (internally, DMA adds quotation marks automatically). If the GetNumber function is selected, an additional drop-down list box appears where you must select a number between 1 and 100 or the word “Last“ (for -1). Click OK to close the Compound Operand dialog box.


Create a Complex Operand

You create a complex operand by selecting two or more operands from the operand pool and applying an arithmetic operator to them. The new operand consists of the selected operands connected by the chosen operator in the order in which they are present in the operand pool (parentheses are added to all complex operands and function evaluation operands). You can change the order of atomic operands by clicking the up or down arrows when an operand is selected in the operand pool.

You can delete any number of selected operands from the operand pool by clicking the Delete button.


Designate the Custom Formula

You designate a custom formula by selecting an operand from the operand pool and clicking the operand pool check-mark button (active when you select one and only one operand in the pool). DMA copies the selected operand to the Custom Formula field.

DMA activates the OK button only when you designate a custom formula. Until you click OK, you can create new operands and change the designated custom formula. Clicking OK closes the Custom Formula Constructor Dialog Box and copies the designated custom formula into the Formula field of the StatType Constructor Dialog Box.

Note: By opening the Custom Formula dialog box again (to designate and save another formula), the new formula replaces the previous one in the Formula field of the StatType Constructor dialog box.


Managing Statistical Parameters

Time Profile Constructor Dialog Box

Invoke the Time Profile Constructor dialog box to create, view, or modify a time profile. DMA displays this dialog box when you select any of the following:

  • New, New From This, or Properties from the Context Menu invoked over a time profile in the right pane

  • New, New From This, or Properties icons from the Report Layout—Time Profile Dialog Box

  • New, New From This, or Properties icons from the Layout Template—Time Profile Dialog Box

If you select New From This, DMA prepopulates the Time Profile Constructor dialog box with the same information as the selected time profile. You must provide a unique name.

Brief field and button descriptions follow.

Name Field

The unique alphanumeric name of the new time profile

Note: Do not use single or double quotes in the name (even though Configuration Manager allows names with such characters).

Definition Field

The formula, consisting of a relative start time and time increment, used to define the time profile

Operand Pool Field

Removes the selected operand from the operand pool

Concatenates all operands and places the result in the Definition field.

Note: At this time, Data Sourcer supports only simple time profiles containing one operand.

Reset Time

The relative start time measured in hours:minutes for which statistics are to be collected

Increment

The increment of time, measured in hours:minutes for which statistics are to be collected

Operand Check Button

Moves the Reset Time and Increment into the Operand Pool.

Description Field

Text description of the time profile


Managing Statistical Parameters

Time Range Constructor Dialog Box

Invoke the Time Range Constructor dialog box to create, view, or modify a time range. DMA displays this dialog box when you select any of the following:

  • New or New From This from the Context Menu invoked over a time range in the right pane.

  • New, New From This, or Properties icons from the Statistic Wizard—Time Ranges dialog box (for stat types having TotalNumberInTimeRange or TotalTimeInTimeRange statistical categories)

  • New from the Edit Menu

  • New from the Toolbar

If you select New From This, DMA prepopulates the Time Range Constructor dialog box with the same information as the selected time range. You must provide a unique name.

Brief field and button descriptions follow.

Name Field

The unique alphanumeric name of the new time range

Note: Do not use single or double quotes in the name (even though Configuration Manager allows names with such characters).

Definition Field

The formula, consisting of a time range start and time range end, used to define the time range

Range Start

The start of the time range measured in seconds

Range End

The end of the time range measured in seconds

Definition Check Button

Moves the selected Range Start and Range End into the Definition field

Description Field

Text description of the time range


Managing Statistical Parameters

Dependent Objects Tree

DMA displays the Dependent Objects Tree when you select Dependent Objects from the Context Menu or when you attempt to delete a statistical parameter that is used in a report layout or layout template.

The image below, for example, shows all objects that depend on the isNotVCB filter.

The VCB_RP layout template has been expanded to reveal four statistics using this filter.


Synchronizing Statistical Parameters

Within DMA, you can synchronize the statistical parameters stored in Stat Server (and backup Stat Server) with those stored in ODS using one of two methods:

  • Click the Synchronize button on the toolbar.

  • Select the Synchronize menu item from the File menu.

The synchronize feature restores ODS definitions of time profiles, time ranges, statistical types, and filters to Stat Server (and backup Stat Server). (The feature does not remove extraneous statistical parameters found in Stat Server [or backup Stat Server] that do not exist in ODS.)

Note: DMA does not request confirmation on a parameter-by-parameter basis nor does it allow you to undo synchronization. Once you select to synchronize Stat Server's parameters to ODS, Data Sourcer processes the request.

Stat Server's statistical parameters can fall out of synchronization with ODS statistical parameters for a number of reasons including:

  • Within Configuration Manager, a user reassigns a different Stat Server (or backup Stat Server) to Data Sourcer.

  • Within Configuration Manager, a user deletes, renames, or redefines statistical parameters in the Stat Server (or backup Stat Server) assigned to Data Sourcer.

If you do not synchronize Stat Server with ODS when the two are out of sync, some data chunks will not contain the requested statistical information. Data Sourcer and Stat Server (or backup Stat Server) will also record anomalies in their respective log files.


Statistic Wizard

Statistic Wizard Overview

Invoke the Statistic Wizard by clicking the Add New Statistic icon in either the Layout Template—Statistic Dialog Box or the Report Layout—Statistic Dialog Box. The Statistic Wizard offers the following four dialog boxes to assist in defining and modifying statistics and their parameters:

  • StatTypes

  • Time Ranges

  • Filters

  • Column Info

All specifications made within the Statistic Wizard are reflected both in ODS and in the configuration of the Stat Server (or backup Stat Server) application where ODS obtains data. Hence, to operate the Statistic Wizard, your Data Sourcer application must have a Stat Server attached.


Statistic Wizard - StatTypes Dialog Box

Statistic Wizard

Statistic Wizard—StatTypes Dialog Box

The first window of the Statistic Wizard is the StatTypes dialog box. You must select a statistical type from the list on the left side of the dialog box. The right side contains several fields with information about the selected statistic. The three icons above the list provide added functionality for defining new statistical types as does the Context Menu.

The next dialog box to appear in the Statistic Wizard depends on the value of the TimeRange Applicable check box. If cleared, the wizard displays the Filters Dialog Box; if selected, the Time Ranges Dialog Box precedes the Filters dialog box.

Note: If the database does not contain any candidate statistics for the chosen type of layout template or report layout, the list view is empty in the Statistic Wizard—Stat Types dialog box. It will require the creation of a new statistic.

Brief field descriptions follow.

Description Field

Text description of the statistical type

Properties Field

Displays the definition of the selected statistical type

Historical

Provided only for reference to indicate whether or not the selected statistical type collects historical statistics

Filter Applicable

Provided only for reference to indicate whether or not the selected statistical type can be filtered

Time Range Applicable

Provided only for reference to indicate whether or not the selected statistical type has a time range defined

Java

Provided only for reference to indicate whether or not the selected statistical type is unknown to Stat Server (or backup Stat Server) and created using the Java Language.

Use the three icons above the list to modify the list of candidate statistics.

New

Invokes the StatType Constructor Dialog Box to create a new statistic

New From This

Invokes and prepopulates the StatType Constructor Dialog Box with values to create a new statistical type based on properties of the selected statistical type

Properties

Invokes the StatType Constructor Dialog Box to display and edit properties of the selected statistical type. (The StatType name cannot be edited.)


Statistic Wizard - Time Ranges

Statistic Wizard

Statistic Wizard—Time Ranges Dialog Box

DMA displays this dialog box if the TimeRanges Applicable check box was selected in the Statistic Wizard—StatTypes Dialog Box.

You must select a time range for the statistic from the time ranges listed. Three icons above the list invoke the Time Range Constructor Dialog Box where you can view, create, or edit the selected time range’s properties.

After selecting a time range, click Next to proceed to the Statistic Wizard—Filters Dialog Box or Back to return to the Statistic Wizard—StatTypes Dialog Box.

Brief column descriptions follow.

Name Field

The unique alphanumeric name of the time range

Note: Do not use single or double quotes in the name (even though this may be permissible in the Configuration Manager).

Definition Field

The time span in seconds for which a statistic using this time range collects data

Description Field

Optional text description of the time range

Use the three icons above the list to modify the selected time range.

New

Invokes the Time Range Constructor Dialog Box to create a new time range

New From This

Invokes and prepopulates the Time Range Constructor Dialog Box with values to create a new time range based on properties of the selected time range

Properties

Invokes the Time Range Constructor Dialog Box to display and edit properties of the selected time range. (You cannot edit the Name.)


Statistic Wizard - Filters Dialog Box

Statistic Wizard

Statistic Wizard—Filters Dialog Box

DMA displays this dialog box displays if you selected the Filter Applicable check box at the Statistic Wizard—StatTypes dialog box.

Select a filter in this dialog box to qualify the statistics to be gathered. The dialog box contains a list which displays information about any filter defined in ODS.

You can select only one row from the list. If you select a row and then Next, DMA applies the selected filter to the statistical type indicated at the previous window (Statistic Wizard—StatTypes dialog box). If you do not select a row, DMA applies no filter.

Five icons above the list provide added functionality for assigning a filter to the statistical type. Four of them invoke the Filter Constructor Dialog Box where you can view, create, edit, or delete the selected filter’s properties. The fifth icon clears any selection made.

Brief column descriptions follow.

Name Field

The alphanumeric name of the filter

Note: Do not use single or double quotes in the name (even though Configuration Manager allows names with such characters.)

Definition Field

The qualifying conditions specified to limit the attributes returned of a particular statistical type

Description Field

Optional text description of the filter

The five icons above the list view allow modification or deletion of the selected filter.

New

Invokes the Filter Constructor Dialog Box to create a new filter

New From This

Invokes and prepopulates the Filter Constructor Dialog Box with values to create a new filter based on properties of the selected filter

Properties

Invokes the Filter Constructor Dialog Box to display and edit properties of the selected filter. (You cannot edit the filter name.)

Note: You can modify filters from an existing Report Layout only when that Report Layout is deactivated.

Delete

Deletes the selected filter with confirmation, if no report layout or layout template references the filter. Refer to Dependent Objects Tree for additional information.

Unselect

Clears the selected row


Statistic Wizard - Column Info

Statistic Wizard

Statistic Wizard—Column Info Dialog Box

The final dialog box of the Statistic Wizard is Column Info where you specify where to store your statistic. In the Table Column Name field, type a name that does not exceed 18 characters. Only use Latin characters, numbers, or the underscore character (_) and do not begin this name with a number. Then, at your discretion, type a description of the statistic in the Description field.

Click Finish to terminate the Statistic Wizard and return to the next window of the Layout Creation Wizard (Report Layout—Statistics Dialog Box) or Template Creation Wizard (Layout Template—Statistics Dialog Box).


DMA Log File

The Data Modeling Assistant application produces a log file (DMA.log) to store information about statistical parameter changes made during a live DMA session. This file—located in the same directory as the DMA executable—contains the following information for each change:

  • Timestamp

  • CS host (Configuration Server host)

  • CS port

  • CS user

  • CS application

  • DBMS user

  • DBMS server

  • Message

The Message field contains information about any statistical types, filters, time profiles, layout templates, report layouts and time ranges that you altered. This changed information includes:

  • Identification number of the changed statistical parameter as stored in ODS.

  • Previous values for various attributes of the statistical parameter.

  • New values for various attributes of the statistical parameter.

  • Update action that occurred in a layout template or report layout.

  • Actual statistic that was modified in a layout template or report layout.

  • Whether the update took place in a layout template, report layout, or both.

The log file is continuous; new changes are appended at the end of the file. If you delete this file, DMA creates a new one when next invoked.