About This File

Call Concentrator 7 Log Events Help

Copyright © 2002–2004 Genesys Telecommunications Laboratories, Inc. All rights reserved.
70cc_logevents-help_11-2004_v3.00

[This file was removed before Call Concentrator 7 Log Events was added into the Combined Log Events Help (v3.10).]


call Concentrator Log Events

call concentrator log events overview

Call Concentrator messages report problems or information about server activity. Call Concentrator Log Events contains additional information about these messages, including diagnostic information and, when applicable, possible corrective actions. It provides more detailed information than the message text that displays on the screen.

To obtain more information about a message:

  1. Identify the message number within the message on the screen.

  2. Select the matching topic in this help document.

Changes to log events from release 6.1 to 7.0 are also documented.

Trace-Level Events in Call Concentrator

Unlike other Genesys applications, Call Concentrator trace-level logging is not meant for onsite customer use, either for analysis or alarm-setting. If you encounter a problem, Genesys Technical Support uses the trace-level log events to identify its source. In the event of a problem manifested in a trace-level log message, report the event to Genesys Technical Support and attach your log file.


CCon_TraceEvents

call Concentrator Log Events

Call Concentrator Trace Events

Unlike other Genesys applications, Call Concentrator trace-level logging is not meant for onsite customer use, either for analysis or alarm-setting. If you encounter a problem, Genesys Technical Support uses the trace-level log events to identify its source.

In the event of a problem manifested in a trace-level log message, report the event to Genesys Technical Support and attach your log file.

Note: Trace-level log events are not individually documented in this Help file.


Call Concentrator--Changes from 6.0 to 6.1

call Concentrator Log Events

call concentrator—Changes from 6.0 to 6.1

Call Concentrator did not support the log event messaging in release 6.0. Log events are new to release 6.1 for Call Concentrator.


Call Concentrator--Changes from 6.1 to 7.0

call Concentrator Log Events

Call Concentrator—Changes from 6.1 to 7.0

There was no 6.5 release of Call Concentrator, and there are no changes to the Call Concentrator log events from release 6.1 to release 7.0.

One log event, 09-21103, was removed in release 7.0.002.03. It is replaced by Common Log Event 00-07001.

These log events were added in release 7.0.001.02:

ID | Level | Text
09-20000 | Standard | Missing host in command line.
09-20001 | Standard | Missing port in command line.
09-20002 | Standard | Wrong port number in the command line (must be a positive integer).
09-20003 | Standard | Missing application name in the command line.
09-20004 | Standard | For usage, run ccon -help.
09-20005 | Standard | Cannot connect to the license manager: [reason].
09-20006 | Standard | Will try to connect to the License Manager once more (remaining time [time]).
09-20007 | Standard | Final attempt to connect to License Manager failed. Quitting....
09-20009 | Standard | License Error (Number): [number].
09-20024 | Standard | PANIC! Can't set timer.
09-20206 | Standard | WARNING! Unknown section '[section_name]'.
09-20207 | Standard | WARNING! Unknown option '[section_name]:[option_name]' has been ignored.
09-20405 | Standard | WARNING! Wrong value [value] of the [option_name] option.
09-21006 | Standard | Unknown exception trapped in [code_location].
09-21007 | Standard | Disconnected from T-Server [T-Server_name] via the Load Distribution Server [LDS_name] at host [host_name] port [port_number].
09-21157 | Standard | DBLIB API error: code [value], message [value2], DB Server [server].


call Concentrator Log Events

09-20005

Level | Standard
Text | Cannot connect to the license manager: [reason].
Attributes | [reason] The reason you cannot connect.
Description | Call Concentrator was unable to connect to the specified License Manager for the specified reason.
Actions | None. Call Concentrator automatically makes additional attempts to connect.


call Concentrator Log Events

09-20006

Level | Standard
Text | Will try to connect to the License Manager once more (remaining time [time]).
Attributes | [time] Duration in seconds.
Description | Call Concentrator will again try to connect to License Manager after the specified time elapses.
Actions | Informational—no action needed.


call Concentrator Log Events

09-20007

Level

Standard

Text

Final attempt to connect to License Manager failed. Quitting....

Attributes

None

Description

Call Concentrator cannot connect to the License Manager you specified. Call Concentrator is no longer trying to connect and is shutting down.

Alarm Advisory

Indicates abnormal conditions. You might consider setting an Alarm Condition for this event.

Actions

  • Check the reason code given in Event 09-20005 and follow the instructions for dealing with it, if any.

  • Ensure that License Manager is properly installed and is running.

  • Ensure that the path and filename or host and port settings for License Manager have been specified correctly in Configuration Manager.

  • Restart Call Concentrator.


call Concentrator Log Events

09-20020

Level | Standard
Text | User break: signal [signal number]. Exiting....
Attributes | [signal number] An integer that specifies the signal used to stop Call Concentrator.
Description | The user entered [CTRL+C] on a Windows platform or the kill command on a Unix platform to stop Call Concentrator.
Actions | Restart Call Concentrator


call Concentrator Log Events

09-20026

Level | Standard
Text | Unknown exception has been trapped in [location]
Attributes | [location] The location within the source code where the exception occurred.
Description | Provides information about an internal Call Concentrator error.
Actions | Restart Call Concentrator. If the problem persists, contact Genesys Technical Support.


call Concentrator Log Events

09-20060

Level | Standard
Text | Will try to connect to the backup Configuration Server [server name]
Attributes | [server name] Name of Configuration Server
Description | Reports that Call Concentrator cannot connect to the primary Configuration Server and will try to connect to the backup server.
Actions | None


call Concentrator Log Events

09-20061

Level | Standard
Text | Security violation: most probably an instance of the application is already running.
Attributes | None
Description | Reports that Call Concentrator cannot connect to the Configuration Server for security reasons. Configuration Server does not allow two daemon applications with the same name to be connected at the same time.
Actions | Determine if another application with the same name is already running. Make sure that the name of the application in the command line matches the name in the Configuration Database.


call Concentrator Log Events

09-20062

Level | Standard
Text | Application login incorrect
Attributes | None
Description | Indicates that Call Concentrator cannot connect to the Configuration Server for security reasons.
Actions | Make sure that the name of the application in the command line matches the name in the Configuration Database.


call Concentrator Log Events

09-20063

Level | Standard
Text | Error while getting startup information about the primary Configuration Server [application name]
Attributes | [application name] Application name of the primary Configuration Server.
Description | Reports that Call Concentrator encountered an error while reading the configuration data.
Actions | Check the configuration and restart the application.


call Concentrator Log Events

09-20064

Level | Standard
Text | Error while getting startup information about the backup Configuration Server [application name]
Attributes | [application name] Application name of the backup Configuration Server.
Description | Reports that Call Concentrator encountered an error while reading the configuration data.
Actions | Check the configuration and restart the application.


call Concentrator Log Events

09-20200

Level | Standard
Text | Option [section name]:[option name] set to [option value]
Attributes | [section name] Name of the section where the option is specified [option name] Option name [option value] Option value
Description | Reports that the given configuration option was set to the given value according to the configuration data.
Actions | None


call Concentrator Log Events

09-20201

Level | Standard
Text | Option [section name]:[option name] was changed from [old option value] to [new option value]
Attributes | [section name] Name of the section where the option is specified [option name] Option name [old option value] Old option value [new option value] New option value
Description | Reports that the value of the given configuration option was changed at runtime.
Actions | None


call Concentrator Log Events

09-20202

Level | Standard
Text | Option [section name]:[option name] was deleted
Attributes | [section name] Name of the section where the option is specified [option name] Option name
Description | Reports that the given configuration option was deleted at runtime.
Actions | None


call Concentrator Log Events

09-20203

Level | Standard
Text | Option [section name]:[option name] absent. Set to default value [option value]
Attributes | [section name] Name of the section where the option is specified [option name] Option name [option value] Option value
Description | Reports that the given configuration option is not explicitly specified and was set to the given default value.
Actions | None


call Concentrator Log Events

09-20204

Level | Standard
Text | The negative value of the option [section name]:[option name] has been changed to the default [option value]
Attributes | [section name] Name of the section where the option is specified [option name] Option name [option value] Option value
Description | Indicates that the value explicitly specified for the given configuration option is out of the admissible range, and the option will therefore be set to the default value instead.
Actions | Verify the admissible range of values for the given option in Call Concentrator 7 Deployment Guide and set the option to an appropriate value. Depending on the option, this setting may or may not take effect at runtime. Refer to the option description in Call Concentrator 7 Deployment Guide for more information.


call Concentrator Log Events

09-20205

Level | Standard
Text | Option [section name]:[option name] change rejected. You need to restart the application to adopt the new option value [option value].
Attributes | [section name] Name of the section where the option is specified. [option name] Option name [Option value] Option value
Description | Reports that a new setting for the given option cannot take effect at runtime.
Actions | If you need the new value to take effect immediately, restart Call Concentrator.


call Concentrator Log Events

09-20206

Level | Standard
Text | WARNING! Unknown section '[section_name]'.
Attributes | [section_name] Name of the unrecognized section in the Call Concentrator Application object Options tab.
Description | Reports that a section name you have entered is misspelled or otherwise unrecognizable.
Actions | Correct the section name.


call Concentrator Log Events

09-20207

Level | Standard
Text | WARNING! Unknown option '[section_name]:[option_name]' has been ignored.
Attributes | [section_name] Name of a section in the Call Concentrator Application object Options tab. [option_name] Name of an unrecognized option in the Call Concentrator Application object Options tab.
Description | Reports that an option name within a recognized section is misspelled or otherwise unrecognizable.
Actions | Correct the option name.


call Concentrator Log Events

09-20300

Level | Standard
Text | WARNING! Wrong port value [port number] specified for the application [application name]
Attributes | [port number] Port Number [application name] Application name
Description | Reports that the port of the given server was specified incorrectly.
Actions | Verify and change the port number.


call Concentrator Log Events

09-20301

Level | Standard
Text | WARNING! No host is specified for the application [application name]
Attributes | [application name] Application name
Description | Reports that the application was unable to connect to the given server because the host of that server was not specified.
Actions | If you want the application to connect to the given server, specify its host and port.


call Concentrator Log Events

09-20302

Level | Standard
Text | PANIC! Can't find the cached object for the [object type] '[object name]' (DBID '[DBID value]')
Attributes | [object type] Type of configuration object [object name] Name of the configuration object deployed by the application [DBID value] The integer value used by Configuration Server as the unique identifier of the configuration object.
Description | At runtime, Call Concentrator maintains an internal cache of appropriate configuration objects. The message reports that the previously cached object was not found in the cache.
Actions | Restart the application. If the message persists, contact Genesys Technical Support.


call Concentrator Log Events

09-20303

Level | Standard
Text | PANIC! Can't find the cached object [object type] object (DBID '[DBID value]')
Attributes | [object type] Type of configuration object [DBID value] The integer value used by Configuration Server as the unique identifier of the configuration object.
Description | At runtime, Call Concentrator maintains an internal cache of appropriate configuration objects. The message reports that the previously cached object was not found in the cache.
Actions | Restart the application. If the message persists, contact Genesys Technical Support.


call Concentrator Log Events

09-20304

Level | Standard
Text | WARNING! Application [application name] of an alien type has been added to the connections. The change is ignored.
Attributes | [application name] Application name
Description | Reports that the type of server being added to the connections of this Call Concentrator application did not correspond to the types of servers a Call Concentrator application can be the client of.
Actions | If you need the Call Concentrator application to connect to a new server, make sure that server is of the right type.


call Concentrator Log Events

09-20306

Level | Standard
Text | Can't read the list of [object type]s for [application type] [application name] from the Configuration Database.
Attributes | [object type] Configuration object type [application type] Application type [application name] Application name
Description | Reports that the application was unable to read objects of the given type, for the specified application, that it required in order to operate. One possible reason is that the connection to the Configuration Server was lost during the initial phase of the application's execution.
Actions | Restart the application. If the message persists, contact Genesys Technical Support.


call Concentrator Log Events

09-20400

Level | Standard
Text | FATAL! No DB Server has been specified in the configuration. Exiting...
Attributes | None
Description | Reports that the application was unable to enter its normal operating mode because no database access point is specified in the configuration.
Actions | Specify the database access point for this application.


call Concentrator Log Events

09-20401

Level | Standard
Text | FATAL! No T-Server has been specified in the configuration. Exiting...
Attributes | None
Description | Reports that the application was unable to enter its normal operating mode because no T-Servers are specified in the configuration.
Actions | Specify a connection to a T-Server for this application.


call Concentrator Log Events

09-20402

Level | Standard
Text | No switch for the '[server name]' [server type]
Attributes | [server name] Server application name [server type] The type of server. Can be either T-Server or Event Multiplexor.
Description | Reports that no switch was associated with the T-Server or Event Multiplexor in the configuration with which the application should connect.
Actions | Specify a switch associated with T-Server or Event Multiplexor.


call Concentrator Log Events

09-20403

Level | Standard
Text | WARNING! Refused connect to the second DB Server '[server name]' (only one allowed)
Attributes | [server name] Server application name
Description | Reports that a second DB Server (or database access point) has been added to the connections of the application and that the addition was ignored because only one database access point (or DB Server) is allowed in the application's configuration.
Actions | Remove the extraneous database access point or DB Server from Call Concentrator's connections.


call Concentrator Log Events

09-20404

Level | Standard
Text | WARNING! Wrong syntax of the '[option name]' option
Attributes | [option name] Option name
Description | Reports that a syntax error has been detected in the option's value.
Actions | Correct the value.


call Concentrator Log Events

09-20405

Level | Standard
Text | WARNING! Wrong value [value] of the [option_name] option.
Attributes | [value] The value that has been entered for the specified option. [option_name] Name of the configuration option name.
Description | Reports that an incorrect value has been entered for a Call Concentrator configuration option in Configuration Manager.
Actions | Consult the documentation to determine a valid value, enter the corrected value, and then restart Call Concentrator.


call Concentrator Log Events

09-20500

Level | Standard
Text | Single CDR number limit exceeded!!! DATA WILL BE LOST!
Attributes | None
Description | Reports that the upper limit for call records details set by the SingleCDRLimit configuration option was reached and that this can eventually cause a loss of data.
Actions | Increase the value of the SingleCDRLimit option or set it to zero.


call Concentrator Log Events

09-20501

Level | Standard
Text | Started creating CDRs
Attributes | None
Description | Reports that the number of Call Detail Records in Call Concentrator's memory has fallen below the limit set by the SingleCDRLimit configuration option and that Call Concentrator has resumed creation of those records.
Actions | None


call Concentrator Log Events

09-20600

Level | Standard
Text | PANIC!!! DB errors limit [error threshold] reached. Please check database and/or Call Concentrator configuration.
Attributes | [error threshold] Threshold for the number of errors reported by the DBMS.
Description | Reports that the number of errors returned by the DBMS in response to writing attempts reached the limit set by the DbMaxErrorsBeforeShutdown configuration option.
Actions | Check the database, DBMS, and Call Concentrator's configurations. Restart Call Concentrator. Change the value of the DbMaxErrorsBeforeShutdown configuration option.


call Concentrator Log Events

09-20601

Level | Standard
Text | 'UseBinding' option ignored (binding is supported only for Oracle DBMS)
Attributes | None
Description | Reports that the UseBinding option set for Call Concentrator was ignored because the DBMS does not support this feature.
Actions | None, or set the UseBinding option to false.


call Concentrator Log Events

09-21001

Level | Standard
Text | Cannot connect to the [application type] [application name] at host [host name] port [port number]
Attributes | [application type] Application type [application name] Application name [host name] Host name [port number] Port number
Description | Reports that Call Concentrator was unable to connect to the given server at the moment. The attempt to connect will be repeated automatically.
Actions | Check the status of the specified server and the network connectivity between the host computers where Call Concentrator and the specified server are running.


call Concentrator Log Events

09-21002

Level | Standard
Text | Connecting to T-Server [application name] via the Load Distribution Server [application name] at host [host name] port [port number]
Attributes | [application name] Application name [application name] Application name [host name] Host name [port number] Port number
Description | Reports that Call Concentrator tried to connect to the specified T-Server by way of the specified Load Distribution Server.
Actions | None


call Concentrator Log Events

09-21003

Level | Standard
Text | Cannot connect to T-Server [application name] via the Load Distribution Server [application name] at host [host name] port [port number]
Attributes | [application name] Application name [application name] Application name [host name] Host name [port number] Port number
Description | Reports that Call Concentrator was unable to connect to the specified T-Server by way of the specified Load Distribution Server. The attempt to connect will be repeated automatically.
Actions | Check the status of the specified Load Distribution Server and the network connectivity between the host computers where Call Concentrator and the Load Distribution Server are running.


call Concentrator Log Events

09-21004

Level | Standard
Text | Will try to reconnect to [application type] [application name] in [reconnect timeout] sec
Attributes | [application type] Application type [application name] Application name [reconnect timeout] Reconnect timeout
Description | Reports that Call Concentrator will make another attempt to connect to the specified server in the specified time interval.
Actions | None


call Concentrator Log Events

09-21005

Level | Standard
Text | Connecting to T-Server [application name] via the Load Distribution Server [application name] at host [host name] port [port number]
Attributes | [application name] Application name [application name] Application name [host name] Host name [port number] Port number
Description | Reports that the application successfully connected to the specified T-Server by way of the specified Load Distribution Server.
Actions | None


call Concentrator Log Events

09-21006

Level | Standard
Text | Unknown exception trapped in [code_location].
Attributes | [code_location] The location in the code where the exception occurs.
Description | Reports an abnormal internal condition.
Alarm Advisory | Indicates abnormal conditions. You might consider setting an Alarm Condition for this event.
Actions | Contact Genesys Technical Support.


call Concentrator Log Events

09-21007

Level

Standard

Text

Disconnected from T-Server [T-Server_name] via the Load Distribution Server [LDS_name] at host [host_name] port [port_number].

Attributes

[T-Server_name]
Name of a T-Server application configured in Configuration Manager.

[LDS_name]
Name of an LDS application configured in Configuration Manager.

[host_name]
Host name of the machine where LDS is running.

[port_number]
Port number of the machine where LDS is running.

Description

Reports that the connection to the specified T-Server has been lost. Might indicate that:

  • There has been no activity on the connection for a long time.

  • Other more important connections should be established.

  • Too many wrong messages have been received from the client.

Actions

A single occurrence is not critical. If the problem persists, check common log event 00-04523 in the server logs to identify the cause of the disconnection.


call Concentrator Log Events

09-21100

Level | Standard
Text | Cannot start [DBMS name] client for the DB Server '[application name]'
Attributes | [DBMS name] DBMS name (Oracle, Sybase, and so on) [application name] Name of the DB Server or Database Access Point
Description | Reports that the attempt to initiate the DB Server component that provides connectivity to the DBMS failed.
Actions | Check DB Server installation. Look for a network problem. Restart the application. If these actions fail to correct the problem, contact Genesys Technical Support.


call Concentrator Log Events

09-21101

Level | Standard
Text | Cannot set the autocommit mode '[mode]'
Attributes | [mode] On or Off
Description | Reports failure of the request to DB Server to set the mode specified by the SendBeginTransaction configuration option.
Actions | Check the DB Server installation. Check if the DBMS is configured to support the autocommit mode. Look for a network problem. Restart the application. If the problem persists, contact Genesys Technical Support.


call Concentrator Log Events

09-21102

Level | Standard
Text | Opening database: user = [user name], password = [password], name = [database name], server = [server name]
Attributes | [user name] Name of the account on whose behalf the database is being opened [password] Password of the account on whose behalf the database is being opened [database name] Name of the database being opened [server name] Name of the database server
Description | Reports that Call Concentrator is trying to open the database for writing.
Actions | None


call Concentrator Log Events

09-21104

Level | Standard
Text | Cannot open database: user = [user name], password = [password], name = [database name], server = [server name]
Attributes | [user name] Name of the account on whose behalf the database is being opened [password] Password of the account on whose behalf the database is being opened [database name] Name of the database being opened [server name] Name of the database server
Description | Reports that Call Concentrator could not open the database for writing using the specified parameters.
Actions | Check the DBMS configuration and related access control settings.


call Concentrator Log Events

09-21105

Level | Standard
Text | Closing database
Attributes | None
Description | Reports that Call Concentrator was closing its connection to the database.
Actions | None


call Concentrator Log Events

09-21106

Level | Standard
Text | Database closed
Attributes | None
Description | Reports that Call Concentrator successfully closed its connection to the database.
Actions | None


call Concentrator Log Events

09-21107

Level | Standard
Text | DB Server [application name] disconnected due to error!
Attributes | [application name] DB Server name
Description | Reports that Call Concentrator disconnected from the DB Server as a result of an error returned by the DB Server. As a rule, the previous log message specifies the cause of the error.
Actions | Correct the error and restart Call Concentrator.


call Concentrator Log Events

09-21108

Level | Standard
Text | May have lost transaction (records since the last commit)
Attributes | None
Description | If the SendBeginTransaction configuration option is set to true and if the connection to the DB Server happens to be lost and then restored, Call Concentrator tries to repeat the last transaction, that is, the one that has not yet been completed. Rarely, the connection may break after the commit request for the transaction was sent but the confirmation has not yet been received. In this case, Call Concentrator takes an optimistic approach and counts the transaction as successful, but warns the user with this message.
Actions | None


call Concentrator Log Events

09-21120

Level | Standard
Text | DB Server '[application name]' cannot execute request having ID'[request ID]'
Attributes | [application name] Name of the DB Server [request ID] An integer used by DB Server to uniquely identify the request. The information may be useful to match the application log with the one in DB Server while resolving the problem.
Description | Reports that DB Server was unable to execute the request due to an error. As a rule, the message is followed by the messages 21121 and 21122 describing the request that prompted the error and the error's cause. The cause of the error is, in general, DBMS dependent and may vary widely. Most probably, the error is because the DBMS, and/or the application itself has been misconfigured. For example, the application can be configured to use a new table format, while the database tables have been created with a 'dart' SQL script.
Actions | Consult the DBMS documentation to understand the cause of the error. Check the system configuration as needed. Correct the error and restart the application.


call Concentrator Log Events

09-21121

Level | Standard
Text | The failed request: [request string]
Attributes | [request string] Textual representation of the failed request. Usually, a SQL statement.
Description | Reports the contents of the request of the DB Server that prompted the error reported in preceding message 21120. As a rule, the message is followed by the message 21122 which describes the cause of the error.
Actions | See the description for message 21120.


call Concentrator Log Events

09-21122

Level | Standard
Text | The DBMS error: [error description]
Attributes | [error description] Textual description of the error.
Description | Reports the text of the message received by DB Server from the respective DBMS in response to a failed request that was reported by messages 21120 and 21121.
Actions | See the action for message 21120.


call Concentrator Log Events

09-21150

Level | Standard
Text | Error has been reported by the DB Server '[application name]' :'[error text]'
Attributes | [application name] Name of the DB Server [error text] Short description of the error
Description | Reports that an error notification was received from the DB Server. Most probably, the error is due to the fact that the DBMS and/or the application itself was misconfigured. For example, the application can be configured to use a new table format, while the database tables have been created with a 'dart' SQL script.
Actions | Consult your DBMS documentation to understand the cause of the error. Check the system configuration as needed. Correct the error and restart Call Concentrator.


call Concentrator Log Events

09-21157

Level | Standard
Text | DBLIB API error: code [value], message [value2], DB Server [server].
Attributes | [value] The code number of the error. [value2] The message text of the error. [server] Identifies the DB Server involved.
Description | Reports an internal problem detected while communicating with DB Server.
Actions | None. Genesys internal use only.