Welcome to the Enterprise SDK

Enterprise SDK 8.0 API Reference
Welcome to the Enterprise SDK

This API Reference includes introductory material that should help you understand and use the Enterprise SDK.

Important Note: Usage of Enterprise SDK that is provided with this Restricted release is supported only for the purpose of Interaction Workspace customization. The Enterprise SDK is not publicly available as a separate product and is subject to change as development continues.
Documentation for this release describes the Enterprise SDK in it's current state, and is provided on an "as is" basis. Updates to reflect API changes are planned as future releases are distributed.
If you have a use case or design that could benefit from using Enterprise SDK, please contact Order Management for more information about how to inquire about a pre-release version of the Enterprise SDK for development purposes.

General Introduction

Description

Enterprise SDK is a Service Oriented Architecture (SOA) implemented on top of .Net 3.5 framework. It includes a set of related components accessible through services and designed to offer a wide range of usability. Enterprise SDK offers the following features: Able to add or remove services, alter behavior and mix technology. Allows access to low level protocol information. Able to add or remove services and Protocols. Includes both declarative (via attributes) and imperative support. Internal architecture is ready for DSL. Technology agnostic within the same eco-system (e.g. .Net platform. Use WWF, WCF, etc)

Prerequisites

Please note the following prerequisites for your Enterprise SDK environment:

  • Genesys supports only the use of release 8.0 or higher of the underlying servers to which your custom applications connect.
  • Ensure that Microsoft .NET Framework 3.5 is installed on the computer on which you plan to run your Enterprise SDK application. (.NET Framework 3.5 can be downloaded free of charge from the Microsoft website.)

Contents

Namespaces

Namespace Name | Description
Genesyslab.Enterprise.Agent | Contains classes and interfaces related to the agent.
Genesyslab.Enterprise.Commons | Contains common classes used in the methods of the ESDK interfaces.
Genesyslab.Enterprise.Commons.Collections | Contains common collections used in the methods of the ESDK interfaces.
Genesyslab.Enterprise.Core | Contains interfaces and classes related to core information.
Genesyslab.Enterprise.Exceptions | Contains general enterprise exceptions.
Genesyslab.Enterprise.Exceptions.Broker | Contains exceptions related to the Event Broker Application Block.
Genesyslab.Enterprise.Exceptions.Channel | Contains exceptions related to the channels' management.
Genesyslab.Enterprise.Exceptions.Protocol | Contains exceptions related to the protocols' management.
Genesyslab.Enterprise.Extensions | Contains the extensions available for the services of the Genesyslab.Enterprise.Services namespace.
Genesyslab.Enterprise.Framework.Container.Unity | Contains unity containers.
Genesyslab.Enterprise.Model.Channel | Contains interfaces, classes, and extensions available to manage channels.
Genesyslab.Enterprise.Model.Common | Contains common collections used in the methods of the Model namespaces.
Genesyslab.Enterprise.Model.ComponentModel | Contains the interfaces, classes, and extensions related to the Event Broker Application Block.
Genesyslab.Enterprise.Model.Device | Contains the interfaces, classes, and extensions available to manage devices.
Genesyslab.Enterprise.Model.Envelope | Contains the interfaces and classes available to manage event envelopes.
Genesyslab.Enterprise.Model.Interaction | Contains the interfaces and classes available to manage interactions.
Genesyslab.Enterprise.Model.Protocol | Contains the interfaces and classes available to manage protocols.
Genesyslab.Enterprise.Model.ServiceModel | Contains the entry point of the Enterprise SDK.
Genesyslab.Enterprise.Services | Contains the services.
Genesyslab.Enterprise.Services.Model | Contains monitor interfaces.

Scope of use

Typical usage scenarios of Enterprise SDK include:
  • Managing agent activity:
    • Implement login and logout functionality.
    • Implement ready, not-ready, and after-call-work features.
  • Handling voice interactions (depending on your switch’s available features):
    • Make an outgoing call.
    • Answer an incoming call.
    • Hold and retrieve a call.
    • Transfer a call.
    • Alternate calls.
    • Initiate, enter, and leave a conference.
  • Managing contacts:
    • Search a contact.
    • Using the system features to get options about the application used in the Configuration Layer.

Documentation Resources

The Enterprise SDK documentation is available online in the Documentation Wiki of the Developer Zone, and covers the following topics:
  • Enterprise SDK Overview: Get familiar with the Enterprise SDK and learn what you can do with this product.
  • Enterprise SDK Get Started: Get a quick start with Enterprise SDK by opening and examining the sample application that included with your installation package.
  • Enterprise SDK Developer's Guide: Read everything that you need to know for writing your own applications built with Enterprise SDK.
  • Enterprise SDK Deployment Guide: Learn how to deploy Enterprise SDK onto your system so that you can create custom applications.
  • Enterprise SDK Resources: Use these code examples, application blocks, and tutorials that Genesys has created to help make your development process easier.
  • Enterprise SDK FAQs: the Frequently Asked Question pages of the Enterprise SDK.

You will find additional help and advice in the Genesys forums.

Note: This document may not be the latest version of the API Reference. For the latest versions of all SDK documents, please see the Genesys Developer Website, the Developer Zone. The Genesys Developer Documentation CD also has all the latest SDK documents. And the Genesys Technical Support website has many of the latest as well.

Additional Information

For more information about the Genesys SDKs, check out the Genesys Developer Zone, which contains the latest versions of all SDK documents, as well as forums and other important sources of developer-related information. DevZone is available at http://www.genesyslab.com/developer.

Additional information on Genesys Telecommunications Laboratories, Inc. is available on our Technical Support website.

Copyright Information

Copyright © 2009–2010 Genesys Telecommunications Laboratories, Inc. All rights reserved.

Any authorized distribution of any copy of this code (including any related documentation) must reproduce the following restrictions, disclaimer and copyright notice:

The Genesys name, trademarks and/or logo(s) of Genesys shall not be used to name (even as a part of another name), endorse and/or promote products derived from this code without prior written permission from Genesys Telecommunications Laboratories, Inc.

The use, copy, and/or distribution of this code is subject to the terms of the Genesys Developer License Agreement. This code shall not be used, copied, and/or distributed under any other license agreement.

THIS CODE IS PROVIDED BY GENESYS TELECOMMUNICATIONS LABORATORIES, INC. (“GENESYS”) “AS IS” WITHOUT ANY WARRANTY OF ANY KIND. GENESYS HEREBY DISCLAIMS ALL EXPRESS, IMPLIED, OR STATUTORY CONDITIONS, REPRESENTATIONS AND WARRANTIES WITH RESPECT TO THIS CODE (OR ANY PART THEREOF), INCLUDING, BUT NOT LIMITED TO, IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR NON-INFRINGEMENT. GENESYS AND ITS SUPPLIERS SHALL NOT BE LIABLE FOR ANY DAMAGE SUFFERED AS A RESULT OF USING THIS CODE. IN NO EVENT SHALL GENESYS AND ITS SUPPLIERS BE LIABLE FOR ANY DIRECT, INDIRECT, CONSEQUENTIAL, ECONOMIC, INCIDENTAL, OR SPECIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, ANY LOST REVENUES OR PROFITS).

Copyright © 2009–2010 Genesys Telecommunications Laboratories, Inc. All rights reserved.

Send comments on this topic to Techpubs.webadmin@genesyslab.com


Genesyslab.Enterprise.Agent Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Agent Namespace
Send Feedback

Interfaces

Interface | Description
IAgent | Agent interface.

Enumerations

Enumeration | Description
AgentStateType | Agent status.
Generated on

Copyright (c) 2008-2010 Genesys Telecommunications Laboratories, Inc. All rights reserved


AgentStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
AgentStateType Enumeration
See Also Send Feedback
Agent status.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum AgentStateType
Visual Basic (Declaration)
Public Enumeration AgentStateType
Visual C++
public enum class AgentStateType

Members

Member name | Description
Unknown | The agent state is unknown.
LoggedOut | The agent state is logged out.
LoggedIn | The agent state is logged in.
Ready | The agent state is ready.
NotReady | The agent state is not ready.
AfterCallWork | The agent state is aftercallwork.
Busy | The agent state is busy.
OutOfService | The agent state is out of service.

See Also

Genesyslab.Enterprise.Agent Namespace


IAgent Interface

[image]

Enterprise SDK 8.0 Reference API
IAgent Interface
Members See Also Send Feedback
Agent interface.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IAgent : IIdentity, IRoleable,
    ISerializable
Visual Basic (Declaration)
Public Interface IAgent _
    Implements IIdentity, IRoleable, ISerializable
Visual C++
public interface class IAgent : IIdentity,
    IRoleable, ISerializable

See Also

IAgent Members
Genesyslab.Enterprise.Agent Namespace


IAgent Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent Members
IAgent Interface Methods Properties See Also Send Feedback

The IAgent type exposes the following members.

Methods

Name | Description
Controller | Overloaded.
DndState | Overloaded.
ForwardDestination | Overloaded.
ForwardMode | Overloaded.
ForwardNumber | Overloaded.
ForwardState | Overloaded.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
HasAgentInfo | Report if a device contains some agent data (Inherited from IIdentity.)
LastUpdateQueue | Queue modified from the last server update received
Queues | Gets the list of Queues on which the agent is logged-in.
State | Overloaded.
WorkModeType | Overloaded.

Properties

Name | Description
Attributes | Dynamic and static data defined for this identity. (Inherited from IIdentity.)
Devices | Collection of associated devices (single or groups). Use IdentityService.SetDevice to associate Device (Inherited from IIdentity.)
FQName | Fully Qualified Name (Unique ID for this object). (Inherited from IIdentity.)
Group | Groups of identities. (Inherited from IIdentity.)
IdentityBase | Gets the Base identity of this identity. (Inherited from IIdentity.)
Item | Gets the property according to its key.
Name | Identity name. (Inherited from IIdentity.)
Role | Gets or sets the role of an object. (Inherited from IRoleable.)
Strategy | Strategies for this identity. (Inherited from IIdentity.)

See Also

IAgent Interface
Genesyslab.Enterprise.Agent Namespace


IAgent Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent Methods
IAgent Interface See Also Send Feedback

The IAgent type exposes the following members.

Methods

Name | Description
Controller | Overloaded.
DndState | Overloaded.
ForwardDestination | Overloaded.
ForwardMode | Overloaded.
ForwardNumber | Overloaded.
ForwardState | Overloaded.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
HasAgentInfo | Report if a device contains some agent data (Inherited from IIdentity.)
LastUpdateQueue | Queue modified from the last server update received
Queues | Gets the list of Queues on which the agent is logged-in.
State | Overloaded.
WorkModeType | Overloaded.

See Also

IAgent Interface
Genesyslab.Enterprise.Agent Namespace


Controller Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.Controller Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
Controller()()() | Gets the Controller of this object. (Inherited from IIdentity.)
Controller(String) | Gets the Controller of this object. (Inherited from IIdentity.)

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


DndState Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.DndState Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
DndState(IClientChannel) | Gets the Do Not Disturb state of the agent according to the channel.
DndState(IDevice) | Gets the Do Not Disturb state of the agent according to the device.
DndState(IClientChannel, MediaType) | Gets the Do Not Disturb state of the agent according to the channel and the media.

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


DndState Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.DndState Method (IClientChannel)
IAgent Interface See Also Send Feedback
Gets the Do Not Disturb state of the agent according to the channel.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool DndState(
    IClientChannel channel
)
Visual Basic (Declaration)
Function DndState ( _
    channel As IClientChannel _
) As Boolean
Visual C++
bool DndState(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.

Return Value

the Do Not Disturb state of this agent.

See Also

IAgent Interface
DndState Overload
Genesyslab.Enterprise.Agent Namespace


DndState Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.DndState Method (IDevice)
IAgent Interface See Also Send Feedback
Gets the Do Not Disturb state of the agent according to the device.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool DndState(
    IDevice device
)
Visual Basic (Declaration)
Function DndState ( _
    device As IDevice _
) As Boolean
Visual C++
bool DndState(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
a device of the agent.

Return Value

the Do Not Disturb state of this agent.

See Also

IAgent Interface
DndState Overload
Genesyslab.Enterprise.Agent Namespace


DndState Method (IClientChannel, MediaType)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.DndState Method (IClientChannel, MediaType)
IAgent Interface See Also Send Feedback
Gets the Do Not Disturb state of the agent according to the channel and the media.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool DndState(
    IClientChannel channel,
    MediaType media
)
Visual Basic (Declaration)
Function DndState ( _
    channel As IClientChannel, _
    media As MediaType _
) As Boolean
Visual C++
bool DndState(
    IClientChannel^ channel,
    MediaType media
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.
media
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType
a media used by this agent.

Return Value

the Do Not Disturb state of this agent.

See Also

IAgent Interface
DndState Overload
Genesyslab.Enterprise.Agent Namespace


ForwardDestination Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardDestination Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
ForwardDestination(IClientChannel) | Obsolete.
ForwardDestination(IDevice) | Obsolete.
ForwardDestination(IClientChannel, MediaType) | Obsolete.

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


ForwardDestination Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardDestination Method (IClientChannel)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use ForwardNumber instead")]
string ForwardDestination(
    IClientChannel channel
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use ForwardNumber instead")> _
Function ForwardDestination ( _
    channel As IClientChannel _
) As String
Visual C++
[ObsoleteAttribute(L"Use ForwardNumber instead")]
String^ ForwardDestination(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IAgent Interface
ForwardDestination Overload
Genesyslab.Enterprise.Agent Namespace


ForwardDestination Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardDestination Method (IDevice)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Device.IDevice)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use ForwardNumber instead")]
string ForwardDestination(
    IDevice device
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use ForwardNumber instead")> _
Function ForwardDestination ( _
    device As IDevice _
) As String
Visual C++
[ObsoleteAttribute(L"Use ForwardNumber instead")]
String^ ForwardDestination(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Device.IDevice)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Device.IDevice)"]

See Also

IAgent Interface
ForwardDestination Overload
Genesyslab.Enterprise.Agent Namespace


ForwardDestination Method (IClientChannel, MediaType)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardDestination Method (IClientChannel, MediaType)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use ForwardNumber instead")]
string ForwardDestination(
    IClientChannel channel,
    MediaType media
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use ForwardNumber instead")> _
Function ForwardDestination ( _
    channel As IClientChannel, _
    media As MediaType _
) As String
Visual C++
[ObsoleteAttribute(L"Use ForwardNumber instead")]
String^ ForwardDestination(
    IClientChannel^ channel,
    MediaType media
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

media
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType

[Missing <param name="media"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

See Also

IAgent Interface
ForwardDestination Overload
Genesyslab.Enterprise.Agent Namespace


ForwardMode Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardMode Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
ForwardMode(IClientChannel) | Gets the ForwardMode of the agent according to the channel.
ForwardMode(IDevice) | Gets the ForwardMode of the agent according to the device.
ForwardMode(IClientChannel, MediaType) | Gets the ForwardMode of the agent according to the channel and the media.

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


ForwardMode Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardMode Method (IClientChannel)
IAgent Interface See Also Send Feedback
Gets the ForwardMode of the agent according to the channel.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ForwardModeType ForwardMode(
    IClientChannel channel
)
Visual Basic (Declaration)
Function ForwardMode ( _
    channel As IClientChannel _
) As ForwardModeType
Visual C++
ForwardModeType ForwardMode(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.

Return Value

the ForwardMode type of this agent.

See Also

IAgent Interface
ForwardMode Overload
Genesyslab.Enterprise.Agent Namespace


ForwardMode Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardMode Method (IDevice)
IAgent Interface See Also Send Feedback
Gets the ForwardMode of the agent according to the device.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ForwardModeType ForwardMode(
    IDevice device
)
Visual Basic (Declaration)
Function ForwardMode ( _
    device As IDevice _
) As ForwardModeType
Visual C++
ForwardModeType ForwardMode(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
a device of the agent.

Return Value

the ForwardMode type of this agent.

See Also

IAgent Interface
ForwardMode Overload
Genesyslab.Enterprise.Agent Namespace


ForwardMode Method (IClientChannel, MediaType)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardMode Method (IClientChannel, MediaType)
IAgent Interface See Also Send Feedback
Gets the ForwardMode of the agent according to the channel and the media.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ForwardModeType ForwardMode(
    IClientChannel channel,
    MediaType media
)
Visual Basic (Declaration)
Function ForwardMode ( _
    channel As IClientChannel, _
    media As MediaType _
) As ForwardModeType
Visual C++
ForwardModeType ForwardMode(
    IClientChannel^ channel,
    MediaType media
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.
media
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType
a media used by this agent.

Return Value

the ForwardMode type of this agent.

See Also

IAgent Interface
ForwardMode Overload
Genesyslab.Enterprise.Agent Namespace


ForwardNumber Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardNumber Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
ForwardNumber(IClientChannel) | Gets the Forward number of the agent according to the channel.
ForwardNumber(IDevice) | Gets the Forward number of the agent according to the device.
ForwardNumber(IClientChannel, MediaType) | Gets the Forward number of the agent according to the channel and the media.

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


ForwardNumber Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardNumber Method (IClientChannel)
IAgent Interface See Also Send Feedback
Gets the Forward number of the agent according to the channel.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string ForwardNumber(
    IClientChannel channel
)
Visual Basic (Declaration)
Function ForwardNumber ( _
    channel As IClientChannel _
) As String
Visual C++
String^ ForwardNumber(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.

Return Value

the Forward number of this agent.

See Also

IAgent Interface
ForwardNumber Overload
Genesyslab.Enterprise.Agent Namespace


ForwardNumber Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardNumber Method (IDevice)
IAgent Interface See Also Send Feedback
Gets the Forward number of the agent according to the device.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string ForwardNumber(
    IDevice device
)
Visual Basic (Declaration)
Function ForwardNumber ( _
    device As IDevice _
) As String
Visual C++
String^ ForwardNumber(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
a device of the agent.

Return Value

the Forward number of this agent.

See Also

IAgent Interface
ForwardNumber Overload
Genesyslab.Enterprise.Agent Namespace


ForwardNumber Method (IClientChannel, MediaType)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardNumber Method (IClientChannel, MediaType)
IAgent Interface See Also Send Feedback
Gets the Forward number of the agent according to the channel and the media.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string ForwardNumber(
    IClientChannel channel,
    MediaType media
)
Visual Basic (Declaration)
Function ForwardNumber ( _
    channel As IClientChannel, _
    media As MediaType _
) As String
Visual C++
String^ ForwardNumber(
    IClientChannel^ channel,
    MediaType media
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.
media
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType
a media used by this agent.

Return Value

the Forward number of this agent.

See Also

IAgent Interface
ForwardNumber Overload
Genesyslab.Enterprise.Agent Namespace


ForwardState Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardState Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
ForwardState(IClientChannel) | Gets the ForwardState of the agent according to the channel.
ForwardState(IDevice) | Gets the ForwardState of the agent according to the device.
ForwardState(IClientChannel, MediaType) | Gets the ForwardState of the agent according to the channel and the media.

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


ForwardState Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardState Method (IClientChannel)
IAgent Interface See Also Send Feedback
Gets the ForwardState of the agent according to the channel.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool ForwardState(
    IClientChannel channel
)
Visual Basic (Declaration)
Function ForwardState ( _
    channel As IClientChannel _
) As Boolean
Visual C++
bool ForwardState(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.

Return Value

the ForwardState of this agent.

See Also

IAgent Interface
ForwardState Overload
Genesyslab.Enterprise.Agent Namespace


ForwardState Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardState Method (IDevice)
IAgent Interface See Also Send Feedback
Gets the ForwardState of the agent according to the device.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool ForwardState(
    IDevice device
)
Visual Basic (Declaration)
Function ForwardState ( _
    device As IDevice _
) As Boolean
Visual C++
bool ForwardState(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
a device of the agent.

Return Value

the ForwardState of this agent.

See Also

IAgent Interface
ForwardState Overload
Genesyslab.Enterprise.Agent Namespace


ForwardState Method (IClientChannel, MediaType)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardState Method (IClientChannel, MediaType)
IAgent Interface See Also Send Feedback
Gets the ForwardState of the agent according to the channel and the media.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool ForwardState(
    IClientChannel channel,
    MediaType media
)
Visual Basic (Declaration)
Function ForwardState ( _
    channel As IClientChannel, _
    media As MediaType _
) As Boolean
Visual C++
bool ForwardState(
    IClientChannel^ channel,
    MediaType media
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.
media
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType
a media used by this agent.

Return Value

the ForwardState of this agent.

See Also

IAgent Interface
ForwardState Overload
Genesyslab.Enterprise.Agent Namespace


LastUpdateQueue Method

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.LastUpdateQueue Method
IAgent Interface See Also Send Feedback
Queue modified from the last server update received

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string LastUpdateQueue(
    IClientChannel channel
)
Visual Basic (Declaration)
Function LastUpdateQueue ( _
    channel As IClientChannel _
) As String
Visual C++
String^ LastUpdateQueue(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.

Return Value

string

See Also

IAgent Interface
Genesyslab.Enterprise.Agent Namespace


Queues Method

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.Queues Method
IAgent Interface See Also Send Feedback
Gets the list of Queues on which the agent is logged-in.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string[] Queues(
    IClientChannel channel
)
Visual Basic (Declaration)
Function Queues ( _
    channel As IClientChannel _
) As String()
Visual C++
array<String^>^ Queues(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.

Return Value

the string array of queues.

See Also

IAgent Interface
Genesyslab.Enterprise.Agent Namespace


State Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.State Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
State(IClientChannel) | Gets the AgentState type of the agent according to the channel.
State(IDevice) | Gets the AgentState type of the agent according to the device.
State(IClientChannel, MediaType) | Gets the AgentState type of the agent according to the channel and the media.

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


State Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.State Method (IClientChannel)
IAgent Interface See Also Send Feedback
Gets the AgentState type of the agent according to the channel.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
AgentStateType State(
    IClientChannel channel
)
Visual Basic (Declaration)
Function State ( _
    channel As IClientChannel _
) As AgentStateType
Visual C++
AgentStateType State(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.

Return Value

the AgentState type of this agent.

See Also

IAgent Interface
State Overload
Genesyslab.Enterprise.Agent Namespace


State Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.State Method (IDevice)
IAgent Interface See Also Send Feedback
Gets the AgentState type of the agent according to the device.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
AgentStateType State(
    IDevice device
)
Visual Basic (Declaration)
Function State ( _
    device As IDevice _
) As AgentStateType
Visual C++
AgentStateType State(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
a device of the agent.

Return Value

the AgentState type of this agent.

See Also

IAgent Interface
State Overload
Genesyslab.Enterprise.Agent Namespace


State Method (IClientChannel, MediaType)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.State Method (IClientChannel, MediaType)
IAgent Interface See Also Send Feedback
Gets the AgentState type of the agent according to the channel and the media.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
AgentStateType State(
    IClientChannel channel,
    MediaType media
)
Visual Basic (Declaration)
Function State ( _
    channel As IClientChannel, _
    media As MediaType _
) As AgentStateType
Visual C++
AgentStateType State(
    IClientChannel^ channel,
    MediaType media
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.
media
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType
a media used by this agent.

Return Value

the AgentState type of this agent.

See Also

IAgent Interface
State Overload
Genesyslab.Enterprise.Agent Namespace


WorkModeType Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.WorkModeType Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
WorkModeType(IClientChannel) | Gets the WorkMode type of the agent according to the channel.
WorkModeType(IDevice) | Gets the WorkMode type of the agent according to the device.

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


WorkModeType Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.WorkModeType Method (IClientChannel)
IAgent Interface See Also Send Feedback
Gets the WorkMode type of the agent according to the channel.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
WorkMode WorkModeType(
    IClientChannel channel
)
Visual Basic (Declaration)
Function WorkModeType ( _
    channel As IClientChannel _
) As WorkMode
Visual C++
WorkMode WorkModeType(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.

Return Value

the WorkMode type of this agent.

See Also

IAgent Interface
WorkModeType Overload
Genesyslab.Enterprise.Agent Namespace


WorkModeType Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.WorkModeType Method (IDevice)
IAgent Interface See Also Send Feedback
Gets the WorkMode type of the agent according to the device.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
WorkMode WorkModeType(
    IDevice device
)
Visual Basic (Declaration)
Function WorkModeType ( _
    device As IDevice _
) As WorkMode
Visual C++
WorkMode WorkModeType(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
a device of the agent.

Return Value

the WorkMode type of this agent.

See Also

IAgent Interface
WorkModeType Overload
Genesyslab.Enterprise.Agent Namespace


IAgent Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent Properties
IAgent Interface See Also Send Feedback

The IAgent type exposes the following members.

Properties

Name | Description
Attributes | Dynamic and static data defined for this identity. (Inherited from IIdentity.)
Devices | Collection of associated devices (single or groups). Use IdentityService.SetDevice to associate Device (Inherited from IIdentity.)
FQName | Fully Qualified Name (Unique ID for this object). (Inherited from IIdentity.)
Group | Groups of identities. (Inherited from IIdentity.)
IdentityBase | Gets the Base identity of this identity. (Inherited from IIdentity.)
Item | Gets the property according to its key.
Name | Identity name. (Inherited from IIdentity.)
Role | Gets or sets the role of an object. (Inherited from IRoleable.)
Strategy | Strategies for this identity. (Inherited from IIdentity.)

See Also

IAgent Interface
Genesyslab.Enterprise.Agent Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.Item Property
IAgent Interface See Also Send Feedback
Gets the property according to its key.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object this[
    string key
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    key As String _
) As Object
Visual C++
property Object^ default[String^ key] {
    Object^ get (String^ key);
}

Parameters

key
Type: System..::.String
the key.

Return Value

the property as object.

See Also

IAgent Interface
Genesyslab.Enterprise.Agent Namespace


Genesyslab.Enterprise.Commons Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Commons Namespace
Send Feedback

Interfaces

Interface | Description
IDeepCopy<(Of <(T>)>) | Creates a full copy of an object instance.
IShallowCopy<(Of <(T>)>) | Hanldes a partial copy of the given object.


IDeepCopy(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IDeepCopy<(Of <(T>)>) Interface
Members See Also Send Feedback
Creates a full copy of an object instance.

Namespace: Genesyslab.Enterprise.Commons
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IDeepCopy<T>
Visual Basic (Declaration)
Public Interface IDeepCopy(Of T)
Visual C++
generic<typename T>
public interface class IDeepCopy

Type Parameters

T
the type of data.

See Also

IDeepCopy<(Of <(T>)>) Members
Genesyslab.Enterprise.Commons Namespace


IDeepCopy(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDeepCopy<(Of <(T>)>) Members
IDeepCopy<(Of <(T>)>) Interface Methods See Also Send Feedback

The IDeepCopy<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object.

See Also

IDeepCopy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Commons Namespace


IDeepCopy(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDeepCopy<(Of <(T>)>) Methods
IDeepCopy<(Of <(T>)>) Interface See Also Send Feedback

The IDeepCopy<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object.

See Also

IDeepCopy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Commons Namespace


DeepCopy Method

[image]

Enterprise SDK 8.0 Reference API
IDeepCopy<(Of <(T>)>)..::.DeepCopy Method
IDeepCopy<(Of <(T>)>) Interface See Also Send Feedback
Full copy of an object.

Namespace: Genesyslab.Enterprise.Commons
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
T DeepCopy()
Visual Basic (Declaration)
Function DeepCopy As T
Visual C++
T DeepCopy()

Return Value

Full copy of this object.

See Also

IDeepCopy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Commons Namespace


IShallowCopy(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IShallowCopy<(Of <(T>)>) Interface
Members See Also Send Feedback
Hanldes a partial copy of the given object.

Namespace: Genesyslab.Enterprise.Commons
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IShallowCopy<T>
Visual Basic (Declaration)
Public Interface IShallowCopy(Of T)
Visual C++
generic<typename T>
public interface class IShallowCopy

Type Parameters

T
Object type.

See Also

IShallowCopy<(Of <(T>)>) Members
Genesyslab.Enterprise.Commons Namespace


IShallowCopy(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IShallowCopy<(Of <(T>)>) Members
IShallowCopy<(Of <(T>)>) Interface Methods See Also Send Feedback

The IShallowCopy<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
ShallowCopy | Partial copy of an object.

See Also

IShallowCopy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Commons Namespace


IShallowCopy(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IShallowCopy<(Of <(T>)>) Methods
IShallowCopy<(Of <(T>)>) Interface See Also Send Feedback

The IShallowCopy<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
ShallowCopy | Partial copy of an object.

See Also

IShallowCopy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Commons Namespace


ShallowCopy Method

[image]

Enterprise SDK 8.0 Reference API
IShallowCopy<(Of <(T>)>)..::.ShallowCopy Method
IShallowCopy<(Of <(T>)>) Interface See Also Send Feedback
Partial copy of an object.

Namespace: Genesyslab.Enterprise.Commons
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
T ShallowCopy()
Visual Basic (Declaration)
Function ShallowCopy As T
Visual C++
T ShallowCopy()

Return Value

Shallow copy of this object.

See Also

IShallowCopy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Commons Namespace


Genesyslab.Enterprise.Commons.Collections Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Commons.Collections Namespace
Send Feedback

Classes

Class | Description
KeyValueCollection | Describes a Key-value collection of the Enterprise SDK.
KeyValueCollectionHelper | Converts key-value collections.
NullableInt | Nullable integer.


KeyValueCollection Class

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Class
Members See Also Send Feedback
Describes a Key-value collection of the Enterprise SDK.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[SerializableAttribute]
public class KeyValueCollection : NameObjectCollectionBase,
    ISerializable, IDictionary, ICollection, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class KeyValueCollection _
    Inherits NameObjectCollectionBase _
    Implements ISerializable, IDictionary, ICollection, IEnumerable
Visual C++
[SerializableAttribute]
public ref class KeyValueCollection : public NameObjectCollectionBase,
    ISerializable, IDictionary, ICollection, IEnumerable

Inheritance Hierarchy

System..::.Object
System.Collections.Specialized..::.NameObjectCollectionBase
Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

See Also

KeyValueCollection Members
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollection Members

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Members
KeyValueCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The KeyValueCollection type exposes the following members.

Constructors

Name | Description
KeyValueCollection | Overloaded.

Methods

Name | Description
Add | Overloaded.
Clear | Clears the collection.
Contains | Returns true if the collection contains this key.
ContainsKey | Returns true if the collection contains this key.
CopyTo | Copies a range of key-value pairs into the given destination array, starting from the given index.
Equals | Returns true if the given object is identical to this collection. (Overrides Object..::.Equals(Object).)
Get | Overloaded.
GetAsBinary | Returns the object associated with the given key as a byte array.
GetAsInt | Returns the object associated with the given key as int.
GetAsKeyValueCollection | Returns the object associated with the given key as KeyValueCollection.
GetAsString | Returns the object associated with the given key as string.
GetEnumerator | Gets the dictionary enumerator. (Overrides NameObjectCollectionBase..::.GetEnumerator()()().)
GetHashCode | Returns the collection's hash code. (Overrides Object..::.GetHashCode()()().)
GetKey | Returns the key at the given index.
GetObjectData | (Overrides NameObjectCollectionBase..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValues | Returns the values for this key.
HasKeys | Returns true if the collection has keys.
OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from NameObjectCollectionBase.)
Remove | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllKeys | Returns all the keys of the collection.
AllValues | Returns all the values of the collection.
Count | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
IsFixedSize | Returns true if the collection size is fixed.
IsReadOnly | Returns true if the collection size is read only.
Item | Overloaded.
Keys | Returns all the keys of the collection.
Values | Returns all the values of the collection.

Explicit Interface Implementations

Name | Description
ICollection..::.CopyTo | Copies the entire NameObjectCollectionBase to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from NameObjectCollectionBase.)
IDictionary..::.GetEnumerator | Gets the dictionary enumerator.
ICollection..::.IsSynchronized | Gets a value indicating whether access to the NameObjectCollectionBase object is synchronized (thread safe). (Inherited from NameObjectCollectionBase.)
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the NameObjectCollectionBase object. (Inherited from NameObjectCollectionBase.)

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollection Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Constructor
KeyValueCollection Class See Also Send Feedback

Overload List

Name | Description
KeyValueCollection()()() | Initializes a new instance of the KeyValueCollection class.
KeyValueCollection(KeyValueCollection) | Copies the entries from the specified KeyValueCollection to a new KeyValueCollection with the same initial capacity as the number of copied entries.
KeyValueCollection(IEqualityComparer) | Initializes a new empty instance of the KeyValueCollection class which uses the specified hash code provider and the specified comparer.
KeyValueCollection(Int32) | Initializes a new empty instance of the KeyValueCollection class with the specified initial capacity.
KeyValueCollection(Int32, KeyValueCollection) | Copies the entries from the specified KeyValueCollection to a new KeyValueCollection with the specified initial capacity or the same initial capacity as the number of copied entries, whichever is greater.

See Also

KeyValueCollection Class
KeyValueCollection Members
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollection Constructor

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Constructor
KeyValueCollection Class See Also Send Feedback
Initializes a new instance of the KeyValueCollection class.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public KeyValueCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
KeyValueCollection()

See Also

KeyValueCollection Class
KeyValueCollection Overload
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollection Constructor (KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Constructor (KeyValueCollection)
KeyValueCollection Class See Also Send Feedback
Copies the entries from the specified KeyValueCollection to a new KeyValueCollection with the same initial capacity as the number of copied entries.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public KeyValueCollection(
    KeyValueCollection col
)
Visual Basic (Declaration)
Public Sub New ( _
    col As KeyValueCollection _
)
Visual C++
public:
KeyValueCollection(
    KeyValueCollection^ col
)

Parameters

col
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
The KeyValueCollection to copy into the new KeyValueCollection instance.

See Also

KeyValueCollection Class
KeyValueCollection Overload
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollection Constructor (IEqualityComparer)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Constructor (IEqualityComparer)
KeyValueCollection Class See Also Send Feedback
Initializes a new empty instance of the KeyValueCollection class which uses the specified hash code provider and the specified comparer.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public KeyValueCollection(
    IEqualityComparer comparer
)
Visual Basic (Declaration)
Public Sub New ( _
    comparer As IEqualityComparer _
)
Visual C++
public:
KeyValueCollection(
    IEqualityComparer^ comparer
)

Parameters

comparer
Type: System.Collections..::.IEqualityComparer
The IComparer to use to determine whether two keys are equal.

See Also

KeyValueCollection Class
KeyValueCollection Overload
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollection Constructor (Int32)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Constructor (Int32)
KeyValueCollection Class See Also Send Feedback
Initializes a new empty instance of the KeyValueCollection class with the specified initial capacity.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public KeyValueCollection(
    int capacity
)
Visual Basic (Declaration)
Public Sub New ( _
    capacity As Integer _
)
Visual C++
public:
KeyValueCollection(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
The initial number of entries that the KeyValueCollection can contain.

See Also

KeyValueCollection Class
KeyValueCollection Overload
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollection Constructor (Int32, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Constructor (Int32, KeyValueCollection)
KeyValueCollection Class See Also Send Feedback
Copies the entries from the specified KeyValueCollection to a new KeyValueCollection with the specified initial capacity or the same initial capacity as the number of copied entries, whichever is greater.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public KeyValueCollection(
    int capacity,
    KeyValueCollection col
)
Visual Basic (Declaration)
Public Sub New ( _
    capacity As Integer, _
    col As KeyValueCollection _
)
Visual C++
public:
KeyValueCollection(
    int capacity,
    KeyValueCollection^ col
)

Parameters

capacity
Type: System..::.Int32
The initial number of entries that the KeyValueCollection can contain.
col
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
The KeyValueCollection to copy to the new KeyValueCollection instance.

See Also

KeyValueCollection Class
KeyValueCollection Overload
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollection Methods

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Methods
KeyValueCollection Class See Also Send Feedback

The KeyValueCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Clears the collection.
Contains | Returns true if the collection contains this key.
ContainsKey | Returns true if the collection contains this key.
CopyTo | Copies a range of key-value pairs into the given destination array, starting from the given index.
Equals | Returns true if the given object is identical to this collection. (Overrides Object..::.Equals(Object).)
Get | Overloaded.
GetAsBinary | Returns the object associated with the given key as a byte array.
GetAsInt | Returns the object associated with the given key as int.
GetAsKeyValueCollection | Returns the object associated with the given key as KeyValueCollection.
GetAsString | Returns the object associated with the given key as string.
GetEnumerator | Gets the dictionary enumerator. (Overrides NameObjectCollectionBase..::.GetEnumerator()()().)
GetHashCode | Returns the collection's hash code. (Overrides Object..::.GetHashCode()()().)
GetKey | Returns the key at the given index.
GetObjectData | (Overrides NameObjectCollectionBase..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValues | Returns the values for this key.
HasKeys | Returns true if the collection has keys.
OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from NameObjectCollectionBase.)
Remove | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICollection..::.CopyTo | Copies the entire NameObjectCollectionBase to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from NameObjectCollectionBase.)
IDictionary..::.GetEnumerator | Gets the dictionary enumerator.

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


IDictionary.GetEnumerator Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.IDictionary..::.GetEnumerator Method
KeyValueCollection Class See Also Send Feedback
Gets the dictionary enumerator.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionaryEnumerator IDictionary.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IDictionaryEnumerator
    Implements IDictionary.GetEnumerator
Visual C++
private:
virtual IDictionaryEnumerator^ GetEnumerator() sealed = IDictionary::GetEnumerator

Return Value

IDictionaryEnumerator

Implements

IDictionary..::.GetEnumerator()()()

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method
KeyValueCollection Class See Also Send Feedback

Overload List

Name | Description
Add(KeyValueCollection) | Adds the given key-value pair.
Add(Object) | Adds the given value as a KeyValueCollection.
Add(Object, Object) | Adds the given key-value pair.
Add(String, KeyValueCollection) | Adds the given value with the given key.
Add(String, NullableInt) | Adds the given key-value pair.
Add(String, array<Byte>[]()[]) | Adds the given key-value pair.
Add(String, Int32) | Adds the given key-value pair.
Add(String, Object) | Adds the given key-value pair.
Add(String, String) | Adds the given key-value pair.

See Also

KeyValueCollection Class
KeyValueCollection Members
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method (KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method (KeyValueCollection)
KeyValueCollection Class See Also Send Feedback
Adds the given key-value pair.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Add(
    KeyValueCollection value
)
Visual Basic (Declaration)
Public Sub Add ( _
    value As KeyValueCollection _
)
Visual C++
public:
void Add(
    KeyValueCollection^ value
)

Parameters

value
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
the value.

See Also

KeyValueCollection Class
Add Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method (Object)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method (Object)
KeyValueCollection Class See Also Send Feedback
Adds the given value as a KeyValueCollection.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Add(
    Object value
)
Visual Basic (Declaration)
Public Sub Add ( _
    value As Object _
)
Visual C++
public:
void Add(
    Object^ value
)

Parameters

value
Type: System..::.Object
the value.

See Also

KeyValueCollection Class
Add Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method (Object, Object)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method (Object, Object)
KeyValueCollection Class See Also Send Feedback
Adds the given key-value pair.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Add(
    Object key,
    Object value
)
Visual Basic (Declaration)
Public Sub Add ( _
    key As Object, _
    value As Object _
)
Visual C++
public:
virtual void Add(
    Object^ key,
    Object^ value
) sealed

Parameters

key
Type: System..::.Object
the key of the value.
value
Type: System..::.Object
the value.

Implements

IDictionary..::.Add(Object, Object)

See Also

KeyValueCollection Class
Add Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method (String, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method (String, KeyValueCollection)
KeyValueCollection Class See Also Send Feedback
Adds the given value with the given key.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Add(
    string key,
    KeyValueCollection value
)
Visual Basic (Declaration)
Public Sub Add ( _
    key As String, _
    value As KeyValueCollection _
)
Visual C++
public:
void Add(
    String^ key,
    KeyValueCollection^ value
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
the value.

See Also

KeyValueCollection Class
Add Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method (String, NullableInt)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method (String, NullableInt)
KeyValueCollection Class See Also Send Feedback
Adds the given key-value pair.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Add(
    string key,
    NullableInt value
)
Visual Basic (Declaration)
Public Sub Add ( _
    key As String, _
    value As NullableInt _
)
Visual C++
public:
void Add(
    String^ key,
    NullableInt^ value
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: Genesyslab.Enterprise.Commons.Collections..::.NullableInt
the value.

See Also

KeyValueCollection Class
Add Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method (String, Byte[])

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method (String, array<Byte>[]()[])
KeyValueCollection Class See Also Send Feedback
Adds the given key-value pair.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Add(
    string key,
    byte[] value
)
Visual Basic (Declaration)
Public Sub Add ( _
    key As String, _
    value As Byte() _
)
Visual C++
public:
void Add(
    String^ key,
    array<unsigned char>^ value
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: array< System..::.Byte >[]()[]
the value.

See Also

KeyValueCollection Class
Add Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method (String, Int32)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method (String, Int32)
KeyValueCollection Class See Also Send Feedback
Adds the given key-value pair.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Add(
    string key,
    int value
)
Visual Basic (Declaration)
Public Sub Add ( _
    key As String, _
    value As Integer _
)
Visual C++
public:
void Add(
    String^ key,
    int value
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: System..::.Int32
the value.

See Also

KeyValueCollection Class
Add Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method (String, Object)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method (String, Object)
KeyValueCollection Class See Also Send Feedback
Adds the given key-value pair.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Add(
    string key,
    Object value
)
Visual Basic (Declaration)
Public Sub Add ( _
    key As String, _
    value As Object _
)
Visual C++
public:
void Add(
    String^ key,
    Object^ value
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: System..::.Object
the value.

See Also

KeyValueCollection Class
Add Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method (String, String)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method (String, String)
KeyValueCollection Class See Also Send Feedback
Adds the given key-value pair.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Add(
    string key,
    string value
)
Visual Basic (Declaration)
Public Sub Add ( _
    key As String, _
    value As String _
)
Visual C++
public:
void Add(
    String^ key,
    String^ value
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: System..::.String
the value.

See Also

KeyValueCollection Class
Add Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Clear Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Clear Method
KeyValueCollection Class See Also Send Feedback
Clears the collection.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

IDictionary..::.Clear()()()

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


Contains Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Contains Method
KeyValueCollection Class See Also Send Feedback
Returns true if the collection contains this key.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool Contains(
    Object key
)
Visual Basic (Declaration)
Public Function Contains ( _
    key As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ key
) sealed

Parameters

key
Type: System..::.Object
the key of the value.

Return Value

true if the collection contains this key.

Implements

IDictionary..::.Contains(Object)

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


ContainsKey Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.ContainsKey Method
KeyValueCollection Class See Also Send Feedback
Returns true if the collection contains this key.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool ContainsKey(
    string key
)
Visual Basic (Declaration)
Public Function ContainsKey ( _
    key As String _
) As Boolean
Visual C++
public:
bool ContainsKey(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the value.

Return Value

true if the collection contains this key.

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


CopyTo Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.CopyTo Method
KeyValueCollection Class See Also Send Feedback
Copies a range of key-value pairs into the given destination array, starting from the given index.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void CopyTo(
    Array destination,
    int index
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    destination As Array, _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ destination,
    int index
) sealed

Parameters

destination
Type: System..::.Array
Destination array. If the given index is greater that this destination's length, an ArgumentException exception is thrown.
index
Type: System..::.Int32
Index range to start the copy.

Implements

ICollection..::.CopyTo(Array, Int32)

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


Equals Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Equals Method
KeyValueCollection Class See Also Send Feedback
Returns true if the given object is identical to this collection.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
the object to compare.

Return Value

true if the given object is identical to this collection.

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


Get Method

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Get Method
KeyValueCollection Class See Also Send Feedback

Overload List

Name | Description
Get(Int32) | Returns the object at the given index.
Get(String) | Returns the object associated with the given key.

See Also

KeyValueCollection Class
KeyValueCollection Members
Genesyslab.Enterprise.Commons.Collections Namespace


Get Method (Int32)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Get Method (Int32)
KeyValueCollection Class See Also Send Feedback
Returns the object at the given index.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Object Get(
    int index
)
Visual Basic (Declaration)
Public Function Get ( _
    index As Integer _
) As Object
Visual C++
public:
Object^ Get(
    int index
)

Parameters

index
Type: System..::.Int32
the index.

Return Value

the value at the given index as object.

See Also

KeyValueCollection Class
Get Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Get Method (String)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Get Method (String)
KeyValueCollection Class See Also Send Feedback
Returns the object associated with the given key.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Object Get(
    string key
)
Visual Basic (Declaration)
Public Function Get ( _
    key As String _
) As Object
Visual C++
public:
Object^ Get(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the value.

Return Value

the value as object.

See Also

KeyValueCollection Class
Get Overload
Genesyslab.Enterprise.Commons.Collections Namespace


GetAsBinary Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.GetAsBinary Method
KeyValueCollection Class See Also Send Feedback
Returns the object associated with the given key as a byte array.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public byte[] GetAsBinary(
    string key
)
Visual Basic (Declaration)
Public Function GetAsBinary ( _
    key As String _
) As Byte()
Visual C++
public:
array<unsigned char>^ GetAsBinary(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the value.

Return Value

the value as byte array.

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


GetAsInt Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.GetAsInt Method
KeyValueCollection Class See Also Send Feedback
Returns the object associated with the given key as int.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public int GetAsInt(
    string key
)
Visual Basic (Declaration)
Public Function GetAsInt ( _
    key As String _
) As Integer
Visual C++
public:
int GetAsInt(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the value.

Return Value

the value as int.

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


GetAsKeyValueCollection Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.GetAsKeyValueCollection Method
KeyValueCollection Class See Also Send Feedback
Returns the object associated with the given key as KeyValueCollection.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public KeyValueCollection GetAsKeyValueCollection(
    string key
)
Visual Basic (Declaration)
Public Function GetAsKeyValueCollection ( _
    key As String _
) As KeyValueCollection
Visual C++
public:
KeyValueCollection^ GetAsKeyValueCollection(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the value.

Return Value

the value as KeyValueCollection.

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


GetAsString Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.GetAsString Method
KeyValueCollection Class See Also Send Feedback
Returns the object associated with the given key as string.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string GetAsString(
    string key
)
Visual Basic (Declaration)
Public Function GetAsString ( _
    key As String _
) As String
Visual C++
public:
String^ GetAsString(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the value.

Return Value

the value as string.

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


GetEnumerator Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.GetEnumerator Method
KeyValueCollection Class See Also Send Feedback
Gets the dictionary enumerator.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overrides Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() override

Return Value

IEnumerator

Implements

IEnumerable..::.GetEnumerator()()()
IEnumerable..::.GetEnumerator()()()

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


GetHashCode Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.GetHashCode Method
KeyValueCollection Class See Also Send Feedback
Returns the collection's hash code.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

Collection's hash code as int.

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


GetKey Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.GetKey Method
KeyValueCollection Class See Also Send Feedback
Returns the key at the given index.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string GetKey(
    int index
)
Visual Basic (Declaration)
Public Function GetKey ( _
    index As Integer _
) As String
Visual C++
public:
String^ GetKey(
    int index
)

Parameters

index
Type: System..::.Int32
the index.

Return Value

the value at the given index as string.

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


GetObjectData Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.GetObjectData Method
KeyValueCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo

[Missing <param name="info"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context
Type: System.Runtime.Serialization..::.StreamingContext

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


GetValues Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.GetValues Method
KeyValueCollection Class See Also Send Feedback
Returns the values for this key.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Object[] GetValues(
    string key
)
Visual Basic (Declaration)
Public Function GetValues ( _
    key As String _
) As Object()
Visual C++
public:
array<Object^>^ GetValues(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the value.

Return Value

the value as string.

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


HasKeys Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.HasKeys Method
KeyValueCollection Class See Also Send Feedback
Returns true if the collection has keys.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool HasKeys()
Visual Basic (Declaration)
Public Function HasKeys As Boolean
Visual C++
public:
bool HasKeys()

Return Value

true if the collection has keys.

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


Remove Method

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Remove Method
KeyValueCollection Class See Also Send Feedback

Overload List

Name | Description
Remove(Object) | Removes the given key and associated object.
Remove(String) | Removes the given key and associated object.

See Also

KeyValueCollection Class
KeyValueCollection Members
Genesyslab.Enterprise.Commons.Collections Namespace


Remove Method (Object)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Remove Method (Object)
KeyValueCollection Class See Also Send Feedback
Removes the given key and associated object.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Remove(
    Object key
)
Visual Basic (Declaration)
Public Sub Remove ( _
    key As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ key
) sealed

Parameters

key
Type: System..::.Object
the key of the value.

Implements

IDictionary..::.Remove(Object)

See Also

KeyValueCollection Class
Remove Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Remove Method (String)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Remove Method (String)
KeyValueCollection Class See Also Send Feedback
Removes the given key and associated object.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Remove(
    string key
)
Visual Basic (Declaration)
Public Sub Remove ( _
    key As String _
)
Visual C++
public:
void Remove(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the value.

See Also

KeyValueCollection Class
Remove Overload
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollection Properties

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Properties
KeyValueCollection Class See Also Send Feedback

The KeyValueCollection type exposes the following members.

Properties

Name | Description
AllKeys | Returns all the keys of the collection.
AllValues | Returns all the values of the collection.
Count | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
IsFixedSize | Returns true if the collection size is fixed.
IsReadOnly | Returns true if the collection size is read only.
Item | Overloaded.
Keys | Returns all the keys of the collection.
Values | Returns all the values of the collection.

Explicit Interface Implementations

Name | Description
ICollection..::.IsSynchronized | Gets a value indicating whether access to the NameObjectCollectionBase object is synchronized (thread safe). (Inherited from NameObjectCollectionBase.)
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the NameObjectCollectionBase object. (Inherited from NameObjectCollectionBase.)

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


AllKeys Property

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.AllKeys Property
KeyValueCollection Class See Also Send Feedback
Returns all the keys of the collection.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string[] AllKeys { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllKeys As String()
Visual C++
public:
property array<String^>^ AllKeys {
    array<String^>^ get ();
}

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


AllValues Property

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.AllValues Property
KeyValueCollection Class See Also Send Feedback
Returns all the values of the collection.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Object[] AllValues { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllValues As Object()
Visual C++
public:
property array<Object^>^ AllValues {
    array<Object^>^ get ();
}

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


IsFixedSize Property

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.IsFixedSize Property
KeyValueCollection Class See Also Send Feedback
Returns true if the collection size is fixed.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool IsFixedSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean
Visual C++
public:
virtual property bool IsFixedSize {
    bool get () sealed;
}

Implements

IDictionary..::.IsFixedSize

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


IsReadOnly Property

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.IsReadOnly Property
KeyValueCollection Class See Also Send Feedback
Returns true if the collection size is read only.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

IDictionary..::.IsReadOnly

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


Item Property

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Item Property
KeyValueCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Returns the value associated with the given index.
Item[([(Object])]) | Returns the value associated with the given key.
Item[([(String])]) | Returns the value associated with the given key.

See Also

KeyValueCollection Class
KeyValueCollection Members
Genesyslab.Enterprise.Commons.Collections Namespace


Item Property (Int32)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Item Property (Int32)
KeyValueCollection Class See Also Send Feedback
Returns the value associated with the given index.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Object this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Object
Visual C++
public:
property Object^ default[int index] {
    Object^ get (int index);
}

Parameters

index
Type: System..::.Int32
the index.

Return Value

the value as object.

See Also

KeyValueCollection Class
Item Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Item Property (Object)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Item Property (Object)
KeyValueCollection Class See Also Send Feedback
Returns the value associated with the given key.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Object this[
    Object key
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    key As Object _
) As Object
Visual C++
public:
virtual property Object^ default[Object^ key] {
    Object^ get (Object^ key) sealed;
    void set (Object^ key, Object^ value) sealed;
}

Parameters

key
Type: System..::.Object

Implements

IDictionary..::.Item[([(Object])])

See Also

KeyValueCollection Class
Item Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Item Property (String)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Item Property (String)
KeyValueCollection Class See Also Send Feedback
Returns the value associated with the given key.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Object this[
    string key
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    key As String _
) As Object
Visual C++
public:
property Object^ default[String^ key] {
    Object^ get (String^ key);
    void set (String^ key, Object^ value);
}

Parameters

key
Type: System..::.String

See Also

KeyValueCollection Class
Item Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Keys Property

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Keys Property
KeyValueCollection Class See Also Send Feedback
Returns all the keys of the collection.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ICollection Keys { get; }
Visual Basic (Declaration)
Public ReadOnly Property Keys As ICollection
Visual C++
public:
virtual property ICollection^ Keys {
    ICollection^ get () sealed;
}

Implements

IDictionary..::.Keys

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


Values Property

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Values Property
KeyValueCollection Class See Also Send Feedback
Returns all the values of the collection.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ICollection Values { get; }
Visual Basic (Declaration)
Public ReadOnly Property Values As ICollection
Visual C++
public:
virtual property ICollection^ Values {
    ICollection^ get () sealed;
}

Implements

IDictionary..::.Values

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollectionHelper Class

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollectionHelper Class
Members See Also Send Feedback
Converts key-value collections.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static class KeyValueCollectionHelper
Visual Basic (Declaration)
Public NotInheritable Class KeyValueCollectionHelper
Visual C++
public ref class KeyValueCollectionHelper abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollectionHelper

See Also

KeyValueCollectionHelper Members
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollectionHelper Members

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollectionHelper Members
KeyValueCollectionHelper Class Methods See Also Send Feedback

Methods

Name | Description
ConvertToEnterpriseKeyValueCollection | Overloaded.
ConvertToPSDKKeyValueCollection | Overloaded.

See Also

KeyValueCollectionHelper Class
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollectionHelper Methods

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollectionHelper Methods
KeyValueCollectionHelper Class See Also Send Feedback

Methods

Name | Description
ConvertToEnterpriseKeyValueCollection | Overloaded.
ConvertToPSDKKeyValueCollection | Overloaded.

See Also

KeyValueCollectionHelper Class
Genesyslab.Enterprise.Commons.Collections Namespace


ConvertToEnterpriseKeyValueCollection Method

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollectionHelper..::.ConvertToEnterpriseKeyValueCollection Method
KeyValueCollectionHelper Class See Also Send Feedback

Overload List

Name | Description
ConvertToEnterpriseKeyValueCollection(IAttributeDataManager<(Of <(IDynamicAttribute>)>)) | Converts the given collection of dynamic attributes to the Enterprise SDK format.
ConvertToEnterpriseKeyValueCollection(KeyValueCollection) | Converts the given Platform SDK key-value collection to the Enterprise SDK format.

See Also

KeyValueCollectionHelper Class
KeyValueCollectionHelper Members
Genesyslab.Enterprise.Commons.Collections Namespace


ConvertToEnterpriseKeyValueCollection Method (IAttributeDataManager(IDynamicAttribute))

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollectionHelper..::.ConvertToEnterpriseKeyValueCollection Method (IAttributeDataManager<(Of <(IDynamicAttribute>)>))
KeyValueCollectionHelper Class See Also Send Feedback
Converts the given collection of dynamic attributes to the Enterprise SDK format.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static KeyValueCollection ConvertToEnterpriseKeyValueCollection(
    IAttributeDataManager<IDynamicAttribute> collection
)
Visual Basic (Declaration)
Public Shared Function ConvertToEnterpriseKeyValueCollection ( _
    collection As IAttributeDataManager(Of IDynamicAttribute) _
) As KeyValueCollection
Visual C++
public:
static KeyValueCollection^ ConvertToEnterpriseKeyValueCollection(
    IAttributeDataManager<IDynamicAttribute^>^ collection
)

Parameters

collection
Type: Genesyslab.Enterprise.Model.Interaction..::.IAttributeDataManager <(Of <( IDynamicAttribute >)>)
the collection to convert.

Return Value

the ESDK collection of the input collection.

See Also

KeyValueCollectionHelper Class
ConvertToEnterpriseKeyValueCollection Overload
Genesyslab.Enterprise.Commons.Collections Namespace


ConvertToEnterpriseKeyValueCollection Method ()

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollectionHelper..::.ConvertToEnterpriseKeyValueCollection Method ()
KeyValueCollectionHelper Class See Also Send Feedback
Converts the given Platform SDK key-value collection to the Enterprise SDK format.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static KeyValueCollection ConvertToEnterpriseKeyValueCollection(
    KeyValueCollection collection
)
Visual Basic (Declaration)
Public Shared Function ConvertToEnterpriseKeyValueCollection ( _
    collection As KeyValueCollection _
) As KeyValueCollection
Visual C++
public:
static KeyValueCollection^ ConvertToEnterpriseKeyValueCollection(
    KeyValueCollection^ collection
)

Parameters

collection
Type: KeyValueCollection
the collection to convert.

Return Value

the ESDK collection of the input collection.

See Also

KeyValueCollectionHelper Class
ConvertToEnterpriseKeyValueCollection Overload
Genesyslab.Enterprise.Commons.Collections Namespace


ConvertToPSDKKeyValueCollection Method

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollectionHelper..::.ConvertToPSDKKeyValueCollection Method
KeyValueCollectionHelper Class See Also Send Feedback

Overload List

Name | Description
ConvertToPSDKKeyValueCollection(KeyValueCollection) | Converts the given Enterprise SDK KeyValueCollection to the PSDK format.
ConvertToPSDKKeyValueCollection(IAttributeDataManager<(Of <(IDynamicAttribute>)>)) | Converts the given collection of dynamic attributes to the Platform SDK format.

See Also

KeyValueCollectionHelper Class
KeyValueCollectionHelper Members
Genesyslab.Enterprise.Commons.Collections Namespace


ConvertToPSDKKeyValueCollection Method (KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollectionHelper..::.ConvertToPSDKKeyValueCollection Method (KeyValueCollection)
KeyValueCollectionHelper Class See Also Send Feedback
Converts the given Enterprise SDK KeyValueCollection to the PSDK format.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static KeyValueCollection ConvertToPSDKKeyValueCollection(
    KeyValueCollection collection
)
Visual Basic (Declaration)
Public Shared Function ConvertToPSDKKeyValueCollection ( _
    collection As KeyValueCollection _
) As KeyValueCollection
Visual C++
public:
static KeyValueCollection^ ConvertToPSDKKeyValueCollection(
    KeyValueCollection^ collection
)

Parameters

collection
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Enterprise SDK Collection

Return Value

KeyValueCollection in PSDK Format

See Also

KeyValueCollectionHelper Class
ConvertToPSDKKeyValueCollection Overload
Genesyslab.Enterprise.Commons.Collections Namespace


ConvertToPSDKKeyValueCollection Method (IAttributeDataManager(IDynamicAttribute))

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollectionHelper..::.ConvertToPSDKKeyValueCollection Method (IAttributeDataManager<(Of <(IDynamicAttribute>)>))
KeyValueCollectionHelper Class See Also Send Feedback
Converts the given collection of dynamic attributes to the Platform SDK format.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static KeyValueCollection ConvertToPSDKKeyValueCollection(
    IAttributeDataManager<IDynamicAttribute> collection
)
Visual Basic (Declaration)
Public Shared Function ConvertToPSDKKeyValueCollection ( _
    collection As IAttributeDataManager(Of IDynamicAttribute) _
) As KeyValueCollection
Visual C++
public:
static KeyValueCollection^ ConvertToPSDKKeyValueCollection(
    IAttributeDataManager<IDynamicAttribute^>^ collection
)

Parameters

collection
Type: Genesyslab.Enterprise.Model.Interaction..::.IAttributeDataManager <(Of <( IDynamicAttribute >)>)
the collection to convert.

Return Value

KeyValueCollection in PSDK Format.

See Also

KeyValueCollectionHelper Class
ConvertToPSDKKeyValueCollection Overload
Genesyslab.Enterprise.Commons.Collections Namespace


NullableInt Class

[image]

Enterprise SDK 8.0 Reference API
NullableInt Class
Members See Also Send Feedback
Nullable integer.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public class NullableInt
Visual Basic (Declaration)
Public Class NullableInt
Visual C++
public ref class NullableInt

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Commons.Collections..::.NullableInt

See Also

NullableInt Members
Genesyslab.Enterprise.Commons.Collections Namespace


NullableInt Members

[image] [image]

Enterprise SDK 8.0 Reference API
NullableInt Members
NullableInt Class Constructors Methods See Also Send Feedback

The NullableInt type exposes the following members.

Constructors

Name | Description
NullableInt | Overloaded.

Methods

Name | Description
Equals | Returns true if the given object is identical. (Overrides Object..::.Equals(Object).)
GetHashCode | Returns the hash code of this object. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Overloaded.

Operators

Name | Description
Explicit | Returns the object's int value.
Implicit | Creates a new nullable integer.

See Also

NullableInt Class
Genesyslab.Enterprise.Commons.Collections Namespace


NullableInt Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
NullableInt Constructor
NullableInt Class See Also Send Feedback

Overload List

Name | Description
NullableInt()()() | Constructor.
NullableInt(Int32) | Constructor.

See Also

NullableInt Class
NullableInt Members
Genesyslab.Enterprise.Commons.Collections Namespace


NullableInt Constructor

[image]

Enterprise SDK 8.0 Reference API
NullableInt Constructor
NullableInt Class See Also Send Feedback
Constructor.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public NullableInt()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NullableInt()

See Also

NullableInt Class
NullableInt Overload
Genesyslab.Enterprise.Commons.Collections Namespace


NullableInt Constructor (Int32)

[image]

Enterprise SDK 8.0 Reference API
NullableInt Constructor (Int32)
NullableInt Class See Also Send Feedback
Constructor.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public NullableInt(
    int value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Integer _
)
Visual C++
public:
NullableInt(
    int value
)

Parameters

value
Type: System..::.Int32
the int value.

See Also

NullableInt Class
NullableInt Overload
Genesyslab.Enterprise.Commons.Collections Namespace


NullableInt Methods

[image] [image]

Enterprise SDK 8.0 Reference API
NullableInt Methods
NullableInt Class See Also Send Feedback

The NullableInt type exposes the following members.

Methods

Name | Description
Equals | Returns true if the given object is identical. (Overrides Object..::.Equals(Object).)
GetHashCode | Returns the hash code of this object. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Overloaded.

Operators

Name | Description
Explicit | Returns the object's int value.
Implicit | Creates a new nullable integer.

See Also

NullableInt Class
Genesyslab.Enterprise.Commons.Collections Namespace


Equals Method

[image]

Enterprise SDK 8.0 Reference API
NullableInt..::.Equals Method
NullableInt Class See Also Send Feedback
Returns true if the given object is identical.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
the object to compare with.

Return Value

true if equal, otherwise false.

See Also

NullableInt Class
Genesyslab.Enterprise.Commons.Collections Namespace


Explicit Operator

[image]

Enterprise SDK 8.0 Reference API
NullableInt..::.Explicit Operator
NullableInt Class See Also Send Feedback
Returns the object's int value.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static explicit operator int (
    NullableInt ni
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    ni As NullableInt _
) As Integer
Visual C++
static explicit operator int (
    NullableInt^ ni
)

Parameters

ni
Type: Genesyslab.Enterprise.Commons.Collections..::.NullableInt
the Nullable instance.

Return Value

the int value.

See Also

NullableInt Class
Genesyslab.Enterprise.Commons.Collections Namespace


GetHashCode Method

[image]

Enterprise SDK 8.0 Reference API
NullableInt..::.GetHashCode Method
NullableInt Class See Also Send Feedback
Returns the hash code of this object.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

the hash code.

See Also

NullableInt Class
Genesyslab.Enterprise.Commons.Collections Namespace


Implicit Operator

[image]

Enterprise SDK 8.0 Reference API
NullableInt..::.Implicit Operator
NullableInt Class See Also Send Feedback
Creates a new nullable integer.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static implicit operator NullableInt (
    int value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Integer _
) As NullableInt
Visual C++
static implicit operator NullableInt^ (
    int value
)

Parameters

value
Type: System..::.Int32
the int value.

Return Value

the Nullable instance of the int value.

See Also

NullableInt Class
Genesyslab.Enterprise.Commons.Collections Namespace


ToString Method

[image] [image]

Enterprise SDK 8.0 Reference API
NullableInt..::.ToString Method
NullableInt Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns the object's string code. (Overrides Object..::.ToString()()().)
ToString(IFormatProvider) | Returns the object's string code.
ToString(String) | Returns the object's string code with the given format.
ToString(String, IFormatProvider) | Returns the object's string code with the given format.

See Also

NullableInt Class
NullableInt Members
Genesyslab.Enterprise.Commons.Collections Namespace


ToString Method

[image]

Enterprise SDK 8.0 Reference API
NullableInt..::.ToString Method
NullableInt Class See Also Send Feedback
Returns the object's string code.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

the string value.

See Also

NullableInt Class
ToString Overload
Genesyslab.Enterprise.Commons.Collections Namespace


ToString Method (IFormatProvider)

[image]

Enterprise SDK 8.0 Reference API
NullableInt..::.ToString Method (IFormatProvider)
NullableInt Class See Also Send Feedback
Returns the object's string code.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string ToString(
    IFormatProvider provider
)
Visual Basic (Declaration)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
Visual C++
public:
String^ ToString(
    IFormatProvider^ provider
)

Parameters

provider
Type: System..::.IFormatProvider
the provider.

Return Value

the string value.

See Also

NullableInt Class
ToString Overload
Genesyslab.Enterprise.Commons.Collections Namespace


ToString Method (String)

[image]

Enterprise SDK 8.0 Reference API
NullableInt..::.ToString Method (String)
NullableInt Class See Also Send Feedback
Returns the object's string code with the given format.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string ToString(
    string format
)
Visual Basic (Declaration)
Public Function ToString ( _
    format As String _
) As String
Visual C++
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: System..::.String
the format.

Return Value

the string value.

See Also

NullableInt Class
ToString Overload
Genesyslab.Enterprise.Commons.Collections Namespace


ToString Method (String, IFormatProvider)

[image]

Enterprise SDK 8.0 Reference API
NullableInt..::.ToString Method (String, IFormatProvider)
NullableInt Class See Also Send Feedback
Returns the object's string code with the given format.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string ToString(
    string format,
    IFormatProvider provider
)
Visual Basic (Declaration)
Public Function ToString ( _
    format As String, _
    provider As IFormatProvider _
) As String
Visual C++
public:
String^ ToString(
    String^ format,
    IFormatProvider^ provider
)

Parameters

format
Type: System..::.String
the format.
provider
Type: System..::.IFormatProvider
the provider.

Return Value

the string value.

See Also

NullableInt Class
ToString Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Genesyslab.Enterprise.Core Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Core Namespace
Send Feedback

Classes

Class | Description
Capability | Describes a capability.
InteractionData | Contains interaction data as dynamic attributes.
PayLoadContext | Describes an event and its associated protocol message.
Role | The Role class.

Interfaces

Interface | Description
IDN | Interface for Directory Numbers.


Capability Class

[image]

Enterprise SDK 8.0 Reference API
Capability Class
Members See Also Send Feedback
Describes a capability.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[SerializableAttribute]
public class Capability : ICapability
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Capability _
    Implements ICapability
Visual C++
[SerializableAttribute]
public ref class Capability : ICapability

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Core..::.Capability

See Also

Capability Members
Genesyslab.Enterprise.Core Namespace


Capability Members

[image] [image]

Enterprise SDK 8.0 Reference API
Capability Members
Capability Class Constructors Methods Properties See Also Send Feedback

The Capability type exposes the following members.

Constructors

Name | Description
Capability | Constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | Description of the feature.
Name | Capability name.
State | Capability status (enabled, disabled, or inactive.)
Value | True if the capability is activated in CME.

See Also

Capability Class
Genesyslab.Enterprise.Core Namespace


Capability Constructor

[image]

Enterprise SDK 8.0 Reference API
Capability Constructor
Capability Class See Also Send Feedback
Constructor.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Capability(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
Capability(
    String^ name
)

Parameters

name
Type: System..::.String
the capability name.

See Also

Capability Class
Genesyslab.Enterprise.Core Namespace


Capability Methods

[image] [image]

Enterprise SDK 8.0 Reference API
Capability Methods
Capability Class See Also Send Feedback

The Capability type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Capability Class
Genesyslab.Enterprise.Core Namespace


Capability Properties

[image] [image]

Enterprise SDK 8.0 Reference API
Capability Properties
Capability Class See Also Send Feedback

The Capability type exposes the following members.

Properties

Name | Description
Description | Description of the feature.
Name | Capability name.
State | Capability status (enabled, disabled, or inactive.)
Value | True if the capability is activated in CME.

See Also

Capability Class
Genesyslab.Enterprise.Core Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
Capability..::.Description Property
Capability Class See Also Send Feedback
Description of the feature.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
}

Implements

ICapability..::.Description

See Also

Capability Class
Genesyslab.Enterprise.Core Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
Capability..::.Name Property
Capability Class See Also Send Feedback
Capability name.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

Implements

ICapability..::.Name

See Also

Capability Class
Genesyslab.Enterprise.Core Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
Capability..::.State Property
Capability Class See Also Send Feedback
Capability status (enabled, disabled, or inactive.)

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public StateType State { get; set; }
Visual Basic (Declaration)
Public Property State As StateType
Visual C++
public:
virtual property StateType State {
    StateType get () sealed;
    void set (StateType value) sealed;
}

Implements

ICapability..::.State

See Also

Capability Class
Genesyslab.Enterprise.Core Namespace


Value Property

[image]

Enterprise SDK 8.0 Reference API
Capability..::.Value Property
Capability Class See Also Send Feedback
True if the capability is activated in CME.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Boolean
Visual C++
public:
virtual property bool Value {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ICapability..::.Value

See Also

Capability Class
Genesyslab.Enterprise.Core Namespace


IDN Interface

[image]

Enterprise SDK 8.0 Reference API
IDN Interface
Members See Also Send Feedback
Interface for Directory Numbers.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IDN : IDevice, ISerializable
Visual Basic (Declaration)
Public Interface IDN _
    Implements IDevice, ISerializable
Visual C++
public interface class IDN : IDevice,
    ISerializable

See Also

IDN Members
Genesyslab.Enterprise.Core Namespace


IDN Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDN Members
IDN Interface Methods Properties See Also Send Feedback

The IDN type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

Properties

Name | Description
ActionsTransitions | The list of actions that the application can do with the device. According to events, strategies, and capabilities, this property updates. Some action transitions can be temporarily unavailable according to the object status. For instance, if the device is configured in the CME to accept a single call, and if the device is already busy, you can't create a new call on this device. handling (Inherited from IDevice.)
ActiveChannels | List of active channels for this device. (Inherited from IDevice.)
Attributes | (Inherited from IDevice.)
Capabilities | Capabilities of the device. These capabilities list the features that you can use on the device, for instance sms, fax, e-mail. (Inherited from IDevice.)
Context | The device context, a set of information about the device, such as its location, its peripheral types (mobile phone, iphone), and so on. (Inherited from IDevice.)
Controller | Returns the state controller of the object. (Inherited from IDevice.)
DnAdress | Gets the DnAddress type of the IDN.
DndState | Gets the Do Not Disturb state of the IDN.
ForwardMode | Gets the ForwardMode type of the IDN.
ForwardNumber | Gets the Forward number of the IDN.
ForwardState | Gets the ForwardState of the IDN.
FQName | Fully Qualified Name. This is the unique identifier of the object instance. In the device's particular case, the FQ name follows this syntax: dn@switch_name. (Inherited from IDevice.)
Group | Group of subdevices which compose this device. (Inherited from IDevice.)
HookState | Gets the HookState of the IDN.
Identity | Identity in relation with the device. (Inherited from IDevice.)
IsComposite | Gets the composition status of the IDN.
Item | Gets a property according to its key.
MuteMode | Gets the MuteMode of the IDN.
Name | Name of the object. This name is not always unique, for instance, in multi-tenant configurations, or in multiple switch configurations. (Inherited from IDevice.)
ProtocolRule | Get the switch policy linked to this object
State | Device status. (Inherited from IDevice.)
Strategy | List of stategies handled by the object. (Inherited from IDevice.)
Tenant | Gets the tenant of the IDN.

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


IDN Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDN Methods
IDN Interface See Also Send Feedback

The IDN type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


IDN Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDN Properties
IDN Interface See Also Send Feedback

The IDN type exposes the following members.

Properties

Name | Description
ActionsTransitions | The list of actions that the application can do with the device. According to events, strategies, and capabilities, this property updates. Some action transitions can be temporarily unavailable according to the object status. For instance, if the device is configured in the CME to accept a single call, and if the device is already busy, you can't create a new call on this device. handling (Inherited from IDevice.)
ActiveChannels | List of active channels for this device. (Inherited from IDevice.)
Attributes | (Inherited from IDevice.)
Capabilities | Capabilities of the device. These capabilities list the features that you can use on the device, for instance sms, fax, e-mail. (Inherited from IDevice.)
Context | The device context, a set of information about the device, such as its location, its peripheral types (mobile phone, iphone), and so on. (Inherited from IDevice.)
Controller | Returns the state controller of the object. (Inherited from IDevice.)
DnAdress | Gets the DnAddress type of the IDN.
DndState | Gets the Do Not Disturb state of the IDN.
ForwardMode | Gets the ForwardMode type of the IDN.
ForwardNumber | Gets the Forward number of the IDN.
ForwardState | Gets the ForwardState of the IDN.
FQName | Fully Qualified Name. This is the unique identifier of the object instance. In the device's particular case, the FQ name follows this syntax: dn@switch_name. (Inherited from IDevice.)
Group | Group of subdevices which compose this device. (Inherited from IDevice.)
HookState | Gets the HookState of the IDN.
Identity | Identity in relation with the device. (Inherited from IDevice.)
IsComposite | Gets the composition status of the IDN.
Item | Gets a property according to its key.
MuteMode | Gets the MuteMode of the IDN.
Name | Name of the object. This name is not always unique, for instance, in multi-tenant configurations, or in multiple switch configurations. (Inherited from IDevice.)
ProtocolRule | Get the switch policy linked to this object
State | Device status. (Inherited from IDevice.)
Strategy | List of stategies handled by the object. (Inherited from IDevice.)
Tenant | Gets the tenant of the IDN.

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


DnAdress Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.DnAdress Property
IDN Interface See Also Send Feedback
Gets the DnAddress type of the IDN.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
DnAdressType DnAdress { get; }
Visual Basic (Declaration)
ReadOnly Property DnAdress As DnAdressType
Visual C++
property DnAdressType DnAdress {
    DnAdressType get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


DndState Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.DndState Property
IDN Interface See Also Send Feedback
Gets the Do Not Disturb state of the IDN.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool DndState { get; }
Visual Basic (Declaration)
ReadOnly Property DndState As Boolean
Visual C++
property bool DndState {
    bool get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


ForwardMode Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.ForwardMode Property
IDN Interface See Also Send Feedback
Gets the ForwardMode type of the IDN.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ForwardModeType ForwardMode { get; }
Visual Basic (Declaration)
ReadOnly Property ForwardMode As ForwardModeType
Visual C++
property ForwardModeType ForwardMode {
    ForwardModeType get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


ForwardNumber Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.ForwardNumber Property
IDN Interface See Also Send Feedback
Gets the Forward number of the IDN.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string ForwardNumber { get; }
Visual Basic (Declaration)
ReadOnly Property ForwardNumber As String
Visual C++
property String^ ForwardNumber {
    String^ get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


ForwardState Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.ForwardState Property
IDN Interface See Also Send Feedback
Gets the ForwardState of the IDN.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool ForwardState { get; }
Visual Basic (Declaration)
ReadOnly Property ForwardState As Boolean
Visual C++
property bool ForwardState {
    bool get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


HookState Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.HookState Property
IDN Interface See Also Send Feedback
Gets the HookState of the IDN.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
HookStateType HookState { get; }
Visual Basic (Declaration)
ReadOnly Property HookState As HookStateType
Visual C++
property HookStateType HookState {
    HookStateType get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


IsComposite Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.IsComposite Property
IDN Interface See Also Send Feedback
Gets the composition status of the IDN.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsComposite { get; }
Visual Basic (Declaration)
ReadOnly Property IsComposite As Boolean
Visual C++
property bool IsComposite {
    bool get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.Item Property
IDN Interface See Also Send Feedback
Gets a property according to its key.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object this[
    string key
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    key As String _
) As Object
Visual C++
property Object^ default[String^ key] {
    Object^ get (String^ key);
}

Parameters

key
Type: System..::.String
the key.

Return Value

the object property of the key.

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


MuteMode Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.MuteMode Property
IDN Interface See Also Send Feedback
Gets the MuteMode of the IDN.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
MuteModeType MuteMode { get; }
Visual Basic (Declaration)
ReadOnly Property MuteMode As MuteModeType
Visual C++
property MuteModeType MuteMode {
    MuteModeType get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


ProtocolRule Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.ProtocolRule Property
IDN Interface See Also Send Feedback
Get the switch policy linked to this object

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IProtocolRule ProtocolRule { get; }
Visual Basic (Declaration)
ReadOnly Property ProtocolRule As IProtocolRule
Visual C++
property IProtocolRule^ ProtocolRule {
    IProtocolRule^ get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.Tenant Property
IDN Interface See Also Send Feedback
Gets the tenant of the IDN.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Tenant { get; }
Visual Basic (Declaration)
ReadOnly Property Tenant As String
Visual C++
property String^ Tenant {
    String^ get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


InteractionData Class

[image]

Enterprise SDK 8.0 Reference API
InteractionData Class
Members See Also Send Feedback
Contains interaction data as dynamic attributes.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[SerializableAttribute]
public class InteractionData : IAttributeDataManager<IDynamicAttribute>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class InteractionData _
    Implements IAttributeDataManager(Of IDynamicAttribute)
Visual C++
[SerializableAttribute]
public ref class InteractionData : IAttributeDataManager<IDynamicAttribute^>

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Core..::.InteractionData

See Also

InteractionData Members
Genesyslab.Enterprise.Core Namespace


InteractionData Members

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionData Members
InteractionData Class Constructors Methods Properties See Also Send Feedback

The InteractionData type exposes the following members.

Constructors

Name | Description
InteractionData | Constructor.

Methods

Name | Description
AddElement | Overloaded.
AllValues | Returns all the values.
ContainsKey | Returns true if this object contains the given key.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAsPSDKCollection | Returns the dynamic attributes as a PSDK collection.
GetElementAsBinary | Returns a dynamic attribute as a binary array.
GetElementAsCollection | Returns a dynamic attribute as an integer.
GetElementAsDynamicAttribute | Overloaded.
GetElementAsInt | Returns a dynamic attribute as an integer.
GetElementAsObject | Returns a dynamic attribute as an object.
GetElementAsString | Returns a dynamic attribute as a string.
GetElementType | Gets the value type of the attribute.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsElementACollection | Overloaded.
IsSynchronized | Gets the synchronized status of an attribute.
RemoveAll | Removes all values.
RemoveElement | Removes a value.
SetElement | Overloaded.
SetElementAsDynamicAttribute | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllKeys | Return all the keys.
Item | Overloaded.
Owner | A pointer to the ultimate client class of the InteractionData or PropertyBag.
Section | The name of the InteractionData.

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


InteractionData Constructor

[image]

Enterprise SDK 8.0 Reference API
InteractionData Constructor
InteractionData Class See Also Send Feedback
Constructor.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public InteractionData(
    string section,
    Object owner
)
Visual Basic (Declaration)
Public Sub New ( _
    section As String, _
    owner As Object _
)
Visual C++
public:
InteractionData(
    String^ section,
    Object^ owner
)

Parameters

section
Type: System..::.String
Section name.
owner
Type: System..::.Object
Reference to the instance owner.

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


InteractionData Methods

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionData Methods
InteractionData Class See Also Send Feedback

The InteractionData type exposes the following members.

Methods

Name | Description
AddElement | Overloaded.
AllValues | Returns all the values.
ContainsKey | Returns true if this object contains the given key.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAsPSDKCollection | Returns the dynamic attributes as a PSDK collection.
GetElementAsBinary | Returns a dynamic attribute as a binary array.
GetElementAsCollection | Returns a dynamic attribute as an integer.
GetElementAsDynamicAttribute | Overloaded.
GetElementAsInt | Returns a dynamic attribute as an integer.
GetElementAsObject | Returns a dynamic attribute as an object.
GetElementAsString | Returns a dynamic attribute as a string.
GetElementType | Gets the value type of the attribute.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsElementACollection | Overloaded.
IsSynchronized | Gets the synchronized status of an attribute.
RemoveAll | Removes all values.
RemoveElement | Removes a value.
SetElement | Overloaded.
SetElementAsDynamicAttribute | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


AddElement Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionData..::.AddElement Method
InteractionData Class See Also Send Feedback

Overload List

Name | Description
AddElement(IDynamicAttribute) | Add a dynamic value.
AddElement(String, IAttributeDataManager<(Of <(IDynamicAttribute>)>)) | Add a dynamic value.

See Also

InteractionData Class
InteractionData Members
Genesyslab.Enterprise.Core Namespace


AddElement Method (IDynamicAttribute)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.AddElement Method (IDynamicAttribute)
InteractionData Class See Also Send Feedback
Add a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> AddElement(
    IDynamicAttribute value
)
Visual Basic (Declaration)
Public Function AddElement ( _
    value As IDynamicAttribute _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ AddElement(
    IDynamicAttribute^ value
) sealed

Parameters

value
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IDynamicAttribute
the attribute value to add.

Return Value

the collection of attributes.

Implements

IAttributeDataManager<(Of <(T>)>)..::.AddElement(IDynamicAttribute)

See Also

InteractionData Class
AddElement Overload
Genesyslab.Enterprise.Core Namespace


AddElement Method (String, IAttributeDataManager(IDynamicAttribute))

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.AddElement Method (String, IAttributeDataManager<(Of <(IDynamicAttribute>)>))
InteractionData Class See Also Send Feedback
Add a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> AddElement(
    string key,
    IAttributeDataManager<IDynamicAttribute> list
)
Visual Basic (Declaration)
Public Function AddElement ( _
    key As String, _
    list As IAttributeDataManager(Of IDynamicAttribute) _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ AddElement(
    String^ key,
    IAttributeDataManager<IDynamicAttribute^>^ list
) sealed

Parameters

key
Type: System..::.String
the key.
list
Type: Genesyslab.Enterprise.Model.Interaction..::.IAttributeDataManager <(Of <( IDynamicAttribute >)>)
the collection of value.

Return Value

the collection of attributes.

Implements

IAttributeDataManager<(Of <(T>)>)..::.AddElement(String, IAttributeDataManager<(Of <(T>)>))

See Also

InteractionData Class
AddElement Overload
Genesyslab.Enterprise.Core Namespace


AllValues Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.AllValues Method
InteractionData Class See Also Send Feedback
Returns all the values.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IDynamicAttribute[] AllValues()
Visual Basic (Declaration)
Public Function AllValues As IDynamicAttribute()
Visual C++
public:
virtual array<IDynamicAttribute^>^ AllValues() sealed

Return Value

an array of attributes.

Implements

IAttributeDataManager<(Of <(T>)>)..::.AllValues()()()

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


ContainsKey Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.ContainsKey Method
InteractionData Class See Also Send Feedback
Returns true if this object contains the given key.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool ContainsKey(
    string key
)
Visual Basic (Declaration)
Public Function ContainsKey ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool ContainsKey(
    String^ key
) sealed

Parameters

key
Type: System..::.String
the key of the attribute.

Return Value

true if the key exists, false otherwise.

Implements

IAttributeDataManager<(Of <(T>)>)..::.ContainsKey(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


GetAsPSDKCollection Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.GetAsPSDKCollection Method
InteractionData Class See Also Send Feedback
Returns the dynamic attributes as a PSDK collection.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public KeyValueCollection GetAsPSDKCollection()
Visual Basic (Declaration)
Public Function GetAsPSDKCollection As KeyValueCollection
Visual C++
public:
virtual KeyValueCollection^ GetAsPSDKCollection() sealed

Return Value

a PSDK collection.

Implements

IAttributeDataManager<(Of <(T>)>)..::.GetAsPSDKCollection()()()

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


GetElementAsBinary Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.GetElementAsBinary Method
InteractionData Class See Also Send Feedback
Returns a dynamic attribute as a binary array.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public byte[] GetElementAsBinary(
    string key
)
Visual Basic (Declaration)
Public Function GetElementAsBinary ( _
    key As String _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ GetElementAsBinary(
    String^ key
) sealed

Parameters

key
Type: System..::.String
the key of the attribute.

Return Value

the value as a byte array.

Implements

IAttributeDataManager<(Of <(T>)>)..::.GetElementAsBinary(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


GetElementAsCollection Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.GetElementAsCollection Method
InteractionData Class See Also Send Feedback
Returns a dynamic attribute as an integer.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> GetElementAsCollection(
    string key
)
Visual Basic (Declaration)
Public Function GetElementAsCollection ( _
    key As String _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ GetElementAsCollection(
    String^ key
) sealed

Parameters

key
Type: System..::.String
the key of the attribute.

Return Value

the collection of attributes.

Implements

IAttributeDataManager<(Of <(T>)>)..::.GetElementAsCollection(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


GetElementAsDynamicAttribute Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionData..::.GetElementAsDynamicAttribute Method
InteractionData Class See Also Send Feedback

Overload List

Name | Description
GetElementAsDynamicAttribute(Int32) | Gets the dynamic attribute that is set at the given index.
GetElementAsDynamicAttribute(String) | Returns a dynamic attribute.

See Also

InteractionData Class
InteractionData Members
Genesyslab.Enterprise.Core Namespace


GetElementAsDynamicAttribute Method (Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.GetElementAsDynamicAttribute Method (Int32)
InteractionData Class See Also Send Feedback
Gets the dynamic attribute that is set at the given index.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IDynamicAttribute GetElementAsDynamicAttribute(
    int index
)
Visual Basic (Declaration)
Public Function GetElementAsDynamicAttribute ( _
    index As Integer _
) As IDynamicAttribute
Visual C++
public:
virtual IDynamicAttribute^ GetElementAsDynamicAttribute(
    int index
) sealed

Parameters

index
Type: System..::.Int32
the index.

Return Value

the dynamic attribute set at the index or null if not found.

Implements

IAttributeDataManager<(Of <(T>)>)..::.GetElementAsDynamicAttribute(Int32)

See Also

InteractionData Class
GetElementAsDynamicAttribute Overload
Genesyslab.Enterprise.Core Namespace


GetElementAsDynamicAttribute Method (String)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.GetElementAsDynamicAttribute Method (String)
InteractionData Class See Also Send Feedback
Returns a dynamic attribute.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IDynamicAttribute GetElementAsDynamicAttribute(
    string key
)
Visual Basic (Declaration)
Public Function GetElementAsDynamicAttribute ( _
    key As String _
) As IDynamicAttribute
Visual C++
public:
virtual IDynamicAttribute^ GetElementAsDynamicAttribute(
    String^ key
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.GetElementAsDynamicAttribute(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.GetElementAsDynamicAttribute(System.String)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.GetElementAsDynamicAttribute(String)

See Also

InteractionData Class
GetElementAsDynamicAttribute Overload
Genesyslab.Enterprise.Core Namespace


GetElementAsInt Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.GetElementAsInt Method
InteractionData Class See Also Send Feedback
Returns a dynamic attribute as an integer.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Nullable<int> GetElementAsInt(
    string key
)
Visual Basic (Declaration)
Public Function GetElementAsInt ( _
    key As String _
) As Nullable(Of Integer)
Visual C++
public:
virtual Nullable<int> GetElementAsInt(
    String^ key
) sealed

Parameters

key
Type: System..::.String
the key of the attribute.

Return Value

the value of the attribute as Nullable instance.

Implements

IAttributeDataManager<(Of <(T>)>)..::.GetElementAsInt(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


GetElementAsObject Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.GetElementAsObject Method
InteractionData Class See Also Send Feedback
Returns a dynamic attribute as an object.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Object GetElementAsObject(
    string key
)
Visual Basic (Declaration)
Public Function GetElementAsObject ( _
    key As String _
) As Object
Visual C++
public:
virtual Object^ GetElementAsObject(
    String^ key
) sealed

Parameters

key
Type: System..::.String
the key of the attribute.

Return Value

the value of the attribute as object.

Implements

IAttributeDataManager<(Of <(T>)>)..::.GetElementAsObject(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


GetElementAsString Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.GetElementAsString Method
InteractionData Class See Also Send Feedback
Returns a dynamic attribute as a string.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string GetElementAsString(
    string key
)
Visual Basic (Declaration)
Public Function GetElementAsString ( _
    key As String _
) As String
Visual C++
public:
virtual String^ GetElementAsString(
    String^ key
) sealed

Parameters

key
Type: System..::.String
the key of the attribute.

Return Value

the value of the attribute as string.

Implements

IAttributeDataManager<(Of <(T>)>)..::.GetElementAsString(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


GetElementType Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.GetElementType Method
InteractionData Class See Also Send Feedback
Gets the value type of the attribute.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Type GetElementType(
    string key
)
Visual Basic (Declaration)
Public Function GetElementType ( _
    key As String _
) As Type
Visual C++
public:
virtual Type^ GetElementType(
    String^ key
) sealed

Parameters

key
Type: System..::.String
the key of the attribute.

Return Value

the Type of the value.

Implements

IAttributeDataManager<(Of <(T>)>)..::.GetElementType(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


IsElementACollection Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionData..::.IsElementACollection Method
InteractionData Class See Also Send Feedback

Overload List

Name | Description
IsElementACollection(Int32) | Returns true if the value for the given index is a collection.
IsElementACollection(String) | Returns true if the value for the given key is a collection.

See Also

InteractionData Class
InteractionData Members
Genesyslab.Enterprise.Core Namespace


IsElementACollection Method (Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.IsElementACollection Method (Int32)
InteractionData Class See Also Send Feedback
Returns true if the value for the given index is a collection.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool IsElementACollection(
    int index
)
Visual Basic (Declaration)
Public Function IsElementACollection ( _
    index As Integer _
) As Boolean
Visual C++
public:
virtual bool IsElementACollection(
    int index
) sealed

Parameters

index
Type: System..::.Int32
the index.

Return Value

true if the value at the given index is a collection, false otherwise.

Implements

IAttributeDataManager<(Of <(T>)>)..::.IsElementACollection(Int32)

See Also

InteractionData Class
IsElementACollection Overload
Genesyslab.Enterprise.Core Namespace


IsElementACollection Method (String)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.IsElementACollection Method (String)
InteractionData Class See Also Send Feedback
Returns true if the value for the given key is a collection.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool IsElementACollection(
    string key
)
Visual Basic (Declaration)
Public Function IsElementACollection ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool IsElementACollection(
    String^ key
) sealed

Parameters

key
Type: System..::.String
the key of the attribute.

Return Value

true if the value at the given index is a collection, false otherwise.

Implements

IAttributeDataManager<(Of <(T>)>)..::.IsElementACollection(String)

See Also

InteractionData Class
IsElementACollection Overload
Genesyslab.Enterprise.Core Namespace


IsSynchronized Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.IsSynchronized Method
InteractionData Class See Also Send Feedback
Gets the synchronized status of an attribute.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool IsSynchronized(
    string key
)
Visual Basic (Declaration)
Public Function IsSynchronized ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool IsSynchronized(
    String^ key
) sealed

Parameters

key
Type: System..::.String
the key of the attribute.

Return Value

true if the attribute is synchronized, false otherwise.

Implements

IAttributeDataManager<(Of <(T>)>)..::.IsSynchronized(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


RemoveAll Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.RemoveAll Method
InteractionData Class See Also Send Feedback
Removes all values.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void RemoveAll()
Visual Basic (Declaration)
Public Sub RemoveAll
Visual C++
public:
virtual void RemoveAll() sealed

Implements

IAttributeDataManager<(Of <(T>)>)..::.RemoveAll()()()

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


RemoveElement Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.RemoveElement Method
InteractionData Class See Also Send Feedback
Removes a value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool RemoveElement(
    string key
)
Visual Basic (Declaration)
Public Function RemoveElement ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool RemoveElement(
    String^ key
) sealed

Parameters

key
Type: System..::.String
the key of the attribute.

Return Value

true if remove operation is successfull, false otherwise.

Implements

IAttributeDataManager<(Of <(T>)>)..::.RemoveElement(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


SetElement Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method
InteractionData Class See Also Send Feedback

Overload List

Name | Description
SetElement(IDynamicAttribute) | Sets a dynamic value.
SetElement(String, IAttributeDataManager<(Of <(IDynamicAttribute>)>)) | Sets a dynamic value.
SetElement(String, array<Byte>[]()[]) | Sets a dynamic value.
SetElement(String, Int32) | Sets a dynamic value.
SetElement(String, Object) | Sets a dynamic value.
SetElement(String, String) | Sets a dynamic value.
SetElement(String, array<Byte>[]()[], String, String) | Sets a dynamic value.
SetElement(String, Object, String, String) | Sets a dynamic value.
SetElement(String, String, String, String) | Sets a dynamic value.

See Also

InteractionData Class
InteractionData Members
Genesyslab.Enterprise.Core Namespace


SetElement Method (IDynamicAttribute)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method (IDynamicAttribute)
InteractionData Class See Also Send Feedback
Sets a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElement(
    IDynamicAttribute value
)
Visual Basic (Declaration)
Public Function SetElement ( _
    value As IDynamicAttribute _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElement(
    IDynamicAttribute^ value
) sealed

Parameters

value
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IDynamicAttribute
the dynamic attribute to set.

Return Value

the collection itself.

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElement(T)

See Also

InteractionData Class
SetElement Overload
Genesyslab.Enterprise.Core Namespace


SetElement Method (String, IAttributeDataManager(IDynamicAttribute))

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method (String, IAttributeDataManager<(Of <(IDynamicAttribute>)>))
InteractionData Class See Also Send Feedback
Sets a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElement(
    string key,
    IAttributeDataManager<IDynamicAttribute> value
)
Visual Basic (Declaration)
Public Function SetElement ( _
    key As String, _
    value As IAttributeDataManager(Of IDynamicAttribute) _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElement(
    String^ key,
    IAttributeDataManager<IDynamicAttribute^>^ value
) sealed

Parameters

key
Type: System..::.String
the key of the attribute.
value
Type: Genesyslab.Enterprise.Model.Interaction..::.IAttributeDataManager <(Of <( IDynamicAttribute >)>)
the value of the attribute.

Return Value

the collection itself.

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElement(String, IAttributeDataManager<(Of <(T>)>))

See Also

InteractionData Class
SetElement Overload
Genesyslab.Enterprise.Core Namespace


SetElement Method (String, Byte[])

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method (String, array<Byte>[]()[])
InteractionData Class See Also Send Feedback
Sets a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElement(
    string key,
    byte[] value
)
Visual Basic (Declaration)
Public Function SetElement ( _
    key As String, _
    value As Byte() _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElement(
    String^ key,
    array<unsigned char>^ value
) sealed

Parameters

key
Type: System..::.String
the key of the attribute.
value
Type: array< System..::.Byte >[]()[]
the value of the attribute.

Return Value

the collection itself.

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElement(String, array<Byte>[]()[])

See Also

InteractionData Class
SetElement Overload
Genesyslab.Enterprise.Core Namespace


SetElement Method (String, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method (String, Int32)
InteractionData Class See Also Send Feedback
Sets a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElement(
    string key,
    int value
)
Visual Basic (Declaration)
Public Function SetElement ( _
    key As String, _
    value As Integer _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElement(
    String^ key,
    int value
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Int32)"]

value
Type: System..::.Int32

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Int32)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElement(String, Int32)

See Also

InteractionData Class
SetElement Overload
Genesyslab.Enterprise.Core Namespace


SetElement Method (String, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method (String, Object)
InteractionData Class See Also Send Feedback
Sets a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElement(
    string key,
    Object value
)
Visual Basic (Declaration)
Public Function SetElement ( _
    key As String, _
    value As Object _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElement(
    String^ key,
    Object^ value
) sealed

Parameters

key
Type: System..::.String
the key of the attribute.
value
Type: System..::.Object
the value of the attribute.

Return Value

the collection itself.

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElement(String, Object)

See Also

InteractionData Class
SetElement Overload
Genesyslab.Enterprise.Core Namespace


SetElement Method (String, String)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method (String, String)
InteractionData Class See Also Send Feedback
Sets a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElement(
    string key,
    string value
)
Visual Basic (Declaration)
Public Function SetElement ( _
    key As String, _
    value As String _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElement(
    String^ key,
    String^ value
) sealed

Parameters

key
Type: System..::.String
the key of the attribute.
value
Type: System..::.String
the value of the attribute.

Return Value

the collection itself.

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElement(String, String)

See Also

InteractionData Class
SetElement Overload
Genesyslab.Enterprise.Core Namespace


SetElement Method (String, Byte[], String, String)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method (String, array<Byte>[]()[], String, String)
InteractionData Class See Also Send Feedback
Sets a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElement(
    string key,
    byte[] value,
    string contentType,
    string contentTypeVersion
)
Visual Basic (Declaration)
Public Function SetElement ( _
    key As String, _
    value As Byte(), _
    contentType As String, _
    contentTypeVersion As String _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElement(
    String^ key,
    array<unsigned char>^ value,
    String^ contentType,
    String^ contentTypeVersion
) sealed

Parameters

key
Type: System..::.String
the key of the attribute.
value
Type: array< System..::.Byte >[]()[]
the value of the attribute.
contentType
Type: System..::.String
the content type of the attribute.
contentTypeVersion
Type: System..::.String
the content type version of the attribute.

Return Value

the collection itself.

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElement(String, array<Byte>[]()[], String, String)

See Also

InteractionData Class
SetElement Overload
Genesyslab.Enterprise.Core Namespace


SetElement Method (String, Object, String, String)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method (String, Object, String, String)
InteractionData Class See Also Send Feedback
Sets a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElement(
    string key,
    Object value,
    string contentType,
    string contentTypeVersion
)
Visual Basic (Declaration)
Public Function SetElement ( _
    key As String, _
    value As Object, _
    contentType As String, _
    contentTypeVersion As String _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElement(
    String^ key,
    Object^ value,
    String^ contentType,
    String^ contentTypeVersion
) sealed

Parameters

key
Type: System..::.String
the key of the attribute.
value
Type: System..::.Object
the value of the attribute.
contentType
Type: System..::.String
the content type of the attribute.
contentTypeVersion
Type: System..::.String
the content type version of the attribute.

Return Value

the collection itself.

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElement(String, Object, String, String)

See Also

InteractionData Class
SetElement Overload
Genesyslab.Enterprise.Core Namespace


SetElement Method (String, String, String, String)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method (String, String, String, String)
InteractionData Class See Also Send Feedback
Sets a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElement(
    string key,
    string value,
    string contentType,
    string contentTypeVersion
)
Visual Basic (Declaration)
Public Function SetElement ( _
    key As String, _
    value As String, _
    contentType As String, _
    contentTypeVersion As String _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElement(
    String^ key,
    String^ value,
    String^ contentType,
    String^ contentTypeVersion
) sealed

Parameters

key
Type: System..::.String
the key of the attribute.
value
Type: System..::.String
the value of the attribute.
contentType
Type: System..::.String
the content type of the attribute.
contentTypeVersion
Type: System..::.String
the content type version of the attribute.

Return Value

the collection itself.

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElement(String, String, String, String)

See Also

InteractionData Class
SetElement Overload
Genesyslab.Enterprise.Core Namespace


SetElementAsDynamicAttribute Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElementAsDynamicAttribute Method
InteractionData Class See Also Send Feedback

Overload List

Name | Description
SetElementAsDynamicAttribute(Int32, IDynamicAttribute) | Sets a dynamic attribute at the given index.
SetElementAsDynamicAttribute(Int32, IAttributeDataManager<(Of <(IDynamicAttribute>)>)) | Sets a dynamic attribute collection at the given index.

See Also

InteractionData Class
InteractionData Members
Genesyslab.Enterprise.Core Namespace


SetElementAsDynamicAttribute Method (Int32, IDynamicAttribute)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElementAsDynamicAttribute Method (Int32, IDynamicAttribute)
InteractionData Class See Also Send Feedback
Sets a dynamic attribute at the given index.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElementAsDynamicAttribute(
    int index,
    IDynamicAttribute data
)
Visual Basic (Declaration)
Public Function SetElementAsDynamicAttribute ( _
    index As Integer, _
    data As IDynamicAttribute _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElementAsDynamicAttribute(
    int index,
    IDynamicAttribute^ data
) sealed

Parameters

index
Type: System..::.Int32
the index.
data
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IDynamicAttribute
the dynamic attribute.

Return Value

the collection itself.

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElementAsDynamicAttribute(Int32, T)

See Also

InteractionData Class
SetElementAsDynamicAttribute Overload
Genesyslab.Enterprise.Core Namespace


SetElementAsDynamicAttribute Method (Int32, IAttributeDataManager(IDynamicAttribute))

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElementAsDynamicAttribute Method (Int32, IAttributeDataManager<(Of <(IDynamicAttribute>)>))
InteractionData Class See Also Send Feedback
Sets a dynamic attribute collection at the given index.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElementAsDynamicAttribute(
    int index,
    IAttributeDataManager<IDynamicAttribute> list
)
Visual Basic (Declaration)
Public Function SetElementAsDynamicAttribute ( _
    index As Integer, _
    list As IAttributeDataManager(Of IDynamicAttribute) _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElementAsDynamicAttribute(
    int index,
    IAttributeDataManager<IDynamicAttribute^>^ list
) sealed

Parameters

index
Type: System..::.Int32
the index.
list
Type: Genesyslab.Enterprise.Model.Interaction..::.IAttributeDataManager <(Of <( IDynamicAttribute >)>)
the collection of dynamic attributes.

Return Value

the collection itself (fluent API).

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElementAsDynamicAttribute(Int32, T)

See Also

InteractionData Class
SetElementAsDynamicAttribute Overload
Genesyslab.Enterprise.Core Namespace


InteractionData Properties

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionData Properties
InteractionData Class See Also Send Feedback

The InteractionData type exposes the following members.

Properties

Name | Description
AllKeys | Return all the keys.
Item | Overloaded.
Owner | A pointer to the ultimate client class of the InteractionData or PropertyBag.
Section | The name of the InteractionData.

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


AllKeys Property

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.AllKeys Property
InteractionData Class See Also Send Feedback
Return all the keys.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string[] AllKeys { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllKeys As String()
Visual C++
public:
virtual property array<String^>^ AllKeys {
    array<String^>^ get () sealed;
}

Implements

IAttributeDataManager<(Of <(T>)>)..::.AllKeys

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


Item Property

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionData..::.Item Property
InteractionData Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) |
Item[([(String])]) | Array of dynamic attributes.

See Also

InteractionData Class
InteractionData Members
Genesyslab.Enterprise.Core Namespace


Item Property (Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.Item Property (Int32)
InteractionData Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Core.InteractionData.Item(System.Int32)"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IDynamicAttribute this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As IDynamicAttribute
Visual C++
public:
virtual property IDynamicAttribute^ default[int index] {
    IDynamicAttribute^ get (int index) sealed;
}

Parameters

index
Type: System..::.Int32

Implements

IAttributeDataManager<(Of <(T>)>)..::.Item[([(Int32])])

See Also

InteractionData Class
Item Overload
Genesyslab.Enterprise.Core Namespace


Item Property (String)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.Item Property (String)
InteractionData Class See Also Send Feedback
Array of dynamic attributes.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IDynamicAttribute this[
    string key
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    key As String _
) As IDynamicAttribute
Visual C++
public:
virtual property IDynamicAttribute^ default[String^ key] {
    IDynamicAttribute^ get (String^ key) sealed;
}

Parameters

key
Type: System..::.String

Return Value

Implements

IAttributeDataManager<(Of <(T>)>)..::.Item[([(String])])

See Also

InteractionData Class
Item Overload
Genesyslab.Enterprise.Core Namespace


Owner Property

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.Owner Property
InteractionData Class See Also Send Feedback
A pointer to the ultimate client class of the InteractionData or PropertyBag.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Object Owner { get; }
Visual Basic (Declaration)
Public ReadOnly Property Owner As Object
Visual C++
public:
virtual property Object^ Owner {
    Object^ get () sealed;
}

Implements

IAttributeDataManager<(Of <(T>)>)..::.Owner

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


Section Property

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.Section Property
InteractionData Class See Also Send Feedback
The name of the InteractionData.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string Section { get; }
Visual Basic (Declaration)
Public ReadOnly Property Section As String
Visual C++
public:
virtual property String^ Section {
    String^ get () sealed;
}

Implements

IAttributeDataManager<(Of <(T>)>)..::.Section

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


PayLoadContext Class

[image]

Enterprise SDK 8.0 Reference API
PayLoadContext Class
Members See Also Send Feedback
Describes an event and its associated protocol message.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[SerializableAttribute]
public class PayLoadContext : IPayLoadContext
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class PayLoadContext _
    Implements IPayLoadContext
Visual C++
[SerializableAttribute]
public ref class PayLoadContext : IPayLoadContext

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Core..::.PayLoadContext

See Also

PayLoadContext Members
Genesyslab.Enterprise.Core Namespace


PayLoadContext Members

[image] [image]

Enterprise SDK 8.0 Reference API
PayLoadContext Members
PayLoadContext Class Constructors Methods Properties See Also Send Feedback

The PayLoadContext type exposes the following members.

Constructors

Name | Description
PayLoadContext | Creates the payload object.

Methods

Name | Description
DeepCopy | Complete copy of the object Msg property is not copied though, for performance issue
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ShallowCopy | Partial copy of the object
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ContextState | Get state type of event: Unknown, Created, Updated, Merged, Deleted, Error,
msg | Get raw PSDK message
Reason | Get reason of event update
TimeStamp | Get time stamp of object creation

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


PayLoadContext Constructor

[image]

Enterprise SDK 8.0 Reference API
PayLoadContext Constructor
PayLoadContext Class See Also Send Feedback
Creates the payload object.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public PayLoadContext(
    IMessage msg,
    ContextStateType contextStateType,
    ReasonTypes reason
)
Visual Basic (Declaration)
Public Sub New ( _
    msg As IMessage, _
    contextStateType As ContextStateType, _
    reason As ReasonTypes _
)
Visual C++
public:
PayLoadContext(
    IMessage^ msg,
    ContextStateType contextStateType,
    ReasonTypes reason
)

Parameters

msg
Type: IMessage
the raw associated PSDK message.
contextStateType
Type: Genesyslab.Enterprise.Model.Interaction..::.ContextStateType
the state type of this payload.
reason
Type: Genesyslab.Enterprise.Model.Interaction..::.ReasonTypes
the reason of this event update.

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


PayLoadContext Methods

[image] [image]

Enterprise SDK 8.0 Reference API
PayLoadContext Methods
PayLoadContext Class See Also Send Feedback

The PayLoadContext type exposes the following members.

Methods

Name | Description
DeepCopy | Complete copy of the object Msg property is not copied though, for performance issue
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ShallowCopy | Partial copy of the object
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


DeepCopy Method

[image]

Enterprise SDK 8.0 Reference API
PayLoadContext..::.DeepCopy Method
PayLoadContext Class See Also Send Feedback
Complete copy of the object Msg property is not copied though, for performance issue

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IPayLoadContext DeepCopy()
Visual Basic (Declaration)
Public Function DeepCopy As IPayLoadContext
Visual C++
public:
virtual IPayLoadContext^ DeepCopy() sealed

Return Value

the full copy of this object (except Msg property).

Implements

IDeepCopy<(Of <(T>)>)..::.DeepCopy()()()

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


ShallowCopy Method

[image]

Enterprise SDK 8.0 Reference API
PayLoadContext..::.ShallowCopy Method
PayLoadContext Class See Also Send Feedback
Partial copy of the object

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IPayLoadContext ShallowCopy()
Visual Basic (Declaration)
Public Function ShallowCopy As IPayLoadContext
Visual C++
public:
virtual IPayLoadContext^ ShallowCopy() sealed

Return Value

the partial copy of this object.

Implements

IShallowCopy<(Of <(T>)>)..::.ShallowCopy()()()

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


PayLoadContext Properties

[image] [image]

Enterprise SDK 8.0 Reference API
PayLoadContext Properties
PayLoadContext Class See Also Send Feedback

The PayLoadContext type exposes the following members.

Properties

Name | Description
ContextState | Get state type of event: Unknown, Created, Updated, Merged, Deleted, Error,
msg | Get raw PSDK message
Reason | Get reason of event update
TimeStamp | Get time stamp of object creation

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


ContextState Property

[image]

Enterprise SDK 8.0 Reference API
PayLoadContext..::.ContextState Property
PayLoadContext Class See Also Send Feedback
Get state type of event: Unknown, Created, Updated, Merged, Deleted, Error,

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ContextStateType ContextState { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContextState As ContextStateType
Visual C++
public:
virtual property ContextStateType ContextState {
    ContextStateType get () sealed;
}

Implements

IPayLoadContext..::.ContextState

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


msg Property

[image]

Enterprise SDK 8.0 Reference API
PayLoadContext..::.msg Property
PayLoadContext Class See Also Send Feedback
Get raw PSDK message

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IMessage msg { get; }
Visual Basic (Declaration)
Public ReadOnly Property msg As IMessage
Visual C++
public:
virtual property IMessage^ msg {
    IMessage^ get () sealed;
}

Implements

IPayLoadContext..::.msg

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


Reason Property

[image]

Enterprise SDK 8.0 Reference API
PayLoadContext..::.Reason Property
PayLoadContext Class See Also Send Feedback
Get reason of event update

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ReasonTypes Reason { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reason As ReasonTypes
Visual C++
public:
virtual property ReasonTypes Reason {
    ReasonTypes get () sealed;
}

Implements

IPayLoadContext..::.Reason

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


TimeStamp Property

[image]

Enterprise SDK 8.0 Reference API
PayLoadContext..::.TimeStamp Property
PayLoadContext Class See Also Send Feedback
Get time stamp of object creation

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public long TimeStamp { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeStamp As Long
Visual C++
public:
virtual property long long TimeStamp {
    long long get () sealed;
}

Implements

IPayLoadContext..::.TimeStamp

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


Role Class

[image]

Enterprise SDK 8.0 Reference API
Role Class
Members See Also Send Feedback
The Role class.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public class Role : IRole
Visual Basic (Declaration)
Public Class Role _
    Implements IRole
Visual C++
public ref class Role : IRole

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Core..::.Role

See Also

Role Members
Genesyslab.Enterprise.Core Namespace


Role Members

[image] [image]

Enterprise SDK 8.0 Reference API
Role Members
Role Class Constructors Methods Properties See Also Send Feedback

The Role type exposes the following members.

Constructors

Name | Description
Role | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capabilities | The capabilities for this role.
Description | The description of the role.
Name | The name of the role.
Parameters | The parameters associated with the role.
RoleProfile | The Role profile type: custom or system.
Visibility | Visibility type of the role.

See Also

Role Class
Genesyslab.Enterprise.Core Namespace


Role Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
Role Constructor
Role Class See Also Send Feedback

Overload List

Name | Description
Role(String, String, PartyType, Visibility) | Creates an instance of this object.
Role(String, String, PartyType, Visibility, array<Object>[]()[]) | Creates an instance of this object.

See Also

Role Class
Role Members
Genesyslab.Enterprise.Core Namespace


Role Constructor (String, String, PartyType, Visibility)

[image]

Enterprise SDK 8.0 Reference API
Role Constructor (String, String, PartyType, Visibility)
Role Class See Also Send Feedback
Creates an instance of this object.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Role(
    string name,
    string description,
    PartyType roleProfile,
    Visibility visibility
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    description As String, _
    roleProfile As PartyType, _
    visibility As Visibility _
)
Visual C++
public:
Role(
    String^ name,
    String^ description,
    PartyType roleProfile,
    Visibility visibility
)

Parameters

name
Type: System..::.String
the name of the role.
description
Type: System..::.String
the description of the role.
roleProfile
Type: Genesyslab.Enterprise.Model.ComponentModel..::.PartyType
the role profile type of the role (system or custom).
visibility
Type: Genesyslab.Enterprise.Model.ComponentModel..::.Visibility

[Missing <param name="visibility"/> documentation for "M:Genesyslab.Enterprise.Core.Role.#ctor(System.String,System.String,Genesyslab.Enterprise.Model.ComponentModel.PartyType,Genesyslab.Enterprise.Model.ComponentModel.Visibility)"]

See Also

Role Class
Role Overload
Genesyslab.Enterprise.Core Namespace


Role Constructor (String, String, PartyType, Visibility, Object[])

[image]

Enterprise SDK 8.0 Reference API
Role Constructor (String, String, PartyType, Visibility, array<Object>[]()[])
Role Class See Also Send Feedback
Creates an instance of this object.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Role(
    string name,
    string description,
    PartyType roleProfile,
    Visibility visibility,
    params Object[] parameters
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    description As String, _
    roleProfile As PartyType, _
    visibility As Visibility, _
    ParamArray parameters As Object() _
)
Visual C++
public:
Role(
    String^ name,
    String^ description,
    PartyType roleProfile,
    Visibility visibility,
    ... array<Object^>^ parameters
)

Parameters

name
Type: System..::.String
the name of the role.
description
Type: System..::.String
the description of the role.
roleProfile
Type: Genesyslab.Enterprise.Model.ComponentModel..::.PartyType
the role profile type of the role (system or custom).
visibility
Type: Genesyslab.Enterprise.Model.ComponentModel..::.Visibility

[Missing <param name="visibility"/> documentation for "M:Genesyslab.Enterprise.Core.Role.#ctor(System.String,System.String,Genesyslab.Enterprise.Model.ComponentModel.PartyType,Genesyslab.Enterprise.Model.ComponentModel.Visibility,System.Object[])"]

parameters
Type: array< System..::.Object >[]()[]
parameters associated with the role.

See Also

Role Class
Role Overload
Genesyslab.Enterprise.Core Namespace


Role Methods

[image] [image]

Enterprise SDK 8.0 Reference API
Role Methods
Role Class See Also Send Feedback

The Role type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Role Class
Genesyslab.Enterprise.Core Namespace


Role Properties

[image] [image]

Enterprise SDK 8.0 Reference API
Role Properties
Role Class See Also Send Feedback

The Role type exposes the following members.

Properties

Name | Description
Capabilities | The capabilities for this role.
Description | The description of the role.
Name | The name of the role.
Parameters | The parameters associated with the role.
RoleProfile | The Role profile type: custom or system.
Visibility | Visibility type of the role.

See Also

Role Class
Genesyslab.Enterprise.Core Namespace


Capabilities Property

[image]

Enterprise SDK 8.0 Reference API
Role..::.Capabilities Property
Role Class See Also Send Feedback
The capabilities for this role.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IDictionary<string, ICapability> Capabilities { get; }
Visual Basic (Declaration)
Public ReadOnly Property Capabilities As IDictionary(Of String, ICapability)
Visual C++
public:
virtual property IDictionary<String^, ICapability^>^ Capabilities {
    IDictionary<String^, ICapability^>^ get () sealed;
}

Implements

IRole..::.Capabilities

See Also

Role Class
Genesyslab.Enterprise.Core Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
Role..::.Description Property
Role Class See Also Send Feedback
The description of the role.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
}

Implements

IRole..::.Description

See Also

Role Class
Genesyslab.Enterprise.Core Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
Role..::.Name Property
Role Class See Also Send Feedback
The name of the role.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

Implements

IRole..::.Name

See Also

Role Class
Genesyslab.Enterprise.Core Namespace


Parameters Property

[image]

Enterprise SDK 8.0 Reference API
Role..::.Parameters Property
Role Class See Also Send Feedback
The parameters associated with the role.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Object[] Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As Object()
Visual C++
public:
virtual property array<Object^>^ Parameters {
    array<Object^>^ get () sealed;
}

Implements

IRole..::.Parameters

See Also

Role Class
Genesyslab.Enterprise.Core Namespace


RoleProfile Property

[image]

Enterprise SDK 8.0 Reference API
Role..::.RoleProfile Property
Role Class See Also Send Feedback
The Role profile type: custom or system.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public PartyType RoleProfile { get; }
Visual Basic (Declaration)
Public ReadOnly Property RoleProfile As PartyType
Visual C++
public:
virtual property PartyType RoleProfile {
    PartyType get () sealed;
}

Implements

IRole..::.RoleProfile

See Also

Role Class
Genesyslab.Enterprise.Core Namespace


Visibility Property

[image]

Enterprise SDK 8.0 Reference API
Role..::.Visibility Property
Role Class See Also Send Feedback
Visibility type of the role.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Visibility Visibility { get; private set; }
Visual Basic (Declaration)
Public Property Visibility As Visibility
Visual C++
public:
virtual property Visibility Visibility {
    Visibility get () sealed;
    void set (Visibility value) sealed;
}

Implements

IRole..::.Visibility

See Also

Role Class
Genesyslab.Enterprise.Core Namespace


Genesyslab.Enterprise.Exceptions Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Exceptions Namespace
Send Feedback

Classes

Class | Description
EnterpriseException | Interface for handling Enterprise Exception.
EnterpriseFrameworkException | Interface for handling Enterprise framework exception.


EnterpriseException Class

[image]

Enterprise SDK 8.0 Reference API
EnterpriseException Class
Members See Also Send Feedback
Interface for handling Enterprise Exception.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public class EnterpriseException : Exception
Visual Basic (Declaration)
Public Class EnterpriseException _
    Inherits Exception
Visual C++
public ref class EnterpriseException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
Genesyslab.Enterprise.Exceptions..::.EnterpriseException
Genesyslab.Enterprise.Exceptions..::.EnterpriseFrameworkException

See Also

EnterpriseException Members
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Members

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseException Members
EnterpriseException Class Constructors Methods Properties See Also Send Feedback

The EnterpriseException type exposes the following members.

Constructors

Name | Description
EnterpriseException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EnterpriseException Class
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseException Constructor
EnterpriseException Class See Also Send Feedback

Overload List

Name | Description
EnterpriseException()()() | Creates an instance of EnterpriseException.
EnterpriseException(Int32) | Creates an instance of EnterpriseException.
EnterpriseException(String) | Creates an instance of EnterpriseException.
EnterpriseException(Int32, String) | Creates an instance of EnterpriseException.
EnterpriseException(SerializationInfo, StreamingContext) | Creates an instance of EnterpriseException.
EnterpriseException(String, Exception) | Creates an instance of EnterpriseException.
EnterpriseException(Int32, String, Exception) | Creates an instance of EnterpriseException.

See Also

EnterpriseException Class
EnterpriseException Members
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Constructor

[image]

Enterprise SDK 8.0 Reference API
EnterpriseException Constructor
EnterpriseException Class See Also Send Feedback
Creates an instance of EnterpriseException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EnterpriseException()

See Also

EnterpriseException Class
EnterpriseException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Constructor (Int32)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseException Constructor (Int32)
EnterpriseException Class See Also Send Feedback
Creates an instance of EnterpriseException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseException(
    int errorCode
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer _
)
Visual C++
public:
EnterpriseException(
    int errorCode
)

Parameters

errorCode
Type: System..::.Int32
the error code.

See Also

EnterpriseException Class
EnterpriseException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Constructor (String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseException Constructor (String)
EnterpriseException Class See Also Send Feedback
Creates an instance of EnterpriseException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
EnterpriseException(
    String^ message
)

Parameters

message
Type: System..::.String
the error message.

See Also

EnterpriseException Class
EnterpriseException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Constructor (Int32, String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseException Constructor (Int32, String)
EnterpriseException Class See Also Send Feedback
Creates an instance of EnterpriseException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseException(
    int errorCode,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String _
)
Visual C++
public:
EnterpriseException(
    int errorCode,
    String^ message
)

Parameters

errorCode
Type: System..::.Int32
the error code.
message
Type: System..::.String
the error message

See Also

EnterpriseException Class
EnterpriseException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Constructor (SerializationInfo, StreamingContext)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseException Constructor (SerializationInfo, StreamingContext)
EnterpriseException Class See Also Send Feedback
Creates an instance of EnterpriseException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
EnterpriseException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
the error info.
context
Type: System.Runtime.Serialization..::.StreamingContext
the error context.

See Also

EnterpriseException Class
EnterpriseException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Constructor (String, Exception)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseException Constructor (String, Exception)
EnterpriseException Class See Also Send Feedback
Creates an instance of EnterpriseException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseException(
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
EnterpriseException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String
the error message.
innerException
Type: System..::.Exception
the inner exception.

See Also

EnterpriseException Class
EnterpriseException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Constructor (Int32, String, Exception)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseException Constructor (Int32, String, Exception)
EnterpriseException Class See Also Send Feedback
Creates an instance of EnterpriseException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseException(
    int errorCode,
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
EnterpriseException(
    int errorCode,
    String^ message,
    Exception^ innerException
)

Parameters

errorCode
Type: System..::.Int32
the error code.
message
Type: System..::.String
the error message.
innerException
Type: System..::.Exception
the inner exception.

See Also

EnterpriseException Class
EnterpriseException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Methods

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseException Methods
EnterpriseException Class See Also Send Feedback

The EnterpriseException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

EnterpriseException Class
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Properties

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseException Properties
EnterpriseException Class See Also Send Feedback

The EnterpriseException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EnterpriseException Class
Genesyslab.Enterprise.Exceptions Namespace


ErrorCode Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseException..::.ErrorCode Property
EnterpriseException Class See Also Send Feedback
Gets or sets Error code.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public int ErrorCode { get; set; }
Visual Basic (Declaration)
Public Property ErrorCode As Integer
Visual C++
public:
property int ErrorCode {
    int get ();
    void set (int value);
}

See Also

EnterpriseException Class
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Class

[image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Class
Members See Also Send Feedback
Interface for handling Enterprise framework exception.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[SerializableAttribute]
public class EnterpriseFrameworkException : EnterpriseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class EnterpriseFrameworkException _
    Inherits EnterpriseException
Visual C++
[SerializableAttribute]
public ref class EnterpriseFrameworkException : public EnterpriseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Genesyslab.Enterprise.Exceptions..::.EnterpriseException
Genesyslab.Enterprise.Exceptions..::.EnterpriseFrameworkException
Genesyslab.Enterprise.Exceptions.Broker..::.BrokerException
Genesyslab.Enterprise.Exceptions.Channel..::.ChannelException
Genesyslab.Enterprise.Exceptions.Protocol..::.ProtocolException

See Also

EnterpriseFrameworkException Members
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Members

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Members
EnterpriseFrameworkException Class Constructors Methods Properties See Also Send Feedback

The EnterpriseFrameworkException type exposes the following members.

Constructors

Name | Description
EnterpriseFrameworkException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code. (Inherited from EnterpriseException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EnterpriseFrameworkException Class
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Constructor
EnterpriseFrameworkException Class See Also Send Feedback

Overload List

Name | Description
EnterpriseFrameworkException()()() | Create an instance of EntrepriseFrameworkException.
EnterpriseFrameworkException(Int32) | Create an instance of EntrepriseFrameworkException.
EnterpriseFrameworkException(String) | Create an instance of EntrepriseFrameworkException.
EnterpriseFrameworkException(Int32, String) | Create an instance of EntrepriseFrameworkException.
EnterpriseFrameworkException(SerializationInfo, StreamingContext) | Create an instance of EntrepriseFrameworkException.
EnterpriseFrameworkException(String, Exception) | Create an instance of EntrepriseFrameworkException.
EnterpriseFrameworkException(Int32, String, Exception) | Create an instance of EntrepriseFrameworkException.

See Also

EnterpriseFrameworkException Class
EnterpriseFrameworkException Members
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Constructor

[image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Constructor
EnterpriseFrameworkException Class See Also Send Feedback
Create an instance of EntrepriseFrameworkException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseFrameworkException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EnterpriseFrameworkException()

See Also

EnterpriseFrameworkException Class
EnterpriseFrameworkException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Constructor (Int32)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Constructor (Int32)
EnterpriseFrameworkException Class See Also Send Feedback
Create an instance of EntrepriseFrameworkException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseFrameworkException(
    int errorCode
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer _
)
Visual C++
public:
EnterpriseFrameworkException(
    int errorCode
)

Parameters

errorCode
Type: System..::.Int32
Error code for the exception.

See Also

EnterpriseFrameworkException Class
EnterpriseFrameworkException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Constructor (String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Constructor (String)
EnterpriseFrameworkException Class See Also Send Feedback
Create an instance of EntrepriseFrameworkException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseFrameworkException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
EnterpriseFrameworkException(
    String^ message
)

Parameters

message
Type: System..::.String
Message for the exception.

See Also

EnterpriseFrameworkException Class
EnterpriseFrameworkException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Constructor (Int32, String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Constructor (Int32, String)
EnterpriseFrameworkException Class See Also Send Feedback
Create an instance of EntrepriseFrameworkException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseFrameworkException(
    int errorCode,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String _
)
Visual C++
public:
EnterpriseFrameworkException(
    int errorCode,
    String^ message
)

Parameters

errorCode
Type: System..::.Int32
Error code for the exception.
message
Type: System..::.String
Message for the exception.

See Also

EnterpriseFrameworkException Class
EnterpriseFrameworkException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Constructor (SerializationInfo, StreamingContext)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Constructor (SerializationInfo, StreamingContext)
EnterpriseFrameworkException Class See Also Send Feedback
Create an instance of EntrepriseFrameworkException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseFrameworkException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
EnterpriseFrameworkException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Serialization information.
context
Type: System.Runtime.Serialization..::.StreamingContext
Context for the serialization streaming.

See Also

EnterpriseFrameworkException Class
EnterpriseFrameworkException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Constructor (String, Exception)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Constructor (String, Exception)
EnterpriseFrameworkException Class See Also Send Feedback
Create an instance of EntrepriseFrameworkException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseFrameworkException(
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
EnterpriseFrameworkException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String
Message for the exception.
innerException
Type: System..::.Exception
The underneath exception.

See Also

EnterpriseFrameworkException Class
EnterpriseFrameworkException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Constructor (Int32, String, Exception)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Constructor (Int32, String, Exception)
EnterpriseFrameworkException Class See Also Send Feedback
Create an instance of EntrepriseFrameworkException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseFrameworkException(
    int errorCode,
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
EnterpriseFrameworkException(
    int errorCode,
    String^ message,
    Exception^ innerException
)

Parameters

errorCode
Type: System..::.Int32
Error code for the exception.
message
Type: System..::.String
Message for the exception.
innerException
Type: System..::.Exception
The underneath exception.

See Also

EnterpriseFrameworkException Class
EnterpriseFrameworkException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Methods

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Methods
EnterpriseFrameworkException Class See Also Send Feedback

The EnterpriseFrameworkException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

EnterpriseFrameworkException Class
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Properties

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Properties
EnterpriseFrameworkException Class See Also Send Feedback

The EnterpriseFrameworkException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code. (Inherited from EnterpriseException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EnterpriseFrameworkException Class
Genesyslab.Enterprise.Exceptions Namespace


Genesyslab.Enterprise.Exceptions.Broker Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Exceptions.Broker Namespace
Send Feedback

Classes

Class | Description
BrokerException | Exception class for Broker.


BrokerException Class

[image]

Enterprise SDK 8.0 Reference API
BrokerException Class
Members See Also Send Feedback
Exception class for Broker.

Namespace: Genesyslab.Enterprise.Exceptions.Broker
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[SerializableAttribute]
public class BrokerException : EnterpriseFrameworkException,
    ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class BrokerException _
    Inherits EnterpriseFrameworkException _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class BrokerException : public EnterpriseFrameworkException,
    ISerializable

Inheritance Hierarchy

System..::.Object
System..::.Exception
Genesyslab.Enterprise.Exceptions..::.EnterpriseException
Genesyslab.Enterprise.Exceptions..::.EnterpriseFrameworkException
Genesyslab.Enterprise.Exceptions.Broker..::.BrokerException

See Also

BrokerException Members
Genesyslab.Enterprise.Exceptions.Broker Namespace


BrokerException Members

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerException Members
BrokerException Class Constructors Methods Properties See Also Send Feedback

The BrokerException type exposes the following members.

Constructors

Name | Description
BrokerException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Custom Serializing. (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code. (Inherited from EnterpriseException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Get error message (Overrides Exception..::.Message.)
Method | Get the strategy name at the origin of error
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Target | Get the strategy name at the origin of error
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BrokerException Class
Genesyslab.Enterprise.Exceptions.Broker Namespace


BrokerException Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerException Constructor
BrokerException Class See Also Send Feedback

Overload List

Name | Description
BrokerException()()() | Construct an empty exception
BrokerException(String) | Construct an default exception.
BrokerException(String, Exception) | Construct an default exception.
BrokerException(Object, MethodInfo, String) | Construct an exception with Target object, Method and Message

See Also

BrokerException Class
BrokerException Members
Genesyslab.Enterprise.Exceptions.Broker Namespace


BrokerException Constructor

[image]

Enterprise SDK 8.0 Reference API
BrokerException Constructor
BrokerException Class See Also Send Feedback
Construct an empty exception

Namespace: Genesyslab.Enterprise.Exceptions.Broker
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public BrokerException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BrokerException()

See Also

BrokerException Class
BrokerException Overload
Genesyslab.Enterprise.Exceptions.Broker Namespace


BrokerException Constructor (String)

[image]

Enterprise SDK 8.0 Reference API
BrokerException Constructor (String)
BrokerException Class See Also Send Feedback
Construct an default exception.

Namespace: Genesyslab.Enterprise.Exceptions.Broker
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public BrokerException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
BrokerException(
    String^ message
)

Parameters

message
Type: System..::.String
the error message.

See Also

BrokerException Class
BrokerException Overload
Genesyslab.Enterprise.Exceptions.Broker Namespace


BrokerException Constructor (String, Exception)

[image]

Enterprise SDK 8.0 Reference API
BrokerException Constructor (String, Exception)
BrokerException Class See Also Send Feedback
Construct an default exception.

Namespace: Genesyslab.Enterprise.Exceptions.Broker
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public BrokerException(
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
BrokerException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String
the error message.
innerException
Type: System..::.Exception
the inner exception.

See Also

BrokerException Class
BrokerException Overload
Genesyslab.Enterprise.Exceptions.Broker Namespace


BrokerException Constructor (Object, MethodInfo, String)

[image]

Enterprise SDK 8.0 Reference API
BrokerException Constructor (Object, MethodInfo, String)
BrokerException Class See Also Send Feedback
Construct an exception with Target object, Method and Message

Namespace: Genesyslab.Enterprise.Exceptions.Broker
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public BrokerException(
    Object target,
    MethodInfo method,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    target As Object, _
    method As MethodInfo, _
    message As String _
)
Visual C++
public:
BrokerException(
    Object^ target,
    MethodInfo^ method,
    String^ message
)

Parameters

target
Type: System..::.Object
the target.
method
Type: System.Reflection..::.MethodInfo
the method.
message
Type: System..::.String
the error message.

See Also

BrokerException Class
BrokerException Overload
Genesyslab.Enterprise.Exceptions.Broker Namespace


BrokerException Methods

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerException Methods
BrokerException Class See Also Send Feedback

The BrokerException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Custom Serializing. (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

BrokerException Class
Genesyslab.Enterprise.Exceptions.Broker Namespace


GetObjectData Method

[image]

Enterprise SDK 8.0 Reference API
BrokerException..::.GetObjectData Method
BrokerException Class See Also Send Feedback
Custom Serializing.

Namespace: Genesyslab.Enterprise.Exceptions.Broker
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
the error info.
context
Type: System.Runtime.Serialization..::.StreamingContext
the error context.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

BrokerException Class
Genesyslab.Enterprise.Exceptions.Broker Namespace


BrokerException Properties

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerException Properties
BrokerException Class See Also Send Feedback

The BrokerException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code. (Inherited from EnterpriseException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Get error message (Overrides Exception..::.Message.)
Method | Get the strategy name at the origin of error
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Target | Get the strategy name at the origin of error
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BrokerException Class
Genesyslab.Enterprise.Exceptions.Broker Namespace


Message Property

[image]

Enterprise SDK 8.0 Reference API
BrokerException..::.Message Property
BrokerException Class See Also Send Feedback
Get error message

Namespace: Genesyslab.Enterprise.Exceptions.Broker
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override string Message { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Message As String
Visual C++
public:
virtual property String^ Message {
    String^ get () override;
}

Implements

_Exception..::.Message

See Also

BrokerException Class
Genesyslab.Enterprise.Exceptions.Broker Namespace


Method Property

[image]

Enterprise SDK 8.0 Reference API
BrokerException..::.Method Property
BrokerException Class See Also Send Feedback
Get the strategy name at the origin of error

Namespace: Genesyslab.Enterprise.Exceptions.Broker
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public MethodInfo Method { get; }
Visual Basic (Declaration)
Public ReadOnly Property Method As MethodInfo
Visual C++
public:
property MethodInfo^ Method {
    MethodInfo^ get ();
}

See Also

BrokerException Class
Genesyslab.Enterprise.Exceptions.Broker Namespace


Target Property

[image]

Enterprise SDK 8.0 Reference API
BrokerException..::.Target Property
BrokerException Class See Also Send Feedback
Get the strategy name at the origin of error

Namespace: Genesyslab.Enterprise.Exceptions.Broker
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Object Target { get; }
Visual Basic (Declaration)
Public ReadOnly Property Target As Object
Visual C++
public:
property Object^ Target {
    Object^ get ();
}

See Also

BrokerException Class
Genesyslab.Enterprise.Exceptions.Broker Namespace


Genesyslab.Enterprise.Exceptions.Channel Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Exceptions.Channel Namespace
Send Feedback

Classes

Class | Description
ChannelException | Interface for handling Channel exception.

Enumerations

Enumeration | Description
ChannelExceptionType | Enumerate for Channel Exception Type.


ChannelException Class

[image]

Enterprise SDK 8.0 Reference API
ChannelException Class
Members See Also Send Feedback
Interface for handling Channel exception.

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[SerializableAttribute]
public class ChannelException : EnterpriseFrameworkException,
    ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ChannelException _
    Inherits EnterpriseFrameworkException _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class ChannelException : public EnterpriseFrameworkException,
    ISerializable

Inheritance Hierarchy

System..::.Object
System..::.Exception
Genesyslab.Enterprise.Exceptions..::.EnterpriseException
Genesyslab.Enterprise.Exceptions..::.EnterpriseFrameworkException
Genesyslab.Enterprise.Exceptions.Channel..::.ChannelException

See Also

ChannelException Members
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Members

[image] [image]

Enterprise SDK 8.0 Reference API
ChannelException Members
ChannelException Class Constructors Methods Properties See Also Send Feedback

The ChannelException type exposes the following members.

Constructors

Name | Description
ChannelException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Custom Serializing. (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code. (Inherited from EnterpriseException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ChannelException Class
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
ChannelException Constructor
ChannelException Class See Also Send Feedback

Overload List

Name | Description
ChannelException()()() | Creates an instance of ChannelException.
ChannelException(Int32) | Creates an instance of ChannelException.
ChannelException(String) | Creates an instance of ChannelException.
ChannelException(Int32, String) | Creates an instance of ChannelException.
ChannelException(String, Exception) | Creates an instance of ChannelException.
ChannelException(Int32, String, Exception) | Creates an instance of ChannelException.

See Also

ChannelException Class
ChannelException Members
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Constructor

[image]

Enterprise SDK 8.0 Reference API
ChannelException Constructor
ChannelException Class See Also Send Feedback
Creates an instance of ChannelException.

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ChannelException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChannelException()

See Also

ChannelException Class
ChannelException Overload
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Constructor (Int32)

[image]

Enterprise SDK 8.0 Reference API
ChannelException Constructor (Int32)
ChannelException Class See Also Send Feedback
Creates an instance of ChannelException.

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ChannelException(
    int errorCode
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer _
)
Visual C++
public:
ChannelException(
    int errorCode
)

Parameters

errorCode
Type: System..::.Int32
the error code.

See Also

ChannelException Class
ChannelException Overload
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Constructor (String)

[image]

Enterprise SDK 8.0 Reference API
ChannelException Constructor (String)
ChannelException Class See Also Send Feedback
Creates an instance of ChannelException.

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ChannelException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
ChannelException(
    String^ message
)

Parameters

message
Type: System..::.String
the error message.

See Also

ChannelException Class
ChannelException Overload
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Constructor (Int32, String)

[image]

Enterprise SDK 8.0 Reference API
ChannelException Constructor (Int32, String)
ChannelException Class See Also Send Feedback
Creates an instance of ChannelException.

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ChannelException(
    int errorCode,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String _
)
Visual C++
public:
ChannelException(
    int errorCode,
    String^ message
)

Parameters

errorCode
Type: System..::.Int32
the error code.
message
Type: System..::.String
the error message.

See Also

ChannelException Class
ChannelException Overload
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Constructor (String, Exception)

[image]

Enterprise SDK 8.0 Reference API
ChannelException Constructor (String, Exception)
ChannelException Class See Also Send Feedback
Creates an instance of ChannelException.

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ChannelException(
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
ChannelException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String
the error message.
innerException
Type: System..::.Exception
the inner exception.

See Also

ChannelException Class
ChannelException Overload
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Constructor (Int32, String, Exception)

[image]

Enterprise SDK 8.0 Reference API
ChannelException Constructor (Int32, String, Exception)
ChannelException Class See Also Send Feedback
Creates an instance of ChannelException.

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ChannelException(
    int errorCode,
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
ChannelException(
    int errorCode,
    String^ message,
    Exception^ innerException
)

Parameters

errorCode
Type: System..::.Int32
the error code.
message
Type: System..::.String
the error message.
innerException
Type: System..::.Exception
the inner exception.

See Also

ChannelException Class
ChannelException Overload
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ChannelException Methods
ChannelException Class See Also Send Feedback

The ChannelException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Custom Serializing. (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ChannelException Class
Genesyslab.Enterprise.Exceptions.Channel Namespace


GetObjectData Method

[image]

Enterprise SDK 8.0 Reference API
ChannelException..::.GetObjectData Method
ChannelException Class See Also Send Feedback
Custom Serializing.

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
the error info.
context
Type: System.Runtime.Serialization..::.StreamingContext
the error context.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ChannelException Class
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ChannelException Properties
ChannelException Class See Also Send Feedback

The ChannelException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code. (Inherited from EnterpriseException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ChannelException Class
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelExceptionType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ChannelExceptionType Enumeration
See Also Send Feedback
Enumerate for Channel Exception Type.

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum ChannelExceptionType
Visual Basic (Declaration)
Public Enumeration ChannelExceptionType
Visual C++
public enum class ChannelExceptionType

Members

Member name | Description
ChannelUnknownError | Unknown Error.
ChannelConnectionFailed | Connection Failed.
ChannelDoesNotExist | Channel does not exist.
ChannelNotInitializedProperly | Channel is not initialized.
ChannelInvalidTimeout | Invalid Time-out.
ChannelClosingFailed | Closing channel failed.
ChannelSendFailed | Send request failed.
ChannelInvalidProtocol | Invalid protocol for this channel.

See Also

Genesyslab.Enterprise.Exceptions.Channel Namespace


Genesyslab.Enterprise.Exceptions.Protocol Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Exceptions.Protocol Namespace
Send Feedback

Classes

Class | Description
ProtocolException | Interface for handling Protocol exception.

Enumerations

Enumeration | Description
ProtocolExceptionType | Enumerate for Protocol Exception type.


ProtocolException Class

[image]

Enterprise SDK 8.0 Reference API
ProtocolException Class
Members See Also Send Feedback
Interface for handling Protocol exception.

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[SerializableAttribute]
public class ProtocolException : EnterpriseFrameworkException,
    ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ProtocolException _
    Inherits EnterpriseFrameworkException _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class ProtocolException : public EnterpriseFrameworkException,
    ISerializable

Inheritance Hierarchy

System..::.Object
System..::.Exception
Genesyslab.Enterprise.Exceptions..::.EnterpriseException
Genesyslab.Enterprise.Exceptions..::.EnterpriseFrameworkException
Genesyslab.Enterprise.Exceptions.Protocol..::.ProtocolException

See Also

ProtocolException Members
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Members

[image] [image]

Enterprise SDK 8.0 Reference API
ProtocolException Members
ProtocolException Class Constructors Methods Properties See Also Send Feedback

The ProtocolException type exposes the following members.

Constructors

Name | Description
ProtocolException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Custom Serializing. (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code. (Inherited from EnterpriseException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ProtocolException Class
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
ProtocolException Constructor
ProtocolException Class See Also Send Feedback

Overload List

Name | Description
ProtocolException()()() | Creates an instance of ProtocolException.
ProtocolException(Int32) | Creates an instance of ProtocolException.
ProtocolException(String) | Creates an instance of ProtocolException.
ProtocolException(Int32, String) | Creates an instance of ProtocolException.
ProtocolException(String, Exception) | Creates an instance of ProtocolException.
ProtocolException(Int32, String, Exception) | Creates an instance of ProtocolException.

See Also

ProtocolException Class
ProtocolException Members
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Constructor

[image]

Enterprise SDK 8.0 Reference API
ProtocolException Constructor
ProtocolException Class See Also Send Feedback
Creates an instance of ProtocolException.

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ProtocolException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProtocolException()

See Also

ProtocolException Class
ProtocolException Overload
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Constructor (Int32)

[image]

Enterprise SDK 8.0 Reference API
ProtocolException Constructor (Int32)
ProtocolException Class See Also Send Feedback
Creates an instance of ProtocolException.

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ProtocolException(
    int errorCode
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer _
)
Visual C++
public:
ProtocolException(
    int errorCode
)

Parameters

errorCode
Type: System..::.Int32
the error code.

See Also

ProtocolException Class
ProtocolException Overload
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Constructor (String)

[image]

Enterprise SDK 8.0 Reference API
ProtocolException Constructor (String)
ProtocolException Class See Also Send Feedback
Creates an instance of ProtocolException.

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ProtocolException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
ProtocolException(
    String^ message
)

Parameters

message
Type: System..::.String
the error message.

See Also

ProtocolException Class
ProtocolException Overload
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Constructor (Int32, String)

[image]

Enterprise SDK 8.0 Reference API
ProtocolException Constructor (Int32, String)
ProtocolException Class See Also Send Feedback
Creates an instance of ProtocolException.

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ProtocolException(
    int errorCode,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String _
)
Visual C++
public:
ProtocolException(
    int errorCode,
    String^ message
)

Parameters

errorCode
Type: System..::.Int32
the error code.
message
Type: System..::.String
the error message.

See Also

ProtocolException Class
ProtocolException Overload
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Constructor (String, Exception)

[image]

Enterprise SDK 8.0 Reference API
ProtocolException Constructor (String, Exception)
ProtocolException Class See Also Send Feedback
Creates an instance of ProtocolException.

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ProtocolException(
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
ProtocolException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String
the error message.
innerException
Type: System..::.Exception
the inner exception.

See Also

ProtocolException Class
ProtocolException Overload
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Constructor (Int32, String, Exception)

[image]

Enterprise SDK 8.0 Reference API
ProtocolException Constructor (Int32, String, Exception)
ProtocolException Class See Also Send Feedback
Creates an instance of ProtocolException.

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ProtocolException(
    int errorCode,
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
ProtocolException(
    int errorCode,
    String^ message,
    Exception^ innerException
)

Parameters

errorCode
Type: System..::.Int32
the error code.
message
Type: System..::.String
the error message.
innerException
Type: System..::.Exception
the inner exception.

See Also

ProtocolException Class
ProtocolException Overload
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ProtocolException Methods
ProtocolException Class See Also Send Feedback

The ProtocolException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Custom Serializing. (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ProtocolException Class
Genesyslab.Enterprise.Exceptions.Protocol Namespace


GetObjectData Method

[image]

Enterprise SDK 8.0 Reference API
ProtocolException..::.GetObjectData Method
ProtocolException Class See Also Send Feedback
Custom Serializing.

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
the error info.
context
Type: System.Runtime.Serialization..::.StreamingContext
the error context.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ProtocolException Class
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ProtocolException Properties
ProtocolException Class See Also Send Feedback

The ProtocolException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code. (Inherited from EnterpriseException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ProtocolException Class
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolExceptionType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ProtocolExceptionType Enumeration
See Also Send Feedback
Enumerate for Protocol Exception type.

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum ProtocolExceptionType
Visual Basic (Declaration)
Public Enumeration ProtocolExceptionType
Visual C++
public enum class ProtocolExceptionType

Members

Member name | Description
InvalidParameter | Invalid parameter.
MissingParameter | Missing parameter in protocol.
InvalidObjectState | Invalid object state for this protocol action.
ProtocolUnknownError | Unknown Error.
MissingProtocol | Missing protocol

See Also

Genesyslab.Enterprise.Exceptions.Protocol Namespace


Genesyslab.Enterprise.Extensions Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Extensions Namespace
Send Feedback

Classes

Class | Description
AgentServiceExtensions |
DeviceServiceExtensions | Extends the device service to perform switch-specific actions on the device.
IdentityService |
IMServiceExtensions | Extends the IM service to start and manage an instant messaging session.
MonitorServiceExtensions | Extension Methods for PAM.
SupervisorServiceExtensions | Extends the Supervisor Service to perform manage the supervision of the device.
VoiceServiceExtensions |


AgentServiceExtensions Class

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Extensions.AgentServiceExtensions"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static class AgentServiceExtensions
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class AgentServiceExtensions
Visual C++
[ExtensionAttribute]
public ref class AgentServiceExtensions abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Extensions..::.AgentServiceExtensions

See Also

AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


AgentServiceExtensions Members

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions Members
AgentServiceExtensions Class Methods See Also Send Feedback

The AgentServiceExtensions type exposes the following members.

Methods

Name | Description
BeginCallForwardCancel | Overloaded.
BeginCallForwardSet | Overloaded.
BeginLogin | Overloaded.
BeginLogout | Overloaded.
BeginNotReady | Overloaded.
BeginReady | Overloaded.
BeginSetDNDOff | Overloaded.
BeginSetDNDOn | Overloaded.
CallForwardCancel | Overloaded.
CallForwardSet | Overloaded.
EndCallForwardCancel | Ends the asynchronous desactivation of the Forward mode for the given agent.
EndCallForwardSet | Ends the asynchonous activation of the Forward mode for the given agent.
EndLogin | Ends the asynchronous login of the agent.
EndLogout | Ends the agent's asynchronous logout of the ACD group specified by the queue parameter.
EndNotReady | Ends the asynchronous operation to set the agent's status to not ready for receiving calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.
EndReady | Ends the asynchronous operation to set the agent's status to ready.
EndSetDNDOff | Ends the asynchronous deactivation of the Do Not Disturb mode for the given agent.
EndSetDNDOn | Ends the asynchronous activation of the Do Not Disturb mode for the given agent.
Login | Overloaded.
Logout | Overloaded.
NotReady | Overloaded.
Ready | Overloaded.
SetDNDOff | Overloaded.
SetDNDOn | Overloaded.

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


AgentServiceExtensions Methods

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions Methods
AgentServiceExtensions Class See Also Send Feedback

The AgentServiceExtensions type exposes the following members.

Methods

Name | Description
BeginCallForwardCancel | Overloaded.
BeginCallForwardSet | Overloaded.
BeginLogin | Overloaded.
BeginLogout | Overloaded.
BeginNotReady | Overloaded.
BeginReady | Overloaded.
BeginSetDNDOff | Overloaded.
BeginSetDNDOn | Overloaded.
CallForwardCancel | Overloaded.
CallForwardSet | Overloaded.
EndCallForwardCancel | Ends the asynchronous desactivation of the Forward mode for the given agent.
EndCallForwardSet | Ends the asynchonous activation of the Forward mode for the given agent.
EndLogin | Ends the asynchronous login of the agent.
EndLogout | Ends the agent's asynchronous logout of the ACD group specified by the queue parameter.
EndNotReady | Ends the asynchronous operation to set the agent's status to not ready for receiving calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.
EndReady | Ends the asynchronous operation to set the agent's status to ready.
EndSetDNDOff | Ends the asynchronous deactivation of the Do Not Disturb mode for the given agent.
EndSetDNDOn | Ends the asynchronous activation of the Do Not Disturb mode for the given agent.
Login | Overloaded.
Logout | Overloaded.
NotReady | Overloaded.
Ready | Overloaded.
SetDNDOff | Overloaded.
SetDNDOn | Overloaded.

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardCancel Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginCallForwardCancel(IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Obsolete. Begins the asynchronous desactivation of the Forward mode for the given agent.
BeginCallForwardCancel(IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginCallForwardCancel(IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Obsolete.
BeginCallForwardCancel(IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginCallForwardCancel(IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Obsolete. Begins the asynchronous desactivation of the Forward mode for the given agent.
BeginCallForwardCancel(IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Obsolete.
BeginCallForwardCancel(IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginCallForwardCancel(IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback
Begins the asynchronous desactivation of the Forward mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginCallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function BeginCallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IAsyncResult^ BeginCallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginCallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginCallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback
Begins the asynchronous desactivation of the Forward mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginCallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginCallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginCallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginCallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardSet Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginCallForwardSet(IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Obsolete. Begins the asynchonous activation of the Forward On mode for the given agent.
BeginCallForwardSet(IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Obsolete.
BeginCallForwardSet(IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginCallForwardSet(IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginCallForwardSet(IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Obsolete. Begins the asynchonous activation of the Forward mode for the given agent.
BeginCallForwardSet(IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginCallForwardSet(IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Obsolete.
BeginCallForwardSet(IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback
Begins the asynchonous activation of the Forward On mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginCallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginCallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginCallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginCallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginCallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginCallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginCallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginCallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback
Begins the asynchonous activation of the Forward mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginCallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginCallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginCallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginCallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginCallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function BeginCallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IAsyncResult^ BeginCallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginCallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginCallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogin Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogin Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginLogin(IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Obsolete.
BeginLogin(IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginLogin(IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Obsolete.
BeginLogin(IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Obsolete.
BeginLogin(IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous login of the agent into the ACD group specified by the queue parameter.
BeginLogin(IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginLogin(IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Obsolete.
BeginLogin(IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Initiates the asynchronous login of the agent into the ACD group specified by the queue parameter.

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginLogin Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogin Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginLogin(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function BeginLogin ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IAsyncResult^ BeginLogin(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginLogin Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogin Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogin Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginLogin(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginLogin ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogin(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginLogin Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogin Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogin Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginLogin(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function BeginLogin ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IAsyncResult^ BeginLogin(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginLogin Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogin Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogin Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginLogin(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginLogin ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogin(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginLogin Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogin Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogin Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback
Initiates the asynchronous login of the agent into the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginLogin(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginLogin ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogin(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginLogin Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogin Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogin Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginLogin(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginLogin ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogin(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginLogin Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogin Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogin Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginLogin(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginLogin ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogin(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginLogin Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogin Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogin Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback
Initiates the asynchronous login of the agent into the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginLogin(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginLogin ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogin(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginLogin Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogout Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogout Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginLogout(IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Obsolete. Initiates the agent's asynchronous logout of the ACD group specified by the queue parameter.
BeginLogout(IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginLogout(IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginLogout(IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginLogout(IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginLogout(IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginLogout(IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginLogout(IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginLogout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback
Initiates the agent's asynchronous logout of the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginLogout(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginLogout ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogout(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginLogout Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginLogout(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginLogout ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogout(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginLogout Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginLogout(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginLogout ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogout(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginLogout Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginLogout(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginLogout ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogout(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginLogout Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginLogout(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginLogout ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogout(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginLogout Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginLogout(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginLogout ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogout(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginLogout Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginLogout(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginLogout ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogout(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginLogout Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginLogout(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginLogout ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogout(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginLogout Overload
Genesyslab.Enterprise.Extensions Namespace


BeginNotReady Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginNotReady Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginNotReady(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Obsolete.
BeginNotReady(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call to set the agent's status to not ready for receiving calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.
BeginNotReady(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginNotReady(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Obsolete.
BeginNotReady(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Initiates the asynchronous call to set the agent's status to not ready for receiving calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.
BeginNotReady(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Initiates the asynchronous call to set the agent's status to not ready for receiving calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginNotReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginNotReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginNotReady(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginNotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginNotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginNotReady Overload
Genesyslab.Enterprise.Extensions Namespace


BeginNotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginNotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call to set the agent's status to not ready for receiving calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginNotReady(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginNotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginNotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
Free user data

Return Value

IAsyncResult

See Also

AgentServiceExtensions Class
BeginNotReady Overload
Genesyslab.Enterprise.Extensions Namespace


BeginNotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginNotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginNotReady(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginNotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginNotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginNotReady Overload
Genesyslab.Enterprise.Extensions Namespace


BeginNotReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginNotReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginNotReady(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function BeginNotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IAsyncResult^ BeginNotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginNotReady Overload
Genesyslab.Enterprise.Extensions Namespace


BeginNotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginNotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call to set the agent's status to not ready for receiving calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginNotReady(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginNotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginNotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginNotReady Overload
Genesyslab.Enterprise.Extensions Namespace


BeginNotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginNotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call to set the agent's status to not ready for receiving calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginNotReady(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginNotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginNotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

See Also

AgentServiceExtensions Class
BeginNotReady Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReady Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginReady Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginReady(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginReady(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginReady(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginReady(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginReady(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginReady(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReady(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReady(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginReady Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReady(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReady(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginReady Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReady(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReady(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginReady Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReady(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReady(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginReady Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReady(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReady(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginReady Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReady(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReady(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginReady Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOff Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSetDNDOff(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Obsolete.
BeginSetDNDOff(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSetDNDOff(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Obsolete. Initiates the asynchronous deactivation of the Do Not Disturb mode for the given agent.
BeginSetDNDOff(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Obsolete.
BeginSetDNDOff(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginSetDNDOff(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSetDNDOff(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Obsolete. Initiates the asynchronous deactivation of the Do Not Disturb mode for the given agent.
BeginSetDNDOff(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginSetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback
Initiates the asynchronous deactivation of the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginSetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginSetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function BeginSetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IAsyncResult^ BeginSetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback
Initiates the asynchronous deactivation of the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginSetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function BeginSetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IAsyncResult^ BeginSetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOn Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSetDNDOn(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Obsolete.
BeginSetDNDOn(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSetDNDOn(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Obsolete. Initiates the asynchronous activation of the Do Not Disturb mode for the given agent.
BeginSetDNDOn(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Obsolete.
BeginSetDNDOn(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginSetDNDOn(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSetDNDOn(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Obsolete. Initiates the asynchronous activation of the Do Not Disturb mode for the given agent.
BeginSetDNDOn(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginSetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function BeginSetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IAsyncResult^ BeginSetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback
Initiates the asynchronous activation of the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginSetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function BeginSetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IAsyncResult^ BeginSetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginSetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function BeginSetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IAsyncResult^ BeginSetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback
Initiates the asynchronous activation of the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginSetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardCancel Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
CallForwardCancel(IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection) | Obsolete.
CallForwardCancel(IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection) |
CallForwardCancel(IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32) | Obsolete.
CallForwardCancel(IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, String) | Obsolete. Deactivates the Forward mode for the given agent.
CallForwardCancel(IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32) |
CallForwardCancel(IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, String) |
CallForwardCancel(IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String) | Obsolete. Deactivates the Forward mode for the given agent.
CallForwardCancel(IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> CallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function CallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ CallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
CallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> CallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ CallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
CallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> CallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function CallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ CallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
CallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, String)
AgentServiceExtensions Class See Also Send Feedback
Deactivates the Forward mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> CallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function CallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ CallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

AgentServiceExtensions Class
CallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> CallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ CallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
CallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> CallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ CallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

AgentServiceExtensions Class
CallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback
Deactivates the Forward mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> CallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function CallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ CallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
CallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> CallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ CallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
CallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardSet Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
CallForwardSet(IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection) | Obsolete.
CallForwardSet(IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection) |
CallForwardSet(IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32) | Obsolete.
CallForwardSet(IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, String) | Obsolete. Activates the Forward mode for the given agent.
CallForwardSet(IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32) |
CallForwardSet(IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, String) |
CallForwardSet(IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String) | Obsolete. Activates the Forward mode for the given agent.
CallForwardSet(IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> CallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function CallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ CallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
CallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> CallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ CallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
CallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> CallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function CallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ CallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
CallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, String)
AgentServiceExtensions Class See Also Send Feedback
Activates the Forward mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> CallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function CallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ CallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

AgentServiceExtensions Class
CallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> CallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ CallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
CallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> CallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ CallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

AgentServiceExtensions Class
CallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback
Activates the Forward mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> CallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function CallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ CallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
CallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> CallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ CallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
CallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


EndCallForwardCancel Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.EndCallForwardCancel Method
AgentServiceExtensions Class See Also Send Feedback
Ends the asynchronous desactivation of the Forward mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> EndCallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndCallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ EndCallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndCallForwardSet Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.EndCallForwardSet Method
AgentServiceExtensions Class See Also Send Feedback
Ends the asynchonous activation of the Forward mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> EndCallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndCallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ EndCallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndLogin Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.EndLogin Method
AgentServiceExtensions Class See Also Send Feedback
Ends the asynchronous login of the agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> EndLogin(
    this IIdentityService service,
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndLogin ( _
    service As IIdentityService, _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ EndLogin(
    IIdentityService^ service,
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndLogout Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.EndLogout Method
AgentServiceExtensions Class See Also Send Feedback
Ends the agent's asynchronous logout of the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> EndLogout(
    this IIdentityService service,
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndLogout ( _
    service As IIdentityService, _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ EndLogout(
    IIdentityService^ service,
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndNotReady Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.EndNotReady Method
AgentServiceExtensions Class See Also Send Feedback
Ends the asynchronous operation to set the agent's status to not ready for receiving calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> EndNotReady(
    this IIdentityService service,
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndNotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ EndNotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndReady Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.EndReady Method
AgentServiceExtensions Class See Also Send Feedback
Ends the asynchronous operation to set the agent's status to ready.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> EndReady(
    this IIdentityService service,
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ EndReady(
    IIdentityService^ service,
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSetDNDOff Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.EndSetDNDOff Method
AgentServiceExtensions Class See Also Send Feedback
Ends the asynchronous deactivation of the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> EndSetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ EndSetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSetDNDOn Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.EndSetDNDOn Method
AgentServiceExtensions Class See Also Send Feedback
Ends the asynchronous activation of the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> EndSetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ EndSetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


Login Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
Login(IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, String) | Obsolete.
Login(IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, String) | Synchronous login with a specified timeout
Login(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection) | Obsolete.
Login(IIdentityService, IAgent, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32) |
Login(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32) | Obsolete.
Login(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, String) | Obsolete. Logs in the agent to the ACD group specified by the queue parameter.
Login(IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection) | Obsolete.
Login(IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection) |
Login(IIdentityService, IAgent, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String) |
Login(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String) | Obsolete. Logs in the agent to the ACD group specified by the queue parameter.
Login(IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32) | Obsolete.
Login(IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, String) | Obsolete.
Login(IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32) |
Login(IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, String) | Logs the agent into the ACD group specified by the queue parameter.

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback
Synchronous login with a specified timeout

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use method without channel as parameters")]
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use method without channel as parameters")> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use method without channel as parameters")]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use method without channel as parameters")]
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use method without channel as parameters")> _
<ExtensionAttribute> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use method without channel as parameters")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, String)
AgentServiceExtensions Class See Also Send Feedback
Logs in the agent to the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use method without channel as parameters")]
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use method without channel as parameters")> _
<ExtensionAttribute> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use method without channel as parameters")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback
Logs in the agent to the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use method without channel as parameters")]
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use method without channel as parameters")> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use method without channel as parameters")]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, String)
AgentServiceExtensions Class See Also Send Feedback
Logs the agent into the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Logout Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
Logout(IIdentityService, IAgent, IClientChannel, String, KeyValueCollection, KeyValueCollection) | Obsolete.
Logout(IIdentityService, IAgent, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32) | Obsolete. Logs the agent out of the ACD group specified by the queue parameter.
Logout(IIdentityService, IAgent, IClientChannel, String, KeyValueCollection, KeyValueCollection, String) | Obsolete. Logs the agent out of the ACD group specified by the queue parameter.
Logout(IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection) |
Logout(IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection) |
Logout(IIdentityService, IAgent, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String) | Obsolete. Logs the agent out of the ACD group specified by the queue parameter.
Logout(IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32) | Logs the agent out of the ACD group specified by the queue parameter.
Logout(IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, String) | Obsolete.
Logout(IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, Int32) |
Logout(IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, String) |
Logout(IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, String) | Obsolete. Logs the agent out of the ACD group specified by the queue parameter.
Logout(IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


Logout Method (IIdentityService, IAgent, IClientChannel, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method (IIdentityService, IAgent, IClientChannel, String, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Logout(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function Logout ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ Logout(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
Logout Overload
Genesyslab.Enterprise.Extensions Namespace


Logout Method (IIdentityService, IAgent, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method (IIdentityService, IAgent, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback
Logs the agent out of the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Logout(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function Logout ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ Logout(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
Logout Overload
Genesyslab.Enterprise.Extensions Namespace


Logout Method (IIdentityService, IAgent, IClientChannel, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method (IIdentityService, IAgent, IClientChannel, String, KeyValueCollection, KeyValueCollection, String)
AgentServiceExtensions Class See Also Send Feedback
Logs the agent out of the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Logout(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function Logout ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ Logout(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

AgentServiceExtensions Class
Logout Overload
Genesyslab.Enterprise.Extensions Namespace


Logout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> Logout(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Logout ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Logout(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
Logout Overload
Genesyslab.Enterprise.Extensions Namespace


Logout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> Logout(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Logout ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Logout(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
Logout Overload
Genesyslab.Enterprise.Extensions Namespace


Logout Method (IIdentityService, IAgent, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method (IIdentityService, IAgent, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback
Logs the agent out of the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Logout(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function Logout ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Logout(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
Logout Overload
Genesyslab.Enterprise.Extensions Namespace


Logout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback
Logs the agent out of the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> Logout(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Logout ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Logout(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
Logout Overload
Genesyslab.Enterprise.Extensions Namespace


Logout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Logout(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function Logout ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ Logout(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

AgentServiceExtensions Class
Logout Overload
Genesyslab.Enterprise.Extensions Namespace


Logout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> Logout(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Logout ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Logout(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
Logout Overload
Genesyslab.Enterprise.Extensions Namespace


Logout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> Logout(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Logout ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Logout(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

AgentServiceExtensions Class
Logout Overload
Genesyslab.Enterprise.Extensions Namespace


Logout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback
Logs the agent out of the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Logout(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function Logout ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Logout(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
Logout Overload
Genesyslab.Enterprise.Extensions Namespace


Logout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> Logout(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Logout ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Logout(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
Logout Overload
Genesyslab.Enterprise.Extensions Namespace


NotReady Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.NotReady Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
NotReady(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection) | Obsolete.
NotReady(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection) |
NotReady(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32) | Obsolete.
NotReady(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, String) | Obsolete.
NotReady(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32) |
NotReady(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, String) | Sets the agent's status to not ready for receiving new calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.
NotReady(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String) | Obsolete. Sets the agent's status to not ready for NOT receiving new ACD calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.
NotReady(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


NotReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.NotReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> NotReady(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function NotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ NotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
NotReady Overload
Genesyslab.Enterprise.Extensions Namespace


NotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.NotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> NotReady(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function NotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ NotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
NotReady Overload
Genesyslab.Enterprise.Extensions Namespace


NotReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.NotReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> NotReady(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function NotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ NotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
NotReady Overload
Genesyslab.Enterprise.Extensions Namespace


NotReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.NotReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> NotReady(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function NotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ NotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

AgentServiceExtensions Class
NotReady Overload
Genesyslab.Enterprise.Extensions Namespace


NotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.NotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> NotReady(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function NotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ NotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
NotReady Overload
Genesyslab.Enterprise.Extensions Namespace


NotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.NotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, String)
AgentServiceExtensions Class See Also Send Feedback
Sets the agent's status to not ready for receiving new calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> NotReady(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function NotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ NotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

AgentServiceExtensions Class
NotReady Overload
Genesyslab.Enterprise.Extensions Namespace


NotReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.NotReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback
Sets the agent's status to not ready for NOT receiving new ACD calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> NotReady(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function NotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ NotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
NotReady Overload
Genesyslab.Enterprise.Extensions Namespace


NotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.NotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> NotReady(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function NotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ NotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
NotReady Overload
Genesyslab.Enterprise.Extensions Namespace


Ready Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Ready Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
Ready(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection) | Obsolete.
Ready(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection) |
Ready(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32) |
Ready(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, String) | Obsolete. Sets the agent's status to ready for receiving new calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.
Ready(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32) |
Ready(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, String) |
Ready(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String) | Obsolete. Sets the agent's status to ready for receiving new calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.
Ready(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


Ready Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Ready Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Ready(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function Ready ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Ready(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
Ready Overload
Genesyslab.Enterprise.Extensions Namespace


Ready Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Ready Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> Ready(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Ready ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Ready(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
Ready Overload
Genesyslab.Enterprise.Extensions Namespace


Ready Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Ready Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> Ready(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Ready ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Ready(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
Ready Overload
Genesyslab.Enterprise.Extensions Namespace


Ready Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Ready Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, String)
AgentServiceExtensions Class See Also Send Feedback
Sets the agent's status to ready for receiving new calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Ready(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function Ready ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Ready(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

AgentServiceExtensions Class
Ready Overload
Genesyslab.Enterprise.Extensions Namespace


Ready Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Ready Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> Ready(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Ready ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Ready(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
Ready Overload
Genesyslab.Enterprise.Extensions Namespace


Ready Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Ready Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> Ready(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Ready ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Ready(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

AgentServiceExtensions Class
Ready Overload
Genesyslab.Enterprise.Extensions Namespace


Ready Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Ready Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback
Sets the agent's status to ready for receiving new calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Ready(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function Ready ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Ready(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
Ready Overload
Genesyslab.Enterprise.Extensions Namespace


Ready Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Ready Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> Ready(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Ready ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Ready(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
Ready Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOff Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SetDNDOff(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection) | Obsolete.
SetDNDOff(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection) |
SetDNDOff(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) | Obsolete.
SetDNDOff(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Obsolete. Deactivates the Do Not Disturb mode for the given agent.
SetDNDOff(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32) |
SetDNDOff(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, String) |
SetDNDOff(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Obsolete. Deactivates the Do Not Disturb mode for the given agent.
SetDNDOff(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> SetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function SetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ SetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
SetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> SetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ SetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
SetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> SetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function SetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ SetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
SetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, String)
AgentServiceExtensions Class See Also Send Feedback
Deactivates the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> SetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function SetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ SetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

AgentServiceExtensions Class
SetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> SetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ SetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
SetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> SetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ SetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

AgentServiceExtensions Class
SetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback
Deactivates the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> SetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function SetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ SetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
SetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> SetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ SetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
SetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOn Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SetDNDOn(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection) | Obsolete.
SetDNDOn(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection) |
SetDNDOn(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) | Obsolete.
SetDNDOn(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Obsolete. Activates the Do Not Disturb mode for the given agent.
SetDNDOn(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32) |
SetDNDOn(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, String) |
SetDNDOn(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Obsolete. Activates the Do Not Disturb mode for the given agent.
SetDNDOn(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> SetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function SetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ SetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
SetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> SetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ SetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
SetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> SetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function SetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ SetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
SetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, String)
AgentServiceExtensions Class See Also Send Feedback
Activates the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> SetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function SetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ SetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

AgentServiceExtensions Class
SetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> SetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ SetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
SetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> SetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ SetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

AgentServiceExtensions Class
SetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback
Activates the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> SetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function SetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ SetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
SetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, String)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IAgent> SetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ SetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

AgentServiceExtensions Class
SetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


DeviceServiceExtensions Class

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions Class
Members See Also Send Feedback
Extends the device service to perform switch-specific actions on the device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static class DeviceServiceExtensions
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class DeviceServiceExtensions
Visual C++
[ExtensionAttribute]
public ref class DeviceServiceExtensions abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Extensions..::.DeviceServiceExtensions

See Also

DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


DeviceServiceExtensions Members

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions Members
DeviceServiceExtensions Class Methods See Also Send Feedback

The DeviceServiceExtensions type exposes the following members.

Methods

Name | Description
Activate | Overloaded.
BeginActivate | Overloaded.
BeginCallForwardCancel | Overloaded.
BeginCallForwardSet | Overloaded.
BeginSetDNDOff | Overloaded.
BeginSetDNDOn | Overloaded.
BeginUnactivate | Overloaded.
CallForwardCancel | Overloaded.
CallForwardSet | Overloaded.
EndActivate | Activates the device in the back-end server.
EndCallForwardCancel | Deactivates the Forward feature for the specified device.
EndCallForwardSet | Activates the Forward feature for the specified device.
EndSetDNDOff | Deactivates the Do Not Disturb feature for the specified device.
EndSetDNDOn | Activates the Do Not Disturb feature for the specified device.
EndUnactivate | Unactivates the device in the back-end server.
SetDNDOff | Overloaded.
SetDNDOn | Overloaded.
Unactivate | Overloaded.

See Also

DeviceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


DeviceServiceExtensions Methods

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions Methods
DeviceServiceExtensions Class See Also Send Feedback

The DeviceServiceExtensions type exposes the following members.

Methods

Name | Description
Activate | Overloaded.
BeginActivate | Overloaded.
BeginCallForwardCancel | Overloaded.
BeginCallForwardSet | Overloaded.
BeginSetDNDOff | Overloaded.
BeginSetDNDOn | Overloaded.
BeginUnactivate | Overloaded.
CallForwardCancel | Overloaded.
CallForwardSet | Overloaded.
EndActivate | Activates the device in the back-end server.
EndCallForwardCancel | Deactivates the Forward feature for the specified device.
EndCallForwardSet | Activates the Forward feature for the specified device.
EndSetDNDOff | Deactivates the Do Not Disturb feature for the specified device.
EndSetDNDOn | Activates the Do Not Disturb feature for the specified device.
EndUnactivate | Unactivates the device in the back-end server.
SetDNDOff | Overloaded.
SetDNDOn | Overloaded.
Unactivate | Overloaded.

See Also

DeviceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


Activate Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.Activate Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
Activate(IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection) | Activates synchronously the device in the back-end server.
Activate(IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, Int32) | Activates synchronously the device in the back-end server.
Activate(IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, String) | Activates synchronously the device in the back-end server.
Activate(IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, Int32, String) | Activates synchronously the device in the back-end server.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


Activate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.Activate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection)
DeviceServiceExtensions Class See Also Send Feedback
Activates synchronously the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> Activate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int registerMode,
    int addressType,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Activate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    registerMode As Integer, _
    addressType As Integer, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ Activate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int registerMode,
    int addressType,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService
Device service.
device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

registerMode
Type: System..::.Int32
Register mode.
addressType
Type: System..::.Int32

[Missing <param name="addressType"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

DeviceServiceExtensions Class
Activate Overload
Genesyslab.Enterprise.Extensions Namespace


Activate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.Activate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, Int32)
DeviceServiceExtensions Class See Also Send Feedback
Activates synchronously the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> Activate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int registerMode,
    int addressType,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Activate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    registerMode As Integer, _
    addressType As Integer, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ Activate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int registerMode,
    int addressType,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService
Device service.
device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

registerMode
Type: System..::.Int32
Register mode.
addressType
Type: System..::.Int32

[Missing <param name="addressType"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

DeviceServiceExtensions Class
Activate Overload
Genesyslab.Enterprise.Extensions Namespace


Activate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.Activate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, String)
DeviceServiceExtensions Class See Also Send Feedback
Activates synchronously the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> Activate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int registerMode,
    int addressType,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Activate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    registerMode As Integer, _
    addressType As Integer, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ Activate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int registerMode,
    int addressType,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

registerMode
Type: System..::.Int32

[Missing <param name="registerMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

addressType
Type: System..::.Int32

[Missing <param name="addressType"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

DeviceServiceExtensions Class
Activate Overload
Genesyslab.Enterprise.Extensions Namespace


Activate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.Activate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, Int32, String)
DeviceServiceExtensions Class See Also Send Feedback
Activates synchronously the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> Activate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int registerMode,
    int addressType,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Activate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    registerMode As Integer, _
    addressType As Integer, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ Activate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int registerMode,
    int addressType,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService
Device service.
device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

registerMode
Type: System..::.Int32
Register mode.
addressType
Type: System..::.Int32

[Missing <param name="addressType"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

DeviceServiceExtensions Class
Activate Overload
Genesyslab.Enterprise.Extensions Namespace


BeginActivate Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginActivate Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginActivate(IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, Int32, AsyncCallback, Object, String) | Activates asynchronously the device in the back-end server.
BeginActivate(IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, AsyncCallback, Object) | Activates asynchronously the device in the back-end server.
BeginActivate(IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, AsyncCallback, Object, String) | Activates asynchronously the device in the back-end server.
BeginActivate(IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, Int32, AsyncCallback, Object) | Activates asynchronously the device in the back-end server.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginActivate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginActivate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, Int32, AsyncCallback, Object, String)
DeviceServiceExtensions Class See Also Send Feedback
Activates asynchronously the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginActivate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int registerMode,
    int addressType,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginActivate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    registerMode As Integer, _
    addressType As Integer, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginActivate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int registerMode,
    int addressType,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

registerMode
Type: System..::.Int32

[Missing <param name="registerMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

addressType
Type: System..::.Int32

[Missing <param name="addressType"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

DeviceServiceExtensions Class
BeginActivate Overload
Genesyslab.Enterprise.Extensions Namespace


BeginActivate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginActivate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback
Activates asynchronously the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginActivate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int registerMode,
    int addressType,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginActivate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    registerMode As Integer, _
    addressType As Integer, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginActivate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int registerMode,
    int addressType,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

registerMode
Type: System..::.Int32

[Missing <param name="registerMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

addressType
Type: System..::.Int32

[Missing <param name="addressType"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginActivate Overload
Genesyslab.Enterprise.Extensions Namespace


BeginActivate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginActivate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, AsyncCallback, Object, String)
DeviceServiceExtensions Class See Also Send Feedback
Activates asynchronously the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginActivate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int registerMode,
    int addressType,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginActivate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    registerMode As Integer, _
    addressType As Integer, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginActivate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int registerMode,
    int addressType,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

registerMode
Type: System..::.Int32

[Missing <param name="registerMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

addressType
Type: System..::.Int32

[Missing <param name="addressType"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

DeviceServiceExtensions Class
BeginActivate Overload
Genesyslab.Enterprise.Extensions Namespace


BeginActivate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginActivate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, Int32, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback
Activates asynchronously the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginActivate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int registerMode,
    int addressType,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginActivate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    registerMode As Integer, _
    addressType As Integer, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginActivate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int registerMode,
    int addressType,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

registerMode
Type: System..::.Int32

[Missing <param name="registerMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

addressType
Type: System..::.Int32

[Missing <param name="addressType"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginActivate Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginCallForwardCancel Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginCallForwardCancel(IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Deactivates the Forward feature for the specified device.
BeginCallForwardCancel(IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginCallForwardCancel(IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Deactivates the Forward feature for the specified device.
BeginCallForwardCancel(IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginCallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
DeviceServiceExtensions Class See Also Send Feedback
Deactivates the Forward feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCallForwardCancel(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardCancel ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardCancel(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

DeviceServiceExtensions Class
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginCallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCallForwardCancel(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardCancel ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardCancel(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginCallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
DeviceServiceExtensions Class See Also Send Feedback
Deactivates the Forward feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCallForwardCancel(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardCancel ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardCancel(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

DeviceServiceExtensions Class
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginCallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCallForwardCancel(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardCancel ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardCancel(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginCallForwardSet Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginCallForwardSet(IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Activates the Forward feature for the specified device.
BeginCallForwardSet(IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginCallForwardSet(IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Activates the Forward feature for the specified device.
BeginCallForwardSet(IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginCallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
DeviceServiceExtensions Class See Also Send Feedback
Activates the Forward feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCallForwardSet(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardSet ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardSet(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

DeviceServiceExtensions Class
BeginCallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginCallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCallForwardSet(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardSet ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardSet(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginCallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginCallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
DeviceServiceExtensions Class See Also Send Feedback
Activates the Forward feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCallForwardSet(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardSet ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardSet(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

DeviceServiceExtensions Class
BeginCallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginCallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCallForwardSet(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardSet ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardSet(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginCallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginSetDNDOff Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSetDNDOff(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSetDNDOff(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Deactivates the Do Not Disturb feature for the specified device.
BeginSetDNDOff(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSetDNDOff(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Deactivates the Do Not Disturb feature for the specified device.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginSetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetDNDOff(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOff ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOff(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginSetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginSetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
DeviceServiceExtensions Class See Also Send Feedback
Deactivates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetDNDOff(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOff ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOff(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

DeviceServiceExtensions Class
BeginSetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginSetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetDNDOff(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOff ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOff(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginSetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginSetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
DeviceServiceExtensions Class See Also Send Feedback
Deactivates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetDNDOff(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOff ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOff(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

DeviceServiceExtensions Class
BeginSetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginSetDNDOn Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSetDNDOn(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSetDNDOn(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Activates the Do Not Disturb feature for the specified device.
BeginSetDNDOn(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSetDNDOn(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Activates the Do Not Disturb feature for the specified device.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginSetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetDNDOn(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOn ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOn(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginSetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginSetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
DeviceServiceExtensions Class See Also Send Feedback
Activates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetDNDOn(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOn ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOn(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

DeviceServiceExtensions Class
BeginSetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginSetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetDNDOn(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOn ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOn(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginSetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginSetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
DeviceServiceExtensions Class See Also Send Feedback
Activates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetDNDOn(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOn ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOn(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

DeviceServiceExtensions Class
BeginSetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginUnactivate Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginUnactivate Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginUnactivate(IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, AsyncCallback, Object) |
BeginUnactivate(IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, AsyncCallback, Object, String) | Unactivates the device in the back-end server.
BeginUnactivate(IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginUnactivate(IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, Int32, AsyncCallback, Object, String) | Unactivates the device in the back-end server.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginUnactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginUnactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginUnactivate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int controlMode,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginUnactivate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    controlMode As Integer, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginUnactivate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int controlMode,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

controlMode
Type: System..::.Int32

[Missing <param name="controlMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginUnactivate Overload
Genesyslab.Enterprise.Extensions Namespace


BeginUnactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginUnactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, AsyncCallback, Object, String)
DeviceServiceExtensions Class See Also Send Feedback
Unactivates the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginUnactivate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int controlMode,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginUnactivate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    controlMode As Integer, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginUnactivate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int controlMode,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

controlMode
Type: System..::.Int32

[Missing <param name="controlMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

DeviceServiceExtensions Class
BeginUnactivate Overload
Genesyslab.Enterprise.Extensions Namespace


BeginUnactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginUnactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, Int32, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginUnactivate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int controlMode,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginUnactivate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    controlMode As Integer, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginUnactivate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int controlMode,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

controlMode
Type: System..::.Int32

[Missing <param name="controlMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginUnactivate Overload
Genesyslab.Enterprise.Extensions Namespace


BeginUnactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginUnactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, Int32, AsyncCallback, Object, String)
DeviceServiceExtensions Class See Also Send Feedback
Unactivates the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginUnactivate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int controlMode,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginUnactivate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    controlMode As Integer, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginUnactivate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int controlMode,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

controlMode
Type: System..::.Int32

[Missing <param name="controlMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

DeviceServiceExtensions Class
BeginUnactivate Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.CallForwardCancel Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
CallForwardCancel(IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection) |
CallForwardCancel(IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32) |
CallForwardCancel(IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, String) |
CallForwardCancel(IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String) | Deactivates the Forward feature for the specified device.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.CallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> CallForwardCancel(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardCancel ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ CallForwardCancel(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

DeviceServiceExtensions Class
CallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.CallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> CallForwardCancel(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardCancel ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ CallForwardCancel(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

DeviceServiceExtensions Class
CallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.CallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, String)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> CallForwardCancel(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardCancel ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ CallForwardCancel(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

DeviceServiceExtensions Class
CallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.CallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String)
DeviceServiceExtensions Class See Also Send Feedback
Deactivates the Forward feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> CallForwardCancel(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardCancel ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ CallForwardCancel(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

DeviceServiceExtensions Class
CallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.CallForwardSet Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
CallForwardSet(IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection) |
CallForwardSet(IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32) |
CallForwardSet(IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, String) |
CallForwardSet(IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String) | Activates the Forward feature for the specified device.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.CallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> CallForwardSet(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardSet ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ CallForwardSet(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

DeviceServiceExtensions Class
CallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.CallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> CallForwardSet(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardSet ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ CallForwardSet(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

DeviceServiceExtensions Class
CallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.CallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, String)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> CallForwardSet(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardSet ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ CallForwardSet(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

DeviceServiceExtensions Class
CallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.CallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String)
DeviceServiceExtensions Class See Also Send Feedback
Activates the Forward feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> CallForwardSet(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardSet ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ CallForwardSet(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

DeviceServiceExtensions Class
CallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


EndActivate Method

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.EndActivate Method
DeviceServiceExtensions Class See Also Send Feedback
Activates the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> EndActivate(
    this IDeviceService service,
    IDevice device,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndActivate ( _
    service As IDeviceService, _
    device As IDevice, _
    aResult As IAsyncResult _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ EndActivate(
    IDeviceService^ service,
    IDevice^ device,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

See Also

DeviceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndCallForwardCancel Method

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.EndCallForwardCancel Method
DeviceServiceExtensions Class See Also Send Feedback
Deactivates the Forward feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> EndCallForwardCancel(
    this IDeviceService service,
    IDevice device,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndCallForwardCancel ( _
    service As IDeviceService, _
    device As IDevice, _
    aResult As IAsyncResult _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ EndCallForwardCancel(
    IDeviceService^ service,
    IDevice^ device,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

See Also

DeviceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndCallForwardSet Method

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.EndCallForwardSet Method
DeviceServiceExtensions Class See Also Send Feedback
Activates the Forward feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> EndCallForwardSet(
    this IDeviceService service,
    IDevice device,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndCallForwardSet ( _
    service As IDeviceService, _
    device As IDevice, _
    aResult As IAsyncResult _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ EndCallForwardSet(
    IDeviceService^ service,
    IDevice^ device,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

See Also

DeviceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSetDNDOff Method

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.EndSetDNDOff Method
DeviceServiceExtensions Class See Also Send Feedback
Deactivates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> EndSetDNDOff(
    this IDeviceService service,
    IDevice device,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSetDNDOff ( _
    service As IDeviceService, _
    device As IDevice, _
    aResult As IAsyncResult _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ EndSetDNDOff(
    IDeviceService^ service,
    IDevice^ device,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

See Also

DeviceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSetDNDOn Method

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.EndSetDNDOn Method
DeviceServiceExtensions Class See Also Send Feedback
Activates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> EndSetDNDOn(
    this IDeviceService service,
    IDevice device,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSetDNDOn ( _
    service As IDeviceService, _
    device As IDevice, _
    aResult As IAsyncResult _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ EndSetDNDOn(
    IDeviceService^ service,
    IDevice^ device,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

See Also

DeviceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndUnactivate Method

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.EndUnactivate Method
DeviceServiceExtensions Class See Also Send Feedback
Unactivates the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> EndUnactivate(
    this IDeviceService service,
    IDevice device,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndUnactivate ( _
    service As IDeviceService, _
    device As IDevice, _
    aResult As IAsyncResult _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ EndUnactivate(
    IDeviceService^ service,
    IDevice^ device,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

See Also

DeviceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.SetDNDOff Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SetDNDOff(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection) |
SetDNDOff(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
SetDNDOff(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Deactivates the Do Not Disturb feature for the specified device.
SetDNDOff(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Deactivates the Do Not Disturb feature for the specified device.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.SetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> SetDNDOff(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOff ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ SetDNDOff(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

DeviceServiceExtensions Class
SetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.SetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> SetDNDOff(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOff ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ SetDNDOff(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

DeviceServiceExtensions Class
SetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.SetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, String)
DeviceServiceExtensions Class See Also Send Feedback
Deactivates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> SetDNDOff(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOff ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ SetDNDOff(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

DeviceServiceExtensions Class
SetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.SetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
DeviceServiceExtensions Class See Also Send Feedback
Deactivates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> SetDNDOff(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOff ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ SetDNDOff(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

DeviceServiceExtensions Class
SetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.SetDNDOn Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SetDNDOn(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection) |
SetDNDOn(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
SetDNDOn(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Activates the Do Not Disturb feature for the specified device.
SetDNDOn(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Activates the Do Not Disturb feature for the specified device.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.SetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> SetDNDOn(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOn ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ SetDNDOn(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

DeviceServiceExtensions Class
SetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.SetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> SetDNDOn(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOn ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ SetDNDOn(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

DeviceServiceExtensions Class
SetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.SetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, String)
DeviceServiceExtensions Class See Also Send Feedback
Activates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> SetDNDOn(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOn ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ SetDNDOn(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

DeviceServiceExtensions Class
SetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.SetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
DeviceServiceExtensions Class See Also Send Feedback
Activates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> SetDNDOn(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOn ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ SetDNDOn(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

DeviceServiceExtensions Class
SetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


Unactivate Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.Unactivate Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
Unactivate(IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection) |
Unactivate(IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, Int32) |
Unactivate(IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, String) | Unactivates the device in the back-end server.
Unactivate(IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, Int32, String) | Unactivates the device in the back-end server.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


Unactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.Unactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> Unactivate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int controlMode,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Unactivate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    controlMode As Integer, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ Unactivate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int controlMode,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

controlMode
Type: System..::.Int32

[Missing <param name="controlMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

DeviceServiceExtensions Class
Unactivate Overload
Genesyslab.Enterprise.Extensions Namespace


Unactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.Unactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, Int32)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> Unactivate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int controlMode,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Unactivate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    controlMode As Integer, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ Unactivate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int controlMode,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

controlMode
Type: System..::.Int32

[Missing <param name="controlMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

DeviceServiceExtensions Class
Unactivate Overload
Genesyslab.Enterprise.Extensions Namespace


Unactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.Unactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, String)
DeviceServiceExtensions Class See Also Send Feedback
Unactivates the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> Unactivate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int controlMode,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Unactivate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    controlMode As Integer, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ Unactivate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int controlMode,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

controlMode
Type: System..::.Int32

[Missing <param name="controlMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

DeviceServiceExtensions Class
Unactivate Overload
Genesyslab.Enterprise.Extensions Namespace


Unactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.Unactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, Int32, String)
DeviceServiceExtensions Class See Also Send Feedback
Unactivates the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IDN> Unactivate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int controlMode,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Unactivate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    controlMode As Integer, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ Unactivate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int controlMode,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

controlMode
Type: System..::.Int32

[Missing <param name="controlMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

DeviceServiceExtensions Class
Unactivate Overload
Genesyslab.Enterprise.Extensions Namespace


IdentityService Class

[image]

Enterprise SDK 8.0 Reference API
IdentityService Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Extensions.IdentityService"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static class IdentityService
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class IdentityService
Visual C++
[ExtensionAttribute]
public ref class IdentityService abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Extensions..::.IdentityService

See Also

IdentityService Members
Genesyslab.Enterprise.Extensions Namespace


IdentityService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IdentityService Members
IdentityService Class Methods See Also Send Feedback

Methods

Name | Description
GetAgent | Overloaded.
GetAgentService | Overloaded.
GetPerson | Overloaded.
GetPersonService | Overloaded.
GetSupervisor | Overloaded.
GetSupervisorService | Overloaded.

See Also

IdentityService Class
Genesyslab.Enterprise.Extensions Namespace


IdentityService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IdentityService Methods
IdentityService Class See Also Send Feedback

Methods

Name | Description
GetAgent | Overloaded.
GetAgentService | Overloaded.
GetPerson | Overloaded.
GetPersonService | Overloaded.
GetSupervisor | Overloaded.
GetSupervisorService | Overloaded.

See Also

IdentityService Class
Genesyslab.Enterprise.Extensions Namespace


GetAgent Method

[image] [image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetAgent Method
IdentityService Class See Also Send Feedback

Overload List

Name | Description
GetAgent(IIdentityService, String, Object) |
GetAgent(IIdentityService, String, Object, IRole) |

See Also

IdentityService Class
IdentityService Members
Genesyslab.Enterprise.Extensions Namespace


GetAgent Method (IIdentityService, String, Object)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetAgent Method (IIdentityService, String, Object)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IIdentity GetAgent(
    this IIdentityService service,
    string name,
    Object controller
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetAgent ( _
    service As IIdentityService, _
    name As String, _
    controller As Object _
) As IIdentity
Visual C++
[ExtensionAttribute]
public:
static IIdentity^ GetAgent(
    IIdentityService^ service,
    String^ name,
    Object^ controller
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

controller
Type: System..::.Object

[Missing <param name="controller"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

See Also

IdentityService Class
GetAgent Overload
Genesyslab.Enterprise.Extensions Namespace


GetAgent Method (IIdentityService, String, Object, IRole)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetAgent Method (IIdentityService, String, Object, IRole)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IIdentity GetAgent(
    this IIdentityService service,
    string name,
    Object controller,
    IRole role
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetAgent ( _
    service As IIdentityService, _
    name As String, _
    controller As Object, _
    role As IRole _
) As IIdentity
Visual C++
[ExtensionAttribute]
public:
static IIdentity^ GetAgent(
    IIdentityService^ service,
    String^ name,
    Object^ controller,
    IRole^ role
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

controller
Type: System..::.Object

[Missing <param name="controller"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IdentityService Class
GetAgent Overload
Genesyslab.Enterprise.Extensions Namespace


GetAgentService Method

[image] [image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetAgentService Method
IdentityService Class See Also Send Feedback

Overload List

Name | Description
GetAgentService(IIdentityService, IAgent) |
GetAgentService(IIdentityService, IRole) |

See Also

IdentityService Class
IdentityService Members
Genesyslab.Enterprise.Extensions Namespace


GetAgentService Method (IIdentityService, IAgent)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetAgentService Method (IIdentityService, IAgent)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgentService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAgentService GetAgentService(
    this IIdentityService service,
    IAgent agent
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetAgentService ( _
    service As IIdentityService, _
    agent As IAgent _
) As IAgentService
Visual C++
[ExtensionAttribute]
public:
static IAgentService^ GetAgentService(
    IIdentityService^ service,
    IAgent^ agent
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgentService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgentService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgentService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

See Also

IdentityService Class
GetAgentService Overload
Genesyslab.Enterprise.Extensions Namespace


GetAgentService Method (IIdentityService, IRole)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetAgentService Method (IIdentityService, IRole)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgentService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAgentService GetAgentService(
    this IIdentityService service,
    IRole role
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetAgentService ( _
    service As IIdentityService, _
    role As IRole _
) As IAgentService
Visual C++
[ExtensionAttribute]
public:
static IAgentService^ GetAgentService(
    IIdentityService^ service,
    IRole^ role
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgentService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgentService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgentService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IdentityService Class
GetAgentService Overload
Genesyslab.Enterprise.Extensions Namespace


GetPerson Method

[image] [image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetPerson Method
IdentityService Class See Also Send Feedback

Overload List

Name | Description
GetPerson(IIdentityService, String, Object) |
GetPerson(IIdentityService, String, Object, IRole) |

See Also

IdentityService Class
IdentityService Members
Genesyslab.Enterprise.Extensions Namespace


GetPerson Method (IIdentityService, String, Object)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetPerson Method (IIdentityService, String, Object)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IIdentity GetPerson(
    this IIdentityService service,
    string name,
    Object controller
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetPerson ( _
    service As IIdentityService, _
    name As String, _
    controller As Object _
) As IIdentity
Visual C++
[ExtensionAttribute]
public:
static IIdentity^ GetPerson(
    IIdentityService^ service,
    String^ name,
    Object^ controller
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

controller
Type: System..::.Object

[Missing <param name="controller"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

See Also

IdentityService Class
GetPerson Overload
Genesyslab.Enterprise.Extensions Namespace


GetPerson Method (IIdentityService, String, Object, IRole)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetPerson Method (IIdentityService, String, Object, IRole)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IIdentity GetPerson(
    this IIdentityService service,
    string name,
    Object controller,
    IRole role
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetPerson ( _
    service As IIdentityService, _
    name As String, _
    controller As Object, _
    role As IRole _
) As IIdentity
Visual C++
[ExtensionAttribute]
public:
static IIdentity^ GetPerson(
    IIdentityService^ service,
    String^ name,
    Object^ controller,
    IRole^ role
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

controller
Type: System..::.Object

[Missing <param name="controller"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IdentityService Class
GetPerson Overload
Genesyslab.Enterprise.Extensions Namespace


GetPersonService Method

[image] [image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetPersonService Method
IdentityService Class See Also Send Feedback

Overload List

Name | Description
GetPersonService(IIdentityService, IAgent) |
GetPersonService(IIdentityService, IRole) |

See Also

IdentityService Class
IdentityService Members
Genesyslab.Enterprise.Extensions Namespace


GetPersonService Method (IIdentityService, IAgent)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetPersonService Method (IIdentityService, IAgent)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPersonService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAgentService GetPersonService(
    this IIdentityService service,
    IAgent person
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetPersonService ( _
    service As IIdentityService, _
    person As IAgent _
) As IAgentService
Visual C++
[ExtensionAttribute]
public:
static IAgentService^ GetPersonService(
    IIdentityService^ service,
    IAgent^ person
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPersonService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

person
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="person"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPersonService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPersonService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

See Also

IdentityService Class
GetPersonService Overload
Genesyslab.Enterprise.Extensions Namespace


GetPersonService Method (IIdentityService, IRole)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetPersonService Method (IIdentityService, IRole)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPersonService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAgentService GetPersonService(
    this IIdentityService service,
    IRole role
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetPersonService ( _
    service As IIdentityService, _
    role As IRole _
) As IAgentService
Visual C++
[ExtensionAttribute]
public:
static IAgentService^ GetPersonService(
    IIdentityService^ service,
    IRole^ role
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPersonService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPersonService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPersonService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IdentityService Class
GetPersonService Overload
Genesyslab.Enterprise.Extensions Namespace


GetSupervisor Method

[image] [image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetSupervisor Method
IdentityService Class See Also Send Feedback

Overload List

Name | Description
GetSupervisor(IIdentityService, String, Object) |
GetSupervisor(IIdentityService, String, Object, IRole) |

See Also

IdentityService Class
IdentityService Members
Genesyslab.Enterprise.Extensions Namespace


GetSupervisor Method (IIdentityService, String, Object)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetSupervisor Method (IIdentityService, String, Object)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IIdentity GetSupervisor(
    this IIdentityService service,
    string name,
    Object controller
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetSupervisor ( _
    service As IIdentityService, _
    name As String, _
    controller As Object _
) As IIdentity
Visual C++
[ExtensionAttribute]
public:
static IIdentity^ GetSupervisor(
    IIdentityService^ service,
    String^ name,
    Object^ controller
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

controller
Type: System..::.Object

[Missing <param name="controller"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

See Also

IdentityService Class
GetSupervisor Overload
Genesyslab.Enterprise.Extensions Namespace


GetSupervisor Method (IIdentityService, String, Object, IRole)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetSupervisor Method (IIdentityService, String, Object, IRole)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IIdentity GetSupervisor(
    this IIdentityService service,
    string name,
    Object controller,
    IRole role
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetSupervisor ( _
    service As IIdentityService, _
    name As String, _
    controller As Object, _
    role As IRole _
) As IIdentity
Visual C++
[ExtensionAttribute]
public:
static IIdentity^ GetSupervisor(
    IIdentityService^ service,
    String^ name,
    Object^ controller,
    IRole^ role
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

controller
Type: System..::.Object

[Missing <param name="controller"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IdentityService Class
GetSupervisor Overload
Genesyslab.Enterprise.Extensions Namespace


GetSupervisorService Method

[image] [image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetSupervisorService Method
IdentityService Class See Also Send Feedback

Overload List

Name | Description
GetSupervisorService(IIdentityService, IAgent) |
GetSupervisorService(IIdentityService, IRole) |

See Also

IdentityService Class
IdentityService Members
Genesyslab.Enterprise.Extensions Namespace


GetSupervisorService Method (IIdentityService, IAgent)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetSupervisorService Method (IIdentityService, IAgent)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisorService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAgentService GetSupervisorService(
    this IIdentityService service,
    IAgent supervisor
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetSupervisorService ( _
    service As IIdentityService, _
    supervisor As IAgent _
) As IAgentService
Visual C++
[ExtensionAttribute]
public:
static IAgentService^ GetSupervisorService(
    IIdentityService^ service,
    IAgent^ supervisor
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisorService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

supervisor
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="supervisor"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisorService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisorService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

See Also

IdentityService Class
GetSupervisorService Overload
Genesyslab.Enterprise.Extensions Namespace


GetSupervisorService Method (IIdentityService, IRole)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetSupervisorService Method (IIdentityService, IRole)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisorService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAgentService GetSupervisorService(
    this IIdentityService service,
    IRole role
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetSupervisorService ( _
    service As IIdentityService, _
    role As IRole _
) As IAgentService
Visual C++
[ExtensionAttribute]
public:
static IAgentService^ GetSupervisorService(
    IIdentityService^ service,
    IRole^ role
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisorService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisorService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisorService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IdentityService Class
GetSupervisorService Overload
Genesyslab.Enterprise.Extensions Namespace


IMServiceExtensions Class

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions Class
Members See Also Send Feedback
Extends the IM service to start and manage an instant messaging session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static class IMServiceExtensions
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class IMServiceExtensions
Visual C++
[ExtensionAttribute]
public ref class IMServiceExtensions abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Extensions..::.IMServiceExtensions

See Also

IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


IMServiceExtensions Members

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions Members
IMServiceExtensions Class Methods See Also Send Feedback

The IMServiceExtensions type exposes the following members.

Methods

Name | Description
Alternate | Overloaded.
AnswerIM | Overloaded.
BeginAlternate | Overloaded.
BeginAnswerIM | Overloaded.
BeginCompleteConference | Overloaded.
BeginCompleteTransfer | Overloaded.
BeginDeleteFromConference | Overloaded.
BeginHoldIM | Overloaded.
BeginInitiateConference | Overloaded.
BeginInitiateTransfer | Overloaded.
BeginListenDisconnect | Overloaded.
BeginListenReconnect | Overloaded.
BeginMakeIM | Overloaded.
BeginMuteTransfer | Overloaded.
BeginReleaseIM | Overloaded.
BeginRetrieveIM | Overloaded.
BeginSendMessage | Overloaded.
BeginSetCallQualification | Overloaded.
BeginSingleStepConference | Overloaded.
BeginSingleStepTransfer | Overloaded.
CompleteConference | Overloaded.
CompleteTransfer | Overloaded.
DeleteFromConference | Overloaded.
EndAlternate | Ends the asynchronous operation to alternate between the held session and the given session.
EndAnswerIM | Ends the asynchronous "answer" for a given instant messaging session.
EndCompleteConference | Ends the asynchronous completion the two-step conference for the given call.
EndCompleteTransfer | Ends the asynchronous operation to complete the two-step transfer of the given instant messaging conversation.
EndDeleteFromConference | Ends the asynchronous of a call. Deletes the given party from the conference.
EndHoldIM | Ends the asynchronous operation of placing a call on hold.
EndInitiateConference | Ends the asynchronous of a call. Initiates the two-step conference for the given call.
EndInitiateTransfer | Ends the asynchronous initiation step of the two-step transfer.
EndListenDisconnect | Ends the asynchronous of a call.
EndListenReconnect | Ends the asynchronous of a call.
EndMakeIM | Ends the asynchronous start of the new Instant Messaging session.
EndMuteTransfer | Ends the asynchronous transfer of the given interaction in a single blind attempt.
EndReleaseIM | Ends the asynchronous release of the instant messaging session.
EndRetrieveIM | Ends the asynchronous operation initiated to retrieve the given instant messaging conversation (placed on hold).
EndSendMessage | Ends the asynchronous of a call. Send Message.
EndSetCallQualification | Ends the asynchronous of a call. Sets the call qualification.
EndSingleStepConference | Ends the asynchronous of a call. Conferences this call in one step.
EndSingleStepTransfer | Ends the asynchronous transfer in a single step of the Instant Messaging session (without creating a consultation call).
HoldIM | Overloaded.
InitiateConference | Overloaded.
InitiateTransfer | Overloaded.
ListenDisconnect | Overloaded.
ListenReconnect | Overloaded.
MakeIM | Overloaded.
MuteTransfer | Overloaded.
ReleaseIM | Overloaded.
RetrieveIM | Overloaded.
SendMessage | Overloaded.
SetCallQualification | Overloaded.
SingleStepConference | Overloaded.
SingleStepTransfer | Overloaded.

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


IMServiceExtensions Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions Methods
IMServiceExtensions Class See Also Send Feedback

The IMServiceExtensions type exposes the following members.

Methods

Name | Description
Alternate | Overloaded.
AnswerIM | Overloaded.
BeginAlternate | Overloaded.
BeginAnswerIM | Overloaded.
BeginCompleteConference | Overloaded.
BeginCompleteTransfer | Overloaded.
BeginDeleteFromConference | Overloaded.
BeginHoldIM | Overloaded.
BeginInitiateConference | Overloaded.
BeginInitiateTransfer | Overloaded.
BeginListenDisconnect | Overloaded.
BeginListenReconnect | Overloaded.
BeginMakeIM | Overloaded.
BeginMuteTransfer | Overloaded.
BeginReleaseIM | Overloaded.
BeginRetrieveIM | Overloaded.
BeginSendMessage | Overloaded.
BeginSetCallQualification | Overloaded.
BeginSingleStepConference | Overloaded.
BeginSingleStepTransfer | Overloaded.
CompleteConference | Overloaded.
CompleteTransfer | Overloaded.
DeleteFromConference | Overloaded.
EndAlternate | Ends the asynchronous operation to alternate between the held session and the given session.
EndAnswerIM | Ends the asynchronous "answer" for a given instant messaging session.
EndCompleteConference | Ends the asynchronous completion the two-step conference for the given call.
EndCompleteTransfer | Ends the asynchronous operation to complete the two-step transfer of the given instant messaging conversation.
EndDeleteFromConference | Ends the asynchronous of a call. Deletes the given party from the conference.
EndHoldIM | Ends the asynchronous operation of placing a call on hold.
EndInitiateConference | Ends the asynchronous of a call. Initiates the two-step conference for the given call.
EndInitiateTransfer | Ends the asynchronous initiation step of the two-step transfer.
EndListenDisconnect | Ends the asynchronous of a call.
EndListenReconnect | Ends the asynchronous of a call.
EndMakeIM | Ends the asynchronous start of the new Instant Messaging session.
EndMuteTransfer | Ends the asynchronous transfer of the given interaction in a single blind attempt.
EndReleaseIM | Ends the asynchronous release of the instant messaging session.
EndRetrieveIM | Ends the asynchronous operation initiated to retrieve the given instant messaging conversation (placed on hold).
EndSendMessage | Ends the asynchronous of a call. Send Message.
EndSetCallQualification | Ends the asynchronous of a call. Sets the call qualification.
EndSingleStepConference | Ends the asynchronous of a call. Conferences this call in one step.
EndSingleStepTransfer | Ends the asynchronous transfer in a single step of the Instant Messaging session (without creating a consultation call).
HoldIM | Overloaded.
InitiateConference | Overloaded.
InitiateTransfer | Overloaded.
ListenDisconnect | Overloaded.
ListenReconnect | Overloaded.
MakeIM | Overloaded.
MuteTransfer | Overloaded.
ReleaseIM | Overloaded.
RetrieveIM | Overloaded.
SendMessage | Overloaded.
SetCallQualification | Overloaded.
SingleStepConference | Overloaded.
SingleStepTransfer | Overloaded.

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


Alternate Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.Alternate Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
Alternate(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) | Alternates between the held session and the given session. The given session is placed on hold.
Alternate(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) | Alternates between the held session and the given session. The given session is placed on hold.
Alternate(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Alternates between the held session and the given session. The given session is placed on hold.
Alternate(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Alternates between the held session and the given session. The given session is placed on hold.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


Alternate Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.Alternate Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback
Alternates between the held session and the given session. The given session is placed on hold.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> Alternate(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Alternate ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ Alternate(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.Alternate(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
Alternate Overload
Genesyslab.Enterprise.Extensions Namespace


Alternate Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.Alternate Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback
Alternates between the held session and the given session. The given session is placed on hold.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> Alternate(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Alternate ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ Alternate(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.Alternate(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
Alternate Overload
Genesyslab.Enterprise.Extensions Namespace


Alternate Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.Alternate Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback
Alternates between the held session and the given session. The given session is placed on hold.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> Alternate(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Alternate ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ Alternate(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.Alternate(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
Alternate Overload
Genesyslab.Enterprise.Extensions Namespace


Alternate Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.Alternate Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
Alternates between the held session and the given session. The given session is placed on hold.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> Alternate(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Alternate ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ Alternate(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.Alternate(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
Alternate Overload
Genesyslab.Enterprise.Extensions Namespace


AnswerIM Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.AnswerIM Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
AnswerIM(IIMService, IIMInteraction, IClientChannel, KeyValueCollection) | Accepts to participate in the given Instant Messaging session.
AnswerIM(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32) | Accepts to participate in the given Instant Messaging session.
AnswerIM(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, String) | Accepts to participate in the given Instant Messaging session.
AnswerIM(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32, String) | Accepts to participate in the given Instant Messaging session.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


AnswerIM Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.AnswerIM Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback
Accepts to participate in the given Instant Messaging session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> AnswerIM(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AnswerIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ AnswerIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction (the ringing session).
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.AnswerIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
AnswerIM Overload
Genesyslab.Enterprise.Extensions Namespace


AnswerIM Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.AnswerIM Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback
Accepts to participate in the given Instant Messaging session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> AnswerIM(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AnswerIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ AnswerIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction (the ringing session).
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.AnswerIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
AnswerIM Overload
Genesyslab.Enterprise.Extensions Namespace


AnswerIM Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.AnswerIM Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback
Accepts to participate in the given Instant Messaging session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> AnswerIM(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AnswerIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ AnswerIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction (the ringing session).
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
correlatorData
Type: System..::.String
User data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.AnswerIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
AnswerIM Overload
Genesyslab.Enterprise.Extensions Namespace


AnswerIM Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.AnswerIM Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
Accepts to participate in the given Instant Messaging session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> AnswerIM(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AnswerIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ AnswerIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction (the ringing session).
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.AnswerIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.AnswerIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
AnswerIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternate Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginAlternate Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginAlternate(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Initiates the asynchronous operation to alternate between the held session and the given session. The given session is placed on hold on the completion of the operation.
BeginAlternate(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous operation to alternate between the held session and the given session. The given session is placed on hold on the completion of the operation.
BeginAlternate(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Initiates the asynchronous operation to alternate between the held session and the given session. The given session is placed on hold on the completion of the operation.
BeginAlternate(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Initiates the asynchronous operation to alternate between the held session and the given session. The given session is placed on hold on the completion of the operation.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginAlternate Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginAlternate Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous operation to alternate between the held session and the given session. The given session is placed on hold on the completion of the operation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAlternate(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternate ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternate(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginAlternate(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginAlternate Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternate Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginAlternate Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous operation to alternate between the held session and the given session. The given session is placed on hold on the completion of the operation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAlternate(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternate ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternate(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginAlternate(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginAlternate Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternate Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginAlternate Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous operation to alternate between the held session and the given session. The given session is placed on hold on the completion of the operation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAlternate(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternate ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternate(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginAlternate(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginAlternate(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginAlternate(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginAlternate Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternate Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginAlternate Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous operation to alternate between the held session and the given session. The given session is placed on hold on the completion of the operation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAlternate(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternate ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternate(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginAlternate(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginAlternate Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerIM Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginAnswerIM Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginAnswerIM(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object) | Accepts to participate in the given Instant Messaging session. (Asynchronous method.)
BeginAnswerIM(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object, String) | Accepts to participate in the given Instant Messaging session. (Asynchronous method.)
BeginAnswerIM(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object) | Accepts to participate in the given Instant Messaging session. (Asynchronous method.)
BeginAnswerIM(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object, String) | Accepts to participate in the given Instant Messaging session. (Asynchronous method.)

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerIM Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginAnswerIM Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Accepts to participate in the given Instant Messaging session. (Asynchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAnswerIM(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAnswerIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAnswerIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction (the ringing session).
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginAnswerIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginAnswerIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerIM Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginAnswerIM Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Accepts to participate in the given Instant Messaging session. (Asynchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAnswerIM(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAnswerIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAnswerIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction (the ringing session).
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginAnswerIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginAnswerIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerIM Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginAnswerIM Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Accepts to participate in the given Instant Messaging session. (Asynchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAnswerIM(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAnswerIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAnswerIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction (the ringing session).
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginAnswerIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginAnswerIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerIM Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginAnswerIM Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Accepts to participate in the given Instant Messaging session. (Asynchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAnswerIM(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAnswerIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAnswerIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction (the ringing session).
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginAnswerIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginAnswerIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginCompleteConference Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginCompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Completes asynchronously the two-step conference for the given session. This method releases the consultation session.
BeginCompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Completes asynchronously the two-step conference for the given session. This method releases the consultation session.
BeginCompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Completes asynchronously the two-step conference for the given session. This method releases the consultation session.
BeginCompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Completes asynchronously the two-step conference for the given session. This method releases the consultation session.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginCompleteConference Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Completes asynchronously the two-step conference for the given session. This method releases the consultation session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginCompleteConference Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Completes asynchronously the two-step conference for the given session. This method releases the consultation session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginCompleteConference Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Completes asynchronously the two-step conference for the given session. This method releases the consultation session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginCompleteConference Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Completes asynchronously the two-step conference for the given session. This method releases the consultation session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginCompleteTransfer Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginCompleteTransfer(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Initiates the asynchronous operation to complete the two-step transfer of the given instant messaging conversation.
BeginCompleteTransfer(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous operation to complete the two-step transfer of the given instant messaging conversation.
BeginCompleteTransfer(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Initiates the asynchronous operation to complete the two-step transfer of the given instant messaging conversation.
BeginCompleteTransfer(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Initiates the asynchronous operation to complete the two-step transfer of the given instant messaging conversation.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginCompleteTransfer Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous operation to complete the two-step transfer of the given instant messaging conversation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to transfer.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginCompleteTransfer Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous operation to complete the two-step transfer of the given instant messaging conversation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to transfer.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginCompleteTransfer Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous operation to complete the two-step transfer of the given instant messaging conversation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to transfer.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginCompleteTransfer Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous operation to complete the two-step transfer of the given instant messaging conversation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to transfer.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginDeleteFromConference Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginDeleteFromConference(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Deletes the given party from the conference.
BeginDeleteFromConference(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginDeleteFromConference(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Deletes the given party from the conference.
BeginDeleteFromConference(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginDeleteFromConference Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Deletes the given party from the conference.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginDeleteFromConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginDeleteFromConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginDeleteFromConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginDeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginDeleteFromConference Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginDeleteFromConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginDeleteFromConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginDeleteFromConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginDeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginDeleteFromConference Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Deletes the given party from the conference.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginDeleteFromConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginDeleteFromConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginDeleteFromConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginDeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginDeleteFromConference Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginDeleteFromConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginDeleteFromConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginDeleteFromConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginDeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginHoldIM Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginHoldIM Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginHoldIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Places on Hold the instant messaging conversation. (Asynchronous).
BeginHoldIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Places on Hold the instant messaging conversation. (Asynchronous).
BeginHoldIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Places on Hold the instant messaging conversation. (Asynchronous).
BeginHoldIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Places on Hold the instant messaging conversation. (Asynchronous).

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginHoldIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginHoldIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Places on Hold the instant messaging conversation. (Asynchronous).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginHoldIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginHoldIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginHoldIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to place on hold.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginHoldIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginHoldIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginHoldIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginHoldIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Places on Hold the instant messaging conversation. (Asynchronous).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginHoldIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginHoldIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginHoldIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to place on hold.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginHoldIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginHoldIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginHoldIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginHoldIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Places on Hold the instant messaging conversation. (Asynchronous).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginHoldIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginHoldIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginHoldIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to place on hold.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginHoldIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginHoldIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginHoldIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginHoldIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Places on Hold the instant messaging conversation. (Asynchronous).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginHoldIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginHoldIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginHoldIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to place on hold.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginHoldIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginHoldIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginInitiateConference Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginInitiateConference(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Initiates the asynchronous two-step conference for the given call. This method creates a consultation session before the validation of the conference (CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)).
BeginInitiateConference(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous two-step conference for the given call. This method creates a consultation session before the validation of the conference (CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)).
BeginInitiateConference(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Initiates the asynchronous two-step conference for the given call. This method creates a consultation session before the validation of the conference (CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)).
BeginInitiateConference(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Initiates the asynchronous two-step conference for the given call. This method creates a consultation session before the validation of the conference (CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)).

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginInitiateConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous two-step conference for the given call. This method creates a consultation session before the validation of the conference (CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to add to the conference.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginInitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginInitiateConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous two-step conference for the given call. This method creates a consultation session before the validation of the conference (CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to add to the conference.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginInitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginInitiateConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous two-step conference for the given call. This method creates a consultation session before the validation of the conference (CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to add to the conference.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginInitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginInitiateConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous two-step conference for the given call. This method creates a consultation session before the validation of the conference (CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to add to the conference.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginInitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginInitiateTransfer Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginInitiateTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Initiates asynchronously the two-step transfer of the given session. This transfer creates a consultation call.
BeginInitiateTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates asynchronously the two-step transfer of the given session. This transfer creates a consultation call.
BeginInitiateTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Initiates the two-step transfer of the given session. This transfer creates a consultation call.
BeginInitiateTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Initiates the two-step transfer of the given session. This transfer creates a consultation call.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginInitiateTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Initiates asynchronously the two-step transfer of the given session. This transfer creates a consultation call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginInitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginInitiateTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates asynchronously the two-step transfer of the given session. This transfer creates a consultation call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginInitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginInitiateTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Initiates the two-step transfer of the given session. This transfer creates a consultation call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginInitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginInitiateTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the two-step transfer of the given session. This transfer creates a consultation call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginInitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginListenDisconnect Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginListenDisconnect(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginListenDisconnect(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginListenDisconnect(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. BeginListenDisconnect
BeginListenDisconnect(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginListenDisconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenDisconnect(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenDisconnect ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenDisconnect(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginListenDisconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenDisconnect(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenDisconnect ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenDisconnect(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginListenDisconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. BeginListenDisconnect

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenDisconnect(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenDisconnect ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenDisconnect(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginListenDisconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenDisconnect(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenDisconnect ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenDisconnect(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginListenReconnect Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginListenReconnect(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | BeginListenReconnect
BeginListenReconnect(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginListenReconnect(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call.
BeginListenReconnect(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginListenReconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
BeginListenReconnect

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenReconnect(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenReconnect ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenReconnect(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginListenReconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenReconnect(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenReconnect ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenReconnect(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginListenReconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenReconnect(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenReconnect ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenReconnect(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginListenReconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenReconnect(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenReconnect ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenReconnect(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeIM Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginMakeIM Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginMakeIM(IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Initiates the asynchronous call. Starts a new Instant Messaging session.
BeginMakeIM(IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Starts a new Instant Messaging session on a Device. (Asynchronous method.)
BeginMakeIM(IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous start of a new Instant Messaging session.
BeginMakeIM(IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Starts a new Instant Messaging session. (Asynchronous).
BeginMakeIM(IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Starts a new Instant Messaging session on a Device. (Asynchronous method.)
BeginMakeIM(IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Starts a new Instant Messaging session on a Device. (Asynchronous method.)
BeginMakeIM(IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Starts a new Instant Messaging session. (Asynchronous).
BeginMakeIM(IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Starts a new Instant Messaging session on a Device. (Asynchronous method.)

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginMakeIM Method (IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginMakeIM Method (IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Starts a new Instant Messaging session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMakeIM(
    this IIMService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeIM ( _
    service As IIMService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeIM(
    IIMService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Dialing agent.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String
DN to call.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginMakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginMakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginMakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginMakeIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeIM Method (IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginMakeIM Method (IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Starts a new Instant Messaging session on a Device. (Asynchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMakeIM(
    this IIMService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeIM ( _
    service As IIMService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeIM(
    IIMService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
device
Type: Genesyslab.Enterprise.Core..::.IDN
Device of the initiator.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.
otherDN
Type: System..::.String
Targeted device.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type. Only INTERNAL is supported.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for starting this session.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Asynchronous callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginMakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginMakeIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeIM Method (IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginMakeIM Method (IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous start of a new Instant Messaging session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMakeIM(
    this IIMService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeIM ( _
    service As IIMService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeIM(
    IIMService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Dialing agent.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String
DN to call.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginMakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginMakeIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeIM Method (IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginMakeIM Method (IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Starts a new Instant Messaging session. (Asynchronous).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMakeIM(
    this IIMService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeIM ( _
    service As IIMService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeIM(
    IIMService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Dialing agent.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String
DN to call.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginMakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginMakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginMakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginMakeIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeIM Method (IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginMakeIM Method (IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Starts a new Instant Messaging session on a Device. (Asynchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMakeIM(
    this IIMService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeIM ( _
    service As IIMService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeIM(
    IIMService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
device
Type: Genesyslab.Enterprise.Core..::.IDN
Device of the initiator.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.
otherDN
Type: System..::.String
The device of the other party.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type. Only INTERNAL is supported.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for starting this session.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Asynchronous callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginMakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginMakeIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeIM Method (IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginMakeIM Method (IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Starts a new Instant Messaging session on a Device. (Asynchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMakeIM(
    this IIMService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeIM ( _
    service As IIMService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeIM(
    IIMService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
device
Type: Genesyslab.Enterprise.Core..::.IDN
Device of the initiator.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.
otherDN
Type: System..::.String
Targeted device.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type. Only INTERNAL is supported.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for starting this sessions.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Asynchronous callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginMakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginMakeIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeIM Method (IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginMakeIM Method (IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Starts a new Instant Messaging session. (Asynchronous).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMakeIM(
    this IIMService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeIM ( _
    service As IIMService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeIM(
    IIMService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Dialing agent.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication.
otherDN
Type: System..::.String
DN to call.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginMakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginMakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginMakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginMakeIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeIM Method (IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginMakeIM Method (IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Starts a new Instant Messaging session on a Device. (Asynchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMakeIM(
    this IIMService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeIM ( _
    service As IIMService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeIM(
    IIMService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
device
Type: Genesyslab.Enterprise.Core..::.IDN
Device of the initiator.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.
otherDN
Type: System..::.String
Targeted device.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type. Only INTERNAL is supported.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for starting this session.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Asynchronous callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator Data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginMakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginMakeIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginMuteTransfer Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginMuteTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Initiates the transfer of the given interaction in a single blind attempt.
BeginMuteTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the transfer of the given interaction in a single blind attempt.
BeginMuteTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Initiates the transfer of the given interaction in a single blind attempt.
BeginMuteTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Initiates the transfer of the given interaction in a single blind attempt.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginMuteTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Initiates the transfer of the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMuteTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMuteTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMuteTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginMuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginMuteTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the transfer of the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMuteTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMuteTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMuteTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginMuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginMuteTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Initiates the transfer of the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMuteTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMuteTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMuteTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginMuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginMuteTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the transfer of the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMuteTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMuteTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMuteTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginMuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReleaseIM Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginReleaseIM Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginReleaseIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Releases the given interaction (asynchronous method).
BeginReleaseIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Releases the given interaction (asynchronous method).
BeginReleaseIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Releases the given interaction (asynchronous method).
BeginReleaseIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Releases the given interaction (asynchronous method).

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginReleaseIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginReleaseIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Releases the given interaction (asynchronous method).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReleaseIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReleaseIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReleaseIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction (session to quit).
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for quitting.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginReleaseIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginReleaseIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReleaseIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginReleaseIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Releases the given interaction (asynchronous method).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReleaseIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReleaseIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReleaseIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction (session to quit).
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for quitting.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginReleaseIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginReleaseIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReleaseIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginReleaseIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Releases the given interaction (asynchronous method).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReleaseIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReleaseIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReleaseIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction (session to quit).
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for quitting.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginReleaseIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginReleaseIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReleaseIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginReleaseIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Releases the given interaction (asynchronous method).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReleaseIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReleaseIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReleaseIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction (session to quit).
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for quitting.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginReleaseIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginReleaseIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveIM Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginRetrieveIM Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginRetrieveIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Retrieves asynchronously the given instant messaging conversation (placed on hold).
BeginRetrieveIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Ends the asynchronous operation initiated to retrieve the given instant messaging conversation (placed on hold).
BeginRetrieveIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Retrieves asynchronously the given instant messaging conversation (placed on hold).
BeginRetrieveIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Retrieves asynchronously the given instant messaging conversation (placed on hold).

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginRetrieveIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Retrieves asynchronously the given instant messaging conversation (placed on hold).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRetrieveIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRetrieveIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRetrieveIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to retrieve.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginRetrieveIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginRetrieveIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginRetrieveIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous operation initiated to retrieve the given instant messaging conversation (placed on hold).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRetrieveIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRetrieveIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRetrieveIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to retrieve.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
User data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginRetrieveIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginRetrieveIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginRetrieveIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Retrieves asynchronously the given instant messaging conversation (placed on hold).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRetrieveIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRetrieveIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRetrieveIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to retrieve.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginRetrieveIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginRetrieveIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginRetrieveIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Retrieves asynchronously the given instant messaging conversation (placed on hold).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRetrieveIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRetrieveIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRetrieveIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to retrieve.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
User data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginRetrieveIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginRetrieveIM Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSendMessage Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSendMessage Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSendMessage(IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Send Message.
BeginSendMessage(IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Initiates the asynchronous call SendMessage. on the given interaction.
BeginSendMessage(IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call send message. on the given interaction.
BeginSendMessage(IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSendMessage Method (IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSendMessage Method (IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Send Message.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSendMessage(
    this IIMService service,
    IIMInteraction interaction,
    string message,
    MessageContentType contentType,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSendMessage ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    message As String, _
    contentType As MessageContentType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSendMessage(
    IIMService^ service,
    IIMInteraction^ interaction,
    String^ message,
    MessageContentType contentType,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

contentType
Type: Genesyslab.Enterprise.Services..::.MessageContentType

[Missing <param name="contentType"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginSendMessage Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSendMessage Method (IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSendMessage Method (IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call SendMessage. on the given interaction.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSendMessage(
    this IIMService service,
    IIMInteraction interaction,
    string message,
    MessageContentType contentType,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSendMessage ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    message As String, _
    contentType As MessageContentType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSendMessage(
    IIMService^ service,
    IIMInteraction^ interaction,
    String^ message,
    MessageContentType contentType,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

contentType
Type: Genesyslab.Enterprise.Services..::.MessageContentType

[Missing <param name="contentType"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginSendMessage Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSendMessage Method (IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSendMessage Method (IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call send message. on the given interaction.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSendMessage(
    this IIMService service,
    IIMInteraction interaction,
    string message,
    MessageContentType contentType,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSendMessage ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    message As String, _
    contentType As MessageContentType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSendMessage(
    IIMService^ service,
    IIMInteraction^ interaction,
    String^ message,
    MessageContentType contentType,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

contentType
Type: Genesyslab.Enterprise.Services..::.MessageContentType

[Missing <param name="contentType"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginSendMessage Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSendMessage Method (IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSendMessage Method (IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSendMessage(
    this IIMService service,
    IIMInteraction interaction,
    string message,
    MessageContentType contentType,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSendMessage ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    message As String, _
    contentType As MessageContentType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSendMessage(
    IIMService^ service,
    IIMInteraction^ interaction,
    String^ message,
    MessageContentType contentType,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

contentType
Type: Genesyslab.Enterprise.Services..::.MessageContentType

[Missing <param name="contentType"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginSendMessage Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSetCallQualification Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSetCallQualification(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object) |
BeginSetCallQualification(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Sets the call qualification.
BeginSetCallQualification(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSetCallQualification(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object, String) | Sets the call qualification.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSetCallQualification Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSetCallQualification Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Sets the call qualification.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSetCallQualification Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSetCallQualification Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Sets the call qualification.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSingleStepConference Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSingleStepConference(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSingleStepConference(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Conferences this call in one step.
BeginSingleStepConference(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSingleStepConference(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Conferences this call in one step.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSingleStepConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginSingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSingleStepConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Conferences this call in one step.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginSingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSingleStepConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginSingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSingleStepConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Conferences this call in one step.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginSingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSingleStepTransfer Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSingleStepTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Initiates the asynchronous transfer in a single step of the Instant Messaging session (without creating a consultation call).
BeginSingleStepTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous transfer in a single step of the Instant Messaging session (without creating a consultation call).
BeginSingleStepTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Initiates the asynchronous transfer in a single step of the Instant Messaging session (without creating a consultation call).
BeginSingleStepTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Initiates the asynchronous transfer in a single step of the Instant Messaging session (without creating a consultation call).

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSingleStepTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous transfer in a single step of the Instant Messaging session (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to transfer.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginSingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSingleStepTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous transfer in a single step of the Instant Messaging session (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to transfer.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginSingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSingleStepTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous transfer in a single step of the Instant Messaging session (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to transfer.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IMServiceExtensions Class
BeginSingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.BeginSingleStepTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the asynchronous transfer in a single step of the Instant Messaging session (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to transfer.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IMServiceExtensions Class
BeginSingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.CompleteConference Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) | Completes the two-step conference for the given session. This method releases the consultation session.
CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) | Completes the two-step conference for the given session. This method releases the consultation session.
CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Completes the two-step conference for the given session. This method releases the consultation session.
CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Completes the two-step conference for the given session. This method releases the consultation session.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.CompleteConference Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback
Completes the two-step conference for the given session. This method releases the consultation session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> CompleteConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ CompleteConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.CompleteConference Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback
Completes the two-step conference for the given session. This method releases the consultation session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> CompleteConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ CompleteConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.CompleteConference Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback
Completes the two-step conference for the given session. This method releases the consultation session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> CompleteConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ CompleteConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.CompleteConference Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
Completes the two-step conference for the given session. This method releases the consultation session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> CompleteConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ CompleteConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.CompleteTransfer Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
CompleteTransfer(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) | Completes the two-step transfer of the given instant messaging conversation.
CompleteTransfer(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) | Completes the two-step transfer of the given instant messaging conversation.
CompleteTransfer(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Completes the two-step transfer of the given instant messaging conversation.
CompleteTransfer(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Completes the two-step transfer of the given instant messaging conversation.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.CompleteTransfer Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback
Completes the two-step transfer of the given instant messaging conversation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> CompleteTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ CompleteTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to transfer.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.CompleteTransfer Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback
Completes the two-step transfer of the given instant messaging conversation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> CompleteTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ CompleteTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to transfer.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.CompleteTransfer Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback
Completes the two-step transfer of the given instant messaging conversation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> CompleteTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ CompleteTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to transfer.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.CompleteTransfer Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
Completes the two-step transfer of the given instant messaging conversation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> CompleteTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ CompleteTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to transfer.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.DeleteFromConference Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
DeleteFromConference(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection) |
DeleteFromConference(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32) |
DeleteFromConference(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String) | Deletes the given party from the conference.
DeleteFromConference(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String) | Deletes the given party from the conference.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.DeleteFromConference Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> DeleteFromConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function DeleteFromConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ DeleteFromConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
DeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.DeleteFromConference Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> DeleteFromConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function DeleteFromConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ DeleteFromConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
DeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.DeleteFromConference Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback
Deletes the given party from the conference.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> DeleteFromConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function DeleteFromConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ DeleteFromConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String
User defined data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
DeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.DeleteFromConference Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
Deletes the given party from the conference.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> DeleteFromConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function DeleteFromConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ DeleteFromConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
User defined data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
DeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


EndAlternate Method

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.EndAlternate Method
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous operation to alternate between the held session and the given session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> EndAlternate(
    this IIMService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndAlternate ( _
    service As IIMService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ EndAlternate(
    IIMService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndAlternate(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndAlternate(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndAlternate(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndAnswerIM Method

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.EndAnswerIM Method
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous "answer" for a given instant messaging session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> EndAnswerIM(
    this IIMService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndAnswerIM ( _
    service As IIMService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ EndAnswerIM(
    IIMService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndAnswerIM(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndAnswerIM(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndAnswerIM(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndCompleteConference Method

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.EndCompleteConference Method
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous completion the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> EndCompleteConference(
    this IIMService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndCompleteConference ( _
    service As IIMService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ EndCompleteConference(
    IIMService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndCompleteConference(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndCompleteConference(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndCompleteConference(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndCompleteTransfer Method

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.EndCompleteTransfer Method
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous operation to complete the two-step transfer of the given instant messaging conversation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> EndCompleteTransfer(
    this IIMService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndCompleteTransfer ( _
    service As IIMService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ EndCompleteTransfer(
    IIMService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndCompleteTransfer(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndCompleteTransfer(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndCompleteTransfer(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndDeleteFromConference Method

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.EndDeleteFromConference Method
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Deletes the given party from the conference.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> EndDeleteFromConference(
    this IIMService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndDeleteFromConference ( _
    service As IIMService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ EndDeleteFromConference(
    IIMService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndDeleteFromConference(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndHoldIM Method

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.EndHoldIM Method
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous operation of placing a call on hold.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> EndHoldIM(
    this IIMService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndHoldIM ( _
    service As IIMService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ EndHoldIM(
    IIMService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndHoldIM(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndHoldIM(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndHoldIM(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndInitiateConference Method

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.EndInitiateConference Method
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Initiates the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> EndInitiateConference(
    this IIMService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndInitiateConference ( _
    service As IIMService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ EndInitiateConference(
    IIMService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndInitiateConference(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndInitiateConference(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndInitiateConference(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndInitiateTransfer Method

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.EndInitiateTransfer Method
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous initiation step of the two-step transfer.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> EndInitiateTransfer(
    this IIMService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndInitiateTransfer ( _
    service As IIMService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ EndInitiateTransfer(
    IIMService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndInitiateTransfer(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndInitiateTransfer(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndInitiateTransfer(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndListenDisconnect Method

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.EndListenDisconnect Method
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> EndListenDisconnect(
    this IIMService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndListenDisconnect ( _
    service As IIMService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ EndListenDisconnect(
    IIMService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndListenDisconnect(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndListenDisconnect(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndListenDisconnect(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndListenReconnect Method

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.EndListenReconnect Method
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> EndListenReconnect(
    this IIMService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndListenReconnect ( _
    service As IIMService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ EndListenReconnect(
    IIMService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndListenReconnect(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndListenReconnect(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndListenReconnect(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndMakeIM Method

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.EndMakeIM Method
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous start of the new Instant Messaging session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> EndMakeIM(
    this IIMService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndMakeIM ( _
    service As IIMService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ EndMakeIM(
    IIMService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndMakeIM(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndMakeIM(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndMakeIM(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndMuteTransfer Method

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.EndMuteTransfer Method
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous transfer of the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> EndMuteTransfer(
    this IIMService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndMuteTransfer ( _
    service As IIMService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ EndMuteTransfer(
    IIMService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndMuteTransfer(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndMuteTransfer(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndMuteTransfer(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndReleaseIM Method

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.EndReleaseIM Method
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous release of the instant messaging session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> EndReleaseIM(
    this IIMService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndReleaseIM ( _
    service As IIMService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ EndReleaseIM(
    IIMService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndReleaseIM(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndReleaseIM(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndRetrieveIM Method

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.EndRetrieveIM Method
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous operation initiated to retrieve the given instant messaging conversation (placed on hold).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> EndRetrieveIM(
    this IIMService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndRetrieveIM ( _
    service As IIMService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ EndRetrieveIM(
    IIMService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndRetrieveIM(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndRetrieveIM(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndRetrieveIM(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSendMessage Method

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.EndSendMessage Method
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Send Message.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> EndSendMessage(
    this IIMService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSendMessage ( _
    service As IIMService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ EndSendMessage(
    IIMService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndSendMessage(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndSendMessage(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndSendMessage(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSetCallQualification Method

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.EndSetCallQualification Method
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Sets the call qualification.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> EndSetCallQualification(
    this IIMService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSetCallQualification ( _
    service As IIMService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ EndSetCallQualification(
    IIMService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndSetCallQualification(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndSetCallQualification(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndSetCallQualification(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSingleStepConference Method

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.EndSingleStepConference Method
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Conferences this call in one step.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> EndSingleStepConference(
    this IIMService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSingleStepConference ( _
    service As IIMService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ EndSingleStepConference(
    IIMService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndSingleStepConference(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndSingleStepConference(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndSingleStepConference(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSingleStepTransfer Method

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.EndSingleStepTransfer Method
IMServiceExtensions Class See Also Send Feedback
Ends the asynchronous transfer in a single step of the Instant Messaging session (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> EndSingleStepTransfer(
    this IIMService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSingleStepTransfer ( _
    service As IIMService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ EndSingleStepTransfer(
    IIMService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndSingleStepTransfer(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndSingleStepTransfer(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.EndSingleStepTransfer(Genesyslab.Enterprise.Services.IIMService,System.IAsyncResult)"]

See Also

IMServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


HoldIM Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.HoldIM Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
HoldIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection) | Places on Hold the instant messaging conversation.
HoldIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32) | Places on Hold the instant messaging conversation.
HoldIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, String) | Places on Hold the instant messaging conversation.
HoldIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, String) | Places on Hold the instant messaging conversation.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


HoldIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.HoldIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback
Places on Hold the instant messaging conversation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> HoldIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function HoldIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ HoldIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to place on hold.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.HoldIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
HoldIM Overload
Genesyslab.Enterprise.Extensions Namespace


HoldIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.HoldIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback
Places on Hold the instant messaging conversation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> HoldIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function HoldIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ HoldIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to place on hold.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.HoldIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
HoldIM Overload
Genesyslab.Enterprise.Extensions Namespace


HoldIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.HoldIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback
Places on Hold the instant messaging conversation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> HoldIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function HoldIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ HoldIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to place on hold.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.HoldIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
HoldIM Overload
Genesyslab.Enterprise.Extensions Namespace


HoldIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.HoldIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
Places on Hold the instant messaging conversation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> HoldIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function HoldIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ HoldIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to place on hold.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.HoldIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
HoldIM Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.InitiateConference Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
InitiateConference(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) | Initiates the two-step conference of the given session. This method creates a consultation session before the validation of the conference (CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)).
InitiateConference(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) | Initiates the two-step conference of the given session. This method creates a consultation session before the validation of the conference (CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)).
InitiateConference(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) | Initiates the two-step conference of the given session. This method creates a consultation session before the validation of the conference (CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)).
InitiateConference(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) | Initiates the two-step conference for the given call. This method creates a consultation session before the validation of the conference (CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)).

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.InitiateConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the two-step conference of the given session. This method creates a consultation session before the validation of the conference (CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> InitiateConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ InitiateConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to add to the conference.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
InitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.InitiateConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback
Initiates the two-step conference of the given session. This method creates a consultation session before the validation of the conference (CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> InitiateConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ InitiateConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to add to the conference.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
InitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.InitiateConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback
Initiates the two-step conference of the given session. This method creates a consultation session before the validation of the conference (CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> InitiateConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ InitiateConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to add to the conference.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
InitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.InitiateConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the two-step conference for the given call. This method creates a consultation session before the validation of the conference (CompleteConference(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> InitiateConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ InitiateConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to add to the conference.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
InitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.InitiateTransfer Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
InitiateTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) | Initiates the two-step transfer of the given session. This transfer creates a consultation call.
InitiateTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) | Initiates the two-step transfer of the given session. This transfer creates a consultation call.
InitiateTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) | Initiates the two-step transfer of the given session. This transfer creates a consultation call.
InitiateTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) | Initiates the two-step transfer of the given session. This transfer creates a consultation call.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.InitiateTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the two-step transfer of the given session. This transfer creates a consultation call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> InitiateTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ InitiateTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
InitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.InitiateTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback
Initiates the two-step transfer of the given session. This transfer creates a consultation call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> InitiateTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ InitiateTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
InitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.InitiateTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback
Initiates the two-step transfer of the given session. This transfer creates a consultation call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> InitiateTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ InitiateTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
InitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.InitiateTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback
Initiates the two-step transfer of the given session. This transfer creates a consultation call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> InitiateTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ InitiateTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
InitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.ListenDisconnect Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
ListenDisconnect(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection) |
ListenDisconnect(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32) |
ListenDisconnect(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String) |
ListenDisconnect(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String) | ListenDisconnect

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.ListenDisconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> ListenDisconnect(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenDisconnect ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ ListenDisconnect(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
ListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.ListenDisconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> ListenDisconnect(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenDisconnect ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ ListenDisconnect(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
ListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.ListenDisconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> ListenDisconnect(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenDisconnect ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ ListenDisconnect(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
ListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.ListenDisconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
ListenDisconnect

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> ListenDisconnect(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenDisconnect ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ ListenDisconnect(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
User defined data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
ListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.ListenReconnect Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
ListenReconnect(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection) |
ListenReconnect(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32) |
ListenReconnect(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String) | ListenReconnect
ListenReconnect(IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String) | ListenReconnect

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.ListenReconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> ListenReconnect(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenReconnect ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ ListenReconnect(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
ListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.ListenReconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> ListenReconnect(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenReconnect ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ ListenReconnect(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
ListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.ListenReconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback
ListenReconnect

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> ListenReconnect(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenReconnect ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ ListenReconnect(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
ListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.ListenReconnect Method (IIMService, IIMInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
ListenReconnect

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> ListenReconnect(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenReconnect ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ ListenReconnect(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
ListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


MakeIM Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.MakeIM Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
MakeIM(IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) | Starts a new Instant Messaging session on a Device.
MakeIM(IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) | Starts a new Instant Messaging session.
MakeIM(IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) | Starts a new Instant Messaging session on a Device.
MakeIM(IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) | Starts a new Instant Messaging session on a Device.
MakeIM(IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) | Starts a new Instant Messaging session.
MakeIM(IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) | Starts a new Instant Messaging session on a Device.
MakeIM(IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) | Starts a new IM session.
MakeIM(IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) | Starts a new Instant Messaging session on a Device.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


MakeIM Method (IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.MakeIM Method (IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback
Starts a new Instant Messaging session on a Device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> MakeIM(
    this IIMService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeIM ( _
    service As IIMService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ MakeIM(
    IIMService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Initiator.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.
otherDN
Type: System..::.String
The device of the other party.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type. Only INTERNAL is supported.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for starting this session.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.MakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
MakeIM Overload
Genesyslab.Enterprise.Extensions Namespace


MakeIM Method (IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.MakeIM Method (IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback
Starts a new Instant Messaging session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> MakeIM(
    this IIMService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeIM ( _
    service As IIMService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ MakeIM(
    IIMService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Dialing agent.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String
DN to call.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.MakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
MakeIM Overload
Genesyslab.Enterprise.Extensions Namespace


MakeIM Method (IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.MakeIM Method (IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback
Starts a new Instant Messaging session on a Device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> MakeIM(
    this IIMService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeIM ( _
    service As IIMService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ MakeIM(
    IIMService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
device
Type: Genesyslab.Enterprise.Core..::.IDN
Device which initiates the IM session.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel to use.
otherDN
Type: System..::.String
The party's DN for this session.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type. Only INTERNAL is supported.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User Data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for starting this session.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Additional Switch Extensions
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.MakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
MakeIM Overload
Genesyslab.Enterprise.Extensions Namespace


MakeIM Method (IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.MakeIM Method (IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback
Starts a new Instant Messaging session on a Device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> MakeIM(
    this IIMService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeIM ( _
    service As IIMService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ MakeIM(
    IIMService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
device
Type: Genesyslab.Enterprise.Core..::.IDN
Device of the initiator.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.
otherDN
Type: System..::.String
Targeted device.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type. Only INTERNAL is supported.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for starting this sessions.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
correlatorData
Type: System..::.String
Correlator Data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.MakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
MakeIM Overload
Genesyslab.Enterprise.Extensions Namespace


MakeIM Method (IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.MakeIM Method (IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
Starts a new Instant Messaging session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> MakeIM(
    this IIMService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeIM ( _
    service As IIMService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ MakeIM(
    IIMService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Dialing agent.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to call.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.MakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
MakeIM Overload
Genesyslab.Enterprise.Extensions Namespace


MakeIM Method (IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.MakeIM Method (IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
Starts a new Instant Messaging session on a Device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> MakeIM(
    this IIMService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeIM ( _
    service As IIMService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ MakeIM(
    IIMService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
device
Type: Genesyslab.Enterprise.Core..::.IDN
Device of the initiator.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.
otherDN
Type: System..::.String
Targeted device.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type. Only INTERNAL is supported.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for starting this sessions.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.MakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
MakeIM Overload
Genesyslab.Enterprise.Extensions Namespace


MakeIM Method (IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.MakeIM Method (IIMService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback
Starts a new IM session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> MakeIM(
    this IIMService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeIM ( _
    service As IIMService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ MakeIM(
    IIMService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Dialing agent.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String
DN to call.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.MakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
MakeIM Overload
Genesyslab.Enterprise.Extensions Namespace


MakeIM Method (IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.MakeIM Method (IIMService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback
Starts a new Instant Messaging session on a Device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> MakeIM(
    this IIMService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeIM ( _
    service As IIMService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ MakeIM(
    IIMService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
device
Type: Genesyslab.Enterprise.Core..::.IDN
Device of the initiator.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.
otherDN
Type: System..::.String
Targeted device.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type. Only INTERNAL is supported.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for starting this sessions.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.MakeIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
MakeIM Overload
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.MuteTransfer Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
MuteTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) | Transfers the given interaction in a single blind attempt.
MuteTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) | Transfers the given interaction in a single blind attempt.
MuteTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) | Transfers the given interaction in a single blind attempt.
MuteTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) | Transfers the given interaction in a single blind attempt.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.MuteTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
Transfers the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> MuteTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MuteTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ MuteTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
MuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.MuteTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback
Transfers the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> MuteTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MuteTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ MuteTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
MuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.MuteTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback
Transfers the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> MuteTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MuteTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ MuteTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
MuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.MuteTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback
Transfers the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> MuteTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MuteTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ MuteTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
correlatorData
Type: System..::.String
Correlator Data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
MuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


ReleaseIM Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.ReleaseIM Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
ReleaseIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection) | Releases the given Instant Messaging session. Note: Use this method to quit the instant messaging conversation.
ReleaseIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32) | Releases the given Instant Messaging session. Note: Use this method to quit the instant messaging conversation.
ReleaseIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, String) | Releases the given Instant Messaging session. Note: Use this method to quit the instant messaging conversation.
ReleaseIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, String) | Releases the given Instant Messaging session. Note: Use this method to quit the instant messaging conversation.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


ReleaseIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.ReleaseIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback
Releases the given Instant Messaging session.
Note: Use this method to quit the instant messaging conversation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> ReleaseIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReleaseIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ ReleaseIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction (session to quit).
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for quitting.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ReleaseIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
ReleaseIM Overload
Genesyslab.Enterprise.Extensions Namespace


ReleaseIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.ReleaseIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback
Releases the given Instant Messaging session.
Note: Use this method to quit the instant messaging conversation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> ReleaseIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReleaseIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ ReleaseIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction (session to quit).
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for quitting.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ReleaseIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
ReleaseIM Overload
Genesyslab.Enterprise.Extensions Namespace


ReleaseIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.ReleaseIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback
Releases the given Instant Messaging session.
Note: Use this method to quit the instant messaging conversation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> ReleaseIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReleaseIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ ReleaseIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction (session to quit).
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for quitting.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ReleaseIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
ReleaseIM Overload
Genesyslab.Enterprise.Extensions Namespace


ReleaseIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.ReleaseIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
Releases the given Instant Messaging session.
Note: Use this method to quit the instant messaging conversation.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> ReleaseIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReleaseIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ ReleaseIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction (session to quit).
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for quitting.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.ReleaseIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
ReleaseIM Overload
Genesyslab.Enterprise.Extensions Namespace


RetrieveIM Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.RetrieveIM Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
RetrieveIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection) | Retrieves the given instant messaging conversation, placed on hold.
RetrieveIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32) | Retrieves the given instant messaging conversation (placed on hold).
RetrieveIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, String) | Retrieves the given instant messaging conversation (placed on hold).
RetrieveIM(IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, String) | Retrieves the given instant messaging conversation (placed on hold).

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


RetrieveIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.RetrieveIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback
Retrieves the given instant messaging conversation, placed on hold.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> RetrieveIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RetrieveIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ RetrieveIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to retrieve.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.RetrieveIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
RetrieveIM Overload
Genesyslab.Enterprise.Extensions Namespace


RetrieveIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.RetrieveIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback
Retrieves the given instant messaging conversation (placed on hold).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> RetrieveIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RetrieveIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ RetrieveIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to retrieve.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.RetrieveIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
RetrieveIM Overload
Genesyslab.Enterprise.Extensions Namespace


RetrieveIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.RetrieveIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback
Retrieves the given instant messaging conversation (placed on hold).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> RetrieveIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RetrieveIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ RetrieveIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to retrieve.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.RetrieveIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
RetrieveIM Overload
Genesyslab.Enterprise.Extensions Namespace


RetrieveIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.RetrieveIM Method (IIMService, IIMInteraction, KeyValueCollection, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
Retrieves the given instant messaging conversation (placed on hold).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> RetrieveIM(
    this IIMService service,
    IIMInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RetrieveIM ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ RetrieveIM(
    IIMService^ service,
    IIMInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to retrieve.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.RetrieveIM(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
RetrieveIM Overload
Genesyslab.Enterprise.Extensions Namespace


SendMessage Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SendMessage Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SendMessage(IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection) | Send Message.
SendMessage(IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, Int32) |
SendMessage(IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, String) | Sends Message.
SendMessage(IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, Int32, String) | Sends Message the given interaction.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SendMessage Method (IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SendMessage Method (IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback
Send Message.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> SendMessage(
    this IIMService service,
    IIMInteraction interaction,
    string message,
    MessageContentType contentType,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SendMessage ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    message As String, _
    contentType As MessageContentType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ SendMessage(
    IIMService^ service,
    IIMInteraction^ interaction,
    String^ message,
    MessageContentType contentType,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

contentType
Type: Genesyslab.Enterprise.Services..::.MessageContentType

[Missing <param name="contentType"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
SendMessage Overload
Genesyslab.Enterprise.Extensions Namespace


SendMessage Method (IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SendMessage Method (IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> SendMessage(
    this IIMService service,
    IIMInteraction interaction,
    string message,
    MessageContentType contentType,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SendMessage ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    message As String, _
    contentType As MessageContentType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ SendMessage(
    IIMService^ service,
    IIMInteraction^ interaction,
    String^ message,
    MessageContentType contentType,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

contentType
Type: Genesyslab.Enterprise.Services..::.MessageContentType

[Missing <param name="contentType"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
SendMessage Overload
Genesyslab.Enterprise.Extensions Namespace


SendMessage Method (IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SendMessage Method (IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback
Sends Message.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> SendMessage(
    this IIMService service,
    IIMInteraction interaction,
    string message,
    MessageContentType contentType,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SendMessage ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    message As String, _
    contentType As MessageContentType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ SendMessage(
    IIMService^ service,
    IIMInteraction^ interaction,
    String^ message,
    MessageContentType contentType,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

contentType
Type: Genesyslab.Enterprise.Services..::.MessageContentType

[Missing <param name="contentType"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
SendMessage Overload
Genesyslab.Enterprise.Extensions Namespace


SendMessage Method (IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SendMessage Method (IIMService, IIMInteraction, String, MessageContentType, KeyValueCollection, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
Sends Message the given interaction.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> SendMessage(
    this IIMService service,
    IIMInteraction interaction,
    string message,
    MessageContentType contentType,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SendMessage ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    message As String, _
    contentType As MessageContentType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ SendMessage(
    IIMService^ service,
    IIMInteraction^ interaction,
    String^ message,
    MessageContentType contentType,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

contentType
Type: Genesyslab.Enterprise.Services..::.MessageContentType

[Missing <param name="contentType"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SendMessage(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,System.String,Genesyslab.Enterprise.Services.MessageContentType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
SendMessage Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SetCallQualification Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SetCallQualification(IIMService, IIMInteraction, IClientChannel, KeyValueCollection) |
SetCallQualification(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32) |
SetCallQualification(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, String) | Sets the call qualification.
SetCallQualification(IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32, String) | Sets the call qualification.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SetCallQualification Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> SetCallQualification(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ SetCallQualification(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SetCallQualification Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> SetCallQualification(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ SetCallQualification(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SetCallQualification Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback
Sets the call qualification.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> SetCallQualification(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ SetCallQualification(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SetCallQualification Method (IIMService, IIMInteraction, IClientChannel, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
Sets the call qualification.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> SetCallQualification(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ SetCallQualification(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SingleStepConference Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SingleStepConference(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) | Conferences this call in one step.
SingleStepConference(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) |
SingleStepConference(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |
SingleStepConference(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) | Conferences this call in one step.

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SingleStepConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
Conferences this call in one step.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> SingleStepConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ SingleStepConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
User defined data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
SingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SingleStepConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> SingleStepConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ SingleStepConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
SingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SingleStepConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> SingleStepConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ SingleStepConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
SingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SingleStepConference Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback
Conferences this call in one step.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> SingleStepConference(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepConference ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ SingleStepConference(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String
User defined data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
SingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SingleStepTransfer Method
IMServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SingleStepTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) | Transfers in a single step the Instant Messaging session (without creating a consultation call).
SingleStepTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) | Transfers in a single step the Instant Messaging session (without creating a consultation call).
SingleStepTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) | Transfers in a single step the Instant Messaging session.
SingleStepTransfer(IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) | Transfers in a single step the Instant Messaging session (without creating a consultation call).

See Also

IMServiceExtensions Class
IMServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SingleStepTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
IMServiceExtensions Class See Also Send Feedback
Transfers in a single step the Instant Messaging session (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> SingleStepTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ SingleStepTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to transfer.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IMServiceExtensions Class
SingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SingleStepTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
IMServiceExtensions Class See Also Send Feedback
Transfers in a single step the Instant Messaging session (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> SingleStepTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ SingleStepTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to transfer.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IMServiceExtensions Class
SingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SingleStepTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
IMServiceExtensions Class See Also Send Feedback
Transfers in a single step the Instant Messaging session.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> SingleStepTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ SingleStepTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to transfer.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IMServiceExtensions Class
SingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions..::.SingleStepTransfer Method (IIMService, IIMInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
IMServiceExtensions Class See Also Send Feedback
Transfers in a single step the Instant Messaging session (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IIMInteraction> SingleStepTransfer(
    this IIMService service,
    IIMInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepTransfer ( _
    service As IIMService, _
    interaction As IIMInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IIMInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IIMInteraction^>^ SingleStepTransfer(
    IIMService^ service,
    IIMInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIMService
Service.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
IM interaction to transfer.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel.
otherDN
Type: System..::.String
DN to which the interaction is transferred.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
correlatorData
Type: System..::.String
Correlator data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IMServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IIMService,Genesyslab.Enterprise.Model.Interaction.IIMInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IMServiceExtensions Class
SingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


MonitorServiceExtensions Class

[image]

Enterprise SDK 8.0 Reference API
MonitorServiceExtensions Class
Members See Also Send Feedback
Extension Methods for PAM.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static class MonitorServiceExtensions
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class MonitorServiceExtensions
Visual C++
[ExtensionAttribute]
public ref class MonitorServiceExtensions abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Extensions..::.MonitorServiceExtensions

See Also

MonitorServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


MonitorServiceExtensions Members

[image] [image]

Enterprise SDK 8.0 Reference API
MonitorServiceExtensions Members
MonitorServiceExtensions Class Methods See Also Send Feedback

The MonitorServiceExtensions type exposes the following members.

Methods

Name | Description
PeekAndSubscribeStatus |
PeekStatus | Peeks the status of an object in the Statistics Server.
SubscribeReasonStatus | Subscribes Extended to the status of an object in the Statistics Server.
SubscribeStatus | Subscribes to the status of an object in the Statistics Server.
SubscribeStatusEx | Subscribes Extended to the status of an object in the Statistics Server.
UnsubscribeReasonStatus | UnsubscribeReasonStatus Extended of an object in statistics server.
UnsubscribeStatus | UnsubscribeStatus of an object in statistics server.
UnsubscribeStatusEx | UnsubscribeStatus Extended of an object in statistics server.

See Also

MonitorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


MonitorServiceExtensions Methods

[image] [image]

Enterprise SDK 8.0 Reference API
MonitorServiceExtensions Methods
MonitorServiceExtensions Class See Also Send Feedback

The MonitorServiceExtensions type exposes the following members.

Methods

Name | Description
PeekAndSubscribeStatus |
PeekStatus | Peeks the status of an object in the Statistics Server.
SubscribeReasonStatus | Subscribes Extended to the status of an object in the Statistics Server.
SubscribeStatus | Subscribes to the status of an object in the Statistics Server.
SubscribeStatusEx | Subscribes Extended to the status of an object in the Statistics Server.
UnsubscribeReasonStatus | UnsubscribeReasonStatus Extended of an object in statistics server.
UnsubscribeStatus | UnsubscribeStatus of an object in statistics server.
UnsubscribeStatusEx | UnsubscribeStatus Extended of an object in statistics server.

See Also

MonitorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


PeekAndSubscribeStatus Method

[image]

Enterprise SDK 8.0 Reference API
MonitorServiceExtensions..::.PeekAndSubscribeStatus Method
MonitorServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.MonitorServiceExtensions.PeekAndSubscribeStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IMonitorEventStatus> PeekAndSubscribeStatus(
    this IMonitorService pamService,
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    string tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue,
    MonitorMethodDelegate listener
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function PeekAndSubscribeStatus ( _
    pamService As IMonitorService, _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    tenantPassword As String, _
    notificationMode As MonitorNotificationMode, _
    notificationValue As Integer, _
    listener As MonitorMethodDelegate _
) As IEnvelope(Of IMonitorEventStatus)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IMonitorEventStatus^>^ PeekAndSubscribeStatus(
    IMonitorService^ pamService,
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    String^ tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue,
    MonitorMethodDelegate^ listener
)

Parameters

pamService
Type: Genesyslab.Enterprise.Services..::.IMonitorService

[Missing <param name="pamService"/> documentation for "M:Genesyslab.Enterprise.Extensions.MonitorServiceExtensions.PeekAndSubscribeStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.MonitorServiceExtensions.PeekAndSubscribeStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType

[Missing <param name="objectType"/> documentation for "M:Genesyslab.Enterprise.Extensions.MonitorServiceExtensions.PeekAndSubscribeStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

objectId
Type: System..::.String

[Missing <param name="objectId"/> documentation for "M:Genesyslab.Enterprise.Extensions.MonitorServiceExtensions.PeekAndSubscribeStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

tenantName
Type: System..::.String

[Missing <param name="tenantName"/> documentation for "M:Genesyslab.Enterprise.Extensions.MonitorServiceExtensions.PeekAndSubscribeStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

tenantPassword
Type: System..::.String

[Missing <param name="tenantPassword"/> documentation for "M:Genesyslab.Enterprise.Extensions.MonitorServiceExtensions.PeekAndSubscribeStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

notificationMode
Type: Genesyslab.Enterprise.Services..::.MonitorNotificationMode

[Missing <param name="notificationMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.MonitorServiceExtensions.PeekAndSubscribeStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

notificationValue
Type: System..::.Int32

[Missing <param name="notificationValue"/> documentation for "M:Genesyslab.Enterprise.Extensions.MonitorServiceExtensions.PeekAndSubscribeStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

listener
Type: Genesyslab.Enterprise.Services..::.MonitorMethodDelegate

[Missing <param name="listener"/> documentation for "M:Genesyslab.Enterprise.Extensions.MonitorServiceExtensions.PeekAndSubscribeStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.MonitorServiceExtensions.PeekAndSubscribeStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

See Also

MonitorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


PeekStatus Method

[image]

Enterprise SDK 8.0 Reference API
MonitorServiceExtensions..::.PeekStatus Method
MonitorServiceExtensions Class See Also Send Feedback
Peeks the status of an object in the Statistics Server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IMonitorEventStatus> PeekStatus(
    this IMonitorService pamService,
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    string tenantPassword
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function PeekStatus ( _
    pamService As IMonitorService, _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    tenantPassword As String _
) As IEnvelope(Of IMonitorEventStatus)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IMonitorEventStatus^>^ PeekStatus(
    IMonitorService^ pamService,
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    String^ tenantPassword
)

Parameters

pamService
Type: Genesyslab.Enterprise.Services..::.IMonitorService
The PAMService reference.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel to which the protocol belongs to.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType
The statistic object type to be retrieved.
objectId
Type: System..::.String
The object ID.
tenantName
Type: System..::.String
The tenant ID.
tenantPassword
Type: System..::.String
The tenant password.

Return Value

An Envelope that contains the statistic result.

See Also

MonitorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


SubscribeReasonStatus Method

[image]

Enterprise SDK 8.0 Reference API
MonitorServiceExtensions..::.SubscribeReasonStatus Method
MonitorServiceExtensions Class See Also Send Feedback
Subscribes Extended to the status of an object in the Statistics Server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static bool SubscribeReasonStatus(
    this IMonitorService pamService,
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    string tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue,
    MonitorMethodDelegate listener
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SubscribeReasonStatus ( _
    pamService As IMonitorService, _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    tenantPassword As String, _
    notificationMode As MonitorNotificationMode, _
    notificationValue As Integer, _
    listener As MonitorMethodDelegate _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool SubscribeReasonStatus(
    IMonitorService^ pamService,
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    String^ tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue,
    MonitorMethodDelegate^ listener
)

Parameters

pamService
Type: Genesyslab.Enterprise.Services..::.IMonitorService
The PAMService reference.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel to which the protocol belongs to.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType
The statistic object type to be retrieved.
objectId
Type: System..::.String
The object ID.
tenantName
Type: System..::.String
The tenant ID.
tenantPassword
Type: System..::.String
The tenant password.
notificationMode
Type: Genesyslab.Enterprise.Services..::.MonitorNotificationMode
The notification mode.
notificationValue
Type: System..::.Int32
Notification value according to the notification mode.
listener
Type: Genesyslab.Enterprise.Services..::.MonitorMethodDelegate
The callback for receiving result.

Return Value

Returns True if the subscribe request succeeded, False otherwise.

See Also

MonitorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


SubscribeStatus Method

[image]

Enterprise SDK 8.0 Reference API
MonitorServiceExtensions..::.SubscribeStatus Method
MonitorServiceExtensions Class See Also Send Feedback
Subscribes to the status of an object in the Statistics Server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static bool SubscribeStatus(
    this IMonitorService pamService,
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    string tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue,
    MonitorMethodDelegate listener
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SubscribeStatus ( _
    pamService As IMonitorService, _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    tenantPassword As String, _
    notificationMode As MonitorNotificationMode, _
    notificationValue As Integer, _
    listener As MonitorMethodDelegate _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool SubscribeStatus(
    IMonitorService^ pamService,
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    String^ tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue,
    MonitorMethodDelegate^ listener
)

Parameters

pamService
Type: Genesyslab.Enterprise.Services..::.IMonitorService
The PAMService reference.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel to which the protocol belongs to.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType
The statistic object type to be retrieved.
objectId
Type: System..::.String
The object ID.
tenantName
Type: System..::.String
The tenant ID.
tenantPassword
Type: System..::.String
The tenant password.
notificationMode
Type: Genesyslab.Enterprise.Services..::.MonitorNotificationMode
The notification mode.
notificationValue
Type: System..::.Int32
Notification value according to the notification mode.
listener
Type: Genesyslab.Enterprise.Services..::.MonitorMethodDelegate
The callback for receiving result.

Return Value

Returns True if the subscribe request succeeded, False otherwise.

See Also

MonitorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


SubscribeStatusEx Method

[image]

Enterprise SDK 8.0 Reference API
MonitorServiceExtensions..::.SubscribeStatusEx Method
MonitorServiceExtensions Class See Also Send Feedback
Subscribes Extended to the status of an object in the Statistics Server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static bool SubscribeStatusEx(
    this IMonitorService pamService,
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    string tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue,
    MonitorMethodDelegate listener
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SubscribeStatusEx ( _
    pamService As IMonitorService, _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    tenantPassword As String, _
    notificationMode As MonitorNotificationMode, _
    notificationValue As Integer, _
    listener As MonitorMethodDelegate _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool SubscribeStatusEx(
    IMonitorService^ pamService,
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    String^ tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue,
    MonitorMethodDelegate^ listener
)

Parameters

pamService
Type: Genesyslab.Enterprise.Services..::.IMonitorService
The PAMService reference.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel to which the protocol belongs to.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType
The statistic object type to be retrieved.
objectId
Type: System..::.String
The object ID.
tenantName
Type: System..::.String
The tenant ID.
tenantPassword
Type: System..::.String
The tenant password.
notificationMode
Type: Genesyslab.Enterprise.Services..::.MonitorNotificationMode
The notification mode.
notificationValue
Type: System..::.Int32
Notification value according to the notification mode.
listener
Type: Genesyslab.Enterprise.Services..::.MonitorMethodDelegate
The callback for receiving result.

Return Value

Returns True if the subscribe request succeeded, False otherwise.

See Also

MonitorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


UnsubscribeReasonStatus Method

[image]

Enterprise SDK 8.0 Reference API
MonitorServiceExtensions..::.UnsubscribeReasonStatus Method
MonitorServiceExtensions Class See Also Send Feedback
UnsubscribeReasonStatus Extended of an object in statistics server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static bool UnsubscribeReasonStatus(
    this IMonitorService pamService,
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    MonitorMethodDelegate listener
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function UnsubscribeReasonStatus ( _
    pamService As IMonitorService, _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    listener As MonitorMethodDelegate _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool UnsubscribeReasonStatus(
    IMonitorService^ pamService,
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    MonitorMethodDelegate^ listener
)

Parameters

pamService
Type: Genesyslab.Enterprise.Services..::.IMonitorService
The PAMService reference.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel to which the protocol belongs to.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType
The statistic object type to be retrieved.
objectId
Type: System..::.String
The object ID.
tenantName
Type: System..::.String
The tenant ID.
listener
Type: Genesyslab.Enterprise.Services..::.MonitorMethodDelegate
The result callback.

Return Value

Returns True if the unsubscribe request succeeded, False otherwise.

See Also

MonitorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


UnsubscribeStatus Method

[image]

Enterprise SDK 8.0 Reference API
MonitorServiceExtensions..::.UnsubscribeStatus Method
MonitorServiceExtensions Class See Also Send Feedback
UnsubscribeStatus of an object in statistics server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static bool UnsubscribeStatus(
    this IMonitorService pamService,
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    MonitorMethodDelegate listener
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function UnsubscribeStatus ( _
    pamService As IMonitorService, _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    listener As MonitorMethodDelegate _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool UnsubscribeStatus(
    IMonitorService^ pamService,
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    MonitorMethodDelegate^ listener
)

Parameters

pamService
Type: Genesyslab.Enterprise.Services..::.IMonitorService
The PAMService reference.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel to which the protocol belongs to.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType
The statistic object type to be retrieved.
objectId
Type: System..::.String
The object ID.
tenantName
Type: System..::.String
The tenant ID.
listener
Type: Genesyslab.Enterprise.Services..::.MonitorMethodDelegate
The result callback.

Return Value

Returns True if the unsubscribe request succeeded, False otherwise.

See Also

MonitorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


UnsubscribeStatusEx Method

[image]

Enterprise SDK 8.0 Reference API
MonitorServiceExtensions..::.UnsubscribeStatusEx Method
MonitorServiceExtensions Class See Also Send Feedback
UnsubscribeStatus Extended of an object in statistics server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static bool UnsubscribeStatusEx(
    this IMonitorService pamService,
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    MonitorMethodDelegate listener
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function UnsubscribeStatusEx ( _
    pamService As IMonitorService, _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    listener As MonitorMethodDelegate _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool UnsubscribeStatusEx(
    IMonitorService^ pamService,
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    MonitorMethodDelegate^ listener
)

Parameters

pamService
Type: Genesyslab.Enterprise.Services..::.IMonitorService
The PAMService reference.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel to which the protocol belongs to.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType
The statistic object type to be retrieved.
objectId
Type: System..::.String
The object ID.
tenantName
Type: System..::.String
The tenant ID.
listener
Type: Genesyslab.Enterprise.Services..::.MonitorMethodDelegate
The result callback.

Return Value

Returns True if the unsubscribe request succeeded, False otherwise.

See Also

MonitorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


SupervisorServiceExtensions Class

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions Class
Members See Also Send Feedback
Extends the Supervisor Service to perform manage the supervision of the device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static class SupervisorServiceExtensions
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class SupervisorServiceExtensions
Visual C++
[ExtensionAttribute]
public ref class SupervisorServiceExtensions abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Extensions..::.SupervisorServiceExtensions

See Also

SupervisorServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SupervisorServiceExtensions Members

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions Members
SupervisorServiceExtensions Class Methods See Also Send Feedback

The SupervisorServiceExtensions type exposes the following members.

Methods

Name | Description
BeginStartMonitor | Activates asynchronously the supervision of the specified device. (Asynchronous method.)
BeginStartMonitoring | Overloaded.
BeginStopMonitoring | Overloaded.
EndStartMonitor | Ends the activation of the supervision feature for the given device.
EndStopMonitoring | Deactivates the supervision feature for the specified device. (Synchronous method.)
StartMonitoring | Overloaded.
StopMonitoring | Overloaded.

See Also

SupervisorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


SupervisorServiceExtensions Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions Methods
SupervisorServiceExtensions Class See Also Send Feedback

The SupervisorServiceExtensions type exposes the following members.

Methods

Name | Description
BeginStartMonitor | Activates asynchronously the supervision of the specified device. (Asynchronous method.)
BeginStartMonitoring | Overloaded.
BeginStopMonitoring | Overloaded.
EndStartMonitor | Ends the activation of the supervision feature for the given device.
EndStopMonitoring | Deactivates the supervision feature for the specified device. (Synchronous method.)
StartMonitoring | Overloaded.
StopMonitoring | Overloaded.

See Also

SupervisorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


BeginStartMonitor Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.BeginStartMonitor Method
SupervisorServiceExtensions Class See Also Send Feedback
Activates asynchronously the supervision of the specified device. (Asynchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginStartMonitor(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginStartMonitor ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    mode As SupervisorModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginStartMonitor(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.BeginStartMonitor(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device to monitor.
mode
Type: Genesyslab.Enterprise.Services..::.SupervisorModeType
Supervisor mode.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific data.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
CallBack object.
context
Type: System..::.Object
Context object.

Return Value

IAsyncResult

See Also

SupervisorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


BeginStartMonitoring Method

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.BeginStartMonitoring Method
SupervisorServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginStartMonitoring(ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Activates asynchronously the supervision of the specified device. (Asynchronous method.)
BeginStartMonitoring(ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Activates asynchronously the supervision of the specified device. (Asynchronous method.)
BeginStartMonitoring(ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Activates asynchronously the supervision of the specified device. (Asynchronous method.)

See Also

SupervisorServiceExtensions Class
SupervisorServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginStartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.BeginStartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
SupervisorServiceExtensions Class See Also Send Feedback
Activates asynchronously the supervision of the specified device. (Asynchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginStartMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginStartMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    mode As SupervisorModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginStartMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.BeginStartMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device to monitor.
mode
Type: Genesyslab.Enterprise.Services..::.SupervisorModeType
Supervisor mode.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific Extensions.
callBack
Type: System..::.AsyncCallback
Callback object.
context
Type: System..::.Object
Context object.
correlatorData
Type: System..::.String
User data.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.BeginStartMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

SupervisorServiceExtensions Class
BeginStartMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


BeginStartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.BeginStartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
SupervisorServiceExtensions Class See Also Send Feedback
Activates asynchronously the supervision of the specified device. (Asynchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginStartMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginStartMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    mode As SupervisorModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginStartMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.BeginStartMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent to monitor (party of the supervised interaction).
mode
Type: Genesyslab.Enterprise.Services..::.SupervisorModeType
Supervisor mode.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific data.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
CallBack.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
Correlator data.

Return Value

IAsyncResult

See Also

SupervisorServiceExtensions Class
BeginStartMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


BeginStartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.BeginStartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
SupervisorServiceExtensions Class See Also Send Feedback
Activates asynchronously the supervision of the specified device. (Asynchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginStartMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginStartMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    mode As SupervisorModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginStartMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.BeginStartMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device to monitor.
mode
Type: Genesyslab.Enterprise.Services..::.SupervisorModeType
Supervisor mode.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific Extensions.
callBack
Type: System..::.AsyncCallback
Callback object.
context
Type: System..::.Object
Context object.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.BeginStartMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

SupervisorServiceExtensions Class
BeginStartMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


BeginStopMonitoring Method

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.BeginStopMonitoring Method
SupervisorServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginStopMonitoring(ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Deactivates the supervision feature for the specified device. (Asynchronous method.)
BeginStopMonitoring(ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Deactivates the supervision feature for the specified device. (Asynchronous method.)
BeginStopMonitoring(ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Deactivates the supervision feature for the specified device. (Asynchronous method.)
BeginStopMonitoring(ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Deactivates the supervision feature for the specified device. (Asynchronous method.)

See Also

SupervisorServiceExtensions Class
SupervisorServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginStopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.BeginStopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates the supervision feature for the specified device. (Asynchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginStopMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginStopMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginStopMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.BeginStopMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent's device.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
context object
correlatorData
Type: System..::.String
User data.

Return Value

IAsyncResult

See Also

SupervisorServiceExtensions Class
BeginStopMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


BeginStopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.BeginStopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates the supervision feature for the specified device. (Asynchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginStopMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginStopMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginStopMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.BeginStopMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent's device.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

IAsyncResult

See Also

SupervisorServiceExtensions Class
BeginStopMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


BeginStopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.BeginStopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates the supervision feature for the specified device. (Asynchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginStopMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginStopMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginStopMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.BeginStopMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent's device.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.
correlatorData
Type: System..::.String
User data.

Return Value

IAsyncResult

See Also

SupervisorServiceExtensions Class
BeginStopMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


BeginStopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.BeginStopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates the supervision feature for the specified device. (Asynchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginStopMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginStopMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginStopMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.BeginStopMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent's device.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
callBack
Type: System..::.AsyncCallback
Callback.
context
Type: System..::.Object
Context.

Return Value

IAsyncResult

See Also

SupervisorServiceExtensions Class
BeginStopMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


EndStartMonitor Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.EndStartMonitor Method
SupervisorServiceExtensions Class See Also Send Feedback
Ends the activation of the supervision feature for the given device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<ISupervisorInfo> EndStartMonitor(
    this ISupervisorService service,
    IClientChannel channel,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndStartMonitor ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    aResult As IAsyncResult _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ EndStartMonitor(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.EndStartMonitor(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.IAsyncResult)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
aResult
Type: System..::.IAsyncResult
callback object

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndStopMonitoring Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.EndStopMonitoring Method
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates the supervision feature for the specified device. (Synchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<ISupervisorInfo> EndStopMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndStopMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    aResult As IAsyncResult _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ EndStopMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.EndStopMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.IAsyncResult)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
aResult
Type: System..::.IAsyncResult
Callback object

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.EndStopMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.IAsyncResult)"]

See Also

SupervisorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


StartMonitoring Method

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StartMonitoring Method
SupervisorServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
StartMonitoring(ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32, String) | Activates the supervision of the given interaction. Synchronous method
StartMonitoring(ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection) | Activates the supervision of the given agent device. (Synchronous method)
StartMonitoring(ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32) | Activates the supervision of the given device. (Synchronous method)
StartMonitoring(ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, String) | Activates the supervision of the given agent device. (Synchronous method)
StartMonitoring(ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, SupervisorModeType, KeyValueCollection, KeyValueCollection) | Activates the supervision of the given interaction. Synchronous method
StartMonitoring(ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32, String) | Activates the supervision of the given device. (Synchronous method.)
StartMonitoring(ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32) | Activates the supervision of the given interaction. Synchronous method
StartMonitoring(ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, SupervisorModeType, KeyValueCollection, KeyValueCollection, String) | Activates the supervision of the given interaction. Synchronous method

See Also

SupervisorServiceExtensions Class
SupervisorServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


StartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32, String)
SupervisorServiceExtensions Class See Also Send Feedback
Activates the supervision of the given interaction. Synchronous method

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StartMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IInteraction interaction,
    IIdentity supervisedIdentity,
    SupervisorModeType mode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StartMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    interaction As IInteraction, _
    supervisedIdentity As IIdentity, _
    mode As SupervisorModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StartMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IInteraction^ interaction,
    IIdentity^ supervisedIdentity,
    SupervisorModeType mode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StartMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Identity.IIdentity,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction to monitor.
supervisedIdentity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent to monitor (party of the supervised interaction).
mode
Type: Genesyslab.Enterprise.Services..::.SupervisorModeType
Supervisor mode.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific data.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
correlatorData
Type: System..::.String
User data.

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StartMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


StartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection)
SupervisorServiceExtensions Class See Also Send Feedback
Activates the supervision of the given agent device. (Synchronous method)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StartMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StartMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    mode As SupervisorModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StartMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StartMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent's device.
mode
Type: Genesyslab.Enterprise.Services..::.SupervisorModeType
Supervision mode.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StartMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


StartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32)
SupervisorServiceExtensions Class See Also Send Feedback
Activates the supervision of the given device. (Synchronous method)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StartMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StartMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    mode As SupervisorModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StartMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StartMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent's device.
mode
Type: Genesyslab.Enterprise.Services..::.SupervisorModeType
Supervision mode.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StartMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


StartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, String)
SupervisorServiceExtensions Class See Also Send Feedback
Activates the supervision of the given agent device. (Synchronous method)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StartMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StartMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    mode As SupervisorModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StartMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StartMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent's device.
mode
Type: Genesyslab.Enterprise.Services..::.SupervisorModeType
Supervision mode.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
correlatorData
Type: System..::.String
User data.

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StartMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


StartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, SupervisorModeType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, SupervisorModeType, KeyValueCollection, KeyValueCollection)
SupervisorServiceExtensions Class See Also Send Feedback
Activates the supervision of the given interaction. Synchronous method

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StartMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IInteraction interaction,
    IIdentity supervisedIdentity,
    SupervisorModeType mode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StartMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    interaction As IInteraction, _
    supervisedIdentity As IIdentity, _
    mode As SupervisorModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StartMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IInteraction^ interaction,
    IIdentity^ supervisedIdentity,
    SupervisorModeType mode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StartMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Identity.IIdentity,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction to monitor.
supervisedIdentity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent to monitor (party of the voice interaction.)
mode
Type: Genesyslab.Enterprise.Services..::.SupervisorModeType
Supervision mode.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific data

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StartMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


StartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32, String)
SupervisorServiceExtensions Class See Also Send Feedback
Activates the supervision of the given device. (Synchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StartMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StartMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    mode As SupervisorModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StartMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StartMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StartMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent's device.
mode
Type: Genesyslab.Enterprise.Services..::.SupervisorModeType
Supervision mode.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
correlatorData
Type: System..::.String
User data.

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StartMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


StartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32)
SupervisorServiceExtensions Class See Also Send Feedback
Activates the supervision of the given interaction. Synchronous method

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StartMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IInteraction interaction,
    IIdentity supervisedIdentity,
    SupervisorModeType mode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StartMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    interaction As IInteraction, _
    supervisedIdentity As IIdentity, _
    mode As SupervisorModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StartMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IInteraction^ interaction,
    IIdentity^ supervisedIdentity,
    SupervisorModeType mode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StartMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Identity.IIdentity,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction to monitor.
supervisedIdentity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent to monitor (party of the supervised interaction).
mode
Type: Genesyslab.Enterprise.Services..::.SupervisorModeType
Supervision mode.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific data.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StartMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


StartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, SupervisorModeType, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StartMonitoring Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, SupervisorModeType, KeyValueCollection, KeyValueCollection, String)
SupervisorServiceExtensions Class See Also Send Feedback
Activates the supervision of the given interaction. Synchronous method

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StartMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IInteraction interaction,
    IIdentity supervisedIdentity,
    SupervisorModeType mode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StartMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    interaction As IInteraction, _
    supervisedIdentity As IIdentity, _
    mode As SupervisorModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StartMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IInteraction^ interaction,
    IIdentity^ supervisedIdentity,
    SupervisorModeType mode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StartMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Identity.IIdentity,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction to monitor.
supervisedIdentity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Monitored Agent (party of the supervised interaction.)
mode
Type: Genesyslab.Enterprise.Services..::.SupervisorModeType
Supervision mode.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific data.
correlatorData
Type: System..::.String
User data.

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StartMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


StopMonitoring Method

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StopMonitoring Method
SupervisorServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
StopMonitoring(ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection) | Deactivates the supervision on the specified device. (Synchronous method.)
StopMonitoring(ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, Int32) | Deactivates the supervision feature for the specified device. (Synchronous method.)
StopMonitoring(ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, String) | Deactivates supervision feature on the specified device (Synchronous method.)
StopMonitoring(ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, KeyValueCollection, KeyValueCollection) | Deactivates the supervision feature for the specified device. (Synchronous method.)
StopMonitoring(ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, Int32, String) | Deactivates the supervision feature for the specified device. (Synchronous method.)
StopMonitoring(ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, KeyValueCollection, KeyValueCollection, Int32) | Deactivates the supervision feature for the specified device. (Synchronous method.)
StopMonitoring(ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, KeyValueCollection, KeyValueCollection, String) | Deactivates the supervision feature for the specified device. (Synchronous method.)
StopMonitoring(ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, KeyValueCollection, KeyValueCollection, Int32, String) | Deactivates the supervision feature for the specified device. (Synchronous method.)

See Also

SupervisorServiceExtensions Class
SupervisorServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


StopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection)
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates the supervision on the specified device. (Synchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StopMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StopMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StopMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StopMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent's device.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StopMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


StopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, Int32)
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates the supervision feature for the specified device. (Synchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StopMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StopMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StopMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StopMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent's device.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StopMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


StopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, String)
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates supervision feature on the specified device (Synchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StopMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StopMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StopMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StopMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent's device.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
correlatorData
Type: System..::.String
User data.

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StopMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


StopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, KeyValueCollection, KeyValueCollection)
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates the supervision feature for the specified device. (Synchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StopMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IInteraction interaction,
    IIdentity supervisedIdentity,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StopMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    interaction As IInteraction, _
    supervisedIdentity As IIdentity, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StopMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IInteraction^ interaction,
    IIdentity^ supervisedIdentity,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StopMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Identity.IIdentity,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction instance.
supervisedIdentity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Identity of the supervised agent.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StopMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


StopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, Int32, String)
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates the supervision feature for the specified device. (Synchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StopMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StopMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StopMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StopMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent's device.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
correlatorData
Type: System..::.String
User data.

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StopMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


StopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, KeyValueCollection, KeyValueCollection, Int32)
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates the supervision feature for the specified device. (Synchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StopMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IInteraction interaction,
    IIdentity supervisedIdentity,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StopMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    interaction As IInteraction, _
    supervisedIdentity As IIdentity, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StopMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IInteraction^ interaction,
    IIdentity^ supervisedIdentity,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StopMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Identity.IIdentity,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction instance.
supervisedIdentity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Identity of the supervised agent.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StopMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


StopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, KeyValueCollection, KeyValueCollection, String)
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates the supervision feature for the specified device. (Synchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StopMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IInteraction interaction,
    IIdentity supervisedIdentity,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StopMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    interaction As IInteraction, _
    supervisedIdentity As IIdentity, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StopMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IInteraction^ interaction,
    IIdentity^ supervisedIdentity,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StopMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Identity.IIdentity,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction instance.
supervisedIdentity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Identity of the supervised agent.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
correlatorData
Type: System..::.String
User data.

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StopMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


StopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StopMonitoring Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, KeyValueCollection, KeyValueCollection, Int32, String)
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates the supervision feature for the specified device. (Synchronous method.)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StopMonitoring(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IInteraction interaction,
    IIdentity supervisedIdentity,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StopMonitoring ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    interaction As IInteraction, _
    supervisedIdentity As IIdentity, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StopMonitoring(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IInteraction^ interaction,
    IIdentity^ supervisedIdentity,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StopMonitoring(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Identity.IIdentity,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction instance.
supervisedIdentity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Identity of the supervised agent.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extensions.
timeOut
Type: System..::.Int32
Period in milliseconds to wait for the server response. Minimum value is 500.
correlatorData
Type: System..::.String
User data.

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StopMonitoring Overload
Genesyslab.Enterprise.Extensions Namespace


VoiceServiceExtensions Class

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static class VoiceServiceExtensions
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class VoiceServiceExtensions
Visual C++
[ExtensionAttribute]
public ref class VoiceServiceExtensions abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Extensions..::.VoiceServiceExtensions

See Also

VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


VoiceServiceExtensions Members

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions Members
VoiceServiceExtensions Class Methods See Also Send Feedback

The VoiceServiceExtensions type exposes the following members.

Methods

Name | Description
AlternateCall | Overloaded.
AnswerCall | Overloaded.
BeginAlternateCall | Overloaded.
BeginAnswerCall | Overloaded.
BeginCompleteConference | Overloaded.
BeginCompleteTransfer | Overloaded.
BeginDeleteFromConference | Overloaded.
BeginHoldCall | Overloaded.
BeginInitiateConference | Overloaded.
BeginInitiateTransfer | Overloaded.
BeginListenDisconnect | Overloaded.
BeginListenReconnect | Overloaded.
BeginMakeCall | Overloaded.
BeginMuteTransfer | Overloaded.
BeginReconnectCall | Overloaded.
BeginRedirectCall | Overloaded.
BeginReleaseCall | Overloaded.
BeginRetrieveCall | Overloaded.
BeginSendDtmf | Overloaded.
BeginSetCallQualification | Overloaded.
BeginSetMuteOff | Overloaded.
BeginSetMuteOn | Overloaded.
BeginSingleStepConference | Overloaded.
BeginSingleStepTransfer | Overloaded.
CompleteConference | Overloaded.
CompleteTransfer | Overloaded.
DeleteFromConference | Overloaded.
EndAlternateCall | Ends the asynchronous of a call. Alternates between the given call and a held call.
EndAnswerCall | Ends the asynchronous of a call. Answers the given call (which is the given ringing interaction).
EndCompleteConference | Ends the asynchronous of a call. Completes the two-step conference for the given call.
EndCompleteTransfer | Ends the asynchronous of a call. Completes the given two-step transfer.
EndDeleteFromConference | Ends the asynchronous of a call. Deletes the given party from the conference.
EndHoldCall | Ends the asynchronous of a call. Places the given interaction on hold.
EndInitiateConference | Ends the asynchronous of a call. Initiates the two-step conference for the given call.
EndInitiateTransfer | Ends the asynchronous of a call. Initiates the two-step transfer of the given call.
EndListenDisconnect | Ends the asynchronous of a call.
EndListenReconnect | Ends the asynchronous of a call.
EndMakeCall | Ends the asynchronous of a call. Dials a new call.
EndMuteTransfer | Ends the asynchronous of a call. Transfers the given interaction in a single blind attempt.
EndReconnectCall | End asynchronous reconnect call
EndRedirectCall | End asynchronous redirect call
EndReleaseCall | Ends the asynchronous of a call. Releases the given interaction.
EndRetrieveCall | Ends the asynchronous of a call. Retrieves the given interaction being held.
EndSendDtmf | Ends the asynchronous of a call. Sends digits as DTMF tones on the given phone call.
EndSetCallQualification | Ends the asynchronous of a call. Sets the call qualification.
EndSetMuteOff | Ends the asynchronous of a call. Cancels the call muting (enables the microphone).
EndSetMuteOn | Ends the asynchronous of a call. Mutes this call (disables the microphone).
EndSingleStepConference | Ends the asynchronous of a call. Conferences this call in one step.
EndSingleStepTransfer | Ends the asynchronous of a call. Transfers the given interaction in a single step (without creating a consultation call).
HoldCall | Overloaded.
InitiateConference | Overloaded.
InitiateTransfer | Overloaded.
ListenDisconnect | Overloaded.
ListenReconnect | Overloaded.
MakeCall | Overloaded.
MuteTransfer | Overloaded.
ReconnectCall | Overloaded.
RedirectCall | Overloaded.
ReleaseCall | Overloaded.
RetrieveCall | Overloaded.
SendDtmf | Overloaded.
SetCallQualification | Overloaded.
SetMuteOff | Overloaded.
SetMuteOn | Overloaded.
SingleStepConference | Overloaded.
SingleStepTransfer | Overloaded.

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


VoiceServiceExtensions Methods

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions Methods
VoiceServiceExtensions Class See Also Send Feedback

The VoiceServiceExtensions type exposes the following members.

Methods

Name | Description
AlternateCall | Overloaded.
AnswerCall | Overloaded.
BeginAlternateCall | Overloaded.
BeginAnswerCall | Overloaded.
BeginCompleteConference | Overloaded.
BeginCompleteTransfer | Overloaded.
BeginDeleteFromConference | Overloaded.
BeginHoldCall | Overloaded.
BeginInitiateConference | Overloaded.
BeginInitiateTransfer | Overloaded.
BeginListenDisconnect | Overloaded.
BeginListenReconnect | Overloaded.
BeginMakeCall | Overloaded.
BeginMuteTransfer | Overloaded.
BeginReconnectCall | Overloaded.
BeginRedirectCall | Overloaded.
BeginReleaseCall | Overloaded.
BeginRetrieveCall | Overloaded.
BeginSendDtmf | Overloaded.
BeginSetCallQualification | Overloaded.
BeginSetMuteOff | Overloaded.
BeginSetMuteOn | Overloaded.
BeginSingleStepConference | Overloaded.
BeginSingleStepTransfer | Overloaded.
CompleteConference | Overloaded.
CompleteTransfer | Overloaded.
DeleteFromConference | Overloaded.
EndAlternateCall | Ends the asynchronous of a call. Alternates between the given call and a held call.
EndAnswerCall | Ends the asynchronous of a call. Answers the given call (which is the given ringing interaction).
EndCompleteConference | Ends the asynchronous of a call. Completes the two-step conference for the given call.
EndCompleteTransfer | Ends the asynchronous of a call. Completes the given two-step transfer.
EndDeleteFromConference | Ends the asynchronous of a call. Deletes the given party from the conference.
EndHoldCall | Ends the asynchronous of a call. Places the given interaction on hold.
EndInitiateConference | Ends the asynchronous of a call. Initiates the two-step conference for the given call.
EndInitiateTransfer | Ends the asynchronous of a call. Initiates the two-step transfer of the given call.
EndListenDisconnect | Ends the asynchronous of a call.
EndListenReconnect | Ends the asynchronous of a call.
EndMakeCall | Ends the asynchronous of a call. Dials a new call.
EndMuteTransfer | Ends the asynchronous of a call. Transfers the given interaction in a single blind attempt.
EndReconnectCall | End asynchronous reconnect call
EndRedirectCall | End asynchronous redirect call
EndReleaseCall | Ends the asynchronous of a call. Releases the given interaction.
EndRetrieveCall | Ends the asynchronous of a call. Retrieves the given interaction being held.
EndSendDtmf | Ends the asynchronous of a call. Sends digits as DTMF tones on the given phone call.
EndSetCallQualification | Ends the asynchronous of a call. Sets the call qualification.
EndSetMuteOff | Ends the asynchronous of a call. Cancels the call muting (enables the microphone).
EndSetMuteOn | Ends the asynchronous of a call. Mutes this call (disables the microphone).
EndSingleStepConference | Ends the asynchronous of a call. Conferences this call in one step.
EndSingleStepTransfer | Ends the asynchronous of a call. Transfers the given interaction in a single step (without creating a consultation call).
HoldCall | Overloaded.
InitiateConference | Overloaded.
InitiateTransfer | Overloaded.
ListenDisconnect | Overloaded.
ListenReconnect | Overloaded.
MakeCall | Overloaded.
MuteTransfer | Overloaded.
ReconnectCall | Overloaded.
RedirectCall | Overloaded.
ReleaseCall | Overloaded.
RetrieveCall | Overloaded.
SendDtmf | Overloaded.
SetCallQualification | Overloaded.
SetMuteOff | Overloaded.
SetMuteOn | Overloaded.
SingleStepConference | Overloaded.
SingleStepTransfer | Overloaded.

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AlternateCall Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
AlternateCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection) |
AlternateCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32) |
AlternateCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String) |
AlternateCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) |
AlternateCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String) |
AlternateCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
AlternateCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Alternates between the given call and a held call.
AlternateCall(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) |
AlternateCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Alternates between the given call and a held call.
AlternateCall(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
AlternateCall(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Synchronous command to Alternate between two interactions Interactions may be linked or not
AlternateCall(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Synchronous command to Alternate between two interactions Interactions may be linked or not

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AlternateCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AlternateCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AlternateCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AlternateCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
AlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AlternateCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AlternateCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AlternateCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AlternateCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
AlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AlternateCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AlternateCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AlternateCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AlternateCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
AlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AlternateCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AlternateCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AlternateCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AlternateCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
AlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AlternateCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AlternateCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AlternateCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AlternateCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
AlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AlternateCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AlternateCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AlternateCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AlternateCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
AlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AlternateCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Alternates between the given call and a held call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AlternateCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AlternateCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AlternateCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Current call.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Extension list.
correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
AlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AlternateCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AlternateCall(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AlternateCall ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AlternateCall(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
AlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AlternateCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Alternates between the given call and a held call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AlternateCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AlternateCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AlternateCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Current call.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Extension list.
timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
AlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AlternateCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AlternateCall(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AlternateCall ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AlternateCall(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
AlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AlternateCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Synchronous command to Alternate between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AlternateCall(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AlternateCall ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AlternateCall(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
AlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AlternateCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Synchronous command to Alternate between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AlternateCall(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AlternateCall ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AlternateCall(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
AlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


AnswerCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AnswerCall Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
AnswerCall(IVoiceService, IInteraction, KeyValueCollection) |
AnswerCall(IVoiceService, IInteraction, KeyValueCollection, Int32) |
AnswerCall(IVoiceService, IInteraction, KeyValueCollection, String) |
AnswerCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection) | Answers the given call (which is the given ringing interaction).
AnswerCall(IVoiceService, IInteraction, KeyValueCollection, Int32, String) |
AnswerCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32) |
AnswerCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, String) | Answers the given call (which is the given ringing interaction).
AnswerCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32, String) | Answers the given call (which is the given ringing interaction).

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


AnswerCall Method (IVoiceService, IInteraction, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AnswerCall Method (IVoiceService, IInteraction, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AnswerCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AnswerCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AnswerCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
AnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


AnswerCall Method (IVoiceService, IInteraction, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AnswerCall Method (IVoiceService, IInteraction, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AnswerCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AnswerCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AnswerCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
AnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


AnswerCall Method (IVoiceService, IInteraction, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AnswerCall Method (IVoiceService, IInteraction, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AnswerCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AnswerCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AnswerCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
AnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


AnswerCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AnswerCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback
Answers the given call (which is the given ringing interaction).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AnswerCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AnswerCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AnswerCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
AnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


AnswerCall Method (IVoiceService, IInteraction, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AnswerCall Method (IVoiceService, IInteraction, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AnswerCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AnswerCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AnswerCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
AnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


AnswerCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AnswerCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AnswerCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AnswerCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AnswerCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
AnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


AnswerCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AnswerCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Answers the given call (which is the given ringing interaction).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AnswerCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AnswerCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AnswerCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
AnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


AnswerCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.AnswerCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Answers the given call (which is the given ringing interaction).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> AnswerCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AnswerCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AnswerCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
user data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
AnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAlternateCall Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginAlternateCall(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Asynchronous command to alternate between two interactions Interactions may be linked or not
BeginAlternateCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginAlternateCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginAlternateCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginAlternateCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginAlternateCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginAlternateCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Alternates between the given call and a held call.
BeginAlternateCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginAlternateCall(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginAlternateCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Alternates between the given call and a held call.
BeginAlternateCall(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Asynchronous command to alternate between two interactions Interactions may be linked or not
BeginAlternateCall(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAlternateCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Asynchronous command to alternate between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAlternateCall(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternateCall ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternateCall(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginAlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAlternateCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAlternateCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternateCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternateCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginAlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAlternateCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAlternateCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternateCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternateCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginAlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAlternateCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAlternateCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternateCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternateCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginAlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAlternateCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAlternateCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternateCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternateCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginAlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAlternateCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAlternateCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternateCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternateCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginAlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAlternateCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Alternates between the given call and a held call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAlternateCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternateCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternateCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Current call.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Extension list.
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginAlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAlternateCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAlternateCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternateCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternateCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginAlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAlternateCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAlternateCall(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternateCall ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternateCall(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginAlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAlternateCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Alternates between the given call and a held call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAlternateCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternateCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternateCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Current call.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Extension list.
timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginAlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAlternateCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Asynchronous command to alternate between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAlternateCall(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternateCall ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternateCall(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginAlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAlternateCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAlternateCall(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternateCall ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternateCall(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginAlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAnswerCall Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginAnswerCall(IVoiceService, IInteraction, KeyValueCollection, AsyncCallback, Object) |
BeginAnswerCall(IVoiceService, IInteraction, KeyValueCollection, AsyncCallback, Object, Int32) |
BeginAnswerCall(IVoiceService, IInteraction, KeyValueCollection, AsyncCallback, Object, String) |
BeginAnswerCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object) |
BeginAnswerCall(IVoiceService, IInteraction, KeyValueCollection, AsyncCallback, Object, Int32, String) |
BeginAnswerCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Answers the call (on the given interaction).
BeginAnswerCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginAnswerCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object, String) | Answers the given call (which is the given ringing interaction).

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerCall Method (IVoiceService, IInteraction, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAnswerCall Method (IVoiceService, IInteraction, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAnswerCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAnswerCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAnswerCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginAnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerCall Method (IVoiceService, IInteraction, KeyValueCollection, AsyncCallback, Object, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAnswerCall Method (IVoiceService, IInteraction, KeyValueCollection, AsyncCallback, Object, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAnswerCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    AsyncCallback callBack,
    Object context,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAnswerCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    timeOut As Integer _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAnswerCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    AsyncCallback^ callBack,
    Object^ context,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32)"]

See Also

VoiceServiceExtensions Class
BeginAnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerCall Method (IVoiceService, IInteraction, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAnswerCall Method (IVoiceService, IInteraction, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAnswerCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAnswerCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAnswerCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginAnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAnswerCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAnswerCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAnswerCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAnswerCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginAnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerCall Method (IVoiceService, IInteraction, KeyValueCollection, AsyncCallback, Object, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAnswerCall Method (IVoiceService, IInteraction, KeyValueCollection, AsyncCallback, Object, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAnswerCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    AsyncCallback callBack,
    Object context,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAnswerCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    timeOut As Integer, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAnswerCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    AsyncCallback^ callBack,
    Object^ context,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
BeginAnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAnswerCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Answers the call (on the given interaction).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAnswerCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAnswerCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAnswerCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginAnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAnswerCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAnswerCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAnswerCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAnswerCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginAnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginAnswerCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Answers the given call (which is the given ringing interaction).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginAnswerCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAnswerCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAnswerCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginAnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteConference Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginCompleteConference(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Asynchronous command to alternate between two interactions Interactions may be linked or not
BeginCompleteConference(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginCompleteConference(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginCompleteConference(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginCompleteConference(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginCompleteConference(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginCompleteConference(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Completes the two-step conference for the given call.
BeginCompleteConference(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginCompleteConference(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginCompleteConference(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Completes the two-step conference for the given call.
BeginCompleteConference(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Asynchronous command to alternate between two interactions Interactions may be linked or not
BeginCompleteConference(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteConference Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Asynchronous command to alternate between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteConference Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteConference Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteConference Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteConference Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteConference Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteConference Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Completes the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteConference Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteConference Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteConference Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Completes the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteConference Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Asynchronous command to alternate between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteConference Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteTransfer Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginCompleteTransfer(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Asynchronous command to alternate between two interactions Interactions may be linked or not
BeginCompleteTransfer(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginCompleteTransfer(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginCompleteTransfer(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginCompleteTransfer(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginCompleteTransfer(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginCompleteTransfer(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Completes the given two-step transfer.
BeginCompleteTransfer(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginCompleteTransfer(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginCompleteTransfer(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Completes the given two-step transfer.
BeginCompleteTransfer(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginCompleteTransfer(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteTransfer Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Asynchronous command to alternate between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteTransfer Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteTransfer Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteTransfer Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteTransfer Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteTransfer Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteTransfer Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Completes the given two-step transfer.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
reasons
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteTransfer Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteTransfer Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteTransfer Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Completes the given two-step transfer.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
reasons
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteTransfer Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginCompleteTransfer Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginDeleteFromConference Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginDeleteFromConference(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Deletes the given party from the conference.
BeginDeleteFromConference(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginDeleteFromConference(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginDeleteFromConference(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginDeleteFromConference(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginDeleteFromConference(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Deletes the given party from the conference.
BeginDeleteFromConference(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginDeleteFromConference(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginDeleteFromConference Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Deletes the given party from the conference.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginDeleteFromConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginDeleteFromConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginDeleteFromConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginDeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginDeleteFromConference Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginDeleteFromConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginDeleteFromConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginDeleteFromConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginDeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginDeleteFromConference Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginDeleteFromConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginDeleteFromConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginDeleteFromConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginDeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginDeleteFromConference Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginDeleteFromConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginDeleteFromConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginDeleteFromConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginDeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginDeleteFromConference Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginDeleteFromConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginDeleteFromConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginDeleteFromConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginDeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginDeleteFromConference Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Deletes the given party from the conference.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginDeleteFromConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginDeleteFromConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginDeleteFromConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginDeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginDeleteFromConference Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginDeleteFromConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginDeleteFromConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginDeleteFromConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginDeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginDeleteFromConference Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginDeleteFromConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginDeleteFromConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginDeleteFromConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginDeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginHoldCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginHoldCall Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginHoldCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginHoldCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginHoldCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginHoldCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginHoldCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginHoldCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Places the given interaction on hold.
BeginHoldCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginHoldCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Places the given interaction on hold.

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginHoldCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginHoldCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginHoldCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginHoldCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginHoldCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginHoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginHoldCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginHoldCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginHoldCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginHoldCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginHoldCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginHoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginHoldCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginHoldCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginHoldCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginHoldCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginHoldCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginHoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginHoldCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginHoldCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginHoldCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginHoldCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginHoldCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginHoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginHoldCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginHoldCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginHoldCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginHoldCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginHoldCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginHoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginHoldCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginHoldCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Places the given interaction on hold.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginHoldCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginHoldCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginHoldCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginHoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginHoldCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginHoldCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginHoldCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginHoldCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginHoldCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginHoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginHoldCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginHoldCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Places the given interaction on hold.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginHoldCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginHoldCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginHoldCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginHoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginInitiateConference Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginInitiateConference(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginInitiateConference(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginInitiateConference(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginInitiateConference(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Initiates the two-step conference for the given call.
BeginInitiateConference(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginInitiateConference(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginInitiateConference(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Initiates the two-step conference for the given call.
BeginInitiateConference(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginInitiateConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginInitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginInitiateConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginInitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginInitiateConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginInitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginInitiateConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Initiates the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginInitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginInitiateConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginInitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginInitiateConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginInitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginInitiateConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginInitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginInitiateConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginInitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginInitiateTransfer Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginInitiateTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginInitiateTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginInitiateTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginInitiateTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Initiates the two-step transfer of the given call.
BeginInitiateTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginInitiateTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginInitiateTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Initiates the two-step transfer of the given call.
BeginInitiateTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginInitiateTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginInitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginInitiateTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginInitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginInitiateTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginInitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginInitiateTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Initiates the two-step transfer of the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginInitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginInitiateTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginInitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginInitiateTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginInitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginInitiateTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the two-step transfer of the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginInitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginInitiateTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginInitiateTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginInitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginListenDisconnect Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginListenDisconnect(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginListenDisconnect(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginListenDisconnect(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginListenDisconnect(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginListenDisconnect(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginListenDisconnect(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. BeginListenDisconnect
BeginListenDisconnect(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginListenDisconnect(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginListenDisconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenDisconnect(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenDisconnect ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenDisconnect(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginListenDisconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenDisconnect(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenDisconnect ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenDisconnect(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginListenDisconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenDisconnect(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenDisconnect ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenDisconnect(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginListenDisconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenDisconnect(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenDisconnect ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenDisconnect(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginListenDisconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenDisconnect(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenDisconnect ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenDisconnect(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginListenDisconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. BeginListenDisconnect

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenDisconnect(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenDisconnect ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenDisconnect(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginListenDisconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenDisconnect(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenDisconnect ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenDisconnect(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginListenDisconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenDisconnect(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenDisconnect ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenDisconnect(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginListenReconnect Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginListenReconnect(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | BeginListenReconnect
BeginListenReconnect(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginListenReconnect(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginListenReconnect(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginListenReconnect(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginListenReconnect(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call.
BeginListenReconnect(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginListenReconnect(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginListenReconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
BeginListenReconnect

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenReconnect(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenReconnect ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenReconnect(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginListenReconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenReconnect(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenReconnect ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenReconnect(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginListenReconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenReconnect(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenReconnect ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenReconnect(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginListenReconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenReconnect(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenReconnect ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenReconnect(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginListenReconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenReconnect(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenReconnect ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenReconnect(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginListenReconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenReconnect(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenReconnect ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenReconnect(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginListenReconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenReconnect(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenReconnect ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenReconnect(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginListenReconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginListenReconnect(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenReconnect ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenReconnect(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginMakeCall Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginMakeCall(IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Initiates the asynchronous call. Dials a new call.
BeginMakeCall(IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Make an asynchronous call on a device
BeginMakeCall(IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Dials a new call.
BeginMakeCall(IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Dials a new call.
BeginMakeCall(IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Make an asynchronous call on a device
BeginMakeCall(IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Make an asynchronous call on a device
BeginMakeCall(IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Dials a new call.
BeginMakeCall(IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Make an asynchronous call on a device

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginMakeCall Method (IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginMakeCall Method (IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Dials a new call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMakeCall(
    this IVoiceService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeCall ( _
    service As IVoiceService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeCall(
    IVoiceService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Dialing agent.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String
DN to call.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extension.
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginMakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeCall Method (IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginMakeCall Method (IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback
Make an asynchronous call on a device

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMakeCall(
    this IVoiceService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeCall ( _
    service As IVoiceService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeCall(
    IVoiceService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Core..::.IDN

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType

[Missing <param name="makeCallType"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginMakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeCall Method (IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginMakeCall Method (IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Dials a new call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMakeCall(
    this IVoiceService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeCall ( _
    service As IVoiceService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeCall(
    IVoiceService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Dialing agent.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String
DN to call.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extension.
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginMakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeCall Method (IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginMakeCall Method (IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback
Dials a new call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMakeCall(
    this IVoiceService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeCall ( _
    service As IVoiceService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeCall(
    IVoiceService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Dialing agent.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String
DN to call.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extension.
timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginMakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeCall Method (IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginMakeCall Method (IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Make an asynchronous call on a device

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMakeCall(
    this IVoiceService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeCall ( _
    service As IVoiceService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeCall(
    IVoiceService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Core..::.IDN

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType

[Missing <param name="makeCallType"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginMakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeCall Method (IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginMakeCall Method (IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback
Make an asynchronous call on a device

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMakeCall(
    this IVoiceService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeCall ( _
    service As IVoiceService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeCall(
    IVoiceService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Core..::.IDN

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType

[Missing <param name="makeCallType"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginMakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeCall Method (IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginMakeCall Method (IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Dials a new call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMakeCall(
    this IVoiceService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeCall ( _
    service As IVoiceService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeCall(
    IVoiceService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Dialing agent.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String
DN to call.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extension.
timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginMakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeCall Method (IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginMakeCall Method (IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Make an asynchronous call on a device

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMakeCall(
    this IVoiceService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeCall ( _
    service As IVoiceService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeCall(
    IVoiceService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Core..::.IDN

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType

[Missing <param name="makeCallType"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginMakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginMuteTransfer Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginMuteTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginMuteTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Begin a mute transfer (asynchronous operation)
BeginMuteTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginMuteTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Transfers the given interaction in a single blind attempt.
BeginMuteTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginMuteTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginMuteTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Transfers the given interaction in a single blind attempt.
BeginMuteTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginMuteTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMuteTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMuteTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMuteTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginMuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginMuteTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Begin a mute transfer (asynchronous operation)

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMuteTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMuteTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMuteTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginMuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginMuteTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMuteTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMuteTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMuteTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginMuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginMuteTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Transfers the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMuteTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMuteTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMuteTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginMuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginMuteTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMuteTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMuteTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMuteTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginMuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginMuteTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMuteTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMuteTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMuteTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginMuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginMuteTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Transfers the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMuteTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMuteTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMuteTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginMuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginMuteTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginMuteTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMuteTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMuteTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginMuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReconnectCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginReconnectCall Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginReconnectCall(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Begin asynchronous reconnect operation
BeginReconnectCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginReconnectCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Begin asynchronous reconnect operation
BeginReconnectCall(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginReconnectCall(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Begin asynchronous reconnect operation
BeginReconnectCall(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginReconnectCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginReconnectCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Begin asynchronous reconnect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReconnectCall(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReconnectCall ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReconnectCall(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReconnectCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginReconnectCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReconnectCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReconnectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReconnectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReconnectCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginReconnectCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Begin asynchronous reconnect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReconnectCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReconnectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReconnectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReconnectCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginReconnectCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReconnectCall(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReconnectCall ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReconnectCall(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReconnectCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginReconnectCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Begin asynchronous reconnect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReconnectCall(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReconnectCall ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReconnectCall(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReconnectCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginReconnectCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReconnectCall(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReconnectCall ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReconnectCall(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRedirectCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginRedirectCall Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginRedirectCall(IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Begin asynchronous redirect operation
BeginRedirectCall(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginRedirectCall(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Begin asynchronous redirect operation
BeginRedirectCall(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginRedirectCall(IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginRedirectCall(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Begin asynchronous redirect operation
BeginRedirectCall(IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Begin asynchronous redirect operation
BeginRedirectCall(IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginRedirectCall Method (IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginRedirectCall Method (IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Begin asynchronous redirect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRedirectCall(
    this IVoiceService service,
    IInteraction interaction,
    string otherDN,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRedirectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRedirectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginRedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRedirectCall Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginRedirectCall Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRedirectCall(
    this IVoiceService service,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRedirectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRedirectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginRedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRedirectCall Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginRedirectCall Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Begin asynchronous redirect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRedirectCall(
    this IVoiceService service,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRedirectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRedirectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginRedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRedirectCall Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginRedirectCall Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRedirectCall(
    this IVoiceService service,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRedirectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRedirectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginRedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRedirectCall Method (IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginRedirectCall Method (IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRedirectCall(
    this IVoiceService service,
    IInteraction interaction,
    string otherDN,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRedirectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRedirectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginRedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRedirectCall Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginRedirectCall Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Begin asynchronous redirect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRedirectCall(
    this IVoiceService service,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRedirectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRedirectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginRedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRedirectCall Method (IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginRedirectCall Method (IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Begin asynchronous redirect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRedirectCall(
    this IVoiceService service,
    IInteraction interaction,
    string otherDN,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRedirectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRedirectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginRedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRedirectCall Method (IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginRedirectCall Method (IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRedirectCall(
    this IVoiceService service,
    IInteraction interaction,
    string otherDN,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRedirectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRedirectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginRedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReleaseCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginReleaseCall Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginReleaseCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginReleaseCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginReleaseCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Initiates the asynchronous call release. on the given interaction.
BeginReleaseCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginReleaseCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call release. on the given interaction.
BeginReleaseCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginReleaseCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Releases the given interaction.

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginReleaseCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginReleaseCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReleaseCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReleaseCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReleaseCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReleaseCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginReleaseCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReleaseCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReleaseCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReleaseCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReleaseCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginReleaseCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call release. on the given interaction.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReleaseCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReleaseCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReleaseCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReleaseCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginReleaseCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReleaseCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReleaseCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReleaseCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReleaseCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginReleaseCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call release. on the given interaction.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReleaseCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReleaseCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReleaseCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReleaseCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginReleaseCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReleaseCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReleaseCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReleaseCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReleaseCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginReleaseCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Releases the given interaction.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginReleaseCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReleaseCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReleaseCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginRetrieveCall Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginRetrieveCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginRetrieveCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginRetrieveCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginRetrieveCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginRetrieveCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginRetrieveCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Retrieves the given interaction being held.
BeginRetrieveCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginRetrieveCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Retrieves the given interaction being held.

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginRetrieveCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRetrieveCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRetrieveCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRetrieveCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginRetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginRetrieveCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRetrieveCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRetrieveCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRetrieveCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginRetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginRetrieveCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRetrieveCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRetrieveCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRetrieveCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginRetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginRetrieveCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRetrieveCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRetrieveCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRetrieveCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginRetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginRetrieveCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRetrieveCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRetrieveCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRetrieveCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginRetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginRetrieveCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Retrieves the given interaction being held.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRetrieveCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRetrieveCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRetrieveCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginRetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginRetrieveCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRetrieveCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRetrieveCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRetrieveCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginRetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginRetrieveCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Retrieves the given interaction being held.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginRetrieveCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRetrieveCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRetrieveCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginRetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSendDtmf Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSendDtmf Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSendDtmf(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Sends digits as DTMF tones on the given phone call.
BeginSendDtmf(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSendDtmf(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSendDtmf(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginSendDtmf(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSendDtmf(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Sends digits as DTMF tones on the given phone call.
BeginSendDtmf(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSendDtmf(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSendDtmf Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSendDtmf Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Sends digits as DTMF tones on the given phone call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSendDtmf(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSendDtmf ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSendDtmf(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSendDtmf Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSendDtmf Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSendDtmf(
    this IVoiceService interactionService,
    IInteraction interaction,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSendDtmf ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSendDtmf(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSendDtmf Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSendDtmf Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSendDtmf(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSendDtmf ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSendDtmf(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSendDtmf Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSendDtmf Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSendDtmf(
    this IVoiceService interactionService,
    IInteraction interaction,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSendDtmf ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSendDtmf(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSendDtmf Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSendDtmf Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSendDtmf(
    this IVoiceService interactionService,
    IInteraction interaction,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSendDtmf ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSendDtmf(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSendDtmf Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSendDtmf Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Sends digits as DTMF tones on the given phone call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSendDtmf(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSendDtmf ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSendDtmf(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSendDtmf Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSendDtmf Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSendDtmf(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSendDtmf ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSendDtmf(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSendDtmf Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSendDtmf Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSendDtmf(
    this IVoiceService interactionService,
    IInteraction interaction,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSendDtmf ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSendDtmf(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetCallQualification Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSetCallQualification(IVoiceService, IInteraction, KeyValueCollection, AsyncCallback, Object) |
BeginSetCallQualification(IVoiceService, IInteraction, KeyValueCollection, AsyncCallback, Object, String) |
BeginSetCallQualification(IVoiceService, IInteraction, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSetCallQualification(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object) |
BeginSetCallQualification(IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, AsyncCallback, Object) |
BeginSetCallQualification(IVoiceService, IInteraction, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginSetCallQualification(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Sets the call qualification.
BeginSetCallQualification(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSetCallQualification(IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, AsyncCallback, Object, String) |
BeginSetCallQualification(IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSetCallQualification(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object, String) | Sets the call qualification.
BeginSetCallQualification(IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, Int32, AsyncCallback, Object, String) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IVoiceService, IInteraction, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetCallQualification Method (IVoiceService, IInteraction, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection userData,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    userData As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ userData,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IVoiceService, IInteraction, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetCallQualification Method (IVoiceService, IInteraction, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection userData,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    userData As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ userData,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IVoiceService, IInteraction, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetCallQualification Method (IVoiceService, IInteraction, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection userData,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    userData As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ userData,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetCallQualification Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetCallQualification Method (IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IVoiceService interactionService,
    IClientChannel channel,
    IDevice device,
    string interactionId,
    KeyValueCollection userData,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    interactionService As IVoiceService, _
    channel As IClientChannel, _
    device As IDevice, _
    interactionId As String, _
    userData As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IVoiceService^ interactionService,
    IClientChannel^ channel,
    IDevice^ device,
    String^ interactionId,
    KeyValueCollection^ userData,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interactionId
Type: System..::.String

[Missing <param name="interactionId"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IVoiceService, IInteraction, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetCallQualification Method (IVoiceService, IInteraction, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection userData,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    userData As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ userData,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetCallQualification Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Sets the call qualification.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetCallQualification Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetCallQualification Method (IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IVoiceService interactionService,
    IClientChannel channel,
    IDevice device,
    string interactionId,
    KeyValueCollection userData,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    interactionService As IVoiceService, _
    channel As IClientChannel, _
    device As IDevice, _
    interactionId As String, _
    userData As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IVoiceService^ interactionService,
    IClientChannel^ channel,
    IDevice^ device,
    String^ interactionId,
    KeyValueCollection^ userData,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interactionId
Type: System..::.String

[Missing <param name="interactionId"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetCallQualification Method (IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IVoiceService interactionService,
    IClientChannel channel,
    IDevice device,
    string interactionId,
    KeyValueCollection userData,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    interactionService As IVoiceService, _
    channel As IClientChannel, _
    device As IDevice, _
    interactionId As String, _
    userData As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IVoiceService^ interactionService,
    IClientChannel^ channel,
    IDevice^ device,
    String^ interactionId,
    KeyValueCollection^ userData,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interactionId
Type: System..::.String

[Missing <param name="interactionId"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetCallQualification Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Sets the call qualification.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetCallQualification Method (IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IVoiceService interactionService,
    IClientChannel channel,
    IDevice device,
    string interactionId,
    KeyValueCollection userData,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    interactionService As IVoiceService, _
    channel As IClientChannel, _
    device As IDevice, _
    interactionId As String, _
    userData As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IVoiceService^ interactionService,
    IClientChannel^ channel,
    IDevice^ device,
    String^ interactionId,
    KeyValueCollection^ userData,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interactionId
Type: System..::.String

[Missing <param name="interactionId"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOff Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetMuteOff Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSetMuteOff(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSetMuteOff(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginSetMuteOff(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSetMuteOff(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSetMuteOff(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginSetMuteOff(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Cancels the call muting (enables the microphone).
BeginSetMuteOff(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSetMuteOff(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Cancels the call muting (enables the microphone).

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOff Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetMuteOff Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetMuteOff(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOff ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOff(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOff Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetMuteOff Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetMuteOff(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOff ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOff(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOff Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetMuteOff Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetMuteOff(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOff ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOff(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOff Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetMuteOff Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetMuteOff(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOff ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOff(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOff Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetMuteOff Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetMuteOff(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOff ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOff(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOff Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetMuteOff Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Cancels the call muting (enables the microphone).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetMuteOff(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOff ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOff(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOff Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetMuteOff Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetMuteOff(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOff ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOff(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOff Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetMuteOff Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Cancels the call muting (enables the microphone).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetMuteOff(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOff ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOff(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOn Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetMuteOn Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSetMuteOn(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSetMuteOn(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginSetMuteOn(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSetMuteOn(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSetMuteOn(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginSetMuteOn(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Mutes this call (disables the microphone).
BeginSetMuteOn(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSetMuteOn(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Mutes this call (disables the microphone).

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOn Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetMuteOn Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetMuteOn(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOn ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOn(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOn Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetMuteOn Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetMuteOn(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOn ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOn(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOn Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetMuteOn Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetMuteOn(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOn ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOn(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOn Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetMuteOn Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetMuteOn(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOn ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOn(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOn Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetMuteOn Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetMuteOn(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOn ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOn(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOn Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetMuteOn Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Mutes this call (disables the microphone).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetMuteOn(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOn ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOn(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOn Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetMuteOn Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetMuteOn(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOn ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOn(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOn Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSetMuteOn Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Mutes this call (disables the microphone).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSetMuteOn(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOn ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOn(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSingleStepConference Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSingleStepConference(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSingleStepConference(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginSingleStepConference(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSingleStepConference(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Conferences this call in one step.
BeginSingleStepConference(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSingleStepConference(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginSingleStepConference(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Conferences this call in one step.
BeginSingleStepConference(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSingleStepConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSingleStepConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSingleStepConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSingleStepConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Conferences this call in one step.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSingleStepConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSingleStepConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSingleStepConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Conferences this call in one step.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSingleStepConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSingleStepTransfer Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSingleStepTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSingleStepTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginSingleStepTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSingleStepTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) | Initiates the asynchronous call. Transfers the given interaction in a single step (without creating a consultation call).
BeginSingleStepTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSingleStepTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginSingleStepTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) | Transfers the given interaction in a single step (without creating a consultation call).
BeginSingleStepTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSingleStepTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSingleStepTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSingleStepTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSingleStepTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call. Transfers the given interaction in a single step (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSingleStepTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSingleStepTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSingleStepTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
VoiceServiceExtensions Class See Also Send Feedback
Transfers the given interaction in a single step (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

VoiceServiceExtensions Class
BeginSingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.BeginSingleStepTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IAsyncResult BeginSingleStepTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

VoiceServiceExtensions Class
BeginSingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteConference Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
CompleteConference(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection) |
CompleteConference(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32) |
CompleteConference(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String) |
CompleteConference(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) |
CompleteConference(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String) |
CompleteConference(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
CompleteConference(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Completes the two-step conference for the given call.
CompleteConference(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) |
CompleteConference(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Completes the two-step conference for the given call.
CompleteConference(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
CompleteConference(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Synchronous command to conference between two interactions Interactions may be linked or not
CompleteConference(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Synchronous command to conference between two interactions Interactions may be linked or not

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteConference Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteConference Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteConference Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteConference Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteConference Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteConference Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteConference Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Completes the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteConference Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteConference(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteConference(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteConference Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Completes the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteConference Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteConference(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteConference(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteConference Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Synchronous command to conference between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteConference(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteConference(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteConference Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Synchronous command to conference between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteConference(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteConference(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteTransfer Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
CompleteTransfer(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection) |
CompleteTransfer(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32) |
CompleteTransfer(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String) |
CompleteTransfer(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) |
CompleteTransfer(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String) |
CompleteTransfer(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
CompleteTransfer(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Completes the given two-step transfer.
CompleteTransfer(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) |
CompleteTransfer(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Completes the given two-step transfer.
CompleteTransfer(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
CompleteTransfer(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String) |
CompleteTransfer(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Synchronous command to conference between two interactions Interactions may be linked or not

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteTransfer Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteTransfer Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteTransfer Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteTransfer Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteTransfer Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteTransfer Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteTransfer Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Completes the given two-step transfer.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
reasons
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteTransfer Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteTransfer(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteTransfer(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteTransfer Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Completes the given two-step transfer.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
reasons
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteTransfer Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteTransfer(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteTransfer(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteTransfer Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteTransfer(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteTransfer(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.CompleteTransfer Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Synchronous command to conference between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> CompleteTransfer(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteTransfer(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.DeleteFromConference Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
DeleteFromConference(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection) |
DeleteFromConference(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection) |
DeleteFromConference(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32) |
DeleteFromConference(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, String) |
DeleteFromConference(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32) |
DeleteFromConference(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String) | Deletes the given party from the conference.
DeleteFromConference(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String) |
DeleteFromConference(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String) | Deletes the given party from the conference.

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.DeleteFromConference Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> DeleteFromConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function DeleteFromConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ DeleteFromConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
DeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.DeleteFromConference Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> DeleteFromConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function DeleteFromConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ DeleteFromConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
DeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.DeleteFromConference Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> DeleteFromConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function DeleteFromConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ DeleteFromConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
DeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.DeleteFromConference Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> DeleteFromConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function DeleteFromConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ DeleteFromConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
DeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.DeleteFromConference Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> DeleteFromConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function DeleteFromConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ DeleteFromConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
DeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.DeleteFromConference Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Deletes the given party from the conference.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> DeleteFromConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function DeleteFromConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ DeleteFromConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String
User defined data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
DeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.DeleteFromConference Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> DeleteFromConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function DeleteFromConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ DeleteFromConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
DeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.DeleteFromConference Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Deletes the given party from the conference.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> DeleteFromConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function DeleteFromConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ DeleteFromConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
User defined data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
DeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


EndAlternateCall Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndAlternateCall Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Alternates between the given call and a held call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndAlternateCall(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndAlternateCall ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndAlternateCall(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndAlternateCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndAnswerCall Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndAnswerCall Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Answers the given call (which is the given ringing interaction).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndAnswerCall(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndAnswerCall ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndAnswerCall(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndAnswerCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndCompleteConference Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndCompleteConference Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Completes the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndCompleteConference(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndCompleteConference ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndCompleteConference(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndCompleteConference(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndCompleteTransfer Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndCompleteTransfer Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Completes the given two-step transfer.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndCompleteTransfer(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndCompleteTransfer ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndCompleteTransfer(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndCompleteTransfer(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndDeleteFromConference Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndDeleteFromConference Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Deletes the given party from the conference.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndDeleteFromConference(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndDeleteFromConference ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndDeleteFromConference(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndDeleteFromConference(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndHoldCall Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndHoldCall Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Places the given interaction on hold.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndHoldCall(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndHoldCall ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndHoldCall(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndHoldCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndHoldCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndHoldCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndInitiateConference Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndInitiateConference Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Initiates the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndInitiateConference(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndInitiateConference ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndInitiateConference(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndInitiateConference(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndInitiateTransfer Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndInitiateTransfer Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Initiates the two-step transfer of the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndInitiateTransfer(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndInitiateTransfer ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndInitiateTransfer(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndInitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndListenDisconnect Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndListenDisconnect Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndListenDisconnect(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndListenDisconnect ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndListenDisconnect(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndListenReconnect Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndListenReconnect Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndListenReconnect(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndListenReconnect ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndListenReconnect(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndMakeCall Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndMakeCall Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Dials a new call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndMakeCall(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndMakeCall ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndMakeCall(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndMakeCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndMakeCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndMakeCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndMuteTransfer Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndMuteTransfer Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Transfers the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndMuteTransfer(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndMuteTransfer ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndMuteTransfer(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndMuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndReconnectCall Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndReconnectCall Method
VoiceServiceExtensions Class See Also Send Feedback
End asynchronous reconnect call

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndReconnectCall(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndReconnectCall ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndReconnectCall(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndRedirectCall Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndRedirectCall Method
VoiceServiceExtensions Class See Also Send Feedback
End asynchronous redirect call

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndRedirectCall(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndRedirectCall ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndRedirectCall(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndRedirectCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndReleaseCall Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndReleaseCall Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Releases the given interaction.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndReleaseCall(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndReleaseCall ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndReleaseCall(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndRetrieveCall Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndRetrieveCall Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Retrieves the given interaction being held.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndRetrieveCall(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndRetrieveCall ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndRetrieveCall(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndRetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSendDtmf Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndSendDtmf Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Sends digits as DTMF tones on the given phone call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndSendDtmf(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSendDtmf ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndSendDtmf(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndSendDtmf(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSetCallQualification Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndSetCallQualification Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Sets the call qualification.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndSetCallQualification(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSetCallQualification ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndSetCallQualification(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndSetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSetMuteOff Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndSetMuteOff Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Cancels the call muting (enables the microphone).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndSetMuteOff(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSetMuteOff ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndSetMuteOff(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndSetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSetMuteOn Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndSetMuteOn Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Mutes this call (disables the microphone).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndSetMuteOn(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSetMuteOn ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndSetMuteOn(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndSetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSingleStepConference Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndSingleStepConference Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Conferences this call in one step.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndSingleStepConference(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSingleStepConference ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndSingleStepConference(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndSingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSingleStepTransfer Method

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.EndSingleStepTransfer Method
VoiceServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Transfers the given interaction in a single step (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> EndSingleStepTransfer(
    this IVoiceService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSingleStepTransfer ( _
    service As IVoiceService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndSingleStepTransfer(
    IVoiceService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.EndSingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,System.IAsyncResult)"]

See Also

VoiceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


HoldCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.HoldCall Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
HoldCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection) |
HoldCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32) |
HoldCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String) |
HoldCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) |
HoldCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String) |
HoldCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
HoldCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Places the given interaction on hold.
HoldCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Places the given interaction on hold.

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


HoldCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.HoldCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> HoldCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function HoldCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ HoldCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
HoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


HoldCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.HoldCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> HoldCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function HoldCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ HoldCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
HoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


HoldCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.HoldCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> HoldCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function HoldCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ HoldCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
HoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


HoldCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.HoldCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> HoldCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function HoldCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ HoldCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
HoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


HoldCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.HoldCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> HoldCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function HoldCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ HoldCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
HoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


HoldCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.HoldCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> HoldCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function HoldCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ HoldCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
HoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


HoldCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.HoldCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Places the given interaction on hold.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> HoldCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function HoldCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ HoldCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
HoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


HoldCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.HoldCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Places the given interaction on hold.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> HoldCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function HoldCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ HoldCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
HoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.InitiateConference Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
InitiateConference(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) | Initiates the two-step conference for the given call.
InitiateConference(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) |
InitiateConference(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) |
InitiateConference(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |
InitiateConference(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) |
InitiateConference(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |
InitiateConference(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) | Initiates the two-step conference for the given call.
InitiateConference(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.InitiateConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> InitiateConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
user data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
InitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.InitiateConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> InitiateConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
InitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.InitiateConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> InitiateConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
InitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.InitiateConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> InitiateConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
InitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.InitiateConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> InitiateConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
InitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.InitiateConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> InitiateConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
InitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.InitiateConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> InitiateConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
InitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.InitiateConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> InitiateConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
InitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.InitiateTransfer Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
InitiateTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) | Initiates the two-step transfer of the given call.
InitiateTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) |
InitiateTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) |
InitiateTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |
InitiateTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) |
InitiateTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |
InitiateTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) | Initiates the two-step transfer of the given call.
InitiateTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.InitiateTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the two-step transfer of the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> InitiateTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
InitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.InitiateTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> InitiateTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
InitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.InitiateTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> InitiateTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
InitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.InitiateTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> InitiateTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
InitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.InitiateTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> InitiateTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
InitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.InitiateTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> InitiateTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
InitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.InitiateTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Initiates the two-step transfer of the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> InitiateTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
InitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.InitiateTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> InitiateTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
InitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ListenDisconnect Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
ListenDisconnect(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection) |
ListenDisconnect(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection) |
ListenDisconnect(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32) |
ListenDisconnect(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, String) |
ListenDisconnect(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32) |
ListenDisconnect(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String) |
ListenDisconnect(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String) |
ListenDisconnect(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String) | ListenDisconnect

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ListenDisconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ListenDisconnect(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenDisconnect ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenDisconnect(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
ListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ListenDisconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ListenDisconnect(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenDisconnect ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenDisconnect(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
ListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ListenDisconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ListenDisconnect(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenDisconnect ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenDisconnect(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
ListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ListenDisconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ListenDisconnect(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenDisconnect ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenDisconnect(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
ListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ListenDisconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ListenDisconnect(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenDisconnect ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenDisconnect(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
ListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ListenDisconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ListenDisconnect(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenDisconnect ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenDisconnect(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
ListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ListenDisconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ListenDisconnect(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenDisconnect ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenDisconnect(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
ListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ListenDisconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
ListenDisconnect

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ListenDisconnect(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenDisconnect ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenDisconnect(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
User defined data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
ListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ListenReconnect Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
ListenReconnect(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection) |
ListenReconnect(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection) |
ListenReconnect(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32) |
ListenReconnect(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, String) |
ListenReconnect(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32) |
ListenReconnect(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String) | ListenReconnect
ListenReconnect(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String) |
ListenReconnect(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String) | ListenReconnect

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ListenReconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ListenReconnect(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenReconnect ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenReconnect(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
ListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ListenReconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ListenReconnect(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenReconnect ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenReconnect(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
ListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ListenReconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ListenReconnect(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenReconnect ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenReconnect(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
ListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ListenReconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ListenReconnect(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenReconnect ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenReconnect(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
ListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ListenReconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ListenReconnect(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenReconnect ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenReconnect(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
ListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ListenReconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
ListenReconnect

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ListenReconnect(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenReconnect ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenReconnect(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
ListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ListenReconnect Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ListenReconnect(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenReconnect ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenReconnect(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
ListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ListenReconnect Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
ListenReconnect

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ListenReconnect(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenReconnect ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenReconnect(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
ListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


MakeCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.MakeCall Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
MakeCall(IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |
MakeCall(IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) | Dials a new call.
MakeCall(IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) | Make synchronous call on a Device
MakeCall(IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) | Make synchronous call on a Device
MakeCall(IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) | Dials a new call.
MakeCall(IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) | Make synchronous call on a Device
MakeCall(IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) | Dials a new call.
MakeCall(IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) | Make synchronous call on a Device

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


MakeCall Method (IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.MakeCall Method (IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> MakeCall(
    this IVoiceService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeCall ( _
    service As IVoiceService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MakeCall(
    IVoiceService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType

[Missing <param name="makeCallType"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
MakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


MakeCall Method (IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.MakeCall Method (IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Dials a new call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> MakeCall(
    this IVoiceService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeCall ( _
    service As IVoiceService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MakeCall(
    IVoiceService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Dialing agent.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String
DN to call.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extension.
correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
MakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


MakeCall Method (IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.MakeCall Method (IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback
Make synchronous call on a Device

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> MakeCall(
    this IVoiceService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeCall ( _
    service As IVoiceService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MakeCall(
    IVoiceService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Core..::.IDN

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType

[Missing <param name="makeCallType"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
MakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


MakeCall Method (IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.MakeCall Method (IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Make synchronous call on a Device

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> MakeCall(
    this IVoiceService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeCall ( _
    service As IVoiceService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MakeCall(
    IVoiceService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

device
Type: Genesyslab.Enterprise.Core..::.IDN

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType

[Missing <param name="makeCallType"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
MakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


MakeCall Method (IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.MakeCall Method (IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Dials a new call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> MakeCall(
    this IVoiceService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeCall ( _
    service As IVoiceService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MakeCall(
    IVoiceService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Dialing agent.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String
DN to call.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extension.
timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
MakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


MakeCall Method (IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.MakeCall Method (IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Make synchronous call on a Device

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> MakeCall(
    this IVoiceService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeCall ( _
    service As IVoiceService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MakeCall(
    IVoiceService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

device
Type: Genesyslab.Enterprise.Core..::.IDN

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType

[Missing <param name="makeCallType"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
MakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


MakeCall Method (IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.MakeCall Method (IVoiceService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback
Dials a new call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> MakeCall(
    this IVoiceService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeCall ( _
    service As IVoiceService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MakeCall(
    IVoiceService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Dialing agent.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String
DN to call.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extension.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
MakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


MakeCall Method (IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.MakeCall Method (IVoiceService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback
Make synchronous call on a Device

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> MakeCall(
    this IVoiceService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeCall ( _
    service As IVoiceService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MakeCall(
    IVoiceService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Core..::.IDN

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType

[Missing <param name="makeCallType"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
MakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.MuteTransfer Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
MuteTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) | Transfers the given interaction in a single blind attempt.
MuteTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) |
MuteTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) |
MuteTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |
MuteTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) |
MuteTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |
MuteTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) | Transfers the given interaction in a single blind attempt.
MuteTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.MuteTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Transfers the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> MuteTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MuteTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MuteTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
MuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.MuteTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> MuteTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MuteTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MuteTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
MuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.MuteTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> MuteTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MuteTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MuteTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
MuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.MuteTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> MuteTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MuteTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MuteTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
MuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.MuteTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> MuteTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MuteTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MuteTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
MuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.MuteTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> MuteTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MuteTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MuteTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
MuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.MuteTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Transfers the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> MuteTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MuteTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MuteTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String
User Data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
MuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.MuteTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> MuteTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MuteTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MuteTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
MuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReconnectCall Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
ReconnectCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection) |
ReconnectCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32) |
ReconnectCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String) | ReconnectCall by specifying only one interaction Begin synchronous reconnect operation
ReconnectCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) |
ReconnectCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String) | ReconnectCall by specifying only one interaction Begin synchronous reconnect operation
ReconnectCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
ReconnectCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String) | ReconnectCall by specifying only one interaction Begin synchronous reconnect operation
ReconnectCall(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) |
ReconnectCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | ReconnectCall by specifying only one interaction Begin synchronous reconnect operation
ReconnectCall(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
ReconnectCall(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Begin synchronous reconnect operation
ReconnectCall(IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | ReconnectCall by specifying only one interaction Begin synchronous reconnect operation

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReconnectCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReconnectCall(
    this IVoiceService service,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReconnectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReconnectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
ReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReconnectCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReconnectCall(
    this IVoiceService service,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReconnectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReconnectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
ReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReconnectCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
ReconnectCall by specifying only one interaction Begin synchronous reconnect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReconnectCall(
    this IVoiceService service,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReconnectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReconnectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
ReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReconnectCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReconnectCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReconnectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReconnectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
ReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReconnectCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
ReconnectCall by specifying only one interaction Begin synchronous reconnect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReconnectCall(
    this IVoiceService service,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReconnectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReconnectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
ReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReconnectCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReconnectCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReconnectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReconnectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
ReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReconnectCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
ReconnectCall by specifying only one interaction Begin synchronous reconnect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReconnectCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReconnectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReconnectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
ReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReconnectCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReconnectCall(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReconnectCall ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReconnectCall(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
ReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReconnectCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
ReconnectCall by specifying only one interaction Begin synchronous reconnect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReconnectCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReconnectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReconnectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
ReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReconnectCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReconnectCall(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReconnectCall ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReconnectCall(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
ReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReconnectCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Begin synchronous reconnect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReconnectCall(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReconnectCall ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReconnectCall(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
ReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReconnectCall Method (IVoiceService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
ReconnectCall by specifying only one interaction Begin synchronous reconnect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReconnectCall(
    this IVoiceService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReconnectCall ( _
    service As IVoiceService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReconnectCall(
    IVoiceService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
ReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


RedirectCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.RedirectCall Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
RedirectCall(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection) |
RedirectCall(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32) |
RedirectCall(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, String) | Begin syncrhonous redirect operation
RedirectCall(IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection) |
RedirectCall(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String) | Begin syncrhonous redirect operation
RedirectCall(IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
RedirectCall(IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Begin syncrhonous redirect operation
RedirectCall(IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Begin syncrhonous redirect operation

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


RedirectCall Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.RedirectCall Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> RedirectCall(
    this IVoiceService service,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RedirectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RedirectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
RedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


RedirectCall Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.RedirectCall Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> RedirectCall(
    this IVoiceService service,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RedirectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RedirectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
RedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


RedirectCall Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.RedirectCall Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Begin syncrhonous redirect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> RedirectCall(
    this IVoiceService service,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RedirectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RedirectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
RedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


RedirectCall Method (IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.RedirectCall Method (IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> RedirectCall(
    this IVoiceService service,
    IInteraction interaction,
    string otherDN,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RedirectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RedirectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
RedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


RedirectCall Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.RedirectCall Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Begin syncrhonous redirect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> RedirectCall(
    this IVoiceService service,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RedirectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RedirectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
RedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


RedirectCall Method (IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.RedirectCall Method (IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> RedirectCall(
    this IVoiceService service,
    IInteraction interaction,
    string otherDN,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RedirectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RedirectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
RedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


RedirectCall Method (IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.RedirectCall Method (IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Begin syncrhonous redirect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> RedirectCall(
    this IVoiceService service,
    IInteraction interaction,
    string otherDN,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RedirectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RedirectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
RedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


RedirectCall Method (IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.RedirectCall Method (IVoiceService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Begin syncrhonous redirect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> RedirectCall(
    this IVoiceService service,
    IInteraction interaction,
    string otherDN,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RedirectCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RedirectCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
RedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReleaseCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReleaseCall Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
ReleaseCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection) |
ReleaseCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32) |
ReleaseCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String) |
ReleaseCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) | Releases the given interaction.
ReleaseCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String) |
ReleaseCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
ReleaseCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Releases the given interaction.
ReleaseCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Releases the given interaction.

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


ReleaseCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReleaseCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReleaseCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReleaseCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReleaseCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
ReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReleaseCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReleaseCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReleaseCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReleaseCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReleaseCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
ReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReleaseCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReleaseCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReleaseCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReleaseCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReleaseCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
ReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReleaseCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReleaseCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback
Releases the given interaction.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReleaseCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReleaseCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReleaseCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
ReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReleaseCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReleaseCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReleaseCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReleaseCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReleaseCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
ReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReleaseCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReleaseCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReleaseCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReleaseCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReleaseCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
ReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReleaseCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReleaseCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Releases the given interaction.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReleaseCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReleaseCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReleaseCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
ReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReleaseCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.ReleaseCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Releases the given interaction.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> ReleaseCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReleaseCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReleaseCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
ReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


RetrieveCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.RetrieveCall Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
RetrieveCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection) |
RetrieveCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32) |
RetrieveCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String) |
RetrieveCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) |
RetrieveCall(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String) |
RetrieveCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
RetrieveCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Retrieves the given interaction being held.
RetrieveCall(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Retrieves the given interaction being held.

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


RetrieveCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.RetrieveCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> RetrieveCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RetrieveCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RetrieveCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
RetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


RetrieveCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.RetrieveCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> RetrieveCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RetrieveCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RetrieveCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
RetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


RetrieveCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.RetrieveCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> RetrieveCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RetrieveCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RetrieveCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
RetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


RetrieveCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.RetrieveCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> RetrieveCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RetrieveCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RetrieveCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
RetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


RetrieveCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.RetrieveCall Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> RetrieveCall(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RetrieveCall ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RetrieveCall(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
RetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


RetrieveCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.RetrieveCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> RetrieveCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RetrieveCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RetrieveCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
RetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


RetrieveCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.RetrieveCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Retrieves the given interaction being held.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> RetrieveCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RetrieveCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RetrieveCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
RetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


RetrieveCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.RetrieveCall Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Retrieves the given interaction being held.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> RetrieveCall(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RetrieveCall ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RetrieveCall(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
user data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
RetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


SendDtmf Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SendDtmf Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SendDtmf(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection) |
SendDtmf(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection) |
SendDtmf(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32) |
SendDtmf(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, String) |
SendDtmf(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32) |
SendDtmf(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String) | Sends digits as DTMF tones on the given phone call.
SendDtmf(IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String) |
SendDtmf(IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String) | Sends digits as DTMF tones on the given phone call.

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SendDtmf Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SendDtmf Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SendDtmf(
    this IVoiceService interactionService,
    IInteraction interaction,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SendDtmf ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SendDtmf(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
SendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


SendDtmf Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SendDtmf Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SendDtmf(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SendDtmf ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SendDtmf(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
SendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


SendDtmf Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SendDtmf Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SendDtmf(
    this IVoiceService interactionService,
    IInteraction interaction,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SendDtmf ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SendDtmf(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
SendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


SendDtmf Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SendDtmf Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SendDtmf(
    this IVoiceService interactionService,
    IInteraction interaction,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SendDtmf ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SendDtmf(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
SendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


SendDtmf Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SendDtmf Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SendDtmf(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SendDtmf ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SendDtmf(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
SendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


SendDtmf Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SendDtmf Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Sends digits as DTMF tones on the given phone call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SendDtmf(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SendDtmf ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SendDtmf(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
SendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


SendDtmf Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SendDtmf Method (IVoiceService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SendDtmf(
    this IVoiceService interactionService,
    IInteraction interaction,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SendDtmf ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SendDtmf(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
SendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


SendDtmf Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SendDtmf Method (IVoiceService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Sends digits as DTMF tones on the given phone call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SendDtmf(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SendDtmf ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SendDtmf(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
SendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetCallQualification Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SetCallQualification(IVoiceService, IInteraction, KeyValueCollection) |
SetCallQualification(IVoiceService, IInteraction, KeyValueCollection, Int32) |
SetCallQualification(IVoiceService, IInteraction, KeyValueCollection, String) |
SetCallQualification(IVoiceService, IInteraction, IClientChannel, KeyValueCollection) |
SetCallQualification(IVoiceService, IClientChannel, IDevice, String, KeyValueCollection) |
SetCallQualification(IVoiceService, IInteraction, KeyValueCollection, Int32, String) |
SetCallQualification(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32) |
SetCallQualification(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, String) | Sets the call qualification.
SetCallQualification(IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, Int32) |
SetCallQualification(IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, String) |
SetCallQualification(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32, String) | Sets the call qualification.
SetCallQualification(IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, Int32, String) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IVoiceService, IInteraction, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetCallQualification Method (IVoiceService, IInteraction, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetCallQualification(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection userData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    userData As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetCallQualification(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ userData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IVoiceService, IInteraction, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetCallQualification Method (IVoiceService, IInteraction, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetCallQualification(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection userData,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    userData As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetCallQualification(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ userData,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IVoiceService, IInteraction, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetCallQualification Method (IVoiceService, IInteraction, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetCallQualification(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection userData,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    userData As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetCallQualification(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ userData,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetCallQualification Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetCallQualification(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetCallQualification(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IVoiceService, IClientChannel, IDevice, String, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetCallQualification Method (IVoiceService, IClientChannel, IDevice, String, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetCallQualification(
    this IVoiceService interactionService,
    IClientChannel channel,
    IDevice device,
    string interactionId,
    KeyValueCollection userData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    interactionService As IVoiceService, _
    channel As IClientChannel, _
    device As IDevice, _
    interactionId As String, _
    userData As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetCallQualification(
    IVoiceService^ interactionService,
    IClientChannel^ channel,
    IDevice^ device,
    String^ interactionId,
    KeyValueCollection^ userData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interactionId
Type: System..::.String

[Missing <param name="interactionId"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IVoiceService, IInteraction, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetCallQualification Method (IVoiceService, IInteraction, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetCallQualification(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection userData,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    userData As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetCallQualification(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ userData,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetCallQualification Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetCallQualification(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetCallQualification(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetCallQualification Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Sets the call qualification.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetCallQualification(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetCallQualification(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetCallQualification Method (IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetCallQualification(
    this IVoiceService interactionService,
    IClientChannel channel,
    IDevice device,
    string interactionId,
    KeyValueCollection userData,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    interactionService As IVoiceService, _
    channel As IClientChannel, _
    device As IDevice, _
    interactionId As String, _
    userData As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetCallQualification(
    IVoiceService^ interactionService,
    IClientChannel^ channel,
    IDevice^ device,
    String^ interactionId,
    KeyValueCollection^ userData,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interactionId
Type: System..::.String

[Missing <param name="interactionId"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetCallQualification Method (IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetCallQualification(
    this IVoiceService interactionService,
    IClientChannel channel,
    IDevice device,
    string interactionId,
    KeyValueCollection userData,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    interactionService As IVoiceService, _
    channel As IClientChannel, _
    device As IDevice, _
    interactionId As String, _
    userData As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetCallQualification(
    IVoiceService^ interactionService,
    IClientChannel^ channel,
    IDevice^ device,
    String^ interactionId,
    KeyValueCollection^ userData,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interactionId
Type: System..::.String

[Missing <param name="interactionId"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetCallQualification Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Sets the call qualification.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetCallQualification(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetCallQualification(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetCallQualification Method (IVoiceService, IClientChannel, IDevice, String, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetCallQualification(
    this IVoiceService interactionService,
    IClientChannel channel,
    IDevice device,
    string interactionId,
    KeyValueCollection userData,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    interactionService As IVoiceService, _
    channel As IClientChannel, _
    device As IDevice, _
    interactionId As String, _
    userData As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetCallQualification(
    IVoiceService^ interactionService,
    IClientChannel^ channel,
    IDevice^ device,
    String^ interactionId,
    KeyValueCollection^ userData,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interactionId
Type: System..::.String

[Missing <param name="interactionId"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOff Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetMuteOff Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SetMuteOff(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection) |
SetMuteOff(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32) |
SetMuteOff(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String) |
SetMuteOff(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) |
SetMuteOff(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String) |
SetMuteOff(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
SetMuteOff(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Cancels the call muting (enables the microphone).
SetMuteOff(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Cancels the call muting (enables the microphone).

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SetMuteOff Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetMuteOff Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOff(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOff ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOff(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
SetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOff Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetMuteOff Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOff(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOff ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOff(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
SetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOff Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetMuteOff Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOff(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOff ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOff(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
SetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOff Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetMuteOff Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOff(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOff ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOff(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
SetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOff Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetMuteOff Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOff(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOff ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOff(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
SetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOff Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetMuteOff Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOff(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOff ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOff(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
SetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOff Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetMuteOff Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Cancels the call muting (enables the microphone).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOff(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOff ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOff(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
SetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOff Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetMuteOff Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Cancels the call muting (enables the microphone).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOff(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOff ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOff(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
SetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOn Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetMuteOn Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SetMuteOn(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection) |
SetMuteOn(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32) |
SetMuteOn(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String) |
SetMuteOn(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) |
SetMuteOn(IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String) |
SetMuteOn(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
SetMuteOn(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String) | Mutes this call (disables the microphone).
SetMuteOn(IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) | Mutes this call (disables the microphone).

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SetMuteOn Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetMuteOn Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOn(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOn ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOn(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
SetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOn Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetMuteOn Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOn(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOn ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOn(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
SetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOn Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetMuteOn Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOn(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOn ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOn(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
SetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOn Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetMuteOn Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOn(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOn ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOn(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
SetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOn Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetMuteOn Method (IVoiceService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOn(
    this IVoiceService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOn ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOn(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
SetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOn Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetMuteOn Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOn(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOn ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOn(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
SetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOn Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetMuteOn Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Mutes this call (disables the microphone).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOn(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOn ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOn(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
SetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOn Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SetMuteOn Method (IVoiceService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Mutes this call (disables the microphone).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOn(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOn ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOn(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
User defined data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
SetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SingleStepConference Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SingleStepConference(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) | Conferences this call in one step.
SingleStepConference(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) |
SingleStepConference(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) |
SingleStepConference(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |
SingleStepConference(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) |
SingleStepConference(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |
SingleStepConference(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) | Conferences this call in one step.
SingleStepConference(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SingleStepConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Conferences this call in one step.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String
User defined data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
SingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SingleStepConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
SingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SingleStepConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
SingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SingleStepConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
SingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SingleStepConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
SingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SingleStepConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
SingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SingleStepConference Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Conferences this call in one step.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepConference(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepConference ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepConference(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String
User defined data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
SingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SingleStepConference Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepConference(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepConference ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepConference(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
SingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SingleStepTransfer Method
VoiceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SingleStepTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) | Transfers the given interaction in a single step (without creating a consultation call).
SingleStepTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) |
SingleStepTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) |
SingleStepTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |
SingleStepTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) |
SingleStepTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |
SingleStepTransfer(IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String) | Transfers the given interaction in a single step (without creating a consultation call).
SingleStepTransfer(IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

VoiceServiceExtensions Class
VoiceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SingleStepTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback
Transfers the given interaction in a single step (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
SingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SingleStepTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
SingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SingleStepTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

VoiceServiceExtensions Class
SingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SingleStepTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
SingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SingleStepTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
SingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SingleStepTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

VoiceServiceExtensions Class
SingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SingleStepTransfer Method (IVoiceService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, String)
VoiceServiceExtensions Class See Also Send Feedback
Transfers the given interaction in a single step (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepTransfer(
    this IVoiceService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepTransfer ( _
    service As IVoiceService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepTransfer(
    IVoiceService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IVoiceService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String
User data

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

VoiceServiceExtensions Class
SingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceServiceExtensions..::.SingleStepTransfer Method (IVoiceService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, String)
VoiceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepTransfer(
    this IVoiceService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepTransfer ( _
    interactionService As IVoiceService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepTransfer(
    IVoiceService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IVoiceService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.VoiceServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IVoiceService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

VoiceServiceExtensions Class
SingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


Genesyslab.Enterprise.Framework.Container.Unity Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Framework.Container.Unity Namespace
Send Feedback

Classes

Class | Description
GlobalThreadLifeTimeManager | Manage of the lifetime of the object in Unity.


GlobalThreadLifeTimeManager Class

[image]

Enterprise SDK 8.0 Reference API
GlobalThreadLifeTimeManager Class
Members See Also Send Feedback
Manage of the lifetime of the object in Unity.

Namespace: Genesyslab.Enterprise.Framework.Container.Unity
Assembly: Genesyslab.Enterprise.Framework (in Genesyslab.Enterprise.Framework.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public class GlobalThreadLifeTimeManager : LifetimeManager,
    IRequiresRecovery
Visual Basic (Declaration)
Public Class GlobalThreadLifeTimeManager _
    Inherits LifetimeManager _
    Implements IRequiresRecovery
Visual C++
public ref class GlobalThreadLifeTimeManager : public LifetimeManager,
    IRequiresRecovery

Inheritance Hierarchy

System..::.Object
LifetimeManager
Genesyslab.Enterprise.Framework.Container.Unity..::.GlobalThreadLifeTimeManager

See Also

GlobalThreadLifeTimeManager Members
Genesyslab.Enterprise.Framework.Container.Unity Namespace


GlobalThreadLifeTimeManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
GlobalThreadLifeTimeManager Members
GlobalThreadLifeTimeManager Class Constructors Methods Explicit Interface Implementations See Also Send Feedback

The GlobalThreadLifeTimeManager type exposes the following members.

Constructors

Name | Description
GlobalThreadLifeTimeManager | Creates an instance of this class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Gets the object. (Overrides LifetimeManagerGetValue()()().)
RemoveValue | Removes the object. (Overrides LifetimeManagerRemoveValue()()().)
SetValue | Sets a new value. (Overrides LifetimeManagerSetValue(Object).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IRequiresRecoveryRecover |

See Also

GlobalThreadLifeTimeManager Class
Genesyslab.Enterprise.Framework.Container.Unity Namespace


GlobalThreadLifeTimeManager Constructor

[image]

Enterprise SDK 8.0 Reference API
GlobalThreadLifeTimeManager Constructor
GlobalThreadLifeTimeManager Class See Also Send Feedback
Creates an instance of this class.

Namespace: Genesyslab.Enterprise.Framework.Container.Unity
Assembly: Genesyslab.Enterprise.Framework (in Genesyslab.Enterprise.Framework.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public GlobalThreadLifeTimeManager()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GlobalThreadLifeTimeManager()

See Also

GlobalThreadLifeTimeManager Class
Genesyslab.Enterprise.Framework.Container.Unity Namespace


GlobalThreadLifeTimeManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
GlobalThreadLifeTimeManager Methods
GlobalThreadLifeTimeManager Class See Also Send Feedback

The GlobalThreadLifeTimeManager type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Gets the object. (Overrides LifetimeManagerGetValue()()().)
RemoveValue | Removes the object. (Overrides LifetimeManagerRemoveValue()()().)
SetValue | Sets a new value. (Overrides LifetimeManagerSetValue(Object).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IRequiresRecoveryRecover |

See Also

GlobalThreadLifeTimeManager Class
Genesyslab.Enterprise.Framework.Container.Unity Namespace


. Method

[image]

Enterprise SDK 8.0 Reference API
GlobalThreadLifeTimeManager..::...::. Method
GlobalThreadLifeTimeManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Framework.Container.Unity.GlobalThreadLifeTimeManager.Microsoft#Practices#ObjectBuilder2#IRequiresRecovery#Recover"]

Namespace: Genesyslab.Enterprise.Framework.Container.Unity
Assembly: Genesyslab.Enterprise.Framework (in Genesyslab.Enterprise.Framework.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void IRequiresRecovery.Recover()
Visual Basic (Declaration)
Private Sub Recover Implements IRequiresRecovery.Recover
Visual C++
private:
virtual void Recover() sealed = IRequiresRecovery::Recover

Implements

IRequiresRecoveryRecover()()()

See Also

GlobalThreadLifeTimeManager Class
Genesyslab.Enterprise.Framework.Container.Unity Namespace


GetValue Method

[image]

Enterprise SDK 8.0 Reference API
GlobalThreadLifeTimeManager..::.GetValue Method
GlobalThreadLifeTimeManager Class See Also Send Feedback
Gets the object.

Namespace: Genesyslab.Enterprise.Framework.Container.Unity
Assembly: Genesyslab.Enterprise.Framework (in Genesyslab.Enterprise.Framework.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override Object GetValue()
Visual Basic (Declaration)
Public Overrides Function GetValue As Object
Visual C++
public:
virtual Object^ GetValue() override

Return Value

the object.

Implements

ILifetimePolicyGetValue()()()

See Also

GlobalThreadLifeTimeManager Class
Genesyslab.Enterprise.Framework.Container.Unity Namespace


RemoveValue Method

[image]

Enterprise SDK 8.0 Reference API
GlobalThreadLifeTimeManager..::.RemoveValue Method
GlobalThreadLifeTimeManager Class See Also Send Feedback
Removes the object.

Namespace: Genesyslab.Enterprise.Framework.Container.Unity
Assembly: Genesyslab.Enterprise.Framework (in Genesyslab.Enterprise.Framework.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override void RemoveValue()
Visual Basic (Declaration)
Public Overrides Sub RemoveValue
Visual C++
public:
virtual void RemoveValue() override

Implements

ILifetimePolicyRemoveValue()()()

See Also

GlobalThreadLifeTimeManager Class
Genesyslab.Enterprise.Framework.Container.Unity Namespace


SetValue Method

[image]

Enterprise SDK 8.0 Reference API
GlobalThreadLifeTimeManager..::.SetValue Method
GlobalThreadLifeTimeManager Class See Also Send Feedback
Sets a new value.

Namespace: Genesyslab.Enterprise.Framework.Container.Unity
Assembly: Genesyslab.Enterprise.Framework (in Genesyslab.Enterprise.Framework.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override void SetValue(
    Object newValue
)
Visual Basic (Declaration)
Public Overrides Sub SetValue ( _
    newValue As Object _
)
Visual C++
public:
virtual void SetValue(
    Object^ newValue
) override

Parameters

newValue
Type: System..::.Object
the new value.

Implements

ILifetimePolicySetValue(Object)

See Also

GlobalThreadLifeTimeManager Class
Genesyslab.Enterprise.Framework.Container.Unity Namespace


Genesyslab.Enterprise.Model.Channel Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Channel Namespace
Send Feedback

Classes

Class | Description
ChannelExtension | Advanced methods for Channel class.

Interfaces

Interface | Description
IChannelManager | Manages channel information.
IClientChannel | Describes a client channel.
IProtocolManager | Manages protocol information in the up-level channel.

Enumerations

Enumeration | Description
ChannelModeType | Describes the mode assigned to this channel: primary, backup, or none.


ChannelExtension Class

[image]

Enterprise SDK 8.0 Reference API
ChannelExtension Class
Members See Also Send Feedback
Advanced methods for Channel class.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.PSDKExtensions (in Genesyslab.Enterprise.PSDKExtensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static class ChannelExtension
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class ChannelExtension
Visual C++
[ExtensionAttribute]
public ref class ChannelExtension abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Model.Channel..::.ChannelExtension

See Also

ChannelExtension Members
Genesyslab.Enterprise.Model.Channel Namespace


ChannelExtension Members

[image] [image]

Enterprise SDK 8.0 Reference API
ChannelExtension Members
ChannelExtension Class Methods See Also Send Feedback

The ChannelExtension type exposes the following members.

Methods

Name | Description
UseClientCertificate | Use Client Certificate to authenticate on the Genesys Channel
UseClientSidePort | Indicate Channel to use a specific Port to communicate with Genesys Servers
UseServerBasedCertificate | Use Server-Based Certificate to authenticate on the Genesys Channel

See Also

ChannelExtension Class
Genesyslab.Enterprise.Model.Channel Namespace


ChannelExtension Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ChannelExtension Methods
ChannelExtension Class See Also Send Feedback

The ChannelExtension type exposes the following members.

Methods

Name | Description
UseClientCertificate | Use Client Certificate to authenticate on the Genesys Channel
UseClientSidePort | Indicate Channel to use a specific Port to communicate with Genesys Servers
UseServerBasedCertificate | Use Server-Based Certificate to authenticate on the Genesys Channel

See Also

ChannelExtension Class
Genesyslab.Enterprise.Model.Channel Namespace


UseClientCertificate Method

[image]

Enterprise SDK 8.0 Reference API
ChannelExtension..::.UseClientCertificate Method
ChannelExtension Class See Also Send Feedback
Use Client Certificate to authenticate on the Genesys Channel

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.PSDKExtensions (in Genesyslab.Enterprise.PSDKExtensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static void UseClientCertificate(
    this IClientChannel clientChannel,
    string certificateName
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Sub UseClientCertificate ( _
    clientChannel As IClientChannel, _
    certificateName As String _
)
Visual C++
[ExtensionAttribute]
public:
static void UseClientCertificate(
    IClientChannel^ clientChannel,
    String^ certificateName
)

Parameters

clientChannel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel on which the certificate applied
certificateName
Type: System..::.String
Client Certificate Name

See Also

ChannelExtension Class
Genesyslab.Enterprise.Model.Channel Namespace


UseClientSidePort Method

[image]

Enterprise SDK 8.0 Reference API
ChannelExtension..::.UseClientSidePort Method
ChannelExtension Class See Also Send Feedback
Indicate Channel to use a specific Port to communicate with Genesys Servers

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.PSDKExtensions (in Genesyslab.Enterprise.PSDKExtensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static void UseClientSidePort(
    this IClientChannel clientChannel,
    string transportAddress,
    int transportPort
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Sub UseClientSidePort ( _
    clientChannel As IClientChannel, _
    transportAddress As String, _
    transportPort As Integer _
)
Visual C++
[ExtensionAttribute]
public:
static void UseClientSidePort(
    IClientChannel^ clientChannel,
    String^ transportAddress,
    int transportPort
)

Parameters

clientChannel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel on which the port definition applied
transportAddress
Type: System..::.String
IP Address that the client application will use for its TCP/IP Connection to Genesys Channel
transportPort
Type: System..::.Int32
Port number that the client application will use for its TCP/IP Connection to Genesys Channel

See Also

ChannelExtension Class
Genesyslab.Enterprise.Model.Channel Namespace


UseServerBasedCertificate Method

[image]

Enterprise SDK 8.0 Reference API
ChannelExtension..::.UseServerBasedCertificate Method
ChannelExtension Class See Also Send Feedback
Use Server-Based Certificate to authenticate on the Genesys Channel

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.PSDKExtensions (in Genesyslab.Enterprise.PSDKExtensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static void UseServerBasedCertificate(
    this IClientChannel clientChannel,
    string certificateName
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Sub UseServerBasedCertificate ( _
    clientChannel As IClientChannel, _
    certificateName As String _
)
Visual C++
[ExtensionAttribute]
public:
static void UseServerBasedCertificate(
    IClientChannel^ clientChannel,
    String^ certificateName
)

Parameters

clientChannel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel on which the certificate applied
certificateName
Type: System..::.String
Certificate Name stored on the Server

See Also

ChannelExtension Class
Genesyslab.Enterprise.Model.Channel Namespace


ChannelModeType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ChannelModeType Enumeration
See Also Send Feedback
Describes the mode assigned to this channel: primary, backup, or none.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum ChannelModeType
Visual Basic (Declaration)
Public Enumeration ChannelModeType
Visual C++
public enum class ChannelModeType

Members

Member name | Description
None |
Primary |
Backup |

See Also

Genesyslab.Enterprise.Model.Channel Namespace


IChannelManager Interface

[image]

Enterprise SDK 8.0 Reference API
IChannelManager Interface
Members See Also Send Feedback
Manages channel information.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IChannelManager
Visual Basic (Declaration)
Public Interface IChannelManager
Visual C++
public interface class IChannelManager

See Also

IChannelManager Members
Genesyslab.Enterprise.Model.Channel Namespace


IChannelManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager Members
IChannelManager Interface Methods See Also Send Feedback

The IChannelManager type exposes the following members.

Methods

Name | Description
AddChannel | Adds the given channel.
Connect | Overloaded.
CreateChannel | Overloaded.
DeleteChannel | Deletes the given channel.
Disconnect | Overloaded.
GetChannel | Overloaded.
ListChannels | Overloaded.
ListDevices | Lists the devices of a specific channel.
SendMessage | Sends a message to the given channel.

See Also

IChannelManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


IChannelManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager Methods
IChannelManager Interface See Also Send Feedback

The IChannelManager type exposes the following members.

Methods

Name | Description
AddChannel | Adds the given channel.
Connect | Overloaded.
CreateChannel | Overloaded.
DeleteChannel | Deletes the given channel.
Disconnect | Overloaded.
GetChannel | Overloaded.
ListChannels | Overloaded.
ListDevices | Lists the devices of a specific channel.
SendMessage | Sends a message to the given channel.

See Also

IChannelManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


AddChannel Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.AddChannel Method
IChannelManager Interface See Also Send Feedback
Adds the given channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager AddChannel(
    IClientChannel channel,
    ProtocolConfiguration config
)
Visual Basic (Declaration)
Function AddChannel ( _
    channel As IClientChannel, _
    config As ProtocolConfiguration _
) As IChannelManager
Visual C++
IChannelManager^ AddChannel(
    IClientChannel^ channel,
    ProtocolConfiguration^ config
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel name.
config
Type: ProtocolConfiguration
Configuration instance.

Return Value

IChannelManager

See Also

IChannelManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method
IChannelManager Interface See Also Send Feedback

Overload List

Name | Description
Connect()()() | Connects all the channels. Note: This method is asynchronous.
Connect(IClientChannel) | Connects the given channel. Note: This method is asynchronous.
Connect(Int32) | Connects all the channels. Note: This method is synchronous.
Connect(String) | Connects the given channel. Note: This method is asynchronous.
Connect(IClientChannel, Int32) | Connects the given channel. Note: This method is synchronous.
Connect(String, Int32) | Connects the given channel. Note: This method is synchronous.

See Also

IChannelManager Interface
IChannelManager Members
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method
IChannelManager Interface See Also Send Feedback
Connects all the channels. Note: This method is asynchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager Connect()
Visual Basic (Declaration)
Function Connect As IChannelManager
Visual C++
IChannelManager^ Connect()

Return Value

IChannelManager

See Also

IChannelManager Interface
Connect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method (IClientChannel)
IChannelManager Interface See Also Send Feedback
Connects the given channel. Note: This method is asynchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager Connect(
    IClientChannel channel
)
Visual Basic (Declaration)
Function Connect ( _
    channel As IClientChannel _
) As IChannelManager
Visual C++
IChannelManager^ Connect(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance

Return Value

IChannelManager

See Also

IChannelManager Interface
Connect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method (Int32)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method (Int32)
IChannelManager Interface See Also Send Feedback
Connects all the channels. Note: This method is synchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager Connect(
    int milliseconds
)
Visual Basic (Declaration)
Function Connect ( _
    milliseconds As Integer _
) As IChannelManager
Visual C++
IChannelManager^ Connect(
    int milliseconds
)

Parameters

milliseconds
Type: System..::.Int32
Maximum time to wait in milliseconds.

Return Value

IChannelManager

See Also

IChannelManager Interface
Connect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method (String)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method (String)
IChannelManager Interface See Also Send Feedback
Connects the given channel. Note: This method is asynchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager Connect(
    string channelName
)
Visual Basic (Declaration)
Function Connect ( _
    channelName As String _
) As IChannelManager
Visual C++
IChannelManager^ Connect(
    String^ channelName
)

Parameters

channelName
Type: System..::.String
Channel name.

Return Value

IChannelManager

See Also

IChannelManager Interface
Connect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method (IClientChannel, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method (IClientChannel, Int32)
IChannelManager Interface See Also Send Feedback
Connects the given channel. Note: This method is synchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager Connect(
    IClientChannel channel,
    int milliseconds
)
Visual Basic (Declaration)
Function Connect ( _
    channel As IClientChannel, _
    milliseconds As Integer _
) As IChannelManager
Visual C++
IChannelManager^ Connect(
    IClientChannel^ channel,
    int milliseconds
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
milliseconds
Type: System..::.Int32
Maximum time to wait in milliseconds.

Return Value

IChannelManager

See Also

IChannelManager Interface
Connect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method (String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method (String, Int32)
IChannelManager Interface See Also Send Feedback
Connects the given channel. Note: This method is synchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager Connect(
    string channelName,
    int milliseconds
)
Visual Basic (Declaration)
Function Connect ( _
    channelName As String, _
    milliseconds As Integer _
) As IChannelManager
Visual C++
IChannelManager^ Connect(
    String^ channelName,
    int milliseconds
)

Parameters

channelName
Type: System..::.String
Channel name.
milliseconds
Type: System..::.Int32
Maximum time to wait in milliseconds.

Return Value

IChannelManager

See Also

IChannelManager Interface
Connect Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method
IChannelManager Interface See Also Send Feedback

Overload List

Name | Description
CreateChannel(ProtocolConfiguration) | Creates a channel based on a user configuration instance without a switch abstraction.
CreateChannel(ProtocolConfiguration, SwitchModelType) | Creates a channel based on the given user configuration and switch type.
CreateChannel(ProtocolConfiguration, String) | Creates a channel based on the given configuration instance.
CreateChannel(String, ProtocolConfiguration) | Creates a channel without switch asbtraction capability.
CreateChannel(String, IProtocol) | Creates a channel based on already existing connection
CreateChannel(String, ProtocolConfiguration, SwitchModelType) | Creates a named channel, with the given user configuration and switch abstraction capability.
CreateChannel(String, ProtocolConfiguration, String) | Creates a channel, with the given user configuration and switch abstraction capability.
CreateChannel(String, IProtocol, SwitchModelType) | Obsolete. Creates a channel based on already existing connection and switch type.
CreateChannel(String, IProtocol, String) | Obsolete. Creates a channel based on already existing connection and switch type.

See Also

IChannelManager Interface
IChannelManager Members
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method ()

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method ()
IChannelManager Interface See Also Send Feedback
Creates a channel based on a user configuration instance without a switch abstraction.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager CreateChannel(
    ProtocolConfiguration config
)
Visual Basic (Declaration)
Function CreateChannel ( _
    config As ProtocolConfiguration _
) As IChannelManager
Visual C++
IChannelManager^ CreateChannel(
    ProtocolConfiguration^ config
)

Parameters

config
Type: ProtocolConfiguration
Custom configuration instance.

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (, SwitchModelType)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (, SwitchModelType)
IChannelManager Interface See Also Send Feedback
Creates a channel based on the given user configuration and switch type.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager CreateChannel(
    ProtocolConfiguration config,
    SwitchModelType switchModel
)
Visual Basic (Declaration)
Function CreateChannel ( _
    config As ProtocolConfiguration, _
    switchModel As SwitchModelType _
) As IChannelManager
Visual C++
IChannelManager^ CreateChannel(
    ProtocolConfiguration^ config,
    SwitchModelType switchModel
)

Parameters

config
Type: ProtocolConfiguration
User configuration.
switchModel
Type: Genesyslab.Enterprise.Model.Protocol..::.SwitchModelType
Type of switch.

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (, String)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (, String)
IChannelManager Interface See Also Send Feedback
Creates a channel based on the given configuration instance.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager CreateChannel(
    ProtocolConfiguration config,
    string switchType
)
Visual Basic (Declaration)
Function CreateChannel ( _
    config As ProtocolConfiguration, _
    switchType As String _
) As IChannelManager
Visual C++
IChannelManager^ CreateChannel(
    ProtocolConfiguration^ config,
    String^ switchType
)

Parameters

config
Type: ProtocolConfiguration
Custom configuration instance.
switchType
Type: System..::.String
Switch entry as defined in the Switch Policy Library (SPL). Valid values are :
  • LucentDefinityG3
  • AlcatelA4400DHS3::Classic
  • AlcatelA4400DHS3::Substitute
  • SIPSwitch
  • NortelDMS100
  • NortelMeridianCallCenter

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, )

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, )
IChannelManager Interface See Also Send Feedback
Creates a channel without switch asbtraction capability.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager CreateChannel(
    string name,
    ProtocolConfiguration config
)
Visual Basic (Declaration)
Function CreateChannel ( _
    name As String, _
    config As ProtocolConfiguration _
) As IChannelManager
Visual C++
IChannelManager^ CreateChannel(
    String^ name,
    ProtocolConfiguration^ config
)

Parameters

name
Type: System..::.String
Channel name.
config
Type: ProtocolConfiguration
User configuration instance.

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, )

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, )
IChannelManager Interface See Also Send Feedback
Creates a channel based on already existing connection

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager CreateChannel(
    string name,
    IProtocol protocol
)
Visual Basic (Declaration)
Function CreateChannel ( _
    name As String, _
    protocol As IProtocol _
) As IChannelManager
Visual C++
IChannelManager^ CreateChannel(
    String^ name,
    IProtocol^ protocol
)

Parameters

name
Type: System..::.String
the channel name.
protocol
Type: IProtocol
the channel protocol.

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, , SwitchModelType)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, , SwitchModelType)
IChannelManager Interface See Also Send Feedback
Creates a named channel, with the given user configuration and switch abstraction capability.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager CreateChannel(
    string name,
    ProtocolConfiguration config,
    SwitchModelType switchModel
)
Visual Basic (Declaration)
Function CreateChannel ( _
    name As String, _
    config As ProtocolConfiguration, _
    switchModel As SwitchModelType _
) As IChannelManager
Visual C++
IChannelManager^ CreateChannel(
    String^ name,
    ProtocolConfiguration^ config,
    SwitchModelType switchModel
)

Parameters

name
Type: System..::.String
Channel name.
config
Type: ProtocolConfiguration
Configruation instance.
switchModel
Type: Genesyslab.Enterprise.Model.Protocol..::.SwitchModelType
Type of switch model.

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, , String)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, , String)
IChannelManager Interface See Also Send Feedback
Creates a channel, with the given user configuration and switch abstraction capability.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager CreateChannel(
    string name,
    ProtocolConfiguration config,
    string switchModel
)
Visual Basic (Declaration)
Function CreateChannel ( _
    name As String, _
    config As ProtocolConfiguration, _
    switchModel As String _
) As IChannelManager
Visual C++
IChannelManager^ CreateChannel(
    String^ name,
    ProtocolConfiguration^ config,
    String^ switchModel
)

Parameters

name
Type: System..::.String
Channel name
config
Type: ProtocolConfiguration
Configruation instance
switchModel
Type: System..::.String
Switch entry as defined in the Switch Policy Library (SPL). Valid values are :
  • LucentDefinityG3
  • AlcatelA4400DHS3::Classic
  • AlcatelA4400DHS3::Substitute
  • SIPSwitch
  • NortelDMS100
  • NortelMeridianCallCenter

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.CreateChannel(System.String,Genesyslab.Platform.ApplicationBlocks.Commons.Protocols.ProtocolConfiguration,System.String)"]

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, , SwitchModelType)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, , SwitchModelType)
IChannelManager Interface See Also Send Feedback
Creates a channel based on already existing connection and switch type.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Will be removed in next release")]
IChannelManager CreateChannel(
    string name,
    IProtocol protocol,
    SwitchModelType switchModel
)
Visual Basic (Declaration)
<ObsoleteAttribute("Will be removed in next release")> _
Function CreateChannel ( _
    name As String, _
    protocol As IProtocol, _
    switchModel As SwitchModelType _
) As IChannelManager
Visual C++
[ObsoleteAttribute(L"Will be removed in next release")]
IChannelManager^ CreateChannel(
    String^ name,
    IProtocol^ protocol,
    SwitchModelType switchModel
)

Parameters

name
Type: System..::.String
the channel name.
protocol
Type: IProtocol
the channel protocol.
switchModel
Type: Genesyslab.Enterprise.Model.Protocol..::.SwitchModelType
the model of the switch.

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, , String)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, , String)
IChannelManager Interface See Also Send Feedback
Creates a channel based on already existing connection and switch type.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Will be removed in next release")]
IChannelManager CreateChannel(
    string name,
    IProtocol protocol,
    string switchModel
)
Visual Basic (Declaration)
<ObsoleteAttribute("Will be removed in next release")> _
Function CreateChannel ( _
    name As String, _
    protocol As IProtocol, _
    switchModel As String _
) As IChannelManager
Visual C++
[ObsoleteAttribute(L"Will be removed in next release")]
IChannelManager^ CreateChannel(
    String^ name,
    IProtocol^ protocol,
    String^ switchModel
)

Parameters

name
Type: System..::.String
the channel name.
protocol
Type: IProtocol
the channel protocol.
switchModel
Type: System..::.String
the model of the switch.

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


DeleteChannel Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.DeleteChannel Method
IChannelManager Interface See Also Send Feedback
Deletes the given channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager DeleteChannel(
    string name
)
Visual Basic (Declaration)
Function DeleteChannel ( _
    name As String _
) As IChannelManager
Visual C++
IChannelManager^ DeleteChannel(
    String^ name
)

Parameters

name
Type: System..::.String
Channel name.

Return Value

IChannelManager

See Also

IChannelManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


Disconnect Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Disconnect Method
IChannelManager Interface See Also Send Feedback

Overload List

Name | Description
Disconnect()()() | Disconnects all the channels.
Disconnect(IClientChannel) | Disconnects the given channel instance. Note: This method is asynchronous.
Disconnect(String) | Disconnects the given channel. Note: This method is asynchronous.
Disconnect(IClientChannel, Int32) | Disconnects the given channel. Note: This method is synchronous.
Disconnect(String, Int32) | Disconnects the given channel. Note: This method is synchronous.

See Also

IChannelManager Interface
IChannelManager Members
Genesyslab.Enterprise.Model.Channel Namespace


Disconnect Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Disconnect Method
IChannelManager Interface See Also Send Feedback
Disconnects all the channels.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager Disconnect()
Visual Basic (Declaration)
Function Disconnect As IChannelManager
Visual C++
IChannelManager^ Disconnect()

Return Value

IChannelManager

See Also

IChannelManager Interface
Disconnect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Disconnect Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Disconnect Method (IClientChannel)
IChannelManager Interface See Also Send Feedback
Disconnects the given channel instance. Note: This method is asynchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager Disconnect(
    IClientChannel channel
)
Visual Basic (Declaration)
Function Disconnect ( _
    channel As IClientChannel _
) As IChannelManager
Visual C++
IChannelManager^ Disconnect(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.

Return Value

IChannelManager

See Also

IChannelManager Interface
Disconnect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Disconnect Method (String)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Disconnect Method (String)
IChannelManager Interface See Also Send Feedback
Disconnects the given channel. Note: This method is asynchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager Disconnect(
    string channelName
)
Visual Basic (Declaration)
Function Disconnect ( _
    channelName As String _
) As IChannelManager
Visual C++
IChannelManager^ Disconnect(
    String^ channelName
)

Parameters

channelName
Type: System..::.String
Channel name

Return Value

IChannelManager

See Also

IChannelManager Interface
Disconnect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Disconnect Method (IClientChannel, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Disconnect Method (IClientChannel, Int32)
IChannelManager Interface See Also Send Feedback
Disconnects the given channel. Note: This method is synchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager Disconnect(
    IClientChannel channel,
    int milliseconds
)
Visual Basic (Declaration)
Function Disconnect ( _
    channel As IClientChannel, _
    milliseconds As Integer _
) As IChannelManager
Visual C++
IChannelManager^ Disconnect(
    IClientChannel^ channel,
    int milliseconds
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
milliseconds
Type: System..::.Int32
Maximum time to wait in milliseconds.

Return Value

IChannelManager

See Also

IChannelManager Interface
Disconnect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Disconnect Method (String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Disconnect Method (String, Int32)
IChannelManager Interface See Also Send Feedback
Disconnects the given channel. Note: This method is synchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager Disconnect(
    string channelName,
    int milliseconds
)
Visual Basic (Declaration)
Function Disconnect ( _
    channelName As String, _
    milliseconds As Integer _
) As IChannelManager
Visual C++
IChannelManager^ Disconnect(
    String^ channelName,
    int milliseconds
)

Parameters

channelName
Type: System..::.String
Channel name.
milliseconds
Type: System..::.Int32
Maximum time to wait in milliseconds.

Return Value

IChannelManager

See Also

IChannelManager Interface
Disconnect Overload
Genesyslab.Enterprise.Model.Channel Namespace


GetChannel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.GetChannel Method
IChannelManager Interface See Also Send Feedback

Overload List

Name | Description
GetChannel(IDevice) | Returns a channel object from a device
GetChannel(String) | Returns a channel object.
GetChannel(Uri) | Returns the channel with the given URI.

See Also

IChannelManager Interface
IChannelManager Members
Genesyslab.Enterprise.Model.Channel Namespace


GetChannel Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.GetChannel Method (IDevice)
IChannelManager Interface See Also Send Feedback
Returns a channel object from a device

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IClientChannel GetChannel(
    IDevice device
)
Visual Basic (Declaration)
Function GetChannel ( _
    device As IDevice _
) As IClientChannel
Visual C++
IClientChannel^ GetChannel(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device instance.

Return Value

IClientChannel

See Also

IChannelManager Interface
GetChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


GetChannel Method (String)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.GetChannel Method (String)
IChannelManager Interface See Also Send Feedback
Returns a channel object.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IClientChannel GetChannel(
    string channel
)
Visual Basic (Declaration)
Function GetChannel ( _
    channel As String _
) As IClientChannel
Visual C++
IClientChannel^ GetChannel(
    String^ channel
)

Parameters

channel
Type: System..::.String
Channel name.

Return Value

IClientChannel

See Also

IChannelManager Interface
GetChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


GetChannel Method (Uri)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.GetChannel Method (Uri)
IChannelManager Interface See Also Send Feedback
Returns the channel with the given URI.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IClientChannel GetChannel(
    Uri name
)
Visual Basic (Declaration)
Function GetChannel ( _
    name As Uri _
) As IClientChannel
Visual C++
IClientChannel^ GetChannel(
    Uri^ name
)

Parameters

name
Type: System..::.Uri
URI to retrieve from the service registry.

Return Value

IClientChannel

See Also

IChannelManager Interface
GetChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


ListChannels Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.ListChannels Method
IChannelManager Interface See Also Send Feedback

Overload List

Name | Description
ListChannels<(Of <(T>)>)()()() | Lists the channels registered in the service.
ListChannels()()() | Lists all the channels registered in the service.

See Also

IChannelManager Interface
IChannelManager Members
Genesyslab.Enterprise.Model.Channel Namespace


ListChannels(T) Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.ListChannels<(Of <(T>)>) Method
IChannelManager Interface See Also Send Feedback
Lists the channels registered in the service.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IClientChannel[] ListChannels<T>()
Visual Basic (Declaration)
Function ListChannels(Of T) As IClientChannel()
Visual C++
generic<typename T>
array<IClientChannel^>^ ListChannels()

Type Parameters

T
Protocol type that is being listed

Return Value

IClientChannel []

See Also

IChannelManager Interface
ListChannels Overload
Genesyslab.Enterprise.Model.Channel Namespace


ListChannels Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.ListChannels Method
IChannelManager Interface See Also Send Feedback
Lists all the channels registered in the service.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IClientChannel[] ListChannels()
Visual Basic (Declaration)
Function ListChannels As IClientChannel()
Visual C++
array<IClientChannel^>^ ListChannels()

Return Value

IClientChannel []

See Also

IChannelManager Interface
ListChannels Overload
Genesyslab.Enterprise.Model.Channel Namespace


ListDevices Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.ListDevices Method
IChannelManager Interface See Also Send Feedback
Lists the devices of a specific channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDevice[] ListDevices(
    string channelName
)
Visual Basic (Declaration)
Function ListDevices ( _
    channelName As String _
) As IDevice()
Visual C++
array<IDevice^>^ ListDevices(
    String^ channelName
)

Parameters

channelName
Type: System..::.String
Channel name.

Return Value

IDevice[]

See Also

IChannelManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


SendMessage Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.SendMessage Method
IChannelManager Interface See Also Send Feedback
Sends a message to the given channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager SendMessage(
    IClientChannel channel,
    IMessage msg
)
Visual Basic (Declaration)
Function SendMessage ( _
    channel As IClientChannel, _
    msg As IMessage _
) As IChannelManager
Visual C++
IChannelManager^ SendMessage(
    IClientChannel^ channel,
    IMessage^ msg
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
msg
Type: IMessage
Message instance.

Return Value

IChannelManager

See Also

IChannelManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


IClientChannel Interface

[image]

Enterprise SDK 8.0 Reference API
IClientChannel Interface
Members See Also Send Feedback
Describes a client channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IClientChannel : IDisposable
Visual Basic (Declaration)
Public Interface IClientChannel _
    Implements IDisposable
Visual C++
public interface class IClientChannel : IDisposable

See Also

IClientChannel Members
Genesyslab.Enterprise.Model.Channel Namespace


IClientChannel Members

[image] [image]

Enterprise SDK 8.0 Reference API
IClientChannel Members
IClientChannel Interface Methods Properties See Also Send Feedback

The IClientChannel type exposes the following members.

Methods

Name | Description
Close | Overloaded.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Open | Overloaded.
Send | Sends a request through the communication channel to the connected server. Note: This method is asynchronous Returns a correlation Id when sending is successfull. If not, method returns a negative value

Properties

Name | Description
Endpoint | Get the Channel Endpoint
EnterpriseProtocols | Get access to the Protocol management interface
FQName | Get a Fully Qualified Name (unique ID).
GetProtocolRule | Returns the protocol rule assigned to the channel
Mode | Channel Mode.
Name | Get channel Name.
Protocol | Protocol associated with this channel.
RawSubscriber | Retrieve the low level subscriber object
Receiver | Message receiver.
Requests | Returns requests currenlty handled by the channel object
State | Get channel Status.
Strategy | Channel strategies.

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


IClientChannel Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IClientChannel Methods
IClientChannel Interface See Also Send Feedback

The IClientChannel type exposes the following members.

Methods

Name | Description
Close | Overloaded.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Open | Overloaded.
Send | Sends a request through the communication channel to the connected server. Note: This method is asynchronous Returns a correlation Id when sending is successfull. If not, method returns a negative value

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Close Method

[image] [image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Close Method
IClientChannel Interface See Also Send Feedback

Overload List

Name | Description
Close()()() | Closes the communication channel. Note: This method is asynchronous.
Close(Int32) | Closes the communication channel. Note: This method is synchronous

See Also

IClientChannel Interface
IClientChannel Members
Genesyslab.Enterprise.Model.Channel Namespace


Close Method

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Close Method
IClientChannel Interface See Also Send Feedback
Closes the communication channel. Note: This method is asynchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Close()
Visual Basic (Declaration)
Sub Close
Visual C++
void Close()

See Also

IClientChannel Interface
Close Overload
Genesyslab.Enterprise.Model.Channel Namespace


Close Method (Int32)

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Close Method (Int32)
IClientChannel Interface See Also Send Feedback
Closes the communication channel. Note: This method is synchronous

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Close(
    int milliseconds
)
Visual Basic (Declaration)
Sub Close ( _
    milliseconds As Integer _
)
Visual C++
void Close(
    int milliseconds
)

Parameters

milliseconds
Type: System..::.Int32
Timeout in milliseconds. Must be greater than 0

See Also

IClientChannel Interface
Close Overload
Genesyslab.Enterprise.Model.Channel Namespace


Open Method

[image] [image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Open Method
IClientChannel Interface See Also Send Feedback

Overload List

Name | Description
Open()()() | Open channel connection Note: This method is asynchronous. Register to the channel object to be notified of object state change
Open(Int32) | Open channel conenction Note: This method is synchronous

See Also

IClientChannel Interface
IClientChannel Members
Genesyslab.Enterprise.Model.Channel Namespace


Open Method

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Open Method
IClientChannel Interface See Also Send Feedback
Open channel connection Note: This method is asynchronous. Register to the channel object to be notified of object state change

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Open()
Visual Basic (Declaration)
Sub Open
Visual C++
void Open()

See Also

IClientChannel Interface
Open Overload
Genesyslab.Enterprise.Model.Channel Namespace


Open Method (Int32)

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Open Method (Int32)
IClientChannel Interface See Also Send Feedback
Open channel conenction Note: This method is synchronous

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Open(
    int milliseconds
)
Visual Basic (Declaration)
Sub Open ( _
    milliseconds As Integer _
)
Visual C++
void Open(
    int milliseconds
)

Parameters

milliseconds
Type: System..::.Int32
Timeout in milliseconds. Must be greater than 0

See Also

IClientChannel Interface
Open Overload
Genesyslab.Enterprise.Model.Channel Namespace


Send Method

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Send Method
IClientChannel Interface See Also Send Feedback
Sends a request through the communication channel to the connected server. Note: This method is asynchronous Returns a correlation Id when sending is successfull. If not, method returns a negative value

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
int Send(
    IRequest request
)
Visual Basic (Declaration)
Function Send ( _
    request As IRequest _
) As Integer
Visual C++
int Send(
    IRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRequest
Request to be sent to the back end server

Return Value

int

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


IClientChannel Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IClientChannel Properties
IClientChannel Interface See Also Send Feedback

The IClientChannel type exposes the following members.

Properties

Name | Description
Endpoint | Get the Channel Endpoint
EnterpriseProtocols | Get access to the Protocol management interface
FQName | Get a Fully Qualified Name (unique ID).
GetProtocolRule | Returns the protocol rule assigned to the channel
Mode | Channel Mode.
Name | Get channel Name.
Protocol | Protocol associated with this channel.
RawSubscriber | Retrieve the low level subscriber object
Receiver | Message receiver.
Requests | Returns requests currenlty handled by the channel object
State | Get channel Status.
Strategy | Channel strategies.

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Endpoint Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Endpoint Property
IClientChannel Interface See Also Send Feedback
Get the Channel Endpoint

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Uri Endpoint { get; }
Visual Basic (Declaration)
ReadOnly Property Endpoint As Uri
Visual C++
property Uri^ Endpoint {
    Uri^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


EnterpriseProtocols Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.EnterpriseProtocols Property
IClientChannel Interface See Also Send Feedback
Get access to the Protocol management interface

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IProtocolManager EnterpriseProtocols { get; }
Visual Basic (Declaration)
ReadOnly Property EnterpriseProtocols As IProtocolManager
Visual C++
property IProtocolManager^ EnterpriseProtocols {
    IProtocolManager^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.FQName Property
IClientChannel Interface See Also Send Feedback
Get a Fully Qualified Name (unique ID).

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string FQName { get; }
Visual Basic (Declaration)
ReadOnly Property FQName As String
Visual C++
property String^ FQName {
    String^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


GetProtocolRule Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.GetProtocolRule Property
IClientChannel Interface See Also Send Feedback
Returns the protocol rule assigned to the channel

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object GetProtocolRule { get; }
Visual Basic (Declaration)
ReadOnly Property GetProtocolRule As Object
Visual C++
property Object^ GetProtocolRule {
    Object^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Mode Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Mode Property
IClientChannel Interface See Also Send Feedback
Channel Mode.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ChannelModeType Mode { get; }
Visual Basic (Declaration)
ReadOnly Property Mode As ChannelModeType
Visual C++
property ChannelModeType Mode {
    ChannelModeType get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Name Property
IClientChannel Interface See Also Send Feedback
Get channel Name.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Protocol Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Protocol Property
IClientChannel Interface See Also Send Feedback
Protocol associated with this channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IProtocol Protocol { get; }
Visual Basic (Declaration)
ReadOnly Property Protocol As IProtocol
Visual C++
property IProtocol^ Protocol {
    IProtocol^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


RawSubscriber Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.RawSubscriber Property
IClientChannel Interface See Also Send Feedback
Retrieve the low level subscriber object

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IServiceSubscriber<IMessage> RawSubscriber { get; }
Visual Basic (Declaration)
ReadOnly Property RawSubscriber As IServiceSubscriber(Of IMessage)
Visual C++
property IServiceSubscriber<IMessage^>^ RawSubscriber {
    IServiceSubscriber<IMessage^>^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Receiver Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Receiver Property
IClientChannel Interface See Also Send Feedback
Message receiver.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IMessageReceiver Receiver { get; set; }
Visual Basic (Declaration)
Property Receiver As IMessageReceiver
Visual C++
property IMessageReceiver^ Receiver {
    IMessageReceiver^ get ();
    void set (IMessageReceiver^ value);
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Requests Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Requests Property
IClientChannel Interface See Also Send Feedback
Returns requests currenlty handled by the channel object

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IRequestManager Requests { get; }
Visual Basic (Declaration)
ReadOnly Property Requests As IRequestManager
Visual C++
property IRequestManager^ Requests {
    IRequestManager^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.State Property
IClientChannel Interface See Also Send Feedback
Get channel Status.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ChannelState State { get; }
Visual Basic (Declaration)
ReadOnly Property State As ChannelState
Visual C++
property ChannelState State {
    ChannelState get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Strategy Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Strategy Property
IClientChannel Interface See Also Send Feedback
Channel strategies.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ICollection<IStrategy> Strategy { get; }
Visual Basic (Declaration)
ReadOnly Property Strategy As ICollection(Of IStrategy)
Visual C++
property ICollection<IStrategy^>^ Strategy {
    ICollection<IStrategy^>^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


IProtocolManager Interface

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager Interface
Members See Also Send Feedback
Manages protocol information in the up-level channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IProtocolManager
Visual Basic (Declaration)
Public Interface IProtocolManager
Visual C++
public interface class IProtocolManager

See Also

IProtocolManager Members
Genesyslab.Enterprise.Model.Channel Namespace


IProtocolManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolManager Members
IProtocolManager Interface Methods Properties See Also Send Feedback

The IProtocolManager type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Deletes all the registered protocols.
ContainsKey | Returns true if the given protocol name exists.
List | Lists all the registered protocols.
Remove | Removes the given protocol.

Properties

Name | Description
Item | Gets a property according to its key.

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


IProtocolManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolManager Methods
IProtocolManager Interface See Also Send Feedback

The IProtocolManager type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Deletes all the registered protocols.
ContainsKey | Returns true if the given protocol name exists.
List | Lists all the registered protocols.
Remove | Removes the given protocol.

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


Add Method

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.Add Method
IProtocolManager Interface See Also Send Feedback

Overload List

Name | Description
Add(String, IEnterpriseProtocol) | Adds the given communication protocol. Note: The protocol's switch policy must match the channel's switch policy.
Add(String, MediaType, IEnumerable<(Of <(IProtocolRequest>)>)) | Adds the given communication protocol using the channel's switch policy.

See Also

IProtocolManager Interface
IProtocolManager Members
Genesyslab.Enterprise.Model.Channel Namespace


Add Method (String, IEnterpriseProtocol)

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.Add Method (String, IEnterpriseProtocol)
IProtocolManager Interface See Also Send Feedback
Adds the given communication protocol. Note: The protocol's switch policy must match the channel's switch policy.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Add(
    string name,
    IEnterpriseProtocol protocol
)
Visual Basic (Declaration)
Sub Add ( _
    name As String, _
    protocol As IEnterpriseProtocol _
)
Visual C++
void Add(
    String^ name,
    IEnterpriseProtocol^ protocol
)

Parameters

name
Type: System..::.String
the protocol name.
protocol
Type: Genesyslab.Enterprise.Model.Protocol..::.IEnterpriseProtocol
the protocol object.

See Also

IProtocolManager Interface
Add Overload
Genesyslab.Enterprise.Model.Channel Namespace


Add Method (String, MediaType, IEnumerable(IProtocolRequest))

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.Add Method (String, MediaType, IEnumerable<(Of <(IProtocolRequest>)>))
IProtocolManager Interface See Also Send Feedback
Adds the given communication protocol using the channel's switch policy.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Add(
    string name,
    MediaType mediaType,
    IEnumerable<IProtocolRequest> listCommands
)
Visual Basic (Declaration)
Sub Add ( _
    name As String, _
    mediaType As MediaType, _
    listCommands As IEnumerable(Of IProtocolRequest) _
)
Visual C++
void Add(
    String^ name,
    MediaType mediaType,
    IEnumerable<IProtocolRequest^>^ listCommands
)

Parameters

name
Type: System..::.String
Protocol name.
mediaType
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType
Communication type.
listCommands
Type: System.Collections.Generic..::.IEnumerable<(Of <( IProtocolRequest >)>)
Commands.

See Also

IProtocolManager Interface
Add Overload
Genesyslab.Enterprise.Model.Channel Namespace


Clear Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.Clear Method
IProtocolManager Interface See Also Send Feedback
Deletes all the registered protocols.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Clear()
Visual Basic (Declaration)
Sub Clear
Visual C++
void Clear()

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


ContainsKey Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.ContainsKey Method
IProtocolManager Interface See Also Send Feedback
Returns true if the given protocol name exists.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool ContainsKey(
    string key
)
Visual Basic (Declaration)
Function ContainsKey ( _
    key As String _
) As Boolean
Visual C++
bool ContainsKey(
    String^ key
)

Parameters

key
Type: System..::.String
the protocol name

Return Value

true if the name is already registered.

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


List Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.List Method
IProtocolManager Interface See Also Send Feedback
Lists all the registered protocols.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnumerator<IEnterpriseProtocol> List()
Visual Basic (Declaration)
Function List As IEnumerator(Of IEnterpriseProtocol)
Visual C++
IEnumerator<IEnterpriseProtocol^>^ List()

Return Value

Collection of protocols.

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


Remove Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.Remove Method
IProtocolManager Interface See Also Send Feedback
Removes the given protocol.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool Remove(
    string key
)
Visual Basic (Declaration)
Function Remove ( _
    key As String _
) As Boolean
Visual C++
bool Remove(
    String^ key
)

Parameters

key
Type: System..::.String
the protocol name

Return Value

true if the protocol is succesfully unregistered.

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


IProtocolManager Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolManager Properties
IProtocolManager Interface See Also Send Feedback

The IProtocolManager type exposes the following members.

Properties

Name | Description
Item | Gets a property according to its key.

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.Item Property
IProtocolManager Interface See Also Send Feedback
Gets a property according to its key.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnterpriseProtocol this[
    string name
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    name As String _
) As IEnterpriseProtocol
Visual C++
property IEnterpriseProtocol^ default[String^ name] {
    IEnterpriseProtocol^ get (String^ name);
}

Parameters

name
Type: System..::.String

Return Value

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


Genesyslab.Enterprise.Model.Common Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Common Namespace
Send Feedback

Classes

Class | Description
ReadOnlyDictionary<(Of <(TKey, TValue>)>) | A read only dictionary implementation.


ReadOnlyDictionary(TKey, TValue) Class

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Members See Also Send Feedback
A read only dictionary implementation.

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public sealed class ReadOnlyDictionary<TKey, TValue> : IDictionary<TKey, TValue>,
    ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>,
    IEnumerable
Visual Basic (Declaration)
Public NotInheritable Class ReadOnlyDictionary(Of TKey, TValue) _
    Implements IDictionary(Of TKey, TValue), ICollection(Of KeyValuePair(Of TKey, TValue)),  _
    IEnumerable(Of KeyValuePair(Of TKey, TValue)), IEnumerable
Visual C++
generic<typename TKey, typename TValue>
public ref class ReadOnlyDictionary sealed : IDictionary<TKey, TValue>,
    ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>,
    IEnumerable

Type Parameters

TKey
the key of the property.
TValue
the value of the property.

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Model.Common..::.ReadOnlyDictionary<(Of <(TKey, TValue>)>)

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Members
Genesyslab.Enterprise.Model.Common Namespace


ReadOnlyDictionary(TKey, TValue) Members

[image] [image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Members
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ReadOnlyDictionary<(Of <(TKey, TValue>)>) type exposes the following members.

Constructors

Name | Description
ReadOnlyDictionary<(Of <(TKey, TValue>)>) | Creates a read only dictionary from another dictionary.

Methods

Name | Description
Contains | Returns true if the property (key, value) exists in the dictionary.
ContainsKey | Returns true if the key of a property exists in the dictionary.
CopyTo | Copies the element of the array into the dictionary at the specified index of the array.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Gets the enumerator for this dictionary.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetValue | Gets the value associated with the specified key.

Properties

Name | Description
Count | Gets the number of elements in the dictionary.
IsReadOnly | Returns true, this dictionary is read only.
Item | Returns the value associated with the specified key.
Keys | Gets all the keys of the dictionary.
Values | Gets all the values of the dictionary.

Explicit Interface Implementations

Name | Description
ICollection<(Of <(KeyValuePair<(Of <(TKey, TValue>)>)>)>)..::.Add |
IDictionary<(Of <(TKey, TValue>)>)..::.Add | Not supported, this dictionary is read only.
ICollection<(Of <(KeyValuePair<(Of <(TKey, TValue>)>)>)>)..::.Clear |
IEnumerable..::.GetEnumerator | Gets the enumerator for this dictionary.
IDictionary<(Of <(TKey, TValue>)>)..::.Item | Gets the value associated with the specified key.
ICollection<(Of <(KeyValuePair<(Of <(TKey, TValue>)>)>)>)..::.Remove |
IDictionary<(Of <(TKey, TValue>)>)..::.Remove | Not supported, this dictionary is read only.

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


ReadOnlyDictionary(TKey, TValue) Constructor

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Constructor
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback
Creates a read only dictionary from another dictionary.

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ReadOnlyDictionary(
    IDictionary<TKey, TValue> source
)
Visual Basic (Declaration)
Public Sub New ( _
    source As IDictionary(Of TKey, TValue) _
)
Visual C++
public:
ReadOnlyDictionary(
    IDictionary<TKey, TValue>^ source
)

Parameters

source
Type: System.Collections.Generic..::.IDictionary<(Of <( TKey, TValue >)>)
the source dictionary.

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


ReadOnlyDictionary(TKey, TValue) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Methods
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

The ReadOnlyDictionary<(Of <(TKey, TValue>)>) type exposes the following members.

Methods

Name | Description
Contains | Returns true if the property (key, value) exists in the dictionary.
ContainsKey | Returns true if the key of a property exists in the dictionary.
CopyTo | Copies the element of the array into the dictionary at the specified index of the array.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Gets the enumerator for this dictionary.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetValue | Gets the value associated with the specified key.

Explicit Interface Implementations

Name | Description
ICollection<(Of <(KeyValuePair<(Of <(TKey, TValue>)>)>)>)..::.Add |
IDictionary<(Of <(TKey, TValue>)>)..::.Add | Not supported, this dictionary is read only.
ICollection<(Of <(KeyValuePair<(Of <(TKey, TValue>)>)>)>)..::.Clear |
IEnumerable..::.GetEnumerator | Gets the enumerator for this dictionary.
ICollection<(Of <(KeyValuePair<(Of <(TKey, TValue>)>)>)>)..::.Remove |
IDictionary<(Of <(TKey, TValue>)>)..::.Remove | Not supported, this dictionary is read only.

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


ICollection(KeyValuePair(TKey, TValue)).Add Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.ICollection<(Of <(KeyValuePair<(Of <(TKey, TValue>)>)>)>)..::.Add Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#ICollection{T}#Add(System.Collections.Generic.KeyValuePair{`0,`1})"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void ICollection<KeyValuePair<TKey, TValue>>.Add(
    KeyValuePair<TKey, TValue> item
)
Visual Basic (Declaration)
Private Sub Add ( _
    item As KeyValuePair(Of TKey, TValue) _
) Implements ICollection(Of KeyValuePair(Of TKey, TValue)).Add
Visual C++
private:
virtual void Add(
    KeyValuePair<TKey, TValue> item
) sealed = ICollection<KeyValuePair<TKey, TValue>>::Add

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair<(Of <( TKey, TValue >)>)

[Missing <param name="item"/> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#ICollection{T}#Add(System.Collections.Generic.KeyValuePair{`0,`1})"]

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


IDictionary(TKey, TValue).Add Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.IDictionary<(Of <(TKey, TValue>)>)..::.Add Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback
Not supported, this dictionary is read only.

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void IDictionary<TKey, TValue>.Add(
    TKey key,
    TValue value
)
Visual Basic (Declaration)
Private Sub Add ( _
    key As TKey, _
    value As TValue _
) Implements IDictionary(Of TKey, TValue).Add
Visual C++
private:
virtual void Add(
    TKey key,
    TValue value
) sealed = IDictionary<TKey, TValue>::Add

Parameters

key
Type: TKey
the key of the property.
value
Type: TValue
the value of the property.

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Add(TKey, TValue)

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


ICollection(KeyValuePair(TKey, TValue)).Clear Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.ICollection<(Of <(KeyValuePair<(Of <(TKey, TValue>)>)>)>)..::.Clear Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#ICollection{T}#Clear"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void ICollection<KeyValuePair<TKey, TValue>>.Clear()
Visual Basic (Declaration)
Private Sub Clear Implements ICollection(Of KeyValuePair(Of TKey, TValue)).Clear
Visual C++
private:
virtual void Clear() sealed = ICollection<KeyValuePair<TKey, TValue>>::Clear

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


IEnumerable.GetEnumerator Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.IEnumerable..::.GetEnumerator Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback
Gets the enumerator for this dictionary.

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

the enumerator.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


ICollection(KeyValuePair(TKey, TValue)).Remove Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.ICollection<(Of <(KeyValuePair<(Of <(TKey, TValue>)>)>)>)..::.Remove Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#ICollection{T}#Remove(System.Collections.Generic.KeyValuePair{`0,`1})"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool ICollection<KeyValuePair<TKey, TValue>>.Remove(
    KeyValuePair<TKey, TValue> item
)
Visual Basic (Declaration)
Private Function Remove ( _
    item As KeyValuePair(Of TKey, TValue) _
) As Boolean Implements ICollection(Of KeyValuePair(Of TKey, TValue)).Remove
Visual C++
private:
virtual bool Remove(
    KeyValuePair<TKey, TValue> item
) sealed = ICollection<KeyValuePair<TKey, TValue>>::Remove

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair<(Of <( TKey, TValue >)>)

[Missing <param name="item"/> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#ICollection{T}#Remove(System.Collections.Generic.KeyValuePair{`0,`1})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#ICollection{T}#Remove(System.Collections.Generic.KeyValuePair{`0,`1})"]

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


IDictionary(TKey, TValue).Remove Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.IDictionary<(Of <(TKey, TValue>)>)..::.Remove Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback
Not supported, this dictionary is read only.

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IDictionary<TKey, TValue>.Remove(
    TKey key
)
Visual Basic (Declaration)
Private Function Remove ( _
    key As TKey _
) As Boolean Implements IDictionary(Of TKey, TValue).Remove
Visual C++
private:
virtual bool Remove(
    TKey key
) sealed = IDictionary<TKey, TValue>::Remove

Parameters

key
Type: TKey
the key of the property.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#IDictionary{TKey@TValue}#Remove(`0)"]

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Remove(TKey)

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


Contains Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.Contains Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback
Returns true if the property (key, value) exists in the dictionary.

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool Contains(
    KeyValuePair<TKey, TValue> item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As KeyValuePair(Of TKey, TValue) _
) As Boolean
Visual C++
public:
virtual bool Contains(
    KeyValuePair<TKey, TValue> item
) sealed

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair<(Of <( TKey, TValue >)>)
pair of key, value.

Return Value

True if the key exists in the dictionary, false otherwise.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


ContainsKey Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.ContainsKey Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback
Returns true if the key of a property exists in the dictionary.

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool ContainsKey(
    TKey key
)
Visual Basic (Declaration)
Public Function ContainsKey ( _
    key As TKey _
) As Boolean
Visual C++
public:
virtual bool ContainsKey(
    TKey key
) sealed

Parameters

key
Type: TKey
the key of the property.

Return Value

True if the key exists in the dictionary, false otherwise.

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.ContainsKey(TKey)

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


CopyTo Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.CopyTo Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback
Copies the element of the array into the dictionary at the specified index of the array.

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void CopyTo(
    KeyValuePair<TKey, TValue>[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As KeyValuePair(Of TKey, TValue)(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<KeyValuePair<TKey, TValue>>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array< System.Collections.Generic..::.KeyValuePair<(Of <( TKey, TValue >)>) >[]()[]
the source array.
arrayIndex
Type: System..::.Int32
the index of the source array.

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


GetEnumerator Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.GetEnumerator Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback
Gets the enumerator for this dictionary.

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnumerator<KeyValuePair<TKey, TValue>> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of TKey, TValue))
Visual C++
public:
virtual IEnumerator<KeyValuePair<TKey, TValue>>^ GetEnumerator() sealed

Return Value

the enumerator.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


TryGetValue Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.TryGetValue Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback
Gets the value associated with the specified key.

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool TryGetValue(
    TKey key,
    out TValue value
)
Visual Basic (Declaration)
Public Function TryGetValue ( _
    key As TKey, _
    <OutAttribute> ByRef value As TValue _
) As Boolean
Visual C++
public:
virtual bool TryGetValue(
    TKey key,
    [OutAttribute] TValue% value
) sealed

Parameters

key
Type: TKey
the key of the property.
value
Type: TValue %
the value of the property.

Return Value

True if the key exists in the dictionary, false otherwise.

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.TryGetValue(TKey, TValue%)

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


ReadOnlyDictionary(TKey, TValue) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Properties
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

The ReadOnlyDictionary<(Of <(TKey, TValue>)>) type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the dictionary.
IsReadOnly | Returns true, this dictionary is read only.
Item | Returns the value associated with the specified key.
Keys | Gets all the keys of the dictionary.
Values | Gets all the values of the dictionary.

Explicit Interface Implementations

Name | Description
IDictionary<(Of <(TKey, TValue>)>)..::.Item | Gets the value associated with the specified key.

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


IDictionary(TKey, TValue).Item Property

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.IDictionary<(Of <(TKey, TValue>)>)..::.Item Property
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback
Gets the value associated with the specified key.

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
TValue IDictionary<TKey, TValue>.Item[
    TKey key
] { get; set; }
Visual Basic (Declaration)
Private Property Item ( _
    key As TKey _
) As TValue Implements IDictionary(Of TKey, TValue).Item
Visual C++
private:
virtual property TValue Item[TKey key] {
    TValue get (TKey key) sealed = IDictionary<TKey, TValue>::Item::get;
    void set (TKey key, TValue value) sealed = IDictionary<TKey, TValue>::Item::set;
}

Parameters

key
Type: TKey

Return Value

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Item[([(TKey])])

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.Count Property
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback
Gets the number of elements in the dictionary.

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


IsReadOnly Property

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.IsReadOnly Property
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback
Returns true, this dictionary is read only.

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.Item Property
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback
Returns the value associated with the specified key.

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public TValue this[
    TKey key
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    key As TKey _
) As TValue
Visual C++
public:
property TValue default[TKey key] {
    TValue get (TKey key);
}

Parameters

key
Type: TKey
the key of the property.

Return Value

the value of the property.

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


Keys Property

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.Keys Property
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback
Gets all the keys of the dictionary.

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ICollection<TKey> Keys { get; }
Visual Basic (Declaration)
Public ReadOnly Property Keys As ICollection(Of TKey)
Visual C++
public:
virtual property ICollection<TKey>^ Keys {
    ICollection<TKey>^ get () sealed;
}

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Keys

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


Values Property

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.Values Property
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback
Gets all the values of the dictionary.

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ICollection<TValue> Values { get; }
Visual Basic (Declaration)
Public ReadOnly Property Values As ICollection(Of TValue)
Visual C++
public:
virtual property ICollection<TValue>^ Values {
    ICollection<TValue>^ get () sealed;
}

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Values

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


Genesyslab.Enterprise.Model.ComponentModel Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.ComponentModel Namespace
Send Feedback

Classes

Class | Description
BrokerManager<(Of <(T>)>) | A BrokerManager class.
DualBrokerManager<(Of <(T>)>) | A Dual Broker Manager class implementation.
Helper | Helper class for managing IMessage.
MessageFilterWrapper<(Of <(T>)>) |
PredicatableWrapper<(Of <(T, S>)>) | IPredicatable wrapper.
SubscribeableWrapper<(Of <(T, S>)>) | ISubscribeable wrapper.
SubscriptionServiceWrapper<(Of <(T>)>) |

Interfaces

Interface | Description
IAttributeService | Interface for getting and setting attributes.
IBrokerFilter | Interface for managing Message Broker filters.
IBrokerManager | Interface for managing publisher/subscriber pattern.
IBrokerManager<(Of <(T>)>) | Interface for managing publisher/subscriber pattern.
IBrokerPublisher | Interface for managing event publisher to subscribers.
IBrokerSubscriber | Interface for managing event subscription.
IBrokerSubscriber<(Of <(T>)>) | Interface for managing event subscription.
ICapability | Interface for managing capability.
ICategoryManager | Interface for managing the categories of data bag.
IContext | Interface for managing context of a party.
IController | Interface for managing state machine controller pattern.
IDataBag<(Of <(T>)>) | Interface for managing data set.
IDelegateSubscriber<(Of <(T>)>) | Interface for managing Broker subscriber.
IDynamicAttribute | Interface for managing dynamic attributes.
IFilter | Interface for managing Filter for Broker Message.
IPersistable<(Of <(T>)>) | Interface for managing the persistency of objects.
IPredicatable<(Of <(T>)>) | Interface defines contract for using a predicate
IPublishable<(Of <(T>)>) | Interface for publishing typed events to subscribers.
IRequest | Interface for managing request that are sent.
IRequestManager | Interface for managing requests.
IRole | Role interface.
IRoleable | Classes that want to play role should implement this Role based interface
IRoleManager<(Of <(T>)>) | Interface for managing the roles.
IServiceSubscriber | Obsolete.
IServiceSubscriber<(Of <(T>)>) | Interface defines subscriber contract for Publish/Subscribe pattern.
ISubscribeable<(Of <(T>)>) | Defines a subscriber contract for Publish/Subscribe pattern.
ITransformer<(Of <(TTarget, TSource>)>) | Objects transformer.

Enumerations

Enumeration | Description
ItemLocation | Enumerate for location of subscribers.
PartyType | Lists the possible party types.
StateType | Enumerate the state type of ICapability.
Visibility | Lists the possible values for the party's visibility.


BrokerManager(T) Class

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>) Class
Members See Also Send Feedback
A BrokerManager class.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public class BrokerManager<T> : IBrokerManager<T>,
    IServiceSubscriber<T>, IBrokerSubscriber<T>, IBrokerPublisher, IDisposable
Visual Basic (Declaration)
Public Class BrokerManager(Of T) _
    Implements IBrokerManager(Of T), IServiceSubscriber(Of T),  _
    IBrokerSubscriber(Of T), IBrokerPublisher, IDisposable
Visual C++
generic<typename T>
public ref class BrokerManager : IBrokerManager<T>,
    IServiceSubscriber<T>, IBrokerSubscriber<T>, IBrokerPublisher, IDisposable

Type Parameters

T
publisher/subscriber object.

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Model.ComponentModel..::.BrokerManager<(Of <(T>)>)

See Also

BrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerManager(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>) Members
BrokerManager<(Of <(T>)>) Class Constructors Methods Properties See Also Send Feedback

The BrokerManager<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
BrokerManager<(Of <(T>)>) | Overloaded.

Methods

Name | Description
Dispose | Disposes this instance.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetList | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Publish<(Of <(T>)>) | Publishes an object.
Register | Overloaded.
Subscriber | Gets the subscriber side of the broker.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unregister | Overloaded.

Properties

Name | Description
BrokerType | Gets the type of the broker.
Count | Gets the number of elements.
EventSubscription | Gets the service subscriber side of this broker.
Parent | Gets and sets the publisher/subscriber object.
SubscriptionBroker |

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerManager(T) Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>) Constructor
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
BrokerManager<(Of <(T>)>)(Object) | Creates an instance.
BrokerManager<(Of <(T>)>)(Object, Type) | Creates an instance.

See Also

BrokerManager<(Of <(T>)>) Class
BrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerManager(T) Constructor (Object)

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>) Constructor (Object)
BrokerManager<(Of <(T>)>) Class See Also Send Feedback
Creates an instance.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public BrokerManager(
    Object instance
)
Visual Basic (Declaration)
Public Sub New ( _
    instance As Object _
)
Visual C++
public:
BrokerManager(
    Object^ instance
)

Parameters

instance
Type: System..::.Object
the publisher/subscriber object.

See Also

BrokerManager<(Of <(T>)>) Class
BrokerManager<(Of <(T>)>) Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerManager(T) Constructor (Object, Type)

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>) Constructor (Object, Type)
BrokerManager<(Of <(T>)>) Class See Also Send Feedback
Creates an instance.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public BrokerManager(
    Object instance,
    Type brokerType
)
Visual Basic (Declaration)
Public Sub New ( _
    instance As Object, _
    brokerType As Type _
)
Visual C++
public:
BrokerManager(
    Object^ instance,
    Type^ brokerType
)

Parameters

instance
Type: System..::.Object
the publisher/subscriber object.
brokerType
Type: System..::.Type
the type of broker.

See Also

BrokerManager<(Of <(T>)>) Class
BrokerManager<(Of <(T>)>) Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerManager(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>) Methods
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

The BrokerManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Dispose | Disposes this instance.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetList | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Publish<(Of <(T>)>) | Publishes an object.
Register | Overloaded.
Subscriber | Gets the subscriber side of the broker.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unregister | Overloaded.

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Dispose Method

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Dispose Method
BrokerManager<(Of <(T>)>) Class See Also Send Feedback
Disposes this instance.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.GetList Method
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the collection.
GetList(Type, ItemLocation) | Gets the collection.

See Also

BrokerManager<(Of <(T>)>) Class
BrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList(U) Method (ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.GetList<(Of <(U>)>) Method (ItemLocation)
BrokerManager<(Of <(T>)>) Class See Also Send Feedback
Gets the collection.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnumerable<U> GetList<U>(
    ItemLocation flag
)
Visual Basic (Declaration)
Public Function GetList(Of U) ( _
    flag As ItemLocation _
) As IEnumerable(Of U)
Visual C++
public:
generic<typename U>
virtual IEnumerable<U>^ GetList(
    ItemLocation flag
) sealed

Parameters

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
item location flag.

Type Parameters

U
object type.

Return Value

The collection as enumerable.

See Also

BrokerManager<(Of <(T>)>) Class
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method (Type, ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.GetList Method (Type, ItemLocation)
BrokerManager<(Of <(T>)>) Class See Also Send Feedback
Gets the collection.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnumerable GetList(
    Type targetObject,
    ItemLocation flag
)
Visual Basic (Declaration)
Public Function GetList ( _
    targetObject As Type, _
    flag As ItemLocation _
) As IEnumerable
Visual C++
public:
virtual IEnumerable^ GetList(
    Type^ targetObject,
    ItemLocation flag
) sealed

Parameters

targetObject
Type: System..::.Type
the object type.
flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
item location flag.

Return Value

The collection as enumerable.

Implements

IBrokerManager<(Of <(T>)>)..::.GetList(Type, ItemLocation)
IBrokerSubscriber<(Of <(T>)>)..::.GetList(Type, ItemLocation)

See Also

BrokerManager<(Of <(T>)>) Class
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Publish(T) Method

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Publish<(Of <(T>)>) Method
BrokerManager<(Of <(T>)>) Class See Also Send Feedback
Publishes an object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IBrokerPublisher Publish<T>(
    T obj
)
Visual Basic (Declaration)
Public Function Publish(Of T) ( _
    obj As T _
) As IBrokerPublisher
Visual C++
public:
generic<typename T>
virtual IBrokerPublisher^ Publish(
    T obj
) sealed

Parameters

obj
Type: T
the object to publish.

Type Parameters

T
the type of object.

Return Value

IBrokerPublisher

Implements

IBrokerPublisher..::.Publish<(Of <(T>)>)(T)

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Register Method
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Register(ISubscribeable<(Of <(T>)>)) | Registers a subscriber.
Register(Action<(Of <(T>)>)) | Registers Action.
Register(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>)) | Register the action and the filter associated with this broker.

See Also

BrokerManager<(Of <(T>)>) Class
BrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Register Method (ISubscribeable<(Of <(T>)>))
BrokerManager<(Of <(T>)>) Class See Also Send Feedback
Registers a subscriber.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Register(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Public Sub Register ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
public:
virtual void Register(
    ISubscribeable<T>^ subscriber
) sealed

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( T >)>)
a subscribeable object.

Implements

IServiceSubscriber<(Of <(T>)>)..::.Register(ISubscribeable<(Of <(T>)>))

See Also

BrokerManager<(Of <(T>)>) Class
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Register Method (Action<(Of <(T>)>))
BrokerManager<(Of <(T>)>) Class See Also Send Feedback
Registers Action.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Register(
    Action<T> handler
)
Visual Basic (Declaration)
Public Sub Register ( _
    handler As Action(Of T) _
)
Visual C++
public:
virtual void Register(
    Action<T>^ handler
) sealed

Parameters

handler
Type: System..::.Action<(Of <( T >)>)
the action handler.

Implements

IServiceSubscriber<(Of <(T>)>)..::.Register(Action<(Of <(T>)>))

See Also

BrokerManager<(Of <(T>)>) Class
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (Action(T), IPredicatable(T))

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Register Method (Action<(Of <(T>)>), IPredicatable<(Of <(T>)>))
BrokerManager<(Of <(T>)>) Class See Also Send Feedback
Register the action and the filter associated with this broker.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Register(
    Action<T> handler,
    IPredicatable<T> filter
)
Visual Basic (Declaration)
Public Sub Register ( _
    handler As Action(Of T), _
    filter As IPredicatable(Of T) _
)
Visual C++
public:
virtual void Register(
    Action<T>^ handler,
    IPredicatable<T>^ filter
) sealed

Parameters

handler
Type: System..::.Action<(Of <( T >)>)
the action handler.
filter
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IPredicatable <(Of <( T >)>)
the filter.

Implements

IServiceSubscriber<(Of <(T>)>)..::.Register(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>))

See Also

BrokerManager<(Of <(T>)>) Class
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Subscriber Method

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Subscriber Method
BrokerManager<(Of <(T>)>) Class See Also Send Feedback
Gets the subscriber side of the broker.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IServiceSubscriber<T> Subscriber()
Visual Basic (Declaration)
Public Function Subscriber As IServiceSubscriber(Of T)
Visual C++
public:
virtual IServiceSubscriber<T>^ Subscriber() sealed

Return Value

a Service Subscriber.

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Unregister Method
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Unregister(ISubscribeable<(Of <(T>)>)) | Unregisters the subscribeable object.
Unregister(Action<(Of <(T>)>)) | Unregisters the action handler.

See Also

BrokerManager<(Of <(T>)>) Class
BrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Unregister Method (ISubscribeable<(Of <(T>)>))
BrokerManager<(Of <(T>)>) Class See Also Send Feedback
Unregisters the subscribeable object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Unregister(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Public Sub Unregister ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
public:
virtual void Unregister(
    ISubscribeable<T>^ subscriber
) sealed

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( T >)>)
the subscribeable object.

Implements

IServiceSubscriber<(Of <(T>)>)..::.Unregister(ISubscribeable<(Of <(T>)>))

See Also

BrokerManager<(Of <(T>)>) Class
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Unregister Method (Action<(Of <(T>)>))
BrokerManager<(Of <(T>)>) Class See Also Send Feedback
Unregisters the action handler.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Unregister(
    Action<T> handler
)
Visual Basic (Declaration)
Public Sub Unregister ( _
    handler As Action(Of T) _
)
Visual C++
public:
virtual void Unregister(
    Action<T>^ handler
) sealed

Parameters

handler
Type: System..::.Action<(Of <( T >)>)
the action handler.

Implements

IServiceSubscriber<(Of <(T>)>)..::.Unregister(Action<(Of <(T>)>))

See Also

BrokerManager<(Of <(T>)>) Class
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerManager(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>) Properties
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

The BrokerManager<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
BrokerType | Gets the type of the broker.
Count | Gets the number of elements.
EventSubscription | Gets the service subscriber side of this broker.
Parent | Gets and sets the publisher/subscriber object.
SubscriptionBroker |

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerType Property

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.BrokerType Property
BrokerManager<(Of <(T>)>) Class See Also Send Feedback
Gets the type of the broker.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Type BrokerType { get; }
Visual Basic (Declaration)
Public ReadOnly Property BrokerType As Type
Visual C++
public:
virtual property Type^ BrokerType {
    Type^ get () sealed;
}

Implements

IBrokerManager<(Of <(T>)>)..::.BrokerType

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Count Property
BrokerManager<(Of <(T>)>) Class See Also Send Feedback
Gets the number of elements.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IBrokerManager<(Of <(T>)>)..::.Count
IBrokerSubscriber<(Of <(T>)>)..::.Count

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


EventSubscription Property

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.EventSubscription Property
BrokerManager<(Of <(T>)>) Class See Also Send Feedback
Gets the service subscriber side of this broker.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IServiceSubscriber<T> EventSubscription { get; }
Visual Basic (Declaration)
Public ReadOnly Property EventSubscription As IServiceSubscriber(Of T)
Visual C++
public:
virtual property IServiceSubscriber<T>^ EventSubscription {
    IServiceSubscriber<T>^ get () sealed;
}

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Parent Property

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Parent Property
BrokerManager<(Of <(T>)>) Class See Also Send Feedback
Gets and sets the publisher/subscriber object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Object Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As Object
Visual C++
public:
virtual property Object^ Parent {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Implements

IBrokerManager<(Of <(T>)>)..::.Parent

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscriptionBroker Property

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.SubscriptionBroker Property
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.SubscriptionBroker"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ISubscriptionService SubscriptionBroker { get; }
Visual Basic (Declaration)
Public ReadOnly Property SubscriptionBroker As ISubscriptionService
Visual C++
public:
virtual property ISubscriptionService^ SubscriptionBroker {
    ISubscriptionService^ get () sealed;
}

Implements

IServiceSubscriber<(Of <(T>)>)..::.SubscriptionBroker

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


DualBrokerManager(T) Class

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>) Class
Members See Also Send Feedback
A Dual Broker Manager class implementation.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public class DualBrokerManager<T> : IBrokerManager<T>,
    IServiceSubscriber<T>, IBrokerSubscriber<T>, IBrokerPublisher, IDisposable
Visual Basic (Declaration)
Public Class DualBrokerManager(Of T) _
    Implements IBrokerManager(Of T), IServiceSubscriber(Of T),  _
    IBrokerSubscriber(Of T), IBrokerPublisher, IDisposable
Visual C++
generic<typename T>
public ref class DualBrokerManager : IBrokerManager<T>,
    IServiceSubscriber<T>, IBrokerSubscriber<T>, IBrokerPublisher, IDisposable

Type Parameters

T
publisher/subscriber object.

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Model.ComponentModel..::.DualBrokerManager<(Of <(T>)>)

See Also

DualBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


DualBrokerManager(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>) Members
DualBrokerManager<(Of <(T>)>) Class Constructors Methods Properties See Also Send Feedback

The DualBrokerManager<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
DualBrokerManager<(Of <(T>)>) | Overloaded.

Methods

Name | Description
Dispose | Disposes this instance.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetList | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Publish<(Of <(T>)>) | Publishes an object.
Register | Overloaded.
Subscriber | Gets the subscriber side of the broker.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unregister | Overloaded.

Properties

Name | Description
BrokerType | Gets the type of the broker.
Count | Gets the number of elements.
EventSubscription | Gets the service subscriber side of this broker.
Parent | Gets and sets the publisher/subscriber object.
SubscriptionBroker |

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


DualBrokerManager(T) Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>) Constructor
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
DualBrokerManager<(Of <(T>)>)(Object) | Creates a DualBrokerManager instance.
DualBrokerManager<(Of <(T>)>)(Object, Type) | Creates a DualBrokerManager instance.

See Also

DualBrokerManager<(Of <(T>)>) Class
DualBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


DualBrokerManager(T) Constructor (Object)

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>) Constructor (Object)
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback
Creates a DualBrokerManager instance.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public DualBrokerManager(
    Object instance
)
Visual Basic (Declaration)
Public Sub New ( _
    instance As Object _
)
Visual C++
public:
DualBrokerManager(
    Object^ instance
)

Parameters

instance
Type: System..::.Object
the publisher/subscriber object.

See Also

DualBrokerManager<(Of <(T>)>) Class
DualBrokerManager<(Of <(T>)>) Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


DualBrokerManager(T) Constructor (Object, Type)

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>) Constructor (Object, Type)
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback
Creates a DualBrokerManager instance.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public DualBrokerManager(
    Object instance,
    Type brokerType
)
Visual Basic (Declaration)
Public Sub New ( _
    instance As Object, _
    brokerType As Type _
)
Visual C++
public:
DualBrokerManager(
    Object^ instance,
    Type^ brokerType
)

Parameters

instance
Type: System..::.Object
the publisher/subscriber object.
brokerType
Type: System..::.Type
the broker type.

See Also

DualBrokerManager<(Of <(T>)>) Class
DualBrokerManager<(Of <(T>)>) Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


DualBrokerManager(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>) Methods
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

The DualBrokerManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Dispose | Disposes this instance.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetList | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Publish<(Of <(T>)>) | Publishes an object.
Register | Overloaded.
Subscriber | Gets the subscriber side of the broker.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unregister | Overloaded.

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Dispose Method

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Dispose Method
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback
Disposes this instance.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.GetList Method
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the collection.
GetList(Type, ItemLocation) | Gets the collection.

See Also

DualBrokerManager<(Of <(T>)>) Class
DualBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList(U) Method (ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.GetList<(Of <(U>)>) Method (ItemLocation)
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback
Gets the collection.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnumerable<U> GetList<U>(
    ItemLocation flag
)
Visual Basic (Declaration)
Public Function GetList(Of U) ( _
    flag As ItemLocation _
) As IEnumerable(Of U)
Visual C++
public:
generic<typename U>
virtual IEnumerable<U>^ GetList(
    ItemLocation flag
) sealed

Parameters

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
item location flag.

Type Parameters

U
object type.

Return Value

The collection as enumerable.

See Also

DualBrokerManager<(Of <(T>)>) Class
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method (Type, ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.GetList Method (Type, ItemLocation)
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback
Gets the collection.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnumerable GetList(
    Type targetObject,
    ItemLocation flag
)
Visual Basic (Declaration)
Public Function GetList ( _
    targetObject As Type, _
    flag As ItemLocation _
) As IEnumerable
Visual C++
public:
virtual IEnumerable^ GetList(
    Type^ targetObject,
    ItemLocation flag
) sealed

Parameters

targetObject
Type: System..::.Type
the object type.
flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
item location flag.

Return Value

The collection as enumerable.

Implements

IBrokerManager<(Of <(T>)>)..::.GetList(Type, ItemLocation)
IBrokerSubscriber<(Of <(T>)>)..::.GetList(Type, ItemLocation)

See Also

DualBrokerManager<(Of <(T>)>) Class
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Publish(T) Method

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Publish<(Of <(T>)>) Method
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback
Publishes an object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IBrokerPublisher Publish<T>(
    T obj
)
Visual Basic (Declaration)
Public Function Publish(Of T) ( _
    obj As T _
) As IBrokerPublisher
Visual C++
public:
generic<typename T>
virtual IBrokerPublisher^ Publish(
    T obj
) sealed

Parameters

obj
Type: T
the object to publish.

Type Parameters

T
the type of object.

Return Value

IBrokerPublisher

Implements

IBrokerPublisher..::.Publish<(Of <(T>)>)(T)

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method

[image] [image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Register Method
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Register(ISubscribeable<(Of <(T>)>)) | Registers a subscriber.
Register(Action<(Of <(T>)>)) | Registers Action.
Register(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>)) | Register the action and the filter associated with this broker.

See Also

DualBrokerManager<(Of <(T>)>) Class
DualBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Register Method (ISubscribeable<(Of <(T>)>))
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback
Registers a subscriber.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Register(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Public Sub Register ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
public:
virtual void Register(
    ISubscribeable<T>^ subscriber
) sealed

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( T >)>)
a subscribeable object.

Implements

IServiceSubscriber<(Of <(T>)>)..::.Register(ISubscribeable<(Of <(T>)>))

See Also

DualBrokerManager<(Of <(T>)>) Class
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Register Method (Action<(Of <(T>)>))
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback
Registers Action.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Register(
    Action<T> handler
)
Visual Basic (Declaration)
Public Sub Register ( _
    handler As Action(Of T) _
)
Visual C++
public:
virtual void Register(
    Action<T>^ handler
) sealed

Parameters

handler
Type: System..::.Action<(Of <( T >)>)
the action handler.

Implements

IServiceSubscriber<(Of <(T>)>)..::.Register(Action<(Of <(T>)>))

See Also

DualBrokerManager<(Of <(T>)>) Class
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (Action(T), IPredicatable(T))

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Register Method (Action<(Of <(T>)>), IPredicatable<(Of <(T>)>))
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback
Register the action and the filter associated with this broker.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Register(
    Action<T> handler,
    IPredicatable<T> filter
)
Visual Basic (Declaration)
Public Sub Register ( _
    handler As Action(Of T), _
    filter As IPredicatable(Of T) _
)
Visual C++
public:
virtual void Register(
    Action<T>^ handler,
    IPredicatable<T>^ filter
) sealed

Parameters

handler
Type: System..::.Action<(Of <( T >)>)
the action handler.
filter
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IPredicatable <(Of <( T >)>)
the filter.

Implements

IServiceSubscriber<(Of <(T>)>)..::.Register(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>))

See Also

DualBrokerManager<(Of <(T>)>) Class
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Subscriber Method

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Subscriber Method
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback
Gets the subscriber side of the broker.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IServiceSubscriber<T> Subscriber()
Visual Basic (Declaration)
Public Function Subscriber As IServiceSubscriber(Of T)
Visual C++
public:
virtual IServiceSubscriber<T>^ Subscriber() sealed

Return Value

a Service Subscriber.

Implements

IBrokerManager<(Of <(T>)>)..::.Subscriber()()()

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method

[image] [image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Unregister Method
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Unregister(ISubscribeable<(Of <(T>)>)) | Unregisters the subscribeable object.
Unregister(Action<(Of <(T>)>)) | Unregisters the action handler.

See Also

DualBrokerManager<(Of <(T>)>) Class
DualBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Unregister Method (ISubscribeable<(Of <(T>)>))
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback
Unregisters the subscribeable object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Unregister(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Public Sub Unregister ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
public:
virtual void Unregister(
    ISubscribeable<T>^ subscriber
) sealed

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( T >)>)
the subscribeable object.

Implements

IServiceSubscriber<(Of <(T>)>)..::.Unregister(ISubscribeable<(Of <(T>)>))

See Also

DualBrokerManager<(Of <(T>)>) Class
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Unregister Method (Action<(Of <(T>)>))
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback
Unregisters the action handler.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Unregister(
    Action<T> handler
)
Visual Basic (Declaration)
Public Sub Unregister ( _
    handler As Action(Of T) _
)
Visual C++
public:
virtual void Unregister(
    Action<T>^ handler
) sealed

Parameters

handler
Type: System..::.Action<(Of <( T >)>)
the action handler.

Implements

IServiceSubscriber<(Of <(T>)>)..::.Unregister(Action<(Of <(T>)>))

See Also

DualBrokerManager<(Of <(T>)>) Class
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


DualBrokerManager(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>) Properties
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

The DualBrokerManager<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
BrokerType | Gets the type of the broker.
Count | Gets the number of elements.
EventSubscription | Gets the service subscriber side of this broker.
Parent | Gets and sets the publisher/subscriber object.
SubscriptionBroker |

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerType Property

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.BrokerType Property
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback
Gets the type of the broker.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Type BrokerType { get; }
Visual Basic (Declaration)
Public ReadOnly Property BrokerType As Type
Visual C++
public:
virtual property Type^ BrokerType {
    Type^ get () sealed;
}

Implements

IBrokerManager<(Of <(T>)>)..::.BrokerType

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Count Property
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback
Gets the number of elements.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IBrokerManager<(Of <(T>)>)..::.Count
IBrokerSubscriber<(Of <(T>)>)..::.Count

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


EventSubscription Property

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.EventSubscription Property
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback
Gets the service subscriber side of this broker.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IServiceSubscriber<T> EventSubscription { get; }
Visual Basic (Declaration)
Public ReadOnly Property EventSubscription As IServiceSubscriber(Of T)
Visual C++
public:
virtual property IServiceSubscriber<T>^ EventSubscription {
    IServiceSubscriber<T>^ get () sealed;
}

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Parent Property

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Parent Property
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback
Gets and sets the publisher/subscriber object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Object Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As Object
Visual C++
public:
virtual property Object^ Parent {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Implements

IBrokerManager<(Of <(T>)>)..::.Parent

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscriptionBroker Property

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.SubscriptionBroker Property
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.SubscriptionBroker"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ISubscriptionService SubscriptionBroker { get; }
Visual Basic (Declaration)
Public ReadOnly Property SubscriptionBroker As ISubscriptionService
Visual C++
public:
virtual property ISubscriptionService^ SubscriptionBroker {
    ISubscriptionService^ get () sealed;
}

Implements

IServiceSubscriber<(Of <(T>)>)..::.SubscriptionBroker

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Helper Class

[image]

Enterprise SDK 8.0 Reference API
Helper Class
Members See Also Send Feedback
Helper class for managing IMessage.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static class Helper
Visual Basic (Declaration)
Public NotInheritable Class Helper
Visual C++
public ref class Helper abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Model.ComponentModel..::.Helper

See Also

Helper Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Helper Members

[image] [image]

Enterprise SDK 8.0 Reference API
Helper Members
Helper Class Methods See Also Send Feedback

The Helper type exposes the following members.

Methods

Name | Description
GetFilterCollection<(Of <(T>)>) | Return elements as a collection of a specific type from a dictionary.
GetPropertyAsIntValue | Gets property from IMessage as integer.
GetPropertyAsLongValue | Gets property from IMessage as long.
GetPropertyAsObject | Gets property from IMessage as Object.
GetPropertyAsString | Gets property from IMessage as String.
GetReferenceId | Gets the reference ID of the message.
IsNameSpaceInternal | Check if a specific namespace and a given object are part of the same namespace We DO assume here that the namespace is at least two levels deep Eg. LeveL0.Level1. ... If not, we return always FALSE.
SetInfo | Adds in a IMessage request, a KeyValueCollection at key value.

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Helper Methods

[image] [image]

Enterprise SDK 8.0 Reference API
Helper Methods
Helper Class See Also Send Feedback

The Helper type exposes the following members.

Methods

Name | Description
GetFilterCollection<(Of <(T>)>) | Return elements as a collection of a specific type from a dictionary.
GetPropertyAsIntValue | Gets property from IMessage as integer.
GetPropertyAsLongValue | Gets property from IMessage as long.
GetPropertyAsObject | Gets property from IMessage as Object.
GetPropertyAsString | Gets property from IMessage as String.
GetReferenceId | Gets the reference ID of the message.
IsNameSpaceInternal | Check if a specific namespace and a given object are part of the same namespace We DO assume here that the namespace is at least two levels deep Eg. LeveL0.Level1. ... If not, we return always FALSE.
SetInfo | Adds in a IMessage request, a KeyValueCollection at key value.

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetFilterCollection(T) Method

[image]

Enterprise SDK 8.0 Reference API
Helper..::.GetFilterCollection<(Of <(T>)>) Method
Helper Class See Also Send Feedback
Return elements as a collection of a specific type from a dictionary.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static ICollection<T> GetFilterCollection<T>(
    IDictionary<Type, Object> list
)
Visual Basic (Declaration)
Public Shared Function GetFilterCollection(Of T) ( _
    list As IDictionary(Of Type, Object) _
) As ICollection(Of T)
Visual C++
public:
generic<typename T>
static ICollection<T>^ GetFilterCollection(
    IDictionary<Type^, Object^>^ list
)

Parameters

list
Type: System.Collections.Generic..::.IDictionary<(Of <(Type, Object>)>)
list of filter type.

Type Parameters

T
The type of the object in the collection.

Return Value

Collection of the specific type.

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetPropertyAsIntValue Method

[image]

Enterprise SDK 8.0 Reference API
Helper..::.GetPropertyAsIntValue Method
Helper Class See Also Send Feedback
Gets property from IMessage as integer.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static int GetPropertyAsIntValue(
    string attribute,
    IMessage msg
)
Visual Basic (Declaration)
Public Shared Function GetPropertyAsIntValue ( _
    attribute As String, _
    msg As IMessage _
) As Integer
Visual C++
public:
static int GetPropertyAsIntValue(
    String^ attribute,
    IMessage^ msg
)

Parameters

attribute
Type: System..::.String
the attribute.
msg
Type: IMessage
the message.

Return Value

the int value of the attribute.

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetPropertyAsLongValue Method

[image]

Enterprise SDK 8.0 Reference API
Helper..::.GetPropertyAsLongValue Method
Helper Class See Also Send Feedback
Gets property from IMessage as long.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static long GetPropertyAsLongValue(
    string attribute,
    IMessage msg
)
Visual Basic (Declaration)
Public Shared Function GetPropertyAsLongValue ( _
    attribute As String, _
    msg As IMessage _
) As Long
Visual C++
public:
static long long GetPropertyAsLongValue(
    String^ attribute,
    IMessage^ msg
)

Parameters

attribute
Type: System..::.String
the attribute.
msg
Type: IMessage
the message.

Return Value

the long value of the attribute.

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetPropertyAsObject Method

[image]

Enterprise SDK 8.0 Reference API
Helper..::.GetPropertyAsObject Method
Helper Class See Also Send Feedback
Gets property from IMessage as Object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static Object GetPropertyAsObject(
    string attribute,
    IMessage msg
)
Visual Basic (Declaration)
Public Shared Function GetPropertyAsObject ( _
    attribute As String, _
    msg As IMessage _
) As Object
Visual C++
public:
static Object^ GetPropertyAsObject(
    String^ attribute,
    IMessage^ msg
)

Parameters

attribute
Type: System..::.String
the attribute.
msg
Type: IMessage
the message.

Return Value

the object value of the attribute.

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetPropertyAsString Method

[image]

Enterprise SDK 8.0 Reference API
Helper..::.GetPropertyAsString Method
Helper Class See Also Send Feedback
Gets property from IMessage as String.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static string GetPropertyAsString(
    string attribute,
    IMessage msg
)
Visual Basic (Declaration)
Public Shared Function GetPropertyAsString ( _
    attribute As String, _
    msg As IMessage _
) As String
Visual C++
public:
static String^ GetPropertyAsString(
    String^ attribute,
    IMessage^ msg
)

Parameters

attribute
Type: System..::.String
the attribute.
msg
Type: IMessage
the message.

Return Value

the string value of the attribute.

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetReferenceId Method

[image]

Enterprise SDK 8.0 Reference API
Helper..::.GetReferenceId Method
Helper Class See Also Send Feedback
Gets the reference ID of the message.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static int GetReferenceId(
    IMessage msg
)
Visual Basic (Declaration)
Public Shared Function GetReferenceId ( _
    msg As IMessage _
) As Integer
Visual C++
public:
static int GetReferenceId(
    IMessage^ msg
)

Parameters

msg
Type: IMessage
the message.

Return Value

the reference ID.

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


IsNameSpaceInternal Method

[image]

Enterprise SDK 8.0 Reference API
Helper..::.IsNameSpaceInternal Method
Helper Class See Also Send Feedback
Check if a specific namespace and a given object are part of the same namespace We DO assume here that the namespace is at least two levels deep Eg. LeveL0.Level1. ... If not, we return always FALSE.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static bool IsNameSpaceInternal(
    string targetNamespace,
    Object data
)
Visual Basic (Declaration)
Public Shared Function IsNameSpaceInternal ( _
    targetNamespace As String, _
    data As Object _
) As Boolean
Visual C++
public:
static bool IsNameSpaceInternal(
    String^ targetNamespace,
    Object^ data
)

Parameters

targetNamespace
Type: System..::.String
string
data
Type: System..::.Object
object

Return Value

true if the namespace and the object namespace are the same.

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


SetInfo Method

[image]

Enterprise SDK 8.0 Reference API
Helper..::.SetInfo Method
Helper Class See Also Send Feedback
Adds in a IMessage request, a KeyValueCollection at key value.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static IMessage SetInfo(
    IMessage request,
    string key,
    IDictionary info
)
Visual Basic (Declaration)
Public Shared Function SetInfo ( _
    request As IMessage, _
    key As String, _
    info As IDictionary _
) As IMessage
Visual C++
public:
static IMessage^ SetInfo(
    IMessage^ request,
    String^ key,
    IDictionary^ info
)

Parameters

request
Type: IMessage
the IMessage request
key
Type: System..::.String
the key index
info
Type: System.Collections..::.IDictionary
the dictionary to be changed into KeyValueCollection for the key

Return Value

the IMessage.

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


IAttributeService Interface

[image]

Enterprise SDK 8.0 Reference API
IAttributeService Interface
Members See Also Send Feedback
Interface for getting and setting attributes.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IAttributeService
Visual Basic (Declaration)
Public Interface IAttributeService
Visual C++
public interface class IAttributeService

See Also

IAttributeService Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IAttributeService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeService Members
IAttributeService Interface Methods See Also Send Feedback

The IAttributeService type exposes the following members.

Methods

Name | Description
GetAttributes | Gets Attributes.
SetAttributes | Overloaded.

See Also

IAttributeService Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IAttributeService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeService Methods
IAttributeService Interface See Also Send Feedback

The IAttributeService type exposes the following members.

Methods

Name | Description
GetAttributes | Gets Attributes.
SetAttributes | Overloaded.

See Also

IAttributeService Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetAttributes Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeService..::.GetAttributes Method
IAttributeService Interface See Also Send Feedback
Gets Attributes.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionary<string, IDynamicAttribute> GetAttributes(
    string name
)
Visual Basic (Declaration)
Function GetAttributes ( _
    name As String _
) As IDictionary(Of String, IDynamicAttribute)
Visual C++
IDictionary<String^, IDynamicAttribute^>^ GetAttributes(
    String^ name
)

Parameters

name
Type: System..::.String
the key of the attributes.

Return Value

the dictionary of attributes.

See Also

IAttributeService Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


SetAttributes Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeService..::.SetAttributes Method
IAttributeService Interface See Also Send Feedback

Overload List

Name | Description
SetAttributes(String, IDynamicAttribute) | Sets attributes from another IDynamicAttribute instance.
SetAttributes(String, IDictionary<(Of <(String, IDynamicAttribute>)>)) | Sets attributes from a dictionary instance.

See Also

IAttributeService Interface
IAttributeService Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


SetAttributes Method (String, IDynamicAttribute)

[image]

Enterprise SDK 8.0 Reference API
IAttributeService..::.SetAttributes Method (String, IDynamicAttribute)
IAttributeService Interface See Also Send Feedback
Sets attributes from another IDynamicAttribute instance.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAttributeService SetAttributes(
    string name,
    IDynamicAttribute attribute
)
Visual Basic (Declaration)
Function SetAttributes ( _
    name As String, _
    attribute As IDynamicAttribute _
) As IAttributeService
Visual C++
IAttributeService^ SetAttributes(
    String^ name,
    IDynamicAttribute^ attribute
)

Parameters

name
Type: System..::.String
the key of the dynamic attribute.
attribute
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IDynamicAttribute
the dynamic attribute value.

Return Value

IAttributeService.

See Also

IAttributeService Interface
SetAttributes Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


SetAttributes Method (String, IDictionary(String, IDynamicAttribute))

[image]

Enterprise SDK 8.0 Reference API
IAttributeService..::.SetAttributes Method (String, IDictionary<(Of <(String, IDynamicAttribute>)>))
IAttributeService Interface See Also Send Feedback
Sets attributes from a dictionary instance.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAttributeService SetAttributes(
    string name,
    IDictionary<string, IDynamicAttribute> attributes
)
Visual Basic (Declaration)
Function SetAttributes ( _
    name As String, _
    attributes As IDictionary(Of String, IDynamicAttribute) _
) As IAttributeService
Visual C++
IAttributeService^ SetAttributes(
    String^ name,
    IDictionary<String^, IDynamicAttribute^>^ attributes
)

Parameters

name
Type: System..::.String
the key of the attributes.
attributes
Type: System.Collections.Generic..::.IDictionary<(Of <(String, IDynamicAttribute >)>)
the dictionary of attributes values.

Return Value

IAttributeService.

See Also

IAttributeService Interface
SetAttributes Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerFilter Interface

[image]

Enterprise SDK 8.0 Reference API
IBrokerFilter Interface
Members See Also Send Feedback
Interface for managing Message Broker filters.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IBrokerFilter
Visual Basic (Declaration)
Public Interface IBrokerFilter
Visual C++
public interface class IBrokerFilter

See Also

IBrokerFilter Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerFilter Members

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerFilter Members
IBrokerFilter Interface Methods See Also Send Feedback

The IBrokerFilter type exposes the following members.

Methods

Name | Description
Filters<(Of <(T>)>) | Gets the Collection of Message Broker Filters.

See Also

IBrokerFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerFilter Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerFilter Methods
IBrokerFilter Interface See Also Send Feedback

The IBrokerFilter type exposes the following members.

Methods

Name | Description
Filters<(Of <(T>)>) | Gets the Collection of Message Broker Filters.

See Also

IBrokerFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Filters(T) Method

[image]

Enterprise SDK 8.0 Reference API
IBrokerFilter..::.Filters<(Of <(T>)>) Method
IBrokerFilter Interface See Also Send Feedback
Gets the Collection of Message Broker Filters.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ICollection<T> Filters<T>()
Visual Basic (Declaration)
Function Filters(Of T) As ICollection(Of T)
Visual C++
generic<typename T>
ICollection<T>^ Filters()

Type Parameters

T
the object type to filter.

Return Value

the filter collection for the object type.

See Also

IBrokerFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager Interface

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager Interface
Members See Also Send Feedback
Interface for managing publisher/subscriber pattern.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IBrokerManager : IServiceSubscriber,
    IBrokerSubscriber, IBrokerPublisher, IDisposable
Visual Basic (Declaration)
Public Interface IBrokerManager _
    Implements IServiceSubscriber, IBrokerSubscriber, IBrokerPublisher, IDisposable
Visual C++
public interface class IBrokerManager : IServiceSubscriber,
    IBrokerSubscriber, IBrokerPublisher, IDisposable

See Also

IBrokerManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager Members
IBrokerManager Interface Methods Properties See Also Send Feedback

The IBrokerManager type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetList | Overloaded.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
Register | Overloaded.
Subscriber<(Of <(T>)>) | Gets the subscription service.
Unregister | Overloaded.

Properties

Name | Description
BrokerType | Gets the type of broker.
Count | Overloaded.
EventSubscription | Gets the subscriber object. (Inherited from IBrokerSubscriber.)
Parent | Gets and sets the parent of the Broker Manager.

See Also

IBrokerManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager Methods
IBrokerManager Interface See Also Send Feedback

The IBrokerManager type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetList | Overloaded.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
Register | Overloaded.
Subscriber<(Of <(T>)>) | Gets the subscription service.
Unregister | Overloaded.

See Also

IBrokerManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.GetList Method
IBrokerManager Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(T>)>)(ItemLocation) | Gets the list of subscribers according to location flag.
GetList<(Of <(T>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber.)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag.
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber.)

See Also

IBrokerManager Interface
IBrokerManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList(T) Method (ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.GetList<(Of <(T>)>) Method (ItemLocation)
IBrokerManager Interface See Also Send Feedback
Gets the list of subscribers according to location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnumerable<T> GetList<T>(
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList(Of T) ( _
    flag As ItemLocation _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ GetList(
    ItemLocation flag
)

Parameters

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
the item location flag.

Type Parameters

T
the subscriber type.

Return Value

the enumeration.

See Also

IBrokerManager Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method (Type, ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.GetList Method (Type, ItemLocation)
IBrokerManager Interface See Also Send Feedback
Gets the list of subscribers according to target and location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnumerable GetList(
    Type targetObject,
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList ( _
    targetObject As Type, _
    flag As ItemLocation _
) As IEnumerable
Visual C++
IEnumerable^ GetList(
    Type^ targetObject,
    ItemLocation flag
)

Parameters

targetObject
Type: System..::.Type
the subscriber type.
flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
the item location flag.

Return Value

the enumeration.

Implements

IBrokerSubscriber..::.GetList(Type, ItemLocation)

See Also

IBrokerManager Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.Register Method
IBrokerManager Interface See Also Send Feedback

Overload List

Name | Description
Register<(Of <(T>)>)(ISubscribeable<(Of <(T>)>)) | Interface of subscriber object being registered. To be used for publishing activities processing (Inherited from IServiceSubscriber.)
Register<(Of <(T>)>)(Action<(Of <(T>)>)) | Registeres an action to be performed when a publishing event occurs (Inherited from IServiceSubscriber.)
Register<(Of <(T>)>)(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>)) | Register a callback method for consumming events (Inherited from IServiceSubscriber.)

See Also

IBrokerManager Interface
IBrokerManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Subscriber(T) Method

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.Subscriber<(Of <(T>)>) Method
IBrokerManager Interface See Also Send Feedback
Gets the subscription service.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IServiceSubscriber Subscriber<T>()
Visual Basic (Declaration)
Function Subscriber(Of T) As IServiceSubscriber
Visual C++
generic<typename T>
IServiceSubscriber^ Subscriber()

Type Parameters

T
the subscriber type.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager.Subscriber``1"]

See Also

IBrokerManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.Unregister Method
IBrokerManager Interface See Also Send Feedback

Overload List

Name | Description
Unregister<(Of <(T>)>)(ISubscribeable<(Of <(T>)>)) | Unregisters a subscriber (instance) from notifications about publishing activities (Inherited from IServiceSubscriber.)
Unregister<(Of <(T>)>)(Action<(Of <(T>)>)) | Unregister a subscriber (method) previously registered for consumming events (Inherited from IServiceSubscriber.)

See Also

IBrokerManager Interface
IBrokerManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager Properties
IBrokerManager Interface See Also Send Feedback

The IBrokerManager type exposes the following members.

Properties

Name | Description
BrokerType | Gets the type of broker.
Count | Overloaded.
EventSubscription | Gets the subscriber object. (Inherited from IBrokerSubscriber.)
Parent | Gets and sets the parent of the Broker Manager.

See Also

IBrokerManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerType Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.BrokerType Property
IBrokerManager Interface See Also Send Feedback
Gets the type of broker.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Type BrokerType { get; }
Visual Basic (Declaration)
ReadOnly Property BrokerType As Type
Visual C++
property Type^ BrokerType {
    Type^ get ();
}

See Also

IBrokerManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.Count Property
IBrokerManager Interface See Also Send Feedback

Overload List

Name | Description
Count | Gets the number of subscribers.
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber.)

See Also

IBrokerManager Interface
IBrokerManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.Count Property
IBrokerManager Interface See Also Send Feedback
Gets the number of subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
int Count { get; }
Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual C++
property int Count {
    int get ();
}

Implements

IBrokerSubscriber..::.Count

See Also

IBrokerManager Interface
Count Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Parent Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.Parent Property
IBrokerManager Interface See Also Send Feedback
Gets and sets the parent of the Broker Manager.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object Parent { get; set; }
Visual Basic (Declaration)
Property Parent As Object
Visual C++
property Object^ Parent {
    Object^ get ();
    void set (Object^ value);
}

See Also

IBrokerManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing publisher/subscriber pattern.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IBrokerManager<T> : IServiceSubscriber<T>,
    IBrokerSubscriber<T>, IBrokerPublisher, IDisposable
Visual Basic (Declaration)
Public Interface IBrokerManager(Of T) _
    Implements IServiceSubscriber(Of T), IBrokerSubscriber(Of T),  _
    IBrokerPublisher, IDisposable
Visual C++
generic<typename T>
public interface class IBrokerManager : IServiceSubscriber<T>,
    IBrokerSubscriber<T>, IBrokerPublisher, IDisposable

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager`1"]

See Also

IBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>) Members
IBrokerManager<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IBrokerManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetList | Overloaded.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
Register | Overloaded.
Subscriber | Gets the subscription service.
Unregister | Overloaded.

Properties

Name | Description
BrokerType | Gets the type of broker.
Count | Overloaded.
EventSubscription | Gets the subscriber object of type T. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
Parent | Gets and sets the parent of the Broker Manager.
SubscriptionBroker | Get raw subscriber (Inherited from IServiceSubscriber<(Of <(T>)>).)

See Also

IBrokerManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>) Methods
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback

The IBrokerManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetList | Overloaded.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
Register | Overloaded.
Subscriber | Gets the subscription service.
Unregister | Overloaded.

See Also

IBrokerManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.GetList Method
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag.
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag.
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IBrokerManager<(Of <(T>)>) Interface
IBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList(U) Method (ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.GetList<(Of <(U>)>) Method (ItemLocation)
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of subscribers according to location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnumerable<U> GetList<U>(
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList(Of U) ( _
    flag As ItemLocation _
) As IEnumerable(Of U)
Visual C++
generic<typename U>
IEnumerable<U>^ GetList(
    ItemLocation flag
)

Parameters

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
the item location flag.

Type Parameters

U
the subscriber type.

Return Value

the enumeration.

See Also

IBrokerManager<(Of <(T>)>) Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method (Type, ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.GetList Method (Type, ItemLocation)
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of subscribers according to target and location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnumerable GetList(
    Type targetObject,
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList ( _
    targetObject As Type, _
    flag As ItemLocation _
) As IEnumerable
Visual C++
IEnumerable^ GetList(
    Type^ targetObject,
    ItemLocation flag
)

Parameters

targetObject
Type: System..::.Type
the subscriber type.
flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
the item location flag.

Return Value

the enumeration.

Implements

IBrokerSubscriber<(Of <(T>)>)..::.GetList(Type, ItemLocation)

See Also

IBrokerManager<(Of <(T>)>) Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.Register Method
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Register(ISubscribeable<(Of <(T>)>)) | Interface of subscriber object being registered. To be used for publishing activities processing (Inherited from IServiceSubscriber<(Of <(T>)>).)
Register(Action<(Of <(T>)>)) | Registers an action to be performed when a publishing event occurs (Inherited from IServiceSubscriber<(Of <(T>)>).)
Register(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>)) | Register a callback method for consumming events (Inherited from IServiceSubscriber<(Of <(T>)>).)

See Also

IBrokerManager<(Of <(T>)>) Interface
IBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Subscriber Method

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.Subscriber Method
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the subscription service.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IServiceSubscriber<T> Subscriber()
Visual Basic (Declaration)
Function Subscriber As IServiceSubscriber(Of T)
Visual C++
IServiceSubscriber<T>^ Subscriber()

Return Value

The IServiceSubscriber.

See Also

IBrokerManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.Unregister Method
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Unregister(ISubscribeable<(Of <(T>)>)) | Unregisters a subscriber (instance) from notifications about publishing activities (Inherited from IServiceSubscriber<(Of <(T>)>).)
Unregister(Action<(Of <(T>)>)) | Unregister a subscriber (method) previously registered for consumming events (Inherited from IServiceSubscriber<(Of <(T>)>).)

See Also

IBrokerManager<(Of <(T>)>) Interface
IBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>) Properties
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback

The IBrokerManager<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
BrokerType | Gets the type of broker.
Count | Overloaded.
EventSubscription | Gets the subscriber object of type T. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
Parent | Gets and sets the parent of the Broker Manager.
SubscriptionBroker | Get raw subscriber (Inherited from IServiceSubscriber<(Of <(T>)>).)

See Also

IBrokerManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerType Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.BrokerType Property
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the type of broker.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Type BrokerType { get; }
Visual Basic (Declaration)
ReadOnly Property BrokerType As Type
Visual C++
property Type^ BrokerType {
    Type^ get ();
}

See Also

IBrokerManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.Count Property
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Count | Gets the number of subscribers.
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IBrokerManager<(Of <(T>)>) Interface
IBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.Count Property
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the number of subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
int Count { get; }
Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual C++
property int Count {
    int get ();
}

Implements

IBrokerSubscriber<(Of <(T>)>)..::.Count

See Also

IBrokerManager<(Of <(T>)>) Interface
Count Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Parent Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.Parent Property
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback
Gets and sets the parent of the Broker Manager.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object Parent { get; set; }
Visual Basic (Declaration)
Property Parent As Object
Visual C++
property Object^ Parent {
    Object^ get ();
    void set (Object^ value);
}

See Also

IBrokerManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerPublisher Interface

[image]

Enterprise SDK 8.0 Reference API
IBrokerPublisher Interface
Members See Also Send Feedback
Interface for managing event publisher to subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IBrokerPublisher
Visual Basic (Declaration)
Public Interface IBrokerPublisher
Visual C++
public interface class IBrokerPublisher

See Also

IBrokerPublisher Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerPublisher Members

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerPublisher Members
IBrokerPublisher Interface Methods See Also Send Feedback

The IBrokerPublisher type exposes the following members.

Methods

Name | Description
Publish<(Of <(T>)>) | Publishes an object to listening subscribers.

See Also

IBrokerPublisher Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerPublisher Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerPublisher Methods
IBrokerPublisher Interface See Also Send Feedback

The IBrokerPublisher type exposes the following members.

Methods

Name | Description
Publish<(Of <(T>)>) | Publishes an object to listening subscribers.

See Also

IBrokerPublisher Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Publish(T) Method

[image]

Enterprise SDK 8.0 Reference API
IBrokerPublisher..::.Publish<(Of <(T>)>) Method
IBrokerPublisher Interface See Also Send Feedback
Publishes an object to listening subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IBrokerPublisher Publish<T>(
    T obj
)
Visual Basic (Declaration)
Function Publish(Of T) ( _
    obj As T _
) As IBrokerPublisher
Visual C++
generic<typename T>
IBrokerPublisher^ Publish(
    T obj
)

Parameters

obj
Type: T
the object instance.

Type Parameters

T
the object type.

Return Value

IBrokerPublisher.

See Also

IBrokerPublisher Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber Interface

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber Interface
Members See Also Send Feedback
Interface for managing event subscription.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IBrokerSubscriber
Visual Basic (Declaration)
Public Interface IBrokerSubscriber
Visual C++
public interface class IBrokerSubscriber

See Also

IBrokerSubscriber Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber Members

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber Members
IBrokerSubscriber Interface Methods Properties See Also Send Feedback

The IBrokerSubscriber type exposes the following members.

Methods

Name | Description
GetList | Overloaded.

Properties

Name | Description
Count | Gets the number of subscribers.
EventSubscription | Gets the subscriber object.

See Also

IBrokerSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber Methods
IBrokerSubscriber Interface See Also Send Feedback

Methods

Name | Description
GetList | Overloaded.

See Also

IBrokerSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber..::.GetList Method
IBrokerSubscriber Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(T>)>)(ItemLocation) | Gets the list of subscribers according to location flag.
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag.

See Also

IBrokerSubscriber Interface
IBrokerSubscriber Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList(T) Method (ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber..::.GetList<(Of <(T>)>) Method (ItemLocation)
IBrokerSubscriber Interface See Also Send Feedback
Gets the list of subscribers according to location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnumerable<T> GetList<T>(
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList(Of T) ( _
    flag As ItemLocation _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ GetList(
    ItemLocation flag
)

Parameters

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
the item location flag.

Type Parameters

T
the object type.

Return Value

the enumeration.

See Also

IBrokerSubscriber Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method (Type, ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber..::.GetList Method (Type, ItemLocation)
IBrokerSubscriber Interface See Also Send Feedback
Gets the list of subscribers according to target and location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnumerable GetList(
    Type targetObject,
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList ( _
    targetObject As Type, _
    flag As ItemLocation _
) As IEnumerable
Visual C++
IEnumerable^ GetList(
    Type^ targetObject,
    ItemLocation flag
)

Parameters

targetObject
Type: System..::.Type
the object type.
flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
the item location flag.

Return Value

the enumeration.

See Also

IBrokerSubscriber Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber Properties
IBrokerSubscriber Interface See Also Send Feedback

The IBrokerSubscriber type exposes the following members.

Properties

Name | Description
Count | Gets the number of subscribers.
EventSubscription | Gets the subscriber object.

See Also

IBrokerSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber..::.Count Property
IBrokerSubscriber Interface See Also Send Feedback
Gets the number of subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
int Count { get; }
Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual C++
property int Count {
    int get ();
}

See Also

IBrokerSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


EventSubscription Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber..::.EventSubscription Property
IBrokerSubscriber Interface See Also Send Feedback
Gets the subscriber object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IServiceSubscriber EventSubscription { get; }
Visual Basic (Declaration)
ReadOnly Property EventSubscription As IServiceSubscriber
Visual C++
property IServiceSubscriber^ EventSubscription {
    IServiceSubscriber^ get ();
}

See Also

IBrokerSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing event subscription.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IBrokerSubscriber<T>
Visual Basic (Declaration)
Public Interface IBrokerSubscriber(Of T)
Visual C++
generic<typename T>
public interface class IBrokerSubscriber

Type Parameters

T
the subscriber object type.

See Also

IBrokerSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>) Members
IBrokerSubscriber<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IBrokerSubscriber<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
GetList | Overloaded.

Properties

Name | Description
Count | Gets the number of subscribers.
EventSubscription | Gets the subscriber object of type T.

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>) Methods
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback

Methods

Name | Description
GetList | Overloaded.

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>)..::.GetList Method
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag.
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag.

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
IBrokerSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList(U) Method (ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>)..::.GetList<(Of <(U>)>) Method (ItemLocation)
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of subscribers according to location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnumerable<U> GetList<U>(
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList(Of U) ( _
    flag As ItemLocation _
) As IEnumerable(Of U)
Visual C++
generic<typename U>
IEnumerable<U>^ GetList(
    ItemLocation flag
)

Parameters

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
the item location flag.

Type Parameters

U
the object type.

Return Value

the enumeration.

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method (Type, ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>)..::.GetList Method (Type, ItemLocation)
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of subscribers according to target and location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnumerable GetList(
    Type targetObject,
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList ( _
    targetObject As Type, _
    flag As ItemLocation _
) As IEnumerable
Visual C++
IEnumerable^ GetList(
    Type^ targetObject,
    ItemLocation flag
)

Parameters

targetObject
Type: System..::.Type
the object type.
flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
the item location flag.

Return Value

the enumeration.

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>) Properties
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback

The IBrokerSubscriber<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Count | Gets the number of subscribers.
EventSubscription | Gets the subscriber object of type T.

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>)..::.Count Property
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Gets the number of subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
int Count { get; }
Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual C++
property int Count {
    int get ();
}

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


EventSubscription Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>)..::.EventSubscription Property
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Gets the subscriber object of type T.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IServiceSubscriber<T> EventSubscription { get; }
Visual Basic (Declaration)
ReadOnly Property EventSubscription As IServiceSubscriber(Of T)
Visual C++
property IServiceSubscriber<T>^ EventSubscription {
    IServiceSubscriber<T>^ get ();
}

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICapability Interface

[image]

Enterprise SDK 8.0 Reference API
ICapability Interface
Members See Also Send Feedback
Interface for managing capability.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface ICapability
Visual Basic (Declaration)
Public Interface ICapability
Visual C++
public interface class ICapability

See Also

ICapability Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICapability Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICapability Members
ICapability Interface Properties See Also Send Feedback

The ICapability type exposes the following members.

Properties

Name | Description
Description | Get capability description
Name | Get capability name
State | Get or set capability state : Inactive, , Disabled or Enabled
Value | Get or set task value (task is ON or OFF)

See Also

ICapability Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICapability Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICapability Properties
ICapability Interface See Also Send Feedback

The ICapability type exposes the following members.

Properties

Name | Description
Description | Get capability description
Name | Get capability name
State | Get or set capability state : Inactive, , Disabled or Enabled
Value | Get or set task value (task is ON or OFF)

See Also

ICapability Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
ICapability..::.Description Property
ICapability Interface See Also Send Feedback
Get capability description

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

ICapability Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
ICapability..::.Name Property
ICapability Interface See Also Send Feedback
Get capability name

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

ICapability Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
ICapability..::.State Property
ICapability Interface See Also Send Feedback
Get or set capability state : Inactive, , Disabled or Enabled

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
StateType State { get; set; }
Visual Basic (Declaration)
Property State As StateType
Visual C++
property StateType State {
    StateType get ();
    void set (StateType value);
}

See Also

ICapability Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Value Property

[image]

Enterprise SDK 8.0 Reference API
ICapability..::.Value Property
ICapability Interface See Also Send Feedback
Get or set task value (task is ON or OFF)

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool Value { get; set; }
Visual Basic (Declaration)
Property Value As Boolean
Visual C++
property bool Value {
    bool get ();
    void set (bool value);
}

See Also

ICapability Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICategoryManager Interface

[image]

Enterprise SDK 8.0 Reference API
ICategoryManager Interface
Members See Also Send Feedback
Interface for managing the categories of data bag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface ICategoryManager
Visual Basic (Declaration)
Public Interface ICategoryManager
Visual C++
public interface class ICategoryManager

See Also

ICategoryManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICategoryManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICategoryManager Members
ICategoryManager Interface Methods Properties See Also Send Feedback

The ICategoryManager type exposes the following members.

Methods

Name | Description
CreateCategory | Creates a category in a data bag.
RemoveCategory | Removes a category in a data bag.

Properties

Name | Description
ListCategories | Gets the list of categories in a data bag.

See Also

ICategoryManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICategoryManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ICategoryManager Methods
ICategoryManager Interface See Also Send Feedback

The ICategoryManager type exposes the following members.

Methods

Name | Description
CreateCategory | Creates a category in a data bag.
RemoveCategory | Removes a category in a data bag.

See Also

ICategoryManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


CreateCategory Method

[image]

Enterprise SDK 8.0 Reference API
ICategoryManager..::.CreateCategory Method
ICategoryManager Interface See Also Send Feedback
Creates a category in a data bag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool CreateCategory(
    string key,
    string category
)
Visual Basic (Declaration)
Function CreateCategory ( _
    key As String, _
    category As String _
) As Boolean
Visual C++
bool CreateCategory(
    String^ key,
    String^ category
)

Parameters

key
Type: System..::.String
the key of the category.
category
Type: System..::.String
the category name.

Return Value

true if operation is successful.

See Also

ICategoryManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


RemoveCategory Method

[image]

Enterprise SDK 8.0 Reference API
ICategoryManager..::.RemoveCategory Method
ICategoryManager Interface See Also Send Feedback
Removes a category in a data bag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool RemoveCategory(
    string key
)
Visual Basic (Declaration)
Function RemoveCategory ( _
    key As String _
) As Boolean
Visual C++
bool RemoveCategory(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the category.

Return Value

true if operation is successful.

See Also

ICategoryManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICategoryManager Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICategoryManager Properties
ICategoryManager Interface See Also Send Feedback

The ICategoryManager type exposes the following members.

Properties

Name | Description
ListCategories | Gets the list of categories in a data bag.

See Also

ICategoryManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ListCategories Property

[image]

Enterprise SDK 8.0 Reference API
ICategoryManager..::.ListCategories Property
ICategoryManager Interface See Also Send Feedback
Gets the list of categories in a data bag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnumerable ListCategories { get; }
Visual Basic (Declaration)
ReadOnly Property ListCategories As IEnumerable
Visual C++
property IEnumerable^ ListCategories {
    IEnumerable^ get ();
}

See Also

ICategoryManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IContext Interface

[image]

Enterprise SDK 8.0 Reference API
IContext Interface
Members See Also Send Feedback
Interface for managing context of a party.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IContext
Visual Basic (Declaration)
Public Interface IContext
Visual C++
public interface class IContext

See Also

IContext Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IContext Members

[image] [image]

Enterprise SDK 8.0 Reference API
IContext Members
IContext Interface Properties See Also Send Feedback

The IContext type exposes the following members.

Properties

Name | Description
Application | Gets and sets the name of the application.
Description | Gets and sets the description of the context.
Location | Gets and sets the name of the Location.

See Also

IContext Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IContext Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IContext Properties
IContext Interface See Also Send Feedback

The IContext type exposes the following members.

Properties

Name | Description
Application | Gets and sets the name of the application.
Description | Gets and sets the description of the context.
Location | Gets and sets the name of the Location.

See Also

IContext Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Application Property

[image]

Enterprise SDK 8.0 Reference API
IContext..::.Application Property
IContext Interface See Also Send Feedback
Gets and sets the name of the application.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Application { get; }
Visual Basic (Declaration)
ReadOnly Property Application As String
Visual C++
property String^ Application {
    String^ get ();
}

See Also

IContext Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IContext..::.Description Property
IContext Interface See Also Send Feedback
Gets and sets the description of the context.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IContext Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Location Property

[image]

Enterprise SDK 8.0 Reference API
IContext..::.Location Property
IContext Interface See Also Send Feedback
Gets and sets the name of the Location.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Location { get; }
Visual Basic (Declaration)
ReadOnly Property Location As String
Visual C++
property String^ Location {
    String^ get ();
}

See Also

IContext Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IController Interface

[image]

Enterprise SDK 8.0 Reference API
IController Interface
Members See Also Send Feedback
Interface for managing state machine controller pattern.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IController
Visual Basic (Declaration)
Public Interface IController
Visual C++
public interface class IController

See Also

IController Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IController Members

[image] [image]

Enterprise SDK 8.0 Reference API
IController Members
IController Interface Methods Properties See Also Send Feedback

The IController type exposes the following members.

Methods

Name | Description
HandleEvent | Calls the state machine with an event transition for changing the state.

Properties

Name | Description
State | Gets the state machine of this controller.

See Also

IController Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IController Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IController Methods
IController Interface See Also Send Feedback

The IController type exposes the following members.

Methods

Name | Description
HandleEvent | Calls the state machine with an event transition for changing the state.

See Also

IController Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


HandleEvent Method

[image]

Enterprise SDK 8.0 Reference API
IController..::.HandleEvent Method
IController Interface See Also Send Feedback
Calls the state machine with an event transition for changing the state.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ControllerResponse HandleEvent(
    string eventName
)
Visual Basic (Declaration)
Function HandleEvent ( _
    eventName As String _
) As ControllerResponse
Visual C++
ControllerResponse HandleEvent(
    String^ eventName
)

Parameters

eventName
Type: System..::.String
the event name.

Return Value

the ControllerResponse.

See Also

IController Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IController Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IController Properties
IController Interface See Also Send Feedback

The IController type exposes the following members.

Properties

Name | Description
State | Gets the state machine of this controller.

See Also

IController Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
IController..::.State Property
IController Interface See Also Send Feedback
Gets the state machine of this controller.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IStateMachineState State { get; }
Visual Basic (Declaration)
ReadOnly Property State As IStateMachineState
Visual C++
property IStateMachineState^ State {
    IStateMachineState^ get ();
}

See Also

IController Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDataBag(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing data set.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IDataBag<T> : ICategoryManager
Visual Basic (Declaration)
Public Interface IDataBag(Of T) _
    Implements ICategoryManager
Visual C++
generic<typename T>
public interface class IDataBag : ICategoryManager

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.IDataBag`1"]

See Also

IDataBag<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDataBag(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>) Members
IDataBag<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IDataBag<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
CreateCategory | Creates a category in a data bag. (Inherited from ICategoryManager.)
RemoveCategory | Removes a category in a data bag. (Inherited from ICategoryManager.)

Properties

Name | Description
Item | Gets or Sets the value for a section.
ListCategories | Gets the list of categories in a data bag. (Inherited from ICategoryManager.)
ListSections | Gets the list of section of this data bag.
Owner | Gets the owner instance (any instance of any class) of this data.

See Also

IDataBag<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDataBag(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>) Methods
IDataBag<(Of <(T>)>) Interface See Also Send Feedback

The IDataBag<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
CreateCategory | Creates a category in a data bag. (Inherited from ICategoryManager.)
RemoveCategory | Removes a category in a data bag. (Inherited from ICategoryManager.)

See Also

IDataBag<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDataBag(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>) Properties
IDataBag<(Of <(T>)>) Interface See Also Send Feedback

The IDataBag<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Item | Gets or Sets the value for a section.
ListCategories | Gets the list of categories in a data bag. (Inherited from ICategoryManager.)
ListSections | Gets the list of section of this data bag.
Owner | Gets the owner instance (any instance of any class) of this data.

See Also

IDataBag<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>)..::.Item Property
IDataBag<(Of <(T>)>) Interface See Also Send Feedback
Gets or Sets the value for a section.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
T this[
    string section
] { get; set; }
Visual Basic (Declaration)
Default Property Item ( _
    section As String _
) As T
Visual C++
property T default[String^ section] {
    T get (String^ section);
    void set (String^ section, T value);
}

Parameters

section
Type: System..::.String
the section name.

Return Value

the value

See Also

IDataBag<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ListSections Property

[image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>)..::.ListSections Property
IDataBag<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of section of this data bag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string[] ListSections { get; }
Visual Basic (Declaration)
ReadOnly Property ListSections As String()
Visual C++
property array<String^>^ ListSections {
    array<String^>^ get ();
}

See Also

IDataBag<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Owner Property

[image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>)..::.Owner Property
IDataBag<(Of <(T>)>) Interface See Also Send Feedback
Gets the owner instance (any instance of any class) of this data.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object Owner { get; }
Visual Basic (Declaration)
ReadOnly Property Owner As Object
Visual C++
property Object^ Owner {
    Object^ get ();
}

See Also

IDataBag<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDelegateSubscriber(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IDelegateSubscriber<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing Broker subscriber.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IDelegateSubscriber<T> : ISubscriber<T>
Visual Basic (Declaration)
Public Interface IDelegateSubscriber(Of T) _
    Implements ISubscriber(Of T)
Visual C++
generic<typename T>
public interface class IDelegateSubscriber : ISubscriber<T>

Type Parameters

T
The subscriber object type.

See Also

IDelegateSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDelegateSubscriber(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDelegateSubscriber<(Of <(T>)>) Members
IDelegateSubscriber<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IDelegateSubscriber<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Handle | (Inherited from ISubscriber<(Of <( T >)>).)

Properties

Name | Description
Filter | (Inherited from ISubscriber<(Of <( T >)>).)
Handler | Gets the handler that manages event.

See Also

IDelegateSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDelegateSubscriber(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDelegateSubscriber<(Of <(T>)>) Methods
IDelegateSubscriber<(Of <(T>)>) Interface See Also Send Feedback

The IDelegateSubscriber<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Handle | (Inherited from ISubscriber<(Of <( T >)>).)

See Also

IDelegateSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDelegateSubscriber(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDelegateSubscriber<(Of <(T>)>) Properties
IDelegateSubscriber<(Of <(T>)>) Interface See Also Send Feedback

The IDelegateSubscriber<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Filter | (Inherited from ISubscriber<(Of <( T >)>).)
Handler | Gets the handler that manages event.

See Also

IDelegateSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Handler Property

[image]

Enterprise SDK 8.0 Reference API
IDelegateSubscriber<(Of <(T>)>)..::.Handler Property
IDelegateSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Gets the handler that manages event.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Action<T> Handler { get; }
Visual Basic (Declaration)
ReadOnly Property Handler As Action(Of T)
Visual C++
property Action<T>^ Handler {
    Action<T>^ get ();
}

See Also

IDelegateSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDynamicAttribute Interface

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute Interface
Members See Also Send Feedback
Interface for managing dynamic attributes.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IDynamicAttribute
Visual Basic (Declaration)
Public Interface IDynamicAttribute
Visual C++
public interface class IDynamicAttribute

See Also

IDynamicAttribute Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDynamicAttribute Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute Members
IDynamicAttribute Interface Properties See Also Send Feedback

The IDynamicAttribute type exposes the following members.

Properties

Name | Description
ContentType | Gets or sets the content type of the value.
ContentTypeVersion | Gets or set the content type version.
ExpiresAt | Gets or sets the expire date of the attribute validity.
Key | Gets the key value of the attribute.
ReadOnly | Gets or sets the read-only flag on the attribute.
Value | Gets or vets the value of the attribute.

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDynamicAttribute Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute Properties
IDynamicAttribute Interface See Also Send Feedback

The IDynamicAttribute type exposes the following members.

Properties

Name | Description
ContentType | Gets or sets the content type of the value.
ContentTypeVersion | Gets or set the content type version.
ExpiresAt | Gets or sets the expire date of the attribute validity.
Key | Gets the key value of the attribute.
ReadOnly | Gets or sets the read-only flag on the attribute.
Value | Gets or vets the value of the attribute.

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ContentType Property

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute..::.ContentType Property
IDynamicAttribute Interface See Also Send Feedback
Gets or sets the content type of the value.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string ContentType { get; set; }
Visual Basic (Declaration)
Property ContentType As String
Visual C++
property String^ ContentType {
    String^ get ();
    void set (String^ value);
}

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ContentTypeVersion Property

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute..::.ContentTypeVersion Property
IDynamicAttribute Interface See Also Send Feedback
Gets or set the content type version.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string ContentTypeVersion { get; set; }
Visual Basic (Declaration)
Property ContentTypeVersion As String
Visual C++
property String^ ContentTypeVersion {
    String^ get ();
    void set (String^ value);
}

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ExpiresAt Property

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute..::.ExpiresAt Property
IDynamicAttribute Interface See Also Send Feedback
Gets or sets the expire date of the attribute validity.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
long ExpiresAt { get; set; }
Visual Basic (Declaration)
Property ExpiresAt As Long
Visual C++
property long long ExpiresAt {
    long long get ();
    void set (long long value);
}

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Key Property

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute..::.Key Property
IDynamicAttribute Interface See Also Send Feedback
Gets the key value of the attribute.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Key { get; }
Visual Basic (Declaration)
ReadOnly Property Key As String
Visual C++
property String^ Key {
    String^ get ();
}

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ReadOnly Property

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute..::.ReadOnly Property
IDynamicAttribute Interface See Also Send Feedback
Gets or sets the read-only flag on the attribute.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool ReadOnly { get; set; }
Visual Basic (Declaration)
Property ReadOnly As Boolean
Visual C++
property bool ReadOnly {
    bool get ();
    void set (bool value);
}

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Value Property

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute..::.Value Property
IDynamicAttribute Interface See Also Send Feedback
Gets or vets the value of the attribute.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object Value { get; set; }
Visual Basic (Declaration)
Property Value As Object
Visual C++
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IFilter Interface

[image]

Enterprise SDK 8.0 Reference API
IFilter Interface
Members See Also Send Feedback
Interface for managing Filter for Broker Message.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IFilter
Visual Basic (Declaration)
Public Interface IFilter
Visual C++
public interface class IFilter

See Also

IFilter Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IFilter Members

[image] [image]

Enterprise SDK 8.0 Reference API
IFilter Members
IFilter Interface Methods Properties See Also Send Feedback

The IFilter type exposes the following members.

Methods

Name | Description
GetFilters | Gets the filters.

Properties

Name | Description
Key | Gets the key of the filter.
Target | Gets the target type on which filter is applied.

See Also

IFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IFilter Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IFilter Methods
IFilter Interface See Also Send Feedback

The IFilter type exposes the following members.

Methods

Name | Description
GetFilters | Gets the filters.

See Also

IFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetFilters Method

[image]

Enterprise SDK 8.0 Reference API
IFilter..::.GetFilters Method
IFilter Interface See Also Send Feedback
Gets the filters.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object GetFilters()
Visual Basic (Declaration)
Function GetFilters As Object
Visual C++
Object^ GetFilters()

Return Value

the object that contains the filters.

See Also

IFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IFilter Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IFilter Properties
IFilter Interface See Also Send Feedback

The IFilter type exposes the following members.

Properties

Name | Description
Key | Gets the key of the filter.
Target | Gets the target type on which filter is applied.

See Also

IFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Key Property

[image]

Enterprise SDK 8.0 Reference API
IFilter..::.Key Property
IFilter Interface See Also Send Feedback
Gets the key of the filter.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Key { get; }
Visual Basic (Declaration)
ReadOnly Property Key As String
Visual C++
property String^ Key {
    String^ get ();
}

See Also

IFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Target Property

[image]

Enterprise SDK 8.0 Reference API
IFilter..::.Target Property
IFilter Interface See Also Send Feedback
Gets the target type on which filter is applied.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Type Target { get; }
Visual Basic (Declaration)
ReadOnly Property Target As Type
Visual C++
property Type^ Target {
    Type^ get ();
}

See Also

IFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPersistable(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing the persistency of objects.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IPersistable<T>
Visual Basic (Declaration)
Public Interface IPersistable(Of T)
Visual C++
generic<typename T>
public interface class IPersistable

Type Parameters

T
the persistent object type.

See Also

IPersistable<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPersistable(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>) Members
IPersistable<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IPersistable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
IsDirty |
Save | Overloaded.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.

See Also

IPersistable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPersistable(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>) Methods
IPersistable<(Of <(T>)>) Interface See Also Send Feedback

The IPersistable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
IsDirty |
Save | Overloaded.

See Also

IPersistable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IsDirty Method

[image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>)..::.IsDirty Method
IPersistable<(Of <(T>)>) Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IPersistable`1.IsDirty"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsDirty()
Visual Basic (Declaration)
Function IsDirty As Boolean
Visual C++
bool IsDirty()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IPersistable`1.IsDirty"]

See Also

IPersistable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Save Method

[image] [image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>)..::.Save Method
IPersistable<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Save(T) | Saves the object into the Contact Server.
Save(T, IStrategy) | Save data by executing the specified strategy

See Also

IPersistable<(Of <(T>)>) Interface
IPersistable<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Save Method (T)

[image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>)..::.Save Method (T)
IPersistable<(Of <(T>)>) Interface See Also Send Feedback
Saves the object into the Contact Server.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool Save(
    T data
)
Visual Basic (Declaration)
Function Save ( _
    data As T _
) As Boolean
Visual C++
bool Save(
    T data
)

Parameters

data
Type: T

[Missing <param name="data"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IPersistable`1.Save(`0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IPersistable`1.Save(`0)"]

See Also

IPersistable<(Of <(T>)>) Interface
Save Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Save Method (T, )

[image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>)..::.Save Method (T, )
IPersistable<(Of <(T>)>) Interface See Also Send Feedback
Save data by executing the specified strategy

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool Save(
    T data,
    IStrategy strategy
)
Visual Basic (Declaration)
Function Save ( _
    data As T, _
    strategy As IStrategy _
) As Boolean
Visual C++
bool Save(
    T data,
    IStrategy^ strategy
)

Parameters

data
Type: T
the interaction of type T.
strategy
Type: IStrategy
the persistence strategy.

Return Value

true if operation is successful.

See Also

IPersistable<(Of <(T>)>) Interface
Save Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPersistable(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>) Properties
IPersistable<(Of <(T>)>) Interface See Also Send Feedback

The IPersistable<(Of <(T>)>) type exposes the following members.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.

See Also

IPersistable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ContactServerId Property

[image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>)..::.ContactServerId Property
IPersistable<(Of <(T>)>) Interface See Also Send Feedback
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string ContactServerId { get; }
Visual Basic (Declaration)
ReadOnly Property ContactServerId As String
Visual C++
property String^ ContactServerId {
    String^ get ();
}

Return Value

string

See Also

IPersistable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPredicatable(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IPredicatable<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface defines contract for using a predicate

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IPredicatable<T>
Visual Basic (Declaration)
Public Interface IPredicatable(Of T)
Visual C++
generic<typename T>
public interface class IPredicatable

Type Parameters

T
Type of data

See Also

IPredicatable<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPredicatable(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPredicatable<(Of <(T>)>) Members
IPredicatable<(Of <(T>)>) Interface Methods See Also Send Feedback

The IPredicatable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Invoke | Object to be used for checking the predicate condition

See Also

IPredicatable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPredicatable(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPredicatable<(Of <(T>)>) Methods
IPredicatable<(Of <(T>)>) Interface See Also Send Feedback

The IPredicatable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Invoke | Object to be used for checking the predicate condition

See Also

IPredicatable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Invoke Method

[image]

Enterprise SDK 8.0 Reference API
IPredicatable<(Of <(T>)>)..::.Invoke Method
IPredicatable<(Of <(T>)>) Interface See Also Send Feedback
Object to be used for checking the predicate condition

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool Invoke(
    T obj
)
Visual Basic (Declaration)
Function Invoke ( _
    obj As T _
) As Boolean
Visual C++
bool Invoke(
    T obj
)

Parameters

obj
Type: T
Represents the truth or false of the predicate's condition

Return Value

bool

See Also

IPredicatable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPublishable(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IPublishable<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for publishing typed events to subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IPublishable<T>
Visual Basic (Declaration)
Public Interface IPublishable(Of T)
Visual C++
generic<typename T>
public interface class IPublishable

Type Parameters

T
the type of data.

See Also

IPublishable<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPublishable(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPublishable<(Of <(T>)>) Members
IPublishable<(Of <(T>)>) Interface Methods See Also Send Feedback

The IPublishable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Publish | Publishes an event to listening subscribers.

See Also

IPublishable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPublishable(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPublishable<(Of <(T>)>) Methods
IPublishable<(Of <(T>)>) Interface See Also Send Feedback

The IPublishable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Publish | Publishes an event to listening subscribers.

See Also

IPublishable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Publish Method

[image]

Enterprise SDK 8.0 Reference API
IPublishable<(Of <(T>)>)..::.Publish Method
IPublishable<(Of <(T>)>) Interface See Also Send Feedback
Publishes an event to listening subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IPublishable<T> Publish(
    T obj
)
Visual Basic (Declaration)
Function Publish ( _
    obj As T _
) As IPublishable(Of T)
Visual C++
IPublishable<T>^ Publish(
    T obj
)

Parameters

obj
Type: T
Object to publish

Return Value

IPublishable

See Also

IPublishable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequest Interface

[image]

Enterprise SDK 8.0 Reference API
IRequest Interface
Members See Also Send Feedback
Interface for managing request that are sent.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IRequest : ISerializable
Visual Basic (Declaration)
Public Interface IRequest _
    Implements ISerializable
Visual C++
public interface class IRequest : ISerializable

See Also

IRequest Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
IRequest Members
IRequest Interface Methods Properties See Also Send Feedback

The IRequest type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

Properties

Name | Description
CorrelatorData | User defined data
Endpoint | Gets the request End-point.
ExpiresAt | Gets or sets the expire date of the request.
Guidance |
IsOriginating | Gets or sets the originating value.
Msg | Gets the IMessage that is sent.
ParentRequestId | Gets the parent request identifier.
RequestId | Gets the unique request identifier.
RequestResult | Gets or sets the request result value.
SourceName | Gets the source name.
SourceUid | Gets the source unique identifier.
TimeStampCreation | Gets the time stamp of request creation.
TimeStampRcv | Gets or sets the time stamp of request return.
TimeStampTx | Gets or sets the time stamp of request transmit.

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IRequest Methods
IRequest Interface See Also Send Feedback

The IRequest type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IRequest Properties
IRequest Interface See Also Send Feedback

The IRequest type exposes the following members.

Properties

Name | Description
CorrelatorData | User defined data
Endpoint | Gets the request End-point.
ExpiresAt | Gets or sets the expire date of the request.
Guidance |
IsOriginating | Gets or sets the originating value.
Msg | Gets the IMessage that is sent.
ParentRequestId | Gets the parent request identifier.
RequestId | Gets the unique request identifier.
RequestResult | Gets or sets the request result value.
SourceName | Gets the source name.
SourceUid | Gets the source unique identifier.
TimeStampCreation | Gets the time stamp of request creation.
TimeStampRcv | Gets or sets the time stamp of request return.
TimeStampTx | Gets or sets the time stamp of request transmit.

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


CorrelatorData Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.CorrelatorData Property
IRequest Interface See Also Send Feedback
User defined data

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string CorrelatorData { get; }
Visual Basic (Declaration)
ReadOnly Property CorrelatorData As String
Visual C++
property String^ CorrelatorData {
    String^ get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Endpoint Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.Endpoint Property
IRequest Interface See Also Send Feedback
Gets the request End-point.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Uri Endpoint { get; }
Visual Basic (Declaration)
ReadOnly Property Endpoint As Uri
Visual C++
property Uri^ Endpoint {
    Uri^ get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ExpiresAt Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.ExpiresAt Property
IRequest Interface See Also Send Feedback
Gets or sets the expire date of the request.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
long ExpiresAt { get; }
Visual Basic (Declaration)
ReadOnly Property ExpiresAt As Long
Visual C++
property long long ExpiresAt {
    long long get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Guidance Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.Guidance Property
IRequest Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.ComponentModel.IRequest.Guidance"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object Guidance { get; }
Visual Basic (Declaration)
ReadOnly Property Guidance As Object
Visual C++
property Object^ Guidance {
    Object^ get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IsOriginating Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.IsOriginating Property
IRequest Interface See Also Send Feedback
Gets or sets the originating value.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsOriginating { get; set; }
Visual Basic (Declaration)
Property IsOriginating As Boolean
Visual C++
property bool IsOriginating {
    bool get ();
    void set (bool value);
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Msg Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.Msg Property
IRequest Interface See Also Send Feedback
Gets the IMessage that is sent.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IMessage Msg { get; }
Visual Basic (Declaration)
ReadOnly Property Msg As IMessage
Visual C++
property IMessage^ Msg {
    IMessage^ get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ParentRequestId Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.ParentRequestId Property
IRequest Interface See Also Send Feedback
Gets the parent request identifier.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
int ParentRequestId { get; }
Visual Basic (Declaration)
ReadOnly Property ParentRequestId As Integer
Visual C++
property int ParentRequestId {
    int get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


RequestId Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.RequestId Property
IRequest Interface See Also Send Feedback
Gets the unique request identifier.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
int RequestId { get; }
Visual Basic (Declaration)
ReadOnly Property RequestId As Integer
Visual C++
property int RequestId {
    int get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


RequestResult Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.RequestResult Property
IRequest Interface See Also Send Feedback
Gets or sets the request result value.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool RequestResult { get; set; }
Visual Basic (Declaration)
Property RequestResult As Boolean
Visual C++
property bool RequestResult {
    bool get ();
    void set (bool value);
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


SourceName Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.SourceName Property
IRequest Interface See Also Send Feedback
Gets the source name.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string SourceName { get; }
Visual Basic (Declaration)
ReadOnly Property SourceName As String
Visual C++
property String^ SourceName {
    String^ get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


SourceUid Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.SourceUid Property
IRequest Interface See Also Send Feedback
Gets the source unique identifier.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string SourceUid { get; }
Visual Basic (Declaration)
ReadOnly Property SourceUid As String
Visual C++
property String^ SourceUid {
    String^ get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


TimeStampCreation Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.TimeStampCreation Property
IRequest Interface See Also Send Feedback
Gets the time stamp of request creation.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
long TimeStampCreation { get; }
Visual Basic (Declaration)
ReadOnly Property TimeStampCreation As Long
Visual C++
property long long TimeStampCreation {
    long long get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


TimeStampRcv Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.TimeStampRcv Property
IRequest Interface See Also Send Feedback
Gets or sets the time stamp of request return.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
long TimeStampRcv { get; set; }
Visual Basic (Declaration)
Property TimeStampRcv As Long
Visual C++
property long long TimeStampRcv {
    long long get ();
    void set (long long value);
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


TimeStampTx Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.TimeStampTx Property
IRequest Interface See Also Send Feedback
Gets or sets the time stamp of request transmit.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
long TimeStampTx { get; set; }
Visual Basic (Declaration)
Property TimeStampTx As Long
Visual C++
property long long TimeStampTx {
    long long get ();
    void set (long long value);
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequestManager Interface

[image]

Enterprise SDK 8.0 Reference API
IRequestManager Interface
Members See Also Send Feedback
Interface for managing requests.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IRequestManager
Visual Basic (Declaration)
Public Interface IRequestManager
Visual C++
public interface class IRequestManager

See Also

IRequestManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequestManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
IRequestManager Members
IRequestManager Interface Methods Properties See Also Send Feedback

The IRequestManager type exposes the following members.

Methods

Name | Description
Count | Gets the number of requests.
DeleteRequestById | Delete a single request
GetInitialRequest | Gets the request by its initial request.
GetRequestById | Gets the request by its identifier.
GetRequestByMsg | Gets the request by its IMessage.
ListRequests | Gets the list of requests.

Properties

Name | Description
Parent | Gets the parent object.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequestManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IRequestManager Methods
IRequestManager Interface See Also Send Feedback

The IRequestManager type exposes the following members.

Methods

Name | Description
Count | Gets the number of requests.
DeleteRequestById | Delete a single request
GetInitialRequest | Gets the request by its initial request.
GetRequestById | Gets the request by its identifier.
GetRequestByMsg | Gets the request by its IMessage.
ListRequests | Gets the list of requests.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.Count Method
IRequestManager Interface See Also Send Feedback
Gets the number of requests.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
int Count()
Visual Basic (Declaration)
Function Count As Integer
Visual C++
int Count()

Return Value

the number of requests.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


DeleteRequestById Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.DeleteRequestById Method
IRequestManager Interface See Also Send Feedback
Delete a single request

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool DeleteRequestById(
    int id
)
Visual Basic (Declaration)
Function DeleteRequestById ( _
    id As Integer _
) As Boolean
Visual C++
bool DeleteRequestById(
    int id
)

Parameters

id
Type: System..::.Int32
Request Id

Return Value

bool

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetInitialRequest Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.GetInitialRequest Method
IRequestManager Interface See Also Send Feedback
Gets the request by its initial request.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IRequest GetInitialRequest(
    IRequest request
)
Visual Basic (Declaration)
Function GetInitialRequest ( _
    request As IRequest _
) As IRequest
Visual C++
IRequest^ GetInitialRequest(
    IRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRequest
the initial request.

Return Value

the associated request.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetRequestById Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.GetRequestById Method
IRequestManager Interface See Also Send Feedback
Gets the request by its identifier.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IRequest GetRequestById(
    int id
)
Visual Basic (Declaration)
Function GetRequestById ( _
    id As Integer _
) As IRequest
Visual C++
IRequest^ GetRequestById(
    int id
)

Parameters

id
Type: System..::.Int32
the request ID.

Return Value

the request.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetRequestByMsg Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.GetRequestByMsg Method
IRequestManager Interface See Also Send Feedback
Gets the request by its IMessage.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IRequest GetRequestByMsg(
    IMessage msg
)
Visual Basic (Declaration)
Function GetRequestByMsg ( _
    msg As IMessage _
) As IRequest
Visual C++
IRequest^ GetRequestByMsg(
    IMessage^ msg
)

Parameters

msg
Type: IMessage
the message.

Return Value

the request.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ListRequests Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.ListRequests Method
IRequestManager Interface See Also Send Feedback
Gets the list of requests.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IRequest[] ListRequests()
Visual Basic (Declaration)
Function ListRequests As IRequest()
Visual C++
array<IRequest^>^ ListRequests()

Return Value

the array of requests.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequestManager Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IRequestManager Properties
IRequestManager Interface See Also Send Feedback

The IRequestManager type exposes the following members.

Properties

Name | Description
Parent | Gets the parent object.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Parent Property

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.Parent Property
IRequestManager Interface See Also Send Feedback
Gets the parent object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object Parent { get; }
Visual Basic (Declaration)
ReadOnly Property Parent As Object
Visual C++
property Object^ Parent {
    Object^ get ();
}

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRole Interface

[image]

Enterprise SDK 8.0 Reference API
IRole Interface
Members See Also Send Feedback
Role interface.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IRole
Visual Basic (Declaration)
Public Interface IRole
Visual C++
public interface class IRole

See Also

IRole Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRole Members

[image] [image]

Enterprise SDK 8.0 Reference API
IRole Members
IRole Interface Properties See Also Send Feedback

The IRole type exposes the following members.

Properties

Name | Description
Capabilities | Returns the capabilities for this role (for instance, the tasks assigned.) See the RBac features in the Configuration Manager.
Description | Role description.
Name | Role name.
Parameters | Returns the parameters associated with the role.
RoleProfile | Role profile: custom or system.
Visibility | Visibility type. Example: Status in a dialog (monitoring, coaching, and so on.)

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRole Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IRole Properties
IRole Interface See Also Send Feedback

The IRole type exposes the following members.

Properties

Name | Description
Capabilities | Returns the capabilities for this role (for instance, the tasks assigned.) See the RBac features in the Configuration Manager.
Description | Role description.
Name | Role name.
Parameters | Returns the parameters associated with the role.
RoleProfile | Role profile: custom or system.
Visibility | Visibility type. Example: Status in a dialog (monitoring, coaching, and so on.)

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Capabilities Property

[image]

Enterprise SDK 8.0 Reference API
IRole..::.Capabilities Property
IRole Interface See Also Send Feedback
Returns the capabilities for this role (for instance, the tasks assigned.) See the RBac features in the Configuration Manager.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionary<string, ICapability> Capabilities { get; }
Visual Basic (Declaration)
ReadOnly Property Capabilities As IDictionary(Of String, ICapability)
Visual C++
property IDictionary<String^, ICapability^>^ Capabilities {
    IDictionary<String^, ICapability^>^ get ();
}

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IRole..::.Description Property
IRole Interface See Also Send Feedback
Role description.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IRole..::.Name Property
IRole Interface See Also Send Feedback
Role name.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Parameters Property

[image]

Enterprise SDK 8.0 Reference API
IRole..::.Parameters Property
IRole Interface See Also Send Feedback
Returns the parameters associated with the role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object[] Parameters { get; }
Visual Basic (Declaration)
ReadOnly Property Parameters As Object()
Visual C++
property array<Object^>^ Parameters {
    array<Object^>^ get ();
}

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


RoleProfile Property

[image]

Enterprise SDK 8.0 Reference API
IRole..::.RoleProfile Property
IRole Interface See Also Send Feedback
Role profile: custom or system.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
PartyType RoleProfile { get; }
Visual Basic (Declaration)
ReadOnly Property RoleProfile As PartyType
Visual C++
property PartyType RoleProfile {
    PartyType get ();
}

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Visibility Property

[image]

Enterprise SDK 8.0 Reference API
IRole..::.Visibility Property
IRole Interface See Also Send Feedback
Visibility type. Example: Status in a dialog (monitoring, coaching, and so on.)

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Visibility Visibility { get; }
Visual Basic (Declaration)
ReadOnly Property Visibility As Visibility
Visual C++
property Visibility Visibility {
    Visibility get ();
}

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRoleable Interface

[image]

Enterprise SDK 8.0 Reference API
IRoleable Interface
Members See Also Send Feedback
Classes that want to play role should implement this Role based interface

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IRoleable
Visual Basic (Declaration)
Public Interface IRoleable
Visual C++
public interface class IRoleable

See Also

IRoleable Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRoleable Members

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleable Members
IRoleable Interface Properties See Also Send Feedback

The IRoleable type exposes the following members.

Properties

Name | Description
Role | Gets or sets the role of an object.

See Also

IRoleable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRoleable Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleable Properties
IRoleable Interface See Also Send Feedback

The IRoleable type exposes the following members.

Properties

Name | Description
Role | Gets or sets the role of an object.

See Also

IRoleable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Role Property

[image]

Enterprise SDK 8.0 Reference API
IRoleable..::.Role Property
IRoleable Interface See Also Send Feedback
Gets or sets the role of an object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IRole Role { get; }
Visual Basic (Declaration)
ReadOnly Property Role As IRole
Visual C++
property IRole^ Role {
    IRole^ get ();
}

See Also

IRoleable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRoleManager(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing the roles.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IRoleManager<T>
where T : IRoleable
Visual Basic (Declaration)
Public Interface IRoleManager(Of T As IRoleable)
Visual C++
generic<typename T>
where T : IRoleable
public interface class IRoleManager

Type Parameters

T
the type of role.

See Also

IRoleManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRoleManager(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>) Members
IRoleManager<(Of <(T>)>) Interface Methods See Also Send Feedback

The IRoleManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
GetActionsRole | Overloaded.
GetObjectRole | Overloaded.
HasRole | Overloaded.
ListRoles | Overloaded.
RegisterActionsForRole | Registers actions available for a role.
RegisterObjectRole | Registers Role available for an object type.
UnregisterActionsForRole | Unregisters actions available for a role.
UnregisterObjectRole | Unregisters Role.

See Also

IRoleManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRoleManager(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>) Methods
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback

The IRoleManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
GetActionsRole | Overloaded.
GetObjectRole | Overloaded.
HasRole | Overloaded.
ListRoles | Overloaded.
RegisterActionsForRole | Registers actions available for a role.
RegisterObjectRole | Registers Role available for an object type.
UnregisterActionsForRole | Unregisters actions available for a role.
UnregisterObjectRole | Unregisters Role.

See Also

IRoleManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetActionsRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.GetActionsRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetActionsRole<(Of <(U>)>)(IRole) | Gets the actions of a role.
GetActionsRole<(Of <(U>)>)(PartyType) | Gets the actions of a role profile type.

See Also

IRoleManager<(Of <(T>)>) Interface
IRoleManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetActionsRole(U) Method (IRole)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.GetActionsRole<(Of <(U>)>) Method (IRole)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the actions of a role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
U GetActionsRole<U>(
    IRole role
)
Visual Basic (Declaration)
Function GetActionsRole(Of U) ( _
    role As IRole _
) As U
Visual C++
generic<typename U>
U GetActionsRole(
    IRole^ role
)

Parameters

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole
the role.

Type Parameters

U
the type of data.

Return Value

The actions.

See Also

IRoleManager<(Of <(T>)>) Interface
GetActionsRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetActionsRole(U) Method (PartyType)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.GetActionsRole<(Of <(U>)>) Method (PartyType)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the actions of a role profile type.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
U GetActionsRole<U>(
    PartyType role
)
Visual Basic (Declaration)
Function GetActionsRole(Of U) ( _
    role As PartyType _
) As U
Visual C++
generic<typename U>
U GetActionsRole(
    PartyType role
)

Parameters

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.PartyType
the profile type of the role.

Type Parameters

U
the type of data.

Return Value

The actions.

See Also

IRoleManager<(Of <(T>)>) Interface
GetActionsRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetObjectRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.GetObjectRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetObjectRole(T, IRole) | Gets the Role for an object according to the role.
GetObjectRole(T, PartyType) | Gets the Role for an object according to the profile type.

See Also

IRoleManager<(Of <(T>)>) Interface
IRoleManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetObjectRole Method (T, IRole)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.GetObjectRole Method (T, IRole)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the Role for an object according to the role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
T GetObjectRole(
    T baseObject,
    IRole role
)
Visual Basic (Declaration)
Function GetObjectRole ( _
    baseObject As T, _
    role As IRole _
) As T
Visual C++
T GetObjectRole(
    T baseObject,
    IRole^ role
)

Parameters

baseObject
Type: T
the object type.
role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole
the role.

Return Value

The role.

See Also

IRoleManager<(Of <(T>)>) Interface
GetObjectRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetObjectRole Method (T, PartyType)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.GetObjectRole Method (T, PartyType)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the Role for an object according to the profile type.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
T GetObjectRole(
    T baseObject,
    PartyType role
)
Visual Basic (Declaration)
Function GetObjectRole ( _
    baseObject As T, _
    role As PartyType _
) As T
Visual C++
T GetObjectRole(
    T baseObject,
    PartyType role
)

Parameters

baseObject
Type: T
the object type.
role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.PartyType
the profile type of the role.

Return Value

The role.

See Also

IRoleManager<(Of <(T>)>) Interface
GetObjectRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


HasRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.HasRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
HasRole(T, IRole) | Gets the Role availability for an object type according to the role.
HasRole(T, PartyType) | Gets the Role availability for an object type according to the profile type.
HasRole(T, Type) | Gets the Role availability for an object type according to the action.

See Also

IRoleManager<(Of <(T>)>) Interface
IRoleManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


HasRole Method (T, IRole)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.HasRole Method (T, IRole)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the Role availability for an object type according to the role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool HasRole(
    T target,
    IRole role
)
Visual Basic (Declaration)
Function HasRole ( _
    target As T, _
    role As IRole _
) As Boolean
Visual C++
bool HasRole(
    T target,
    IRole^ role
)

Parameters

target
Type: T
the object type.
role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole
the role.

Return Value

true if the object has the role.

See Also

IRoleManager<(Of <(T>)>) Interface
HasRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


HasRole Method (T, PartyType)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.HasRole Method (T, PartyType)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the Role availability for an object type according to the profile type.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool HasRole(
    T target,
    PartyType role
)
Visual Basic (Declaration)
Function HasRole ( _
    target As T, _
    role As PartyType _
) As Boolean
Visual C++
bool HasRole(
    T target,
    PartyType role
)

Parameters

target
Type: T
the object type.
role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.PartyType
the profile type of the role.

Return Value

true if the object has the role profile type.

See Also

IRoleManager<(Of <(T>)>) Interface
HasRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


HasRole Method (T, Type)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.HasRole Method (T, Type)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the Role availability for an object type according to the action.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool HasRole(
    T target,
    Type ActionRole
)
Visual Basic (Declaration)
Function HasRole ( _
    target As T, _
    ActionRole As Type _
) As Boolean
Visual C++
bool HasRole(
    T target,
    Type^ ActionRole
)

Parameters

target
Type: T
the object type.
ActionRole
Type: System..::.Type
the action of the role.

Return Value

true if the object has the action role.

See Also

IRoleManager<(Of <(T>)>) Interface
HasRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


ListRoles Method

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.ListRoles Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
ListRoles()()() | Gets the list of Role.
ListRoles(T) | Gets the list of Role available for an object type.

See Also

IRoleManager<(Of <(T>)>) Interface
IRoleManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


ListRoles Method

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.ListRoles Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of Role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IRole[] ListRoles()
Visual Basic (Declaration)
Function ListRoles As IRole()
Visual C++
array<IRole^>^ ListRoles()

Return Value

the list of Role.

See Also

IRoleManager<(Of <(T>)>) Interface
ListRoles Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


ListRoles Method (T)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.ListRoles Method (T)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of Role available for an object type.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IRole[] ListRoles(
    T target
)
Visual Basic (Declaration)
Function ListRoles ( _
    target As T _
) As IRole()
Visual C++
array<IRole^>^ ListRoles(
    T target
)

Parameters

target
Type: T
the object type.

Return Value

the array of Role.

See Also

IRoleManager<(Of <(T>)>) Interface
ListRoles Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


RegisterActionsForRole Method

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.RegisterActionsForRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Registers actions available for a role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IRoleManager<T> RegisterActionsForRole(
    Type abstractActionRole,
    Type concreteActionRole,
    IRole role
)
Visual Basic (Declaration)
Function RegisterActionsForRole ( _
    abstractActionRole As Type, _
    concreteActionRole As Type, _
    role As IRole _
) As IRoleManager(Of T)
Visual C++
IRoleManager<T>^ RegisterActionsForRole(
    Type^ abstractActionRole,
    Type^ concreteActionRole,
    IRole^ role
)

Parameters

abstractActionRole
Type: System..::.Type
the abstract action role type.
concreteActionRole
Type: System..::.Type
the concrete action role type.
role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole
the role.

Return Value

the IRoleManager.

See Also

IRoleManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


RegisterObjectRole Method

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.RegisterObjectRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Registers Role available for an object type.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IRoleManager<T> RegisterObjectRole(
    Type abstractObjectRole,
    Type concreteObjectRole,
    IRole role
)
Visual Basic (Declaration)
Function RegisterObjectRole ( _
    abstractObjectRole As Type, _
    concreteObjectRole As Type, _
    role As IRole _
) As IRoleManager(Of T)
Visual C++
IRoleManager<T>^ RegisterObjectRole(
    Type^ abstractObjectRole,
    Type^ concreteObjectRole,
    IRole^ role
)

Parameters

abstractObjectRole
Type: System..::.Type
the abstract object role.
concreteObjectRole
Type: System..::.Type
the concrete object role.
role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole
the role.

Return Value

the IRoleManager.

See Also

IRoleManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


UnregisterActionsForRole Method

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.UnregisterActionsForRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Unregisters actions available for a role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IRoleManager<T> UnregisterActionsForRole(
    IRole role
)
Visual Basic (Declaration)
Function UnregisterActionsForRole ( _
    role As IRole _
) As IRoleManager(Of T)
Visual C++
IRoleManager<T>^ UnregisterActionsForRole(
    IRole^ role
)

Parameters

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole
the role.

Return Value

the IRoleManager.

See Also

IRoleManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


UnregisterObjectRole Method

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.UnregisterObjectRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Unregisters Role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IRoleManager<T> UnregisterObjectRole(
    IRole role
)
Visual Basic (Declaration)
Function UnregisterObjectRole ( _
    role As IRole _
) As IRoleManager(Of T)
Visual C++
IRoleManager<T>^ UnregisterObjectRole(
    IRole^ role
)

Parameters

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole
the role.

Return Value

the IRoleManager.

See Also

IRoleManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber Interface

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.IServiceSubscriber"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use typed interface")]
public interface IServiceSubscriber
Visual Basic (Declaration)
<ObsoleteAttribute("Use typed interface")> _
Public Interface IServiceSubscriber
Visual C++
[ObsoleteAttribute(L"Use typed interface")]
public interface class IServiceSubscriber

See Also

IServiceSubscriber Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber Members

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber Members
IServiceSubscriber Interface Methods See Also Send Feedback

Methods

Name | Description
Register | Overloaded.
Unregister | Overloaded.

See Also

IServiceSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber Methods
IServiceSubscriber Interface See Also Send Feedback

Methods

Name | Description
Register | Overloaded.
Unregister | Overloaded.

See Also

IServiceSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Register Method
IServiceSubscriber Interface See Also Send Feedback

Overload List

Name | Description
Register<(Of <(T>)>)(ISubscribeable<(Of <(T>)>)) | Interface of subscriber object being registered. To be used for publishing activities processing
Register<(Of <(T>)>)(Action<(Of <(T>)>)) | Registeres an action to be performed when a publishing event occurs
Register<(Of <(T>)>)(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>)) | Register a callback method for consumming events

See Also

IServiceSubscriber Interface
IServiceSubscriber Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register(T) Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Register<(Of <(T>)>) Method (ISubscribeable<(Of <(T>)>))
IServiceSubscriber Interface See Also Send Feedback
Interface of subscriber object being registered. To be used for publishing activities processing

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Register<T>(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Sub Register(Of T) ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
generic<typename T>
void Register(
    ISubscribeable<T>^ subscriber
)

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <(T>)>)
Object that should receive events

Type Parameters

T
Type of parameter

See Also

IServiceSubscriber Interface
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register(T) Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Register<(Of <(T>)>) Method (Action<(Of <(T>)>))
IServiceSubscriber Interface See Also Send Feedback
Registeres an action to be performed when a publishing event occurs

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Register<T>(
    Action<T> handler
)
Visual Basic (Declaration)
Sub Register(Of T) ( _
    handler As Action(Of T) _
)
Visual C++
generic<typename T>
void Register(
    Action<T>^ handler
)

Parameters

handler
Type: System..::.Action<(Of <(T>)>)
Represents the method that performs an action on the specified object when a publishing event occurs

Type Parameters

T
Type of parameter

See Also

IServiceSubscriber Interface
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register(T) Method (Action(T), IPredicatable(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Register<(Of <(T>)>) Method (Action<(Of <(T>)>), IPredicatable<(Of <(T>)>))
IServiceSubscriber Interface See Also Send Feedback
Register a callback method for consumming events

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Register<T>(
    Action<T> handler,
    IPredicatable<T> filter
)
Visual Basic (Declaration)
Sub Register(Of T) ( _
    handler As Action(Of T), _
    filter As IPredicatable(Of T) _
)
Visual C++
generic<typename T>
void Register(
    Action<T>^ handler,
    IPredicatable<T>^ filter
)

Parameters

handler
Type: System..::.Action<(Of <(T>)>)
Function that performs an action on the specified object T when a publishing event occurs
filter
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IPredicatable <(Of <(T>)>)
filter predicate that allows checking whether publishing event should be processed or ignored

Type Parameters

T
Type of data to handle

See Also

IServiceSubscriber Interface
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Unregister Method
IServiceSubscriber Interface See Also Send Feedback

Overload List

Name | Description
Unregister<(Of <(T>)>)(ISubscribeable<(Of <(T>)>)) | Unregisters a subscriber (instance) from notifications about publishing activities
Unregister<(Of <(T>)>)(Action<(Of <(T>)>)) | Unregister a subscriber (method) previously registered for consumming events

See Also

IServiceSubscriber Interface
IServiceSubscriber Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister(T) Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Unregister<(Of <(T>)>) Method (ISubscribeable<(Of <(T>)>))
IServiceSubscriber Interface See Also Send Feedback
Unregisters a subscriber (instance) from notifications about publishing activities

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Unregister<T>(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Sub Unregister(Of T) ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
generic<typename T>
void Unregister(
    ISubscribeable<T>^ subscriber
)

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <(T>)>)
Interface of subscriber object being unregistered

Type Parameters

T
Type of data to handle.

See Also

IServiceSubscriber Interface
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister(T) Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Unregister<(Of <(T>)>) Method (Action<(Of <(T>)>))
IServiceSubscriber Interface See Also Send Feedback
Unregister a subscriber (method) previously registered for consumming events

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Unregister<T>(
    Action<T> handler
)
Visual Basic (Declaration)
Sub Unregister(Of T) ( _
    handler As Action(Of T) _
)
Visual C++
generic<typename T>
void Unregister(
    Action<T>^ handler
)

Parameters

handler
Type: System..::.Action<(Of <(T>)>)
Function that performs an action on the specified object T when a publishing event occurs.

Type Parameters

T
Type of data to handle.

See Also

IServiceSubscriber Interface
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface defines subscriber contract for Publish/Subscribe pattern.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IServiceSubscriber<T>
Visual Basic (Declaration)
Public Interface IServiceSubscriber(Of T)
Visual C++
generic<typename T>
public interface class IServiceSubscriber

Type Parameters

T
the type of data.

See Also

IServiceSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>) Members
IServiceSubscriber<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IServiceSubscriber<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Register | Overloaded.
Unregister | Overloaded.

Properties

Name | Description
SubscriptionBroker | Get raw subscriber

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>) Methods
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback

Methods

Name | Description
Register | Overloaded.
Unregister | Overloaded.

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Register Method
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Register(ISubscribeable<(Of <(T>)>)) | Interface of subscriber object being registered. To be used for publishing activities processing
Register(Action<(Of <(T>)>)) | Registers an action to be performed when a publishing event occurs
Register(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>)) | Register a callback method for consumming events

See Also

IServiceSubscriber<(Of <(T>)>) Interface
IServiceSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Register Method (ISubscribeable<(Of <(T>)>))
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Interface of subscriber object being registered. To be used for publishing activities processing

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Register(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Sub Register ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
void Register(
    ISubscribeable<T>^ subscriber
)

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( T >)>)
Object that should receive events

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Register Method (Action<(Of <(T>)>))
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Registers an action to be performed when a publishing event occurs

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Register(
    Action<T> handler
)
Visual Basic (Declaration)
Sub Register ( _
    handler As Action(Of T) _
)
Visual C++
void Register(
    Action<T>^ handler
)

Parameters

handler
Type: System..::.Action<(Of <( T >)>)
Represents the method that performs an action on the specified object when a publishing event occurs

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (Action(T), IPredicatable(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Register Method (Action<(Of <(T>)>), IPredicatable<(Of <(T>)>))
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Register a callback method for consumming events

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Register(
    Action<T> handler,
    IPredicatable<T> filter
)
Visual Basic (Declaration)
Sub Register ( _
    handler As Action(Of T), _
    filter As IPredicatable(Of T) _
)
Visual C++
void Register(
    Action<T>^ handler,
    IPredicatable<T>^ filter
)

Parameters

handler
Type: System..::.Action<(Of <( T >)>)
Function that performs an action on the specified object T when a publishing event occurs
filter
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IPredicatable <(Of <( T >)>)
filter predicate that allows checking whether publishing event should be processed or ignored

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Unregister Method
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Unregister(ISubscribeable<(Of <(T>)>)) | Unregisters a subscriber (instance) from notifications about publishing activities
Unregister(Action<(Of <(T>)>)) | Unregister a subscriber (method) previously registered for consumming events

See Also

IServiceSubscriber<(Of <(T>)>) Interface
IServiceSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Unregister Method (ISubscribeable<(Of <(T>)>))
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Unregisters a subscriber (instance) from notifications about publishing activities

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Unregister(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Sub Unregister ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
void Unregister(
    ISubscribeable<T>^ subscriber
)

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( T >)>)
Interface of subscriber object being unregistered

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Unregister Method (Action<(Of <(T>)>))
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Unregister a subscriber (method) previously registered for consumming events

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Unregister(
    Action<T> handler
)
Visual Basic (Declaration)
Sub Unregister ( _
    handler As Action(Of T) _
)
Visual C++
void Unregister(
    Action<T>^ handler
)

Parameters

handler
Type: System..::.Action<(Of <( T >)>)
Function that performs an action on the specified object T when a publishing event occurs.

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>) Properties
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback

The IServiceSubscriber<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
SubscriptionBroker | Get raw subscriber

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscriptionBroker Property

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.SubscriptionBroker Property
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Get raw subscriber

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ISubscriptionService SubscriptionBroker { get; }
Visual Basic (Declaration)
ReadOnly Property SubscriptionBroker As ISubscriptionService
Visual C++
property ISubscriptionService^ SubscriptionBroker {
    ISubscriptionService^ get ();
}

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ISubscribeable(T) Interface

[image]

Enterprise SDK 8.0 Reference API
ISubscribeable<(Of <(T>)>) Interface
Members See Also Send Feedback
Defines a subscriber contract for Publish/Subscribe pattern.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface ISubscribeable<T>
Visual Basic (Declaration)
Public Interface ISubscribeable(Of T)
Visual C++
generic<typename T>
public interface class ISubscribeable

Type Parameters

T
Type of data

See Also

ISubscribeable<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


ISubscribeable(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISubscribeable<(Of <(T>)>) Members
ISubscribeable<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The ISubscribeable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Handle | Processes a publishing event.

Properties

Name | Description
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored.

See Also

ISubscribeable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ISubscribeable(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ISubscribeable<(Of <(T>)>) Methods
ISubscribeable<(Of <(T>)>) Interface See Also Send Feedback

The ISubscribeable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Handle | Processes a publishing event.

See Also

ISubscribeable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Handle Method

[image]

Enterprise SDK 8.0 Reference API
ISubscribeable<(Of <(T>)>)..::.Handle Method
ISubscribeable<(Of <(T>)>) Interface See Also Send Feedback
Processes a publishing event.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Handle(
    T obj
)
Visual Basic (Declaration)
Sub Handle ( _
    obj As T _
)
Visual C++
void Handle(
    T obj
)

Parameters

obj
Type: T
Event that the subscribers can process.

See Also

ISubscribeable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ISubscribeable(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ISubscribeable<(Of <(T>)>) Properties
ISubscribeable<(Of <(T>)>) Interface See Also Send Feedback

The ISubscribeable<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored.

See Also

ISubscribeable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Filter Property

[image]

Enterprise SDK 8.0 Reference API
ISubscribeable<(Of <(T>)>)..::.Filter Property
ISubscribeable<(Of <(T>)>) Interface See Also Send Feedback
Returns the filter predicate which indicates whether publishing event should be processed or ignored.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IPredicatable<T> Filter { get; }
Visual Basic (Declaration)
ReadOnly Property Filter As IPredicatable(Of T)
Visual C++
property IPredicatable<T>^ Filter {
    IPredicatable<T>^ get ();
}

See Also

ISubscribeable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ItemLocation Enumeration

[image]

Enterprise SDK 8.0 Reference API
ItemLocation Enumeration
See Also Send Feedback
Enumerate for location of subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[FlagsAttribute]
public enum ItemLocation
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration ItemLocation
Visual C++
[FlagsAttribute]
public enum class ItemLocation

Members

Member name | Description
Internal |
External |
All |

See Also

Genesyslab.Enterprise.Model.ComponentModel Namespace


ITransformer(TTarget, TSource) Interface

[image]

Enterprise SDK 8.0 Reference API
ITransformer<(Of <(TTarget, TSource>)>) Interface
Members See Also Send Feedback
Objects transformer.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface ITransformer<TTarget, TSource>
Visual Basic (Declaration)
Public Interface ITransformer(Of TTarget, TSource)
Visual C++
generic<typename TTarget, typename TSource>
public interface class ITransformer

Type Parameters

TTarget
Target type.
TSource
Source type.

See Also

ITransformer<(Of <(TTarget, TSource>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


ITransformer(TTarget, TSource) Members

[image] [image]

Enterprise SDK 8.0 Reference API
ITransformer<(Of <(TTarget, TSource>)>) Members
ITransformer<(Of <(TTarget, TSource>)>) Interface Methods See Also Send Feedback

The ITransformer<(Of <(TTarget, TSource>)>) type exposes the following members.

Methods

Name | Description
Transform | Thransforms the source object to target object.

See Also

ITransformer<(Of <(TTarget, TSource>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ITransformer(TTarget, TSource) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ITransformer<(Of <(TTarget, TSource>)>) Methods
ITransformer<(Of <(TTarget, TSource>)>) Interface See Also Send Feedback

The ITransformer<(Of <(TTarget, TSource>)>) type exposes the following members.

Methods

Name | Description
Transform | Thransforms the source object to target object.

See Also

ITransformer<(Of <(TTarget, TSource>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Transform Method

[image]

Enterprise SDK 8.0 Reference API
ITransformer<(Of <(TTarget, TSource>)>)..::.Transform Method
ITransformer<(Of <(TTarget, TSource>)>) Interface See Also Send Feedback
Thransforms the source object to target object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
TTarget Transform(
    TSource source
)
Visual Basic (Declaration)
Function Transform ( _
    source As TSource _
) As TTarget
Visual C++
TTarget Transform(
    TSource source
)

Parameters

source
Type: TSource
The object to transform.

Return Value

Target object.

See Also

ITransformer<(Of <(TTarget, TSource>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


MessageFilterWrapper(T) Class

[image]

Enterprise SDK 8.0 Reference API
MessageFilterWrapper<(Of <(T>)>) Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.MessageFilterWrapper`1"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public class MessageFilterWrapper<T> : IPredicatable<T>
Visual Basic (Declaration)
Public Class MessageFilterWrapper(Of T) _
    Implements IPredicatable(Of T)
Visual C++
generic<typename T>
public ref class MessageFilterWrapper : IPredicatable<T>

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.MessageFilterWrapper`1"]

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Model.ComponentModel..::.MessageFilterWrapper<(Of <(T>)>)

See Also

MessageFilterWrapper<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


MessageFilterWrapper(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
MessageFilterWrapper<(Of <(T>)>) Members
MessageFilterWrapper<(Of <(T>)>) Class Constructors Methods Properties See Also Send Feedback

The MessageFilterWrapper<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
MessageFilterWrapper<(Of <(T>)>) |

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Predicate |

See Also

MessageFilterWrapper<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


MessageFilterWrapper(T) Constructor

[image]

Enterprise SDK 8.0 Reference API
MessageFilterWrapper<(Of <(T>)>) Constructor
MessageFilterWrapper<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.MessageFilterWrapper`1.#ctor(Genesyslab.Platform.ApplicationBlocks.Commons.IPredicate{`0})"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public MessageFilterWrapper(
    IPredicate<T> predicate
)
Visual Basic (Declaration)
Public Sub New ( _
    predicate As IPredicate(Of T) _
)
Visual C++
public:
MessageFilterWrapper(
    IPredicate<T>^ predicate
)

Parameters

predicate
Type: IPredicate<(Of <( T >)>)

[Missing <param name="predicate"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.MessageFilterWrapper`1.#ctor(Genesyslab.Platform.ApplicationBlocks.Commons.IPredicate{`0})"]

See Also

MessageFilterWrapper<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


MessageFilterWrapper(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
MessageFilterWrapper<(Of <(T>)>) Methods
MessageFilterWrapper<(Of <(T>)>) Class See Also Send Feedback

The MessageFilterWrapper<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MessageFilterWrapper<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Equals Method

[image]

Enterprise SDK 8.0 Reference API
MessageFilterWrapper<(Of <(T>)>)..::.Equals Method
MessageFilterWrapper<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.MessageFilterWrapper`1.Equals(System.Object)"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.MessageFilterWrapper`1.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.MessageFilterWrapper`1.Equals(System.Object)"]

See Also

MessageFilterWrapper<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetHashCode Method

[image]

Enterprise SDK 8.0 Reference API
MessageFilterWrapper<(Of <(T>)>)..::.GetHashCode Method
MessageFilterWrapper<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.MessageFilterWrapper`1.GetHashCode"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.MessageFilterWrapper`1.GetHashCode"]

See Also

MessageFilterWrapper<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Invoke Method

[image]

Enterprise SDK 8.0 Reference API
MessageFilterWrapper<(Of <(T>)>)..::.Invoke Method
MessageFilterWrapper<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.MessageFilterWrapper`1.Invoke(`0)"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool Invoke(
    T obj
)
Visual Basic (Declaration)
Public Function Invoke ( _
    obj As T _
) As Boolean
Visual C++
public:
virtual bool Invoke(
    T obj
) sealed

Parameters

obj
Type: T

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.MessageFilterWrapper`1.Invoke(`0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.MessageFilterWrapper`1.Invoke(`0)"]

Implements

IPredicatable<(Of <(T>)>)..::.Invoke(T)

See Also

MessageFilterWrapper<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


MessageFilterWrapper(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
MessageFilterWrapper<(Of <(T>)>) Properties
MessageFilterWrapper<(Of <(T>)>) Class See Also Send Feedback

The MessageFilterWrapper<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Predicate |

See Also

MessageFilterWrapper<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Predicate Property

[image]

Enterprise SDK 8.0 Reference API
MessageFilterWrapper<(Of <(T>)>)..::.Predicate Property
MessageFilterWrapper<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.ComponentModel.MessageFilterWrapper`1.Predicate"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IPredicate<T> Predicate { get; }
Visual Basic (Declaration)
Public ReadOnly Property Predicate As IPredicate(Of T)
Visual C++
public:
property IPredicate<T>^ Predicate {
    IPredicate<T>^ get ();
}

See Also

MessageFilterWrapper<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


PartyType Enumeration

[image]

Enterprise SDK 8.0 Reference API
PartyType Enumeration
See Also Send Feedback
Lists the possible party types.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum PartyType
Visual Basic (Declaration)
Public Enumeration PartyType
Visual C++
public enum class PartyType

Members

Member name | Description
Unknown | Constant for unknown type.
Client | Constant for client type.
Agent | Constant for agent type.
Supervisor | Constant for supervisor type.
External | Constant for external type.

See Also

Genesyslab.Enterprise.Model.ComponentModel Namespace


PredicatableWrapper(T, S) Class

[image]

Enterprise SDK 8.0 Reference API
PredicatableWrapper<(Of <(T, S>)>) Class
Members See Also Send Feedback
IPredicatable wrapper.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public class PredicatableWrapper<T, S> : IPredicatable<T>
Visual Basic (Declaration)
Public Class PredicatableWrapper(Of T, S) _
    Implements IPredicatable(Of T)
Visual C++
generic<typename T, typename S>
public ref class PredicatableWrapper : IPredicatable<T>

Type Parameters

T
Targer data type.
S
Source data type.

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Model.ComponentModel..::.PredicatableWrapper<(Of <(T, S>)>)

See Also

PredicatableWrapper<(Of <(T, S>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


PredicatableWrapper(T, S) Members

[image] [image]

Enterprise SDK 8.0 Reference API
PredicatableWrapper<(Of <(T, S>)>) Members
PredicatableWrapper<(Of <(T, S>)>) Class Constructors Methods See Also Send Feedback

The PredicatableWrapper<(Of <(T, S>)>) type exposes the following members.

Constructors

Name | Description
PredicatableWrapper<(Of <(T, S>)>) | PredicatableWrapper constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Invoke the source condition.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredicatableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


PredicatableWrapper(T, S) Constructor

[image]

Enterprise SDK 8.0 Reference API
PredicatableWrapper<(Of <(T, S>)>) Constructor
PredicatableWrapper<(Of <(T, S>)>) Class See Also Send Feedback
PredicatableWrapper constructor.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public PredicatableWrapper(
    ITransformer<S, T> transformer,
    IPredicatable<S> predicate
)
Visual Basic (Declaration)
Public Sub New ( _
    transformer As ITransformer(Of S, T), _
    predicate As IPredicatable(Of S) _
)
Visual C++
public:
PredicatableWrapper(
    ITransformer<S, T>^ transformer,
    IPredicatable<S>^ predicate
)

Parameters

transformer
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ITransformer <(Of <( S, T >)>)
Data transformer.
predicate
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IPredicatable <(Of <( S >)>)
The filter to wrap.

See Also

PredicatableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


PredicatableWrapper(T, S) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
PredicatableWrapper<(Of <(T, S>)>) Methods
PredicatableWrapper<(Of <(T, S>)>) Class See Also Send Feedback

The PredicatableWrapper<(Of <(T, S>)>) type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Invoke the source condition.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredicatableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Invoke Method

[image]

Enterprise SDK 8.0 Reference API
PredicatableWrapper<(Of <(T, S>)>)..::.Invoke Method
PredicatableWrapper<(Of <(T, S>)>) Class See Also Send Feedback
Invoke the source condition.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool Invoke(
    T obj
)
Visual Basic (Declaration)
Public Function Invoke ( _
    obj As T _
) As Boolean
Visual C++
public:
virtual bool Invoke(
    T obj
) sealed

Parameters

obj
Type: T
Data.

Return Value

The result of the condition.

Implements

IPredicatable<(Of <(T>)>)..::.Invoke(T)

See Also

PredicatableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


StateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
StateType Enumeration
See Also Send Feedback
Enumerate the state type of ICapability.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum StateType
Visual Basic (Declaration)
Public Enumeration StateType
Visual C++
public enum class StateType

Members

Member name | Description
Inactive |
Disabled |
Enabled |

See Also

Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscribeableWrapper(T, S) Class

[image]

Enterprise SDK 8.0 Reference API
SubscribeableWrapper<(Of <(T, S>)>) Class
Members See Also Send Feedback
ISubscribeable wrapper.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public class SubscribeableWrapper<T, S> : ISubscribeable<T>
Visual Basic (Declaration)
Public Class SubscribeableWrapper(Of T, S) _
    Implements ISubscribeable(Of T)
Visual C++
generic<typename T, typename S>
public ref class SubscribeableWrapper : ISubscribeable<T>

Type Parameters

T
Targer data type.
S
Source data type.

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Model.ComponentModel..::.SubscribeableWrapper<(Of <(T, S>)>)

See Also

SubscribeableWrapper<(Of <(T, S>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscribeableWrapper(T, S) Members

[image] [image]

Enterprise SDK 8.0 Reference API
SubscribeableWrapper<(Of <(T, S>)>) Members
SubscribeableWrapper<(Of <(T, S>)>) Class Constructors Methods Properties See Also Send Feedback

The SubscribeableWrapper<(Of <(T, S>)>) type exposes the following members.

Constructors

Name | Description
SubscribeableWrapper<(Of <(T, S>)>) | SubscribeableWrapper constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Handle | Publish the data.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Filter | Wrapped filter predicate.

See Also

SubscribeableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscribeableWrapper(T, S) Constructor

[image]

Enterprise SDK 8.0 Reference API
SubscribeableWrapper<(Of <(T, S>)>) Constructor
SubscribeableWrapper<(Of <(T, S>)>) Class See Also Send Feedback
SubscribeableWrapper constructor.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public SubscribeableWrapper(
    ITransformer<S, T> transformer,
    ISubscribeable<S> subscriber
)
Visual Basic (Declaration)
Public Sub New ( _
    transformer As ITransformer(Of S, T), _
    subscriber As ISubscribeable(Of S) _
)
Visual C++
public:
SubscribeableWrapper(
    ITransformer<S, T>^ transformer,
    ISubscribeable<S>^ subscriber
)

Parameters

transformer
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ITransformer <(Of <( S, T >)>)
Data transformer.
subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( S >)>)
The subscriber to wrap.

See Also

SubscribeableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscribeableWrapper(T, S) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SubscribeableWrapper<(Of <(T, S>)>) Methods
SubscribeableWrapper<(Of <(T, S>)>) Class See Also Send Feedback

The SubscribeableWrapper<(Of <(T, S>)>) type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Handle | Publish the data.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubscribeableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Handle Method

[image]

Enterprise SDK 8.0 Reference API
SubscribeableWrapper<(Of <(T, S>)>)..::.Handle Method
SubscribeableWrapper<(Of <(T, S>)>) Class See Also Send Feedback
Publish the data.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Handle(
    T obj
)
Visual Basic (Declaration)
Public Sub Handle ( _
    obj As T _
)
Visual C++
public:
virtual void Handle(
    T obj
) sealed

Parameters

obj
Type: T
Data.

Implements

ISubscribeable<(Of <(T>)>)..::.Handle(T)

See Also

SubscribeableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscribeableWrapper(T, S) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SubscribeableWrapper<(Of <(T, S>)>) Properties
SubscribeableWrapper<(Of <(T, S>)>) Class See Also Send Feedback

The SubscribeableWrapper<(Of <(T, S>)>) type exposes the following members.

Properties

Name | Description
Filter | Wrapped filter predicate.

See Also

SubscribeableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Filter Property

[image]

Enterprise SDK 8.0 Reference API
SubscribeableWrapper<(Of <(T, S>)>)..::.Filter Property
SubscribeableWrapper<(Of <(T, S>)>) Class See Also Send Feedback
Wrapped filter predicate.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IPredicatable<T> Filter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filter As IPredicatable(Of T)
Visual C++
public:
virtual property IPredicatable<T>^ Filter {
    IPredicatable<T>^ get () sealed;
}

Implements

ISubscribeable<(Of <(T>)>)..::.Filter

See Also

SubscribeableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscriptionServiceWrapper(T) Class

[image]

Enterprise SDK 8.0 Reference API
SubscriptionServiceWrapper<(Of <(T>)>) Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public class SubscriptionServiceWrapper<T> : IServiceSubscriber<T>
Visual Basic (Declaration)
Public Class SubscriptionServiceWrapper(Of T) _
    Implements IServiceSubscriber(Of T)
Visual C++
generic<typename T>
public ref class SubscriptionServiceWrapper : IServiceSubscriber<T>

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1"]

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Model.ComponentModel..::.SubscriptionServiceWrapper<(Of <(T>)>)

See Also

SubscriptionServiceWrapper<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscriptionServiceWrapper(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
SubscriptionServiceWrapper<(Of <(T>)>) Members
SubscriptionServiceWrapper<(Of <(T>)>) Class Constructors Methods Properties See Also Send Feedback

The SubscriptionServiceWrapper<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
SubscriptionServiceWrapper<(Of <(T>)>) |

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Register | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unregister | Overloaded.

Properties

Name | Description
SubscriptionBroker |

See Also

SubscriptionServiceWrapper<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscriptionServiceWrapper(T) Constructor

[image]

Enterprise SDK 8.0 Reference API
SubscriptionServiceWrapper<(Of <(T>)>) Constructor
SubscriptionServiceWrapper<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.#ctor(Genesyslab.Platform.ApplicationBlocks.Commons.Broker.ISubscriptionService)"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public SubscriptionServiceWrapper(
    ISubscriptionService subscriptionService
)
Visual Basic (Declaration)
Public Sub New ( _
    subscriptionService As ISubscriptionService _
)
Visual C++
public:
SubscriptionServiceWrapper(
    ISubscriptionService^ subscriptionService
)

Parameters

subscriptionService
Type: ISubscriptionService

[Missing <param name="subscriptionService"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.#ctor(Genesyslab.Platform.ApplicationBlocks.Commons.Broker.ISubscriptionService)"]

See Also

SubscriptionServiceWrapper<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscriptionServiceWrapper(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SubscriptionServiceWrapper<(Of <(T>)>) Methods
SubscriptionServiceWrapper<(Of <(T>)>) Class See Also Send Feedback

The SubscriptionServiceWrapper<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Register | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unregister | Overloaded.

See Also

SubscriptionServiceWrapper<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Equals Method

[image]

Enterprise SDK 8.0 Reference API
SubscriptionServiceWrapper<(Of <(T>)>)..::.Equals Method
SubscriptionServiceWrapper<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.Equals(System.Object)"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.Equals(System.Object)"]

See Also

SubscriptionServiceWrapper<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetHashCode Method

[image]

Enterprise SDK 8.0 Reference API
SubscriptionServiceWrapper<(Of <(T>)>)..::.GetHashCode Method
SubscriptionServiceWrapper<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.GetHashCode"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.GetHashCode"]

See Also

SubscriptionServiceWrapper<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method

[image] [image]

Enterprise SDK 8.0 Reference API
SubscriptionServiceWrapper<(Of <(T>)>)..::.Register Method
SubscriptionServiceWrapper<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Register(ISubscribeable<(Of <(T>)>)) |
Register(Action<(Of <(T>)>)) |
Register(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>)) |

See Also

SubscriptionServiceWrapper<(Of <(T>)>) Class
SubscriptionServiceWrapper<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
SubscriptionServiceWrapper<(Of <(T>)>)..::.Register Method (ISubscribeable<(Of <(T>)>))
SubscriptionServiceWrapper<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.Register(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{`0})"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Register(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Public Sub Register ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
public:
virtual void Register(
    ISubscribeable<T>^ subscriber
) sealed

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( T >)>)

[Missing <param name="subscriber"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.Register(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{`0})"]

Implements

IServiceSubscriber<(Of <(T>)>)..::.Register(ISubscribeable<(Of <(T>)>))

See Also

SubscriptionServiceWrapper<(Of <(T>)>) Class
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
SubscriptionServiceWrapper<(Of <(T>)>)..::.Register Method (Action<(Of <(T>)>))
SubscriptionServiceWrapper<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.Register(System.Action{`0})"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Register(
    Action<T> handler
)
Visual Basic (Declaration)
Public Sub Register ( _
    handler As Action(Of T) _
)
Visual C++
public:
virtual void Register(
    Action<T>^ handler
) sealed

Parameters

handler
Type: System..::.Action<(Of <( T >)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.Register(System.Action{`0})"]

Implements

IServiceSubscriber<(Of <(T>)>)..::.Register(Action<(Of <(T>)>))

See Also

SubscriptionServiceWrapper<(Of <(T>)>) Class
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (Action(T), IPredicatable(T))

[image]

Enterprise SDK 8.0 Reference API
SubscriptionServiceWrapper<(Of <(T>)>)..::.Register Method (Action<(Of <(T>)>), IPredicatable<(Of <(T>)>))
SubscriptionServiceWrapper<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.Register(System.Action{`0},Genesyslab.Enterprise.Model.ComponentModel.IPredicatable{`0})"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Register(
    Action<T> handler,
    IPredicatable<T> filter
)
Visual Basic (Declaration)
Public Sub Register ( _
    handler As Action(Of T), _
    filter As IPredicatable(Of T) _
)
Visual C++
public:
virtual void Register(
    Action<T>^ handler,
    IPredicatable<T>^ filter
) sealed

Parameters

handler
Type: System..::.Action<(Of <( T >)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.Register(System.Action{`0},Genesyslab.Enterprise.Model.ComponentModel.IPredicatable{`0})"]

filter
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IPredicatable <(Of <( T >)>)

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.Register(System.Action{`0},Genesyslab.Enterprise.Model.ComponentModel.IPredicatable{`0})"]

Implements

IServiceSubscriber<(Of <(T>)>)..::.Register(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>))

See Also

SubscriptionServiceWrapper<(Of <(T>)>) Class
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method

[image] [image]

Enterprise SDK 8.0 Reference API
SubscriptionServiceWrapper<(Of <(T>)>)..::.Unregister Method
SubscriptionServiceWrapper<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Unregister(ISubscribeable<(Of <(T>)>)) |
Unregister(Action<(Of <(T>)>)) |

See Also

SubscriptionServiceWrapper<(Of <(T>)>) Class
SubscriptionServiceWrapper<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
SubscriptionServiceWrapper<(Of <(T>)>)..::.Unregister Method (ISubscribeable<(Of <(T>)>))
SubscriptionServiceWrapper<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.Unregister(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{`0})"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Unregister(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Public Sub Unregister ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
public:
virtual void Unregister(
    ISubscribeable<T>^ subscriber
) sealed

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( T >)>)

[Missing <param name="subscriber"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.Unregister(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{`0})"]

Implements

IServiceSubscriber<(Of <(T>)>)..::.Unregister(ISubscribeable<(Of <(T>)>))

See Also

SubscriptionServiceWrapper<(Of <(T>)>) Class
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
SubscriptionServiceWrapper<(Of <(T>)>)..::.Unregister Method (Action<(Of <(T>)>))
SubscriptionServiceWrapper<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.Unregister(System.Action{`0})"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Unregister(
    Action<T> handler
)
Visual Basic (Declaration)
Public Sub Unregister ( _
    handler As Action(Of T) _
)
Visual C++
public:
virtual void Unregister(
    Action<T>^ handler
) sealed

Parameters

handler
Type: System..::.Action<(Of <( T >)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.Unregister(System.Action{`0})"]

Implements

IServiceSubscriber<(Of <(T>)>)..::.Unregister(Action<(Of <(T>)>))

See Also

SubscriptionServiceWrapper<(Of <(T>)>) Class
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscriptionServiceWrapper(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SubscriptionServiceWrapper<(Of <(T>)>) Properties
SubscriptionServiceWrapper<(Of <(T>)>) Class See Also Send Feedback

The SubscriptionServiceWrapper<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
SubscriptionBroker |

See Also

SubscriptionServiceWrapper<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscriptionBroker Property

[image]

Enterprise SDK 8.0 Reference API
SubscriptionServiceWrapper<(Of <(T>)>)..::.SubscriptionBroker Property
SubscriptionServiceWrapper<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.ComponentModel.SubscriptionServiceWrapper`1.SubscriptionBroker"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ISubscriptionService SubscriptionBroker { get; }
Visual Basic (Declaration)
Public ReadOnly Property SubscriptionBroker As ISubscriptionService
Visual C++
public:
virtual property ISubscriptionService^ SubscriptionBroker {
    ISubscriptionService^ get () sealed;
}

Implements

IServiceSubscriber<(Of <(T>)>)..::.SubscriptionBroker

See Also

SubscriptionServiceWrapper<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Visibility Enumeration

[image]

Enterprise SDK 8.0 Reference API
Visibility Enumeration
See Also Send Feedback
Lists the possible values for the party's visibility.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum Visibility
Visual Basic (Declaration)
Public Enumeration Visibility
Visual C++
public enum class Visibility

Members

Member name | Description
Unknown | Constant for unknown visibility.
All | Constant for all visibility (conference).
Int | Constant for internal visibility (coaching).
Vip | Constant for secrete intrusion visibility (monitor).

See Also

Genesyslab.Enterprise.Model.ComponentModel Namespace


Genesyslab.Enterprise.Model.Device Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Device Namespace
Send Feedback

Interfaces

Interface | Description
IDevice | Describes a device. To learn how to create a device, or how to register for its events, see the summary descriptions and examples of [!:Genesyslab.Enterprise.Services.IDeviceService].

Enumerations

Enumeration | Description
DeviceStateType | Enumeration for the possible states of a device.
DeviceType | Enumeration for the device types that you can find in the supported switches.
ForwardModeType | Enumeration types for the forward mode.


DeviceStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
DeviceStateType Enumeration
See Also Send Feedback
Enumeration for the possible states of a device.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[SerializableAttribute]
public enum DeviceStateType
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration DeviceStateType
Visual C++
[SerializableAttribute]
public enum class DeviceStateType

Members

Member name | Description
Unknown |
OutOfService |
Registering |
Registered |
NotRegistered |
Unavailable |

See Also

Genesyslab.Enterprise.Model.Device Namespace


DeviceType Enumeration

[image]

Enterprise SDK 8.0 Reference API
DeviceType Enumeration
See Also Send Feedback
Enumeration for the device types that you can find in the supported switches.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum DeviceType
Visual Basic (Declaration)
Public Enumeration DeviceType
Visual C++
public enum class DeviceType

Members

Member name | Description
Unknown |
Acdposition |
Extension |

See Also

Genesyslab.Enterprise.Model.Device Namespace


ForwardModeType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ForwardModeType Enumeration
See Also Send Feedback
Enumeration types for the forward mode.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum ForwardModeType
Visual Basic (Declaration)
Public Enumeration ForwardModeType
Visual C++
public enum class ForwardModeType

Members

Member name | Description
Unknown |
None |
Unconditional |
OnBusy |
OnNoAnswer |
OnBusyAndNoAnswer |
SendAllCalls |

See Also

Genesyslab.Enterprise.Model.Device Namespace


IDevice Interface

[image]

Enterprise SDK 8.0 Reference API
IDevice Interface
Members See Also Send Feedback
Describes a device. To learn how to create a device, or how to register for its events, see the summary descriptions and examples of [!:Genesyslab.Enterprise.Services.IDeviceService].

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IDevice : ISerializable
Visual Basic (Declaration)
Public Interface IDevice _
    Implements ISerializable
Visual C++
public interface class IDevice : ISerializable

See Also

IDevice Members
Genesyslab.Enterprise.Model.Device Namespace


IDevice Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDevice Members
IDevice Interface Methods Properties See Also Send Feedback

The IDevice type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

Properties

Name | Description
ActionsTransitions | The list of actions that the application can do with the device. According to events, strategies, and capabilities, this property updates. Some action transitions can be temporarily unavailable according to the object status. For instance, if the device is configured in the CME to accept a single call, and if the device is already busy, you can't create a new call on this device. handling
ActiveChannels | List of active channels for this device.
Attributes |
Capabilities | Capabilities of the device. These capabilities list the features that you can use on the device, for instance sms, fax, e-mail.
Context | The device context, a set of information about the device, such as its location, its peripheral types (mobile phone, iphone), and so on.
Controller | Returns the state controller of the object.
FQName | Fully Qualified Name. This is the unique identifier of the object instance. In the device's particular case, the FQ name follows this syntax: dn@switch_name.
Group | Group of subdevices which compose this device.
Identity | Identity in relation with the device.
Name | Name of the object. This name is not always unique, for instance, in multi-tenant configurations, or in multiple switch configurations.
State | Device status.
Strategy | List of stategies handled by the object.

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


IDevice Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDevice Methods
IDevice Interface See Also Send Feedback

The IDevice type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


IDevice Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDevice Properties
IDevice Interface See Also Send Feedback

The IDevice type exposes the following members.

Properties

Name | Description
ActionsTransitions | The list of actions that the application can do with the device. According to events, strategies, and capabilities, this property updates. Some action transitions can be temporarily unavailable according to the object status. For instance, if the device is configured in the CME to accept a single call, and if the device is already busy, you can't create a new call on this device. handling
ActiveChannels | List of active channels for this device.
Attributes |
Capabilities | Capabilities of the device. These capabilities list the features that you can use on the device, for instance sms, fax, e-mail.
Context | The device context, a set of information about the device, such as its location, its peripheral types (mobile phone, iphone), and so on.
Controller | Returns the state controller of the object.
FQName | Fully Qualified Name. This is the unique identifier of the object instance. In the device's particular case, the FQ name follows this syntax: dn@switch_name.
Group | Group of subdevices which compose this device.
Identity | Identity in relation with the device.
Name | Name of the object. This name is not always unique, for instance, in multi-tenant configurations, or in multiple switch configurations.
State | Device status.
Strategy | List of stategies handled by the object.

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


ActionsTransitions Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.ActionsTransitions Property
IDevice Interface See Also Send Feedback
The list of actions that the application can do with the device. According to events, strategies, and capabilities, this property updates. Some action transitions can be temporarily unavailable according to the object status. For instance, if the device is configured in the CME to accept a single call, and if the device is already busy, you can't create a new call on this device. handling

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool[] ActionsTransitions { get; }
Visual Basic (Declaration)
ReadOnly Property ActionsTransitions As Boolean()
Visual C++
property array<bool>^ ActionsTransitions {
    array<bool>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


ActiveChannels Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.ActiveChannels Property
IDevice Interface See Also Send Feedback
List of active channels for this device.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Uri[] ActiveChannels { get; }
Visual Basic (Declaration)
ReadOnly Property ActiveChannels As Uri()
Visual C++
property array<Uri^>^ ActiveChannels {
    array<Uri^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Attributes Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Attributes Property
IDevice Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Device.IDevice.Attributes"]

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDataBag<IAttributeDataManager<IDynamicAttribute>> Attributes { get; }
Visual Basic (Declaration)
ReadOnly Property Attributes As IDataBag(Of IAttributeDataManager(Of IDynamicAttribute))
Visual C++
property IDataBag<IAttributeDataManager<IDynamicAttribute^>^>^ Attributes {
    IDataBag<IAttributeDataManager<IDynamicAttribute^>^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Capabilities Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Capabilities Property
IDevice Interface See Also Send Feedback
Capabilities of the device. These capabilities list the features that you can use on the device, for instance sms, fax, e-mail.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionary<string, ICapability> Capabilities { get; }
Visual Basic (Declaration)
ReadOnly Property Capabilities As IDictionary(Of String, ICapability)
Visual C++
property IDictionary<String^, ICapability^>^ Capabilities {
    IDictionary<String^, ICapability^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Context Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Context Property
IDevice Interface See Also Send Feedback
The device context, a set of information about the device, such as its location, its peripheral types (mobile phone, iphone), and so on.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionary<string, IContext> Context { get; }
Visual Basic (Declaration)
ReadOnly Property Context As IDictionary(Of String, IContext)
Visual C++
property IDictionary<String^, IContext^>^ Context {
    IDictionary<String^, IContext^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Controller Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Controller Property
IDevice Interface See Also Send Feedback
Returns the state controller of the object.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object Controller { get; }
Visual Basic (Declaration)
ReadOnly Property Controller As Object
Visual C++
property Object^ Controller {
    Object^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.FQName Property
IDevice Interface See Also Send Feedback

Fully Qualified Name. This is the unique identifier of the object instance. In the device's particular case, the FQ name follows this syntax: dn@switch_name.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string FQName { get; }
Visual Basic (Declaration)
ReadOnly Property FQName As String
Visual C++
property String^ FQName {
    String^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Group Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Group Property
IDevice Interface See Also Send Feedback
Group of subdevices which compose this device.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionary<string, IDevice> Group { get; }
Visual Basic (Declaration)
ReadOnly Property Group As IDictionary(Of String, IDevice)
Visual C++
property IDictionary<String^, IDevice^>^ Group {
    IDictionary<String^, IDevice^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Identity Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Identity Property
IDevice Interface See Also Send Feedback
Identity in relation with the device.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionary<string, IIdentity> Identity { get; }
Visual Basic (Declaration)
ReadOnly Property Identity As IDictionary(Of String, IIdentity)
Visual C++
property IDictionary<String^, IIdentity^>^ Identity {
    IDictionary<String^, IIdentity^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Name Property
IDevice Interface See Also Send Feedback
Name of the object. This name is not always unique, for instance, in multi-tenant configurations, or in multiple switch configurations.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.State Property
IDevice Interface See Also Send Feedback
Device status.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
DeviceStateType State { get; }
Visual Basic (Declaration)
ReadOnly Property State As DeviceStateType
Visual C++
property DeviceStateType State {
    DeviceStateType get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Strategy Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Strategy Property
IDevice Interface See Also Send Feedback
List of stategies handled by the object.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ICollection<IStrategy> Strategy { get; }
Visual Basic (Declaration)
ReadOnly Property Strategy As ICollection(Of IStrategy)
Visual C++
property ICollection<IStrategy^>^ Strategy {
    ICollection<IStrategy^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Genesyslab.Enterprise.Model.Envelope Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Envelope Namespace
Send Feedback

Interfaces

Interface Description
IEnvelope<(Of <(T>)>)
Describes the event that occurred on the related published object, and contains the updated copy of this object.

This container is divided into two parts:

  • Header Details the event information.
  • BodyCopy of the published object.
Note: Make sure that you use the returned object copy to update accordingly your application and in further calls to Enterprise SDK methods. Do not keep a reference on a deprecated copy: if a new event occurs

IHeader
Describes the event which occurred on a published object. This interface details what happened to this object (modification if State value is 0, else this is an error) and provides its context as the list of the related protocol messages which resulted in this E-SDK event.
  • The last protocol message is available in CurrentContext.
  • Other related messages are available in the ContextByIndex(Int32).
IPayLoadContext
Describes an event and its associated protocol message (msg).

Enumerations

Enumeration | Description
EnvelopeStateType | Status of the envelope.


EnvelopeStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
EnvelopeStateType Enumeration
See Also Send Feedback
Status of the envelope.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum EnvelopeStateType
Visual Basic (Declaration)
Public Enumeration EnvelopeStateType
Visual C++
public enum class EnvelopeStateType

Members

Member name | Description
Unknown | Unknown.
Created | Creation.
Complete | Complete.
Read | Read.
Written | Written.
Copied | Copied.
Closed | Closed.

See Also

Genesyslab.Enterprise.Model.Envelope Namespace


IEnvelope(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>) Interface
Members See Also Send Feedback
Describes the event that occurred on the related published object, and contains the updated copy of this object.

This container is divided into two parts:

  • Header Details the event information.
  • BodyCopy of the published object.
Note: Make sure that you use the returned object copy to update accordingly your application and in further calls to Enterprise SDK methods. Do not keep a reference on a deprecated copy: if a new event occurs

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IEnvelope<T>
Visual Basic (Declaration)
Public Interface IEnvelope(Of T)
Visual C++
generic<typename T>
public interface class IEnvelope

Type Parameters

T
Type of the published object.

Remarks

To receive events, your application must register a callback method with the service. For instance, see the IChannelService description to read an example of callback registration on a given channel.

See Also

IEnvelope<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Envelope Namespace


IEnvelope(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>) Members
IEnvelope<(Of <(T>)>) Interface Properties See Also Send Feedback

The IEnvelope<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Body | Returns the copy of the published object.
EnvelopeState | Status of this envelope.
Header | Details the event information.

See Also

IEnvelope<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IEnvelope(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>) Properties
IEnvelope<(Of <(T>)>) Interface See Also Send Feedback

The IEnvelope<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Body | Returns the copy of the published object.
EnvelopeState | Status of this envelope.
Header | Details the event information.

See Also

IEnvelope<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Envelope Namespace


Body Property

[image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>)..::.Body Property
IEnvelope<(Of <(T>)>) Interface See Also Send Feedback
Returns the copy of the published object.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
T Body { get; }
Visual Basic (Declaration)
ReadOnly Property Body As T
Visual C++
property T Body {
    T get ();
}

See Also

IEnvelope<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Envelope Namespace


EnvelopeState Property

[image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>)..::.EnvelopeState Property
IEnvelope<(Of <(T>)>) Interface See Also Send Feedback
Status of this envelope.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
EnvelopeStateType EnvelopeState { get; }
Visual Basic (Declaration)
ReadOnly Property EnvelopeState As EnvelopeStateType
Visual C++
property EnvelopeStateType EnvelopeState {
    EnvelopeStateType get ();
}

See Also

IEnvelope<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Envelope Namespace


Header Property

[image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>)..::.Header Property
IEnvelope<(Of <(T>)>) Interface See Also Send Feedback
Details the event information.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IHeader Header { get; }
Visual Basic (Declaration)
ReadOnly Property Header As IHeader
Visual C++
property IHeader^ Header {
    IHeader^ get ();
}

See Also

IEnvelope<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IHeader Interface

[image]

Enterprise SDK 8.0 Reference API
IHeader Interface
Members See Also Send Feedback
Describes the event which occurred on a published object. This interface details what happened to this object (modification if State value is 0, else this is an error) and provides its context as the list of the related protocol messages which resulted in this E-SDK event.
  • The last protocol message is available in CurrentContext.
  • Other related messages are available in the ContextByIndex(Int32).

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IHeader
Visual Basic (Declaration)
Public Interface IHeader
Visual C++
public interface class IHeader

See Also

IHeader Members
Genesyslab.Enterprise.Model.Envelope Namespace


IHeader Members

[image] [image]

Enterprise SDK 8.0 Reference API
IHeader Members
IHeader Interface Methods Properties See Also Send Feedback

The IHeader type exposes the following members.

Methods

Name | Description
ContextByIndex | Returns the related protocol message with the given index.

Properties

Name Description
CorrelationId
ID of the request associated with this event.
CorrelatorData
Get the related customer defined information
Count
Number of protocol messages associated with this event message.
CurrentContext
Returns the context of the last protocol message.
Message
Error message if State > 0.
SourceName
Name of the source object which published the event.
SourceUid
FQName of the source object which published the event.
State
Event state.
  • State=0: modification.
  • State>0: error code

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IHeader Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IHeader Methods
IHeader Interface See Also Send Feedback

The IHeader type exposes the following members.

Methods

Name | Description
ContextByIndex | Returns the related protocol message with the given index.

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


ContextByIndex Method

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.ContextByIndex Method
IHeader Interface See Also Send Feedback
Returns the related protocol message with the given index.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IPayLoadContext ContextByIndex(
    int index
)
Visual Basic (Declaration)
Function ContextByIndex ( _
    index As Integer _
) As IPayLoadContext
Visual C++
IPayLoadContext^ ContextByIndex(
    int index
)

Parameters

index
Type: System..::.Int32
Index of the message (range: 0-count)

Return Value

the IPayLoadContext that contains the message.

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IHeader Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IHeader Properties
IHeader Interface See Also Send Feedback

The IHeader type exposes the following members.

Properties

Name Description
CorrelationId
ID of the request associated with this event.
CorrelatorData
Get the related customer defined information
Count
Number of protocol messages associated with this event message.
CurrentContext
Returns the context of the last protocol message.
Message
Error message if State > 0.
SourceName
Name of the source object which published the event.
SourceUid
FQName of the source object which published the event.
State
Event state.
  • State=0: modification.
  • State>0: error code

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


CorrelationId Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.CorrelationId Property
IHeader Interface See Also Send Feedback
ID of the request associated with this event.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
int CorrelationId { get; }
Visual Basic (Declaration)
ReadOnly Property CorrelationId As Integer
Visual C++
property int CorrelationId {
    int get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


CorrelatorData Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.CorrelatorData Property
IHeader Interface See Also Send Feedback
Get the related customer defined information

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string CorrelatorData { get; }
Visual Basic (Declaration)
ReadOnly Property CorrelatorData As String
Visual C++
property String^ CorrelatorData {
    String^ get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.Count Property
IHeader Interface See Also Send Feedback
Number of protocol messages associated with this event message.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
int Count { get; }
Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual C++
property int Count {
    int get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


CurrentContext Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.CurrentContext Property
IHeader Interface See Also Send Feedback
Returns the context of the last protocol message.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IPayLoadContext CurrentContext { get; }
Visual Basic (Declaration)
ReadOnly Property CurrentContext As IPayLoadContext
Visual C++
property IPayLoadContext^ CurrentContext {
    IPayLoadContext^ get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


Message Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.Message Property
IHeader Interface See Also Send Feedback
Error message if State > 0.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Message { get; }
Visual Basic (Declaration)
ReadOnly Property Message As String
Visual C++
property String^ Message {
    String^ get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


SourceName Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.SourceName Property
IHeader Interface See Also Send Feedback
Name of the source object which published the event.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string SourceName { get; }
Visual Basic (Declaration)
ReadOnly Property SourceName As String
Visual C++
property String^ SourceName {
    String^ get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


SourceUid Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.SourceUid Property
IHeader Interface See Also Send Feedback
FQName of the source object which published the event.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string SourceUid { get; }
Visual Basic (Declaration)
ReadOnly Property SourceUid As String
Visual C++
property String^ SourceUid {
    String^ get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.State Property
IHeader Interface See Also Send Feedback
Event state.
  • State=0: modification.
  • State>0: error code

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
int State { get; }
Visual Basic (Declaration)
ReadOnly Property State As Integer
Visual C++
property int State {
    int get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IPayLoadContext Interface

[image]

Enterprise SDK 8.0 Reference API
IPayLoadContext Interface
Members See Also Send Feedback
Describes an event and its associated protocol message (msg).

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IPayLoadContext
Visual Basic (Declaration)
Public Interface IPayLoadContext
Visual C++
public interface class IPayLoadContext

See Also

IPayLoadContext Members
Genesyslab.Enterprise.Model.Envelope Namespace


IPayLoadContext Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPayLoadContext Members
IPayLoadContext Interface Properties See Also Send Feedback

The IPayLoadContext type exposes the following members.

Properties

Name Description
ContextState
Returns the state type of this event:
  • Unknown
  • Created
  • Updated
  • Merged
  • Deleted
  • Error
msg
Returns the raw associated PSDK message.
Reason
Returns the reason of this event update.
TimeStamp
Returns the time stamp of the object creation.

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IPayLoadContext Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IPayLoadContext Properties
IPayLoadContext Interface See Also Send Feedback

The IPayLoadContext type exposes the following members.

Properties

Name Description
ContextState
Returns the state type of this event:
  • Unknown
  • Created
  • Updated
  • Merged
  • Deleted
  • Error
msg
Returns the raw associated PSDK message.
Reason
Returns the reason of this event update.
TimeStamp
Returns the time stamp of the object creation.

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


ContextState Property

[image]

Enterprise SDK 8.0 Reference API
IPayLoadContext..::.ContextState Property
IPayLoadContext Interface See Also Send Feedback
Returns the state type of this event:
  • Unknown
  • Created
  • Updated
  • Merged
  • Deleted
  • Error

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ContextStateType ContextState { get; }
Visual Basic (Declaration)
ReadOnly Property ContextState As ContextStateType
Visual C++
property ContextStateType ContextState {
    ContextStateType get ();
}

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


msg Property

[image]

Enterprise SDK 8.0 Reference API
IPayLoadContext..::.msg Property
IPayLoadContext Interface See Also Send Feedback
Returns the raw associated PSDK message.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IMessage msg { get; }
Visual Basic (Declaration)
ReadOnly Property msg As IMessage
Visual C++
property IMessage^ msg {
    IMessage^ get ();
}

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


Reason Property

[image]

Enterprise SDK 8.0 Reference API
IPayLoadContext..::.Reason Property
IPayLoadContext Interface See Also Send Feedback
Returns the reason of this event update.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ReasonTypes Reason { get; }
Visual Basic (Declaration)
ReadOnly Property Reason As ReasonTypes
Visual C++
property ReasonTypes Reason {
    ReasonTypes get ();
}

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


TimeStamp Property

[image]

Enterprise SDK 8.0 Reference API
IPayLoadContext..::.TimeStamp Property
IPayLoadContext Interface See Also Send Feedback
Returns the time stamp of the object creation.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
long TimeStamp { get; }
Visual Basic (Declaration)
ReadOnly Property TimeStamp As Long
Visual C++
property long long TimeStamp {
    long long get ();
}

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


Genesyslab.Enterprise.Model.Identity Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Identity Namespace
Send Feedback

Interfaces

Interface | Description
IAlias | Describes an alias associated with an identity.
IAliasManager | Manages the aliases of an existing identity.
ICredential | Describes credentials.
IEntity | Describes a person as an entity (first name, last name, IDs) with associated business values.
IIdentity | Describes an identity.
IIdentityType | Identity type.

Enumerations

Enumeration | Description
WorkMode | Describes the agent's workmode.


IAlias Interface

[image]

Enterprise SDK 8.0 Reference API
IAlias Interface
Members See Also Send Feedback
Describes an alias associated with an identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IAlias
Visual Basic (Declaration)
Public Interface IAlias
Visual C++
public interface class IAlias

See Also

IAlias Members
Genesyslab.Enterprise.Model.Identity Namespace


IAlias Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAlias Members
IAlias Interface Properties See Also Send Feedback

The IAlias type exposes the following members.

Properties

Name | Description
Name | Alias name.

See Also

IAlias Interface
Genesyslab.Enterprise.Model.Identity Namespace


IAlias Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IAlias Properties
IAlias Interface See Also Send Feedback

The IAlias type exposes the following members.

Properties

Name | Description
Name | Alias name.

See Also

IAlias Interface
Genesyslab.Enterprise.Model.Identity Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IAlias..::.Name Property
IAlias Interface See Also Send Feedback
Alias name.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IAlias Interface
Genesyslab.Enterprise.Model.Identity Namespace


IAliasManager Interface

[image]

Enterprise SDK 8.0 Reference API
IAliasManager Interface
Members See Also Send Feedback
Manages the aliases of an existing identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IAliasManager
Visual Basic (Declaration)
Public Interface IAliasManager
Visual C++
public interface class IAliasManager

See Also

IAliasManager Members
Genesyslab.Enterprise.Model.Identity Namespace


IAliasManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAliasManager Members
IAliasManager Interface Methods See Also Send Feedback

The IAliasManager type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias.
ListAliases | Returns the list of aliases asscoiated with the given identity.
LookupByAlias | Searches for an alias.
RemoveAlias | Overloaded.

See Also

IAliasManager Interface
Genesyslab.Enterprise.Model.Identity Namespace


IAliasManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IAliasManager Methods
IAliasManager Interface See Also Send Feedback

The IAliasManager type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias.
ListAliases | Returns the list of aliases asscoiated with the given identity.
LookupByAlias | Searches for an alias.
RemoveAlias | Overloaded.

See Also

IAliasManager Interface
Genesyslab.Enterprise.Model.Identity Namespace


AddAlias Method

[image]

Enterprise SDK 8.0 Reference API
IAliasManager..::.AddAlias Method
IAliasManager Interface See Also Send Feedback
Adds an alias.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAliasManager AddAlias(
    IAlias identityAlias
)
Visual Basic (Declaration)
Function AddAlias ( _
    identityAlias As IAlias _
) As IAliasManager
Visual C++
IAliasManager^ AddAlias(
    IAlias^ identityAlias
)

Parameters

identityAlias
Type: Genesyslab.Enterprise.Model.Identity..::.IAlias
the alias to add.

Return Value

the IAliasManager.

See Also

IAliasManager Interface
Genesyslab.Enterprise.Model.Identity Namespace


ListAliases Method

[image]

Enterprise SDK 8.0 Reference API
IAliasManager..::.ListAliases Method
IAliasManager Interface See Also Send Feedback
Returns the list of aliases asscoiated with the given identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAlias[] ListAliases(
    string name
)
Visual Basic (Declaration)
Function ListAliases ( _
    name As String _
) As IAlias()
Visual C++
array<IAlias^>^ ListAliases(
    String^ name
)

Parameters

name
Type: System..::.String
the identity name.

Return Value

the list of aliases associated with the given identity.

See Also

IAliasManager Interface
Genesyslab.Enterprise.Model.Identity Namespace


LookupByAlias Method

[image]

Enterprise SDK 8.0 Reference API
IAliasManager..::.LookupByAlias Method
IAliasManager Interface See Also Send Feedback
Searches for an alias.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentity LookupByAlias(
    IAlias identityAlias
)
Visual Basic (Declaration)
Function LookupByAlias ( _
    identityAlias As IAlias _
) As IIdentity
Visual C++
IIdentity^ LookupByAlias(
    IAlias^ identityAlias
)

Parameters

identityAlias
Type: Genesyslab.Enterprise.Model.Identity..::.IAlias
the alias to lookup.

Return Value

returns the identity associated with the alias.

See Also

IAliasManager Interface
Genesyslab.Enterprise.Model.Identity Namespace


RemoveAlias Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAliasManager..::.RemoveAlias Method
IAliasManager Interface See Also Send Feedback

Overload List

Name | Description
RemoveAlias(IAlias) | Removes an alias.
RemoveAlias(String) | Removes an alias.

See Also

IAliasManager Interface
IAliasManager Members
Genesyslab.Enterprise.Model.Identity Namespace


RemoveAlias Method (IAlias)

[image]

Enterprise SDK 8.0 Reference API
IAliasManager..::.RemoveAlias Method (IAlias)
IAliasManager Interface See Also Send Feedback
Removes an alias.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAliasManager RemoveAlias(
    IAlias identityAlias
)
Visual Basic (Declaration)
Function RemoveAlias ( _
    identityAlias As IAlias _
) As IAliasManager
Visual C++
IAliasManager^ RemoveAlias(
    IAlias^ identityAlias
)

Parameters

identityAlias
Type: Genesyslab.Enterprise.Model.Identity..::.IAlias
the alias to remove.

Return Value

the IAliasManager.

See Also

IAliasManager Interface
RemoveAlias Overload
Genesyslab.Enterprise.Model.Identity Namespace


RemoveAlias Method (String)

[image]

Enterprise SDK 8.0 Reference API
IAliasManager..::.RemoveAlias Method (String)
IAliasManager Interface See Also Send Feedback
Removes an alias.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAliasManager RemoveAlias(
    string identityAlias
)
Visual Basic (Declaration)
Function RemoveAlias ( _
    identityAlias As String _
) As IAliasManager
Visual C++
IAliasManager^ RemoveAlias(
    String^ identityAlias
)

Parameters

identityAlias
Type: System..::.String
the alias to remove.

Return Value

the IAliasManager.

See Also

IAliasManager Interface
RemoveAlias Overload
Genesyslab.Enterprise.Model.Identity Namespace


ICredential Interface

[image]

Enterprise SDK 8.0 Reference API
ICredential Interface
Members See Also Send Feedback
Describes credentials.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface ICredential
Visual Basic (Declaration)
Public Interface ICredential
Visual C++
public interface class ICredential

See Also

ICredential Members
Genesyslab.Enterprise.Model.Identity Namespace


ICredential Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICredential Members
ICredential Interface Properties See Also Send Feedback

The ICredential type exposes the following members.

Properties

Name | Description
Password | Password.

See Also

ICredential Interface
Genesyslab.Enterprise.Model.Identity Namespace


ICredential Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICredential Properties
ICredential Interface See Also Send Feedback

The ICredential type exposes the following members.

Properties

Name | Description
Password | Password.

See Also

ICredential Interface
Genesyslab.Enterprise.Model.Identity Namespace


Password Property

[image]

Enterprise SDK 8.0 Reference API
ICredential..::.Password Property
ICredential Interface See Also Send Feedback
Password.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Password { get; set; }
Visual Basic (Declaration)
Property Password As String
Visual C++
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

ICredential Interface
Genesyslab.Enterprise.Model.Identity Namespace


IEntity Interface

[image]

Enterprise SDK 8.0 Reference API
IEntity Interface
Members See Also Send Feedback
Describes a person as an entity (first name, last name, IDs) with associated business values.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IEntity
Visual Basic (Declaration)
Public Interface IEntity
Visual C++
public interface class IEntity

See Also

IEntity Members
Genesyslab.Enterprise.Model.Identity Namespace


IEntity Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEntity Members
IEntity Interface Properties See Also Send Feedback

The IEntity type exposes the following members.

Properties

Name | Description
Agent | Returns the agent IDs associated with this person.
Attributes | Entity attributes.
Email | Returns the person's e-mail.
EmployeeId | Returns the employee ID of this person.
ExternalUserId | Returns the external user ID.
FirstName | Returns the first name of this person.
FQName | Fully Qualified Name associated with the object instance.
IsAgent | Returns true if this Person is an agent. In this case, the object can be casted onto {@link Agent} in order to access agent-related methods.
IsEnabled | Returns true if this person is activated in the Configuration Layer.
LastName | Returns the last name of this person.
UserName | Returns the user name of this person. The user name is another name for the ID. Returns the same value than GetUID.

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IEntity Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IEntity Properties
IEntity Interface See Also Send Feedback

The IEntity type exposes the following members.

Properties

Name | Description
Agent | Returns the agent IDs associated with this person.
Attributes | Entity attributes.
Email | Returns the person's e-mail.
EmployeeId | Returns the employee ID of this person.
ExternalUserId | Returns the external user ID.
FirstName | Returns the first name of this person.
FQName | Fully Qualified Name associated with the object instance.
IsAgent | Returns true if this Person is an agent. In this case, the object can be casted onto {@link Agent} in order to access agent-related methods.
IsEnabled | Returns true if this person is activated in the Configuration Layer.
LastName | Returns the last name of this person.
UserName | Returns the user name of this person. The user name is another name for the ID. Returns the same value than GetUID.

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Agent Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.Agent Property
IEntity Interface See Also Send Feedback
Returns the agent IDs associated with this person.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ICollection<IIdentity> Agent { get; }
Visual Basic (Declaration)
ReadOnly Property Agent As ICollection(Of IIdentity)
Visual C++
property ICollection<IIdentity^>^ Agent {
    ICollection<IIdentity^>^ get ();
}

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Attributes Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.Attributes Property
IEntity Interface See Also Send Feedback
Entity attributes.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionary<string, IDynamicAttribute> Attributes { get; }
Visual Basic (Declaration)
ReadOnly Property Attributes As IDictionary(Of String, IDynamicAttribute)
Visual C++
property IDictionary<String^, IDynamicAttribute^>^ Attributes {
    IDictionary<String^, IDynamicAttribute^>^ get ();
}

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Email Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.Email Property
IEntity Interface See Also Send Feedback
Returns the person's e-mail.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Email { get; }
Visual Basic (Declaration)
ReadOnly Property Email As String
Visual C++
property String^ Email {
    String^ get ();
}

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


EmployeeId Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.EmployeeId Property
IEntity Interface See Also Send Feedback
Returns the employee ID of this person.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string EmployeeId { get; }
Visual Basic (Declaration)
ReadOnly Property EmployeeId As String
Visual C++
property String^ EmployeeId {
    String^ get ();
}

Return Value

string

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


ExternalUserId Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.ExternalUserId Property
IEntity Interface See Also Send Feedback
Returns the external user ID.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string ExternalUserId { get; }
Visual Basic (Declaration)
ReadOnly Property ExternalUserId As String
Visual C++
property String^ ExternalUserId {
    String^ get ();
}

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


FirstName Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.FirstName Property
IEntity Interface See Also Send Feedback
Returns the first name of this person.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string FirstName { get; }
Visual Basic (Declaration)
ReadOnly Property FirstName As String
Visual C++
property String^ FirstName {
    String^ get ();
}

Return Value

string

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.FQName Property
IEntity Interface See Also Send Feedback
Fully Qualified Name associated with the object instance.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string FQName { get; }
Visual Basic (Declaration)
ReadOnly Property FQName As String
Visual C++
property String^ FQName {
    String^ get ();
}

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IsAgent Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.IsAgent Property
IEntity Interface See Also Send Feedback
Returns true if this Person is an agent. In this case, the object can be casted onto {@link Agent} in order to access agent-related methods.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsAgent { get; }
Visual Basic (Declaration)
ReadOnly Property IsAgent As Boolean
Visual C++
property bool IsAgent {
    bool get ();
}

Return Value

bool

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IsEnabled Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.IsEnabled Property
IEntity Interface See Also Send Feedback
Returns true if this person is activated in the Configuration Layer.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsEnabled { get; }
Visual Basic (Declaration)
ReadOnly Property IsEnabled As Boolean
Visual C++
property bool IsEnabled {
    bool get ();
}

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


LastName Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.LastName Property
IEntity Interface See Also Send Feedback
Returns the last name of this person.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string LastName { get; }
Visual Basic (Declaration)
ReadOnly Property LastName As String
Visual C++
property String^ LastName {
    String^ get ();
}

Return Value

string

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


UserName Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.UserName Property
IEntity Interface See Also Send Feedback
Returns the user name of this person. The user name is another name for the ID. Returns the same value than GetUID.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string UserName { get; }
Visual Basic (Declaration)
ReadOnly Property UserName As String
Visual C++
property String^ UserName {
    String^ get ();
}

Return Value

string

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IIdentity Interface

[image]

Enterprise SDK 8.0 Reference API
IIdentity Interface
Members See Also Send Feedback
Describes an identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IIdentity : IRoleable,
    ISerializable
Visual Basic (Declaration)
Public Interface IIdentity _
    Implements IRoleable, ISerializable
Visual C++
public interface class IIdentity : IRoleable,
    ISerializable

See Also

IIdentity Members
Genesyslab.Enterprise.Model.Identity Namespace


IIdentity Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentity Members
IIdentity Interface Methods Properties See Also Send Feedback

The IIdentity type exposes the following members.

Methods

Name | Description
Controller | Overloaded.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
HasAgentInfo | Report if a device contains some agent data

Properties

Name | Description
Attributes | Dynamic and static data defined for this identity.
Devices | Collection of associated devices (single or groups). Use IdentityService.SetDevice to associate Device
FQName | Fully Qualified Name (Unique ID for this object).
Group | Groups of identities.
IdentityBase | Gets the Base identity of this identity.
Name | Identity name.
Role | Gets or sets the role of an object. (Inherited from IRoleable.)
Strategy | Strategies for this identity.

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IIdentity Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentity Methods
IIdentity Interface See Also Send Feedback

The IIdentity type exposes the following members.

Methods

Name | Description
Controller | Overloaded.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
HasAgentInfo | Report if a device contains some agent data

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Controller Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Controller Method
IIdentity Interface See Also Send Feedback

Overload List

Name | Description
Controller()()() | Gets the Controller of this object.
Controller(String) | Gets the Controller of this object.

See Also

IIdentity Interface
IIdentity Members
Genesyslab.Enterprise.Model.Identity Namespace


Controller Method

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Controller Method
IIdentity Interface See Also Send Feedback
Gets the Controller of this object.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object Controller()
Visual Basic (Declaration)
Function Controller As Object
Visual C++
Object^ Controller()

Return Value

an object for the controller.

See Also

IIdentity Interface
Controller Overload
Genesyslab.Enterprise.Model.Identity Namespace


Controller Method (String)

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Controller Method (String)
IIdentity Interface See Also Send Feedback
Gets the Controller of this object.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object Controller(
    string deviceName
)
Visual Basic (Declaration)
Function Controller ( _
    deviceName As String _
) As Object
Visual C++
Object^ Controller(
    String^ deviceName
)

Parameters

deviceName
Type: System..::.String
the name of the device.

Return Value

an object for the controller.

See Also

IIdentity Interface
Controller Overload
Genesyslab.Enterprise.Model.Identity Namespace


HasAgentInfo Method

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.HasAgentInfo Method
IIdentity Interface See Also Send Feedback
Report if a device contains some agent data

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool HasAgentInfo(
    IDevice device
)
Visual Basic (Declaration)
Function HasAgentInfo ( _
    device As IDevice _
) As Boolean
Visual C++
bool HasAgentInfo(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Model.Identity.IIdentity.HasAgentInfo(Genesyslab.Enterprise.Model.Device.IDevice)"]

Return Value

bool

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IIdentity Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentity Properties
IIdentity Interface See Also Send Feedback

The IIdentity type exposes the following members.

Properties

Name | Description
Attributes | Dynamic and static data defined for this identity.
Devices | Collection of associated devices (single or groups). Use IdentityService.SetDevice to associate Device
FQName | Fully Qualified Name (Unique ID for this object).
Group | Groups of identities.
IdentityBase | Gets the Base identity of this identity.
Name | Identity name.
Role | Gets or sets the role of an object. (Inherited from IRoleable.)
Strategy | Strategies for this identity.

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Attributes Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Attributes Property
IIdentity Interface See Also Send Feedback
Dynamic and static data defined for this identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDataBag<IAttributeDataManager<IDynamicAttribute>> Attributes { get; }
Visual Basic (Declaration)
ReadOnly Property Attributes As IDataBag(Of IAttributeDataManager(Of IDynamicAttribute))
Visual C++
property IDataBag<IAttributeDataManager<IDynamicAttribute^>^>^ Attributes {
    IDataBag<IAttributeDataManager<IDynamicAttribute^>^>^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Devices Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Devices Property
IIdentity Interface See Also Send Feedback
Collection of associated devices (single or groups). Use IdentityService.SetDevice to associate Device

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionary<string, IDevice> Devices { get; }
Visual Basic (Declaration)
ReadOnly Property Devices As IDictionary(Of String, IDevice)
Visual C++
property IDictionary<String^, IDevice^>^ Devices {
    IDictionary<String^, IDevice^>^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.FQName Property
IIdentity Interface See Also Send Feedback
Fully Qualified Name (Unique ID for this object).

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string FQName { get; }
Visual Basic (Declaration)
ReadOnly Property FQName As String
Visual C++
property String^ FQName {
    String^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Group Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Group Property
IIdentity Interface See Also Send Feedback
Groups of identities.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionary<string, IIdentity> Group { get; }
Visual Basic (Declaration)
ReadOnly Property Group As IDictionary(Of String, IIdentity)
Visual C++
property IDictionary<String^, IIdentity^>^ Group {
    IDictionary<String^, IIdentity^>^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IdentityBase Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.IdentityBase Property
IIdentity Interface See Also Send Feedback
Gets the Base identity of this identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentity IdentityBase { get; }
Visual Basic (Declaration)
ReadOnly Property IdentityBase As IIdentity
Visual C++
property IIdentity^ IdentityBase {
    IIdentity^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Name Property
IIdentity Interface See Also Send Feedback
Identity name.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Strategy Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Strategy Property
IIdentity Interface See Also Send Feedback
Strategies for this identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ICollection<IStrategy> Strategy { get; }
Visual Basic (Declaration)
ReadOnly Property Strategy As ICollection(Of IStrategy)
Visual C++
property ICollection<IStrategy^>^ Strategy {
    ICollection<IStrategy^>^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IIdentityType Interface

[image]

Enterprise SDK 8.0 Reference API
IIdentityType Interface
Members See Also Send Feedback
Identity type.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IIdentityType
Visual Basic (Declaration)
Public Interface IIdentityType
Visual C++
public interface class IIdentityType

See Also

IIdentityType Members
Genesyslab.Enterprise.Model.Identity Namespace


IIdentityType Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityType Members
IIdentityType Interface Properties See Also Send Feedback

The IIdentityType type exposes the following members.

Properties

Name | Description
Name | Type name.

See Also

IIdentityType Interface
Genesyslab.Enterprise.Model.Identity Namespace


IIdentityType Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityType Properties
IIdentityType Interface See Also Send Feedback

The IIdentityType type exposes the following members.

Properties

Name | Description
Name | Type name.

See Also

IIdentityType Interface
Genesyslab.Enterprise.Model.Identity Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IIdentityType..::.Name Property
IIdentityType Interface See Also Send Feedback
Type name.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IIdentityType Interface
Genesyslab.Enterprise.Model.Identity Namespace


WorkMode Enumeration

[image]

Enterprise SDK 8.0 Reference API
WorkMode Enumeration
See Also Send Feedback
Describes the agent's workmode.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum WorkMode
Visual Basic (Declaration)
Public Enumeration WorkMode
Visual C++
public enum class WorkMode

Members

Member name | Description
Unknown | Unknown.
ManualIn | Manual in.
AutoIn | Auto in.
LegalGuard | Legar guard.
AfterCallWork | After call work.
AuxWork | Auxiliary work.
NoCallDisconnect | No call disconnect.
WalkAway | Walk away (absent).
ReturnBack | Return back.

See Also

Genesyslab.Enterprise.Model.Identity Namespace


Genesyslab.Enterprise.Model.Interaction Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Interaction Namespace
Send Feedback

Interfaces

Interface Description
IAttributeDataManager<(Of <(T>)>)
Manages attribute data.
IExtension
Describes the interaction's extension.
IIMEvent
Describes a new event during an instant messaging session.
IIMInteraction
Describes an Instant Messaging session.
IIMMessage
Represents a message during an Instant Messaging session.
IIMParty
Represents a party of the Instant Messaging session.
IIMPartyJoined
Occurs during an Instant Messaging session if a party joined.
IIMPartyLeft
Occurs during an Instant Messaging session if a party left.
IIMPartyReenter
Occurs during an Instant Messaging session if a party reentered.
IInteraction
Describes an interaction.
IInteractionType
Describes the interaction type:
  • Media content.
  • Media direction.
  • The interaction's subtype.
  • Internality.
IParty
Describes one party of a device or a call.
IPreviewInteraction
Describes a preview interaction.

Enumerations

Enumeration | Description
ContextStateType | State of the Interaction Context.
InteractionStateType | Lists the possible types for interactions state.
MakeCallType | Enumerates the possible call types for voice interactions.
MediaContentType | Enumerates the media content types.
PartyInfoType | Enumerates the party types.
PartyTranslationType |
ProfileType | Enumerates the profile types.
ReasonTypes |


ContextStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ContextStateType Enumeration
See Also Send Feedback
State of the Interaction Context.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum ContextStateType
Visual Basic (Declaration)
Public Enumeration ContextStateType
Visual C++
public enum class ContextStateType

Members

Member name | Description
Unknown | Unknown state of the context.
Created | The context is created.
Updated | The context is updated.
Merged | The context is merged with another context (conference).
Deleted | The context is deleted.
Error | Error state of the context.

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


IAttributeDataManager(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>) Interface
Members See Also Send Feedback
Manages attribute data.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IAttributeDataManager<T>
Visual Basic (Declaration)
Public Interface IAttributeDataManager(Of T)
Visual C++
generic<typename T>
public interface class IAttributeDataManager

Type Parameters

T
The type of the data.

See Also

IAttributeDataManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Interaction Namespace


IAttributeDataManager(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>) Members
IAttributeDataManager<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IAttributeDataManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
AddElement | Overloaded.
AllValues | All the values.
ContainsKey | True if contains the given key.
GetAsPSDKCollection | Returns this manager's content as a Platform SDK collection.
GetElementAsBinary | Returns the element associated with the given key as a byte array.
GetElementAsCollection | Returns the element associated with the given key as a collection.
GetElementAsDynamicAttribute | Overloaded.
GetElementAsInt | Returns the element associated with the given key as int.
GetElementAsObject | Returns the element associated with the given key as an object.
GetElementAsString | Returns the element associated with the given key as a string.
GetElementType | Returns the type for the element associated with the given key.
IsElementACollection | Overloaded.
IsSynchronized | True if the manager is synchronized.
RemoveAll | Removes all the elements.
RemoveElement | Removes the element associated with the given key.
SetElement | Overloaded.
SetElementAsDynamicAttribute | Overloaded.

Properties

Name | Description
AllKeys | All the keys.
Item | Overloaded.
Owner | Returns the owner of this object.
Section | Returns the section name.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IAttributeDataManager(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>) Methods
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

The IAttributeDataManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
AddElement | Overloaded.
AllValues | All the values.
ContainsKey | True if contains the given key.
GetAsPSDKCollection | Returns this manager's content as a Platform SDK collection.
GetElementAsBinary | Returns the element associated with the given key as a byte array.
GetElementAsCollection | Returns the element associated with the given key as a collection.
GetElementAsDynamicAttribute | Overloaded.
GetElementAsInt | Returns the element associated with the given key as int.
GetElementAsObject | Returns the element associated with the given key as an object.
GetElementAsString | Returns the element associated with the given key as a string.
GetElementType | Returns the type for the element associated with the given key.
IsElementACollection | Overloaded.
IsSynchronized | True if the manager is synchronized.
RemoveAll | Removes all the elements.
RemoveElement | Removes the element associated with the given key.
SetElement | Overloaded.
SetElementAsDynamicAttribute | Overloaded.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


AddElement Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.AddElement Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
AddElement(IDynamicAttribute) | Add a new element (may be already existing).
AddElement(String, IAttributeDataManager<(Of <(T>)>)) | Add a new element (may be already existing).

See Also

IAttributeDataManager<(Of <(T>)>) Interface
IAttributeDataManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Interaction Namespace


AddElement Method (IDynamicAttribute)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.AddElement Method (IDynamicAttribute)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Add a new element (may be already existing).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAttributeDataManager<T> AddElement(
    IDynamicAttribute value
)
Visual Basic (Declaration)
Function AddElement ( _
    value As IDynamicAttribute _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ AddElement(
    IDynamicAttribute^ value
)

Parameters

value
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IDynamicAttribute
the value of the dynamic attribute to add.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
AddElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


AddElement Method (String, IAttributeDataManager(T))

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.AddElement Method (String, IAttributeDataManager<(Of <(T>)>))
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Add a new element (may be already existing).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAttributeDataManager<T> AddElement(
    string key,
    IAttributeDataManager<T> list
)
Visual Basic (Declaration)
Function AddElement ( _
    key As String, _
    list As IAttributeDataManager(Of T) _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ AddElement(
    String^ key,
    IAttributeDataManager<T>^ list
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute to add.
list
Type: Genesyslab.Enterprise.Model.Interaction..::.IAttributeDataManager <(Of <( T >)>)
the list of attributes.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
AddElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


AllValues Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.AllValues Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
All the values.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
T[] AllValues()
Visual Basic (Declaration)
Function AllValues As T()
Visual C++
array<T>^ AllValues()

Return Value

All the values as an array.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ContainsKey Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.ContainsKey Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
True if contains the given key.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool ContainsKey(
    string key
)
Visual Basic (Declaration)
Function ContainsKey ( _
    key As String _
) As Boolean
Visual C++
bool ContainsKey(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

True if contains the given key.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetAsPSDKCollection Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetAsPSDKCollection Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns this manager's content as a Platform SDK collection.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
KeyValueCollection GetAsPSDKCollection()
Visual Basic (Declaration)
Function GetAsPSDKCollection As KeyValueCollection
Visual C++
KeyValueCollection^ GetAsPSDKCollection()

Return Value

the KeyValueCollection.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsBinary Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsBinary Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given key as a byte array.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
byte[] GetElementAsBinary(
    string key
)
Visual Basic (Declaration)
Function GetElementAsBinary ( _
    key As String _
) As Byte()
Visual C++
array<unsigned char>^ GetElementAsBinary(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

the element as a byte array.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsCollection Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsCollection Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given key as a collection.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAttributeDataManager<T> GetElementAsCollection(
    string key
)
Visual Basic (Declaration)
Function GetElementAsCollection ( _
    key As String _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ GetElementAsCollection(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

the element as an IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsDynamicAttribute Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsDynamicAttribute Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetElementAsDynamicAttribute(Int32) | Returns the element associated with the given index as a dynamic attribute.
GetElementAsDynamicAttribute(String) | Returns the element associated with the given key as a dynamic attribute.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
IAttributeDataManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsDynamicAttribute Method (Int32)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsDynamicAttribute Method (Int32)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given index as a dynamic attribute.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
T GetElementAsDynamicAttribute(
    int key
)
Visual Basic (Declaration)
Function GetElementAsDynamicAttribute ( _
    key As Integer _
) As T
Visual C++
T GetElementAsDynamicAttribute(
    int key
)

Parameters

key
Type: System..::.Int32
the index of the dynamic attribute.

Return Value

The element as DynamicAttribute.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
GetElementAsDynamicAttribute Overload
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsDynamicAttribute Method (String)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsDynamicAttribute Method (String)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given key as a dynamic attribute.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
T GetElementAsDynamicAttribute(
    string key
)
Visual Basic (Declaration)
Function GetElementAsDynamicAttribute ( _
    key As String _
) As T
Visual C++
T GetElementAsDynamicAttribute(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

The element as DynamicAttribute.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
GetElementAsDynamicAttribute Overload
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsInt Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsInt Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given key as int.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Nullable<int> GetElementAsInt(
    string key
)
Visual Basic (Declaration)
Function GetElementAsInt ( _
    key As String _
) As Nullable(Of Integer)
Visual C++
Nullable<int> GetElementAsInt(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

the element as int.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsObject Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsObject Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given key as an object.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object GetElementAsObject(
    string key
)
Visual Basic (Declaration)
Function GetElementAsObject ( _
    key As String _
) As Object
Visual C++
Object^ GetElementAsObject(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

the element as a object.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsString Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsString Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given key as a string.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string GetElementAsString(
    string key
)
Visual Basic (Declaration)
Function GetElementAsString ( _
    key As String _
) As String
Visual C++
String^ GetElementAsString(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

the element as a string.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementType Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementType Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the type for the element associated with the given key.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Type GetElementType(
    string key
)
Visual Basic (Declaration)
Function GetElementType ( _
    key As String _
) As Type
Visual C++
Type^ GetElementType(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

The type of the element.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsElementACollection Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.IsElementACollection Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
IsElementACollection(Int32) | True if the value associated with the given index is a collection.
IsElementACollection(String) | True if the value associated with the given key is a collection.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
IAttributeDataManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Interaction Namespace


IsElementACollection Method (Int32)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.IsElementACollection Method (Int32)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
True if the value associated with the given index is a collection.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsElementACollection(
    int index
)
Visual Basic (Declaration)
Function IsElementACollection ( _
    index As Integer _
) As Boolean
Visual C++
bool IsElementACollection(
    int index
)

Parameters

index
Type: System..::.Int32
the index of the dynamic attribute.

Return Value

True if the value associated with the given index is a collection.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
IsElementACollection Overload
Genesyslab.Enterprise.Model.Interaction Namespace


IsElementACollection Method (String)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.IsElementACollection Method (String)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
True if the value associated with the given key is a collection.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsElementACollection(
    string key
)
Visual Basic (Declaration)
Function IsElementACollection ( _
    key As String _
) As Boolean
Visual C++
bool IsElementACollection(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

True if the value associated with the given key is a collection.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
IsElementACollection Overload
Genesyslab.Enterprise.Model.Interaction Namespace


IsSynchronized Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.IsSynchronized Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
True if the manager is synchronized.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsSynchronized(
    string key
)
Visual Basic (Declaration)
Function IsSynchronized ( _
    key As String _
) As Boolean
Visual C++
bool IsSynchronized(
    String^ key
)

Parameters

key
Type: System..::.String
the key.

Return Value

True if the manager is synchronized.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


RemoveAll Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.RemoveAll Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Removes all the elements.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void RemoveAll()
Visual Basic (Declaration)
Sub RemoveAll
Visual C++
void RemoveAll()

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


RemoveElement Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.RemoveElement Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Removes the element associated with the given key.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool RemoveElement(
    string key
)
Visual Basic (Declaration)
Function RemoveElement ( _
    key As String _
) As Boolean
Visual C++
bool RemoveElement(
    String^ key
)

Parameters

key
Type: System..::.String
the key to remove.

Return Value

True if the operation is successful.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
SetElement(T) | Sets an existing element.
SetElement(String, IAttributeDataManager<(Of <(T>)>)) | Sets an element.
SetElement(String, array<Byte>[]()[]) | Sets an element.
SetElement(String, Int32) | Sets an element.
SetElement(String, Object) | Sets an element.
SetElement(String, String) | Sets an element.
SetElement(String, array<Byte>[]()[], String, String) | Sets an element.
SetElement(String, Object, String, String) | Sets an element.
SetElement(String, String, String, String) | Sets an element.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
IAttributeDataManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (T)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (T)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an existing element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAttributeDataManager<T> SetElement(
    T value
)
Visual Basic (Declaration)
Function SetElement ( _
    value As T _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    T value
)

Parameters

value
Type: T
the value to add.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, IAttributeDataManager(T))

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, IAttributeDataManager<(Of <(T>)>))
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    IAttributeDataManager<T> value
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As IAttributeDataManager(Of T) _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    IAttributeDataManager<T>^ value
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: Genesyslab.Enterprise.Model.Interaction..::.IAttributeDataManager <(Of <( T >)>)
the value.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, Byte[])

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, array<Byte>[]()[])
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    byte[] value
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As Byte() _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    array<unsigned char>^ value
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: array< System..::.Byte >[]()[]
the value.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, Int32)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    int value
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As Integer _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    int value
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: System..::.Int32
the value as int.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, Object)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, Object)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    Object value
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As Object _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    Object^ value
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: System..::.Object
the value.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, String)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, String)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    string value
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As String _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    String^ value
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: System..::.String
the value.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, Byte[], String, String)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, array<Byte>[]()[], String, String)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    byte[] value,
    string contentType,
    string contentTypeVersion
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As Byte(), _
    contentType As String, _
    contentTypeVersion As String _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    array<unsigned char>^ value,
    String^ contentType,
    String^ contentTypeVersion
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: array< System..::.Byte >[]()[]
the value.
contentType
Type: System..::.String
the content type of the value.
contentTypeVersion
Type: System..::.String
the content type version.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, Object, String, String)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, Object, String, String)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    Object value,
    string contentType,
    string contentTypeVersion
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As Object, _
    contentType As String, _
    contentTypeVersion As String _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    Object^ value,
    String^ contentType,
    String^ contentTypeVersion
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: System..::.Object
the value.
contentType
Type: System..::.String
the content type of the value.
contentTypeVersion
Type: System..::.String
the content type version.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, String, String, String)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, String, String, String)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    string value,
    string contentType,
    string contentTypeVersion
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As String, _
    contentType As String, _
    contentTypeVersion As String _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    String^ value,
    String^ contentType,
    String^ contentTypeVersion
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: System..::.String
the value.
contentType
Type: System..::.String
the content type of the value.
contentTypeVersion
Type: System..::.String
the content type version.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElementAsDynamicAttribute Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElementAsDynamicAttribute Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
SetElementAsDynamicAttribute(Int32, IAttributeDataManager<(Of <(T>)>)) | Sets a collection from index
SetElementAsDynamicAttribute(Int32, T) | Sets an element from index

See Also

IAttributeDataManager<(Of <(T>)>) Interface
IAttributeDataManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Interaction Namespace


SetElementAsDynamicAttribute Method (Int32, IAttributeDataManager(T))

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElementAsDynamicAttribute Method (Int32, IAttributeDataManager<(Of <(T>)>))
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets a collection from index

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAttributeDataManager<T> SetElementAsDynamicAttribute(
    int index,
    IAttributeDataManager<T> list
)
Visual Basic (Declaration)
Function SetElementAsDynamicAttribute ( _
    index As Integer, _
    list As IAttributeDataManager(Of T) _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElementAsDynamicAttribute(
    int index,
    IAttributeDataManager<T>^ list
)

Parameters

index
Type: System..::.Int32
the index.
list
Type: Genesyslab.Enterprise.Model.Interaction..::.IAttributeDataManager <(Of <( T >)>)
the list of dynamic attribute.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElementAsDynamicAttribute Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElementAsDynamicAttribute Method (Int32, T)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElementAsDynamicAttribute Method (Int32, T)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element from index

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAttributeDataManager<T> SetElementAsDynamicAttribute(
    int index,
    T data
)
Visual Basic (Declaration)
Function SetElementAsDynamicAttribute ( _
    index As Integer, _
    data As T _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElementAsDynamicAttribute(
    int index,
    T data
)

Parameters

index
Type: System..::.Int32
the index.
data
Type: T
the value.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElementAsDynamicAttribute Overload
Genesyslab.Enterprise.Model.Interaction Namespace


IAttributeDataManager(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>) Properties
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

The IAttributeDataManager<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
AllKeys | All the keys.
Item | Overloaded.
Owner | Returns the owner of this object.
Section | Returns the section name.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


AllKeys Property

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.AllKeys Property
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
All the keys.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string[] AllKeys { get; }
Visual Basic (Declaration)
ReadOnly Property AllKeys As String()
Visual C++
property array<String^>^ AllKeys {
    array<String^>^ get ();
}

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Item Property

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.Item Property
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Returns the value associated with the given index.
Item[([(String])]) | Returns the value associated with the given key.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
IAttributeDataManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Interaction Namespace


Item Property (Int32)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.Item Property (Int32)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the value associated with the given index.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
T this[
    int index
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    index As Integer _
) As T
Visual C++
property T default[int index] {
    T get (int index);
}

Parameters

index
Type: System..::.Int32
the given index.

Return Value

the value.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Item Overload
Genesyslab.Enterprise.Model.Interaction Namespace


Item Property (String)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.Item Property (String)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the value associated with the given key.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
T this[
    string key
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    key As String _
) As T
Visual C++
property T default[String^ key] {
    T get (String^ key);
}

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

the value of the dynamic attribute.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Item Overload
Genesyslab.Enterprise.Model.Interaction Namespace


Owner Property

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.Owner Property
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the owner of this object.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object Owner { get; }
Visual Basic (Declaration)
ReadOnly Property Owner As Object
Visual C++
property Object^ Owner {
    Object^ get ();
}

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Section Property

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.Section Property
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the section name.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Section { get; }
Visual Basic (Declaration)
ReadOnly Property Section As String
Visual C++
property String^ Section {
    String^ get ();
}

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IExtension Interface

[image]

Enterprise SDK 8.0 Reference API
IExtension Interface
Members See Also Send Feedback
Describes the interaction's extension.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IExtension
Visual Basic (Declaration)
Public Interface IExtension
Visual C++
public interface class IExtension

See Also

IExtension Members
Genesyslab.Enterprise.Model.Interaction Namespace


IExtension Members

[image] [image]

Enterprise SDK 8.0 Reference API
IExtension Members
IExtension Interface Properties See Also Send Feedback

The IExtension type exposes the following members.

Properties

Name | Description
Attributes | Content of the extension (dynamic attributes).
Description | Description of the extension's content.
Name | Extension name.

See Also

IExtension Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IExtension Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IExtension Properties
IExtension Interface See Also Send Feedback

The IExtension type exposes the following members.

Properties

Name | Description
Attributes | Content of the extension (dynamic attributes).
Description | Description of the extension's content.
Name | Extension name.

See Also

IExtension Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Attributes Property

[image]

Enterprise SDK 8.0 Reference API
IExtension..::.Attributes Property
IExtension Interface See Also Send Feedback
Content of the extension (dynamic attributes).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionary<string, IDynamicAttribute> Attributes { get; }
Visual Basic (Declaration)
ReadOnly Property Attributes As IDictionary(Of String, IDynamicAttribute)
Visual C++
property IDictionary<String^, IDynamicAttribute^>^ Attributes {
    IDictionary<String^, IDynamicAttribute^>^ get ();
}

See Also

IExtension Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IExtension..::.Description Property
IExtension Interface See Also Send Feedback
Description of the extension's content.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IExtension Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IExtension..::.Name Property
IExtension Interface See Also Send Feedback
Extension name.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IExtension Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMEvent Interface

[image]

Enterprise SDK 8.0 Reference API
IIMEvent Interface
Members See Also Send Feedback
Describes a new event during an instant messaging session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IIMEvent
Visual Basic (Declaration)
Public Interface IIMEvent
Visual C++
public interface class IIMEvent

See Also

IIMEvent Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMEvent Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMEvent Members
IIMEvent Interface Properties See Also Send Feedback

The IIMEvent type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event.
Party | Returns the party of this IM event

See Also

IIMEvent Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMEvent Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMEvent Properties
IIMEvent Interface See Also Send Feedback

The IIMEvent type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event.
Party | Returns the party of this IM event

See Also

IIMEvent Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Date Property

[image]

Enterprise SDK 8.0 Reference API
IIMEvent..::.Date Property
IIMEvent Interface See Also Send Feedback
Returns the date of this IM event.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
DateTime Date { get; }
Visual Basic (Declaration)
ReadOnly Property Date As DateTime
Visual C++
property DateTime Date {
    DateTime get ();
}

See Also

IIMEvent Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Party Property

[image]

Enterprise SDK 8.0 Reference API
IIMEvent..::.Party Property
IIMEvent Interface See Also Send Feedback
Returns the party of this IM event

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIMParty Party { get; }
Visual Basic (Declaration)
ReadOnly Property Party As IIMParty
Visual C++
property IIMParty^ Party {
    IIMParty^ get ();
}

See Also

IIMEvent Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMInteraction Interface

[image]

Enterprise SDK 8.0 Reference API
IIMInteraction Interface
Members See Also Send Feedback
Describes an Instant Messaging session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IIMInteraction : IInteraction,
    ISerializable
Visual Basic (Declaration)
Public Interface IIMInteraction _
    Implements IInteraction, ISerializable
Visual C++
public interface class IIMInteraction : IInteraction,
    ISerializable

See Also

IIMInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMInteraction Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMInteraction Members
IIMInteraction Interface Methods Properties See Also Send Feedback

The IIMInteraction type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible. (Inherited from IInteraction.)

Properties

Name Description
ActionsTransitions
Get IsPossible feature
(Inherited from IInteraction.)
ActiveChannel
Returns the active channel.
(Inherited from IInteraction.)
Channels
Returns the channels associated with this interaction.
(Inherited from IInteraction.)
Controller
Controller.
(Inherited from IInteraction.)
Customer
Returns the customer party.
(Inherited from IInteraction.)
Data
Returns the data associated with the interaction.
(Inherited from IInteraction.)
EndDate
Interaction end data. Same as server end date.
(Inherited from IInteraction.)
FQName
Returns the interaction's Fully Qualified Name (unique Id).
(Inherited from IInteraction.)
Id
Returns the interaction's identifier.
(Inherited from IInteraction.)
IdType
Returns the interaction type.
(Inherited from IInteraction.)
IMEvent
Returns the events of the instant messaging session.
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
(Inherited from IInteraction.)
Originator
Returns the originting party when interaction is transfered
(Inherited from IInteraction.)
Owner
Returns the party who owns this interaction.
(Inherited from IInteraction.)
Parties
Returns all the parties involved wihtin the interaction.
(Inherited from IInteraction.)
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
(Inherited from IInteraction.)
Queue
Queues associated with the interaction.
(Inherited from IInteraction.)
RelatedId
Returns the related interaction IDs.
(Inherited from IInteraction.)
StartDate
Interaction start data. Same as the server date.
(Inherited from IInteraction.)
State
Returns the interaction status.
(Inherited from IInteraction.)
Strategy
Returns the strategies associated with the interaction.
(Inherited from IInteraction.)
Target
Returns the target party when interaction is transfered
(Inherited from IInteraction.)

See Also

IIMInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMInteraction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIMInteraction Methods
IIMInteraction Interface See Also Send Feedback

The IIMInteraction type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible. (Inherited from IInteraction.)

See Also

IIMInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMInteraction Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMInteraction Properties
IIMInteraction Interface See Also Send Feedback

The IIMInteraction type exposes the following members.

Properties

Name Description
ActionsTransitions
Get IsPossible feature
(Inherited from IInteraction.)
ActiveChannel
Returns the active channel.
(Inherited from IInteraction.)
Channels
Returns the channels associated with this interaction.
(Inherited from IInteraction.)
Controller
Controller.
(Inherited from IInteraction.)
Customer
Returns the customer party.
(Inherited from IInteraction.)
Data
Returns the data associated with the interaction.
(Inherited from IInteraction.)
EndDate
Interaction end data. Same as server end date.
(Inherited from IInteraction.)
FQName
Returns the interaction's Fully Qualified Name (unique Id).
(Inherited from IInteraction.)
Id
Returns the interaction's identifier.
(Inherited from IInteraction.)
IdType
Returns the interaction type.
(Inherited from IInteraction.)
IMEvent
Returns the events of the instant messaging session.
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
(Inherited from IInteraction.)
Originator
Returns the originting party when interaction is transfered
(Inherited from IInteraction.)
Owner
Returns the party who owns this interaction.
(Inherited from IInteraction.)
Parties
Returns all the parties involved wihtin the interaction.
(Inherited from IInteraction.)
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
(Inherited from IInteraction.)
Queue
Queues associated with the interaction.
(Inherited from IInteraction.)
RelatedId
Returns the related interaction IDs.
(Inherited from IInteraction.)
StartDate
Interaction start data. Same as the server date.
(Inherited from IInteraction.)
State
Returns the interaction status.
(Inherited from IInteraction.)
Strategy
Returns the strategies associated with the interaction.
(Inherited from IInteraction.)
Target
Returns the target party when interaction is transfered
(Inherited from IInteraction.)

See Also

IIMInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IMEvent Property

[image]

Enterprise SDK 8.0 Reference API
IIMInteraction..::.IMEvent Property
IIMInteraction Interface See Also Send Feedback
Returns the events of the instant messaging session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ICollection<IIMEvent> IMEvent { get; }
Visual Basic (Declaration)
ReadOnly Property IMEvent As ICollection(Of IIMEvent)
Visual C++
property ICollection<IIMEvent^>^ IMEvent {
    ICollection<IIMEvent^>^ get ();
}

Return Value

See Also

IIMInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMMessage Interface

[image]

Enterprise SDK 8.0 Reference API
IIMMessage Interface
Members See Also Send Feedback
Represents a message during an Instant Messaging session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IIMMessage : IIMEvent
Visual Basic (Declaration)
Public Interface IIMMessage _
    Implements IIMEvent
Visual C++
public interface class IIMMessage : IIMEvent

See Also

IIMMessage Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMMessage Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMMessage Members
IIMMessage Interface Properties See Also Send Feedback

The IIMMessage type exposes the following members.

Properties

Name Description
Content
Returns the text of this message.
ContentType
Returns the
CopyC#
ContentType
 of this message. Possible values are "text/plain" and "text/html".
Date
Returns the date of this IM event.
(Inherited from IIMEvent.)
Party
Returns the party of this IM event
(Inherited from IIMEvent.)

See Also

IIMMessage Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMMessage Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMMessage Properties
IIMMessage Interface See Also Send Feedback

The IIMMessage type exposes the following members.

Properties

Name Description
Content
Returns the text of this message.
ContentType
Returns the
CopyC#
ContentType
 of this message. Possible values are "text/plain" and "text/html".
Date
Returns the date of this IM event.
(Inherited from IIMEvent.)
Party
Returns the party of this IM event
(Inherited from IIMEvent.)

See Also

IIMMessage Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Content Property

[image]

Enterprise SDK 8.0 Reference API
IIMMessage..::.Content Property
IIMMessage Interface See Also Send Feedback
Returns the text of this message.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Content { get; }
Visual Basic (Declaration)
ReadOnly Property Content As String
Visual C++
property String^ Content {
    String^ get ();
}

Return Value

See Also

IIMMessage Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ContentType Property

[image]

Enterprise SDK 8.0 Reference API
IIMMessage..::.ContentType Property
IIMMessage Interface See Also Send Feedback
Returns the
CopyC#
ContentType
 of this message. Possible values are "text/plain" and "text/html".

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string ContentType { get; }
Visual Basic (Declaration)
ReadOnly Property ContentType As String
Visual C++
property String^ ContentType {
    String^ get ();
}

Return Value

"text/plain" or "text/html"

See Also

IIMMessage Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMParty Interface

[image]

Enterprise SDK 8.0 Reference API
IIMParty Interface
Members See Also Send Feedback
Represents a party of the Instant Messaging session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IIMParty
Visual Basic (Declaration)
Public Interface IIMParty
Visual C++
public interface class IIMParty

See Also

IIMParty Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMParty Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMParty Members
IIMParty Interface Properties See Also Send Feedback

The IIMParty type exposes the following members.

Properties

Name | Description
Nickname | Returns the nickname of this party.
Type | Returns the type of this party.
Visibility | Returns the visibility of this party.

See Also

IIMParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMParty Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMParty Properties
IIMParty Interface See Also Send Feedback

The IIMParty type exposes the following members.

Properties

Name | Description
Nickname | Returns the nickname of this party.
Type | Returns the type of this party.
Visibility | Returns the visibility of this party.

See Also

IIMParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Nickname Property

[image]

Enterprise SDK 8.0 Reference API
IIMParty..::.Nickname Property
IIMParty Interface See Also Send Feedback
Returns the nickname of this party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Nickname { get; }
Visual Basic (Declaration)
ReadOnly Property Nickname As String
Visual C++
property String^ Nickname {
    String^ get ();
}

Return Value

See Also

IIMParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
IIMParty..::.Type Property
IIMParty Interface See Also Send Feedback
Returns the type of this party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
PartyType Type { get; }
Visual Basic (Declaration)
ReadOnly Property Type As PartyType
Visual C++
property PartyType Type {
    PartyType get ();
}

Return Value

See Also

IIMParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Visibility Property

[image]

Enterprise SDK 8.0 Reference API
IIMParty..::.Visibility Property
IIMParty Interface See Also Send Feedback
Returns the visibility of this party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Visibility Visibility { get; }
Visual Basic (Declaration)
ReadOnly Property Visibility As Visibility
Visual C++
property Visibility Visibility {
    Visibility get ();
}

Return Value

See Also

IIMParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyJoined Interface

[image]

Enterprise SDK 8.0 Reference API
IIMPartyJoined Interface
Members See Also Send Feedback
Occurs during an Instant Messaging session if a party joined.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IIMPartyJoined : IIMEvent
Visual Basic (Declaration)
Public Interface IIMPartyJoined _
    Implements IIMEvent
Visual C++
public interface class IIMPartyJoined : IIMEvent

See Also

IIMPartyJoined Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyJoined Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyJoined Members
IIMPartyJoined Interface Properties See Also Send Feedback

The IIMPartyJoined type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)

See Also

IIMPartyJoined Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyJoined Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyJoined Properties
IIMPartyJoined Interface See Also Send Feedback

The IIMPartyJoined type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)

See Also

IIMPartyJoined Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyLeft Interface

[image]

Enterprise SDK 8.0 Reference API
IIMPartyLeft Interface
Members See Also Send Feedback
Occurs during an Instant Messaging session if a party left.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IIMPartyLeft : IIMEvent
Visual Basic (Declaration)
Public Interface IIMPartyLeft _
    Implements IIMEvent
Visual C++
public interface class IIMPartyLeft : IIMEvent

See Also

IIMPartyLeft Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyLeft Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyLeft Members
IIMPartyLeft Interface Properties See Also Send Feedback

The IIMPartyLeft type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)

See Also

IIMPartyLeft Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyLeft Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyLeft Properties
IIMPartyLeft Interface See Also Send Feedback

The IIMPartyLeft type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)

See Also

IIMPartyLeft Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyReenter Interface

[image]

Enterprise SDK 8.0 Reference API
IIMPartyReenter Interface
Members See Also Send Feedback
Occurs during an Instant Messaging session if a party reentered.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IIMPartyReenter : IIMEvent
Visual Basic (Declaration)
Public Interface IIMPartyReenter _
    Implements IIMEvent
Visual C++
public interface class IIMPartyReenter : IIMEvent

See Also

IIMPartyReenter Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyReenter Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyReenter Members
IIMPartyReenter Interface Properties See Also Send Feedback

The IIMPartyReenter type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)

See Also

IIMPartyReenter Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyReenter Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyReenter Properties
IIMPartyReenter Interface See Also Send Feedback

The IIMPartyReenter type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)

See Also

IIMPartyReenter Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteraction Interface

[image]

Enterprise SDK 8.0 Reference API
IInteraction Interface
Members See Also Send Feedback
Describes an interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IInteraction : ISerializable
Visual Basic (Declaration)
Public Interface IInteraction _
    Implements ISerializable
Visual C++
public interface class IInteraction : ISerializable

See Also

IInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


IInteraction Members

[image] [image]

Enterprise SDK 8.0 Reference API
IInteraction Members
IInteraction Interface Methods Properties See Also Send Feedback

The IInteraction type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible.

Properties

Name Description
ActionsTransitions
Get IsPossible feature
ActiveChannel
Returns the active channel.
Channels
Returns the channels associated with this interaction.
Controller
Controller.
Customer
Returns the customer party.
Data
Returns the data associated with the interaction.
EndDate
Interaction end data. Same as server end date.
FQName
Returns the interaction's Fully Qualified Name (unique Id).
Id
Returns the interaction's identifier.
IdType
Returns the interaction type.
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
Originator
Returns the originting party when interaction is transfered
Owner
Returns the party who owns this interaction.
Parties
Returns all the parties involved wihtin the interaction.
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
Queue
Queues associated with the interaction.
RelatedId
Returns the related interaction IDs.
StartDate
Interaction start data. Same as the server date.
State
Returns the interaction status.
Strategy
Returns the strategies associated with the interaction.
Target
Returns the target party when interaction is transfered

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteraction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IInteraction Methods
IInteraction Interface See Also Send Feedback

The IInteraction type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible.

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsDone Method

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.IsDone Method
IInteraction Interface See Also Send Feedback
Returns true if the interaction is disabled. When done, further state changes are impossible.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsDone()
Visual Basic (Declaration)
Function IsDone As Boolean
Visual C++
bool IsDone()

Return Value

bool

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteraction Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IInteraction Properties
IInteraction Interface See Also Send Feedback

The IInteraction type exposes the following members.

Properties

Name Description
ActionsTransitions
Get IsPossible feature
ActiveChannel
Returns the active channel.
Channels
Returns the channels associated with this interaction.
Controller
Controller.
Customer
Returns the customer party.
Data
Returns the data associated with the interaction.
EndDate
Interaction end data. Same as server end date.
FQName
Returns the interaction's Fully Qualified Name (unique Id).
Id
Returns the interaction's identifier.
IdType
Returns the interaction type.
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
Originator
Returns the originting party when interaction is transfered
Owner
Returns the party who owns this interaction.
Parties
Returns all the parties involved wihtin the interaction.
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
Queue
Queues associated with the interaction.
RelatedId
Returns the related interaction IDs.
StartDate
Interaction start data. Same as the server date.
State
Returns the interaction status.
Strategy
Returns the strategies associated with the interaction.
Target
Returns the target party when interaction is transfered

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ActionsTransitions Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.ActionsTransitions Property
IInteraction Interface See Also Send Feedback
Get IsPossible feature

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool[] ActionsTransitions { get; }
Visual Basic (Declaration)
ReadOnly Property ActionsTransitions As Boolean()
Visual C++
property array<bool>^ ActionsTransitions {
    array<bool>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ActiveChannel Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.ActiveChannel Property
IInteraction Interface See Also Send Feedback
Returns the active channel.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IClientChannel ActiveChannel { get; set; }
Visual Basic (Declaration)
Property ActiveChannel As IClientChannel
Visual C++
property IClientChannel^ ActiveChannel {
    IClientChannel^ get ();
    void set (IClientChannel^ value);
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Channels Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Channels Property
IInteraction Interface See Also Send Feedback
Returns the channels associated with this interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionary<string, IClientChannel> Channels { get; }
Visual Basic (Declaration)
ReadOnly Property Channels As IDictionary(Of String, IClientChannel)
Visual C++
property IDictionary<String^, IClientChannel^>^ Channels {
    IDictionary<String^, IClientChannel^>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Controller Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Controller Property
IInteraction Interface See Also Send Feedback
Controller.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object Controller { get; }
Visual Basic (Declaration)
ReadOnly Property Controller As Object
Visual C++
property Object^ Controller {
    Object^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Customer Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Customer Property
IInteraction Interface See Also Send Feedback
Returns the customer party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IParty Customer { get; }
Visual Basic (Declaration)
ReadOnly Property Customer As IParty
Visual C++
property IParty^ Customer {
    IParty^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Data Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Data Property
IInteraction Interface See Also Send Feedback
Returns the data associated with the interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDataBag<IAttributeDataManager<IDynamicAttribute>> Data { get; }
Visual Basic (Declaration)
ReadOnly Property Data As IDataBag(Of IAttributeDataManager(Of IDynamicAttribute))
Visual C++
property IDataBag<IAttributeDataManager<IDynamicAttribute^>^>^ Data {
    IDataBag<IAttributeDataManager<IDynamicAttribute^>^>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


EndDate Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.EndDate Property
IInteraction Interface See Also Send Feedback
Interaction end data. Same as server end date.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
DateTime EndDate { get; }
Visual Basic (Declaration)
ReadOnly Property EndDate As DateTime
Visual C++
property DateTime EndDate {
    DateTime get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.FQName Property
IInteraction Interface See Also Send Feedback
Returns the interaction's Fully Qualified Name (unique Id).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string FQName { get; }
Visual Basic (Declaration)
ReadOnly Property FQName As String
Visual C++
property String^ FQName {
    String^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Id Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Id Property
IInteraction Interface See Also Send Feedback
Returns the interaction's identifier.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Id { get; }
Visual Basic (Declaration)
ReadOnly Property Id As String
Visual C++
property String^ Id {
    String^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IdType Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.IdType Property
IInteraction Interface See Also Send Feedback
Returns the interaction type.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteractionType IdType { get; }
Visual Basic (Declaration)
ReadOnly Property IdType As IInteractionType
Visual C++
property IInteractionType^ IdType {
    IInteractionType^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Item Property
IInteraction Interface See Also Send Feedback
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object this[
    string name
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    name As String _
) As Object
Visual C++
property Object^ default[String^ name] {
    Object^ get (String^ name);
}

Parameters

name
Type: System..::.String

Return Value

object

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Originator Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Originator Property
IInteraction Interface See Also Send Feedback
Returns the originting party when interaction is transfered

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IParty Originator { get; }
Visual Basic (Declaration)
ReadOnly Property Originator As IParty
Visual C++
property IParty^ Originator {
    IParty^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Owner Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Owner Property
IInteraction Interface See Also Send Feedback
Returns the party who owns this interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IParty Owner { get; }
Visual Basic (Declaration)
ReadOnly Property Owner As IParty
Visual C++
property IParty^ Owner {
    IParty^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Parties Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Parties Property
IInteraction Interface See Also Send Feedback
Returns all the parties involved wihtin the interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IParty[] Parties { get; }
Visual Basic (Declaration)
ReadOnly Property Parties As IParty()
Visual C++
property array<IParty^>^ Parties {
    array<IParty^>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Profile Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Profile Property
IInteraction Interface See Also Send Feedback
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ProfileType Profile { get; }
Visual Basic (Declaration)
ReadOnly Property Profile As ProfileType
Visual C++
property ProfileType Profile {
    ProfileType get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Queue Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Queue Property
IInteraction Interface See Also Send Feedback
Queues associated with the interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string[] Queue { get; }
Visual Basic (Declaration)
ReadOnly Property Queue As String()
Visual C++
property array<String^>^ Queue {
    array<String^>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


RelatedId Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.RelatedId Property
IInteraction Interface See Also Send Feedback
Returns the related interaction IDs.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string[] RelatedId { get; }
Visual Basic (Declaration)
ReadOnly Property RelatedId As String()
Visual C++
property array<String^>^ RelatedId {
    array<String^>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


StartDate Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.StartDate Property
IInteraction Interface See Also Send Feedback
Interaction start data. Same as the server date.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
DateTime StartDate { get; }
Visual Basic (Declaration)
ReadOnly Property StartDate As DateTime
Visual C++
property DateTime StartDate {
    DateTime get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.State Property
IInteraction Interface See Also Send Feedback
Returns the interaction status.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
InteractionStateType State { get; }
Visual Basic (Declaration)
ReadOnly Property State As InteractionStateType
Visual C++
property InteractionStateType State {
    InteractionStateType get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Strategy Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Strategy Property
IInteraction Interface See Also Send Feedback
Returns the strategies associated with the interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ICollection<IStrategy> Strategy { get; }
Visual Basic (Declaration)
ReadOnly Property Strategy As ICollection(Of IStrategy)
Visual C++
property ICollection<IStrategy^>^ Strategy {
    ICollection<IStrategy^>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Target Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Target Property
IInteraction Interface See Also Send Feedback
Returns the target party when interaction is transfered

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IParty Target { get; }
Visual Basic (Declaration)
ReadOnly Property Target As IParty
Visual C++
property IParty^ Target {
    IParty^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteractionType Interface

[image]

Enterprise SDK 8.0 Reference API
IInteractionType Interface
Members See Also Send Feedback
Describes the interaction type:
  • Media content.
  • Media direction.
  • The interaction's subtype.
  • Internality.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IInteractionType
Visual Basic (Declaration)
Public Interface IInteractionType
Visual C++
public interface class IInteractionType

See Also

IInteractionType Members
Genesyslab.Enterprise.Model.Interaction Namespace


IInteractionType Members

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionType Members
IInteractionType Interface Properties See Also Send Feedback

The IInteractionType type exposes the following members.

Properties

Name | Description
Direction | Media direction.
Internal | True if the interaction is internal. False if interaction is external Null is interaction type is not known
MediaType | Type for the media content.
Subtype | Interaction subtype (string).

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteractionType Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionType Properties
IInteractionType Interface See Also Send Feedback

The IInteractionType type exposes the following members.

Properties

Name | Description
Direction | Media direction.
Internal | True if the interaction is internal. False if interaction is external Null is interaction type is not known
MediaType | Type for the media content.
Subtype | Interaction subtype (string).

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Direction Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionType..::.Direction Property
IInteractionType Interface See Also Send Feedback
Media direction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
MediaDirectionType Direction { get; }
Visual Basic (Declaration)
ReadOnly Property Direction As MediaDirectionType
Visual C++
property MediaDirectionType Direction {
    MediaDirectionType get ();
}

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Internal Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionType..::.Internal Property
IInteractionType Interface See Also Send Feedback
True if the interaction is internal. False if interaction is external Null is interaction type is not known

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Nullable<bool> Internal { get; }
Visual Basic (Declaration)
ReadOnly Property Internal As Nullable(Of Boolean)
Visual C++
property Nullable<bool> Internal {
    Nullable<bool> get ();
}

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


MediaType Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionType..::.MediaType Property
IInteractionType Interface See Also Send Feedback
Type for the media content.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
MediaContentType MediaType { get; }
Visual Basic (Declaration)
ReadOnly Property MediaType As MediaContentType
Visual C++
property MediaContentType MediaType {
    MediaContentType get ();
}

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Subtype Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionType..::.Subtype Property
IInteractionType Interface See Also Send Feedback
Interaction subtype (string).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Subtype { get; }
Visual Basic (Declaration)
ReadOnly Property Subtype As String
Visual C++
property String^ Subtype {
    String^ get ();
}

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


InteractionStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
InteractionStateType Enumeration
See Also Send Feedback
Lists the possible types for interactions state.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum InteractionStateType
Visual Basic (Declaration)
Public Enumeration InteractionStateType
Visual C++
public enum class InteractionStateType

Members

Member name | Description
Unknown |
PresentedIn |
PresentedOut |
Connected |
Held |
Ended |
Dropped |
Queued |
Abandonned |
Redirected |
HeldPresentedIn |
HeldPresentedOut |
Preview |
Busy |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


IParty Interface

[image]

Enterprise SDK 8.0 Reference API
IParty Interface
Members See Also Send Feedback
Describes one party of a device or a call.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IParty : IRoleable
Visual Basic (Declaration)
Public Interface IParty _
    Implements IRoleable
Visual C++
public interface class IParty : IRoleable

See Also

IParty Members
Genesyslab.Enterprise.Model.Interaction Namespace


IParty Members

[image] [image]

Enterprise SDK 8.0 Reference API
IParty Members
IParty Interface Methods Properties See Also Send Feedback

The IParty type exposes the following members.

Methods

Name | Description
Translate | Get the translation of a party

Properties

Name | Description
Attributes | Dynamic/static data of the party.
Context | Context of the party.
Device | Linked devices to the party.
DisplayName | Name displayed to the user
Extensions | Extensions of the party instance.
Interaction | Linked interaction to the party.
IsIdentified | True if the party could be identified
IsMonitored | True if the party is monitored.
IsOwner | True if this party is the interaction's owner.
Name | Name of the party.
PartyType | Party type. Indicates whether this party is the caller, the callee, or a third party for instance during a transfer.
Role | Gets or sets the role of an object. (Inherited from IRoleable.)

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IParty Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IParty Methods
IParty Interface See Also Send Feedback

The IParty type exposes the following members.

Methods

Name | Description
Translate | Get the translation of a party

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Translate Method

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Translate Method
IParty Interface See Also Send Feedback
Get the translation of a party

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Translate(
    PartyTranslationType description
)
Visual Basic (Declaration)
Function Translate ( _
    description As PartyTranslationType _
) As String
Visual C++
String^ Translate(
    PartyTranslationType description
)

Parameters

description
Type: Genesyslab.Enterprise.Model.Interaction..::.PartyTranslationType

[Missing <param name="description"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IParty.Translate(Genesyslab.Enterprise.Model.Interaction.PartyTranslationType)"]

Return Value

string

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IParty Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IParty Properties
IParty Interface See Also Send Feedback

The IParty type exposes the following members.

Properties

Name | Description
Attributes | Dynamic/static data of the party.
Context | Context of the party.
Device | Linked devices to the party.
DisplayName | Name displayed to the user
Extensions | Extensions of the party instance.
Interaction | Linked interaction to the party.
IsIdentified | True if the party could be identified
IsMonitored | True if the party is monitored.
IsOwner | True if this party is the interaction's owner.
Name | Name of the party.
PartyType | Party type. Indicates whether this party is the caller, the callee, or a third party for instance during a transfer.
Role | Gets or sets the role of an object. (Inherited from IRoleable.)

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Attributes Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Attributes Property
IParty Interface See Also Send Feedback
Dynamic/static data of the party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionary<string, IDynamicAttribute> Attributes { get; }
Visual Basic (Declaration)
ReadOnly Property Attributes As IDictionary(Of String, IDynamicAttribute)
Visual C++
property IDictionary<String^, IDynamicAttribute^>^ Attributes {
    IDictionary<String^, IDynamicAttribute^>^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Context Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Context Property
IParty Interface See Also Send Feedback
Context of the party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IContext Context { get; }
Visual Basic (Declaration)
ReadOnly Property Context As IContext
Visual C++
property IContext^ Context {
    IContext^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Device Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Device Property
IParty Interface See Also Send Feedback
Linked devices to the party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDevice[] Device { get; }
Visual Basic (Declaration)
ReadOnly Property Device As IDevice()
Visual C++
property array<IDevice^>^ Device {
    array<IDevice^>^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.DisplayName Property
IParty Interface See Also Send Feedback
Name displayed to the user

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string DisplayName { get; }
Visual Basic (Declaration)
ReadOnly Property DisplayName As String
Visual C++
property String^ DisplayName {
    String^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Extensions Property
IParty Interface See Also Send Feedback
Extensions of the party instance.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionary<string, IExtension> Extensions { get; }
Visual Basic (Declaration)
ReadOnly Property Extensions As IDictionary(Of String, IExtension)
Visual C++
property IDictionary<String^, IExtension^>^ Extensions {
    IDictionary<String^, IExtension^>^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Interaction Property
IParty Interface See Also Send Feedback
Linked interaction to the party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction Interaction { get; }
Visual Basic (Declaration)
ReadOnly Property Interaction As IInteraction
Visual C++
property IInteraction^ Interaction {
    IInteraction^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsIdentified Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.IsIdentified Property
IParty Interface See Also Send Feedback
True if the party could be identified

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsIdentified { get; }
Visual Basic (Declaration)
ReadOnly Property IsIdentified As Boolean
Visual C++
property bool IsIdentified {
    bool get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsMonitored Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.IsMonitored Property
IParty Interface See Also Send Feedback
True if the party is monitored.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsMonitored { get; }
Visual Basic (Declaration)
ReadOnly Property IsMonitored As Boolean
Visual C++
property bool IsMonitored {
    bool get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsOwner Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.IsOwner Property
IParty Interface See Also Send Feedback
True if this party is the interaction's owner.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsOwner { get; }
Visual Basic (Declaration)
ReadOnly Property IsOwner As Boolean
Visual C++
property bool IsOwner {
    bool get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Name Property
IParty Interface See Also Send Feedback
Name of the party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


PartyType Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.PartyType Property
IParty Interface See Also Send Feedback
Party type. Indicates whether this party is the caller, the callee, or a third party for instance during a transfer.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
PartyInfoType PartyType { get; }
Visual Basic (Declaration)
ReadOnly Property PartyType As PartyInfoType
Visual C++
property PartyInfoType PartyType {
    PartyInfoType get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IPreviewInteraction Interface

[image]

Enterprise SDK 8.0 Reference API
IPreviewInteraction Interface
Members See Also Send Feedback
Describes a preview interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IPreviewInteraction : ISerializable
Visual Basic (Declaration)
Public Interface IPreviewInteraction _
    Implements ISerializable
Visual C++
public interface class IPreviewInteraction : ISerializable

See Also

IPreviewInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


IPreviewInteraction Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPreviewInteraction Members
IPreviewInteraction Interface Methods See Also Send Feedback

The IPreviewInteraction type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IPreviewInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IPreviewInteraction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPreviewInteraction Methods
IPreviewInteraction Interface See Also Send Feedback

The IPreviewInteraction type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IPreviewInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


MakeCallType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MakeCallType Enumeration
See Also Send Feedback
Enumerates the possible call types for voice interactions.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum MakeCallType
Visual Basic (Declaration)
Public Enumeration MakeCallType
Visual C++
public enum class MakeCallType

Members

Member name | Description
Regular |
DirectAgent |
SupervisorAssist |
Priority |
DirectPriority |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


MediaContentType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MediaContentType Enumeration
See Also Send Feedback
Enumerates the media content types.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum MediaContentType
Visual Basic (Declaration)
Public Enumeration MediaContentType
Visual C++
public enum class MediaContentType

Members

Member name | Description
MediaVoice |
MediaIM |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


PartyInfoType Enumeration

[image]

Enterprise SDK 8.0 Reference API
PartyInfoType Enumeration
See Also Send Feedback
Enumerates the party types.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum PartyInfoType
Visual Basic (Declaration)
Public Enumeration PartyInfoType
Visual C++
public enum class PartyInfoType

Members

Member name | Description
Unknown |
Caller |
Callee |
ConferenceMember |
ConferenceMaster |
Supervisor |
Originator |
Target |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


PartyTranslationType Enumeration

[image]

Enterprise SDK 8.0 Reference API
PartyTranslationType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Interaction.PartyTranslationType"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum PartyTranslationType
Visual Basic (Declaration)
Public Enumeration PartyTranslationType
Visual C++
public enum class PartyTranslationType

Members

Member name | Description
Unknown |
Physical |
AgentLogin |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


ProfileType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ProfileType Enumeration
See Also Send Feedback
Enumerates the profile types.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum ProfileType
Visual Basic (Declaration)
Public Enumeration ProfileType
Visual C++
public enum class ProfileType

Members

Member name | Description
Unknown |
Primary |
PrimaryInConf |
Transfered |
TransferedInConf |
Consult |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


ReasonTypes Enumeration

[image]

Enterprise SDK 8.0 Reference API
ReasonTypes Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Interaction.ReasonTypes"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[FlagsAttribute]
public enum ReasonTypes
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration ReasonTypes
Visual C++
[FlagsAttribute]
public enum class ReasonTypes

Members

Member name | Description
None |
ObjectState |
ObjectComposition |
ObjectSubscriber |
ObjectListener |
ObjectContainer |
ObjectForwardMode |
ObjectDndMode |
ObjectAttribute |
StrategyAttribute |
ContextAttribute |
CapableAttribute |
AliasAttribute |
RoleAttribute |
MediaProtocolAttribute |
ConfigurableAttribute |
FilterAttribute |
ControllerAttribute |
CredentialAttribute |
ExtensionAttribute |
PartyAttribute |
SubscriberAttribute |
CustomDataAttribute |
SubSystem |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


Genesyslab.Enterprise.Model.Protocol Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Protocol Namespace
Send Feedback

Interfaces

Interface | Description
IEnterpriseProtocol | Interface for handling Media protocol.
IParam | Interface for managing protocol parameters.
IProtocolRequest | Interface for managing protocol.
ISwitchPolicy<(Of <(T>)>) | Interface for managing the switch policy.

Enumerations

Enumeration | Description
MediaDirectionType | Enumerates the media direction types.
MediaType | Enumerates for the media types.
SwitchModelType | Enumerates the switch model types.


IEnterpriseProtocol Interface

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol Interface
Members See Also Send Feedback
Interface for handling Media protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IEnterpriseProtocol
Visual Basic (Declaration)
Public Interface IEnterpriseProtocol
Visual C++
public interface class IEnterpriseProtocol

See Also

IEnterpriseProtocol Members
Genesyslab.Enterprise.Model.Protocol Namespace


IEnterpriseProtocol Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol Members
IEnterpriseProtocol Interface Methods Properties See Also Send Feedback

The IEnterpriseProtocol type exposes the following members.

Methods

Name | Description
Add | Overloaded.
GetProtocolRequest | Overloaded.
Remove | Removes a protocol.

Properties

Name | Description
ListProtocols | Gets the list of media protocols.
MediaSupport | Gets the media type of the protocol.
Name | Gets the name of the protocol.

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IEnterpriseProtocol Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol Methods
IEnterpriseProtocol Interface See Also Send Feedback

The IEnterpriseProtocol type exposes the following members.

Methods

Name | Description
Add | Overloaded.
GetProtocolRequest | Overloaded.
Remove | Removes a protocol.

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Add Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.Add Method
IEnterpriseProtocol Interface See Also Send Feedback

Overload List

Name | Description
Add(IProtocolRequest) | Adds a protocol.
Add(IEnumerable<(Of <(IProtocolRequest>)>)) | Adds a list of protocols.

See Also

IEnterpriseProtocol Interface
IEnterpriseProtocol Members
Genesyslab.Enterprise.Model.Protocol Namespace


Add Method (IProtocolRequest)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.Add Method (IProtocolRequest)
IEnterpriseProtocol Interface See Also Send Feedback
Adds a protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnterpriseProtocol Add(
    IProtocolRequest protocol
)
Visual Basic (Declaration)
Function Add ( _
    protocol As IProtocolRequest _
) As IEnterpriseProtocol
Visual C++
IEnterpriseProtocol^ Add(
    IProtocolRequest^ protocol
)

Parameters

protocol
Type: Genesyslab.Enterprise.Model.Protocol..::.IProtocolRequest
the protocol to add.

Return Value

the IEnterpriseProtocol.

See Also

IEnterpriseProtocol Interface
Add Overload
Genesyslab.Enterprise.Model.Protocol Namespace


Add Method (IEnumerable(IProtocolRequest))

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.Add Method (IEnumerable<(Of <(IProtocolRequest>)>))
IEnterpriseProtocol Interface See Also Send Feedback
Adds a list of protocols.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnterpriseProtocol Add(
    IEnumerable<IProtocolRequest> protocols
)
Visual Basic (Declaration)
Function Add ( _
    protocols As IEnumerable(Of IProtocolRequest) _
) As IEnterpriseProtocol
Visual C++
IEnterpriseProtocol^ Add(
    IEnumerable<IProtocolRequest^>^ protocols
)

Parameters

protocols
Type: System.Collections.Generic..::.IEnumerable<(Of <( IProtocolRequest >)>)
the list of protocols.

Return Value

the IEnterpriseProtocol.

See Also

IEnterpriseProtocol Interface
Add Overload
Genesyslab.Enterprise.Model.Protocol Namespace


GetProtocolRequest Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.GetProtocolRequest Method
IEnterpriseProtocol Interface See Also Send Feedback

Overload List

Name | Description
GetProtocolRequest(String) | Gets a protocol by its name.
GetProtocolRequest(String, Boolean) | Gets a protocol by name and switch abstraction flag.

See Also

IEnterpriseProtocol Interface
IEnterpriseProtocol Members
Genesyslab.Enterprise.Model.Protocol Namespace


GetProtocolRequest Method (String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.GetProtocolRequest Method (String)
IEnterpriseProtocol Interface See Also Send Feedback
Gets a protocol by its name.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IProtocolRequest GetProtocolRequest(
    string name
)
Visual Basic (Declaration)
Function GetProtocolRequest ( _
    name As String _
) As IProtocolRequest
Visual C++
IProtocolRequest^ GetProtocolRequest(
    String^ name
)

Parameters

name
Type: System..::.String
the name of the protocol.

Return Value

the IProtocolRequest.

See Also

IEnterpriseProtocol Interface
GetProtocolRequest Overload
Genesyslab.Enterprise.Model.Protocol Namespace


GetProtocolRequest Method (String, Boolean)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.GetProtocolRequest Method (String, Boolean)
IEnterpriseProtocol Interface See Also Send Feedback
Gets a protocol by name and switch abstraction flag.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IProtocolRequest GetProtocolRequest(
    string name,
    bool enableSwitchAbstraction
)
Visual Basic (Declaration)
Function GetProtocolRequest ( _
    name As String, _
    enableSwitchAbstraction As Boolean _
) As IProtocolRequest
Visual C++
IProtocolRequest^ GetProtocolRequest(
    String^ name,
    bool enableSwitchAbstraction
)

Parameters

name
Type: System..::.String
the name of the protocol.
enableSwitchAbstraction
Type: System..::.Boolean
the switch abstraction flag, true if switch abstraction is enabled.

Return Value

the IProtocolRequest.

See Also

IEnterpriseProtocol Interface
GetProtocolRequest Overload
Genesyslab.Enterprise.Model.Protocol Namespace


Remove Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.Remove Method
IEnterpriseProtocol Interface See Also Send Feedback
Removes a protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnterpriseProtocol Remove(
    IProtocolRequest protocol
)
Visual Basic (Declaration)
Function Remove ( _
    protocol As IProtocolRequest _
) As IEnterpriseProtocol
Visual C++
IEnterpriseProtocol^ Remove(
    IProtocolRequest^ protocol
)

Parameters

protocol
Type: Genesyslab.Enterprise.Model.Protocol..::.IProtocolRequest
the protocol to remove.

Return Value

the IEnterpriseProtocol.

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IEnterpriseProtocol Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol Properties
IEnterpriseProtocol Interface See Also Send Feedback

The IEnterpriseProtocol type exposes the following members.

Properties

Name | Description
ListProtocols | Gets the list of media protocols.
MediaSupport | Gets the media type of the protocol.
Name | Gets the name of the protocol.

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


ListProtocols Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.ListProtocols Property
IEnterpriseProtocol Interface See Also Send Feedback
Gets the list of media protocols.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ICollection<IProtocolRequest> ListProtocols { get; }
Visual Basic (Declaration)
ReadOnly Property ListProtocols As ICollection(Of IProtocolRequest)
Visual C++
property ICollection<IProtocolRequest^>^ ListProtocols {
    ICollection<IProtocolRequest^>^ get ();
}

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


MediaSupport Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.MediaSupport Property
IEnterpriseProtocol Interface See Also Send Feedback
Gets the media type of the protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
MediaType MediaSupport { get; }
Visual Basic (Declaration)
ReadOnly Property MediaSupport As MediaType
Visual C++
property MediaType MediaSupport {
    MediaType get ();
}

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.Name Property
IEnterpriseProtocol Interface See Also Send Feedback
Gets the name of the protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IParam Interface

[image]

Enterprise SDK 8.0 Reference API
IParam Interface
Members See Also Send Feedback
Interface for managing protocol parameters.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IParam
Visual Basic (Declaration)
Public Interface IParam
Visual C++
public interface class IParam

See Also

IParam Members
Genesyslab.Enterprise.Model.Protocol Namespace


IParam Members

[image] [image]

Enterprise SDK 8.0 Reference API
IParam Members
IParam Interface Methods Properties See Also Send Feedback

The IParam type exposes the following members.

Methods

Name | Description
Get | Gets the object.
ParamType | Gets the type of parameter.
Set | Sets an object as parameter.

Properties

Name | Description
Name | Gets the name of the parameter.

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IParam Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IParam Methods
IParam Interface See Also Send Feedback

The IParam type exposes the following members.

Methods

Name | Description
Get | Gets the object.
ParamType | Gets the type of parameter.
Set | Sets an object as parameter.

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Get Method

[image]

Enterprise SDK 8.0 Reference API
IParam..::.Get Method
IParam Interface See Also Send Feedback
Gets the object.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object Get()
Visual Basic (Declaration)
Function Get As Object
Visual C++
Object^ Get()

Return Value

returns the object.

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


ParamType Method

[image]

Enterprise SDK 8.0 Reference API
IParam..::.ParamType Method
IParam Interface See Also Send Feedback
Gets the type of parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Type ParamType()
Visual Basic (Declaration)
Function ParamType As Type
Visual C++
Type^ ParamType()

Return Value

the Type.

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Set Method

[image]

Enterprise SDK 8.0 Reference API
IParam..::.Set Method
IParam Interface See Also Send Feedback
Sets an object as parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IParam Set(
    Object data
)
Visual Basic (Declaration)
Function Set ( _
    data As Object _
) As IParam
Visual C++
IParam^ Set(
    Object^ data
)

Parameters

data
Type: System..::.Object
the object.

Return Value

the IParam.

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IParam Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IParam Properties
IParam Interface See Also Send Feedback

The IParam type exposes the following members.

Properties

Name | Description
Name | Gets the name of the parameter.

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IParam..::.Name Property
IParam Interface See Also Send Feedback
Gets the name of the parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IProtocolRequest Interface

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest Interface
Members See Also Send Feedback
Interface for managing protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IProtocolRequest
Visual Basic (Declaration)
Public Interface IProtocolRequest
Visual C++
public interface class IProtocolRequest

See Also

IProtocolRequest Members
Genesyslab.Enterprise.Model.Protocol Namespace


IProtocolRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolRequest Members
IProtocolRequest Interface Methods Properties See Also Send Feedback

The IProtocolRequest type exposes the following members.

Methods

Name | Description
AddParam | Adds a parameter to this protocol.
CreateCommands | Creates a command for this protocol.
Get | Gets a parameter.
GetCommands | Returns the list of commands for this protocol.
GetParams | Returns all the parameters of the protocol.
RemoveParam | Removes a parameter from this protocol.
To | Overloaded.
With | Overloaded.

Properties

Name | Description
Description | Gets the description of the protocol.
IsSynchronized | Returns true if the protocol is synchronized.
Name | Returns the name of the procotol.
SwitchPolicy | Gets or sets the switch policy which applies to this protocol and switch.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IProtocolRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolRequest Methods
IProtocolRequest Interface See Also Send Feedback

The IProtocolRequest type exposes the following members.

Methods

Name | Description
AddParam | Adds a parameter to this protocol.
CreateCommands | Creates a command for this protocol.
Get | Gets a parameter.
GetCommands | Returns the list of commands for this protocol.
GetParams | Returns all the parameters of the protocol.
RemoveParam | Removes a parameter from this protocol.
To | Overloaded.
With | Overloaded.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


AddParam Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.AddParam Method
IProtocolRequest Interface See Also Send Feedback
Adds a parameter to this protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IProtocolRequest AddParam(
    IParam item
)
Visual Basic (Declaration)
Function AddParam ( _
    item As IParam _
) As IProtocolRequest
Visual C++
IProtocolRequest^ AddParam(
    IParam^ item
)

Parameters

item
Type: Genesyslab.Enterprise.Model.Protocol..::.IParam
the item to add.

Return Value

the IProtocolRequest.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


CreateCommands Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.CreateCommands Method
IProtocolRequest Interface See Also Send Feedback
Creates a command for this protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ICollection<IProtocolRequest> CreateCommands()
Visual Basic (Declaration)
Function CreateCommands As ICollection(Of IProtocolRequest)
Visual C++
ICollection<IProtocolRequest^>^ CreateCommands()

Return Value

the collection of ProtocolRquests.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Get Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.Get Method
IProtocolRequest Interface See Also Send Feedback
Gets a parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object Get(
    string name
)
Visual Basic (Declaration)
Function Get ( _
    name As String _
) As Object
Visual C++
Object^ Get(
    String^ name
)

Parameters

name
Type: System..::.String
the parameter name.

Return Value

the object.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


GetCommands Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.GetCommands Method
IProtocolRequest Interface See Also Send Feedback
Returns the list of commands for this protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ICollection<string> GetCommands()
Visual Basic (Declaration)
Function GetCommands As ICollection(Of String)
Visual C++
ICollection<String^>^ GetCommands()

Return Value

Collection of protocol commands.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


GetParams Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.GetParams Method
IProtocolRequest Interface See Also Send Feedback
Returns all the parameters of the protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionary<string, IParam> GetParams()
Visual Basic (Declaration)
Function GetParams As IDictionary(Of String, IParam)
Visual C++
IDictionary<String^, IParam^>^ GetParams()

Return Value

the dictionary of protocols.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


RemoveParam Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.RemoveParam Method
IProtocolRequest Interface See Also Send Feedback
Removes a parameter from this protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IProtocolRequest RemoveParam(
    IParam item
)
Visual Basic (Declaration)
Function RemoveParam ( _
    item As IParam _
) As IProtocolRequest
Visual C++
IProtocolRequest^ RemoveParam(
    IParam^ item
)

Parameters

item
Type: Genesyslab.Enterprise.Model.Protocol..::.IParam
the item to remove.

Return Value

the IProtocolRequest.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


To Method

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.To Method
IProtocolRequest Interface See Also Send Feedback

Overload List

Name | Description
To(IClientChannel) | Sets the channel where to send the request and all parameters.
To(IClientChannel, String) | Sets the channel where to send the request and all parameters.

See Also

IProtocolRequest Interface
IProtocolRequest Members
Genesyslab.Enterprise.Model.Protocol Namespace


To Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.To Method (IClientChannel)
IProtocolRequest Interface See Also Send Feedback
Sets the channel where to send the request and all parameters.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
int To(
    IClientChannel channel
)
Visual Basic (Declaration)
Function To ( _
    channel As IClientChannel _
) As Integer
Visual C++
int To(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the channel.

Return Value

the request ID.

See Also

IProtocolRequest Interface
To Overload
Genesyslab.Enterprise.Model.Protocol Namespace


To Method (IClientChannel, String)

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.To Method (IClientChannel, String)
IProtocolRequest Interface See Also Send Feedback
Sets the channel where to send the request and all parameters.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
int To(
    IClientChannel channel,
    string correlatorData
)
Visual Basic (Declaration)
Function To ( _
    channel As IClientChannel, _
    correlatorData As String _
) As Integer
Visual C++
int To(
    IClientChannel^ channel,
    String^ correlatorData
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Target channelUser defined data
correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.To(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String)"]

Return Value

the request ID.

See Also

IProtocolRequest Interface
To Overload
Genesyslab.Enterprise.Model.Protocol Namespace


With Method

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.With Method
IProtocolRequest Interface See Also Send Feedback

Overload List

Name | Description
With(array<Object>[]()[]) | Sets a list of parameters.
With(String, Int32) | Sets an integer parameter.
With(String, Object) | Sets an object parameter.
With(String, String) | Sets a string parameter.

See Also

IProtocolRequest Interface
IProtocolRequest Members
Genesyslab.Enterprise.Model.Protocol Namespace


With Method (Object[])

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.With Method (array<Object>[]()[])
IProtocolRequest Interface See Also Send Feedback
Sets a list of parameters.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IProtocolRequest With(
    params Object[] list
)
Visual Basic (Declaration)
Function With ( _
    ParamArray list As Object() _
) As IProtocolRequest
Visual C++
IProtocolRequest^ With(
    ... array<Object^>^ list
)

Parameters

list
Type: array< System..::.Object >[]()[]
list of parameters.

Return Value

the IProtocolRequest.

See Also

IProtocolRequest Interface
With Overload
Genesyslab.Enterprise.Model.Protocol Namespace


With Method (String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.With Method (String, Int32)
IProtocolRequest Interface See Also Send Feedback
Sets an integer parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IProtocolRequest With(
    string name,
    int value
)
Visual Basic (Declaration)
Function With ( _
    name As String, _
    value As Integer _
) As IProtocolRequest
Visual C++
IProtocolRequest^ With(
    String^ name,
    int value
)

Parameters

name
Type: System..::.String
the parameter name.
value
Type: System..::.Int32
the parameter value.

Return Value

the IProtocolRequest.

See Also

IProtocolRequest Interface
With Overload
Genesyslab.Enterprise.Model.Protocol Namespace


With Method (String, Object)

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.With Method (String, Object)
IProtocolRequest Interface See Also Send Feedback
Sets an object parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IProtocolRequest With(
    string name,
    Object value
)
Visual Basic (Declaration)
Function With ( _
    name As String, _
    value As Object _
) As IProtocolRequest
Visual C++
IProtocolRequest^ With(
    String^ name,
    Object^ value
)

Parameters

name
Type: System..::.String
the parameter name.
value
Type: System..::.Object
the parameter value.

Return Value

the IProtocolRequest.

See Also

IProtocolRequest Interface
With Overload
Genesyslab.Enterprise.Model.Protocol Namespace


With Method (String, String)

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.With Method (String, String)
IProtocolRequest Interface See Also Send Feedback
Sets a string parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IProtocolRequest With(
    string name,
    string value
)
Visual Basic (Declaration)
Function With ( _
    name As String, _
    value As String _
) As IProtocolRequest
Visual C++
IProtocolRequest^ With(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::.String
the parameter name.
value
Type: System..::.String
the parameter value.

Return Value

the IProtocolRequest.

See Also

IProtocolRequest Interface
With Overload
Genesyslab.Enterprise.Model.Protocol Namespace


IProtocolRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolRequest Properties
IProtocolRequest Interface See Also Send Feedback

The IProtocolRequest type exposes the following members.

Properties

Name | Description
Description | Gets the description of the protocol.
IsSynchronized | Returns true if the protocol is synchronized.
Name | Returns the name of the procotol.
SwitchPolicy | Gets or sets the switch policy which applies to this protocol and switch.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.Description Property
IProtocolRequest Interface See Also Send Feedback
Gets the description of the protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IsSynchronized Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.IsSynchronized Property
IProtocolRequest Interface See Also Send Feedback
Returns true if the protocol is synchronized.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsSynchronized { get; }
Visual Basic (Declaration)
ReadOnly Property IsSynchronized As Boolean
Visual C++
property bool IsSynchronized {
    bool get ();
}

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.Name Property
IProtocolRequest Interface See Also Send Feedback
Returns the name of the procotol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


SwitchPolicy Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.SwitchPolicy Property
IProtocolRequest Interface See Also Send Feedback
Gets or sets the switch policy which applies to this protocol and switch.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object SwitchPolicy { get; set; }
Visual Basic (Declaration)
Property SwitchPolicy As Object
Visual C++
property Object^ SwitchPolicy {
    Object^ get ();
    void set (Object^ value);
}

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


ISwitchPolicy(T) Interface

[image]

Enterprise SDK 8.0 Reference API
ISwitchPolicy<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing the switch policy.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface ISwitchPolicy<T>
Visual Basic (Declaration)
Public Interface ISwitchPolicy(Of T)
Visual C++
generic<typename T>
public interface class ISwitchPolicy

Type Parameters

T
Type.

See Also

ISwitchPolicy<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Protocol Namespace


ISwitchPolicy(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISwitchPolicy<(Of <(T>)>) Members
ISwitchPolicy<(Of <(T>)>) Interface Properties See Also Send Feedback

The ISwitchPolicy<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
GetProtocolRule | Gets the rules that manages a protocol according to a switch.

See Also

ISwitchPolicy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Protocol Namespace


ISwitchPolicy(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ISwitchPolicy<(Of <(T>)>) Properties
ISwitchPolicy<(Of <(T>)>) Interface See Also Send Feedback

The ISwitchPolicy<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
GetProtocolRule | Gets the rules that manages a protocol according to a switch.

See Also

ISwitchPolicy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Protocol Namespace


GetProtocolRule Property

[image]

Enterprise SDK 8.0 Reference API
ISwitchPolicy<(Of <(T>)>)..::.GetProtocolRule Property
ISwitchPolicy<(Of <(T>)>) Interface See Also Send Feedback
Gets the rules that manages a protocol according to a switch.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
T GetProtocolRule { get; set; }
Visual Basic (Declaration)
Property GetProtocolRule As T
Visual C++
property T GetProtocolRule {
    T get ();
    void set (T value);
}

See Also

ISwitchPolicy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Protocol Namespace


MediaDirectionType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MediaDirectionType Enumeration
See Also Send Feedback
Enumerates the media direction types.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum MediaDirectionType
Visual Basic (Declaration)
Public Enumeration MediaDirectionType
Visual C++
public enum class MediaDirectionType

Members

Member name | Description
Unknown | Unknown direction.
In | Inbound direction.
Out | Outbound direction.

See Also

Genesyslab.Enterprise.Model.Protocol Namespace


MediaType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MediaType Enumeration
See Also Send Feedback
Enumerates for the media types.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[FlagsAttribute]
public enum MediaType
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration MediaType
Visual C++
[FlagsAttribute]
public enum class MediaType

Members

Member name | Description
Unknown | Media type not specified
Voice | Voice media.
Chat | Chat, Instant Messaging media.
Custom | Custom media.
All | All media.

See Also

Genesyslab.Enterprise.Model.Protocol Namespace


SwitchModelType Enumeration

[image]

Enterprise SDK 8.0 Reference API
SwitchModelType Enumeration
See Also Send Feedback
Enumerates the switch model types.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum SwitchModelType
Visual Basic (Declaration)
Public Enumeration SwitchModelType
Visual C++
public enum class SwitchModelType

Members

Member name | Description
Unknown | Unknown Switch.
AlcatelOxeClassic | Alcatel Oxe in Classic Mode Switch.
AlcatelOxeSubstitute | Alcatel Oxe in Substitute Mode Switch.
AlcatelOxeEmulated | Alcatel Oxe in Emulated Mode Switch.
LucentDefinityG3 | Lucent G3 Switch.
NortelDMS100 | Nortel DMS 100 Switch (Nortel Communication Server 2000/2001)
GenesysSip | Genesys SIP Server Soft Switch.
AspectCallCenter | Aspect switch
CiscoCM | Cisco Call Manager
IntecomIBX80 | EADS Telecom Intecom M6880 Point Span
EricssonMD110 | Ericsson MD110
NortelDMS100PDNMode | Nortel DMS 100 Switch with PDN mode (Nortel Communication Server 2000/2001)
NortelSymposium | Nortel CS1000 with Symposium
NortelMeridian | Nortel CS1000 with meridian link
NortelMeridianCallCenter | Nortel CS 1000 with meridian link
NEC | Nec switches ( NEC Small TDM, Small Hybrid, Large Hybrid, Large TDM )
NECSV7000 | NEC SV7000
RockwellSpectrum | Spcctrum
SiemensHicom300E | Siemens Hicom300 E
SiemensHicom300H | Siemens Hicom 300 H
SiemensHiPath4000 | Siemens HiPath 4000

See Also

Genesyslab.Enterprise.Model.Protocol Namespace


Genesyslab.Enterprise.Model.ServiceModel Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.ServiceModel Namespace
Send Feedback

Interfaces

Interface Description
IEnterpriseServiceProvider

Entry point of the Enterprise SDK.

As a start, create an instance of this interface. From that point, use it to retrieve ESDK services.

The following code snippet creates a new instance, passing a Unity container.

CopyC#
IEnterpriseServiceProvider EsdkService = new EnterpriseServiceProvider(new UnityContainer(), typeof(GlobalThreadLifeTimeManager), null);

Then, you can retrieve the services implemented by the Enterprise SDK. For instance, you get a instance of a channel service by passing its type as a string.

CopyC#
channelService = EsdkService.Resolve<IChannelService>("channelService");

IService
Service data.


IEnterpriseServiceProvider Interface

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider Interface
Members See Also Send Feedback

Entry point of the Enterprise SDK.

As a start, create an instance of this interface. From that point, use it to retrieve ESDK services.

The following code snippet creates a new instance, passing a Unity container.

CopyC#
IEnterpriseServiceProvider EsdkService = new EnterpriseServiceProvider(new UnityContainer(), typeof(GlobalThreadLifeTimeManager), null);

Then, you can retrieve the services implemented by the Enterprise SDK. For instance, you get a instance of a channel service by passing its type as a string.

CopyC#
channelService = EsdkService.Resolve<IChannelService>("channelService");

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IEnterpriseServiceProvider : IDisposable
Visual Basic (Declaration)
Public Interface IEnterpriseServiceProvider _
    Implements IDisposable
Visual C++
public interface class IEnterpriseServiceProvider : IDisposable

See Also

IEnterpriseServiceProvider Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


IEnterpriseServiceProvider Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider Members
IEnterpriseServiceProvider Interface Methods Properties See Also Send Feedback

The IEnterpriseServiceProvider type exposes the following members.

Methods

Name | Description
CreateChildContainer | Creates a child container for the current container.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Evaluate | Overloaded.
Load | Overloaded.
RegisterInstance<(Of <(TInterface>)>) | Registers an instance with the container.
RegisterType | Overloaded.
Resolve | Overloaded.
ResolveAll<(Of <(T>)>) | Resolves all the instances.

Properties

Name | Description
Filter | Define filter for plugin loading * - match zero or more characters ? - match any one character [abc] - match one character if it's in the characters inside the brackets. All other characters in the glob are literals. Example: *.dll
Provider | ¨ESDK provider.
ServiceName | Name.

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


IEnterpriseServiceProvider Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider Methods
IEnterpriseServiceProvider Interface See Also Send Feedback

The IEnterpriseServiceProvider type exposes the following members.

Methods

Name | Description
CreateChildContainer | Creates a child container for the current container.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Evaluate | Overloaded.
Load | Overloaded.
RegisterInstance<(Of <(TInterface>)>) | Registers an instance with the container.
RegisterType | Overloaded.
Resolve | Overloaded.
ResolveAll<(Of <(T>)>) | Resolves all the instances.

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


CreateChildContainer Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.CreateChildContainer Method
IEnterpriseServiceProvider Interface See Also Send Feedback
Creates a child container for the current container.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnterpriseServiceProvider CreateChildContainer()
Visual Basic (Declaration)
Function CreateChildContainer As IEnterpriseServiceProvider
Visual C++
IEnterpriseServiceProvider^ CreateChildContainer()

Return Value

the IEnterpriseServiceProvider.

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Evaluate Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Evaluate Method
IEnterpriseServiceProvider Interface See Also Send Feedback

Overload List

Name | Description
Evaluate<(Of <(T>)>)(T) | Applies the strategies of the container to objects built externally.
Evaluate<(Of <(T>)>)(T, String) | Applies the strategies of the container to objects built externally.

See Also

IEnterpriseServiceProvider Interface
IEnterpriseServiceProvider Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


Evaluate(T) Method (T)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Evaluate<(Of <(T>)>) Method (T)
IEnterpriseServiceProvider Interface See Also Send Feedback
Applies the strategies of the container to objects built externally.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnterpriseServiceProvider Evaluate<T>(
    T data
)
Visual Basic (Declaration)
Function Evaluate(Of T) ( _
    data As T _
) As IEnterpriseServiceProvider
Visual C++
generic<typename T>
IEnterpriseServiceProvider^ Evaluate(
    T data
)

Parameters

data
Type: T
Data.

Type Parameters

T
Data type.

Return Value

Provider.

See Also

IEnterpriseServiceProvider Interface
Evaluate Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Evaluate(T) Method (T, String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Evaluate<(Of <(T>)>) Method (T, String)
IEnterpriseServiceProvider Interface See Also Send Feedback
Applies the strategies of the container to objects built externally.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnterpriseServiceProvider Evaluate<T>(
    T data,
    string name
)
Visual Basic (Declaration)
Function Evaluate(Of T) ( _
    data As T, _
    name As String _
) As IEnterpriseServiceProvider
Visual C++
generic<typename T>
IEnterpriseServiceProvider^ Evaluate(
    T data,
    String^ name
)

Parameters

data
Type: T
Data.
name
Type: System..::.String
The name of the object.

Type Parameters

T
Data type.

Return Value

Provider.

See Also

IEnterpriseServiceProvider Interface
Evaluate Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Load Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Load Method
IEnterpriseServiceProvider Interface See Also Send Feedback

Overload List

Name | Description
Load()()() | Loads the services. Use it to force the loading of the services. By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method.
Load(Assembly) | Loads the services. Use it to force the loading of the services. By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method.
Load(String) | Loads the services. Use it to force the loading of the services. By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method.

See Also

IEnterpriseServiceProvider Interface
IEnterpriseServiceProvider Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


Load Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Load Method
IEnterpriseServiceProvider Interface See Also Send Feedback
Loads the services. Use it to force the loading of the services.

By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool Load()
Visual Basic (Declaration)
Function Load As Boolean
Visual C++
bool Load()

Return Value

True if the services are loaded.

See Also

IEnterpriseServiceProvider Interface
Load Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Load Method (Assembly)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Load Method (Assembly)
IEnterpriseServiceProvider Interface See Also Send Feedback
Loads the services. Use it to force the loading of the services.

By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool Load(
    Assembly asssembly
)
Visual Basic (Declaration)
Function Load ( _
    asssembly As Assembly _
) As Boolean
Visual C++
bool Load(
    Assembly^ asssembly
)

Parameters

asssembly
Type: System.Reflection..::.Assembly
Assembly which describes the services.

Return Value

Returns true if the services are loaded.

See Also

IEnterpriseServiceProvider Interface
Load Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Load Method (String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Load Method (String)
IEnterpriseServiceProvider Interface See Also Send Feedback
Loads the services. Use it to force the loading of the services.

By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool Load(
    string filename
)
Visual Basic (Declaration)
Function Load ( _
    filename As String _
) As Boolean
Visual C++
bool Load(
    String^ filename
)

Parameters

filename
Type: System..::.String
XML file which describes the services.

Return Value

Returns true if the service is loaded.

See Also

IEnterpriseServiceProvider Interface
Load Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterInstance(TInterface) Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterInstance<(Of <(TInterface>)>) Method
IEnterpriseServiceProvider Interface See Also Send Feedback
Registers an instance with the container.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnterpriseServiceProvider RegisterInstance<TInterface>(
    string name,
    TInterface instance
)
Visual Basic (Declaration)
Function RegisterInstance(Of TInterface) ( _
    name As String, _
    instance As TInterface _
) As IEnterpriseServiceProvider
Visual C++
generic<typename TInterface>
IEnterpriseServiceProvider^ RegisterInstance(
    String^ name,
    TInterface instance
)

Parameters

name
Type: System..::.String
Name for the new instance.
instance
Type: TInterface
Instance to register.

Type Parameters

TInterface
Type.

Return Value

IEnterpriseServiceProvider

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterType Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterType Method
IEnterpriseServiceProvider Interface See Also Send Feedback

Overload List

Name | Description
RegisterType<(Of <(T>)>)()()() | Registers a LifetimeManager for the given type with the container. No type mapping is performed for this type.
RegisterType(Type, Type) | Registers a type mapping with the container, where the created instances will use the provided LifetimeManager.
RegisterType(Type, Type, array<Object>[]()[]) | Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.
RegisterType(Type, Type, String) | Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.
RegisterType(Type, Type, String, array<Object>[]()[]) | Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.

See Also

IEnterpriseServiceProvider Interface
IEnterpriseServiceProvider Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterType(T) Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterType<(Of <(T>)>) Method
IEnterpriseServiceProvider Interface See Also Send Feedback
Registers a LifetimeManager for the given type with the container. No type mapping is performed for this type.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnterpriseServiceProvider RegisterType<T>()
Visual Basic (Declaration)
Function RegisterType(Of T) As IEnterpriseServiceProvider
Visual C++
generic<typename T>
IEnterpriseServiceProvider^ RegisterType()

Type Parameters

T
the type of data.

Return Value

IEnterpriseServiceProvider

See Also

IEnterpriseServiceProvider Interface
RegisterType Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterType Method (Type, Type)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterType Method (Type, Type)
IEnterpriseServiceProvider Interface See Also Send Feedback
Registers a type mapping with the container, where the created instances will use the provided LifetimeManager.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnterpriseServiceProvider RegisterType(
    Type from,
    Type to
)
Visual Basic (Declaration)
Function RegisterType ( _
    from As Type, _
    to As Type _
) As IEnterpriseServiceProvider
Visual C++
IEnterpriseServiceProvider^ RegisterType(
    Type^ from,
    Type^ to
)

Parameters

from
Type: System..::.Type
Interface to register.
to
Type: System..::.Type
Concrete class to map.

Return Value

IEnterpriseServiceProvider

See Also

IEnterpriseServiceProvider Interface
RegisterType Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterType Method (Type, Type, Object[])

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterType Method (Type, Type, array<Object>[]()[])
IEnterpriseServiceProvider Interface See Also Send Feedback
Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnterpriseServiceProvider RegisterType(
    Type from,
    Type to,
    params Object[] list
)
Visual Basic (Declaration)
Function RegisterType ( _
    from As Type, _
    to As Type, _
    ParamArray list As Object() _
) As IEnterpriseServiceProvider
Visual C++
IEnterpriseServiceProvider^ RegisterType(
    Type^ from,
    Type^ to,
    ... array<Object^>^ list
)

Parameters

from
Type: System..::.Type
Interface to register.
to
Type: System..::.Type
Concrete class to map.
list
Type: array< System..::.Object >[]()[]
Parameters for the object constructor.

Return Value

IEnterpriseServiceProvider

See Also

IEnterpriseServiceProvider Interface
RegisterType Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterType Method (Type, Type, String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterType Method (Type, Type, String)
IEnterpriseServiceProvider Interface See Also Send Feedback
Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnterpriseServiceProvider RegisterType(
    Type from,
    Type to,
    string name
)
Visual Basic (Declaration)
Function RegisterType ( _
    from As Type, _
    to As Type, _
    name As String _
) As IEnterpriseServiceProvider
Visual C++
IEnterpriseServiceProvider^ RegisterType(
    Type^ from,
    Type^ to,
    String^ name
)

Parameters

from
Type: System..::.Type
Interface to register.
to
Type: System..::.Type
Concrete class to map.
name
Type: System..::.String
the name of the instance.

Return Value

IEnterpriseServiceProvider

See Also

IEnterpriseServiceProvider Interface
RegisterType Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterType Method (Type, Type, String, Object[])

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterType Method (Type, Type, String, array<Object>[]()[])
IEnterpriseServiceProvider Interface See Also Send Feedback
Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnterpriseServiceProvider RegisterType(
    Type from,
    Type to,
    string name,
    params Object[] list
)
Visual Basic (Declaration)
Function RegisterType ( _
    from As Type, _
    to As Type, _
    name As String, _
    ParamArray list As Object() _
) As IEnterpriseServiceProvider
Visual C++
IEnterpriseServiceProvider^ RegisterType(
    Type^ from,
    Type^ to,
    String^ name,
    ... array<Object^>^ list
)

Parameters

from
Type: System..::.Type
Interface to register.
to
Type: System..::.Type
Concrete class to map.
name
Type: System..::.String
The name of the instance.
list
Type: array< System..::.Object >[]()[]
Parameters for the object constructor.

Return Value

IEnterpriseServiceProvider

See Also

IEnterpriseServiceProvider Interface
RegisterType Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Resolve Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Resolve Method
IEnterpriseServiceProvider Interface See Also Send Feedback

Overload List

Name | Description
Resolve<(Of <(T>)>)()()() | Resolves an instance of the requested type.
Resolve<(Of <(T>)>)(String) | Resolves an instance.
Resolve(Type) | Resolves an instance of the requested type.
Resolve(Type, String) | Resolves an instance of the requested type with the given name.

See Also

IEnterpriseServiceProvider Interface
IEnterpriseServiceProvider Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


Resolve(T) Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Resolve<(Of <(T>)>) Method
IEnterpriseServiceProvider Interface See Also Send Feedback
Resolves an instance of the requested type.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
T Resolve<T>()
Visual Basic (Declaration)
Function Resolve(Of T) As T
Visual C++
generic<typename T>
T Resolve()

Type Parameters

T
Type.

Return Value

an instance of the type.

See Also

IEnterpriseServiceProvider Interface
Resolve Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Resolve(T) Method (String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Resolve<(Of <(T>)>) Method (String)
IEnterpriseServiceProvider Interface See Also Send Feedback
Resolves an instance.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
T Resolve<T>(
    string name
)
Visual Basic (Declaration)
Function Resolve(Of T) ( _
    name As String _
) As T
Visual C++
generic<typename T>
T Resolve(
    String^ name
)

Parameters

name
Type: System..::.String
Name of the service to resolve.

Type Parameters

T
Type.

Return Value

an instance of the type.

See Also

IEnterpriseServiceProvider Interface
Resolve Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Resolve Method (Type)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Resolve Method (Type)
IEnterpriseServiceProvider Interface See Also Send Feedback
Resolves an instance of the requested type.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object Resolve(
    Type t
)
Visual Basic (Declaration)
Function Resolve ( _
    t As Type _
) As Object
Visual C++
Object^ Resolve(
    Type^ t
)

Parameters

t
Type: System..::.Type
Type to resolve.

Return Value

Instance.

See Also

IEnterpriseServiceProvider Interface
Resolve Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Resolve Method (Type, String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Resolve Method (Type, String)
IEnterpriseServiceProvider Interface See Also Send Feedback
Resolves an instance of the requested type with the given name.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object Resolve(
    Type t,
    string name
)
Visual Basic (Declaration)
Function Resolve ( _
    t As Type, _
    name As String _
) As Object
Visual C++
Object^ Resolve(
    Type^ t,
    String^ name
)

Parameters

t
Type: System..::.Type
Type to resolve.
name
Type: System..::.String
The name of the object to resolve.

Return Value

object

See Also

IEnterpriseServiceProvider Interface
Resolve Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


ResolveAll(T) Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.ResolveAll<(Of <(T>)>) Method
IEnterpriseServiceProvider Interface See Also Send Feedback
Resolves all the instances.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnumerable<T> ResolveAll<T>()
Visual Basic (Declaration)
Function ResolveAll(Of T) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ResolveAll()

Type Parameters

T
The type to resolve.

Return Value

the enumeration of all instances.

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


IEnterpriseServiceProvider Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider Properties
IEnterpriseServiceProvider Interface See Also Send Feedback

The IEnterpriseServiceProvider type exposes the following members.

Properties

Name | Description
Filter | Define filter for plugin loading * - match zero or more characters ? - match any one character [abc] - match one character if it's in the characters inside the brackets. All other characters in the glob are literals. Example: *.dll
Provider | ¨ESDK provider.
ServiceName | Name.

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Filter Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Filter Property
IEnterpriseServiceProvider Interface See Also Send Feedback
Define filter for plugin loading * - match zero or more characters ? - match any one character [abc] - match one character if it's in the characters inside the brackets. All other characters in the glob are literals. Example: *.dll

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Filter { get; set; }
Visual Basic (Declaration)
Property Filter As String
Visual C++
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Provider Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Provider Property
IEnterpriseServiceProvider Interface See Also Send Feedback
¨ESDK provider.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnterpriseServiceProvider Provider { get; }
Visual Basic (Declaration)
ReadOnly Property Provider As IEnterpriseServiceProvider
Visual C++
property IEnterpriseServiceProvider^ Provider {
    IEnterpriseServiceProvider^ get ();
}

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


ServiceName Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.ServiceName Property
IEnterpriseServiceProvider Interface See Also Send Feedback
Name.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string ServiceName { get; }
Visual Basic (Declaration)
ReadOnly Property ServiceName As String
Visual C++
property String^ ServiceName {
    String^ get ();
}

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


IService Interface

[image]

Enterprise SDK 8.0 Reference API
IService Interface
Members See Also Send Feedback
Service data.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IService : IDisposable
Visual Basic (Declaration)
Public Interface IService _
    Implements IDisposable
Visual C++
public interface class IService : IDisposable

See Also

IService Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


IService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IService Members
IService Interface Methods Properties See Also Send Feedback

The IService type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)

Properties

Name | Description
Container | Container.
Description | Service description.
FQName | Fully Qualified Name.
LifeTimeManager | Life time manager.
ParentContainer | Parent container.
ServiceName | Name of the service.

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


IService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IService Methods
IService Interface See Also Send Feedback

The IService type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


IService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IService Properties
IService Interface See Also Send Feedback

The IService type exposes the following members.

Properties

Name | Description
Container | Container.
Description | Service description.
FQName | Fully Qualified Name.
LifeTimeManager | Life time manager.
ParentContainer | Parent container.
ServiceName | Name of the service.

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Container Property

[image]

Enterprise SDK 8.0 Reference API
IService..::.Container Property
IService Interface See Also Send Feedback
Container.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object Container { get; }
Visual Basic (Declaration)
ReadOnly Property Container As Object
Visual C++
property Object^ Container {
    Object^ get ();
}

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IService..::.Description Property
IService Interface See Also Send Feedback
Service description.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Description { get; set; }
Visual Basic (Declaration)
Property Description As String
Visual C++
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
IService..::.FQName Property
IService Interface See Also Send Feedback
Fully Qualified Name.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string FQName { get; }
Visual Basic (Declaration)
ReadOnly Property FQName As String
Visual C++
property String^ FQName {
    String^ get ();
}

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


LifeTimeManager Property

[image]

Enterprise SDK 8.0 Reference API
IService..::.LifeTimeManager Property
IService Interface See Also Send Feedback
Life time manager.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Type LifeTimeManager { get; }
Visual Basic (Declaration)
ReadOnly Property LifeTimeManager As Type
Visual C++
property Type^ LifeTimeManager {
    Type^ get ();
}

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


ParentContainer Property

[image]

Enterprise SDK 8.0 Reference API
IService..::.ParentContainer Property
IService Interface See Also Send Feedback
Parent container.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object ParentContainer { get; }
Visual Basic (Declaration)
ReadOnly Property ParentContainer As Object
Visual C++
property Object^ ParentContainer {
    Object^ get ();
}

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


ServiceName Property

[image]

Enterprise SDK 8.0 Reference API
IService..::.ServiceName Property
IService Interface See Also Send Feedback
Name of the service.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string ServiceName { get; }
Visual Basic (Declaration)
ReadOnly Property ServiceName As String
Visual C++
property String^ ServiceName {
    String^ get ();
}

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Genesyslab.Enterprise.Services Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Services Namespace
Send Feedback

Classes

Class Description
CustomSubscriber<(Of <(T>)>)
Abstract class for creation of Entreprise IService.
EnterpriseServiceProvider
Entry point of the Enterprise SDK.

As a start, create an instance of this interface. From that point, use it to retrieve ESDK services.

The following code snippet creates a new instance, passing a Unity container.

CopyC#
IEnterpriseServiceProvider EsdkService = new EnterpriseServiceProvider(new UnityContainer(), typeof(GlobalThreadLifeTimeManager), null);

Then, you can retrieve the services implemented by the Enterprise SDK. For instance, you get a instance of a channel service by passing its type as a string.

CopyC#
channelService = EsdkService.Resolve<IChannelService>("channelService");

EnterpriseServiceProviderExtension
Advanced methods for EnterpriseServiceProvider class.
StatisticsItem
SupervisorObjectState
State for the supervisor.
SupervisorService
Monitor class implementation
VoiceService

Interfaces

Interface | Description
IAgentService | Interface for Agent management.
IChannelService | Interface for managing channels. With this interface, you declare and declare new communication channels, one for each media connection (for instance a switch.)
IDeviceDomain | Manages device data.
IDeviceService | Manages handlers and filters on devices.
IEntityDomain | Manages entities and identities for groups and persons.
IEventManager<(Of <(D, T>)>) | Event Manager.
IIdentityDomain | Manages the identity domain.
IIdentityService | Manages the identities. Note: To use an agent with a device, create a link between these objects with the IIdentityService.SetDevice() method.
IIMDomain | Manages Instant Messaging data.
IIMService |
IInteractionDomain | Enables your application to manage interactions.
IMonitorService | Statistics service.
IPreviewDomain | Preview Interaction domain.
IPreviewService | Manages the Preview Interaction features.
IPSTService | Provides Possible State Transition (PST) information. The isPossible methods of this service use the loaded stategies and the given objects' data (including its own status and strategies) to determine whether a requested action can be processed. The isCapable methods of this service use the loaded strategies to indicate whether the feature is available regardless of the object status. For instance, if your switch does not provide a mute feature, the isCapable methods return false for the ProtocolAction.MuteOn action.
ISupervisorDomain | Actions of the supervisor domain.
ISupervisorInfo | Describes the supervisor information of the object identified by the Id member. The MonitorObject member identifies the type of the monitored object (possible types are enumerated in SupervisorObjectType: agent, interaction, device, and so on.)
ISupervisorService |
IVoiceService | Manages callback and filters related to interaction events.

Delegates

Delegate | Description
MonitorMethodDelegate | Listener for Statistics events. This is the callback for subscribed statistics events.

Enumerations

Enumeration | Description
AgentAction | Enumerates the actions that are possible on this agent. To be used in the methods of IsPossible.
DeviceAction | Enumerates the actions that are possible on this device. To be used in the methods of IsPossible.
ForwardAction | Enumerates the actions that are possible on this agent. To be used in the methods of IsPossible.
MessageContentType | Enumerates the content type of the message.
MonitorNotificationMode | Statistics Notification mode. Event notification mode for subscribed statistics.
MonitorObjectType | Enumerate for statistics object type. Type of the statistics objects that can be monitored.
ProtocolAction | Enumerates the actions that are possible on this interaction. To be used in the methods of IsPossible.
SupervisorModeType | Enumerates the monitor modes.
SupervisorObjectType | Enumerates the types of objects involved in supervision.
SupervisorStateType | Enumerates the supervisor statuses.


AgentAction Enumeration

[image]

Enterprise SDK 8.0 Reference API
AgentAction Enumeration
See Also Send Feedback
Enumerates the actions that are possible on this agent. To be used in the methods of IsPossible.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum AgentAction
Visual Basic (Declaration)
Public Enumeration AgentAction
Visual C++
public enum class AgentAction

Members

Member name | Description
Login | Login this device.
Logout | Logout this device.
NotReady | Sets not ready this device.
Ready | Sets this device ready.

See Also

Genesyslab.Enterprise.Services Namespace


CustomSubscriber(T) Class

[image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>) Class
Members See Also Send Feedback
Abstract class for creation of Entreprise IService.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public abstract class CustomSubscriber<T> : ContainerBase,
    IBrokerSubscriber<T>, IBrokerPublisher
Visual Basic (Declaration)
Public MustInherit Class CustomSubscriber(Of T) _
    Inherits ContainerBase _
    Implements IBrokerSubscriber(Of T), IBrokerPublisher
Visual C++
generic<typename T>
public ref class CustomSubscriber abstract : public ContainerBase,
    IBrokerSubscriber<T>, IBrokerPublisher

Type Parameters

T
the type of data.

Inheritance Hierarchy

System..::.Object
ContainerBase
Genesyslab.Enterprise.Services..::.CustomSubscriber<(Of <(T>)>)
Genesyslab.Enterprise.Services..::.SupervisorService
Genesyslab.Enterprise.Services..::.VoiceService

See Also

CustomSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Services Namespace


CustomSubscriber(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>) Members
CustomSubscriber<(Of <(T>)>) Class Methods Properties See Also Send Feedback

The CustomSubscriber<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetList | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Publish<(Of <(T>)>) | Publishes an object to listening subscribers.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of service subscribers.
EventSubscription | Gets the Service subscriber.

See Also

CustomSubscriber<(Of <(T>)>) Class
Genesyslab.Enterprise.Services Namespace


CustomSubscriber(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>) Methods
CustomSubscriber<(Of <(T>)>) Class See Also Send Feedback

The CustomSubscriber<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetList | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Publish<(Of <(T>)>) | Publishes an object to listening subscribers.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomSubscriber<(Of <(T>)>) Class
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>)..::.GetList Method
CustomSubscriber<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the collection of service subscribers.
GetList(Type, ItemLocation) | Gets the collection of service subscribers.

See Also

CustomSubscriber<(Of <(T>)>) Class
CustomSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Services Namespace


GetList(U) Method (ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>)..::.GetList<(Of <(U>)>) Method (ItemLocation)
CustomSubscriber<(Of <(T>)>) Class See Also Send Feedback
Gets the collection of service subscribers.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnumerable<U> GetList<U>(
    ItemLocation flag
)
Visual Basic (Declaration)
Public Function GetList(Of U) ( _
    flag As ItemLocation _
) As IEnumerable(Of U)
Visual C++
public:
generic<typename U>
virtual IEnumerable<U>^ GetList(
    ItemLocation flag
) sealed

Parameters

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
the item location flag.

Type Parameters

U
the type of data.

Return Value

the enumeration.

See Also

CustomSubscriber<(Of <(T>)>) Class
GetList Overload
Genesyslab.Enterprise.Services Namespace


GetList Method (Type, ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>)..::.GetList Method (Type, ItemLocation)
CustomSubscriber<(Of <(T>)>) Class See Also Send Feedback
Gets the collection of service subscribers.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnumerable GetList(
    Type targetObject,
    ItemLocation flag
)
Visual Basic (Declaration)
Public Function GetList ( _
    targetObject As Type, _
    flag As ItemLocation _
) As IEnumerable
Visual C++
public:
virtual IEnumerable^ GetList(
    Type^ targetObject,
    ItemLocation flag
) sealed

Parameters

targetObject
Type: System..::.Type
the type of data.
flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
the item location flag.

Return Value

the enumeration.

Implements

IBrokerSubscriber<(Of <(T>)>)..::.GetList(Type, ItemLocation)

See Also

CustomSubscriber<(Of <(T>)>) Class
GetList Overload
Genesyslab.Enterprise.Services Namespace


Publish(T) Method

[image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>)..::.Publish<(Of <(T>)>) Method
CustomSubscriber<(Of <(T>)>) Class See Also Send Feedback
Publishes an object to listening subscribers.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IBrokerPublisher Publish<T>(
    T obj
)
Visual Basic (Declaration)
Public Function Publish(Of T) ( _
    obj As T _
) As IBrokerPublisher
Visual C++
public:
generic<typename T>
virtual IBrokerPublisher^ Publish(
    T obj
) sealed

Parameters

obj
Type: T
the object instance to publish.

Type Parameters

T
the object type.

Return Value

the IBrokerPublisher.

Implements

IBrokerPublisher..::.Publish<(Of <(T>)>)(T)

See Also

CustomSubscriber<(Of <(T>)>) Class
Genesyslab.Enterprise.Services Namespace


CustomSubscriber(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>) Properties
CustomSubscriber<(Of <(T>)>) Class See Also Send Feedback

The CustomSubscriber<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Count | Gets the number of service subscribers.
EventSubscription | Gets the Service subscriber.

See Also

CustomSubscriber<(Of <(T>)>) Class
Genesyslab.Enterprise.Services Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>)..::.Count Property
CustomSubscriber<(Of <(T>)>) Class See Also Send Feedback
Gets the number of service subscribers.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IBrokerSubscriber<(Of <(T>)>)..::.Count

See Also

CustomSubscriber<(Of <(T>)>) Class
Genesyslab.Enterprise.Services Namespace


EventSubscription Property

[image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>)..::.EventSubscription Property
CustomSubscriber<(Of <(T>)>) Class See Also Send Feedback
Gets the Service subscriber.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public virtual IServiceSubscriber<T> EventSubscription { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property EventSubscription As IServiceSubscriber(Of T)
Visual C++
public:
virtual property IServiceSubscriber<T>^ EventSubscription {
    IServiceSubscriber<T>^ get ();
}

Implements

IBrokerSubscriber<(Of <(T>)>)..::.EventSubscription

See Also

CustomSubscriber<(Of <(T>)>) Class
Genesyslab.Enterprise.Services Namespace


DeviceAction Enumeration

[image]

Enterprise SDK 8.0 Reference API
DeviceAction Enumeration
See Also Send Feedback
Enumerates the actions that are possible on this device. To be used in the methods of IsPossible.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum DeviceAction
Visual Basic (Declaration)
Public Enumeration DeviceAction
Visual C++
public enum class DeviceAction

Members

Member name | Description
CancelForward | Sets the Forwarding feature to Off.
Login | Login this device.
Logout | Logout this device.
NotReady | Sets not ready this device.
Ready | Sets this device ready.
SetDNDOff | Deactivates the Do-Not-Disturb (DND) mode.
SetDNDOn | Activates the Do-Not-Disturb (DND) mode.
SetForward | Sets the Forwarding feature to On.

See Also

Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Class

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Class
Members See Also Send Feedback
Entry point of the Enterprise SDK.

As a start, create an instance of this interface. From that point, use it to retrieve ESDK services.

The following code snippet creates a new instance, passing a Unity container.

CopyC#
IEnterpriseServiceProvider EsdkService = new EnterpriseServiceProvider(new UnityContainer(), typeof(GlobalThreadLifeTimeManager), null);

Then, you can retrieve the services implemented by the Enterprise SDK. For instance, you get a instance of a channel service by passing its type as a string.

CopyC#
channelService = EsdkService.Resolve<IChannelService>("channelService");

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public class EnterpriseServiceProvider : IService,
    IEnterpriseServiceProvider, IDisposable
Visual Basic (Declaration)
Public Class EnterpriseServiceProvider _
    Implements IService, IEnterpriseServiceProvider, IDisposable
Visual C++
public ref class EnterpriseServiceProvider : IService,
    IEnterpriseServiceProvider, IDisposable

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Services..::.EnterpriseServiceProvider

See Also

EnterpriseServiceProvider Members
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Members

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Members
EnterpriseServiceProvider Class Constructors Methods Properties See Also Send Feedback

The EnterpriseServiceProvider type exposes the following members.

Constructors

Name | Description
EnterpriseServiceProvider | Overloaded.

Methods

Name | Description
CreateChildContainer | Creates a child container for the current container.
Dispose | Cleans this object. Therefore, you should call GC.SupressFinalize to take this object off the finalization queue and prevent finalization code for this object from executing a second time.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Overloaded.
RegisterInstance<(Of <(TInterface>)>) | Registers an instance with the container.
RegisterType | Overloaded.
Resolve | Overloaded.
ResolveAll<(Of <(T>)>) | Resolves all.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Container | Container.
Description | Description.
Filter | Define filter for plugin loading * - match zero or more characters ? - match any one character [abc] - match one character if it's in the characters inside the brackets. All other characters in the glob are literals. Example: *.dll
FQName | Fully Qualified Name (Unique ID).
LifeTimeManager | Lifetime manager.
Logger | Returns the logger.
ParentContainer | Parent container.
Provider | Applies the strategies of the container to objects built externally.
ServiceName | Returns the service name.

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Constructor
EnterpriseServiceProvider Class See Also Send Feedback

Overload List

Name | Description
EnterpriseServiceProvider(ILogger) | Creates a new service provider instance, which uses the given logger.
EnterpriseServiceProvider(ILogger, ILogger) | Creates a new service provider instance, which uses the given loggers.
EnterpriseServiceProvider(Object, ILogger) | Injection constructor.
EnterpriseServiceProvider(Object, ILogger, ILogger) | Creates a new service provider instance, which uses the given logger.
EnterpriseServiceProvider(Object, Type, ILogger) | Injection constructor.
EnterpriseServiceProvider(Object, Type, ILogger, ILogger) | Injection constructor.

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Members
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Constructor ()

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Constructor ()
EnterpriseServiceProvider Class See Also Send Feedback
Creates a new service provider instance, which uses the given logger.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseServiceProvider(
    ILogger enterpriseLogger
)
Visual Basic (Declaration)
Public Sub New ( _
    enterpriseLogger As ILogger _
)
Visual C++
public:
EnterpriseServiceProvider(
    ILogger^ enterpriseLogger
)

Parameters

enterpriseLogger
Type: ILogger
Enterprise SDK logger.

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Overload
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Constructor (, )

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Constructor (, )
EnterpriseServiceProvider Class See Also Send Feedback
Creates a new service provider instance, which uses the given loggers.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseServiceProvider(
    ILogger enterpriseLogger,
    ILogger psdkLogger
)
Visual Basic (Declaration)
Public Sub New ( _
    enterpriseLogger As ILogger, _
    psdkLogger As ILogger _
)
Visual C++
public:
EnterpriseServiceProvider(
    ILogger^ enterpriseLogger,
    ILogger^ psdkLogger
)

Parameters

enterpriseLogger
Type: ILogger
Enterprise SDK logger.
psdkLogger
Type: ILogger
Platform SDK logger to separate PSDK messages from Enterprise SDK messages. If null, enterprise logger is used instead

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Overload
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Constructor (Object, )

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Constructor (Object, )
EnterpriseServiceProvider Class See Also Send Feedback
Injection constructor.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseServiceProvider(
    Object container,
    ILogger enterpriseLogger
)
Visual Basic (Declaration)
Public Sub New ( _
    container As Object, _
    enterpriseLogger As ILogger _
)
Visual C++
public:
EnterpriseServiceProvider(
    Object^ container,
    ILogger^ enterpriseLogger
)

Parameters

container
Type: System..::.Object
the external container.
enterpriseLogger
Type: ILogger
Enterprise SDK logger.

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Overload
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Constructor (Object, , )

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Constructor (Object, , )
EnterpriseServiceProvider Class See Also Send Feedback
Creates a new service provider instance, which uses the given logger.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseServiceProvider(
    Object container,
    ILogger enterpriseLogger,
    ILogger psdkLogger
)
Visual Basic (Declaration)
Public Sub New ( _
    container As Object, _
    enterpriseLogger As ILogger, _
    psdkLogger As ILogger _
)
Visual C++
public:
EnterpriseServiceProvider(
    Object^ container,
    ILogger^ enterpriseLogger,
    ILogger^ psdkLogger
)

Parameters

container
Type: System..::.Object
the external container.
enterpriseLogger
Type: ILogger
Enterprise SDK logger.
psdkLogger
Type: ILogger
Platform SDK logger to separate PSDK messages from Enterprise SDK messages. If null, enterprise logger is used instead

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Overload
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Constructor (Object, Type, )

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Constructor (Object, Type, )
EnterpriseServiceProvider Class See Also Send Feedback
Injection constructor.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseServiceProvider(
    Object container,
    Type lfm,
    ILogger enterpriseLogger
)
Visual Basic (Declaration)
Public Sub New ( _
    container As Object, _
    lfm As Type, _
    enterpriseLogger As ILogger _
)
Visual C++
public:
EnterpriseServiceProvider(
    Object^ container,
    Type^ lfm,
    ILogger^ enterpriseLogger
)

Parameters

container
Type: System..::.Object
the external container.
lfm
Type: System..::.Type
the life time manager of instances
enterpriseLogger
Type: ILogger
Enterprise SDK logger.

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Overload
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Constructor (Object, Type, , )

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Constructor (Object, Type, , )
EnterpriseServiceProvider Class See Also Send Feedback
Injection constructor.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public EnterpriseServiceProvider(
    Object container,
    Type lfm,
    ILogger enterpriseLogger,
    ILogger psdkLogger
)
Visual Basic (Declaration)
Public Sub New ( _
    container As Object, _
    lfm As Type, _
    enterpriseLogger As ILogger, _
    psdkLogger As ILogger _
)
Visual C++
public:
EnterpriseServiceProvider(
    Object^ container,
    Type^ lfm,
    ILogger^ enterpriseLogger,
    ILogger^ psdkLogger
)

Parameters

container
Type: System..::.Object
the external container.
lfm
Type: System..::.Type
the life time manager of instances
enterpriseLogger
Type: ILogger
Enterprise SDK logger.
psdkLogger
Type: ILogger
Platform SDK logger to separate PSDK messages from Enterprise SDK messages. If null, enterprise logger is used instead

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Overload
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Methods

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Methods
EnterpriseServiceProvider Class See Also Send Feedback

The EnterpriseServiceProvider type exposes the following members.

Methods

Name | Description
CreateChildContainer | Creates a child container for the current container.
Dispose | Cleans this object. Therefore, you should call GC.SupressFinalize to take this object off the finalization queue and prevent finalization code for this object from executing a second time.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Overloaded.
RegisterInstance<(Of <(TInterface>)>) | Registers an instance with the container.
RegisterType | Overloaded.
Resolve | Overloaded.
ResolveAll<(Of <(T>)>) | Resolves all.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


CreateChildContainer Method

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.CreateChildContainer Method
EnterpriseServiceProvider Class See Also Send Feedback
Creates a child container for the current container.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnterpriseServiceProvider CreateChildContainer()
Visual Basic (Declaration)
Public Function CreateChildContainer As IEnterpriseServiceProvider
Visual C++
public:
virtual IEnterpriseServiceProvider^ CreateChildContainer() sealed

Return Value

the IEnterpriseServiceProvider.

Implements

IEnterpriseServiceProvider..::.CreateChildContainer()()()

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


Dispose Method

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Dispose Method
EnterpriseServiceProvider Class See Also Send Feedback
Cleans this object. Therefore, you should call GC.SupressFinalize to take this object off the finalization queue and prevent finalization code for this object from executing a second time.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


Evaluate Method

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Evaluate Method
EnterpriseServiceProvider Class See Also Send Feedback

Overload List

Name | Description
Evaluate<(Of <(T>)>)(T) | Applies the strategies of the container to objects built externally.
Evaluate<(Of <(T>)>)(T, String) | Evaluate a typed and named object externally created with container strategies (Externally means not created by the serviceProvider container)

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Members
Genesyslab.Enterprise.Services Namespace


Evaluate(T) Method (T)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Evaluate<(Of <(T>)>) Method (T)
EnterpriseServiceProvider Class See Also Send Feedback
Applies the strategies of the container to objects built externally.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnterpriseServiceProvider Evaluate<T>(
    T data
)
Visual Basic (Declaration)
Public Function Evaluate(Of T) ( _
    data As T _
) As IEnterpriseServiceProvider
Visual C++
public:
generic<typename T>
virtual IEnterpriseServiceProvider^ Evaluate(
    T data
) sealed

Parameters

data
Type: T
Data.

Type Parameters

T
Data type.

Return Value

Provider.

Implements

IEnterpriseServiceProvider..::.Evaluate<(Of <(T>)>)(T)

See Also

EnterpriseServiceProvider Class
Evaluate Overload
Genesyslab.Enterprise.Services Namespace


Evaluate(T) Method (T, String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Evaluate<(Of <(T>)>) Method (T, String)
EnterpriseServiceProvider Class See Also Send Feedback
Evaluate a typed and named object externally created with container strategies (Externally means not created by the serviceProvider container)

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnterpriseServiceProvider Evaluate<T>(
    T data,
    string name
)
Visual Basic (Declaration)
Public Function Evaluate(Of T) ( _
    data As T, _
    name As String _
) As IEnterpriseServiceProvider
Visual C++
public:
generic<typename T>
virtual IEnterpriseServiceProvider^ Evaluate(
    T data,
    String^ name
) sealed

Parameters

data
Type: T

[Missing <param name="data"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.Evaluate``1(``0,System.String)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.Evaluate``1(``0,System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.Evaluate``1(``0,System.String)"]

Return Value

IEnterpriseServiceProvider

Implements

IEnterpriseServiceProvider..::.Evaluate<(Of <(T>)>)(T, String)

See Also

EnterpriseServiceProvider Class
Evaluate Overload
Genesyslab.Enterprise.Services Namespace


Load Method

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Load Method
EnterpriseServiceProvider Class See Also Send Feedback

Overload List

Name | Description
Load()()() | Loads the predefined services. Use it to force the loading of the services. By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the Initialize() method, and call this Load() method.
Load(Assembly) | Loads a specific assembly into the ServiceProvider container.
Load(String) | Loads a configuration file to configure the container. Loading does not overwrite the existing configuration of the container.

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Members
Genesyslab.Enterprise.Services Namespace


Load Method

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Load Method
EnterpriseServiceProvider Class See Also Send Feedback
Loads the predefined services. Use it to force the loading of the services.

By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the Initialize() method, and call this Load() method.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public virtual bool Load()
Visual Basic (Declaration)
Public Overridable Function Load As Boolean
Visual C++
public:
virtual bool Load()

Return Value

True if the services are loaded.

Implements

IEnterpriseServiceProvider..::.Load()()()

See Also

EnterpriseServiceProvider Class
Load Overload
Genesyslab.Enterprise.Services Namespace


Load Method (Assembly)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Load Method (Assembly)
EnterpriseServiceProvider Class See Also Send Feedback
Loads a specific assembly into the ServiceProvider container.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public virtual bool Load(
    Assembly assembly
)
Visual Basic (Declaration)
Public Overridable Function Load ( _
    assembly As Assembly _
) As Boolean
Visual C++
public:
virtual bool Load(
    Assembly^ assembly
)

Parameters

assembly
Type: System.Reflection..::.Assembly
Assembly to load

Return Value

bool

Implements

IEnterpriseServiceProvider..::.Load(Assembly)

See Also

EnterpriseServiceProvider Class
Load Overload
Genesyslab.Enterprise.Services Namespace


Load Method (String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Load Method (String)
EnterpriseServiceProvider Class Example See Also Send Feedback
Loads a configuration file to configure the container. Loading does not overwrite the existing configuration of the container.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public virtual bool Load(
    string filename
)
Visual Basic (Declaration)
Public Overridable Function Load ( _
    filename As String _
) As Boolean
Visual C++
public:
virtual bool Load(
    String^ filename
)

Parameters

filename
Type: System..::.String
Complete path of the configuration filename

Return Value

bool

Implements

IEnterpriseServiceProvider..::.Load(String)

Examples

Example of a Unity configuration file for EntrepriseSDK.
CopyC#
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
 <configSections>
  <section name="unity"
            type="Microsoft.Practices.Unity.Configuration.UnityConfigurationSection, Microsoft.Practices.Unity.Configuration, Version=1.2.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
            />
 </configSections>
 <unity>
   <typeAliases>
     <typeAlias alias="personalLifetimeManager"
          type="Genesyslab.Enterprise.Framework.Container.Unity.GlobalThreadLifeTimeManager,
              Genesyslab.Enterprise.Framework" />
     <typeAlias alias="identityService"
          type="Genesyslab.Enterprise.Services.IIdentityService, Genesyslab.Enterprise.Services" />
     <typeAlias alias="voiceService"
         type="Genesyslab.Enterprise.Services.IInteractionService, Genesyslab.Enterprise.Services" />
     <typeAlias alias="channelService"
         type="Genesyslab.Enterprise.Services.IChannelService, Genesyslab.Enterprise.Services" />
     <typeAlias alias="deviceService"
         type="Genesyslab.Enterprise.Services.IDeviceService, Genesyslab.Enterprise.Services" />
   </typeAliases>
   <containers>
     <container>
       <types>
         <type type="identityService"
               mapTo="Genesyslab.Enterprise.Services.IdentityService, Genesyslab.Enterprise.Services " name="identityService">
           <lifetime type="personalLifetimeManager" />
         </type>
         <type type="voiceService"
               mapTo="Genesyslab.Enterprise.Services.InteractionService, Genesyslab.Enterprise.Services " name="voiceService">
           <lifetime type="personalLifetimeManager" />
         </type>
         <type type="channelService"
             mapTo="Genesyslab.Enterprise.Services.ChannelService, Genesyslab.Enterprise.Services " name="channelService">
           <lifetime type="personalLifetimeManager" />
         </type>
         <type type="deviceService"
            mapTo="Genesyslab.Enterprise.Services.DeviceService, Genesyslab.Enterprise.Services " name="deviceService">
           <lifetime type="personalLifetimeManager" />
         </type>
         </types>
         <instances>
         </instances>
         <extensions>
           <add type="Microsoft.Practices.Unity.InterceptionExtension.Interception, Microsoft.Practices.Unity.Interception" />
         </extensions>
       <extensionConfig>
         </extensionConfig>
       </container>
     </containers>
 </unity>
</configuration>

See Also

EnterpriseServiceProvider Class
Load Overload
Genesyslab.Enterprise.Services Namespace


RegisterInstance(TInterface) Method

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.RegisterInstance<(Of <(TInterface>)>) Method
EnterpriseServiceProvider Class See Also Send Feedback
Registers an instance with the container.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnterpriseServiceProvider RegisterInstance<TInterface>(
    string name,
    TInterface instance
)
Visual Basic (Declaration)
Public Function RegisterInstance(Of TInterface) ( _
    name As String, _
    instance As TInterface _
) As IEnterpriseServiceProvider
Visual C++
public:
generic<typename TInterface>
virtual IEnterpriseServiceProvider^ RegisterInstance(
    String^ name,
    TInterface instance
) sealed

Parameters

name
Type: System..::.String
the name of the interface.
instance
Type: TInterface
the instance.

Type Parameters

TInterface
the type of interface

Return Value

the IEnterpriseServiceProvider.

Implements

IEnterpriseServiceProvider..::.RegisterInstance<(Of <(TInterface>)>)(String, TInterface)

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


RegisterType Method

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.RegisterType Method
EnterpriseServiceProvider Class See Also Send Feedback

Overload List

Name | Description
RegisterType<(Of <(TType>)>)()()() | Registers a LifetimeManager for the given type with the container. No type mapping is performed for this type.
RegisterType(Type, Type) | Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.
RegisterType(Type, Type, array<Object>[]()[]) | Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.
RegisterType(Type, Type, String) | Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.
RegisterType(Type, Type, String, array<Object>[]()[]) | Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Members
Genesyslab.Enterprise.Services Namespace


RegisterType(TType) Method

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.RegisterType<(Of <(TType>)>) Method
EnterpriseServiceProvider Class See Also Send Feedback
Registers a LifetimeManager for the given type with the container. No type mapping is performed for this type.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnterpriseServiceProvider RegisterType<TType>()
Visual Basic (Declaration)
Public Function RegisterType(Of TType) As IEnterpriseServiceProvider
Visual C++
public:
generic<typename TType>
virtual IEnterpriseServiceProvider^ RegisterType() sealed

Type Parameters

TType

[Missing <typeparam name="TType"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.RegisterType``1"]

Return Value

the IEnterpriseServiceProvider.

Implements

IEnterpriseServiceProvider..::.RegisterType<(Of <(T>)>)()()()

See Also

EnterpriseServiceProvider Class
RegisterType Overload
Genesyslab.Enterprise.Services Namespace


RegisterType Method (Type, Type)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.RegisterType Method (Type, Type)
EnterpriseServiceProvider Class See Also Send Feedback
Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnterpriseServiceProvider RegisterType(
    Type from,
    Type to
)
Visual Basic (Declaration)
Public Function RegisterType ( _
    from As Type, _
    to As Type _
) As IEnterpriseServiceProvider
Visual C++
public:
virtual IEnterpriseServiceProvider^ RegisterType(
    Type^ from,
    Type^ to
) sealed

Parameters

from
Type: System..::.Type
Interface to register.
to
Type: System..::.Type
Concrete class to map.

Return Value

the IEnterpriseServiceProvider.

Implements

IEnterpriseServiceProvider..::.RegisterType(Type, Type)

See Also

EnterpriseServiceProvider Class
RegisterType Overload
Genesyslab.Enterprise.Services Namespace


RegisterType Method (Type, Type, Object[])

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.RegisterType Method (Type, Type, array<Object>[]()[])
EnterpriseServiceProvider Class See Also Send Feedback
Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnterpriseServiceProvider RegisterType(
    Type from,
    Type to,
    params Object[] list
)
Visual Basic (Declaration)
Public Function RegisterType ( _
    from As Type, _
    to As Type, _
    ParamArray list As Object() _
) As IEnterpriseServiceProvider
Visual C++
public:
virtual IEnterpriseServiceProvider^ RegisterType(
    Type^ from,
    Type^ to,
    ... array<Object^>^ list
) sealed

Parameters

from
Type: System..::.Type
Interface to register.
to
Type: System..::.Type
Concrete class to map.
list
Type: array< System..::.Object >[]()[]
Parameters for the object constructor.

Return Value

the IEnterpriseServiceProvider.

Implements

IEnterpriseServiceProvider..::.RegisterType(Type, Type, array<Object>[]()[])

See Also

EnterpriseServiceProvider Class
RegisterType Overload
Genesyslab.Enterprise.Services Namespace


RegisterType Method (Type, Type, String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.RegisterType Method (Type, Type, String)
EnterpriseServiceProvider Class See Also Send Feedback
Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnterpriseServiceProvider RegisterType(
    Type from,
    Type to,
    string name
)
Visual Basic (Declaration)
Public Function RegisterType ( _
    from As Type, _
    to As Type, _
    name As String _
) As IEnterpriseServiceProvider
Visual C++
public:
virtual IEnterpriseServiceProvider^ RegisterType(
    Type^ from,
    Type^ to,
    String^ name
) sealed

Parameters

from
Type: System..::.Type
Interface to register.
to
Type: System..::.Type
Concrete class to map.
name
Type: System..::.String
Name for the new instance.

Return Value

the IEnterpriseServiceProvider.

Implements

IEnterpriseServiceProvider..::.RegisterType(Type, Type, String)

See Also

EnterpriseServiceProvider Class
RegisterType Overload
Genesyslab.Enterprise.Services Namespace


RegisterType Method (Type, Type, String, Object[])

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.RegisterType Method (Type, Type, String, array<Object>[]()[])
EnterpriseServiceProvider Class See Also Send Feedback
Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnterpriseServiceProvider RegisterType(
    Type from,
    Type to,
    string name,
    params Object[] list
)
Visual Basic (Declaration)
Public Function RegisterType ( _
    from As Type, _
    to As Type, _
    name As String, _
    ParamArray list As Object() _
) As IEnterpriseServiceProvider
Visual C++
public:
virtual IEnterpriseServiceProvider^ RegisterType(
    Type^ from,
    Type^ to,
    String^ name,
    ... array<Object^>^ list
) sealed

Parameters

from
Type: System..::.Type
Interface to register.
to
Type: System..::.Type
Concrete class to map.
name
Type: System..::.String
Name for the new instance.
list
Type: array< System..::.Object >[]()[]
Parameters for the object constructor.

Return Value

the IEnterpriseServiceProvider.

Implements

IEnterpriseServiceProvider..::.RegisterType(Type, Type, String, array<Object>[]()[])

See Also

EnterpriseServiceProvider Class
RegisterType Overload
Genesyslab.Enterprise.Services Namespace


Resolve Method

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Resolve Method
EnterpriseServiceProvider Class See Also Send Feedback

Overload List

Name | Description
Resolve<(Of <(TType>)>)()()() | Resolves an instance of the requested type.
Resolve<(Of <(TType>)>)(String) | Resolves an instance of the requested type.
Resolve(Type) | Resolves an instance of the requested type.
Resolve(Type, String) | Resolves an instance of the requested type.

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Members
Genesyslab.Enterprise.Services Namespace


Resolve(TType) Method

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Resolve<(Of <(TType>)>) Method
EnterpriseServiceProvider Class See Also Send Feedback
Resolves an instance of the requested type.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public TType Resolve<TType>()
Visual Basic (Declaration)
Public Function Resolve(Of TType) As TType
Visual C++
public:
generic<typename TType>
virtual TType Resolve() sealed

Type Parameters

TType
the type.

Return Value

the type.

See Also

EnterpriseServiceProvider Class
Resolve Overload
Genesyslab.Enterprise.Services Namespace


Resolve(TType) Method (String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Resolve<(Of <(TType>)>) Method (String)
EnterpriseServiceProvider Class See Also Send Feedback
Resolves an instance of the requested type.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public TType Resolve<TType>(
    string name
)
Visual Basic (Declaration)
Public Function Resolve(Of TType) ( _
    name As String _
) As TType
Visual C++
public:
generic<typename TType>
virtual TType Resolve(
    String^ name
) sealed

Parameters

name
Type: System..::.String
the name of the instance.

Type Parameters

TType
the type.

Return Value

the type of the instance.

See Also

EnterpriseServiceProvider Class
Resolve Overload
Genesyslab.Enterprise.Services Namespace


Resolve Method (Type)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Resolve Method (Type)
EnterpriseServiceProvider Class See Also Send Feedback
Resolves an instance of the requested type.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Object Resolve(
    Type t
)
Visual Basic (Declaration)
Public Function Resolve ( _
    t As Type _
) As Object
Visual C++
public:
virtual Object^ Resolve(
    Type^ t
) sealed

Parameters

t
Type: System..::.Type
the type.

Return Value

the object instance.

Implements

IEnterpriseServiceProvider..::.Resolve(Type)

See Also

EnterpriseServiceProvider Class
Resolve Overload
Genesyslab.Enterprise.Services Namespace


Resolve Method (Type, String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Resolve Method (Type, String)
EnterpriseServiceProvider Class See Also Send Feedback
Resolves an instance of the requested type.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Object Resolve(
    Type t,
    string name
)
Visual Basic (Declaration)
Public Function Resolve ( _
    t As Type, _
    name As String _
) As Object
Visual C++
public:
virtual Object^ Resolve(
    Type^ t,
    String^ name
) sealed

Parameters

t
Type: System..::.Type
the type.
name
Type: System..::.String
the name of the instance.

Return Value

the instance.

Implements

IEnterpriseServiceProvider..::.Resolve(Type, String)

See Also

EnterpriseServiceProvider Class
Resolve Overload
Genesyslab.Enterprise.Services Namespace


ResolveAll(T) Method

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.ResolveAll<(Of <(T>)>) Method
EnterpriseServiceProvider Class See Also Send Feedback
Resolves all.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnumerable<T> ResolveAll<T>()
Visual Basic (Declaration)
Public Function ResolveAll(Of T) As IEnumerable(Of T)
Visual C++
public:
generic<typename T>
virtual IEnumerable<T>^ ResolveAll() sealed

Type Parameters

T
the type of data.

Return Value

the enumeration.

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Properties

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Properties
EnterpriseServiceProvider Class See Also Send Feedback

The EnterpriseServiceProvider type exposes the following members.

Properties

Name | Description
Container | Container.
Description | Description.
Filter | Define filter for plugin loading * - match zero or more characters ? - match any one character [abc] - match one character if it's in the characters inside the brackets. All other characters in the glob are literals. Example: *.dll
FQName | Fully Qualified Name (Unique ID).
LifeTimeManager | Lifetime manager.
Logger | Returns the logger.
ParentContainer | Parent container.
Provider | Applies the strategies of the container to objects built externally.
ServiceName | Returns the service name.

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


Container Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Container Property
EnterpriseServiceProvider Class See Also Send Feedback
Container.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Object Container { get; }
Visual Basic (Declaration)
Public ReadOnly Property Container As Object
Visual C++
public:
virtual property Object^ Container {
    Object^ get () sealed;
}

Implements

IService..::.Container

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Description Property
EnterpriseServiceProvider Class See Also Send Feedback
Description.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IService..::.Description

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


Filter Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Filter Property
EnterpriseServiceProvider Class See Also Send Feedback
Define filter for plugin loading * - match zero or more characters ? - match any one character [abc] - match one character if it's in the characters inside the brackets. All other characters in the glob are literals. Example: *.dll

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string Filter { get; set; }
Visual Basic (Declaration)
Public Property Filter As String
Visual C++
public:
virtual property String^ Filter {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IEnterpriseServiceProvider..::.Filter

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.FQName Property
EnterpriseServiceProvider Class See Also Send Feedback
Fully Qualified Name (Unique ID).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string FQName { get; internal set; }
Visual Basic (Declaration)
Public Property FQName As String
Visual C++
public:
virtual property String^ FQName {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IService..::.FQName

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


LifeTimeManager Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.LifeTimeManager Property
EnterpriseServiceProvider Class See Also Send Feedback
Lifetime manager.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Type LifeTimeManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property LifeTimeManager As Type
Visual C++
public:
virtual property Type^ LifeTimeManager {
    Type^ get () sealed;
}

Implements

IService..::.LifeTimeManager

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


Logger Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Logger Property
EnterpriseServiceProvider Class See Also Send Feedback
Returns the logger.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ILogger Logger { get; }
Visual Basic (Declaration)
Public ReadOnly Property Logger As ILogger
Visual C++
public:
property ILogger^ Logger {
    ILogger^ get ();
}

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


ParentContainer Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.ParentContainer Property
EnterpriseServiceProvider Class See Also Send Feedback
Parent container.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public Object ParentContainer { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentContainer As Object
Visual C++
public:
virtual property Object^ ParentContainer {
    Object^ get () sealed;
}

Implements

IService..::.ParentContainer

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


Provider Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Provider Property
EnterpriseServiceProvider Class See Also Send Feedback
Applies the strategies of the container to objects built externally.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnterpriseServiceProvider Provider { get; }
Visual Basic (Declaration)
Public ReadOnly Property Provider As IEnterpriseServiceProvider
Visual C++
public:
virtual property IEnterpriseServiceProvider^ Provider {
    IEnterpriseServiceProvider^ get () sealed;
}

Return Value

IEnterpriseServiceProvider

Implements

IEnterpriseServiceProvider..::.Provider

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


ServiceName Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.ServiceName Property
EnterpriseServiceProvider Class See Also Send Feedback
Returns the service name.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string ServiceName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ServiceName As String
Visual C++
public:
virtual property String^ ServiceName {
    String^ get () sealed;
}

Implements

IService..::.ServiceName
IEnterpriseServiceProvider..::.ServiceName

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProviderExtension Class

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProviderExtension Class
Members See Also Send Feedback
Advanced methods for EnterpriseServiceProvider class.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.PSDKExtensions (in Genesyslab.Enterprise.PSDKExtensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static class EnterpriseServiceProviderExtension
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class EnterpriseServiceProviderExtension
Visual C++
[ExtensionAttribute]
public ref class EnterpriseServiceProviderExtension abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Services..::.EnterpriseServiceProviderExtension

See Also

EnterpriseServiceProviderExtension Members
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProviderExtension Members

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProviderExtension Members
EnterpriseServiceProviderExtension Class Methods See Also Send Feedback

Methods

Name | Description
Init | Overloaded.

See Also

EnterpriseServiceProviderExtension Class
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProviderExtension Methods

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProviderExtension Methods
EnterpriseServiceProviderExtension Class See Also Send Feedback

Methods

Name | Description
Init | Overloaded.

See Also

EnterpriseServiceProviderExtension Class
Genesyslab.Enterprise.Services Namespace


Init Method

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProviderExtension..::.Init Method
EnterpriseServiceProviderExtension Class See Also Send Feedback

Overload List

Name | Description
Init(IEnterpriseServiceProvider, ConfServerConfiguration) | Initializes the ESDK with a configuration.
Init(IEnterpriseServiceProvider, IProtocol, CfgAppType, String) | Initializes the ESDK with a configuration.

See Also

EnterpriseServiceProviderExtension Class
EnterpriseServiceProviderExtension Members
Genesyslab.Enterprise.Services Namespace


Init Method (IEnterpriseServiceProvider, )

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProviderExtension..::.Init Method (IEnterpriseServiceProvider, )
EnterpriseServiceProviderExtension Class See Also Send Feedback
Initializes the ESDK with a configuration.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.PSDKExtensions (in Genesyslab.Enterprise.PSDKExtensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static void Init(
    this IEnterpriseServiceProvider provider,
    ConfServerConfiguration confServerConfiguration
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Sub Init ( _
    provider As IEnterpriseServiceProvider, _
    confServerConfiguration As ConfServerConfiguration _
)
Visual C++
[ExtensionAttribute]
public:
static void Init(
    IEnterpriseServiceProvider^ provider,
    ConfServerConfiguration^ confServerConfiguration
)

Parameters

provider
Type: Genesyslab.Enterprise.Model.ServiceModel..::.IEnterpriseServiceProvider
the EnterpriseServiceProvider instance.
confServerConfiguration
Type: ConfServerConfiguration
the configuration of the application.

See Also

EnterpriseServiceProviderExtension Class
Init Overload
Genesyslab.Enterprise.Services Namespace


Init Method (IEnterpriseServiceProvider, , , String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProviderExtension..::.Init Method (IEnterpriseServiceProvider, , , String)
EnterpriseServiceProviderExtension Class See Also Send Feedback
Initializes the ESDK with a configuration.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.PSDKExtensions (in Genesyslab.Enterprise.PSDKExtensions.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static void Init(
    this IEnterpriseServiceProvider provider,
    IProtocol configurationProtocol,
    CfgAppType appType,
    string appName
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Sub Init ( _
    provider As IEnterpriseServiceProvider, _
    configurationProtocol As IProtocol, _
    appType As CfgAppType, _
    appName As String _
)
Visual C++
[ExtensionAttribute]
public:
static void Init(
    IEnterpriseServiceProvider^ provider,
    IProtocol^ configurationProtocol,
    CfgAppType appType,
    String^ appName
)

Parameters

provider
Type: Genesyslab.Enterprise.Model.ServiceModel..::.IEnterpriseServiceProvider
the EnterpriseServiceProvider instance.
configurationProtocol
Type: IProtocol
the configuration protocol.
appType
Type: CfgAppType
the application prototype.
appName
Type: System..::.String
the application name.

See Also

EnterpriseServiceProviderExtension Class
Init Overload
Genesyslab.Enterprise.Services Namespace


ForwardAction Enumeration

[image]

Enterprise SDK 8.0 Reference API
ForwardAction Enumeration
See Also Send Feedback
Enumerates the actions that are possible on this agent. To be used in the methods of IsPossible.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum ForwardAction
Visual Basic (Declaration)
Public Enumeration ForwardAction
Visual C++
public enum class ForwardAction

Members

Member name | Description
CancelForward | Sets the Forwarding feature to Off.
SetForward | Sets the Forwarding feature to On.

See Also

Genesyslab.Enterprise.Services Namespace


IAgentService Interface

[image]

Enterprise SDK 8.0 Reference API
IAgentService Interface
Members See Also Send Feedback
Interface for Agent management.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IAgentService
Visual Basic (Declaration)
Public Interface IAgentService
Visual C++
public interface class IAgentService

See Also

IAgentService Members
Genesyslab.Enterprise.Services Namespace


IAgentService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService Members
IAgentService Interface Methods See Also Send Feedback

The IAgentService type exposes the following members.

Methods

Name | Description
BeginCallForwardCancel | Overloaded.
BeginCallForwardSet | Overloaded.
BeginLogin | Overloaded.
BeginLogout | Overloaded.
BeginNotReady | Overloaded.
BeginReady | Overloaded.
BeginSetDNDOff | Overloaded.
BeginSetDNDOn | Overloaded.
CallForwardCancel | Overloaded.
CallForwardSet | Overloaded.
EndCallForwardCancel |
EndCallForwardSet |
EndLogin |
EndLogout |
EndNotReady |
EndReady |
EndSetDNDOff |
EndSetDNDOn |
Login | Overloaded.
Logout | Overloaded.
NotReady | Overloaded.
Ready | Overloaded.
SetDNDOff | Overloaded.
SetDNDOn | Overloaded.

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


IAgentService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService Methods
IAgentService Interface See Also Send Feedback

The IAgentService type exposes the following members.

Methods

Name | Description
BeginCallForwardCancel | Overloaded.
BeginCallForwardSet | Overloaded.
BeginLogin | Overloaded.
BeginLogout | Overloaded.
BeginNotReady | Overloaded.
BeginReady | Overloaded.
BeginSetDNDOff | Overloaded.
BeginSetDNDOn | Overloaded.
CallForwardCancel | Overloaded.
CallForwardSet | Overloaded.
EndCallForwardCancel |
EndCallForwardSet |
EndLogin |
EndLogout |
EndNotReady |
EndReady |
EndSetDNDOff |
EndSetDNDOn |
Login | Overloaded.
Logout | Overloaded.
NotReady | Overloaded.
Ready | Overloaded.
SetDNDOff | Overloaded.
SetDNDOn | Overloaded.

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


BeginCallForwardCancel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginCallForwardCancel Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginCallForwardCancel(IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginCallForwardCancel(IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginCallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginCallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAsyncResult BeginCallForwardCancel(
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginCallForwardCancel ( _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginCallForwardCancel(
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Services Namespace


BeginCallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginCallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAsyncResult BeginCallForwardCancel(
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginCallForwardCancel ( _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginCallForwardCancel(
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Services Namespace


BeginCallForwardSet Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginCallForwardSet Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginCallForwardSet(IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginCallForwardSet(IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginCallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginCallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAsyncResult BeginCallForwardSet(
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginCallForwardSet ( _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginCallForwardSet(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginCallForwardSet Overload
Genesyslab.Enterprise.Services Namespace


BeginCallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginCallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAsyncResult BeginCallForwardSet(
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginCallForwardSet ( _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginCallForwardSet(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginCallForwardSet Overload
Genesyslab.Enterprise.Services Namespace


BeginLogin Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginLogin Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginLogin(IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginLogin(IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginLogin Method (IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginLogin Method (IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAsyncResult BeginLogin(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginLogin ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginLogin(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginLogin Overload
Genesyslab.Enterprise.Services Namespace


BeginLogin Method (IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginLogin Method (IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAsyncResult BeginLogin(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginLogin ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginLogin(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginLogin Overload
Genesyslab.Enterprise.Services Namespace


BeginLogout Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginLogout Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginLogout(IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginLogout(IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginLogout Method (IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginLogout Method (IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAsyncResult BeginLogout(
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginLogout ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginLogout(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginLogout Overload
Genesyslab.Enterprise.Services Namespace


BeginLogout Method (IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginLogout Method (IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAsyncResult BeginLogout(
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginLogout ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginLogout(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginLogout Overload
Genesyslab.Enterprise.Services Namespace


BeginNotReady Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginNotReady Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginNotReady(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginNotReady(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginNotReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginNotReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAsyncResult BeginNotReady(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginNotReady ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginNotReady(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginNotReady Overload
Genesyslab.Enterprise.Services Namespace


BeginNotReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginNotReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAsyncResult BeginNotReady(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginNotReady ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginNotReady(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginNotReady Overload
Genesyslab.Enterprise.Services Namespace


BeginReady Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginReady Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginReady(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginReady(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAsyncResult BeginReady(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginReady ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginReady(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginReady Overload
Genesyslab.Enterprise.Services Namespace


BeginReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAsyncResult BeginReady(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginReady ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginReady(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginReady Overload
Genesyslab.Enterprise.Services Namespace


BeginSetDNDOff Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginSetDNDOff Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginSetDNDOff(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginSetDNDOff(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginSetDNDOff Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginSetDNDOff Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAsyncResult BeginSetDNDOff(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginSetDNDOff ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginSetDNDOff(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginSetDNDOff Overload
Genesyslab.Enterprise.Services Namespace


BeginSetDNDOff Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginSetDNDOff Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAsyncResult BeginSetDNDOff(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginSetDNDOff ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginSetDNDOff(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginSetDNDOff Overload
Genesyslab.Enterprise.Services Namespace


BeginSetDNDOn Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginSetDNDOn Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginSetDNDOn(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginSetDNDOn(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginSetDNDOn Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginSetDNDOn Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAsyncResult BeginSetDNDOn(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginSetDNDOn ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginSetDNDOn(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginSetDNDOn Overload
Genesyslab.Enterprise.Services Namespace


BeginSetDNDOn Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginSetDNDOn Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IAsyncResult BeginSetDNDOn(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginSetDNDOn ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginSetDNDOn(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginSetDNDOn Overload
Genesyslab.Enterprise.Services Namespace


CallForwardCancel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.CallForwardCancel Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
CallForwardCancel(IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, String) |
CallForwardCancel(IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


CallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.CallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> CallForwardCancel(
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function CallForwardCancel ( _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ CallForwardCancel(
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IAgentService Interface
CallForwardCancel Overload
Genesyslab.Enterprise.Services Namespace


CallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.CallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> CallForwardCancel(
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
Function CallForwardCancel ( _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ CallForwardCancel(
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IAgentService Interface
CallForwardCancel Overload
Genesyslab.Enterprise.Services Namespace


CallForwardSet Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.CallForwardSet Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
CallForwardSet(IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, String) |
CallForwardSet(IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


CallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.CallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> CallForwardSet(
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function CallForwardSet ( _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ CallForwardSet(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IAgentService Interface
CallForwardSet Overload
Genesyslab.Enterprise.Services Namespace


CallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.CallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> CallForwardSet(
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
Function CallForwardSet ( _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ CallForwardSet(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IAgentService Interface
CallForwardSet Overload
Genesyslab.Enterprise.Services Namespace


EndCallForwardCancel Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndCallForwardCancel Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> EndCallForwardCancel(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndCallForwardCancel ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndCallForwardCancel(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndCallForwardSet Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndCallForwardSet Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> EndCallForwardSet(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndCallForwardSet ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndCallForwardSet(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndLogin Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndLogin Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogin(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> EndLogin(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndLogin ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndLogin(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogin(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogin(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogin(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndLogout Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndLogout Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogout(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> EndLogout(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndLogout ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndLogout(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogout(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogout(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogout(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndNotReady Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndNotReady Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndNotReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> EndNotReady(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndNotReady ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndNotReady(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndNotReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndNotReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndNotReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndReady Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndReady Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> EndReady(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndReady ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndReady(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndSetDNDOff Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndSetDNDOff Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> EndSetDNDOff(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndSetDNDOff ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndSetDNDOff(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndSetDNDOn Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndSetDNDOn Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> EndSetDNDOn(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndSetDNDOn ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndSetDNDOn(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


Login Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Login Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
Login(IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, String) |
Login(IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


Login Method (IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Login Method (IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> Login(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function Login ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ Login(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IAgentService Interface
Login Overload
Genesyslab.Enterprise.Services Namespace


Login Method (IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Login Method (IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> Login(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
Function Login ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ Login(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IAgentService Interface
Login Overload
Genesyslab.Enterprise.Services Namespace


Logout Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Logout Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
Logout(IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, String) |
Logout(IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


Logout Method (IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Logout Method (IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> Logout(
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function Logout ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ Logout(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IAgentService Interface
Logout Overload
Genesyslab.Enterprise.Services Namespace


Logout Method (IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Logout Method (IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> Logout(
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
Function Logout ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ Logout(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IAgentService Interface
Logout Overload
Genesyslab.Enterprise.Services Namespace


NotReady Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.NotReady Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
NotReady(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, String) |
NotReady(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


NotReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.NotReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> NotReady(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function NotReady ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ NotReady(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IAgentService Interface
NotReady Overload
Genesyslab.Enterprise.Services Namespace


NotReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.NotReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> NotReady(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
Function NotReady ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ NotReady(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IAgentService Interface
NotReady Overload
Genesyslab.Enterprise.Services Namespace


Ready Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Ready Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
Ready(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, String) |
Ready(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


Ready Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Ready Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> Ready(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function Ready ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ Ready(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IAgentService Interface
Ready Overload
Genesyslab.Enterprise.Services Namespace


Ready Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Ready Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> Ready(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
Function Ready ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ Ready(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IAgentService Interface
Ready Overload
Genesyslab.Enterprise.Services Namespace


SetDNDOff Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.SetDNDOff Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
SetDNDOff(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, String) |
SetDNDOff(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


SetDNDOff Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.SetDNDOff Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> SetDNDOff(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function SetDNDOff ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ SetDNDOff(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IAgentService Interface
SetDNDOff Overload
Genesyslab.Enterprise.Services Namespace


SetDNDOff Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.SetDNDOff Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> SetDNDOff(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
Function SetDNDOff ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ SetDNDOff(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IAgentService Interface
SetDNDOff Overload
Genesyslab.Enterprise.Services Namespace


SetDNDOn Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.SetDNDOn Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
SetDNDOn(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, String) |
SetDNDOn(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


SetDNDOn Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.SetDNDOn Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> SetDNDOn(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function SetDNDOn ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ SetDNDOn(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IAgentService Interface
SetDNDOn Overload
Genesyslab.Enterprise.Services Namespace


SetDNDOn Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.SetDNDOn Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnvelope<IAgent> SetDNDOn(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
Function SetDNDOn ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ SetDNDOn(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IAgentService Interface
SetDNDOn Overload
Genesyslab.Enterprise.Services Namespace


IChannelService Interface

[image]

Enterprise SDK 8.0 Reference API
IChannelService Interface
Members Example See Also Send Feedback
Interface for managing channels.

With this interface, you declare and declare new communication channels, one for each media connection (for instance a switch.)

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IChannelService : IChannelManager,
    IEventManager<IChannelService, IClientChannel>
Visual Basic (Declaration)
Public Interface IChannelService _
    Implements IChannelManager, IEventManager(Of IChannelService, IClientChannel)
Visual C++
public interface class IChannelService : IChannelManager,
    IEventManager<IChannelService^, IClientChannel^>

Examples

This code sample show how to create and register a channel:
CopyC#
IChannelService channelService = EsdkService.Resolve<IChannelService>("channelService");
TServerConfiguration conf = new TServerConfiguration("Label name");
//Identify the client in TServer
conf.ClientName = "Channel Name";
conf.Uri = new Uri("tcp://hostname:port_value");
conf.WarmStandbyAttempts = 10;
conf.WarmStandbyTimeout = 5;
conf.WarmStandbyUri = new Uri("tcp://hostname:19345");
conf.UseAddp = false;

channelService.CreateChannel("Label name", conf, SwitchModelType.LucentDefinityG3 );
Genesyslab.Enterprise.Model.Channel.IClientChannel channel = channelService.GetChannel("Label name");

Then you can register a method for channel events:

CopyC#
//Register for Channel events
channelService.RegisterEvents<Genesyslab.Enterprise.Model.Channel.IClientChannel>(channel, new Action<Genesyslab.Enterprise.Model.Channel.IClientChannel>(ChannelEvent));

Do not forget to declare a ChannelEvent method somewhere else in your code, as shown below:

CopyC#
protected void ChannelEvent(Genesyslab.Enterprise.Model.Channel.IClientChannel channel)
{
        System.Console.Write("[ChannelEvent] Status="+ channel.State));
}

Then, you can bind devices with channels. In the following code snippet, DeviceA is a reference of type IDevice.

CopyC#
channelService.BindDevice(deviceA, channel);
 Note: See IDeviceService for further details about creating and managing devices.

See Also

IChannelService Members
Genesyslab.Enterprise.Services Namespace


IChannelService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService Members
IChannelService Interface Methods Properties See Also Send Feedback

The IChannelService type exposes the following members.

Methods

Name | Description
AddChannel | Overloaded.
BindDevice | Binds a device with a channel. Before you bind the device with the channel, you must first register your channel in the channel service, and your device in the device service ().
Connect | Overloaded.
CreateChannel | Overloaded.
DeleteChannel | Deletes the given channel. (Inherited from IChannelManager.)
Disconnect | Overloaded.
GetChannel | Overloaded.
ListChannels | Overloaded.
ListDevices | Lists the devices of a specific channel. (Inherited from IChannelManager.)
RegisterEvents | Overloaded.
RemoveChannel | Removes the given channel from the monitoring list. Your application no longer receives events for this channel. (Inherited from IEventManager<(Of <(D, T>)>).)
SendMessage | Sends a message to the given channel. (Inherited from IChannelManager.)
UnbindDevice | Unbinds a device.
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)

Properties

Name | Description
ProtocolManager | Returns the associated protocol manager.

See Also

IChannelService Interface
Genesyslab.Enterprise.Services Namespace


IChannelService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService Methods
IChannelService Interface See Also Send Feedback

The IChannelService type exposes the following members.

Methods

Name | Description
AddChannel | Overloaded.
BindDevice | Binds a device with a channel. Before you bind the device with the channel, you must first register your channel in the channel service, and your device in the device service ().
Connect | Overloaded.
CreateChannel | Overloaded.
DeleteChannel | Deletes the given channel. (Inherited from IChannelManager.)
Disconnect | Overloaded.
GetChannel | Overloaded.
ListChannels | Overloaded.
ListDevices | Lists the devices of a specific channel. (Inherited from IChannelManager.)
RegisterEvents | Overloaded.
RemoveChannel | Removes the given channel from the monitoring list. Your application no longer receives events for this channel. (Inherited from IEventManager<(Of <(D, T>)>).)
SendMessage | Sends a message to the given channel. (Inherited from IChannelManager.)
UnbindDevice | Unbinds a device.
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

IChannelService Interface
Genesyslab.Enterprise.Services Namespace


AddChannel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.AddChannel Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
AddChannel(IClientChannel) | Enables the monitoring of the given channel. Note: This method does not report events. Your application needs to call the [!:StartMonitor] method. (Inherited from IEventManager<(Of <(D, T>)>).)
AddChannel(IClientChannel, ProtocolConfiguration) | Adds the given channel. (Inherited from IChannelManager.)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


BindDevice Method

[image]

Enterprise SDK 8.0 Reference API
IChannelService..::.BindDevice Method
IChannelService Interface See Also Send Feedback
Binds a device with a channel. Before you bind the device with the channel, you must first register your channel in the channel service, and your device in the device service ().

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager BindDevice(
    IDevice device,
    IClientChannel channel
)
Visual Basic (Declaration)
Function BindDevice ( _
    device As IDevice, _
    channel As IClientChannel _
) As IChannelManager
Visual C++
IChannelManager^ BindDevice(
    IDevice^ device,
    IClientChannel^ channel
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device to bind with the channel.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.

Return Value

the IChannelManager.

Remarks

See also this service description for code examples.

See Also

IChannelService Interface
Genesyslab.Enterprise.Services Namespace
Genesyslab.Enterprise.Services..::.IDeviceService


Connect Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.Connect Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
Connect()()() | Connects all the channels. Note: This method is asynchronous. (Inherited from IChannelManager.)
Connect(IClientChannel) | Connects the given channel. Note: This method is asynchronous. (Inherited from IChannelManager.)
Connect(Int32) | Connects all the channels. Note: This method is synchronous. (Inherited from IChannelManager.)
Connect(String) | Connects the given channel. Note: This method is asynchronous. (Inherited from IChannelManager.)
Connect(IClientChannel, Int32) | Connects the given channel. Note: This method is synchronous. (Inherited from IChannelManager.)
Connect(String, Int32) | Connects the given channel. Note: This method is synchronous. (Inherited from IChannelManager.)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


CreateChannel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.CreateChannel Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
CreateChannel(ProtocolConfiguration) | Creates a channel based on a user configuration instance without a switch abstraction. (Inherited from IChannelManager.)
CreateChannel(ProtocolConfiguration, SwitchModelType) | Creates a channel based on the given user configuration and switch type. (Inherited from IChannelManager.)
CreateChannel(ProtocolConfiguration, String) | Creates a channel based on the given configuration instance. (Inherited from IChannelManager.)
CreateChannel(String, ProtocolConfiguration) | Creates a channel without switch asbtraction capability. (Inherited from IChannelManager.)
CreateChannel(String, IProtocol) | Creates a channel based on already existing connection (Inherited from IChannelManager.)
CreateChannel(String, ProtocolConfiguration, SwitchModelType) | Creates a named channel, with the given user configuration and switch abstraction capability. (Inherited from IChannelManager.)
CreateChannel(String, ProtocolConfiguration, String) | Creates a channel, with the given user configuration and switch abstraction capability. (Inherited from IChannelManager.)
CreateChannel(String, IProtocol, SwitchModelType) | Obsolete. Creates a channel based on already existing connection and switch type. (Inherited from IChannelManager.)
CreateChannel(String, IProtocol, String) | Obsolete. Creates a channel based on already existing connection and switch type. (Inherited from IChannelManager.)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


Disconnect Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.Disconnect Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
Disconnect()()() | Disconnects all the channels. (Inherited from IChannelManager.)
Disconnect(IClientChannel) | Disconnects the given channel instance. Note: This method is asynchronous. (Inherited from IChannelManager.)
Disconnect(String) | Disconnects the given channel. Note: This method is asynchronous. (Inherited from IChannelManager.)
Disconnect(IClientChannel, Int32) | Disconnects the given channel. Note: This method is synchronous. (Inherited from IChannelManager.)
Disconnect(String, Int32) | Disconnects the given channel. Note: This method is synchronous. (Inherited from IChannelManager.)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


GetChannel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.GetChannel Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
GetChannel(IDevice) | Returns a channel object from a device (Inherited from IChannelManager.)
GetChannel(String) | Returns a channel object. (Inherited from IChannelManager.)
GetChannel(Uri) | Returns the channel with the given URI. (Inherited from IChannelManager.)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


ListChannels Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.ListChannels Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
ListChannels<(Of <(T>)>)()()() | Lists the channels registered in the service. (Inherited from IChannelManager.)
ListChannels()()() | Lists all the channels registered in the service. (Inherited from IChannelManager.)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.RegisterEvents Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


UnbindDevice Method

[image]

Enterprise SDK 8.0 Reference API
IChannelService..::.UnbindDevice Method
IChannelService Interface See Also Send Feedback
Unbinds a device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IChannelManager UnbindDevice(
    IDevice device,
    IClientChannel channel
)
Visual Basic (Declaration)
Function UnbindDevice ( _
    device As IDevice, _
    channel As IClientChannel _
) As IChannelManager
Visual C++
IChannelManager^ UnbindDevice(
    IDevice^ device,
    IClientChannel^ channel
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device to unbind.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.

Return Value

the IChannelManager.

See Also

IChannelService Interface
Genesyslab.Enterprise.Services Namespace


IChannelService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService Properties
IChannelService Interface See Also Send Feedback

The IChannelService type exposes the following members.

Properties

Name | Description
ProtocolManager | Returns the associated protocol manager.

See Also

IChannelService Interface
Genesyslab.Enterprise.Services Namespace


ProtocolManager Property

[image]

Enterprise SDK 8.0 Reference API
IChannelService..::.ProtocolManager Property
IChannelService Interface See Also Send Feedback
Returns the associated protocol manager.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
Object ProtocolManager { get; }
Visual Basic (Declaration)
ReadOnly Property ProtocolManager As Object
Visual C++
property Object^ ProtocolManager {
    Object^ get ();
}

See Also

IChannelService Interface
Genesyslab.Enterprise.Services Namespace


IDeviceDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain Interface
Members See Also Send Feedback
Manages device data.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IDeviceDomain
Visual Basic (Declaration)
Public Interface IDeviceDomain
Visual C++
public interface class IDeviceDomain

See Also

IDeviceDomain Members
Genesyslab.Enterprise.Services Namespace


IDeviceDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceDomain Members
IDeviceDomain Interface Methods See Also Send Feedback

The IDeviceDomain type exposes the following members.

Methods

Name | Description
AddDevice | Adds the given device to the given group.
CreateDevice | Overloaded.
DeleteDevice | Overloaded.
GetDevice | Returns the device associated with the given DN name / tenant / Channel.
GetDevices | Returns the all devices associated with the given DN name / tenant.
ListDevices | Overloaded.
RemoveDevice | Removes the given device from the given group.

See Also

IDeviceDomain Interface
Genesyslab.Enterprise.Services Namespace


IDeviceDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceDomain Methods
IDeviceDomain Interface See Also Send Feedback

The IDeviceDomain type exposes the following members.

Methods

Name | Description
AddDevice | Adds the given device to the given group.
CreateDevice | Overloaded.
DeleteDevice | Overloaded.
GetDevice | Returns the device associated with the given DN name / tenant / Channel.
GetDevices | Returns the all devices associated with the given DN name / tenant.
ListDevices | Overloaded.
RemoveDevice | Removes the given device from the given group.

See Also

IDeviceDomain Interface
Genesyslab.Enterprise.Services Namespace


AddDevice Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.AddDevice Method
IDeviceDomain Interface See Also Send Feedback
Adds the given device to the given group.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDeviceDomain AddDevice(
    IDevice device,
    IDevice group,
    bool allowEvents
)
Visual Basic (Declaration)
Function AddDevice ( _
    device As IDevice, _
    group As IDevice, _
    allowEvents As Boolean _
) As IDeviceDomain
Visual C++
IDeviceDomain^ AddDevice(
    IDevice^ device,
    IDevice^ group,
    bool allowEvents
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device to add to the group
group
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Group of devices
allowEvents
Type: System..::.Boolean
true to enable event reporting for the given device.

Return Value

IDeviceDomain

See Also

IDeviceDomain Interface
Genesyslab.Enterprise.Services Namespace


CreateDevice Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method
IDeviceDomain Interface See Also Send Feedback

Overload List

Name | Description
CreateDevice(String, DeviceType) | Obsolete. Creates a device with a specific name and type (see CME).
CreateDevice(String, IClientChannel, array<IDevice>[]()[]) | Obsolete.
CreateDevice(String, DeviceType, Object) | Obsolete. Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME
CreateDevice(String, SwitchConfig, array<IDevice>[]()[]) | Obsolete. Creates a virtual device based on the given configuration. Default tenant is used
CreateDevice(String, String, DeviceType) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME
CreateDevice(String, String, IClientChannel, array<IDevice>[]()[]) | Creates a virtual device from a list of devices, based on the switch abstraction defined in the given channel.
CreateDevice(String, String, DeviceType, Object) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME
CreateDevice(String, String, SwitchModelType, array<IDevice>[]()[]) | Creates a virtual device based on the given switch policy.
CreateDevice(String, String, SwitchConfig, array<IDevice>[]()[]) | Creates a virtual device based on the given configuration.
CreateDevice(String, String, String, array<IDevice>[]()[]) | Creates a virtual device based on the given switch policy.
CreateDevice(String, String, DeviceType, Object, SwitchModelType) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME
CreateDevice(String, String, DeviceType, Object, String) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME

See Also

IDeviceDomain Interface
IDeviceDomain Members
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, DeviceType)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, DeviceType)
IDeviceDomain Interface See Also Send Feedback
Creates a device with a specific name and type (see CME).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")]
IDevice CreateDevice(
    string name,
    DeviceType deviceType
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")> _
Function CreateDevice ( _
    name As String, _
    deviceType As DeviceType _
) As IDevice
Visual C++
[ObsoleteAttribute(L"Use CreateDevice() with tenant parameter instead")]
IDevice^ CreateDevice(
    String^ name,
    DeviceType deviceType
)

Parameters

name
Type: System..::.String
Unique name. Must match a CME configuration entry.
deviceType
Type: Genesyslab.Enterprise.Model.Device..::.DeviceType
Type.

Return Value

Created device.

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, IClientChannel, IDevice[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, IClientChannel, array<IDevice>[]()[])
IDeviceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")]
IDevice[] CreateDevice(
    string name,
    IClientChannel channel,
    IDevice[] list
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")> _
Function CreateDevice ( _
    name As String, _
    channel As IClientChannel, _
    list As IDevice() _
) As IDevice()
Visual C++
[ObsoleteAttribute(L"Use CreateDevice() with tenant parameter instead")]
array<IDevice^>^ CreateDevice(
    String^ name,
    IClientChannel^ channel,
    array<IDevice^>^ list
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

list
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]

[Missing <param name="list"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, DeviceType, Object)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, DeviceType, Object)
IDeviceDomain Interface See Also Send Feedback
Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")]
IDevice CreateDevice(
    string name,
    DeviceType deviceType,
    Object stateController
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")> _
Function CreateDevice ( _
    name As String, _
    deviceType As DeviceType, _
    stateController As Object _
) As IDevice
Visual C++
[ObsoleteAttribute(L"Use CreateDevice() with tenant parameter instead")]
IDevice^ CreateDevice(
    String^ name,
    DeviceType deviceType,
    Object^ stateController
)

Parameters

name
Type: System..::.String
Unique name. Must match a CME configuration entry.
deviceType
Type: Genesyslab.Enterprise.Model.Device..::.DeviceType
Type.
stateController
Type: System..::.Object
Controller object

Return Value

Created device.

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, , IDevice[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, , array<IDevice>[]()[])
IDeviceDomain Interface See Also Send Feedback
Creates a virtual device based on the given configuration. Default tenant is used

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")]
IDevice[] CreateDevice(
    string name,
    SwitchConfig config,
    IDevice[] list
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")> _
Function CreateDevice ( _
    name As String, _
    config As SwitchConfig, _
    list As IDevice() _
) As IDevice()
Visual C++
[ObsoleteAttribute(L"Use CreateDevice() with tenant parameter instead")]
array<IDevice^>^ CreateDevice(
    String^ name,
    SwitchConfig config,
    array<IDevice^>^ list
)

Parameters

name
Type: System..::.String
Name of device to be created
config
Type: SwitchConfig
Configuration structure.
list
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]
List of devices to be virtualized according to the config template

Return Value

IDevice[]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, DeviceType)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, DeviceType)
IDeviceDomain Interface See Also Send Feedback
Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDevice CreateDevice(
    string name,
    string tenant,
    DeviceType deviceType
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    deviceType As DeviceType _
) As IDevice
Visual C++
IDevice^ CreateDevice(
    String^ name,
    String^ tenant,
    DeviceType deviceType
)

Parameters

name
Type: System..::.String
Unique name. Must match a CME configuration entry.
tenant
Type: System..::.String
Must match a tenant name in CME
deviceType
Type: Genesyslab.Enterprise.Model.Device..::.DeviceType
Type.

Return Value

Created device.

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, IClientChannel, IDevice[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, IClientChannel, array<IDevice>[]()[])
IDeviceDomain Interface See Also Send Feedback
Creates a virtual device from a list of devices, based on the switch abstraction defined in the given channel.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDevice[] CreateDevice(
    string name,
    string tenant,
    IClientChannel channel,
    IDevice[] list
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    channel As IClientChannel, _
    list As IDevice() _
) As IDevice()
Visual C++
array<IDevice^>^ CreateDevice(
    String^ name,
    String^ tenant,
    IClientChannel^ channel,
    array<IDevice^>^ list
)

Parameters

name
Type: System..::.String
Name of device to be created.
tenant
Type: System..::.String
Name of related tenant to which the device belongs to.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel
list
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]
List of devices to evaluate as a virtual (global) device according to the channel switch rules

Return Value

IDevice[]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, DeviceType, Object)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, DeviceType, Object)
IDeviceDomain Interface See Also Send Feedback
Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDevice CreateDevice(
    string name,
    string tenant,
    DeviceType deviceType,
    Object stateController
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    deviceType As DeviceType, _
    stateController As Object _
) As IDevice
Visual C++
IDevice^ CreateDevice(
    String^ name,
    String^ tenant,
    DeviceType deviceType,
    Object^ stateController
)

Parameters

name
Type: System..::.String
Unique name. Must match a CME configuration entry.
tenant
Type: System..::.String
Must match a tenant name in CME
deviceType
Type: Genesyslab.Enterprise.Model.Device..::.DeviceType
Type.
stateController
Type: System..::.Object
State controller.

Return Value

IDevice

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, SwitchModelType, IDevice[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, SwitchModelType, array<IDevice>[]()[])
IDeviceDomain Interface See Also Send Feedback
Creates a virtual device based on the given switch policy.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDevice[] CreateDevice(
    string name,
    string tenant,
    SwitchModelType switchType,
    IDevice[] list
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    switchType As SwitchModelType, _
    list As IDevice() _
) As IDevice()
Visual C++
array<IDevice^>^ CreateDevice(
    String^ name,
    String^ tenant,
    SwitchModelType switchType,
    array<IDevice^>^ list
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Protocol.SwitchModelType,Genesyslab.Enterprise.Model.Device.IDevice[])"]

tenant
Type: System..::.String

[Missing <param name="tenant"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Protocol.SwitchModelType,Genesyslab.Enterprise.Model.Device.IDevice[])"]

switchType
Type: Genesyslab.Enterprise.Model.Protocol..::.SwitchModelType

[Missing <param name="switchType"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Protocol.SwitchModelType,Genesyslab.Enterprise.Model.Device.IDevice[])"]

list
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]

[Missing <param name="list"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Protocol.SwitchModelType,Genesyslab.Enterprise.Model.Device.IDevice[])"]

Return Value

IDevice[]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, , IDevice[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, , array<IDevice>[]()[])
IDeviceDomain Interface See Also Send Feedback
Creates a virtual device based on the given configuration.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDevice[] CreateDevice(
    string name,
    string tenant,
    SwitchConfig config,
    IDevice[] list
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    config As SwitchConfig, _
    list As IDevice() _
) As IDevice()
Visual C++
array<IDevice^>^ CreateDevice(
    String^ name,
    String^ tenant,
    SwitchConfig config,
    array<IDevice^>^ list
)

Parameters

name
Type: System..::.String
Name of device to be created
tenant
Type: System..::.String
Name of related tenant to which device belongd to
config
Type: SwitchConfig
Configuration structure.
list
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]
List of devices to be virtualized according to the config template

Return Value

IDevice[]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, String, IDevice[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, String, array<IDevice>[]()[])
IDeviceDomain Interface See Also Send Feedback
Creates a virtual device based on the given switch policy.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDevice[] CreateDevice(
    string name,
    string tenant,
    string switchType,
    IDevice[] list
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    switchType As String, _
    list As IDevice() _
) As IDevice()
Visual C++
array<IDevice^>^ CreateDevice(
    String^ name,
    String^ tenant,
    String^ switchType,
    array<IDevice^>^ list
)

Parameters

name
Type: System..::.String
Name of device to be created
tenant
Type: System..::.String
Name of related tenant to which device belongd to
switchType
Type: System..::.String

[Missing <param name="switchType"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,System.String,Genesyslab.Enterprise.Model.Device.IDevice[])"]

list
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]
List of devices to be virtualized according to the switch policy rules

Return Value

IDevice[]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, DeviceType, Object, SwitchModelType)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, DeviceType, Object, SwitchModelType)
IDeviceDomain Interface See Also Send Feedback
Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDevice CreateDevice(
    string name,
    string tenant,
    DeviceType deviceType,
    Object stateController,
    SwitchModelType switchType
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    deviceType As DeviceType, _
    stateController As Object, _
    switchType As SwitchModelType _
) As IDevice
Visual C++
IDevice^ CreateDevice(
    String^ name,
    String^ tenant,
    DeviceType deviceType,
    Object^ stateController,
    SwitchModelType switchType
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,Genesyslab.Enterprise.Model.Protocol.SwitchModelType)"]

tenant
Type: System..::.String

[Missing <param name="tenant"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,Genesyslab.Enterprise.Model.Protocol.SwitchModelType)"]

deviceType
Type: Genesyslab.Enterprise.Model.Device..::.DeviceType

[Missing <param name="deviceType"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,Genesyslab.Enterprise.Model.Protocol.SwitchModelType)"]

stateController
Type: System..::.Object

[Missing <param name="stateController"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,Genesyslab.Enterprise.Model.Protocol.SwitchModelType)"]

switchType
Type: Genesyslab.Enterprise.Model.Protocol..::.SwitchModelType

[Missing <param name="switchType"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,Genesyslab.Enterprise.Model.Protocol.SwitchModelType)"]

Return Value

IDevice

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, DeviceType, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, DeviceType, Object, String)
IDeviceDomain Interface See Also Send Feedback
Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDevice CreateDevice(
    string name,
    string tenant,
    DeviceType deviceType,
    Object stateController,
    string switchType
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    deviceType As DeviceType, _
    stateController As Object, _
    switchType As String _
) As IDevice
Visual C++
IDevice^ CreateDevice(
    String^ name,
    String^ tenant,
    DeviceType deviceType,
    Object^ stateController,
    String^ switchType
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,System.String)"]

tenant
Type: System..::.String

[Missing <param name="tenant"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,System.String)"]

deviceType
Type: Genesyslab.Enterprise.Model.Device..::.DeviceType

[Missing <param name="deviceType"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,System.String)"]

stateController
Type: System..::.Object

[Missing <param name="stateController"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,System.String)"]

switchType
Type: System..::.String

[Missing <param name="switchType"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,System.String)"]

Return Value

IDevice

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


DeleteDevice Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.DeleteDevice Method
IDeviceDomain Interface See Also Send Feedback

Overload List

Name | Description
DeleteDevice(IDevice) | Deletes a device.
DeleteDevice(String, String, String) | Deletes the given device.

See Also

IDeviceDomain Interface
IDeviceDomain Members
Genesyslab.Enterprise.Services Namespace


DeleteDevice Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.DeleteDevice Method (IDevice)
IDeviceDomain Interface See Also Send Feedback
Deletes a device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDeviceDomain DeleteDevice(
    IDevice device
)
Visual Basic (Declaration)
Function DeleteDevice ( _
    device As IDevice _
) As IDeviceDomain
Visual C++
IDeviceDomain^ DeleteDevice(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device instance to delete.

Return Value

IDeviceDomain

See Also

IDeviceDomain Interface
DeleteDevice Overload
Genesyslab.Enterprise.Services Namespace


DeleteDevice Method (String, String, String)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.DeleteDevice Method (String, String, String)
IDeviceDomain Interface See Also Send Feedback
Deletes the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void DeleteDevice(
    string name,
    string tenant,
    string channel
)
Visual Basic (Declaration)
Sub DeleteDevice ( _
    name As String, _
    tenant As String, _
    channel As String _
)
Visual C++
void DeleteDevice(
    String^ name,
    String^ tenant,
    String^ channel
)

Parameters

name
Type: System..::.String
Device name
tenant
Type: System..::.String
Tenant name
channel
Type: System..::.String
Channel name

See Also

IDeviceDomain Interface
DeleteDevice Overload
Genesyslab.Enterprise.Services Namespace


GetDevice Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.GetDevice Method
IDeviceDomain Interface See Also Send Feedback
Returns the device associated with the given DN name / tenant / Channel.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDevice GetDevice(
    string name,
    string tenant,
    string channel
)
Visual Basic (Declaration)
Function GetDevice ( _
    name As String, _
    tenant As String, _
    channel As String _
) As IDevice
Visual C++
IDevice^ GetDevice(
    String^ name,
    String^ tenant,
    String^ channel
)

Parameters

name
Type: System..::.String
Device name
tenant
Type: System..::.String
tenant name
channel
Type: System..::.String
Channel name

Return Value

Created device.

See Also

IDeviceDomain Interface
Genesyslab.Enterprise.Services Namespace


GetDevices Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.GetDevices Method
IDeviceDomain Interface See Also Send Feedback
Returns the all devices associated with the given DN name / tenant.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDevice[] GetDevices(
    string name,
    string tenant
)
Visual Basic (Declaration)
Function GetDevices ( _
    name As String, _
    tenant As String _
) As IDevice()
Visual C++
array<IDevice^>^ GetDevices(
    String^ name,
    String^ tenant
)

Parameters

name
Type: System..::.String
Device name
tenant
Type: System..::.String
tenant name

Return Value

Created devices.

See Also

IDeviceDomain Interface
Genesyslab.Enterprise.Services Namespace


ListDevices Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.ListDevices Method
IDeviceDomain Interface See Also Send Feedback

Overload List

Name | Description
ListDevices()()() | Lists all Devices registered
ListDevices(IDevice) | Lists all the devices which compose the given device or which are stored in the service.
ListDevices(String) | Lists all the devices which are part of a channel
ListDevices(IDevice, String) | Lists all the devices which compose the given device or which are stored in the service.

See Also

IDeviceDomain Interface
IDeviceDomain Members
Genesyslab.Enterprise.Services Namespace


ListDevices Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.ListDevices Method
IDeviceDomain Interface See Also Send Feedback
Lists all Devices registered

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDevice[] ListDevices()
Visual Basic (Declaration)
Function ListDevices As IDevice()
Visual C++
array<IDevice^>^ ListDevices()

Return Value

IDevice []

See Also

IDeviceDomain Interface
ListDevices Overload
Genesyslab.Enterprise.Services Namespace


ListDevices Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.ListDevices Method (IDevice)
IDeviceDomain Interface See Also Send Feedback
Lists all the devices which compose the given device or which are stored in the service.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDevice[] ListDevices(
    IDevice device
)
Visual Basic (Declaration)
Function ListDevices ( _
    device As IDevice _
) As IDevice()
Visual C++
array<IDevice^>^ ListDevices(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device name, or null to get all the devices of the service.

Return Value

IDevice []

See Also

IDeviceDomain Interface
ListDevices Overload
Genesyslab.Enterprise.Services Namespace


ListDevices Method (String)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.ListDevices Method (String)
IDeviceDomain Interface See Also Send Feedback
Lists all the devices which are part of a channel

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDevice[] ListDevices(
    string channel
)
Visual Basic (Declaration)
Function ListDevices ( _
    channel As String _
) As IDevice()
Visual C++
array<IDevice^>^ ListDevices(
    String^ channel
)

Parameters

channel
Type: System..::.String
channel name

Return Value

IDevice []

See Also

IDeviceDomain Interface
ListDevices Overload
Genesyslab.Enterprise.Services Namespace


ListDevices Method (IDevice, String)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.ListDevices Method (IDevice, String)
IDeviceDomain Interface See Also Send Feedback
Lists all the devices which compose the given device or which are stored in the service.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDevice[] ListDevices(
    IDevice device,
    string channel
)
Visual Basic (Declaration)
Function ListDevices ( _
    device As IDevice, _
    channel As String _
) As IDevice()
Visual C++
array<IDevice^>^ ListDevices(
    IDevice^ device,
    String^ channel
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device name, or null to get all the devices of the service.
channel
Type: System..::.String
channel

Return Value

IDevice []

See Also

IDeviceDomain Interface
ListDevices Overload
Genesyslab.Enterprise.Services Namespace


RemoveDevice Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.RemoveDevice Method
IDeviceDomain Interface See Also Send Feedback
Removes the given device from the given group.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDeviceDomain RemoveDevice(
    IDevice device,
    IDevice group
)
Visual Basic (Declaration)
Function RemoveDevice ( _
    device As IDevice, _
    group As IDevice _
) As IDeviceDomain
Visual C++
IDeviceDomain^ RemoveDevice(
    IDevice^ device,
    IDevice^ group
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device to remove from the specified group
group
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Group

Return Value

the IDeviceDomain.

See Also

IDeviceDomain Interface
Genesyslab.Enterprise.Services Namespace


IDeviceService Interface

[image]

Enterprise SDK 8.0 Reference API
IDeviceService Interface
Members Example See Also Send Feedback
Manages handlers and filters on devices.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IDeviceService : IDeviceDomain
Visual Basic (Declaration)
Public Interface IDeviceService _
    Implements IDeviceDomain
Visual C++
public interface class IDeviceService : IDeviceDomain

Examples

The following code snippet shows how to register a handler on a device. First, retrieve an instance of the service.
CopyC#
IEnterpriseServiceProvider EsdkService = new EnterpriseServiceProvider(new UnityContainer(), typeof(GlobalThreadLifeTimeManager), null);
IDeviceService deviceService = EsdkService.Resolve<IDeviceService>("deviceService");
 Then, registers a handler on a device, of type extension for instance.
CopyC#
IDevice deviceA = deviceService.CreateDevice("Device name", DeviceType.Extension);
deviceService.RegisterEvents(deviceA, new Action<IEnvelope<IDN>>(DeviceEvent));
 Also, declare your event handler.
CopyC#
protected void DeviceEvent(IEnvelope<IDN> tsp)
{
    if (tsp != null)
    {
        int referenceId = tsp.Header.CorrelationId;
        string dn = tsp.Body.Name;
        //...
     }
}

See Also

IDeviceService Members
Genesyslab.Enterprise.Services Namespace


IDeviceService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService Members
IDeviceService Interface Methods See Also Send Feedback

The IDeviceService type exposes the following members.

Methods

Name | Description
AddDevice | Adds the given device to the given group. (Inherited from IDeviceDomain.)
CreateDevice | Overloaded.
DeleteDevice | Overloaded.
GetDevice | Returns the device associated with the given DN name / tenant / Channel. (Inherited from IDeviceDomain.)
GetDevices | Returns the all devices associated with the given DN name / tenant. (Inherited from IDeviceDomain.)
ListDevices | Overloaded.
ListFilter<(Of <(T>)>) | Returns the list of filters for the given device.
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers an event filter for the given device.
RemoveDevice | Removes the given device from the given group. (Inherited from IDeviceDomain.)
UnRegisterEvents | Unregisters the given handler for the specified device.
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for the given device.

See Also

IDeviceService Interface
Genesyslab.Enterprise.Services Namespace


IDeviceService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService Methods
IDeviceService Interface See Also Send Feedback

The IDeviceService type exposes the following members.

Methods

Name | Description
AddDevice | Adds the given device to the given group. (Inherited from IDeviceDomain.)
CreateDevice | Overloaded.
DeleteDevice | Overloaded.
GetDevice | Returns the device associated with the given DN name / tenant / Channel. (Inherited from IDeviceDomain.)
GetDevices | Returns the all devices associated with the given DN name / tenant. (Inherited from IDeviceDomain.)
ListDevices | Overloaded.
ListFilter<(Of <(T>)>) | Returns the list of filters for the given device.
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers an event filter for the given device.
RemoveDevice | Removes the given device from the given group. (Inherited from IDeviceDomain.)
UnRegisterEvents | Unregisters the given handler for the specified device.
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for the given device.

See Also

IDeviceService Interface
Genesyslab.Enterprise.Services Namespace


CreateDevice Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.CreateDevice Method
IDeviceService Interface See Also Send Feedback

Overload List

Name | Description
CreateDevice(String, DeviceType) | Obsolete. Creates a device with a specific name and type (see CME). (Inherited from IDeviceDomain.)
CreateDevice(String, IClientChannel, array<IDevice>[]()[]) | Obsolete. (Inherited from IDeviceDomain.)
CreateDevice(String, DeviceType, Object) | Obsolete. Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME (Inherited from IDeviceDomain.)
CreateDevice(String, SwitchConfig, array<IDevice>[]()[]) | Obsolete. Creates a virtual device based on the given configuration. Default tenant is used (Inherited from IDeviceDomain.)
CreateDevice(String, String, DeviceType) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME (Inherited from IDeviceDomain.)
CreateDevice(String, String, IClientChannel, array<IDevice>[]()[]) | Creates a virtual device from a list of devices, based on the switch abstraction defined in the given channel. (Inherited from IDeviceDomain.)
CreateDevice(String, String, DeviceType, Object) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME (Inherited from IDeviceDomain.)
CreateDevice(String, String, SwitchModelType, array<IDevice>[]()[]) | Creates a virtual device based on the given switch policy. (Inherited from IDeviceDomain.)
CreateDevice(String, String, SwitchConfig, array<IDevice>[]()[]) | Creates a virtual device based on the given configuration. (Inherited from IDeviceDomain.)
CreateDevice(String, String, String, array<IDevice>[]()[]) | Creates a virtual device based on the given switch policy. (Inherited from IDeviceDomain.)
CreateDevice(String, String, DeviceType, Object, SwitchModelType) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME (Inherited from IDeviceDomain.)
CreateDevice(String, String, DeviceType, Object, String) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME (Inherited from IDeviceDomain.)

See Also

IDeviceService Interface
IDeviceService Members
Genesyslab.Enterprise.Services Namespace


DeleteDevice Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.DeleteDevice Method
IDeviceService Interface See Also Send Feedback

Overload List

Name | Description
DeleteDevice(IDevice) | Deletes a device. (Inherited from IDeviceDomain.)
DeleteDevice(String, String, String) | Deletes the given device. (Inherited from IDeviceDomain.)

See Also

IDeviceService Interface
IDeviceService Members
Genesyslab.Enterprise.Services Namespace


ListDevices Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.ListDevices Method
IDeviceService Interface See Also Send Feedback

Overload List

Name | Description
ListDevices()()() | Lists all Devices registered (Inherited from IDeviceDomain.)
ListDevices(IDevice) | Lists all the devices which compose the given device or which are stored in the service. (Inherited from IDeviceDomain.)
ListDevices(String) | Lists all the devices which are part of a channel (Inherited from IDeviceDomain.)
ListDevices(IDevice, String) | Lists all the devices which compose the given device or which are stored in the service. (Inherited from IDeviceDomain.)

See Also

IDeviceService Interface
IDeviceService Members
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.ListFilter<(Of <(T>)>) Method
IDeviceService Interface See Also Send Feedback
Returns the list of filters for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnumerable<T> ListFilter<T>(
    IDevice device
)
Visual Basic (Declaration)
Function ListFilter(Of T) ( _
    device As IDevice _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ListFilter(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.

Type Parameters

T
Type for the returned filters.

Return Value

Filters for this device.

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterEvents Method
IDeviceService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>)) | Registers the given handler for the given device.
RegisterEvents(IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>), array<IStrategy>[]()[], array<IFilter>[]()[]) | Registers the given event handler for the given device.
RegisterEvents(IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[]) | Registers the given event handler for the given device.
RegisterEvents(IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers the given event handler for the given device.

See Also

IDeviceService Interface
IDeviceService Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IDevice, Action(IEnvelope(IDN)))

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterEvents Method (IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>))
IDeviceService Interface See Also Send Feedback
Registers the given handler for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDeviceDomain RegisterEvents(
    IDevice device,
    Action<IEnvelope<IDN>> handler
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of IDN)) _
) As IDeviceDomain
Visual C++
IDeviceDomain^ RegisterEvents(
    IDevice^ device,
    Action<IEnvelope<IDN^>^>^ handler
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( IDN >)>)>)>)
Handler method.

Return Value

Domain.

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IDevice, Action(IEnvelope(IDN)), [], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterEvents Method (IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>), array<>[]()[], array<IFilter>[]()[])
IDeviceService Interface See Also Send Feedback
Registers the given event handler for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDeviceService RegisterEvents(
    IDevice device,
    Action<IEnvelope<IDN>> handler,
    IStrategy[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of IDN)), _
    strategyList As IStrategy(), _
    filterList As IFilter() _
) As IDeviceService
Visual C++
IDeviceService^ RegisterEvents(
    IDevice^ device,
    Action<IEnvelope<IDN^>^>^ handler,
    array<IStrategy^>^ strategyList,
    array<IFilter^>^ filterList
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( IDN >)>)>)>)
Handler to register.
strategyList
Type: array< IStrategy >[]()[]
Strategies.
filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]
Filters.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IDeviceService.RegisterEvents(Genesyslab.Enterprise.Model.Device.IDevice,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Core.IDN}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IDevice, Action(IEnvelope(IDN)), Attribute[], Attribute[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterEvents Method (IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[])
IDeviceService Interface See Also Send Feedback
Registers the given event handler for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDeviceService RegisterEvents(
    IDevice device,
    Action<IEnvelope<IDN>> handler,
    Attribute[] strategyList,
    Attribute[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of IDN)), _
    strategyList As Attribute(), _
    filterList As Attribute() _
) As IDeviceService
Visual C++
IDeviceService^ RegisterEvents(
    IDevice^ device,
    Action<IEnvelope<IDN^>^>^ handler,
    array<Attribute^>^ strategyList,
    array<Attribute^>^ filterList
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( IDN >)>)>)>)
Event handler to register.
strategyList
Type: array< System..::.Attribute >[]()[]
Strategies.
filterList
Type: array< System..::.Attribute >[]()[]
Filters.

Return Value

the IDeviceService.

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IDevice, Action(IEnvelope(IDN)), String[], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterEvents Method (IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>), array<String>[]()[], array<IFilter>[]()[])
IDeviceService Interface See Also Send Feedback
Registers the given event handler for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDeviceService RegisterEvents(
    IDevice device,
    Action<IEnvelope<IDN>> handler,
    string[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of IDN)), _
    strategyList As String(), _
    filterList As IFilter() _
) As IDeviceService
Visual C++
IDeviceService^ RegisterEvents(
    IDevice^ device,
    Action<IEnvelope<IDN^>^>^ handler,
    array<String^>^ strategyList,
    array<IFilter^>^ filterList
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( IDN >)>)>)>)
Handler to register.
strategyList
Type: array< System..::.String >[]()[]
Strategies.
filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]
Filters.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IDeviceService.RegisterEvents(Genesyslab.Enterprise.Model.Device.IDevice,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Core.IDN}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterFilter<(Of <(T>)>) Method
IDeviceService Interface See Also Send Feedback
Registers an event filter for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDeviceService RegisterFilter<T>(
    IDevice device,
    T filter
)
Visual Basic (Declaration)
Function RegisterFilter(Of T) ( _
    device As IDevice, _
    filter As T _
) As IDeviceService
Visual C++
generic<typename T>
IDeviceService^ RegisterFilter(
    IDevice^ device,
    T filter
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
filter
Type: T
Filter to register.

Type Parameters

T
Filter type.

Return Value

the IDeviceService.

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.UnRegisterEvents Method
IDeviceService Interface See Also Send Feedback
Unregisters the given handler for the specified device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDeviceDomain UnRegisterEvents(
    IDevice device,
    Action<IEnvelope<IDN>> handler
)
Visual Basic (Declaration)
Function UnRegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of IDN)) _
) As IDeviceDomain
Visual C++
IDeviceDomain^ UnRegisterEvents(
    IDevice^ device,
    Action<IEnvelope<IDN^>^>^ handler
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( IDN >)>)>)>)
Handler to unregister.

Return Value

Domain.

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.UnRegisterFilter<(Of <(T>)>) Method
IDeviceService Interface See Also Send Feedback
Unregisters a filter for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDeviceService UnRegisterFilter<T>(
    IDevice device,
    T filter
)
Visual Basic (Declaration)
Function UnRegisterFilter(Of T) ( _
    device As IDevice, _
    filter As T _
) As IDeviceService
Visual C++
generic<typename T>
IDeviceService^ UnRegisterFilter(
    IDevice^ device,
    T filter
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
filter
Type: T
Filter to unregister.

Type Parameters

T
Filter type.

Return Value

the IDeviceService.

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
Genesyslab.Enterprise.Services Namespace


IEntityDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain Interface
Members See Also Send Feedback
Manages entities and identities for groups and persons.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IEntityDomain : IAliasManager
Visual Basic (Declaration)
Public Interface IEntityDomain _
    Implements IAliasManager
Visual C++
public interface class IEntityDomain : IAliasManager

See Also

IEntityDomain Members
Genesyslab.Enterprise.Services Namespace


IEntityDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEntityDomain Members
IEntityDomain Interface Methods See Also Send Feedback

The IEntityDomain type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias. (Inherited from IAliasManager.)
AddRole | Adds a Role.
CreatePerson | Creates a new person identity with the specified name (this person is not a group). Note: Names must be unique across both group identities and person identities. Names must be unique across types within a namespace.
DeletePerson | Deletes the specified object and all related data. Upon successful completion, aliases, profiles, and preferences are deleted from the system. The object is also removed from all the groups to which it belonged.
ListAliases | Returns the list of aliases asscoiated with the given identity. (Inherited from IAliasManager.)
ListPersons | Lists the Identities (group) for the specified group.
ListRoles | Lists the roles.
LookupByAlias | Searches for an alias. (Inherited from IAliasManager.)
RemoveAlias | Overloaded.
RemovePerson | Removes an Identity from and existing object Group.
RemoveRole | Removes the specified Role.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


IEntityDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IEntityDomain Methods
IEntityDomain Interface See Also Send Feedback

The IEntityDomain type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias. (Inherited from IAliasManager.)
AddRole | Adds a Role.
CreatePerson | Creates a new person identity with the specified name (this person is not a group). Note: Names must be unique across both group identities and person identities. Names must be unique across types within a namespace.
DeletePerson | Deletes the specified object and all related data. Upon successful completion, aliases, profiles, and preferences are deleted from the system. The object is also removed from all the groups to which it belonged.
ListAliases | Returns the list of aliases asscoiated with the given identity. (Inherited from IAliasManager.)
ListPersons | Lists the Identities (group) for the specified group.
ListRoles | Lists the roles.
LookupByAlias | Searches for an alias. (Inherited from IAliasManager.)
RemoveAlias | Overloaded.
RemovePerson | Removes an Identity from and existing object Group.
RemoveRole | Removes the specified Role.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


AddRole Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.AddRole Method
IEntityDomain Interface See Also Send Feedback
Adds a Role.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEntityDomain AddRole(
    IRole role
)
Visual Basic (Declaration)
Function AddRole ( _
    role As IRole _
) As IEntityDomain
Visual C++
IEntityDomain^ AddRole(
    IRole^ role
)

Parameters

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole
the role to add.

Return Value

the IEntityDomain.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


CreatePerson Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.CreatePerson Method
IEntityDomain Interface See Also Send Feedback
Creates a new person identity with the specified name (this person is not a group). Note: Names must be unique across both group identities and person identities. Names must be unique across types within a namespace.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentity CreatePerson(
    string name
)
Visual Basic (Declaration)
Function CreatePerson ( _
    name As String _
) As IIdentity
Visual C++
IIdentity^ CreatePerson(
    String^ name
)

Parameters

name
Type: System..::.String
Name to create.

Return Value

Created identity.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


DeletePerson Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.DeletePerson Method
IEntityDomain Interface See Also Send Feedback
Deletes the specified object and all related data. Upon successful completion, aliases, profiles, and preferences are deleted from the system. The object is also removed from all the groups to which it belonged.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEntityDomain DeletePerson(
    IEntity group
)
Visual Basic (Declaration)
Function DeletePerson ( _
    group As IEntity _
) As IEntityDomain
Visual C++
IEntityDomain^ DeletePerson(
    IEntity^ group
)

Parameters

group
Type: Genesyslab.Enterprise.Model.Identity..::.IEntity
Group

Return Value

the IEntityDomain.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


ListPersons Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.ListPersons Method
IEntityDomain Interface See Also Send Feedback
Lists the Identities (group) for the specified group.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEntity[] ListPersons(
    IEntity group
)
Visual Basic (Declaration)
Function ListPersons ( _
    group As IEntity _
) As IEntity()
Visual C++
array<IEntity^>^ ListPersons(
    IEntity^ group
)

Parameters

group
Type: Genesyslab.Enterprise.Model.Identity..::.IEntity
the specified group.

Return Value

Array of IEntity.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


ListRoles Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.ListRoles Method
IEntityDomain Interface See Also Send Feedback
Lists the roles.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IRole[] ListRoles()
Visual Basic (Declaration)
Function ListRoles As IRole()
Visual C++
array<IRole^>^ ListRoles()

Return Value

the array of roles.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


RemoveAlias Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.RemoveAlias Method
IEntityDomain Interface See Also Send Feedback

Overload List

Name | Description
RemoveAlias(IAlias) | Removes an alias. (Inherited from IAliasManager.)
RemoveAlias(String) | Removes an alias. (Inherited from IAliasManager.)

See Also

IEntityDomain Interface
IEntityDomain Members
Genesyslab.Enterprise.Services Namespace


RemovePerson Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.RemovePerson Method
IEntityDomain Interface See Also Send Feedback
Removes an Identity from and existing object Group.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEntityDomain RemovePerson(
    IEntity group
)
Visual Basic (Declaration)
Function RemovePerson ( _
    group As IEntity _
) As IEntityDomain
Visual C++
IEntityDomain^ RemovePerson(
    IEntity^ group
)

Parameters

group
Type: Genesyslab.Enterprise.Model.Identity..::.IEntity
the identity to remove.

Return Value

the IEntityDomain.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


RemoveRole Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.RemoveRole Method
IEntityDomain Interface See Also Send Feedback
Removes the specified Role.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEntityDomain RemoveRole(
    IRole role
)
Visual Basic (Declaration)
Function RemoveRole ( _
    role As IRole _
) As IEntityDomain
Visual C++
IEntityDomain^ RemoveRole(
    IRole^ role
)

Parameters

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole
the role to remove.

Return Value

the IEntityDomain.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


IEventManager(D, T) Interface

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>) Interface
Members See Also Send Feedback
Event Manager.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IEventManager<D, T>
where D : class
Visual Basic (Declaration)
Public Interface IEventManager(Of D As Class, T)
Visual C++
generic<typename D, typename T>
where D : ref class
public interface class IEventManager

Type Parameters

D
the type of data.
T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Services.IEventManager`2"]

See Also

IEventManager<(Of <(D, T>)>) Members
Genesyslab.Enterprise.Services Namespace


IEventManager(D, T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>) Members
IEventManager<(Of <(D, T>)>) Interface Methods See Also Send Feedback

The IEventManager<(Of <(D, T>)>) type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not report events. Your application needs to call the [!:StartMonitor] method.
RegisterEvents | Overloaded.
RemoveChannel | Removes the given channel from the monitoring list. Your application no longer receives events for this channel.
UnRegisterEvents | Unregisters a specific handler for a given channel.

See Also

IEventManager<(Of <(D, T>)>) Interface
Genesyslab.Enterprise.Services Namespace


IEventManager(D, T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>) Methods
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback

The IEventManager<(Of <(D, T>)>) type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not report events. Your application needs to call the [!:StartMonitor] method.
RegisterEvents | Overloaded.
RemoveChannel | Removes the given channel from the monitoring list. Your application no longer receives events for this channel.
UnRegisterEvents | Unregisters a specific handler for a given channel.

See Also

IEventManager<(Of <(D, T>)>) Interface
Genesyslab.Enterprise.Services Namespace


AddChannel Method

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.AddChannel Method
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Enables the monitoring of the given channel. Note: This method does not report events. Your application needs to call the [!:StartMonitor] method.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
D AddChannel(
    IClientChannel channel
)
Visual Basic (Declaration)
Function AddChannel ( _
    channel As IClientChannel _
) As D
Visual C++
D AddChannel(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel object

Return Value

the data.

See Also

IEventManager<(Of <(D, T>)>) Interface
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.RegisterEvents Method
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel.
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<IStrategy>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters.
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<Attribute>[]()[], array<Attribute>[]()[]) | Registers a callback method on the given channel with attribute filters.
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters.

See Also

IEventManager<(Of <(D, T>)>) Interface
IEventManager<(Of <(D, T>)>) Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(T))

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.RegisterEvents Method (IClientChannel, Action<(Of <(T>)>))
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Registers a callback method for the given channel.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
D RegisterEvents(
    IClientChannel channel,
    Action<T> handler
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of T) _
) As D
Visual C++
D RegisterEvents(
    IClientChannel^ channel,
    Action<T>^ handler
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Event source.
handler
Type: System..::.Action<(Of <( T >)>)
Callback method.

Return Value

the data.

See Also

IEventManager<(Of <(D, T>)>) Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(T), [], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.RegisterEvents Method (IClientChannel, Action<(Of <(T>)>), array<>[]()[], array<IFilter>[]()[])
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Registers a callback method on the given channel with filters.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
D RegisterEvents(
    IClientChannel channel,
    Action<T> handler,
    IStrategy[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of T), _
    strategyList As IStrategy(), _
    filterList As IFilter() _
) As D
Visual C++
D RegisterEvents(
    IClientChannel^ channel,
    Action<T>^ handler,
    array<IStrategy^>^ strategyList,
    array<IFilter^>^ filterList
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Event source.
handler
Type: System..::.Action<(Of <( T >)>)
Callback method.
strategyList
Type: array< IStrategy >[]()[]
The strategies to apply with filters. Strategy must be of filter type.
filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]
Array of filters.

Return Value

ISupervisorService

See Also

IEventManager<(Of <(D, T>)>) Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(T), Attribute[], Attribute[])

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.RegisterEvents Method (IClientChannel, Action<(Of <(T>)>), array<Attribute>[]()[], array<Attribute>[]()[])
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Registers a callback method on the given channel with attribute filters.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
D RegisterEvents(
    IClientChannel channel,
    Action<T> handler,
    Attribute[] strategyList,
    Attribute[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of T), _
    strategyList As Attribute(), _
    filterList As Attribute() _
) As D
Visual C++
D RegisterEvents(
    IClientChannel^ channel,
    Action<T>^ handler,
    array<Attribute^>^ strategyList,
    array<Attribute^>^ filterList
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Event source.
handler
Type: System..::.Action<(Of <( T >)>)
Callback method.
strategyList
Type: array< System..::.Attribute >[]()[]
Array of strategies attribute. Strategy must be of filter type
filterList
Type: array< System..::.Attribute >[]()[]
Array of filters attributes (defined within the code).

Return Value

the data.

See Also

IEventManager<(Of <(D, T>)>) Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(T), String[], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.RegisterEvents Method (IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[])
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Registers a callback method on the given channel with filters.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
D RegisterEvents(
    IClientChannel channel,
    Action<T> handler,
    string[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of T), _
    strategyList As String(), _
    filterList As IFilter() _
) As D
Visual C++
D RegisterEvents(
    IClientChannel^ channel,
    Action<T>^ handler,
    array<String^>^ strategyList,
    array<IFilter^>^ filterList
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Event source.
handler
Type: System..::.Action<(Of <( T >)>)
Callback method.
strategyList
Type: array< System..::.String >[]()[]
Names of the strategies to apply with the filters. Strategy must be of IFilter type.
filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]
List of filters.

Return Value

the data.

See Also

IEventManager<(Of <(D, T>)>) Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RemoveChannel Method

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.RemoveChannel Method
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Removes the given channel from the monitoring list. Your application no longer receives events for this channel.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
D RemoveChannel(
    IClientChannel channel
)
Visual Basic (Declaration)
Function RemoveChannel ( _
    channel As IClientChannel _
) As D
Visual C++
D RemoveChannel(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel object

Return Value

the data.

See Also

IEventManager<(Of <(D, T>)>) Interface
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.UnRegisterEvents Method
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Unregisters a specific handler for a given channel.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
D UnRegisterEvents(
    IClientChannel channel,
    Action<T> handler
)
Visual Basic (Declaration)
Function UnRegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of T) _
) As D
Visual C++
D UnRegisterEvents(
    IClientChannel^ channel,
    Action<T>^ handler
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Event source.
handler
Type: System..::.Action<(Of <( T >)>)
Callback method to unregister.

Return Value

the data.

See Also

IEventManager<(Of <(D, T>)>) Interface
Genesyslab.Enterprise.Services Namespace


IIdentityDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain Interface
Members See Also Send Feedback
Manages the identity domain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IIdentityDomain : IAliasManager,
    IRoleManager<IIdentity>
Visual Basic (Declaration)
Public Interface IIdentityDomain _
    Implements IAliasManager, IRoleManager(Of IIdentity)
Visual C++
public interface class IIdentityDomain : IAliasManager,
    IRoleManager<IIdentity^>

See Also

IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


IIdentityDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain Members
IIdentityDomain Interface Methods See Also Send Feedback

The IIdentityDomain type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias. (Inherited from IAliasManager.)
AddIdentity | Adds the Identity to the given Identity group.
CreateIdentity | Overloaded.
DeleteIdentity | Deletes the specified identity and all its related data. Upon successful completion, associated Aliases, Profiles and Preferences are deleted from the system The identity is also removed from all the groups to which the identity belonged before this operation.
GetActionsRole | Overloaded.
GetDevices | Returns all the devices associated with this identity.
GetIdentities | Returns all the registered identity intances.
GetIdentity | Retrieves the identity associated with the given name.
GetObjectRole | Overloaded.
HasRole | Overloaded.
IsIdentity | Overloaded.
ListAliases | Returns the list of aliases asscoiated with the given identity. (Inherited from IAliasManager.)
ListIdentities | Lists all the identities that belong to an identity group (which is a composite component).
ListRoles | Overloaded.
LookupByAlias | Searches for an alias. (Inherited from IAliasManager.)
RegisterActionsForRole | Registers actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
RegisterObjectRole | Registers Role available for an object type. (Inherited from IRoleManager<(Of <(T>)>).)
RemoveAlias | Overloaded.
RemoveDevice | Removes the device from the given identity instance.
RemoveIdentity | Removes the Identity from the given Identity Group.
SetDevice | Associates a device with an identity instance.
UnregisterActionsForRole | Unregisters actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
UnregisterObjectRole | Unregisters Role. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


IIdentityDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain Methods
IIdentityDomain Interface See Also Send Feedback

The IIdentityDomain type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias. (Inherited from IAliasManager.)
AddIdentity | Adds the Identity to the given Identity group.
CreateIdentity | Overloaded.
DeleteIdentity | Deletes the specified identity and all its related data. Upon successful completion, associated Aliases, Profiles and Preferences are deleted from the system The identity is also removed from all the groups to which the identity belonged before this operation.
GetActionsRole | Overloaded.
GetDevices | Returns all the devices associated with this identity.
GetIdentities | Returns all the registered identity intances.
GetIdentity | Retrieves the identity associated with the given name.
GetObjectRole | Overloaded.
HasRole | Overloaded.
IsIdentity | Overloaded.
ListAliases | Returns the list of aliases asscoiated with the given identity. (Inherited from IAliasManager.)
ListIdentities | Lists all the identities that belong to an identity group (which is a composite component).
ListRoles | Overloaded.
LookupByAlias | Searches for an alias. (Inherited from IAliasManager.)
RegisterActionsForRole | Registers actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
RegisterObjectRole | Registers Role available for an object type. (Inherited from IRoleManager<(Of <(T>)>).)
RemoveAlias | Overloaded.
RemoveDevice | Removes the device from the given identity instance.
RemoveIdentity | Removes the Identity from the given Identity Group.
SetDevice | Associates a device with an identity instance.
UnregisterActionsForRole | Unregisters actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
UnregisterObjectRole | Unregisters Role. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


AddIdentity Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.AddIdentity Method
IIdentityDomain Interface See Also Send Feedback
Adds the Identity to the given Identity group.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentityDomain AddIdentity(
    IIdentity identity,
    IIdentity group,
    bool allowEvents
)
Visual Basic (Declaration)
Function AddIdentity ( _
    identity As IIdentity, _
    group As IIdentity, _
    allowEvents As Boolean _
) As IIdentityDomain
Visual C++
IIdentityDomain^ AddIdentity(
    IIdentity^ identity,
    IIdentity^ group,
    bool allowEvents
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Identity to add.
group
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Group of identities.
allowEvents
Type: System..::.Boolean
True to allow event propagation to the upper layer.

Return Value

IIdentityDomain

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


CreateIdentity Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.CreateIdentity Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
CreateIdentity(String) | Creates a new non-group Identity with the specified name.
CreateIdentity(String, Object) | Creates a new non-composite Identity with the specified name and controller.

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


CreateIdentity Method (String)

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.CreateIdentity Method (String)
IIdentityDomain Interface See Also Send Feedback
Creates a new non-group Identity with the specified name.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentity CreateIdentity(
    string name
)
Visual Basic (Declaration)
Function CreateIdentity ( _
    name As String _
) As IIdentity
Visual C++
IIdentity^ CreateIdentity(
    String^ name
)

Parameters

name
Type: System..::.String
the name of the identity.

Return Value

IIdentity

See Also

IIdentityDomain Interface
CreateIdentity Overload
Genesyslab.Enterprise.Services Namespace


CreateIdentity Method (String, Object)

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.CreateIdentity Method (String, Object)
IIdentityDomain Interface See Also Send Feedback
Creates a new non-composite Identity with the specified name and controller.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentity CreateIdentity(
    string name,
    Object controller
)
Visual Basic (Declaration)
Function CreateIdentity ( _
    name As String, _
    controller As Object _
) As IIdentity
Visual C++
IIdentity^ CreateIdentity(
    String^ name,
    Object^ controller
)

Parameters

name
Type: System..::.String
Name of the new identity.
controller
Type: System..::.Object
Controller.

Return Value

IIdentity

See Also

IIdentityDomain Interface
CreateIdentity Overload
Genesyslab.Enterprise.Services Namespace


DeleteIdentity Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.DeleteIdentity Method
IIdentityDomain Interface See Also Send Feedback
Deletes the specified identity and all its related data. Upon successful completion, associated Aliases, Profiles and Preferences are deleted from the system The identity is also removed from all the groups to which the identity belonged before this operation.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentityDomain DeleteIdentity(
    IIdentity identity
)
Visual Basic (Declaration)
Function DeleteIdentity ( _
    identity As IIdentity _
) As IIdentityDomain
Visual C++
IIdentityDomain^ DeleteIdentity(
    IIdentity^ identity
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
the identity.

Return Value

IIdentityDomain

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


GetActionsRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.GetActionsRole Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
GetActionsRole<(Of <(U>)>)(IRole) | Gets the actions of a role. (Inherited from IRoleManager<(Of <(T>)>).)
GetActionsRole<(Of <(U>)>)(PartyType) | Gets the actions of a role profile type. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


GetDevices Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.GetDevices Method
IIdentityDomain Interface See Also Send Feedback
Returns all the devices associated with this identity.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDevice[] GetDevices(
    IIdentity identity
)
Visual Basic (Declaration)
Function GetDevices ( _
    identity As IIdentity _
) As IDevice()
Visual C++
array<IDevice^>^ GetDevices(
    IIdentity^ identity
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
identity instance

Return Value

IDevice[]

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


GetIdentities Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.GetIdentities Method
IIdentityDomain Interface See Also Send Feedback
Returns all the registered identity intances.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentity[] GetIdentities()
Visual Basic (Declaration)
Function GetIdentities As IIdentity()
Visual C++
array<IIdentity^>^ GetIdentities()

Return Value

IIdentity[]

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


GetIdentity Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.GetIdentity Method
IIdentityDomain Interface See Also Send Feedback
Retrieves the identity associated with the given name.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentity GetIdentity(
    string name
)
Visual Basic (Declaration)
Function GetIdentity ( _
    name As String _
) As IIdentity
Visual C++
IIdentity^ GetIdentity(
    String^ name
)

Parameters

name
Type: System..::.String
Name.

Return Value

IIdentity

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


GetObjectRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.GetObjectRole Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
GetObjectRole(T, IRole) | Gets the Role for an object according to the role. (Inherited from IRoleManager<(Of <(T>)>).)
GetObjectRole(T, PartyType) | Gets the Role for an object according to the profile type. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


HasRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.HasRole Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
HasRole(T, IRole) | Gets the Role availability for an object type according to the role. (Inherited from IRoleManager<(Of <(T>)>).)
HasRole(T, PartyType) | Gets the Role availability for an object type according to the profile type. (Inherited from IRoleManager<(Of <(T>)>).)
HasRole(T, Type) | Gets the Role availability for an object type according to the action. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


IsIdentity Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.IsIdentity Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
IsIdentity(IIdentity) | Returns true if the given identity is not composite, or false if this identity is a composite group of identities.
IsIdentity(String) | Returns true if the given identity is not composite, or false if this identity is a composite group of identities.

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


IsIdentity Method (IIdentity)

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.IsIdentity Method (IIdentity)
IIdentityDomain Interface See Also Send Feedback
Returns true if the given identity is not composite, or false if this identity is a composite group of identities.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsIdentity(
    IIdentity identity
)
Visual Basic (Declaration)
Function IsIdentity ( _
    identity As IIdentity _
) As Boolean
Visual C++
bool IsIdentity(
    IIdentity^ identity
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
the identity to check.

Return Value

true if the given identity is not composite.

See Also

IIdentityDomain Interface
IsIdentity Overload
Genesyslab.Enterprise.Services Namespace


IsIdentity Method (String)

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.IsIdentity Method (String)
IIdentityDomain Interface See Also Send Feedback
Returns true if the given identity is not composite, or false if this identity is a composite group of identities.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsIdentity(
    string name
)
Visual Basic (Declaration)
Function IsIdentity ( _
    name As String _
) As Boolean
Visual C++
bool IsIdentity(
    String^ name
)

Parameters

name
Type: System..::.String
the identity name to check.

Return Value

true if the given identity is not composite.

See Also

IIdentityDomain Interface
IsIdentity Overload
Genesyslab.Enterprise.Services Namespace


ListIdentities Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.ListIdentities Method
IIdentityDomain Interface See Also Send Feedback
Lists all the identities that belong to an identity group (which is a composite component).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentity[] ListIdentities(
    IIdentity identity
)
Visual Basic (Declaration)
Function ListIdentities ( _
    identity As IIdentity _
) As IIdentity()
Visual C++
array<IIdentity^>^ ListIdentities(
    IIdentity^ identity
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Identity to search.

Return Value

IIdentity[]

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


ListRoles Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.ListRoles Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
ListRoles()()() | Gets the list of Role. (Inherited from IRoleManager<(Of <(T>)>).)
ListRoles(T) | Gets the list of Role available for an object type. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


RemoveAlias Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.RemoveAlias Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
RemoveAlias(IAlias) | Removes an alias. (Inherited from IAliasManager.)
RemoveAlias(String) | Removes an alias. (Inherited from IAliasManager.)

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


RemoveDevice Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.RemoveDevice Method
IIdentityDomain Interface See Also Send Feedback
Removes the device from the given identity instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentityDomain RemoveDevice(
    IIdentity identity,
    IDevice device
)
Visual Basic (Declaration)
Function RemoveDevice ( _
    identity As IIdentity, _
    device As IDevice _
) As IIdentityDomain
Visual C++
IIdentityDomain^ RemoveDevice(
    IIdentity^ identity,
    IDevice^ device
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Identity target instance.
device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device instance to be linked.

Return Value

IIdentityDomain

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


RemoveIdentity Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.RemoveIdentity Method
IIdentityDomain Interface See Also Send Feedback
Removes the Identity from the given Identity Group.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentityDomain RemoveIdentity(
    IIdentity identity,
    IIdentity group
)
Visual Basic (Declaration)
Function RemoveIdentity ( _
    identity As IIdentity, _
    group As IIdentity _
) As IIdentityDomain
Visual C++
IIdentityDomain^ RemoveIdentity(
    IIdentity^ identity,
    IIdentity^ group
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
the identity to remove.
group
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Target group.

Return Value

IIdentityDomain

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


SetDevice Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.SetDevice Method
IIdentityDomain Interface See Also Send Feedback
Associates a device with an identity instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentityDomain SetDevice(
    IIdentity identity,
    IDevice device
)
Visual Basic (Declaration)
Function SetDevice ( _
    identity As IIdentity, _
    device As IDevice _
) As IIdentityDomain
Visual C++
IIdentityDomain^ SetDevice(
    IIdentity^ identity,
    IDevice^ device
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
the identity.
device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
the device.

Return Value

IIdentityDomain

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


IIdentityService Interface

[image]

Enterprise SDK 8.0 Reference API
IIdentityService Interface
Members Example See Also Send Feedback
Manages the identities.
Note: To use an agent with a device, create a link between these objects with the IIdentityService.SetDevice() method.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IIdentityService : IIdentityDomain,
    IAliasManager, IRoleManager<IIdentity>
Visual Basic (Declaration)
Public Interface IIdentityService _
    Implements IIdentityDomain, IAliasManager, IRoleManager(Of IIdentity)
Visual C++
public interface class IIdentityService : IIdentityDomain,
    IAliasManager, IRoleManager<IIdentity^>

Examples

Associate an Agent with a Device and monitor Agent Events.
CopyC#
IIdentityService identityService = EsdkService.Resolve<IIdentityService>("identityService");
            if (identityService != null)
            {
               //Create Agent
               agent = identityService.CreateIdentity("Lucent_1000") as IAgent;

               //Associate the Agent with a Device
               identityService.SetDevice(agent, device);

               //Register a handler
               identityService.RegisterEvents(agentA, new Action<IEnvelope<IAgent>>(AgentEvent));
               //...
            }
 To make this snippet work, you need to declare an AgentEvent() method:
CopyC#
[EnterpriseAgentEvent()]
protected void AgentEvent(IEnvelope<IAgent> tsp)
{
    int referenceId = tsp.Header.CorrelationId;
    //...
}

See Also

IIdentityService Members
Genesyslab.Enterprise.Services Namespace


IIdentityService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService Members
IIdentityService Interface Methods See Also Send Feedback

The IIdentityService type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias. (Inherited from IAliasManager.)
AddIdentity | Adds the Identity to the given Identity group. (Inherited from IIdentityDomain.)
CreateIdentity | Overloaded.
DeleteIdentity | Deletes the specified identity and all its related data. Upon successful completion, associated Aliases, Profiles and Preferences are deleted from the system The identity is also removed from all the groups to which the identity belonged before this operation. (Inherited from IIdentityDomain.)
GetActionsRole | Overloaded.
GetDevices | Returns all the devices associated with this identity. (Inherited from IIdentityDomain.)
GetIdentities | Returns all the registered identity intances. (Inherited from IIdentityDomain.)
GetIdentity | Retrieves the identity associated with the given name. (Inherited from IIdentityDomain.)
GetObjectRole | Overloaded.
HasRole | Overloaded.
IsIdentity | Overloaded.
ListAliases | Returns the list of aliases asscoiated with the given identity. (Inherited from IAliasManager.)
ListFilter<(Of <(T>)>) | Returns the filters registered for the given agent.
ListIdentities | Lists all the identities that belong to an identity group (which is a composite component). (Inherited from IIdentityDomain.)
ListRoles | Overloaded.
LookupByAlias | Searches for an alias. (Inherited from IAliasManager.)
RegisterActionsForRole | Registers actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for the given agent.
RegisterObjectRole | Registers Role available for an object type. (Inherited from IRoleManager<(Of <(T>)>).)
RemoveAlias | Overloaded.
RemoveDevice | Removes the device from the given identity instance. (Inherited from IIdentityDomain.)
RemoveIdentity | Removes the Identity from the given Identity Group. (Inherited from IIdentityDomain.)
SetDevice | Associates a device with an identity instance. (Inherited from IIdentityDomain.)
UnregisterActionsForRole | Unregisters actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
UnRegisterEvents | Unregisters for the events of the given agent.
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for the given agent.
UnregisterObjectRole | Unregisters Role. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityService Interface
Genesyslab.Enterprise.Services Namespace


IIdentityService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService Methods
IIdentityService Interface See Also Send Feedback

The IIdentityService type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias. (Inherited from IAliasManager.)
AddIdentity | Adds the Identity to the given Identity group. (Inherited from IIdentityDomain.)
CreateIdentity | Overloaded.
DeleteIdentity | Deletes the specified identity and all its related data. Upon successful completion, associated Aliases, Profiles and Preferences are deleted from the system The identity is also removed from all the groups to which the identity belonged before this operation. (Inherited from IIdentityDomain.)
GetActionsRole | Overloaded.
GetDevices | Returns all the devices associated with this identity. (Inherited from IIdentityDomain.)
GetIdentities | Returns all the registered identity intances. (Inherited from IIdentityDomain.)
GetIdentity | Retrieves the identity associated with the given name. (Inherited from IIdentityDomain.)
GetObjectRole | Overloaded.
HasRole | Overloaded.
IsIdentity | Overloaded.
ListAliases | Returns the list of aliases asscoiated with the given identity. (Inherited from IAliasManager.)
ListFilter<(Of <(T>)>) | Returns the filters registered for the given agent.
ListIdentities | Lists all the identities that belong to an identity group (which is a composite component). (Inherited from IIdentityDomain.)
ListRoles | Overloaded.
LookupByAlias | Searches for an alias. (Inherited from IAliasManager.)
RegisterActionsForRole | Registers actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for the given agent.
RegisterObjectRole | Registers Role available for an object type. (Inherited from IRoleManager<(Of <(T>)>).)
RemoveAlias | Overloaded.
RemoveDevice | Removes the device from the given identity instance. (Inherited from IIdentityDomain.)
RemoveIdentity | Removes the Identity from the given Identity Group. (Inherited from IIdentityDomain.)
SetDevice | Associates a device with an identity instance. (Inherited from IIdentityDomain.)
UnregisterActionsForRole | Unregisters actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
UnRegisterEvents | Unregisters for the events of the given agent.
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for the given agent.
UnregisterObjectRole | Unregisters Role. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityService Interface
Genesyslab.Enterprise.Services Namespace


CreateIdentity Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.CreateIdentity Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
CreateIdentity(String) | Creates a new non-group Identity with the specified name. (Inherited from IIdentityDomain.)
CreateIdentity(String, Object) | Creates a new non-composite Identity with the specified name and controller. (Inherited from IIdentityDomain.)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


GetActionsRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.GetActionsRole Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
GetActionsRole<(Of <(U>)>)(IRole) | Gets the actions of a role. (Inherited from IRoleManager<(Of <(T>)>).)
GetActionsRole<(Of <(U>)>)(PartyType) | Gets the actions of a role profile type. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


GetObjectRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.GetObjectRole Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
GetObjectRole(T, IRole) | Gets the Role for an object according to the role. (Inherited from IRoleManager<(Of <(T>)>).)
GetObjectRole(T, PartyType) | Gets the Role for an object according to the profile type. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


HasRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.HasRole Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
HasRole(T, IRole) | Gets the Role availability for an object type according to the role. (Inherited from IRoleManager<(Of <(T>)>).)
HasRole(T, PartyType) | Gets the Role availability for an object type according to the profile type. (Inherited from IRoleManager<(Of <(T>)>).)
HasRole(T, Type) | Gets the Role availability for an object type according to the action. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


IsIdentity Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.IsIdentity Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
IsIdentity(IIdentity) | Returns true if the given identity is not composite, or false if this identity is a composite group of identities. (Inherited from IIdentityDomain.)
IsIdentity(String) | Returns true if the given identity is not composite, or false if this identity is a composite group of identities. (Inherited from IIdentityDomain.)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.ListFilter<(Of <(T>)>) Method
IIdentityService Interface See Also Send Feedback
Returns the filters registered for the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnumerable<T> ListFilter<T>(
    IIdentity agent
)
Visual Basic (Declaration)
Function ListFilter(Of T) ( _
    agent As IIdentity _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ListFilter(
    IIdentity^ agent
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent

Type Parameters

T
Filter type.

Return Value

Filters of the agent.

See Also

IIdentityService Interface
Genesyslab.Enterprise.Services Namespace


ListRoles Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.ListRoles Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
ListRoles()()() | Gets the list of Role. (Inherited from IRoleManager<(Of <(T>)>).)
ListRoles(T) | Gets the list of Role available for an object type. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RegisterEvents Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>)) | Registers an event handler for the given agent.
RegisterEvents(IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>), array<IStrategy>[]()[], array<IFilter>[]()[]) | Registers for agent events with a handler, a strategy list, and a filter list.
RegisterEvents(IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[]) | Registers for agent events with a handler, and arrays of attributes for strategies and filters.
RegisterEvents(IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers for agent events with a handler, a list of strategy IDs, and a filter list.

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IIdentity, Action(IEnvelope(IAgent)))

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RegisterEvents Method (IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>))
IIdentityService Interface Example See Also Send Feedback
Registers an event handler for the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentityService RegisterEvents(
    IIdentity agent,
    Action<IEnvelope<IAgent>> handler
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    agent As IIdentity, _
    handler As Action(Of IEnvelope(Of IAgent)) _
) As IIdentityService
Visual C++
IIdentityService^ RegisterEvents(
    IIdentity^ agent,
    Action<IEnvelope<IAgent^>^>^ handler
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( IAgent >)>)>)>)
Handler method to register.

Return Value

the IIdentityService.

Examples

CopyC#
IIdentityService identityService = EsdkService.Resolve<IIdentityService>("identityService");
            if (identityService != null)
            {
               //Create Agent
               agent = identityService.CreateIdentity("Lucent_1000") as IAgent;

               //Associate the Agent with a Device
               identityService.SetDevice(agent, device);

               //Register a handler
               identityService.RegisterEvents(agentA, new Action<IEnvelope<IAgent>>(AgentEvent));
               //...
            }
 To make this snippet work, you need to declare an AgentEvent() method:
CopyC#
[EnterpriseAgentEvent()]
protected void AgentEvent(IEnvelope<IAgent> tsp)
{
    int referenceId = tsp.Header.CorrelationId;
    //...
}

See Also

IIdentityService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IIdentity, Action(IEnvelope(IAgent)), [], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RegisterEvents Method (IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>), array<>[]()[], array<IFilter>[]()[])
IIdentityService Interface See Also Send Feedback
Registers for agent events with a handler, a strategy list, and a filter list.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentityService RegisterEvents(
    IIdentity agent,
    Action<IEnvelope<IAgent>> handler,
    IStrategy[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    agent As IIdentity, _
    handler As Action(Of IEnvelope(Of IAgent)), _
    strategyList As IStrategy(), _
    filterList As IFilter() _
) As IIdentityService
Visual C++
IIdentityService^ RegisterEvents(
    IIdentity^ agent,
    Action<IEnvelope<IAgent^>^>^ handler,
    array<IStrategy^>^ strategyList,
    array<IFilter^>^ filterList
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( IAgent >)>)>)>)
Handler to register.
strategyList
Type: array< IStrategy >[]()[]
Strategies.
filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]
Filters.

Return Value

the IIdentityService.

See Also

IIdentityService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IIdentity, Action(IEnvelope(IAgent)), Attribute[], Attribute[])

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RegisterEvents Method (IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[])
IIdentityService Interface See Also Send Feedback
Registers for agent events with a handler, and arrays of attributes for strategies and filters.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentityService RegisterEvents(
    IIdentity agent,
    Action<IEnvelope<IAgent>> handler,
    Attribute[] strategyList,
    Attribute[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    agent As IIdentity, _
    handler As Action(Of IEnvelope(Of IAgent)), _
    strategyList As Attribute(), _
    filterList As Attribute() _
) As IIdentityService
Visual C++
IIdentityService^ RegisterEvents(
    IIdentity^ agent,
    Action<IEnvelope<IAgent^>^>^ handler,
    array<Attribute^>^ strategyList,
    array<Attribute^>^ filterList
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( IAgent >)>)>)>)
Handler method to register.
strategyList
Type: array< System..::.Attribute >[]()[]
Strategy attributes
filterList
Type: array< System..::.Attribute >[]()[]
Filter attributes.

Return Value

the IIdentityService.

See Also

IIdentityService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IIdentity, Action(IEnvelope(IAgent)), String[], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RegisterEvents Method (IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>), array<String>[]()[], array<IFilter>[]()[])
IIdentityService Interface See Also Send Feedback
Registers for agent events with a handler, a list of strategy IDs, and a filter list.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentityService RegisterEvents(
    IIdentity agent,
    Action<IEnvelope<IAgent>> handler,
    string[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    agent As IIdentity, _
    handler As Action(Of IEnvelope(Of IAgent)), _
    strategyList As String(), _
    filterList As IFilter() _
) As IIdentityService
Visual C++
IIdentityService^ RegisterEvents(
    IIdentity^ agent,
    Action<IEnvelope<IAgent^>^>^ handler,
    array<String^>^ strategyList,
    array<IFilter^>^ filterList
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( IAgent >)>)>)>)
Handler to register.
strategyList
Type: array< System..::.String >[]()[]
Strategy IDs.
filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]
Filters.

Return Value

the IIdentityService.

See Also

IIdentityService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RegisterFilter<(Of <(T>)>) Method
IIdentityService Interface See Also Send Feedback
Registers a filter for the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentityService RegisterFilter<T>(
    IIdentity agent,
    T filter
)
Visual Basic (Declaration)
Function RegisterFilter(Of T) ( _
    agent As IIdentity, _
    filter As T _
) As IIdentityService
Visual C++
generic<typename T>
IIdentityService^ RegisterFilter(
    IIdentity^ agent,
    T filter
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
filter
Type: T
Registers the filter for the given agent.

Type Parameters

T
Type for the filter.

Return Value

the IIdentityService.

See Also

IIdentityService Interface
Genesyslab.Enterprise.Services Namespace


RemoveAlias Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RemoveAlias Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
RemoveAlias(IAlias) | Removes an alias. (Inherited from IAliasManager.)
RemoveAlias(String) | Removes an alias. (Inherited from IAliasManager.)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.UnRegisterEvents Method
IIdentityService Interface See Also Send Feedback
Unregisters for the events of the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentityService UnRegisterEvents(
    IIdentity agent,
    Action<IEnvelope<IAgent>> handler
)
Visual Basic (Declaration)
Function UnRegisterEvents ( _
    agent As IIdentity, _
    handler As Action(Of IEnvelope(Of IAgent)) _
) As IIdentityService
Visual C++
IIdentityService^ UnRegisterEvents(
    IIdentity^ agent,
    Action<IEnvelope<IAgent^>^>^ handler
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( IAgent >)>)>)>)
Handler to unregister.

Return Value

the IIdentityService.

See Also

IIdentityService Interface
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.UnRegisterFilter<(Of <(T>)>) Method
IIdentityService Interface See Also Send Feedback
Unregisters a filter for the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IIdentityService UnRegisterFilter<T>(
    IIdentity agent,
    T filter
)
Visual Basic (Declaration)
Function UnRegisterFilter(Of T) ( _
    agent As IIdentity, _
    filter As T _
) As IIdentityService
Visual C++
generic<typename T>
IIdentityService^ UnRegisterFilter(
    IIdentity^ agent,
    T filter
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
filter
Type: T
The filter to unregister.

Type Parameters

T
Type.

Return Value

the IIdentityService.

See Also

IIdentityService Interface
Genesyslab.Enterprise.Services Namespace


IIMDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IIMDomain Interface
Members See Also Send Feedback
Manages Instant Messaging data.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IIMDomain
Visual Basic (Declaration)
Public Interface IIMDomain
Visual C++
public interface class IIMDomain

See Also

IIMDomain Members
Genesyslab.Enterprise.Services Namespace


IIMDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMDomain Members
IIMDomain Interface Methods See Also Send Feedback

The IIMDomain type exposes the following members.

Methods

Name | Description
CreateInteraction | Uses an existing interaction to create a new Instant Messaging interaction associated with a set of devices.
DeleteInteraction | Deletes the given interaction.
DeleteInteractions | Delete all interactions
GetAttachedData | Returns the user defined attached data of this interaction.
GetInteraction | Overloaded.
GetInteractions | Overloaded.
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically.
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers.
SetAttachedData | Overloaded.

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


IIMDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIMDomain Methods
IIMDomain Interface See Also Send Feedback

The IIMDomain type exposes the following members.

Methods

Name | Description
CreateInteraction | Uses an existing interaction to create a new Instant Messaging interaction associated with a set of devices.
DeleteInteraction | Deletes the given interaction.
DeleteInteractions | Delete all interactions
GetAttachedData | Returns the user defined attached data of this interaction.
GetInteraction | Overloaded.
GetInteractions | Overloaded.
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically.
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers.
SetAttachedData | Overloaded.

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.CreateInteraction Method
IIMDomain Interface See Also Send Feedback
Uses an existing interaction to create a new Instant Messaging interaction associated with a set of devices.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction CreateInteraction(
    IInteraction currentInteraction,
    IEnumerable<IDevice> deviceList
)
Visual Basic (Declaration)
Function CreateInteraction ( _
    currentInteraction As IInteraction, _
    deviceList As IEnumerable(Of IDevice) _
) As IInteraction
Visual C++
IInteraction^ CreateInteraction(
    IInteraction^ currentInteraction,
    IEnumerable<IDevice^>^ deviceList
)

Parameters

currentInteraction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Current instance of the IM interaction.
deviceList
Type: System.Collections.Generic..::.IEnumerable<(Of <( IDevice >)>)
List of devices to associate with the new interaction.

Return Value

IInteraction

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


DeleteInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.DeleteInteraction Method
IIMDomain Interface See Also Send Feedback
Deletes the given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteractionDomain DeleteInteraction(
    IInteraction interaction
)
Visual Basic (Declaration)
Function DeleteInteraction ( _
    interaction As IInteraction _
) As IInteractionDomain
Visual C++
IInteractionDomain^ DeleteInteraction(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the IM interaction.

Return Value

IInteractionDomain

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


DeleteInteractions Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.DeleteInteractions Method
IIMDomain Interface See Also Send Feedback
Delete all interactions

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteractionDomain DeleteInteractions()
Visual Basic (Declaration)
Function DeleteInteractions As IInteractionDomain
Visual C++
IInteractionDomain^ DeleteInteractions()

Return Value

IInteractionDomain

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


GetAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetAttachedData Method
IIMDomain Interface See Also Send Feedback
Returns the user defined attached data of this interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
KeyValueCollection GetAttachedData(
    IInteraction interaction
)
Visual Basic (Declaration)
Function GetAttachedData ( _
    interaction As IInteraction _
) As KeyValueCollection
Visual C++
KeyValueCollection^ GetAttachedData(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction.

Return Value

IDictionary<string, Object>

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


GetInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetInteraction Method
IIMDomain Interface See Also Send Feedback

Overload List

Name | Description
GetInteraction(IAgent, String) | Retrieves the interaction associated with an agent from its unique Id, or null if no interaction exists.
GetInteraction(IDN, String) | Retrieves the interaction associated with a device from its unique Id, or null if no interaction exists.

See Also

IIMDomain Interface
IIMDomain Members
Genesyslab.Enterprise.Services Namespace


GetInteraction Method (IAgent, String)

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetInteraction Method (IAgent, String)
IIMDomain Interface See Also Send Feedback
Retrieves the interaction associated with an agent from its unique Id, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction GetInteraction(
    IAgent agent,
    string interactionId
)
Visual Basic (Declaration)
Function GetInteraction ( _
    agent As IAgent, _
    interactionId As String _
) As IInteraction
Visual C++
IInteraction^ GetInteraction(
    IAgent^ agent,
    String^ interactionId
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
the agent.
interactionId
Type: System..::.String
the interaction ID.

Return Value

IInteraction

See Also

IIMDomain Interface
GetInteraction Overload
Genesyslab.Enterprise.Services Namespace


GetInteraction Method (IDN, String)

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetInteraction Method (IDN, String)
IIMDomain Interface See Also Send Feedback
Retrieves the interaction associated with a device from its unique Id, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction GetInteraction(
    IDN dn,
    string interactionId
)
Visual Basic (Declaration)
Function GetInteraction ( _
    dn As IDN, _
    interactionId As String _
) As IInteraction
Visual C++
IInteraction^ GetInteraction(
    IDN^ dn,
    String^ interactionId
)

Parameters

dn
Type: Genesyslab.Enterprise.Core..::.IDN
Device linked to the interaction
interactionId
Type: System..::.String
Unique Id of the interaction

Return Value

IInteraction

See Also

IIMDomain Interface
GetInteraction Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetInteractions Method
IIMDomain Interface See Also Send Feedback

Overload List

Name | Description
GetInteractions()()() | Returns all the existing IM interactions.
GetInteractions(IAgent) | Retrieves the interactions associated with an Agent, or null if no interaction exists.
GetInteractions(IDN) | Retrieves the interactions associated with a device, or null if no interaction exists.
GetInteractions(String) | Returns the existing IM interaction(s) associated with an interaction ID.

See Also

IIMDomain Interface
IIMDomain Members
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetInteractions Method
IIMDomain Interface See Also Send Feedback
Returns all the existing IM interactions.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction[] GetInteractions()
Visual Basic (Declaration)
Function GetInteractions As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions()

Return Value

IInteraction []

See Also

IIMDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (IAgent)

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetInteractions Method (IAgent)
IIMDomain Interface See Also Send Feedback
Retrieves the interactions associated with an Agent, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction[] GetInteractions(
    IAgent agent
)
Visual Basic (Declaration)
Function GetInteractions ( _
    agent As IAgent _
) As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions(
    IAgent^ agent
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Agent.

Return Value

IInteraction []

See Also

IIMDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (IDN)

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetInteractions Method (IDN)
IIMDomain Interface See Also Send Feedback
Retrieves the interactions associated with a device, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction[] GetInteractions(
    IDN dn
)
Visual Basic (Declaration)
Function GetInteractions ( _
    dn As IDN _
) As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions(
    IDN^ dn
)

Parameters

dn
Type: Genesyslab.Enterprise.Core..::.IDN
Device.

Return Value

IInteraction[]

See Also

IIMDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (String)

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetInteractions Method (String)
IIMDomain Interface See Also Send Feedback
Returns the existing IM interaction(s) associated with an interaction ID.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction[] GetInteractions(
    string interactionId
)
Visual Basic (Declaration)
Function GetInteractions ( _
    interactionId As String _
) As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions(
    String^ interactionId
)

Parameters

interactionId
Type: System..::.String
Unique identifier of the interaction.

Return Value

IInteraction []

See Also

IIMDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


RemoveAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.RemoveAttachedData Method
IIMDomain Interface See Also Send Feedback
Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction RemoveAttachedData(
    IInteraction interaction,
    string key
)
Visual Basic (Declaration)
Function RemoveAttachedData ( _
    interaction As IInteraction, _
    key As String _
) As IInteraction
Visual C++
IInteraction^ RemoveAttachedData(
    IInteraction^ interaction,
    String^ key
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction.
key
Type: System..::.String
the key of the attached data.

Return Value

IInteraction

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


SaveAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.SaveAttachedData Method
IIMDomain Interface See Also Send Feedback
Saves the modifications of the attached data. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction SaveAttachedData(
    IInteraction interaction
)
Visual Basic (Declaration)
Function SaveAttachedData ( _
    interaction As IInteraction _
) As IInteraction
Visual C++
IInteraction^ SaveAttachedData(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction.

Return Value

IInteraction.

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


SaveInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.SaveInteraction Method
IIMDomain Interface See Also Send Feedback
Saves the interaction in the service's repository. All data are synchronized with the back-end servers.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteractionDomain SaveInteraction(
    IInteraction interaction
)
Visual Basic (Declaration)
Function SaveInteraction ( _
    interaction As IInteraction _
) As IInteractionDomain
Visual C++
IInteractionDomain^ SaveInteraction(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction instance

Return Value

this IInteractionDomain.

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.SetAttachedData Method
IIMDomain Interface See Also Send Feedback

Overload List

Name | Description
SetAttachedData(IInteraction, KeyValueCollection) | Attaches several key-value pairs at once. The update in the back-end server is performed automatically.
SetAttachedData(IInteraction, String, Object) | Sets the user defined data as attached key-value pair. The update in the back-end server is performed automatically.

See Also

IIMDomain Interface
IIMDomain Members
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method (IInteraction, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.SetAttachedData Method (IInteraction, KeyValueCollection)
IIMDomain Interface See Also Send Feedback
Attaches several key-value pairs at once. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction SetAttachedData(
    IInteraction interaction,
    KeyValueCollection data
)
Visual Basic (Declaration)
Function SetAttachedData ( _
    interaction As IInteraction, _
    data As KeyValueCollection _
) As IInteraction
Visual C++
IInteraction^ SetAttachedData(
    IInteraction^ interaction,
    KeyValueCollection^ data
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction.
data
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
the KeyValueCollection data.

Return Value

IInteraction

See Also

IIMDomain Interface
SetAttachedData Overload
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method (IInteraction, String, Object)

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.SetAttachedData Method (IInteraction, String, Object)
IIMDomain Interface See Also Send Feedback
Sets the user defined data as attached key-value pair. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction SetAttachedData(
    IInteraction interaction,
    string key,
    Object value
)
Visual Basic (Declaration)
Function SetAttachedData ( _
    interaction As IInteraction, _
    key As String, _
    value As Object _
) As IInteraction
Visual C++
IInteraction^ SetAttachedData(
    IInteraction^ interaction,
    String^ key,
    Object^ value
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction to modify.
key
Type: System..::.String
Key of the pair.
value
Type: System..::.Object
Value of the pair.

Return Value

IInteraction

See Also

IIMDomain Interface
SetAttachedData Overload
Genesyslab.Enterprise.Services Namespace


IIMService Interface

[image]

Enterprise SDK 8.0 Reference API
IIMService Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.IIMService"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IIMService : IIMDomain,
    IBrokerSubscriber<IEnvelope<IIMInteraction>>, IBrokerPublisher, ISubscribeable<IEnvelope<IRequest>>,
    IPersistable<IIMInteraction>
Visual Basic (Declaration)
Public Interface IIMService _
    Implements IIMDomain, IBrokerSubscriber(Of IEnvelope(Of IIMInteraction)),  _
    IBrokerPublisher, ISubscribeable(Of IEnvelope(Of IRequest)), IPersistable(Of IIMInteraction)
Visual C++
public interface class IIMService : IIMDomain,
    IBrokerSubscriber<IEnvelope<IIMInteraction^>^>, IBrokerPublisher, ISubscribeable<IEnvelope<IRequest^>^>,
    IPersistable<IIMInteraction^>

See Also

IIMService Members
Genesyslab.Enterprise.Services Namespace


IIMService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService Members
IIMService Interface Methods Properties See Also Send Feedback

The IIMService type exposes the following members.

Methods

Name | Description
CreateInteraction | Uses an existing interaction to create a new Instant Messaging interaction associated with a set of devices. (Inherited from IIMDomain.)
DeleteInteraction | Deletes the given interaction. (Inherited from IIMDomain.)
DeleteInteractions | Delete all interactions (Inherited from IIMDomain.)
GetAttachedData | Returns the user defined attached data of this interaction. (Inherited from IIMDomain.)
GetInteraction | Overloaded.
GetInteractions | Overloaded.
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically. (Inherited from IIMDomain.)
Save | Overloaded.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically. (Inherited from IIMDomain.)
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers. (Inherited from IIMDomain.)
SetAttachedData | Overloaded.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the subscriber object of type T.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IIMService Interface
Genesyslab.Enterprise.Services Namespace


IIMService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService Methods
IIMService Interface See Also Send Feedback

The IIMService type exposes the following members.

Methods

Name | Description
CreateInteraction | Uses an existing interaction to create a new Instant Messaging interaction associated with a set of devices. (Inherited from IIMDomain.)
DeleteInteraction | Deletes the given interaction. (Inherited from IIMDomain.)
DeleteInteractions | Delete all interactions (Inherited from IIMDomain.)
GetAttachedData | Returns the user defined attached data of this interaction. (Inherited from IIMDomain.)
GetInteraction | Overloaded.
GetInteractions | Overloaded.
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically. (Inherited from IIMDomain.)
Save | Overloaded.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically. (Inherited from IIMDomain.)
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers. (Inherited from IIMDomain.)
SetAttachedData | Overloaded.

See Also

IIMService Interface
Genesyslab.Enterprise.Services Namespace


GetInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService..::.GetInteraction Method
IIMService Interface See Also Send Feedback

Overload List

Name | Description
GetInteraction(IAgent, String) | Retrieves the interaction associated with an agent from its unique Id, or null if no interaction exists. (Inherited from IIMDomain.)
GetInteraction(IDN, String) | Retrieves the interaction associated with a device from its unique Id, or null if no interaction exists. (Inherited from IIMDomain.)

See Also

IIMService Interface
IIMService Members
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService..::.GetInteractions Method
IIMService Interface See Also Send Feedback

Overload List

Name | Description
GetInteractions()()() | Returns all the existing IM interactions. (Inherited from IIMDomain.)
GetInteractions(IAgent) | Retrieves the interactions associated with an Agent, or null if no interaction exists. (Inherited from IIMDomain.)
GetInteractions(IDN) | Retrieves the interactions associated with a device, or null if no interaction exists. (Inherited from IIMDomain.)
GetInteractions(String) | Returns the existing IM interaction(s) associated with an interaction ID. (Inherited from IIMDomain.)

See Also

IIMService Interface
IIMService Members
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService..::.GetList Method
IIMService Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IIMService Interface
IIMService Members
Genesyslab.Enterprise.Services Namespace


Save Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService..::.Save Method
IIMService Interface See Also Send Feedback

Overload List

Name | Description
Save(T) | Saves the object into the Contact Server. (Inherited from IPersistable<(Of <(T>)>).)
Save(T, IStrategy) | Save data by executing the specified strategy (Inherited from IPersistable<(Of <(T>)>).)

See Also

IIMService Interface
IIMService Members
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService..::.SetAttachedData Method
IIMService Interface See Also Send Feedback

Overload List

Name | Description
SetAttachedData(IInteraction, KeyValueCollection) | Attaches several key-value pairs at once. The update in the back-end server is performed automatically. (Inherited from IIMDomain.)
SetAttachedData(IInteraction, String, Object) | Sets the user defined data as attached key-value pair. The update in the back-end server is performed automatically. (Inherited from IIMDomain.)

See Also

IIMService Interface
IIMService Members
Genesyslab.Enterprise.Services Namespace


IIMService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService Properties
IIMService Interface See Also Send Feedback

The IIMService type exposes the following members.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the subscriber object of type T.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IIMService Interface
Genesyslab.Enterprise.Services Namespace


IInteractionDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain Interface
Members See Also Send Feedback
Enables your application to manage interactions.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IInteractionDomain
Visual Basic (Declaration)
Public Interface IInteractionDomain
Visual C++
public interface class IInteractionDomain

Remarks

You can find code snippets for interaction creation in the CreateInteraction(IEnumerable<(Of <(IDevice>)>)) methods.

See Also

IInteractionDomain Members
Genesyslab.Enterprise.Services Namespace


IInteractionDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionDomain Members
IInteractionDomain Interface Methods See Also Send Feedback

The IInteractionDomain type exposes the following members.

Methods

Name | Description
CreateInteraction | Overloaded.
DeleteInteraction | Deletes the given interaction.
DeleteInteractions | Delete all interactions
GetAttachedData | Returns the user defined attached data of this interaction.
GetInteraction | Overloaded.
GetInteractions | Overloaded.
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically.
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers.
SetAttachedData | Overloaded.

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


IInteractionDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionDomain Methods
IInteractionDomain Interface See Also Send Feedback

The IInteractionDomain type exposes the following members.

Methods

Name | Description
CreateInteraction | Overloaded.
DeleteInteraction | Deletes the given interaction.
DeleteInteractions | Delete all interactions
GetAttachedData | Returns the user defined attached data of this interaction.
GetInteraction | Overloaded.
GetInteractions | Overloaded.
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically.
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers.
SetAttachedData | Overloaded.

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.CreateInteraction Method
IInteractionDomain Interface See Also Send Feedback

Overload List

Name | Description
CreateInteraction(IEnumerable<(Of <(IDevice>)>)) | Creates a new interaction associated with a set of devices and a unique ID.
CreateInteraction(IInteraction, IEnumerable<(Of <(IDevice>)>)) | Uses an existing interaction to create a new interaction associated with a set of devices.

See Also

IInteractionDomain Interface
IInteractionDomain Members
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method (IEnumerable(IDevice))

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.CreateInteraction Method (IEnumerable<(Of <(IDevice>)>))
IInteractionDomain Interface See Also Send Feedback
Creates a new interaction associated with a set of devices and a unique ID.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction CreateInteraction(
    IEnumerable<IDevice> deviceList
)
Visual Basic (Declaration)
Function CreateInteraction ( _
    deviceList As IEnumerable(Of IDevice) _
) As IInteraction
Visual C++
IInteraction^ CreateInteraction(
    IEnumerable<IDevice^>^ deviceList
)

Parameters

deviceList
Type: System.Collections.Generic..::.IEnumerable<(Of <( IDevice >)>)
List of devices associated with the interaction.

Return Value

IInteraction

Remarks

The following example shows how to make an Asynchronous Activate command. ///
CopyC#
IInteraction interaction = interactionService.CreateInteraction(deviceList);
if (interaction != null)
{
    ISubscribeable<IEnvelope>IRequest subscriber = interaction as ISubscribeable<IEnvelope<IRequest>>;
    if (subscriber != null)
    {
       subscriber.Handle(envelope);
    }
}

See Also

IInteractionDomain Interface
CreateInteraction Overload
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method (IInteraction, IEnumerable(IDevice))

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.CreateInteraction Method (IInteraction, IEnumerable<(Of <(IDevice>)>))
IInteractionDomain Interface Example See Also Send Feedback
Uses an existing interaction to create a new interaction associated with a set of devices.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction CreateInteraction(
    IInteraction currentInteraction,
    IEnumerable<IDevice> deviceList
)
Visual Basic (Declaration)
Function CreateInteraction ( _
    currentInteraction As IInteraction, _
    deviceList As IEnumerable(Of IDevice) _
) As IInteraction
Visual C++
IInteraction^ CreateInteraction(
    IInteraction^ currentInteraction,
    IEnumerable<IDevice^>^ deviceList
)

Parameters

currentInteraction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Current instance of the interaction.
deviceList
Type: System.Collections.Generic..::.IEnumerable<(Of <( IDevice >)>)
List of devices to associate with the new interaction.

Return Value

IInteraction

Examples

The following example shows how to make an Asynchronous Activate command.
CopyC#
IInteraction interaction = interactionService.CreateInteraction(previousInteraction, deviceList);
if (interaction != null)
{
    ISubscriber<IEnvelope<IRequest>> subscriber = interaction as ISubscriber<IEnvelope<IRequest>>;
    if (subscriber != null)
    {
       subscriber.Handle(envelope);
    }
}

See Also

IInteractionDomain Interface
CreateInteraction Overload
Genesyslab.Enterprise.Services Namespace


DeleteInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.DeleteInteraction Method
IInteractionDomain Interface See Also Send Feedback
Deletes the given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteractionDomain DeleteInteraction(
    IInteraction interaction
)
Visual Basic (Declaration)
Function DeleteInteraction ( _
    interaction As IInteraction _
) As IInteractionDomain
Visual C++
IInteractionDomain^ DeleteInteraction(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction.

Return Value

IInteractionDomain

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


DeleteInteractions Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.DeleteInteractions Method
IInteractionDomain Interface See Also Send Feedback
Delete all interactions

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteractionDomain DeleteInteractions()
Visual Basic (Declaration)
Function DeleteInteractions As IInteractionDomain
Visual C++
IInteractionDomain^ DeleteInteractions()

Return Value

IInteractionDomain

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


GetAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetAttachedData Method
IInteractionDomain Interface See Also Send Feedback
Returns the user defined attached data of this interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
KeyValueCollection GetAttachedData(
    IInteraction interaction
)
Visual Basic (Declaration)
Function GetAttachedData ( _
    interaction As IInteraction _
) As KeyValueCollection
Visual C++
KeyValueCollection^ GetAttachedData(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction

Return Value

IDictionary<string, Object>

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


GetInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteraction Method
IInteractionDomain Interface See Also Send Feedback

Overload List

Name | Description
GetInteraction(IAgent, String) | Retrieves the interaction associated with an agent from its unique Id, or null if no interaction exists.
GetInteraction(IDN, String) | Retrieves the interaction associated with a device from its unique Id, or null if no interaction exists.

See Also

IInteractionDomain Interface
IInteractionDomain Members
Genesyslab.Enterprise.Services Namespace


GetInteraction Method (IAgent, String)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteraction Method (IAgent, String)
IInteractionDomain Interface See Also Send Feedback
Retrieves the interaction associated with an agent from its unique Id, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction GetInteraction(
    IAgent agent,
    string interactionId
)
Visual Basic (Declaration)
Function GetInteraction ( _
    agent As IAgent, _
    interactionId As String _
) As IInteraction
Visual C++
IInteraction^ GetInteraction(
    IAgent^ agent,
    String^ interactionId
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
the agent.
interactionId
Type: System..::.String
the interaction ID.

Return Value

IInteraction

See Also

IInteractionDomain Interface
GetInteraction Overload
Genesyslab.Enterprise.Services Namespace


GetInteraction Method (IDN, String)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteraction Method (IDN, String)
IInteractionDomain Interface See Also Send Feedback
Retrieves the interaction associated with a device from its unique Id, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction GetInteraction(
    IDN dn,
    string interactionId
)
Visual Basic (Declaration)
Function GetInteraction ( _
    dn As IDN, _
    interactionId As String _
) As IInteraction
Visual C++
IInteraction^ GetInteraction(
    IDN^ dn,
    String^ interactionId
)

Parameters

dn
Type: Genesyslab.Enterprise.Core..::.IDN
Device linked to the interaction
interactionId
Type: System..::.String
Unique Id of the interaction

Return Value

IInteraction

See Also

IInteractionDomain Interface
GetInteraction Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteractions Method
IInteractionDomain Interface See Also Send Feedback

Overload List

Name | Description
GetInteractions()()() | Returns all the existing interactions.
GetInteractions(IAgent) | Retrieves the interactions associated with an Agent, or null if no interaction exists.
GetInteractions(IDN) | Retrieves the interactions associated with a device, or null if no interaction exists.
GetInteractions(String) | Returns the existing interaction(s) associated with an interaction ID.

See Also

IInteractionDomain Interface
IInteractionDomain Members
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteractions Method
IInteractionDomain Interface See Also Send Feedback
Returns all the existing interactions.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction[] GetInteractions()
Visual Basic (Declaration)
Function GetInteractions As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions()

Return Value

IInteraction []

See Also

IInteractionDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (IAgent)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteractions Method (IAgent)
IInteractionDomain Interface See Also Send Feedback
Retrieves the interactions associated with an Agent, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction[] GetInteractions(
    IAgent agent
)
Visual Basic (Declaration)
Function GetInteractions ( _
    agent As IAgent _
) As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions(
    IAgent^ agent
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Agent.

Return Value

IInteraction []

See Also

IInteractionDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (IDN)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteractions Method (IDN)
IInteractionDomain Interface See Also Send Feedback
Retrieves the interactions associated with a device, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction[] GetInteractions(
    IDN dn
)
Visual Basic (Declaration)
Function GetInteractions ( _
    dn As IDN _
) As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions(
    IDN^ dn
)

Parameters

dn
Type: Genesyslab.Enterprise.Core..::.IDN
Device.

Return Value

IInteraction[]

See Also

IInteractionDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (String)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteractions Method (String)
IInteractionDomain Interface See Also Send Feedback
Returns the existing interaction(s) associated with an interaction ID.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction[] GetInteractions(
    string interactionId
)
Visual Basic (Declaration)
Function GetInteractions ( _
    interactionId As String _
) As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions(
    String^ interactionId
)

Parameters

interactionId
Type: System..::.String
Unique identifier of the interaction.

Return Value

IInteraction []

See Also

IInteractionDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


RemoveAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.RemoveAttachedData Method
IInteractionDomain Interface See Also Send Feedback
Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction RemoveAttachedData(
    IInteraction interaction,
    string key
)
Visual Basic (Declaration)
Function RemoveAttachedData ( _
    interaction As IInteraction, _
    key As String _
) As IInteraction
Visual C++
IInteraction^ RemoveAttachedData(
    IInteraction^ interaction,
    String^ key
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction.
key
Type: System..::.String
the key of the attached data.

Return Value

IInteraction

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


SaveAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.SaveAttachedData Method
IInteractionDomain Interface See Also Send Feedback
Saves the modifications of the attached data. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction SaveAttachedData(
    IInteraction interaction
)
Visual Basic (Declaration)
Function SaveAttachedData ( _
    interaction As IInteraction _
) As IInteraction
Visual C++
IInteraction^ SaveAttachedData(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction.

Return Value

this IInteraction.

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


SaveInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.SaveInteraction Method
IInteractionDomain Interface See Also Send Feedback
Saves the interaction in the service's repository. All data are synchronized with the back-end servers.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteractionDomain SaveInteraction(
    IInteraction interaction
)
Visual Basic (Declaration)
Function SaveInteraction ( _
    interaction As IInteraction _
) As IInteractionDomain
Visual C++
IInteractionDomain^ SaveInteraction(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction instance

Return Value

this IInteractionDomain.

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.SetAttachedData Method
IInteractionDomain Interface See Also Send Feedback

Overload List

Name | Description
SetAttachedData(IInteraction, KeyValueCollection) | Attaches several key-value pairs at once. The update in the back-end server is performed automatically.
SetAttachedData(IInteraction, String, Object) | Sets the user defined data as attached key-value pair. The update in the back-end server is performed automatically.

See Also

IInteractionDomain Interface
IInteractionDomain Members
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method (IInteraction, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.SetAttachedData Method (IInteraction, KeyValueCollection)
IInteractionDomain Interface See Also Send Feedback
Attaches several key-value pairs at once. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction SetAttachedData(
    IInteraction interaction,
    KeyValueCollection data
)
Visual Basic (Declaration)
Function SetAttachedData ( _
    interaction As IInteraction, _
    data As KeyValueCollection _
) As IInteraction
Visual C++
IInteraction^ SetAttachedData(
    IInteraction^ interaction,
    KeyValueCollection^ data
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction to modify.
data
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
the KeyValueCollection data.

Return Value

IInteraction

See Also

IInteractionDomain Interface
SetAttachedData Overload
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method (IInteraction, String, Object)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.SetAttachedData Method (IInteraction, String, Object)
IInteractionDomain Interface See Also Send Feedback
Sets the user defined data as attached key-value pair. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IInteraction SetAttachedData(
    IInteraction interaction,
    string key,
    Object value
)
Visual Basic (Declaration)
Function SetAttachedData ( _
    interaction As IInteraction, _
    key As String, _
    value As Object _
) As IInteraction
Visual C++
IInteraction^ SetAttachedData(
    IInteraction^ interaction,
    String^ key,
    Object^ value
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction to modify.
key
Type: System..::.String
Key of the pair.
value
Type: System..::.Object
Value of the pair.

Return Value

IInteraction

See Also

IInteractionDomain Interface
SetAttachedData Overload
Genesyslab.Enterprise.Services Namespace


IMonitorService Interface

[image]

Enterprise SDK 8.0 Reference API
IMonitorService Interface
See Also Send Feedback
Statistics service.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IMonitorService
Visual Basic (Declaration)
Public Interface IMonitorService
Visual C++
public interface class IMonitorService

See Also

Genesyslab.Enterprise.Services Namespace


IPreviewDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IPreviewDomain Interface
See Also Send Feedback
Preview Interaction domain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IPreviewDomain
Visual Basic (Declaration)
Public Interface IPreviewDomain
Visual C++
public interface class IPreviewDomain

See Also

Genesyslab.Enterprise.Services Namespace


IPreviewService Interface

[image]

Enterprise SDK 8.0 Reference API
IPreviewService Interface
Members See Also Send Feedback
Manages the Preview Interaction features.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IPreviewService : IPreviewDomain,
    IBrokerPublisher
Visual Basic (Declaration)
Public Interface IPreviewService _
    Implements IPreviewDomain, IBrokerPublisher
Visual C++
public interface class IPreviewService : IPreviewDomain,
    IBrokerPublisher

See Also

IPreviewService Members
Genesyslab.Enterprise.Services Namespace


IPreviewService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPreviewService Members
IPreviewService Interface Methods See Also Send Feedback

The IPreviewService type exposes the following members.

Methods

Name | Description
Accept | Accepts to preview the interaction.
Decline | Declines to preview the interaction.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)

See Also

IPreviewService Interface
Genesyslab.Enterprise.Services Namespace


IPreviewService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPreviewService Methods
IPreviewService Interface See Also Send Feedback

The IPreviewService type exposes the following members.

Methods

Name | Description
Accept | Accepts to preview the interaction.
Decline | Declines to preview the interaction.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)

See Also

IPreviewService Interface
Genesyslab.Enterprise.Services Namespace


Accept Method

[image]

Enterprise SDK 8.0 Reference API
IPreviewService..::.Accept Method
IPreviewService Interface See Also Send Feedback
Accepts to preview the interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Accept(
    IInteraction interaction
)
Visual Basic (Declaration)
Sub Accept ( _
    interaction As IInteraction _
)
Visual C++
void Accept(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Preview Interaction. An interaction in InteractionStateType.Preview state.

See Also

IPreviewService Interface
Genesyslab.Enterprise.Services Namespace


Decline Method

[image]

Enterprise SDK 8.0 Reference API
IPreviewService..::.Decline Method
IPreviewService Interface See Also Send Feedback
Declines to preview the interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
void Decline(
    IInteraction interaction
)
Visual Basic (Declaration)
Sub Decline ( _
    interaction As IInteraction _
)
Visual C++
void Decline(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Preview Interaction. This interaction is in InteractionStateType.Preview state.

See Also

IPreviewService Interface
Genesyslab.Enterprise.Services Namespace


IPSTService Interface

[image]

Enterprise SDK 8.0 Reference API
IPSTService Interface
Members See Also Send Feedback
Provides Possible State Transition (PST) information. The isPossible methods of this service use the loaded stategies and the given objects' data (including its own status and strategies) to determine whether a requested action can be processed. The isCapable methods of this service use the loaded strategies to indicate whether the feature is available regardless of the object status. For instance, if your switch does not provide a mute feature, the isCapable methods return false for the ProtocolAction.MuteOn action.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IPSTService
Visual Basic (Declaration)
Public Interface IPSTService
Visual C++
public interface class IPSTService

Remarks

Make sure that you do not pass deprecated references when calling the methods of this service. On events, ESDK updates core objects (interactions, agents, DNs, and so on.) and provides your application with a new copy of the updated object, but ESDK does not update this copy with further events. As a result, if you pass a reference on an old copy instead of the most recent one to this service, it returns deprecated results instead of the current possible state transitions for this object.

See Also

IPSTService Members
Genesyslab.Enterprise.Services Namespace


IPSTService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPSTService Members
IPSTService Interface Methods See Also Send Feedback

Methods

Name | Description
AreCapable | Overloaded.
ArePossible | Overloaded.
IsCapable | Overloaded.
IsPossible | Overloaded.

See Also

IPSTService Interface
Genesyslab.Enterprise.Services Namespace


IPSTService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPSTService Methods
IPSTService Interface See Also Send Feedback

Methods

Name | Description
AreCapable | Overloaded.
ArePossible | Overloaded.
IsCapable | Overloaded.
IsPossible | Overloaded.

See Also

IPSTService Interface
Genesyslab.Enterprise.Services Namespace


AreCapable Method

[image] [image]

Enterprise SDK 8.0 Reference API
IPSTService..::.AreCapable Method
IPSTService Interface See Also Send Feedback

Overload List

Name | Description
AreCapable(IClientChannel) | Returns the list of actions that the given channel supports as a table of bool values.
AreCapable(String) | Returns the list of actions that the given channel supports as a table of bool values.

See Also

IPSTService Interface
IPSTService Members
Genesyslab.Enterprise.Services Namespace


AreCapable Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.AreCapable Method (IClientChannel)
IPSTService Interface See Also Send Feedback
Returns the list of actions that the given channel supports as a table of bool values.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool[] AreCapable(
    IClientChannel channel
)
Visual Basic (Declaration)
Function AreCapable ( _
    channel As IClientChannel _
) As Boolean()
Visual C++
array<bool>^ AreCapable(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel object.

Return Value

null in case of error, or an array of bool values; true for each action that the channel supports, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
AreCapable Overload
Genesyslab.Enterprise.Services Namespace


AreCapable Method (String)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.AreCapable Method (String)
IPSTService Interface See Also Send Feedback
Returns the list of actions that the given channel supports as a table of bool values.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool[] AreCapable(
    string ID
)
Visual Basic (Declaration)
Function AreCapable ( _
    ID As String _
) As Boolean()
Visual C++
array<bool>^ AreCapable(
    String^ ID
)

Parameters

ID
Type: System..::.String
The channel ID.

Return Value

null in case of error, or an array of bool values; true for each action that the channel supports, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
AreCapable Overload
Genesyslab.Enterprise.Services Namespace


ArePossible Method

[image] [image]

Enterprise SDK 8.0 Reference API
IPSTService..::.ArePossible Method
IPSTService Interface See Also Send Feedback

Overload List

Name | Description
ArePossible(IDevice) | Returns the list of actions that your application can request for the given device as a table of bool values.
ArePossible(IInteraction) | Returns the list of actions that your application can request for the given interaction as a table of bool values.

See Also

IPSTService Interface
IPSTService Members
Genesyslab.Enterprise.Services Namespace


ArePossible Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.ArePossible Method (IDevice)
IPSTService Interface See Also Send Feedback
Returns the list of actions that your application can request for the given device as a table of bool values.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool[] ArePossible(
    IDevice device
)
Visual Basic (Declaration)
Function ArePossible ( _
    device As IDevice _
) As Boolean()
Visual C++
array<bool>^ ArePossible(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The device object.

Return Value

null in case of error, or an array of bool values; true for each permitted action, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
ArePossible Overload
Genesyslab.Enterprise.Services Namespace


ArePossible Method (IInteraction)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.ArePossible Method (IInteraction)
IPSTService Interface See Also Send Feedback
Returns the list of actions that your application can request for the given interaction as a table of bool values.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool[] ArePossible(
    IInteraction interaction
)
Visual Basic (Declaration)
Function ArePossible ( _
    interaction As IInteraction _
) As Boolean()
Visual C++
array<bool>^ ArePossible(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
The interaction object.

Return Value

null in case of error, or an array of bool values, true for each permitted action, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
ArePossible Overload
Genesyslab.Enterprise.Services Namespace


IsCapable Method

[image] [image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsCapable Method
IPSTService Interface See Also Send Feedback

Overload List

Name | Description
IsCapable(IClientChannel, ProtocolAction) | Returns true if the channel is capable to perform this action.
IsCapable(String, ProtocolAction) | Returns true if the channel is capable to perform this action.

See Also

IPSTService Interface
IPSTService Members
Genesyslab.Enterprise.Services Namespace


IsCapable Method (IClientChannel, ProtocolAction)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsCapable Method (IClientChannel, ProtocolAction)
IPSTService Interface See Also Send Feedback
Returns true if the channel is capable to perform this action.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsCapable(
    IClientChannel channel,
    ProtocolAction action
)
Visual Basic (Declaration)
Function IsCapable ( _
    channel As IClientChannel, _
    action As ProtocolAction _
) As Boolean
Visual C++
bool IsCapable(
    IClientChannel^ channel,
    ProtocolAction action
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel object.
action
Type: Genesyslab.Enterprise.Services..::.ProtocolAction
The action.

Return Value

true if the channel is capable of the action, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
IsCapable Overload
Genesyslab.Enterprise.Services Namespace


IsCapable Method (String, ProtocolAction)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsCapable Method (String, ProtocolAction)
IPSTService Interface See Also Send Feedback
Returns true if the channel is capable to perform this action.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsCapable(
    string ID,
    ProtocolAction action
)
Visual Basic (Declaration)
Function IsCapable ( _
    ID As String, _
    action As ProtocolAction _
) As Boolean
Visual C++
bool IsCapable(
    String^ ID,
    ProtocolAction action
)

Parameters

ID
Type: System..::.String
The channel ID.
action
Type: Genesyslab.Enterprise.Services..::.ProtocolAction
the action

Return Value

true if the channel is capable of the action, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
IsCapable Overload
Genesyslab.Enterprise.Services Namespace


IsPossible Method

[image] [image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsPossible Method
IPSTService Interface See Also Send Feedback

Overload List

Name | Description
IsPossible(IDevice, DeviceAction) | Returns true if the given action is available on the given device.
IsPossible(IInteraction, ProtocolAction) | Returns true if you can process the given protocol action on the given interaction.
IsPossible(IDevice, AgentAction, WorkMode) | Returns true if the given action is available on the given device with the specified mode
IsPossible(IDevice, ForwardAction, ForwardModeType) | Returns true if the given action is available on the given device with the specified mode
IsPossible(IInteraction, AgentAction, WorkMode) | Returns true if the given action is available on the given device with the specified mode
IsPossible(IInteraction, ForwardAction, ForwardModeType) | Returns true if the given action is available on the given device with the specified mode

See Also

IPSTService Interface
IPSTService Members
Genesyslab.Enterprise.Services Namespace


IsPossible Method (IDevice, DeviceAction)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsPossible Method (IDevice, DeviceAction)
IPSTService Interface See Also Send Feedback
Returns true if the given action is available on the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsPossible(
    IDevice device,
    DeviceAction action
)
Visual Basic (Declaration)
Function IsPossible ( _
    device As IDevice, _
    action As DeviceAction _
) As Boolean
Visual C++
bool IsPossible(
    IDevice^ device,
    DeviceAction action
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The device object.
action
Type: Genesyslab.Enterprise.Services..::.DeviceAction
The action.

Return Value

true if the action can be invoked according to the device status, false otherwise

Remarks

See the remark section in this service description

Remarks

See the remark section in this service description

See Also

IPSTService Interface
IsPossible Overload
Genesyslab.Enterprise.Services Namespace


IsPossible Method (IInteraction, ProtocolAction)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsPossible Method (IInteraction, ProtocolAction)
IPSTService Interface See Also Send Feedback
Returns true if you can process the given protocol action on the given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsPossible(
    IInteraction interaction,
    ProtocolAction action
)
Visual Basic (Declaration)
Function IsPossible ( _
    interaction As IInteraction, _
    action As ProtocolAction _
) As Boolean
Visual C++
bool IsPossible(
    IInteraction^ interaction,
    ProtocolAction action
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
The interaction object.
action
Type: Genesyslab.Enterprise.Services..::.ProtocolAction
The requested action.

Return Value

true if the action can be invoked according to the interaction status, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
IsPossible Overload
Genesyslab.Enterprise.Services Namespace


IsPossible Method (IDevice, AgentAction, WorkMode)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsPossible Method (IDevice, AgentAction, WorkMode)
IPSTService Interface See Also Send Feedback
Returns true if the given action is available on the given device with the specified mode

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsPossible(
    IDevice device,
    AgentAction action,
    WorkMode mode
)
Visual Basic (Declaration)
Function IsPossible ( _
    device As IDevice, _
    action As AgentAction, _
    mode As WorkMode _
) As Boolean
Visual C++
bool IsPossible(
    IDevice^ device,
    AgentAction action,
    WorkMode mode
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.AgentAction,Genesyslab.Enterprise.Model.Identity.WorkMode)"]

action
Type: Genesyslab.Enterprise.Services..::.AgentAction

[Missing <param name="action"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.AgentAction,Genesyslab.Enterprise.Model.Identity.WorkMode)"]

mode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="mode"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.AgentAction,Genesyslab.Enterprise.Model.Identity.WorkMode)"]

Return Value

bool

See Also

IPSTService Interface
IsPossible Overload
Genesyslab.Enterprise.Services Namespace


IsPossible Method (IDevice, ForwardAction, ForwardModeType)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsPossible Method (IDevice, ForwardAction, ForwardModeType)
IPSTService Interface See Also Send Feedback
Returns true if the given action is available on the given device with the specified mode

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsPossible(
    IDevice device,
    ForwardAction action,
    ForwardModeType mode
)
Visual Basic (Declaration)
Function IsPossible ( _
    device As IDevice, _
    action As ForwardAction, _
    mode As ForwardModeType _
) As Boolean
Visual C++
bool IsPossible(
    IDevice^ device,
    ForwardAction action,
    ForwardModeType mode
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.ForwardAction,Genesyslab.Enterprise.Model.Device.ForwardModeType)"]

action
Type: Genesyslab.Enterprise.Services..::.ForwardAction

[Missing <param name="action"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.ForwardAction,Genesyslab.Enterprise.Model.Device.ForwardModeType)"]

mode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="mode"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.ForwardAction,Genesyslab.Enterprise.Model.Device.ForwardModeType)"]

Return Value

bool

See Also

IPSTService Interface
IsPossible Overload
Genesyslab.Enterprise.Services Namespace


IsPossible Method (IInteraction, AgentAction, WorkMode)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsPossible Method (IInteraction, AgentAction, WorkMode)
IPSTService Interface See Also Send Feedback
Returns true if the given action is available on the given device with the specified mode

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsPossible(
    IInteraction interaction,
    AgentAction action,
    WorkMode mode
)
Visual Basic (Declaration)
Function IsPossible ( _
    interaction As IInteraction, _
    action As AgentAction, _
    mode As WorkMode _
) As Boolean
Visual C++
bool IsPossible(
    IInteraction^ interaction,
    AgentAction action,
    WorkMode mode
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Services.AgentAction,Genesyslab.Enterprise.Model.Identity.WorkMode)"]

action
Type: Genesyslab.Enterprise.Services..::.AgentAction

[Missing <param name="action"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Services.AgentAction,Genesyslab.Enterprise.Model.Identity.WorkMode)"]

mode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="mode"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Services.AgentAction,Genesyslab.Enterprise.Model.Identity.WorkMode)"]

Return Value

bool

See Also

IPSTService Interface
IsPossible Overload
Genesyslab.Enterprise.Services Namespace


IsPossible Method (IInteraction, ForwardAction, ForwardModeType)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsPossible Method (IInteraction, ForwardAction, ForwardModeType)
IPSTService Interface See Also Send Feedback
Returns true if the given action is available on the given device with the specified mode

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsPossible(
    IInteraction interaction,
    ForwardAction action,
    ForwardModeType mode
)
Visual Basic (Declaration)
Function IsPossible ( _
    interaction As IInteraction, _
    action As ForwardAction, _
    mode As ForwardModeType _
) As Boolean
Visual C++
bool IsPossible(
    IInteraction^ interaction,
    ForwardAction action,
    ForwardModeType mode
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Services.ForwardAction,Genesyslab.Enterprise.Model.Device.ForwardModeType)"]

action
Type: Genesyslab.Enterprise.Services..::.ForwardAction

[Missing <param name="action"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Services.ForwardAction,Genesyslab.Enterprise.Model.Device.ForwardModeType)"]

mode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="mode"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Services.ForwardAction,Genesyslab.Enterprise.Model.Device.ForwardModeType)"]

Return Value

bool

See Also

IPSTService Interface
IsPossible Overload
Genesyslab.Enterprise.Services Namespace


ISupervisorDomain Interface

[image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain Interface
Members See Also Send Feedback
Actions of the supervisor domain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface ISupervisorDomain
Visual Basic (Declaration)
Public Interface ISupervisorDomain
Visual C++
public interface class ISupervisorDomain

See Also

ISupervisorDomain Members
Genesyslab.Enterprise.Services Namespace


ISupervisorDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain Members
ISupervisorDomain Interface Methods See Also Send Feedback

Methods

Name | Description
IsMonitored | Overloaded.

See Also

ISupervisorDomain Interface
Genesyslab.Enterprise.Services Namespace


ISupervisorDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain Methods
ISupervisorDomain Interface See Also Send Feedback

Methods

Name | Description
IsMonitored | Overloaded.

See Also

ISupervisorDomain Interface
Genesyslab.Enterprise.Services Namespace


IsMonitored Method

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain..::.IsMonitored Method
ISupervisorDomain Interface See Also Send Feedback

Overload List

Name | Description
IsMonitored(IDevice) | Returns true if your application monitors the given device in supervisor mode.
IsMonitored(IIdentity) | Returns true if your application monitors the given identity in supervisor mode.
IsMonitored(IInteraction) | Returns true if your application monitors the given interaction in supervisor mode.

See Also

ISupervisorDomain Interface
ISupervisorDomain Members
Genesyslab.Enterprise.Services Namespace


IsMonitored Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain..::.IsMonitored Method (IDevice)
ISupervisorDomain Interface See Also Send Feedback
Returns true if your application monitors the given device in supervisor mode.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsMonitored(
    IDevice device
)
Visual Basic (Declaration)
Function IsMonitored ( _
    device As IDevice _
) As Boolean
Visual C++
bool IsMonitored(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device instance to evaluate.

Return Value

true, if the device is monitored.

See Also

ISupervisorDomain Interface
IsMonitored Overload
Genesyslab.Enterprise.Services Namespace


IsMonitored Method (IIdentity)

[image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain..::.IsMonitored Method (IIdentity)
ISupervisorDomain Interface See Also Send Feedback
Returns true if your application monitors the given identity in supervisor mode.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsMonitored(
    IIdentity identity
)
Visual Basic (Declaration)
Function IsMonitored ( _
    identity As IIdentity _
) As Boolean
Visual C++
bool IsMonitored(
    IIdentity^ identity
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Identity instance

Return Value

true, if the given interaction is monitored.

See Also

ISupervisorDomain Interface
IsMonitored Overload
Genesyslab.Enterprise.Services Namespace


IsMonitored Method (IInteraction)

[image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain..::.IsMonitored Method (IInteraction)
ISupervisorDomain Interface See Also Send Feedback
Returns true if your application monitors the given interaction in supervisor mode.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
bool IsMonitored(
    IInteraction interaction
)
Visual Basic (Declaration)
Function IsMonitored ( _
    interaction As IInteraction _
) As Boolean
Visual C++
bool IsMonitored(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction instance

Return Value

true, if the given interaction is monitored.

See Also

ISupervisorDomain Interface
IsMonitored Overload
Genesyslab.Enterprise.Services Namespace


ISupervisorInfo Interface

[image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo Interface
Members See Also Send Feedback
Describes the supervisor information of the object identified by the Id member. The MonitorObject member identifies the type of the monitored object (possible types are enumerated in SupervisorObjectType: agent, interaction, device, and so on.)

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface ISupervisorInfo : ISerializable
Visual Basic (Declaration)
Public Interface ISupervisorInfo _
    Implements ISerializable
Visual C++
public interface class ISupervisorInfo : ISerializable

See Also

ISupervisorInfo Members
Genesyslab.Enterprise.Services Namespace


ISupervisorInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo Members
ISupervisorInfo Interface Methods Properties See Also Send Feedback

The ISupervisorInfo type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

Properties

Name | Description
Id | Returns the ID of the object monitored by the supervisor.
Media | Returns the object's media type.
MonitorObject | Returns the type of object which is monitored. (For example, agent, interaction, device, and so on).
MonitorState | Returns the monitoring status for the associated object (On, Off).

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


ISupervisorInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo Methods
ISupervisorInfo Interface See Also Send Feedback

The ISupervisorInfo type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


ISupervisorInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo Properties
ISupervisorInfo Interface See Also Send Feedback

The ISupervisorInfo type exposes the following members.

Properties

Name | Description
Id | Returns the ID of the object monitored by the supervisor.
Media | Returns the object's media type.
MonitorObject | Returns the type of object which is monitored. (For example, agent, interaction, device, and so on).
MonitorState | Returns the monitoring status for the associated object (On, Off).

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


Id Property

[image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo..::.Id Property
ISupervisorInfo Interface See Also Send Feedback
Returns the ID of the object monitored by the supervisor.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string Id { get; }
Visual Basic (Declaration)
ReadOnly Property Id As String
Visual C++
property String^ Id {
    String^ get ();
}

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


Media Property

[image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo..::.Media Property
ISupervisorInfo Interface See Also Send Feedback
Returns the object's media type.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
MediaType Media { get; }
Visual Basic (Declaration)
ReadOnly Property Media As MediaType
Visual C++
property MediaType Media {
    MediaType get ();
}

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


MonitorObject Property

[image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo..::.MonitorObject Property
ISupervisorInfo Interface See Also Send Feedback
Returns the type of object which is monitored. (For example, agent, interaction, device, and so on).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
SupervisorObjectType MonitorObject { get; }
Visual Basic (Declaration)
ReadOnly Property MonitorObject As SupervisorObjectType
Visual C++
property SupervisorObjectType MonitorObject {
    SupervisorObjectType get ();
}

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


MonitorState Property

[image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo..::.MonitorState Property
ISupervisorInfo Interface See Also Send Feedback
Returns the monitoring status for the associated object (On, Off).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
SupervisorStateType MonitorState { get; }
Visual Basic (Declaration)
ReadOnly Property MonitorState As SupervisorStateType
Visual C++
property SupervisorStateType MonitorState {
    SupervisorStateType get ();
}

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


ISupervisorService Interface

[image]

Enterprise SDK 8.0 Reference API
ISupervisorService Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.ISupervisorService"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface ISupervisorService : IEventManager<ISupervisorService, IEnvelope<ISupervisorInfo>>,
    ISupervisorDomain, IBrokerSubscriber<IEnvelope<ISupervisorInfo>>, IBrokerPublisher,
    ISubscribeable<IEnvelope<IRequest>>
Visual Basic (Declaration)
Public Interface ISupervisorService _
    Implements IEventManager(Of ISupervisorService, IEnvelope(Of ISupervisorInfo)),  _
    ISupervisorDomain, IBrokerSubscriber(Of IEnvelope(Of ISupervisorInfo)), IBrokerPublisher,  _
    ISubscribeable(Of IEnvelope(Of IRequest))
Visual C++
public interface class ISupervisorService : IEventManager<ISupervisorService^, IEnvelope<ISupervisorInfo^>^>,
    ISupervisorDomain, IBrokerSubscriber<IEnvelope<ISupervisorInfo^>^>, IBrokerPublisher,
    ISubscribeable<IEnvelope<IRequest^>^>

See Also

ISupervisorService Members
Genesyslab.Enterprise.Services Namespace


ISupervisorService Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorService Members
ISupervisorService Interface Methods Properties See Also Send Feedback

The ISupervisorService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not report events. Your application needs to call the [!:StartMonitor] method. (Inherited from IEventManager<(Of <(D, T>)>).)
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsMonitored | Overloaded.
ListFilter<(Of <(T>)>) | Lists the filters registered for the given supervision instance.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for the given supervision instance.
RemoveChannel | Removes the given channel from the monitoring list. Your application no longer receives events for this channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for the given supervision instance.

Properties

Name | Description
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription | Gets the subscriber object of type T. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored. (Inherited from ISubscribeable<(Of <(T>)>).)

See Also

ISupervisorService Interface
Genesyslab.Enterprise.Services Namespace


ISupervisorService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorService Methods
ISupervisorService Interface See Also Send Feedback

The ISupervisorService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not report events. Your application needs to call the [!:StartMonitor] method. (Inherited from IEventManager<(Of <(D, T>)>).)
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsMonitored | Overloaded.
ListFilter<(Of <(T>)>) | Lists the filters registered for the given supervision instance.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for the given supervision instance.
RemoveChannel | Removes the given channel from the monitoring list. Your application no longer receives events for this channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for the given supervision instance.

See Also

ISupervisorService Interface
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorService..::.GetList Method
ISupervisorService Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

ISupervisorService Interface
ISupervisorService Members
Genesyslab.Enterprise.Services Namespace


IsMonitored Method

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorService..::.IsMonitored Method
ISupervisorService Interface See Also Send Feedback

Overload List

Name | Description
IsMonitored(IDevice) | Returns true if your application monitors the given device in supervisor mode. (Inherited from ISupervisorDomain.)
IsMonitored(IIdentity) | Returns true if your application monitors the given identity in supervisor mode. (Inherited from ISupervisorDomain.)
IsMonitored(IInteraction) | Returns true if your application monitors the given interaction in supervisor mode. (Inherited from ISupervisorDomain.)

See Also

ISupervisorService Interface
ISupervisorService Members
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
ISupervisorService..::.ListFilter<(Of <(T>)>) Method
ISupervisorService Interface See Also Send Feedback
Lists the filters registered for the given supervision instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnumerable<T> ListFilter<T>(
    ISupervisorInfo context
)
Visual Basic (Declaration)
Function ListFilter(Of T) ( _
    context As ISupervisorInfo _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ListFilter(
    ISupervisorInfo^ context
)

Parameters

context
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo
Target interaction object.

Type Parameters

T
Type of data handled in filter object.

Return Value

IEnumerable<T>

See Also

ISupervisorService Interface
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorService..::.RegisterEvents Method
ISupervisorService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

ISupervisorService Interface
ISupervisorService Members
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
ISupervisorService..::.RegisterFilter<(Of <(T>)>) Method
ISupervisorService Interface See Also Send Feedback
Registers a filter for the given supervision instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ISupervisorService RegisterFilter<T>(
    ISupervisorInfo context,
    T filter
)
Visual Basic (Declaration)
Function RegisterFilter(Of T) ( _
    context As ISupervisorInfo, _
    filter As T _
) As ISupervisorService
Visual C++
generic<typename T>
ISupervisorService^ RegisterFilter(
    ISupervisorInfo^ context,
    T filter
)

Parameters

context
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo
ISupervisorInfo.
filter
Type: T
Filter instance.

Type Parameters

T
Filter type.

Return Value

ISupervisorService

See Also

ISupervisorService Interface
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
ISupervisorService..::.UnRegisterFilter<(Of <(T>)>) Method
ISupervisorService Interface See Also Send Feedback
Unregisters a filter for the given supervision instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
ISupervisorService UnRegisterFilter<T>(
    ISupervisorInfo context,
    T filter
)
Visual Basic (Declaration)
Function UnRegisterFilter(Of T) ( _
    context As ISupervisorInfo, _
    filter As T _
) As ISupervisorService
Visual C++
generic<typename T>
ISupervisorService^ UnRegisterFilter(
    ISupervisorInfo^ context,
    T filter
)

Parameters

context
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo
ISupervisorInfo
filter
Type: T
Filter instance

Type Parameters

T
Type of data for the filter instance.

Return Value

ISupervisorService

See Also

ISupervisorService Interface
Genesyslab.Enterprise.Services Namespace


ISupervisorService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorService Properties
ISupervisorService Interface See Also Send Feedback

The ISupervisorService type exposes the following members.

Properties

Name | Description
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription | Gets the subscriber object of type T. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored. (Inherited from ISubscribeable<(Of <(T>)>).)

See Also

ISupervisorService Interface
Genesyslab.Enterprise.Services Namespace


IVoiceService Interface

[image]

Enterprise SDK 8.0 Reference API
IVoiceService Interface
Members Example See Also Send Feedback
Manages callback and filters related to interaction events.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IVoiceService : IInteractionDomain,
    IEventManager<IVoiceService, IEnvelope<IInteraction>>, IBrokerSubscriber<IEnvelope<IInteraction>>,
    IBrokerPublisher, ISubscribeable<IEnvelope<IRequest>>, IPersistable<IInteraction>
Visual Basic (Declaration)
Public Interface IVoiceService _
    Implements IInteractionDomain, IEventManager(Of IVoiceService, IEnvelope(Of IInteraction)),  _
    IBrokerSubscriber(Of IEnvelope(Of IInteraction)), IBrokerPublisher, ISubscribeable(Of IEnvelope(Of IRequest)),  _
    IPersistable(Of IInteraction)
Visual C++
public interface class IVoiceService : IInteractionDomain,
    IEventManager<IVoiceService^, IEnvelope<IInteraction^>^>, IBrokerSubscriber<IEnvelope<IInteraction^>^>,
    IBrokerPublisher, ISubscribeable<IEnvelope<IRequest^>^>, IPersistable<IInteraction^>

Examples

The following code sample registers a handler for a given interaction.
CopyC#
EsdkService = new EnterpriseServiceProvider(new UnityContainer(), typeof(GlobalThreadLifeTimeManager));
IInteractionService interactionService = EsdkService.Resolve<IInteractionService>("voiceService");
interactionService.RegisterEvents<IEnvelope<IInteraction>>(channel, new Action<IEnvelope<IInteraction>>(InteractionEvent));
 To make this snippet work, you must also declare an InteractionEvent method.
CopyC#
//Filter sample and declaration of the handler
[EnterpriseInteractionEvent("TServerSIPChannel")]
     protected void InteractionEvent(IEnvelope<IInteraction> tsp)
     {
     }

See Also

IVoiceService Members
Genesyslab.Enterprise.Services Namespace


IVoiceService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService Members
IVoiceService Interface Methods Properties See Also Send Feedback

The IVoiceService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not report events. Your application needs to call the [!:StartMonitor] method. (Inherited from IEventManager<(Of <(D, T>)>).)
CreateInteraction | Overloaded.
DeleteInteraction | Deletes the given interaction. (Inherited from IInteractionDomain.)
DeleteInteractions | Delete all interactions (Inherited from IInteractionDomain.)
GetAttachedData | Returns the user defined attached data of this interaction. (Inherited from IInteractionDomain.)
GetInteraction | Overloaded.
GetInteractions | Overloaded.
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
ListFilter<(Of <(T>)>) | Lists the filters registered for the given interaction instance.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for a given interaction.
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically. (Inherited from IInteractionDomain.)
RemoveChannel | Removes the given channel from the monitoring list. Your application no longer receives events for this channel. (Inherited from IEventManager<(Of <(D, T>)>).)
Save | Overloaded.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically. (Inherited from IInteractionDomain.)
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers. (Inherited from IInteractionDomain.)
SetAttachedData | Overloaded.
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for a given interaction.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the subscriber object of type T.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IVoiceService Interface
Genesyslab.Enterprise.Services Namespace


IVoiceService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService Methods
IVoiceService Interface See Also Send Feedback

The IVoiceService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not report events. Your application needs to call the [!:StartMonitor] method. (Inherited from IEventManager<(Of <(D, T>)>).)
CreateInteraction | Overloaded.
DeleteInteraction | Deletes the given interaction. (Inherited from IInteractionDomain.)
DeleteInteractions | Delete all interactions (Inherited from IInteractionDomain.)
GetAttachedData | Returns the user defined attached data of this interaction. (Inherited from IInteractionDomain.)
GetInteraction | Overloaded.
GetInteractions | Overloaded.
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
ListFilter<(Of <(T>)>) | Lists the filters registered for the given interaction instance.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for a given interaction.
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically. (Inherited from IInteractionDomain.)
RemoveChannel | Removes the given channel from the monitoring list. Your application no longer receives events for this channel. (Inherited from IEventManager<(Of <(D, T>)>).)
Save | Overloaded.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically. (Inherited from IInteractionDomain.)
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers. (Inherited from IInteractionDomain.)
SetAttachedData | Overloaded.
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for a given interaction.

See Also

IVoiceService Interface
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.CreateInteraction Method
IVoiceService Interface See Also Send Feedback

Overload List

Name | Description
CreateInteraction(IEnumerable<(Of <(IDevice>)>)) | Creates a new interaction associated with a set of devices and a unique ID. (Inherited from IInteractionDomain.)
CreateInteraction(IInteraction, IEnumerable<(Of <(IDevice>)>)) | Uses an existing interaction to create a new interaction associated with a set of devices. (Inherited from IInteractionDomain.)

See Also

IVoiceService Interface
IVoiceService Members
Genesyslab.Enterprise.Services Namespace


GetInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.GetInteraction Method
IVoiceService Interface See Also Send Feedback

Overload List

Name | Description
GetInteraction(IAgent, String) | Retrieves the interaction associated with an agent from its unique Id, or null if no interaction exists. (Inherited from IInteractionDomain.)
GetInteraction(IDN, String) | Retrieves the interaction associated with a device from its unique Id, or null if no interaction exists. (Inherited from IInteractionDomain.)

See Also

IVoiceService Interface
IVoiceService Members
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.GetInteractions Method
IVoiceService Interface See Also Send Feedback

Overload List

Name | Description
GetInteractions()()() | Returns all the existing interactions. (Inherited from IInteractionDomain.)
GetInteractions(IAgent) | Retrieves the interactions associated with an Agent, or null if no interaction exists. (Inherited from IInteractionDomain.)
GetInteractions(IDN) | Retrieves the interactions associated with a device, or null if no interaction exists. (Inherited from IInteractionDomain.)
GetInteractions(String) | Returns the existing interaction(s) associated with an interaction ID. (Inherited from IInteractionDomain.)

See Also

IVoiceService Interface
IVoiceService Members
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.GetList Method
IVoiceService Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IVoiceService Interface
IVoiceService Members
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.ListFilter<(Of <(T>)>) Method
IVoiceService Interface See Also Send Feedback
Lists the filters registered for the given interaction instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IEnumerable<T> ListFilter<T>(
    IInteraction interaction
)
Visual Basic (Declaration)
Function ListFilter(Of T) ( _
    interaction As IInteraction _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ListFilter(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Target interaction object.

Type Parameters

T
Type of data handled in filter object

Return Value

Filters.

See Also

IVoiceService Interface
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.RegisterEvents Method
IVoiceService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

IVoiceService Interface
IVoiceService Members
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.RegisterFilter<(Of <(T>)>) Method
IVoiceService Interface See Also Send Feedback
Registers a filter for a given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IVoiceService RegisterFilter<T>(
    IInteraction interaction,
    T filter
)
Visual Basic (Declaration)
Function RegisterFilter(Of T) ( _
    interaction As IInteraction, _
    filter As T _
) As IVoiceService
Visual C++
generic<typename T>
IVoiceService^ RegisterFilter(
    IInteraction^ interaction,
    T filter
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction.
filter
Type: T
Filter instance.

Type Parameters

T
Filter type.

Return Value

IInteractionService

See Also

IVoiceService Interface
Genesyslab.Enterprise.Services Namespace


Save Method

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.Save Method
IVoiceService Interface See Also Send Feedback

Overload List

Name | Description
Save(T) | Saves the object into the Contact Server. (Inherited from IPersistable<(Of <(T>)>).)
Save(T, IStrategy) | Save data by executing the specified strategy (Inherited from IPersistable<(Of <(T>)>).)

See Also

IVoiceService Interface
IVoiceService Members
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.SetAttachedData Method
IVoiceService Interface See Also Send Feedback

Overload List

Name | Description
SetAttachedData(IInteraction, KeyValueCollection) | Attaches several key-value pairs at once. The update in the back-end server is performed automatically. (Inherited from IInteractionDomain.)
SetAttachedData(IInteraction, String, Object) | Sets the user defined data as attached key-value pair. The update in the back-end server is performed automatically. (Inherited from IInteractionDomain.)

See Also

IVoiceService Interface
IVoiceService Members
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.UnRegisterFilter<(Of <(T>)>) Method
IVoiceService Interface See Also Send Feedback
Unregisters a filter for a given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IVoiceService UnRegisterFilter<T>(
    IInteraction interaction,
    T filter
)
Visual Basic (Declaration)
Function UnRegisterFilter(Of T) ( _
    interaction As IInteraction, _
    filter As T _
) As IVoiceService
Visual C++
generic<typename T>
IVoiceService^ UnRegisterFilter(
    IInteraction^ interaction,
    T filter
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction.
filter
Type: T
Filter instance.

Type Parameters

T
Type of data for the filter instance.

Return Value

IInteractionService

See Also

IVoiceService Interface
Genesyslab.Enterprise.Services Namespace


IVoiceService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService Properties
IVoiceService Interface See Also Send Feedback

The IVoiceService type exposes the following members.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the subscriber object of type T.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IVoiceService Interface
Genesyslab.Enterprise.Services Namespace


MessageContentType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MessageContentType Enumeration
See Also Send Feedback
Enumerates the content type of the message.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum MessageContentType
Visual Basic (Declaration)
Public Enumeration MessageContentType
Visual C++
public enum class MessageContentType

Members

Member name | Description
TextPlain | Textual data; Defined in RFC 2046 and RFC 3676. text/plain
TextHTML | Content HTML; Defined in RFC 2854. text/html

See Also

Genesyslab.Enterprise.Services Namespace


MonitorMethodDelegate Delegate

[image]

Enterprise SDK 8.0 Reference API
MonitorMethodDelegate Delegate
See Also Send Feedback
Listener for Statistics events. This is the callback for subscribed statistics events.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public delegate void MonitorMethodDelegate(
    IEnvelope<IMonitorEventStatus> msg
)
Visual Basic (Declaration)
Public Delegate Sub MonitorMethodDelegate ( _
    msg As IEnvelope(Of IMonitorEventStatus) _
)
Visual C++
public delegate void MonitorMethodDelegate(
    IEnvelope<IMonitorEventStatus^>^ msg
)

Parameters

msg
Type: Genesyslab.Enterprise.Model.Envelope..::.IEnvelope <(Of <( IMonitorEventStatus >)>)

See Also

Genesyslab.Enterprise.Services Namespace


MonitorNotificationMode Enumeration

[image]

Enterprise SDK 8.0 Reference API
MonitorNotificationMode Enumeration
See Also Send Feedback
Statistics Notification mode. Event notification mode for subscribed statistics.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum MonitorNotificationMode
Visual Basic (Declaration)
Public Enumeration MonitorNotificationMode
Visual C++
public enum class MonitorNotificationMode

Members

Member name | Description
ChangesBased | Based on statistics changes.
TimeBased | Based on time.

See Also

Genesyslab.Enterprise.Services Namespace


MonitorObjectType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MonitorObjectType Enumeration
See Also Send Feedback
Enumerate for statistics object type. Type of the statistics objects that can be monitored.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum MonitorObjectType
Visual Basic (Declaration)
Public Enumeration MonitorObjectType
Visual C++
public enum class MonitorObjectType

Members

Member name | Description
Agent | Gets statistics of Agent type.
AgentGroup | Gets statistics of AgentGroup type.

See Also

Genesyslab.Enterprise.Services Namespace


ProtocolAction Enumeration

[image]

Enterprise SDK 8.0 Reference API
ProtocolAction Enumeration
See Also Send Feedback
Enumerates the actions that are possible on this interaction. To be used in the methods of IsPossible.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum ProtocolAction
Visual Basic (Declaration)
Public Enumeration ProtocolAction
Visual C++
public enum class ProtocolAction

Members

Member name | Description
Alternate | Places the active call on hold and connects the call that was held.
AnswerCall | Answers the ringing call.
AttachUserData | Attach User Data to the current call.
CancelForward | Sets the Forwarding feature to Off.
CompleteConference | Completes a conference previously initiated.
CompleteTransfer | Completes the two-step transfer.
InitConference | Initiates a conference. Holds the current call and dials a consultation call with another agent.
DeleteFromConference | Deletes a party from the conference.
DeleteUserData | Delete User Data from the current call.
Hold | Places the call on hold.
InitTransfer | Initiates a two-step transfer. Holds the current call and dials a consultation call with another agent.
ListenDisconnect | Sets the Deaf mode for the specified party.
ListenReconnect | Cancels Deaf mode for the specified party.
Login | Login this device.
Logout | Logout this device.
MakeCall | Makes a regular call.
MuteOff | Cancels the Mute mode for the specified party.
MuteOn | Sets the Mute mode for the specified party.
MuteTransfer | Transfers this call in one blind step to the destination.
NotReady | Sets not ready this device.
Ready | Sets this device ready.
Reconnect | Releases the active call and retrieves the previously held call.
RedirectCall | Redirects the call, without an answer.
ReleaseCall | Releases the call.
Retrieve | Retrieves the call placed on hold.
SendDTMF | Sends digits to an Interactive Voice Response (IVR) system.
SetDNDOff | Deactivates the Do-Not-Disturb (DND) mode.
SetDNDOn | Activates the Do-Not-Disturb (DND) mode.
SetForward | Sets the Forwarding feature to On.
SingleStepConference | Adds a new party to an existing call and creates a conference.
SingleStepTransfer | Transfers this call in one step to the destination.
UpdateUserData | Update User Data of the current call.

See Also

Genesyslab.Enterprise.Services Namespace


StatisticsItem Class

[image]

Enterprise SDK 8.0 Reference API
StatisticsItem Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.StatisticsItem"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public class StatisticsItem
Visual Basic (Declaration)
Public Class StatisticsItem
Visual C++
public ref class StatisticsItem

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Services..::.StatisticsItem

See Also

StatisticsItem Members
Genesyslab.Enterprise.Services Namespace


StatisticsItem Members

[image] [image]

Enterprise SDK 8.0 Reference API
StatisticsItem Members
StatisticsItem Class Constructors Methods Properties See Also Send Feedback

The StatisticsItem type exposes the following members.

Constructors

Name | Description
StatisticsItem |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Channel |
Listener |
NotificationMode |
NotificationValue |
ObjectId |
ObjectType |
Request |
StatisticID |
TenantName |
TenantPassword |

See Also

StatisticsItem Class
Genesyslab.Enterprise.Services Namespace


StatisticsItem Constructor

[image]

Enterprise SDK 8.0 Reference API
StatisticsItem Constructor
StatisticsItem Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.StatisticsItem.#ctor"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public StatisticsItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StatisticsItem()

See Also

StatisticsItem Class
Genesyslab.Enterprise.Services Namespace


StatisticsItem Methods

[image] [image]

Enterprise SDK 8.0 Reference API
StatisticsItem Methods
StatisticsItem Class See Also Send Feedback

The StatisticsItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StatisticsItem Class
Genesyslab.Enterprise.Services Namespace


StatisticsItem Properties

[image] [image]

Enterprise SDK 8.0 Reference API
StatisticsItem Properties
StatisticsItem Class See Also Send Feedback

The StatisticsItem type exposes the following members.

Properties

Name | Description
Channel |
Listener |
NotificationMode |
NotificationValue |
ObjectId |
ObjectType |
Request |
StatisticID |
TenantName |
TenantPassword |

See Also

StatisticsItem Class
Genesyslab.Enterprise.Services Namespace


Channel Property

[image]

Enterprise SDK 8.0 Reference API
StatisticsItem..::.Channel Property
StatisticsItem Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.StatisticsItem.Channel"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IClientChannel Channel { get; set; }
Visual Basic (Declaration)
Public Property Channel As IClientChannel
Visual C++
public:
property IClientChannel^ Channel {
    IClientChannel^ get ();
    void set (IClientChannel^ value);
}

See Also

StatisticsItem Class
Genesyslab.Enterprise.Services Namespace


Listener Property

[image]

Enterprise SDK 8.0 Reference API
StatisticsItem..::.Listener Property
StatisticsItem Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.StatisticsItem.Listener"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public MonitorMethodDelegate Listener { get; set; }
Visual Basic (Declaration)
Public Property Listener As MonitorMethodDelegate
Visual C++
public:
property MonitorMethodDelegate^ Listener {
    MonitorMethodDelegate^ get ();
    void set (MonitorMethodDelegate^ value);
}

See Also

StatisticsItem Class
Genesyslab.Enterprise.Services Namespace


NotificationMode Property

[image]

Enterprise SDK 8.0 Reference API
StatisticsItem..::.NotificationMode Property
StatisticsItem Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.StatisticsItem.NotificationMode"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public MonitorNotificationMode NotificationMode { get; set; }
Visual Basic (Declaration)
Public Property NotificationMode As MonitorNotificationMode
Visual C++
public:
property MonitorNotificationMode NotificationMode {
    MonitorNotificationMode get ();
    void set (MonitorNotificationMode value);
}

See Also

StatisticsItem Class
Genesyslab.Enterprise.Services Namespace


NotificationValue Property

[image]

Enterprise SDK 8.0 Reference API
StatisticsItem..::.NotificationValue Property
StatisticsItem Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.StatisticsItem.NotificationValue"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public int NotificationValue { get; set; }
Visual Basic (Declaration)
Public Property NotificationValue As Integer
Visual C++
public:
property int NotificationValue {
    int get ();
    void set (int value);
}

See Also

StatisticsItem Class
Genesyslab.Enterprise.Services Namespace


ObjectId Property

[image]

Enterprise SDK 8.0 Reference API
StatisticsItem..::.ObjectId Property
StatisticsItem Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.StatisticsItem.ObjectId"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string ObjectId { get; set; }
Visual Basic (Declaration)
Public Property ObjectId As String
Visual C++
public:
property String^ ObjectId {
    String^ get ();
    void set (String^ value);
}

See Also

StatisticsItem Class
Genesyslab.Enterprise.Services Namespace


ObjectType Property

[image]

Enterprise SDK 8.0 Reference API
StatisticsItem..::.ObjectType Property
StatisticsItem Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.StatisticsItem.ObjectType"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public MonitorObjectType ObjectType { get; set; }
Visual Basic (Declaration)
Public Property ObjectType As MonitorObjectType
Visual C++
public:
property MonitorObjectType ObjectType {
    MonitorObjectType get ();
    void set (MonitorObjectType value);
}

See Also

StatisticsItem Class
Genesyslab.Enterprise.Services Namespace


Request Property

[image]

Enterprise SDK 8.0 Reference API
StatisticsItem..::.Request Property
StatisticsItem Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.StatisticsItem.Request"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public RequestOpenStatisticEx Request { get; set; }
Visual Basic (Declaration)
Public Property Request As RequestOpenStatisticEx
Visual C++
public:
property RequestOpenStatisticEx^ Request {
    RequestOpenStatisticEx^ get ();
    void set (RequestOpenStatisticEx^ value);
}

See Also

StatisticsItem Class
Genesyslab.Enterprise.Services Namespace


StatisticID Property

[image]

Enterprise SDK 8.0 Reference API
StatisticsItem..::.StatisticID Property
StatisticsItem Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.StatisticsItem.StatisticID"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public int StatisticID { get; set; }
Visual Basic (Declaration)
Public Property StatisticID As Integer
Visual C++
public:
property int StatisticID {
    int get ();
    void set (int value);
}

See Also

StatisticsItem Class
Genesyslab.Enterprise.Services Namespace


TenantName Property

[image]

Enterprise SDK 8.0 Reference API
StatisticsItem..::.TenantName Property
StatisticsItem Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.StatisticsItem.TenantName"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string TenantName { get; set; }
Visual Basic (Declaration)
Public Property TenantName As String
Visual C++
public:
property String^ TenantName {
    String^ get ();
    void set (String^ value);
}

See Also

StatisticsItem Class
Genesyslab.Enterprise.Services Namespace


TenantPassword Property

[image]

Enterprise SDK 8.0 Reference API
StatisticsItem..::.TenantPassword Property
StatisticsItem Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.StatisticsItem.TenantPassword"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string TenantPassword { get; set; }
Visual Basic (Declaration)
Public Property TenantPassword As String
Visual C++
public:
property String^ TenantPassword {
    String^ get ();
    void set (String^ value);
}

See Also

StatisticsItem Class
Genesyslab.Enterprise.Services Namespace


SupervisorModeType Enumeration

[image]

Enterprise SDK 8.0 Reference API
SupervisorModeType Enumeration
See Also Send Feedback
Enumerates the monitor modes.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum SupervisorModeType
Visual Basic (Declaration)
Public Enumeration SupervisorModeType
Visual C++
public enum class SupervisorModeType

Members

Member name | Description
Single | Monitor once call.
All | Monitor all calls until explicitely canceled.

See Also

Genesyslab.Enterprise.Services Namespace


SupervisorObjectState Class

[image]

Enterprise SDK 8.0 Reference API
SupervisorObjectState Class
Members See Also Send Feedback
State for the supervisor.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public class SupervisorObjectState
Visual Basic (Declaration)
Public Class SupervisorObjectState
Visual C++
public ref class SupervisorObjectState

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Services..::.SupervisorObjectState

See Also

SupervisorObjectState Members
Genesyslab.Enterprise.Services Namespace


SupervisorObjectState Members

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorObjectState Members
SupervisorObjectState Class Constructors Methods Properties See Also Send Feedback

The SupervisorObjectState type exposes the following members.

Constructors

Name | Description
SupervisorObjectState |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Mode | The mode type of the supervision.
Originator | The originator device of supervision.
State | The state type of the supervision.
Target | The target device of supervision.

See Also

SupervisorObjectState Class
Genesyslab.Enterprise.Services Namespace


SupervisorObjectState Constructor

[image]

Enterprise SDK 8.0 Reference API
SupervisorObjectState Constructor
SupervisorObjectState Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorObjectState.#ctor"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public SupervisorObjectState()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SupervisorObjectState()

See Also

SupervisorObjectState Class
Genesyslab.Enterprise.Services Namespace


SupervisorObjectState Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorObjectState Methods
SupervisorObjectState Class See Also Send Feedback

The SupervisorObjectState type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SupervisorObjectState Class
Genesyslab.Enterprise.Services Namespace


SupervisorObjectState Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorObjectState Properties
SupervisorObjectState Class See Also Send Feedback

The SupervisorObjectState type exposes the following members.

Properties

Name | Description
Mode | The mode type of the supervision.
Originator | The originator device of supervision.
State | The state type of the supervision.
Target | The target device of supervision.

See Also

SupervisorObjectState Class
Genesyslab.Enterprise.Services Namespace


Mode Property

[image]

Enterprise SDK 8.0 Reference API
SupervisorObjectState..::.Mode Property
SupervisorObjectState Class See Also Send Feedback
The mode type of the supervision.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public SupervisorModeType Mode { get; set; }
Visual Basic (Declaration)
Public Property Mode As SupervisorModeType
Visual C++
public:
property SupervisorModeType Mode {
    SupervisorModeType get ();
    void set (SupervisorModeType value);
}

See Also

SupervisorObjectState Class
Genesyslab.Enterprise.Services Namespace


Originator Property

[image]

Enterprise SDK 8.0 Reference API
SupervisorObjectState..::.Originator Property
SupervisorObjectState Class See Also Send Feedback
The originator device of supervision.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IDevice Originator { get; set; }
Visual Basic (Declaration)
Public Property Originator As IDevice
Visual C++
public:
property IDevice^ Originator {
    IDevice^ get ();
    void set (IDevice^ value);
}

See Also

SupervisorObjectState Class
Genesyslab.Enterprise.Services Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
SupervisorObjectState..::.State Property
SupervisorObjectState Class See Also Send Feedback
The state type of the supervision.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public SupervisorStateType State { get; set; }
Visual Basic (Declaration)
Public Property State As SupervisorStateType
Visual C++
public:
property SupervisorStateType State {
    SupervisorStateType get ();
    void set (SupervisorStateType value);
}

See Also

SupervisorObjectState Class
Genesyslab.Enterprise.Services Namespace


Target Property

[image]

Enterprise SDK 8.0 Reference API
SupervisorObjectState..::.Target Property
SupervisorObjectState Class See Also Send Feedback
The target device of supervision.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IDevice Target { get; set; }
Visual Basic (Declaration)
Public Property Target As IDevice
Visual C++
public:
property IDevice^ Target {
    IDevice^ get ();
    void set (IDevice^ value);
}

See Also

SupervisorObjectState Class
Genesyslab.Enterprise.Services Namespace


SupervisorObjectType Enumeration

[image]

Enterprise SDK 8.0 Reference API
SupervisorObjectType Enumeration
See Also Send Feedback
Enumerates the types of objects involved in supervision.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum SupervisorObjectType
Visual Basic (Declaration)
Public Enumeration SupervisorObjectType
Visual C++
public enum class SupervisorObjectType

Members

Member name | Description
Agent |
Device |
Interaction |

See Also

Genesyslab.Enterprise.Services Namespace


SupervisorService Class

[image]

Enterprise SDK 8.0 Reference API
SupervisorService Class
Members See Also Send Feedback
Monitor class implementation

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public class SupervisorService : CustomSubscriber<IEnvelope<ISupervisorInfo>>,
    ISupervisorService, IEventManager<ISupervisorService, IEnvelope<ISupervisorInfo>>,
    ISupervisorDomain, IBrokerSubscriber<IEnvelope<ISupervisorInfo>>, IBrokerPublisher,
    ISubscribeable<IEnvelope<IRequest>>
Visual Basic (Declaration)
Public Class SupervisorService _
    Inherits CustomSubscriber(Of IEnvelope(Of ISupervisorInfo)) _
    Implements ISupervisorService, IEventManager(Of ISupervisorService, IEnvelope(Of ISupervisorInfo)),  _
    ISupervisorDomain, IBrokerSubscriber(Of IEnvelope(Of ISupervisorInfo)), IBrokerPublisher,  _
    ISubscribeable(Of IEnvelope(Of IRequest))
Visual C++
public ref class SupervisorService : public CustomSubscriber<IEnvelope<ISupervisorInfo^>^>,
    ISupervisorService, IEventManager<ISupervisorService^, IEnvelope<ISupervisorInfo^>^>,
    ISupervisorDomain, IBrokerSubscriber<IEnvelope<ISupervisorInfo^>^>, IBrokerPublisher,
    ISubscribeable<IEnvelope<IRequest^>^>

Inheritance Hierarchy

System..::.Object
ContainerBase
Genesyslab.Enterprise.Services..::.CustomSubscriber <(Of <( IEnvelope <(Of <( ISupervisorInfo >)>)>)>)
Genesyslab.Enterprise.Services..::.SupervisorService

See Also

SupervisorService Members
Genesyslab.Enterprise.Services Namespace


SupervisorService Members

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorService Members
SupervisorService Class Constructors Methods Properties See Also Send Feedback

The SupervisorService type exposes the following members.

Constructors

Name | Description
SupervisorService | Overloaded.

Methods

Name | Description
AddChannel | Add a channel to the service
AddRequest |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Get hash code of object Hascode is computed by concatenating the Name and the FQName (Uid) (Overrides Object..::.GetHashCode()()().)
GetList | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Handle |
IsMonitored | Overloaded.
ListFilter<(Of <(T>)>) |
ListStrategies | List strategies within the interaction object specified If a null parameter is used, strategies from the service are reported
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from CustomSubscriber<(Of <(T>)>).)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) |
RemoveAllStrategies |
RemoveChannel | Remove a channel from the service
RemoveStrategy |
SetStrategy |
ToString | Returns the Id of the service (Overrides Object..::.ToString()()().)
UnRegisterEvents | Overloaded.
UnRegisterFilter<(Of <(T>)>) |

Properties

Name | Description
Count | Gets the number of service subscribers. (Inherited from CustomSubscriber<(Of <(T>)>).)
Description | Get friendly description of the service (Overrides ContainerBaseDescription()()().)
EventSubscription | Gets the Service subscriber. (Inherited from CustomSubscriber<(Of <(T>)>).)
Filter |
ServiceName | Get friendly service name (Overrides ContainerBaseServiceName()()().)

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


SupervisorService Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorService Constructor
SupervisorService Class See Also Send Feedback

Overload List

Name | Description
SupervisorService(IContainerBase) |
SupervisorService(IContainerBase, IBrokerManager<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>)) |

See Also

SupervisorService Class
SupervisorService Members
Genesyslab.Enterprise.Services Namespace


SupervisorService Constructor ()

[image]

Enterprise SDK 8.0 Reference API
SupervisorService Constructor ()
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public SupervisorService(
    IContainerBase provider
)
Visual Basic (Declaration)
Public Sub New ( _
    provider As IContainerBase _
)
Visual C++
public:
SupervisorService(
    IContainerBase^ provider
)

Parameters

provider
Type: IContainerBase

[Missing <param name="provider"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase)"]

See Also

SupervisorService Class
SupervisorService Overload
Genesyslab.Enterprise.Services Namespace


SupervisorService Constructor (, IBrokerManager(IEnvelope(ISupervisorInfo)))

[image]

Enterprise SDK 8.0 Reference API
SupervisorService Constructor (, IBrokerManager<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>))
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase,Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public SupervisorService(
    IContainerBase provider,
    IBrokerManager<IEnvelope<ISupervisorInfo>> eventBroker
)
Visual Basic (Declaration)
Public Sub New ( _
    provider As IContainerBase, _
    eventBroker As IBrokerManager(Of IEnvelope(Of ISupervisorInfo)) _
)
Visual C++
public:
SupervisorService(
    IContainerBase^ provider,
    IBrokerManager<IEnvelope<ISupervisorInfo^>^>^ eventBroker
)

Parameters

provider
Type: IContainerBase

[Missing <param name="provider"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase,Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

eventBroker
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IBrokerManager <(Of <( IEnvelope <(Of <( ISupervisorInfo >)>)>)>)

[Missing <param name="eventBroker"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase,Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

See Also

SupervisorService Class
SupervisorService Overload
Genesyslab.Enterprise.Services Namespace


SupervisorService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorService Methods
SupervisorService Class See Also Send Feedback

The SupervisorService type exposes the following members.

Methods

Name | Description
AddChannel | Add a channel to the service
AddRequest |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Get hash code of object Hascode is computed by concatenating the Name and the FQName (Uid) (Overrides Object..::.GetHashCode()()().)
GetList | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Handle |
IsMonitored | Overloaded.
ListFilter<(Of <(T>)>) |
ListStrategies | List strategies within the interaction object specified If a null parameter is used, strategies from the service are reported
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from CustomSubscriber<(Of <(T>)>).)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) |
RemoveAllStrategies |
RemoveChannel | Remove a channel from the service
RemoveStrategy |
SetStrategy |
ToString | Returns the Id of the service (Overrides Object..::.ToString()()().)
UnRegisterEvents | Overloaded.
UnRegisterFilter<(Of <(T>)>) |

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


AddChannel Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.AddChannel Method
SupervisorService Class See Also Send Feedback
Add a channel to the service

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ISupervisorService AddChannel(
    IClientChannel channel
)
Visual Basic (Declaration)
Public Function AddChannel ( _
    channel As IClientChannel _
) As ISupervisorService
Visual C++
public:
virtual ISupervisorService^ AddChannel(
    IClientChannel^ channel
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
channel instance

Return Value

ISupervisorService

Implements

IEventManager<(Of <(D, T>)>)..::.AddChannel(IClientChannel)

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


AddRequest Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.AddRequest Method
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.AddRequest(Genesyslab.Enterprise.Services.SupervisorObjectState)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool AddRequest(
    SupervisorObjectState request
)
Visual Basic (Declaration)
Public Function AddRequest ( _
    request As SupervisorObjectState _
) As Boolean
Visual C++
public:
bool AddRequest(
    SupervisorObjectState^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Services..::.SupervisorObjectState

[Missing <param name="request"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.AddRequest(Genesyslab.Enterprise.Services.SupervisorObjectState)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.AddRequest(Genesyslab.Enterprise.Services.SupervisorObjectState)"]

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


GetHashCode Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.GetHashCode Method
SupervisorService Class See Also Send Feedback
Get hash code of object Hascode is computed by concatenating the Name and the FQName (Uid)

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

int

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.GetList Method
SupervisorService Class See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the collection of service subscribers. (Inherited from CustomSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the collection of service subscribers. (Inherited from CustomSubscriber<(Of <(T>)>).)

See Also

SupervisorService Class
SupervisorService Members
Genesyslab.Enterprise.Services Namespace


Handle Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.Handle Method
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.Handle(Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.ComponentModel.IRequest})"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Handle(
    IEnvelope<IRequest> obj
)
Visual Basic (Declaration)
Public Sub Handle ( _
    obj As IEnvelope(Of IRequest) _
)
Visual C++
public:
virtual void Handle(
    IEnvelope<IRequest^>^ obj
) sealed

Parameters

obj
Type: Genesyslab.Enterprise.Model.Envelope..::.IEnvelope <(Of <( IRequest >)>)

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.Handle(Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.ComponentModel.IRequest})"]

Implements

ISubscribeable<(Of <(T>)>)..::.Handle(T)

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


IsMonitored Method

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.IsMonitored Method
SupervisorService Class See Also Send Feedback

Overload List

Name | Description
IsMonitored(IDevice) | Check if the specified device is monitored
IsMonitored(IIdentity) | Check if an identity is currently monitored or not
IsMonitored(IInteraction) | Check if an interaction is currently monitored

See Also

SupervisorService Class
SupervisorService Members
Genesyslab.Enterprise.Services Namespace


IsMonitored Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.IsMonitored Method (IDevice)
SupervisorService Class See Also Send Feedback
Check if the specified device is monitored

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool IsMonitored(
    IDevice device
)
Visual Basic (Declaration)
Public Function IsMonitored ( _
    device As IDevice _
) As Boolean
Visual C++
public:
virtual bool IsMonitored(
    IDevice^ device
) sealed

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device instance to evaluate

Return Value

bool

Implements

ISupervisorDomain..::.IsMonitored(IDevice)

See Also

SupervisorService Class
IsMonitored Overload
Genesyslab.Enterprise.Services Namespace


IsMonitored Method (IIdentity)

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.IsMonitored Method (IIdentity)
SupervisorService Class See Also Send Feedback
Check if an identity is currently monitored or not

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool IsMonitored(
    IIdentity identity
)
Visual Basic (Declaration)
Public Function IsMonitored ( _
    identity As IIdentity _
) As Boolean
Visual C++
public:
virtual bool IsMonitored(
    IIdentity^ identity
) sealed

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Identity instance

Return Value

bool

Implements

ISupervisorDomain..::.IsMonitored(IIdentity)

See Also

SupervisorService Class
IsMonitored Overload
Genesyslab.Enterprise.Services Namespace


IsMonitored Method (IInteraction)

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.IsMonitored Method (IInteraction)
SupervisorService Class See Also Send Feedback
Check if an interaction is currently monitored

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool IsMonitored(
    IInteraction interaction
)
Visual Basic (Declaration)
Public Function IsMonitored ( _
    interaction As IInteraction _
) As Boolean
Visual C++
public:
virtual bool IsMonitored(
    IInteraction^ interaction
) sealed

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction instance

Return Value

bool

Implements

ISupervisorDomain..::.IsMonitored(IInteraction)

See Also

SupervisorService Class
IsMonitored Overload
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.ListFilter<(Of <(T>)>) Method
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.ListFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnumerable<T> ListFilter<T>(
    ISupervisorInfo interaction
)
Visual Basic (Declaration)
Public Function ListFilter(Of T) ( _
    interaction As ISupervisorInfo _
) As IEnumerable(Of T)
Visual C++
public:
generic<typename T>
virtual IEnumerable<T>^ ListFilter(
    ISupervisorInfo^ interaction
) sealed

Parameters

interaction
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.ListFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.ListFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.ListFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo)"]

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


ListStrategies Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.ListStrategies Method
SupervisorService Class See Also Send Feedback
List strategies within the interaction object specified If a null parameter is used, strategies from the service are reported

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IStrategy[] ListStrategies(
    ISupervisorInfo targetObject
)
Visual Basic (Declaration)
Public Function ListStrategies ( _
    targetObject As ISupervisorInfo _
) As IStrategy()
Visual C++
public:
virtual array<IStrategy^>^ ListStrategies(
    ISupervisorInfo^ targetObject
) sealed

Parameters

targetObject
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.ListStrategies(Genesyslab.Enterprise.Services.ISupervisorInfo)"]

Return Value

IStrategy []

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.RegisterEvents Method
SupervisorService Class See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>)) |
RegisterEvents(IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>), array<IStrategy>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>), array<String>[]()[], array<IFilter>[]()[]) |

See Also

SupervisorService Class
SupervisorService Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(IEnvelope(ISupervisorInfo)))

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.RegisterEvents Method (IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>))
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ISupervisorService RegisterEvents(
    IClientChannel channel,
    Action<IEnvelope<ISupervisorInfo>> handler
)
Visual Basic (Declaration)
Public Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of IEnvelope(Of ISupervisorInfo)) _
) As ISupervisorService
Visual C++
public:
virtual ISupervisorService^ RegisterEvents(
    IClientChannel^ channel,
    Action<IEnvelope<ISupervisorInfo^>^>^ handler
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( ISupervisorInfo >)>)>)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

Implements

IEventManager<(Of <(D, T>)>)..::.RegisterEvents(IClientChannel, Action<(Of <(T>)>))

See Also

SupervisorService Class
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(IEnvelope(ISupervisorInfo)), [], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.RegisterEvents Method (IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>), array<>[]()[], array<IFilter>[]()[])
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ISupervisorService RegisterEvents(
    IClientChannel channel,
    Action<IEnvelope<ISupervisorInfo>> handler,
    IStrategy[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Public Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of IEnvelope(Of ISupervisorInfo)), _
    strategyList As IStrategy(), _
    filterList As IFilter() _
) As ISupervisorService
Visual C++
public:
virtual ISupervisorService^ RegisterEvents(
    IClientChannel^ channel,
    Action<IEnvelope<ISupervisorInfo^>^>^ handler,
    array<IStrategy^>^ strategyList,
    array<IFilter^>^ filterList
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( ISupervisorInfo >)>)>)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

strategyList
Type: array< IStrategy >[]()[]

[Missing <param name="strategyList"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]

[Missing <param name="filterList"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Implements

IEventManager<(Of <(D, T>)>)..::.RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[])

See Also

SupervisorService Class
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(IEnvelope(ISupervisorInfo)), Attribute[], Attribute[])

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.RegisterEvents Method (IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[])
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.Attribute[],System.Attribute[])"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ISupervisorService RegisterEvents(
    IClientChannel channel,
    Action<IEnvelope<ISupervisorInfo>> handler,
    Attribute[] strategyList,
    Attribute[] filterList
)
Visual Basic (Declaration)
Public Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of IEnvelope(Of ISupervisorInfo)), _
    strategyList As Attribute(), _
    filterList As Attribute() _
) As ISupervisorService
Visual C++
public:
virtual ISupervisorService^ RegisterEvents(
    IClientChannel^ channel,
    Action<IEnvelope<ISupervisorInfo^>^>^ handler,
    array<Attribute^>^ strategyList,
    array<Attribute^>^ filterList
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.Attribute[],System.Attribute[])"]

handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( ISupervisorInfo >)>)>)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.Attribute[],System.Attribute[])"]

strategyList
Type: array< System..::.Attribute >[]()[]

[Missing <param name="strategyList"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.Attribute[],System.Attribute[])"]

filterList
Type: array< System..::.Attribute >[]()[]

[Missing <param name="filterList"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.Attribute[],System.Attribute[])"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.Attribute[],System.Attribute[])"]

Implements

IEventManager<(Of <(D, T>)>)..::.RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[])

See Also

SupervisorService Class
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(IEnvelope(ISupervisorInfo)), String[], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.RegisterEvents Method (IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>), array<String>[]()[], array<IFilter>[]()[])
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ISupervisorService RegisterEvents(
    IClientChannel channel,
    Action<IEnvelope<ISupervisorInfo>> handler,
    string[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Public Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of IEnvelope(Of ISupervisorInfo)), _
    strategyList As String(), _
    filterList As IFilter() _
) As ISupervisorService
Visual C++
public:
virtual ISupervisorService^ RegisterEvents(
    IClientChannel^ channel,
    Action<IEnvelope<ISupervisorInfo^>^>^ handler,
    array<String^>^ strategyList,
    array<IFilter^>^ filterList
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( ISupervisorInfo >)>)>)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

strategyList
Type: array< System..::.String >[]()[]

[Missing <param name="strategyList"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]

[Missing <param name="filterList"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Implements

IEventManager<(Of <(D, T>)>)..::.RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[])

See Also

SupervisorService Class
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.RegisterFilter<(Of <(T>)>) Method
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ISupervisorService RegisterFilter<T>(
    ISupervisorInfo context,
    T filter
)
Visual Basic (Declaration)
Public Function RegisterFilter(Of T) ( _
    context As ISupervisorInfo, _
    filter As T _
) As ISupervisorService
Visual C++
public:
generic<typename T>
virtual ISupervisorService^ RegisterFilter(
    ISupervisorInfo^ context,
    T filter
) sealed

Parameters

context
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

filter
Type: T

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

Implements

ISupervisorService..::.RegisterFilter<(Of <(T>)>)(ISupervisorInfo, T)

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


RemoveAllStrategies Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.RemoveAllStrategies Method
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RemoveAllStrategies"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IStrategyManager<ISupervisorInfo> RemoveAllStrategies()
Visual Basic (Declaration)
Public Function RemoveAllStrategies As IStrategyManager(Of ISupervisorInfo)
Visual C++
public:
virtual IStrategyManager<ISupervisorInfo^>^ RemoveAllStrategies() sealed

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RemoveAllStrategies"]

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


RemoveChannel Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.RemoveChannel Method
SupervisorService Class See Also Send Feedback
Remove a channel from the service

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ISupervisorService RemoveChannel(
    IClientChannel channel
)
Visual Basic (Declaration)
Public Function RemoveChannel ( _
    channel As IClientChannel _
) As ISupervisorService
Visual C++
public:
virtual ISupervisorService^ RemoveChannel(
    IClientChannel^ channel
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
channel instance

Return Value

ISupervisorService

Implements

IEventManager<(Of <(D, T>)>)..::.RemoveChannel(IClientChannel)

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


RemoveStrategy Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.RemoveStrategy Method
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RemoveStrategy(Genesyslab.Enterprise.Services.ISupervisorInfo,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IStrategyManager<ISupervisorInfo> RemoveStrategy(
    ISupervisorInfo targetObject,
    IStrategy strategy
)
Visual Basic (Declaration)
Public Function RemoveStrategy ( _
    targetObject As ISupervisorInfo, _
    strategy As IStrategy _
) As IStrategyManager(Of ISupervisorInfo)
Visual C++
public:
virtual IStrategyManager<ISupervisorInfo^>^ RemoveStrategy(
    ISupervisorInfo^ targetObject,
    IStrategy^ strategy
) sealed

Parameters

targetObject
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RemoveStrategy(Genesyslab.Enterprise.Services.ISupervisorInfo,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

strategy
Type: IStrategy

[Missing <param name="strategy"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RemoveStrategy(Genesyslab.Enterprise.Services.ISupervisorInfo,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RemoveStrategy(Genesyslab.Enterprise.Services.ISupervisorInfo,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


SetStrategy Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.SetStrategy Method
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.SetStrategy(Genesyslab.Enterprise.Services.ISupervisorInfo,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IStrategyManager<ISupervisorInfo> SetStrategy(
    ISupervisorInfo targetObject,
    IStrategy strategy
)
Visual Basic (Declaration)
Public Function SetStrategy ( _
    targetObject As ISupervisorInfo, _
    strategy As IStrategy _
) As IStrategyManager(Of ISupervisorInfo)
Visual C++
public:
virtual IStrategyManager<ISupervisorInfo^>^ SetStrategy(
    ISupervisorInfo^ targetObject,
    IStrategy^ strategy
) sealed

Parameters

targetObject
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.SetStrategy(Genesyslab.Enterprise.Services.ISupervisorInfo,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

strategy
Type: IStrategy

[Missing <param name="strategy"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.SetStrategy(Genesyslab.Enterprise.Services.ISupervisorInfo,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.SetStrategy(Genesyslab.Enterprise.Services.ISupervisorInfo,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


ToString Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.ToString Method
SupervisorService Class See Also Send Feedback
Returns the Id of the service

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.ToString"]

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.UnRegisterEvents Method
SupervisorService Class See Also Send Feedback

Overload List

Name | Description
UnRegisterEvents(IClientChannel, Action<(Of <(IEnvelope<(Of <(IRequest>)>)>)>)) | Unregister events from the specified channel
UnRegisterEvents(IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>)) |

See Also

SupervisorService Class
SupervisorService Members
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method (IClientChannel, Action(IEnvelope(IRequest)))

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.UnRegisterEvents Method (IClientChannel, Action<(Of <(IEnvelope<(Of <(IRequest>)>)>)>))
SupervisorService Class See Also Send Feedback
Unregister events from the specified channel

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ISupervisorService UnRegisterEvents(
    IClientChannel channel,
    Action<IEnvelope<IRequest>> handler
)
Visual Basic (Declaration)
Public Function UnRegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of IEnvelope(Of IRequest)) _
) As ISupervisorService
Visual C++
public:
ISupervisorService^ UnRegisterEvents(
    IClientChannel^ channel,
    Action<IEnvelope<IRequest^>^>^ handler
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.ComponentModel.IRequest}})"]

handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( IRequest >)>)>)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.ComponentModel.IRequest}})"]

Return Value

IInteractionService

See Also

SupervisorService Class
UnRegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method (IClientChannel, Action(IEnvelope(ISupervisorInfo)))

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.UnRegisterEvents Method (IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>))
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ISupervisorService UnRegisterEvents(
    IClientChannel channel,
    Action<IEnvelope<ISupervisorInfo>> handler
)
Visual Basic (Declaration)
Public Function UnRegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of IEnvelope(Of ISupervisorInfo)) _
) As ISupervisorService
Visual C++
public:
virtual ISupervisorService^ UnRegisterEvents(
    IClientChannel^ channel,
    Action<IEnvelope<ISupervisorInfo^>^>^ handler
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( ISupervisorInfo >)>)>)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

Implements

IEventManager<(Of <(D, T>)>)..::.UnRegisterEvents(IClientChannel, Action<(Of <(T>)>))

See Also

SupervisorService Class
UnRegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.UnRegisterFilter<(Of <(T>)>) Method
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ISupervisorService UnRegisterFilter<T>(
    ISupervisorInfo context,
    T filter
)
Visual Basic (Declaration)
Public Function UnRegisterFilter(Of T) ( _
    context As ISupervisorInfo, _
    filter As T _
) As ISupervisorService
Visual C++
public:
generic<typename T>
virtual ISupervisorService^ UnRegisterFilter(
    ISupervisorInfo^ context,
    T filter
) sealed

Parameters

context
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

filter
Type: T

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

Implements

ISupervisorService..::.UnRegisterFilter<(Of <(T>)>)(ISupervisorInfo, T)

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


SupervisorService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorService Properties
SupervisorService Class See Also Send Feedback

The SupervisorService type exposes the following members.

Properties

Name | Description
Count | Gets the number of service subscribers. (Inherited from CustomSubscriber<(Of <(T>)>).)
Description | Get friendly description of the service (Overrides ContainerBaseDescription()()().)
EventSubscription | Gets the Service subscriber. (Inherited from CustomSubscriber<(Of <(T>)>).)
Filter |
ServiceName | Get friendly service name (Overrides ContainerBaseServiceName()()().)

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.Description Property
SupervisorService Class See Also Send Feedback
Get friendly description of the service

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override string Description { get; set; }
Visual Basic (Declaration)
Public Overrides Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IService..::.Description

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


Filter Property

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.Filter Property
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.SupervisorService.Filter"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IPredicatable<IEnvelope<IRequest>> Filter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filter As IPredicatable(Of IEnvelope(Of IRequest))
Visual C++
public:
virtual property IPredicatable<IEnvelope<IRequest^>^>^ Filter {
    IPredicatable<IEnvelope<IRequest^>^>^ get () sealed;
}

Implements

ISubscribeable<(Of <(T>)>)..::.Filter

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


ServiceName Property

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.ServiceName Property
SupervisorService Class See Also Send Feedback
Get friendly service name

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override string ServiceName { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ServiceName As String
Visual C++
public:
virtual property String^ ServiceName {
    String^ get () override;
}

Implements

IService..::.ServiceName
IEnterpriseServiceProvider..::.ServiceName

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


SupervisorStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
SupervisorStateType Enumeration
See Also Send Feedback
Enumerates the supervisor statuses.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public enum SupervisorStateType
Visual Basic (Declaration)
Public Enumeration SupervisorStateType
Visual C++
public enum class SupervisorStateType

Members

Member name | Description
Unknown |
On |
Off |

See Also

Genesyslab.Enterprise.Services Namespace


VoiceService Class

[image]

Enterprise SDK 8.0 Reference API
VoiceService Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.VoiceService"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public class VoiceService : CustomSubscriber<IEnvelope<IInteraction>>,
    IVoiceService, IInteractionDomain, IEventManager<IVoiceService, IEnvelope<IInteraction>>,
    IBrokerSubscriber<IEnvelope<IInteraction>>, IBrokerPublisher, ISubscribeable<IEnvelope<IRequest>>,
    IPersistable<IInteraction>
Visual Basic (Declaration)
Public Class VoiceService _
    Inherits CustomSubscriber(Of IEnvelope(Of IInteraction)) _
    Implements IVoiceService, IInteractionDomain, IEventManager(Of IVoiceService, IEnvelope(Of IInteraction)),  _
    IBrokerSubscriber(Of IEnvelope(Of IInteraction)), IBrokerPublisher, ISubscribeable(Of IEnvelope(Of IRequest)),  _
    IPersistable(Of IInteraction)
Visual C++
public ref class VoiceService : public CustomSubscriber<IEnvelope<IInteraction^>^>,
    IVoiceService, IInteractionDomain, IEventManager<IVoiceService^, IEnvelope<IInteraction^>^>,
    IBrokerSubscriber<IEnvelope<IInteraction^>^>, IBrokerPublisher, ISubscribeable<IEnvelope<IRequest^>^>,
    IPersistable<IInteraction^>

Inheritance Hierarchy

System..::.Object
ContainerBase
Genesyslab.Enterprise.Services..::.CustomSubscriber <(Of <( IEnvelope <(Of <( IInteraction >)>)>)>)
Genesyslab.Enterprise.Services..::.VoiceService

See Also

VoiceService Members
Genesyslab.Enterprise.Services Namespace


VoiceService Members

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceService Members
VoiceService Class Constructors Methods Properties See Also Send Feedback

The VoiceService type exposes the following members.

Constructors

Name | Description
VoiceService | Overloaded.

Methods

Name | Description
AddChannel | Add a channel to the service
CreateInteraction | Overloaded.
DeleteInteraction | Delete an interaction
DeleteInteractions |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAttachedData | Retrieve attached data of an interaction as KeyValueCollection
GetHashCode | Get hash code of object Hascode is computed by concatenating the Name and the FQName (Uid) (Overrides Object..::.GetHashCode()()().)
GetInteraction | Overloaded.
GetInteractions | Overloaded.
GetLinkedInteractions |
GetList | Overloaded.
GetParentInteraction |
GetType | Gets the Type of the current instance. (Inherited from Object.)
Handle |
IsDirty |
ListFilter<(Of <(T>)>) |
ListStrategies | List strategies within the interaction object specified If a null parameter is used, strategies from the service are reported
Publish | Overloaded.
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) |
RemoveAllStrategies |
RemoveAttachedData | Remove a key withtin atatched data of the specified interaction Update wihtin the interaction context occurs when acknowledge by the back end server If no key is specified (null parameter), all user data are removed. Using this method does not require a SaveAtatchedData()
RemoveChannel | Remove a channel from the service
RemoveStrategy |
Save | Overloaded.
SaveAttachedData | Save attached data of an interaction. Manual synchronization Use this method if attributes are modified without using the SetAtatchedData methods
SaveInteraction | Save interaction specified wihtin the interaction service
SetAttachedData | Overloaded.
SetStrategy |
ToString | (Overrides Object..::.ToString()()().)
UnRegisterEvents | Unregister events from the specified channel
UnRegisterFilter<(Of <(T>)>) |

Properties

Name | Description
ContactServerId |
Count | Gets the number of service subscribers. (Inherited from CustomSubscriber<(Of <(T>)>).)
Description | Get friendly description of the service (Overrides ContainerBaseDescription()()().)
EventSubscription | Gets the Service subscriber. (Inherited from CustomSubscriber<(Of <(T>)>).)
Filter |
ServiceName | Get friendly service name (Overrides ContainerBaseServiceName()()().)

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


VoiceService Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceService Constructor
VoiceService Class See Also Send Feedback

Overload List

Name | Description
VoiceService(IContainerBase) |
VoiceService(IContainerBase, IBrokerManager<(Of <(IEnvelope<(Of <(IInteraction>)>)>)>)) |

See Also

VoiceService Class
VoiceService Members
Genesyslab.Enterprise.Services Namespace


VoiceService Constructor ()

[image]

Enterprise SDK 8.0 Reference API
VoiceService Constructor ()
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public VoiceService(
    IContainerBase provider
)
Visual Basic (Declaration)
Public Sub New ( _
    provider As IContainerBase _
)
Visual C++
public:
VoiceService(
    IContainerBase^ provider
)

Parameters

provider
Type: IContainerBase

[Missing <param name="provider"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase)"]

See Also

VoiceService Class
VoiceService Overload
Genesyslab.Enterprise.Services Namespace


VoiceService Constructor (, IBrokerManager(IEnvelope(IInteraction)))

[image]

Enterprise SDK 8.0 Reference API
VoiceService Constructor (, IBrokerManager<(Of <(IEnvelope<(Of <(IInteraction>)>)>)>))
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase,Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}})"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public VoiceService(
    IContainerBase provider,
    IBrokerManager<IEnvelope<IInteraction>> eventBroker
)
Visual Basic (Declaration)
Public Sub New ( _
    provider As IContainerBase, _
    eventBroker As IBrokerManager(Of IEnvelope(Of IInteraction)) _
)
Visual C++
public:
VoiceService(
    IContainerBase^ provider,
    IBrokerManager<IEnvelope<IInteraction^>^>^ eventBroker
)

Parameters

provider
Type: IContainerBase

[Missing <param name="provider"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase,Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}})"]

eventBroker
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IBrokerManager <(Of <( IEnvelope <(Of <( IInteraction >)>)>)>)

[Missing <param name="eventBroker"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase,Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}})"]

See Also

VoiceService Class
VoiceService Overload
Genesyslab.Enterprise.Services Namespace


VoiceService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceService Methods
VoiceService Class See Also Send Feedback

The VoiceService type exposes the following members.

Methods

Name | Description
AddChannel | Add a channel to the service
CreateInteraction | Overloaded.
DeleteInteraction | Delete an interaction
DeleteInteractions |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAttachedData | Retrieve attached data of an interaction as KeyValueCollection
GetHashCode | Get hash code of object Hascode is computed by concatenating the Name and the FQName (Uid) (Overrides Object..::.GetHashCode()()().)
GetInteraction | Overloaded.
GetInteractions | Overloaded.
GetLinkedInteractions |
GetList | Overloaded.
GetParentInteraction |
GetType | Gets the Type of the current instance. (Inherited from Object.)
Handle |
IsDirty |
ListFilter<(Of <(T>)>) |
ListStrategies | List strategies within the interaction object specified If a null parameter is used, strategies from the service are reported
Publish | Overloaded.
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) |
RemoveAllStrategies |
RemoveAttachedData | Remove a key withtin atatched data of the specified interaction Update wihtin the interaction context occurs when acknowledge by the back end server If no key is specified (null parameter), all user data are removed. Using this method does not require a SaveAtatchedData()
RemoveChannel | Remove a channel from the service
RemoveStrategy |
Save | Overloaded.
SaveAttachedData | Save attached data of an interaction. Manual synchronization Use this method if attributes are modified without using the SetAtatchedData methods
SaveInteraction | Save interaction specified wihtin the interaction service
SetAttachedData | Overloaded.
SetStrategy |
ToString | (Overrides Object..::.ToString()()().)
UnRegisterEvents | Unregister events from the specified channel
UnRegisterFilter<(Of <(T>)>) |

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


AddChannel Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.AddChannel Method
VoiceService Class See Also Send Feedback
Add a channel to the service

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IVoiceService AddChannel(
    IClientChannel channel
)
Visual Basic (Declaration)
Public Function AddChannel ( _
    channel As IClientChannel _
) As IVoiceService
Visual C++
public:
virtual IVoiceService^ AddChannel(
    IClientChannel^ channel
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.AddChannel(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Return Value

IInteractionService

Implements

IEventManager<(Of <(D, T>)>)..::.AddChannel(IClientChannel)

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceService..::.CreateInteraction Method
VoiceService Class See Also Send Feedback

Overload List

Name | Description
CreateInteraction(IEnumerable<(Of <(IDevice>)>)) |
CreateInteraction(IInteraction, IEnumerable<(Of <(IDevice>)>)) |
CreateInteraction(IEnumerable<(Of <(IDevice>)>), MediaType) |

See Also

VoiceService Class
VoiceService Members
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method (IEnumerable(IDevice))

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.CreateInteraction Method (IEnumerable<(Of <(IDevice>)>))
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.CreateInteraction(System.Collections.Generic.IEnumerable{Genesyslab.Enterprise.Model.Device.IDevice})"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IInteraction CreateInteraction(
    IEnumerable<IDevice> deviceList
)
Visual Basic (Declaration)
Public Function CreateInteraction ( _
    deviceList As IEnumerable(Of IDevice) _
) As IInteraction
Visual C++
public:
virtual IInteraction^ CreateInteraction(
    IEnumerable<IDevice^>^ deviceList
) sealed

Parameters

deviceList
Type: System.Collections.Generic..::.IEnumerable<(Of <( IDevice >)>)

[Missing <param name="deviceList"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.CreateInteraction(System.Collections.Generic.IEnumerable{Genesyslab.Enterprise.Model.Device.IDevice})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.CreateInteraction(System.Collections.Generic.IEnumerable{Genesyslab.Enterprise.Model.Device.IDevice})"]

Implements

IInteractionDomain..::.CreateInteraction(IEnumerable<(Of <(IDevice>)>))

See Also

VoiceService Class
CreateInteraction Overload
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method (IInteraction, IEnumerable(IDevice))

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.CreateInteraction Method (IInteraction, IEnumerable<(Of <(IDevice>)>))
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.CreateInteraction(Genesyslab.Enterprise.Model.Interaction.IInteraction,System.Collections.Generic.IEnumerable{Genesyslab.Enterprise.Model.Device.IDevice})"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IInteraction CreateInteraction(
    IInteraction currentInteraction,
    IEnumerable<IDevice> deviceList
)
Visual Basic (Declaration)
Public Function CreateInteraction ( _
    currentInteraction As IInteraction, _
    deviceList As IEnumerable(Of IDevice) _
) As IInteraction
Visual C++
public:
virtual IInteraction^ CreateInteraction(
    IInteraction^ currentInteraction,
    IEnumerable<IDevice^>^ deviceList
) sealed

Parameters

currentInteraction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="currentInteraction"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.CreateInteraction(Genesyslab.Enterprise.Model.Interaction.IInteraction,System.Collections.Generic.IEnumerable{Genesyslab.Enterprise.Model.Device.IDevice})"]

deviceList
Type: System.Collections.Generic..::.IEnumerable<(Of <( IDevice >)>)

[Missing <param name="deviceList"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.CreateInteraction(Genesyslab.Enterprise.Model.Interaction.IInteraction,System.Collections.Generic.IEnumerable{Genesyslab.Enterprise.Model.Device.IDevice})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.CreateInteraction(Genesyslab.Enterprise.Model.Interaction.IInteraction,System.Collections.Generic.IEnumerable{Genesyslab.Enterprise.Model.Device.IDevice})"]

Implements

IInteractionDomain..::.CreateInteraction(IInteraction, IEnumerable<(Of <(IDevice>)>))

See Also

VoiceService Class
CreateInteraction Overload
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method (IEnumerable(IDevice), MediaType)

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.CreateInteraction Method (IEnumerable<(Of <(IDevice>)>), MediaType)
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.CreateInteraction(System.Collections.Generic.IEnumerable{Genesyslab.Enterprise.Model.Device.IDevice},Genesyslab.Enterprise.Model.Protocol.MediaType)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IInteraction CreateInteraction(
    IEnumerable<IDevice> deviceList,
    MediaType _media
)
Visual Basic (Declaration)
Public Function CreateInteraction ( _
    deviceList As IEnumerable(Of IDevice), _
    _media As MediaType _
) As IInteraction
Visual C++
public:
IInteraction^ CreateInteraction(
    IEnumerable<IDevice^>^ deviceList,
    MediaType _media
)

Parameters

deviceList
Type: System.Collections.Generic..::.IEnumerable<(Of <( IDevice >)>)

[Missing <param name="deviceList"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.CreateInteraction(System.Collections.Generic.IEnumerable{Genesyslab.Enterprise.Model.Device.IDevice},Genesyslab.Enterprise.Model.Protocol.MediaType)"]

_media
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType

[Missing <param name="_media"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.CreateInteraction(System.Collections.Generic.IEnumerable{Genesyslab.Enterprise.Model.Device.IDevice},Genesyslab.Enterprise.Model.Protocol.MediaType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.CreateInteraction(System.Collections.Generic.IEnumerable{Genesyslab.Enterprise.Model.Device.IDevice},Genesyslab.Enterprise.Model.Protocol.MediaType)"]

See Also

VoiceService Class
CreateInteraction Overload
Genesyslab.Enterprise.Services Namespace


DeleteInteraction Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.DeleteInteraction Method
VoiceService Class See Also Send Feedback
Delete an interaction

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IInteractionDomain DeleteInteraction(
    IInteraction interaction
)
Visual Basic (Declaration)
Public Function DeleteInteraction ( _
    interaction As IInteraction _
) As IInteractionDomain
Visual C++
public:
virtual IInteractionDomain^ DeleteInteraction(
    IInteraction^ interaction
) sealed

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.DeleteInteraction(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Return Value

IInteractionDomain

Implements

IInteractionDomain..::.DeleteInteraction(IInteraction)

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


DeleteInteractions Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.DeleteInteractions Method
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.DeleteInteractions"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IInteractionDomain DeleteInteractions()
Visual Basic (Declaration)
Public Function DeleteInteractions As IInteractionDomain
Visual C++
public:
virtual IInteractionDomain^ DeleteInteractions() sealed

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.DeleteInteractions"]

Implements

IInteractionDomain..::.DeleteInteractions()()()

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


GetAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.GetAttachedData Method
VoiceService Class See Also Send Feedback
Retrieve attached data of an interaction as KeyValueCollection

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public KeyValueCollection GetAttachedData(
    IInteraction interaction
)
Visual Basic (Declaration)
Public Function GetAttachedData ( _
    interaction As IInteraction _
) As KeyValueCollection
Visual C++
public:
virtual KeyValueCollection^ GetAttachedData(
    IInteraction^ interaction
) sealed

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction instance

Return Value

KeyValueCollection

Implements

IInteractionDomain..::.GetAttachedData(IInteraction)

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


GetHashCode Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.GetHashCode Method
VoiceService Class See Also Send Feedback
Get hash code of object Hascode is computed by concatenating the Name and the FQName (Uid)

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

int

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


GetInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceService..::.GetInteraction Method
VoiceService Class See Also Send Feedback

Overload List

Name | Description
GetInteraction(IAgent, String) | Retrieve an interaction matching the agent and interaction id specified
GetInteraction(IDN, String) | Get an existing interaction from the specified device and interaction Id Returns null if nothing is found

See Also

VoiceService Class
VoiceService Members
Genesyslab.Enterprise.Services Namespace


GetInteraction Method (IAgent, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.GetInteraction Method (IAgent, String)
VoiceService Class See Also Send Feedback
Retrieve an interaction matching the agent and interaction id specified

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IInteraction GetInteraction(
    IAgent agent,
    string interactionId
)
Visual Basic (Declaration)
Public Function GetInteraction ( _
    agent As IAgent, _
    interactionId As String _
) As IInteraction
Visual C++
public:
virtual IInteraction^ GetInteraction(
    IAgent^ agent,
    String^ interactionId
) sealed

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.GetInteraction(Genesyslab.Enterprise.Agent.IAgent,System.String)"]

interactionId
Type: System..::.String

[Missing <param name="interactionId"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.GetInteraction(Genesyslab.Enterprise.Agent.IAgent,System.String)"]

Return Value

IInteraction

Implements

IInteractionDomain..::.GetInteraction(IAgent, String)

See Also

VoiceService Class
GetInteraction Overload
Genesyslab.Enterprise.Services Namespace


GetInteraction Method (IDN, String)

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.GetInteraction Method (IDN, String)
VoiceService Class See Also Send Feedback
Get an existing interaction from the specified device and interaction Id Returns null if nothing is found

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IInteraction GetInteraction(
    IDN dn,
    string interactionId
)
Visual Basic (Declaration)
Public Function GetInteraction ( _
    dn As IDN, _
    interactionId As String _
) As IInteraction
Visual C++
public:
virtual IInteraction^ GetInteraction(
    IDN^ dn,
    String^ interactionId
) sealed

Parameters

dn
Type: Genesyslab.Enterprise.Core..::.IDN

[Missing <param name="dn"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.GetInteraction(Genesyslab.Enterprise.Core.IDN,System.String)"]

interactionId
Type: System..::.String

[Missing <param name="interactionId"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.GetInteraction(Genesyslab.Enterprise.Core.IDN,System.String)"]

Return Value

IInteraction

Implements

IInteractionDomain..::.GetInteraction(IDN, String)

See Also

VoiceService Class
GetInteraction Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceService..::.GetInteractions Method
VoiceService Class See Also Send Feedback

Overload List

Name | Description
GetInteractions()()() | Get ALL interactions
GetInteractions(IAgent) | Get an existing interaction(s) associated to an agent /// Returns null if nothing is found
GetInteractions(IDN) | Get an existing interaction for a specific device Returns null if nothing is found
GetInteractions(String) | Get interactions associated to an Id Returns null if nothing is found

See Also

VoiceService Class
VoiceService Members
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.GetInteractions Method
VoiceService Class See Also Send Feedback
Get ALL interactions

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IInteraction[] GetInteractions()
Visual Basic (Declaration)
Public Function GetInteractions As IInteraction()
Visual C++
public:
virtual array<IInteraction^>^ GetInteractions() sealed

Return Value

IInteraction[]

Implements

IInteractionDomain..::.GetInteractions()()()

See Also

VoiceService Class
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (IAgent)

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.GetInteractions Method (IAgent)
VoiceService Class See Also Send Feedback
Get an existing interaction(s) associated to an agent /// Returns null if nothing is found

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IInteraction[] GetInteractions(
    IAgent agent
)
Visual Basic (Declaration)
Public Function GetInteractions ( _
    agent As IAgent _
) As IInteraction()
Visual C++
public:
virtual array<IInteraction^>^ GetInteractions(
    IAgent^ agent
) sealed

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Agent linked to the interaction

Return Value

IInteraction []

Implements

IInteractionDomain..::.GetInteractions(IAgent)

See Also

VoiceService Class
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (IDN)

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.GetInteractions Method (IDN)
VoiceService Class See Also Send Feedback
Get an existing interaction for a specific device Returns null if nothing is found

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IInteraction[] GetInteractions(
    IDN dn
)
Visual Basic (Declaration)
Public Function GetInteractions ( _
    dn As IDN _
) As IInteraction()
Visual C++
public:
virtual array<IInteraction^>^ GetInteractions(
    IDN^ dn
) sealed

Parameters

dn
Type: Genesyslab.Enterprise.Core..::.IDN
Device linked to the interaction

Return Value

IInteraction []

Implements

IInteractionDomain..::.GetInteractions(IDN)

See Also

VoiceService Class
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (String)

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.GetInteractions Method (String)
VoiceService Class See Also Send Feedback
Get interactions associated to an Id Returns null if nothing is found

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IInteraction[] GetInteractions(
    string interactionId
)
Visual Basic (Declaration)
Public Function GetInteractions ( _
    interactionId As String _
) As IInteraction()
Visual C++
public:
virtual array<IInteraction^>^ GetInteractions(
    String^ interactionId
) sealed

Parameters

interactionId
Type: System..::.String
Unique identifier of the interaction

Return Value

IInteraction[]

Implements

IInteractionDomain..::.GetInteractions(String)

See Also

VoiceService Class
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetLinkedInteractions Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.GetLinkedInteractions Method
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.GetLinkedInteractions(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public ICollection<IInteraction> GetLinkedInteractions(
    IInteraction interaction
)
Visual Basic (Declaration)
Public Function GetLinkedInteractions ( _
    interaction As IInteraction _
) As ICollection(Of IInteraction)
Visual C++
public:
ICollection<IInteraction^>^ GetLinkedInteractions(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.GetLinkedInteractions(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.GetLinkedInteractions(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceService..::.GetList Method
VoiceService Class See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the collection of service subscribers. (Inherited from CustomSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the collection of service subscribers. (Inherited from CustomSubscriber<(Of <(T>)>).)

See Also

VoiceService Class
VoiceService Members
Genesyslab.Enterprise.Services Namespace


GetParentInteraction Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.GetParentInteraction Method
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.GetParentInteraction(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IInteraction GetParentInteraction(
    IInteraction interaction
)
Visual Basic (Declaration)
Public Function GetParentInteraction ( _
    interaction As IInteraction _
) As IInteraction
Visual C++
public:
IInteraction^ GetParentInteraction(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.GetParentInteraction(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.GetParentInteraction(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


Handle Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.Handle Method
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.Handle(Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.ComponentModel.IRequest})"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public void Handle(
    IEnvelope<IRequest> msg
)
Visual Basic (Declaration)
Public Sub Handle ( _
    msg As IEnvelope(Of IRequest) _
)
Visual C++
public:
virtual void Handle(
    IEnvelope<IRequest^>^ msg
) sealed

Parameters

msg
Type: Genesyslab.Enterprise.Model.Envelope..::.IEnvelope <(Of <( IRequest >)>)

[Missing <param name="msg"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.Handle(Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.ComponentModel.IRequest})"]

Implements

ISubscribeable<(Of <(T>)>)..::.Handle(T)

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


IsDirty Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.IsDirty Method
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.IsDirty"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool IsDirty()
Visual Basic (Declaration)
Public Function IsDirty As Boolean
Visual C++
public:
virtual bool IsDirty() sealed

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.IsDirty"]

Implements

IPersistable<(Of <(T>)>)..::.IsDirty()()()

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.ListFilter<(Of <(T>)>) Method
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.ListFilter``1(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IEnumerable<T> ListFilter<T>(
    IInteraction interaction
)
Visual Basic (Declaration)
Public Function ListFilter(Of T) ( _
    interaction As IInteraction _
) As IEnumerable(Of T)
Visual C++
public:
generic<typename T>
virtual IEnumerable<T>^ ListFilter(
    IInteraction^ interaction
) sealed

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.ListFilter``1(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.ListFilter``1(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.ListFilter``1(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


ListStrategies Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.ListStrategies Method
VoiceService Class See Also Send Feedback
List strategies within the interaction object specified If a null parameter is used, strategies from the service are reported

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IStrategy[] ListStrategies(
    IInteraction targetObject
)
Visual Basic (Declaration)
Public Function ListStrategies ( _
    targetObject As IInteraction _
) As IStrategy()
Visual C++
public:
virtual array<IStrategy^>^ ListStrategies(
    IInteraction^ targetObject
) sealed

Parameters

targetObject
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.ListStrategies(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Return Value

IStrategy []

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


Publish Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceService..::.Publish Method
VoiceService Class See Also Send Feedback

Overload List

Name | Description
Publish<(Of <(T>)>)(T) | Publishes an object to listening subscribers. (Inherited from CustomSubscriber<(Of <(T>)>).)
Publish<(Of <(T>)>)(T) | Publish an event from the service

See Also

VoiceService Class
VoiceService Members
Genesyslab.Enterprise.Services Namespace


Publish(T) Method (T)

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.Publish<(Of <(T>)>) Method (T)
VoiceService Class See Also Send Feedback
Publish an event from the service

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IBrokerPublisher Publish<T>(
    T obj
)
Visual Basic (Declaration)
Public Function Publish(Of T) ( _
    obj As T _
) As IBrokerPublisher
Visual C++
public:
generic<typename T>
virtual IBrokerPublisher^ Publish(
    T obj
) sealed

Parameters

obj
Type: T

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.Publish``1(``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.Publish``1(``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.Publish``1(``0)"]

Implements

IBrokerPublisher..::.Publish<(Of <(T>)>)(T)

See Also

VoiceService Class
Publish Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceService..::.RegisterEvents Method
VoiceService Class See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(IEnvelope<(Of <(IInteraction>)>)>)>)) |
RegisterEvents(IClientChannel, Action<(Of <(IEnvelope<(Of <(IInteraction>)>)>)>), array<IStrategy>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(IEnvelope<(Of <(IInteraction>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(IEnvelope<(Of <(IInteraction>)>)>)>), array<String>[]()[], array<IFilter>[]()[]) |

See Also

VoiceService Class
VoiceService Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(IEnvelope(IInteraction)))

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.RegisterEvents Method (IClientChannel, Action<(Of <(IEnvelope<(Of <(IInteraction>)>)>)>))
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}})"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IVoiceService RegisterEvents(
    IClientChannel channel,
    Action<IEnvelope<IInteraction>> handler
)
Visual Basic (Declaration)
Public Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of IEnvelope(Of IInteraction)) _
) As IVoiceService
Visual C++
public:
virtual IVoiceService^ RegisterEvents(
    IClientChannel^ channel,
    Action<IEnvelope<IInteraction^>^>^ handler
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}})"]

handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( IInteraction >)>)>)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}})"]

Implements

IEventManager<(Of <(D, T>)>)..::.RegisterEvents(IClientChannel, Action<(Of <(T>)>))

See Also

VoiceService Class
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(IEnvelope(IInteraction)), [], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.RegisterEvents Method (IClientChannel, Action<(Of <(IEnvelope<(Of <(IInteraction>)>)>)>), array<>[]()[], array<IFilter>[]()[])
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IVoiceService RegisterEvents(
    IClientChannel channel,
    Action<IEnvelope<IInteraction>> handler,
    IStrategy[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Public Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of IEnvelope(Of IInteraction)), _
    strategyList As IStrategy(), _
    filterList As IFilter() _
) As IVoiceService
Visual C++
public:
virtual IVoiceService^ RegisterEvents(
    IClientChannel^ channel,
    Action<IEnvelope<IInteraction^>^>^ handler,
    array<IStrategy^>^ strategyList,
    array<IFilter^>^ filterList
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( IInteraction >)>)>)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

strategyList
Type: array< IStrategy >[]()[]

[Missing <param name="strategyList"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]

[Missing <param name="filterList"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Implements

IEventManager<(Of <(D, T>)>)..::.RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[])

See Also

VoiceService Class
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(IEnvelope(IInteraction)), Attribute[], Attribute[])

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.RegisterEvents Method (IClientChannel, Action<(Of <(IEnvelope<(Of <(IInteraction>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[])
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}},System.Attribute[],System.Attribute[])"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IVoiceService RegisterEvents(
    IClientChannel channel,
    Action<IEnvelope<IInteraction>> handler,
    Attribute[] strategyList,
    Attribute[] filterList
)
Visual Basic (Declaration)
Public Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of IEnvelope(Of IInteraction)), _
    strategyList As Attribute(), _
    filterList As Attribute() _
) As IVoiceService
Visual C++
public:
virtual IVoiceService^ RegisterEvents(
    IClientChannel^ channel,
    Action<IEnvelope<IInteraction^>^>^ handler,
    array<Attribute^>^ strategyList,
    array<Attribute^>^ filterList
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}},System.Attribute[],System.Attribute[])"]

handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( IInteraction >)>)>)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}},System.Attribute[],System.Attribute[])"]

strategyList
Type: array< System..::.Attribute >[]()[]

[Missing <param name="strategyList"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}},System.Attribute[],System.Attribute[])"]

filterList
Type: array< System..::.Attribute >[]()[]

[Missing <param name="filterList"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}},System.Attribute[],System.Attribute[])"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}},System.Attribute[],System.Attribute[])"]

Implements

IEventManager<(Of <(D, T>)>)..::.RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[])

See Also

VoiceService Class
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(IEnvelope(IInteraction)), String[], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.RegisterEvents Method (IClientChannel, Action<(Of <(IEnvelope<(Of <(IInteraction>)>)>)>), array<String>[]()[], array<IFilter>[]()[])
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IVoiceService RegisterEvents(
    IClientChannel channel,
    Action<IEnvelope<IInteraction>> handler,
    string[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Public Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of IEnvelope(Of IInteraction)), _
    strategyList As String(), _
    filterList As IFilter() _
) As IVoiceService
Visual C++
public:
virtual IVoiceService^ RegisterEvents(
    IClientChannel^ channel,
    Action<IEnvelope<IInteraction^>^>^ handler,
    array<String^>^ strategyList,
    array<IFilter^>^ filterList
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( IInteraction >)>)>)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

strategyList
Type: array< System..::.String >[]()[]

[Missing <param name="strategyList"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]

[Missing <param name="filterList"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Implements

IEventManager<(Of <(D, T>)>)..::.RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[])

See Also

VoiceService Class
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.RegisterFilter<(Of <(T>)>) Method
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterFilter``1(Genesyslab.Enterprise.Model.Interaction.IInteraction,``0)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IVoiceService RegisterFilter<T>(
    IInteraction interaction,
    T filter
)
Visual Basic (Declaration)
Public Function RegisterFilter(Of T) ( _
    interaction As IInteraction, _
    filter As T _
) As IVoiceService
Visual C++
public:
generic<typename T>
virtual IVoiceService^ RegisterFilter(
    IInteraction^ interaction,
    T filter
) sealed

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterFilter``1(Genesyslab.Enterprise.Model.Interaction.IInteraction,``0)"]

filter
Type: T

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterFilter``1(Genesyslab.Enterprise.Model.Interaction.IInteraction,``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterFilter``1(Genesyslab.Enterprise.Model.Interaction.IInteraction,``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RegisterFilter``1(Genesyslab.Enterprise.Model.Interaction.IInteraction,``0)"]

Implements

IVoiceService..::.RegisterFilter<(Of <(T>)>)(IInteraction, T)

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


RemoveAllStrategies Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.RemoveAllStrategies Method
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RemoveAllStrategies"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IStrategyManager<IInteraction> RemoveAllStrategies()
Visual Basic (Declaration)
Public Function RemoveAllStrategies As IStrategyManager(Of IInteraction)
Visual C++
public:
virtual IStrategyManager<IInteraction^>^ RemoveAllStrategies() sealed

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RemoveAllStrategies"]

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


RemoveAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.RemoveAttachedData Method
VoiceService Class See Also Send Feedback
Remove a key withtin atatched data of the specified interaction Update wihtin the interaction context occurs when acknowledge by the back end server If no key is specified (null parameter), all user data are removed. Using this method does not require a SaveAtatchedData()

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IInteraction RemoveAttachedData(
    IInteraction interaction,
    string key
)
Visual Basic (Declaration)
Public Function RemoveAttachedData ( _
    interaction As IInteraction, _
    key As String _
) As IInteraction
Visual C++
public:
virtual IInteraction^ RemoveAttachedData(
    IInteraction^ interaction,
    String^ key
) sealed

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RemoveAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String)"]

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RemoveAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String)"]

Return Value

IInteraction

Implements

IInteractionDomain..::.RemoveAttachedData(IInteraction, String)

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


RemoveChannel Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.RemoveChannel Method
VoiceService Class See Also Send Feedback
Remove a channel from the service

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IVoiceService RemoveChannel(
    IClientChannel channel
)
Visual Basic (Declaration)
Public Function RemoveChannel ( _
    channel As IClientChannel _
) As IVoiceService
Visual C++
public:
virtual IVoiceService^ RemoveChannel(
    IClientChannel^ channel
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RemoveChannel(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Return Value

IInteractionService

Implements

IEventManager<(Of <(D, T>)>)..::.RemoveChannel(IClientChannel)

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


RemoveStrategy Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.RemoveStrategy Method
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RemoveStrategy(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IStrategyManager<IInteraction> RemoveStrategy(
    IInteraction targetObject,
    IStrategy strategy
)
Visual Basic (Declaration)
Public Function RemoveStrategy ( _
    targetObject As IInteraction, _
    strategy As IStrategy _
) As IStrategyManager(Of IInteraction)
Visual C++
public:
virtual IStrategyManager<IInteraction^>^ RemoveStrategy(
    IInteraction^ targetObject,
    IStrategy^ strategy
) sealed

Parameters

targetObject
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RemoveStrategy(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

strategy
Type: IStrategy

[Missing <param name="strategy"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RemoveStrategy(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.RemoveStrategy(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


Save Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceService..::.Save Method
VoiceService Class See Also Send Feedback

Overload List

Name | Description
Save(IInteraction) |
Save(IInteraction, IStrategy) |

See Also

VoiceService Class
VoiceService Members
Genesyslab.Enterprise.Services Namespace


Save Method (IInteraction)

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.Save Method (IInteraction)
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.Save(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool Save(
    IInteraction data
)
Visual Basic (Declaration)
Public Function Save ( _
    data As IInteraction _
) As Boolean
Visual C++
public:
virtual bool Save(
    IInteraction^ data
) sealed

Parameters

data
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="data"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.Save(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.Save(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Implements

IPersistable<(Of <(T>)>)..::.Save(T)

See Also

VoiceService Class
Save Overload
Genesyslab.Enterprise.Services Namespace


Save Method (IInteraction, )

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.Save Method (IInteraction, )
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.Save(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public bool Save(
    IInteraction data,
    IStrategy strategy
)
Visual Basic (Declaration)
Public Function Save ( _
    data As IInteraction, _
    strategy As IStrategy _
) As Boolean
Visual C++
public:
virtual bool Save(
    IInteraction^ data,
    IStrategy^ strategy
) sealed

Parameters

data
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="data"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.Save(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

strategy
Type: IStrategy

[Missing <param name="strategy"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.Save(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.Save(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

Implements

IPersistable<(Of <(T>)>)..::.Save(T, IStrategy)

See Also

VoiceService Class
Save Overload
Genesyslab.Enterprise.Services Namespace


SaveAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.SaveAttachedData Method
VoiceService Class See Also Send Feedback
Save attached data of an interaction. Manual synchronization Use this method if attributes are modified without using the SetAtatchedData methods

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IInteraction SaveAttachedData(
    IInteraction interaction
)
Visual Basic (Declaration)
Public Function SaveAttachedData ( _
    interaction As IInteraction _
) As IInteraction
Visual C++
public:
virtual IInteraction^ SaveAttachedData(
    IInteraction^ interaction
) sealed

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.SaveAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Return Value

IInteraction

Implements

IInteractionDomain..::.SaveAttachedData(IInteraction)

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


SaveInteraction Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.SaveInteraction Method
VoiceService Class See Also Send Feedback
Save interaction specified wihtin the interaction service

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IInteractionDomain SaveInteraction(
    IInteraction interaction
)
Visual Basic (Declaration)
Public Function SaveInteraction ( _
    interaction As IInteraction _
) As IInteractionDomain
Visual C++
public:
virtual IInteractionDomain^ SaveInteraction(
    IInteraction^ interaction
) sealed

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.SaveInteraction(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Return Value

IInteractionDomain

Implements

IInteractionDomain..::.SaveInteraction(IInteraction)

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceService..::.SetAttachedData Method
VoiceService Class See Also Send Feedback

Overload List

Name | Description
SetAttachedData(IInteraction, KeyValueCollection) | Set attached data specified in parameter to the interaction, in the "UserData" section Update in interaction is done when acknowledge by the back end server Using this method does not require a SaveAtatchedData()
SetAttachedData(IInteraction, String, Object) | Set attached data to the specified interaction, Update in interaction ("UserData" section) is done when acknowledge by the back end server Using this method does not require a SaveAtatchedData()

See Also

VoiceService Class
VoiceService Members
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method (IInteraction, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.SetAttachedData Method (IInteraction, KeyValueCollection)
VoiceService Class See Also Send Feedback
Set attached data specified in parameter to the interaction, in the "UserData" section Update in interaction is done when acknowledge by the back end server Using this method does not require a SaveAtatchedData()

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IInteraction SetAttachedData(
    IInteraction interaction,
    KeyValueCollection data
)
Visual Basic (Declaration)
Public Function SetAttachedData ( _
    interaction As IInteraction, _
    data As KeyValueCollection _
) As IInteraction
Visual C++
public:
virtual IInteraction^ SetAttachedData(
    IInteraction^ interaction,
    KeyValueCollection^ data
) sealed

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.SetAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

data
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="data"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.SetAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

IInteraction

Implements

IInteractionDomain..::.SetAttachedData(IInteraction, KeyValueCollection)

See Also

VoiceService Class
SetAttachedData Overload
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method (IInteraction, String, Object)

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.SetAttachedData Method (IInteraction, String, Object)
VoiceService Class See Also Send Feedback
Set attached data to the specified interaction, Update in interaction ("UserData" section) is done when acknowledge by the back end server Using this method does not require a SaveAtatchedData()

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IInteraction SetAttachedData(
    IInteraction interaction,
    string key,
    Object value
)
Visual Basic (Declaration)
Public Function SetAttachedData ( _
    interaction As IInteraction, _
    key As String, _
    value As Object _
) As IInteraction
Visual C++
public:
virtual IInteraction^ SetAttachedData(
    IInteraction^ interaction,
    String^ key,
    Object^ value
) sealed

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.SetAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.Object)"]

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.SetAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.Object)"]

value
Type: System..::.Object

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.SetAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.Object)"]

Return Value

IInteraction

Implements

IInteractionDomain..::.SetAttachedData(IInteraction, String, Object)

See Also

VoiceService Class
SetAttachedData Overload
Genesyslab.Enterprise.Services Namespace


SetStrategy Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.SetStrategy Method
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.SetStrategy(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IStrategyManager<IInteraction> SetStrategy(
    IInteraction targetObject,
    IStrategy strategy
)
Visual Basic (Declaration)
Public Function SetStrategy ( _
    targetObject As IInteraction, _
    strategy As IStrategy _
) As IStrategyManager(Of IInteraction)
Visual C++
public:
virtual IStrategyManager<IInteraction^>^ SetStrategy(
    IInteraction^ targetObject,
    IStrategy^ strategy
) sealed

Parameters

targetObject
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.SetStrategy(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

strategy
Type: IStrategy

[Missing <param name="strategy"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.SetStrategy(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.SetStrategy(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


ToString Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.ToString Method
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.ToString"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.ToString"]

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.UnRegisterEvents Method
VoiceService Class See Also Send Feedback
Unregister events from the specified channel

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IVoiceService UnRegisterEvents(
    IClientChannel channel,
    Action<IEnvelope<IInteraction>> handler
)
Visual Basic (Declaration)
Public Function UnRegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of IEnvelope(Of IInteraction)) _
) As IVoiceService
Visual C++
public:
virtual IVoiceService^ UnRegisterEvents(
    IClientChannel^ channel,
    Action<IEnvelope<IInteraction^>^>^ handler
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.UnRegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}})"]

handler
Type: System..::.Action<(Of <( IEnvelope <(Of <( IInteraction >)>)>)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.UnRegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.Interaction.IInteraction}})"]

Return Value

IInteractionService

Implements

IEventManager<(Of <(D, T>)>)..::.UnRegisterEvents(IClientChannel, Action<(Of <(T>)>))

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.UnRegisterFilter<(Of <(T>)>) Method
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.UnRegisterFilter``1(Genesyslab.Enterprise.Model.Interaction.IInteraction,``0)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IVoiceService UnRegisterFilter<T>(
    IInteraction interaction,
    T filter
)
Visual Basic (Declaration)
Public Function UnRegisterFilter(Of T) ( _
    interaction As IInteraction, _
    filter As T _
) As IVoiceService
Visual C++
public:
generic<typename T>
virtual IVoiceService^ UnRegisterFilter(
    IInteraction^ interaction,
    T filter
) sealed

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.UnRegisterFilter``1(Genesyslab.Enterprise.Model.Interaction.IInteraction,``0)"]

filter
Type: T

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.UnRegisterFilter``1(Genesyslab.Enterprise.Model.Interaction.IInteraction,``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.UnRegisterFilter``1(Genesyslab.Enterprise.Model.Interaction.IInteraction,``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.VoiceService.UnRegisterFilter``1(Genesyslab.Enterprise.Model.Interaction.IInteraction,``0)"]

Implements

IVoiceService..::.UnRegisterFilter<(Of <(T>)>)(IInteraction, T)

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


VoiceService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
VoiceService Properties
VoiceService Class See Also Send Feedback

The VoiceService type exposes the following members.

Properties

Name | Description
ContactServerId |
Count | Gets the number of service subscribers. (Inherited from CustomSubscriber<(Of <(T>)>).)
Description | Get friendly description of the service (Overrides ContainerBaseDescription()()().)
EventSubscription | Gets the Service subscriber. (Inherited from CustomSubscriber<(Of <(T>)>).)
Filter |
ServiceName | Get friendly service name (Overrides ContainerBaseServiceName()()().)

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


ContactServerId Property

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.ContactServerId Property
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.VoiceService.ContactServerId"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public string ContactServerId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContactServerId As String
Visual C++
public:
virtual property String^ ContactServerId {
    String^ get () sealed;
}

Implements

IPersistable<(Of <(T>)>)..::.ContactServerId

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.Description Property
VoiceService Class See Also Send Feedback
Get friendly description of the service

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override string Description { get; set; }
Visual Basic (Declaration)
Public Overrides Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IService..::.Description

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


Filter Property

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.Filter Property
VoiceService Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.VoiceService.Filter"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public IPredicatable<IEnvelope<IRequest>> Filter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filter As IPredicatable(Of IEnvelope(Of IRequest))
Visual C++
public:
virtual property IPredicatable<IEnvelope<IRequest^>^>^ Filter {
    IPredicatable<IEnvelope<IRequest^>^>^ get () sealed;
}

Implements

ISubscribeable<(Of <(T>)>)..::.Filter

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


ServiceName Property

[image]

Enterprise SDK 8.0 Reference API
VoiceService..::.ServiceName Property
VoiceService Class See Also Send Feedback
Get friendly service name

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public override string ServiceName { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ServiceName As String
Visual C++
public:
virtual property String^ ServiceName {
    String^ get () override;
}

Implements

IService..::.ServiceName
IEnterpriseServiceProvider..::.ServiceName

See Also

VoiceService Class
Genesyslab.Enterprise.Services Namespace


Genesyslab.Enterprise.Services.Model Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Services.Model Namespace
Send Feedback

Interfaces

Interface | Description
IMonitorAgentGroupStatus | AgentGroup status.
IMonitorAgentStatus | Interface for Agent Status Monitoring.
IMonitorEventStatus | Interface for Event Status Monitoring.

Enumerations

Enumeration | Description
AgentGroupStatus | Enumerate for Agent Group statistics object type.
AgentStatus | Enumerate for Agent statistics object type.


AgentGroupStatus Enumeration

[image]

Enterprise SDK 8.0 Reference API
AgentGroupStatus Enumeration
See Also Send Feedback
Enumerate for Agent Group statistics object type.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[SerializableAttribute]
public enum AgentGroupStatus
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration AgentGroupStatus
Visual C++
[SerializableAttribute]
public enum class AgentGroupStatus

Members

Member name | Description
LoggedOut |
Ready |
NotReady |
AfterCallWork |
CallInbound |
CallInternal |
CallOutbound |

See Also

Genesyslab.Enterprise.Services.Model Namespace


AgentStatus Enumeration

[image]

Enterprise SDK 8.0 Reference API
AgentStatus Enumeration
See Also Send Feedback
Enumerate for Agent statistics object type.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
[SerializableAttribute]
public enum AgentStatus
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration AgentStatus
Visual C++
[SerializableAttribute]
public enum class AgentStatus

Members

Member name | Description
LoggedOut |
Ready |
NotReady |
AfterCallWork |
CallInbound |
CallInternal |
CallOutbound |
CallConsult |
CallOnHold |

See Also

Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentGroupStatus Interface

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus Interface
Members See Also Send Feedback
AgentGroup status.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IMonitorAgentGroupStatus : IMonitorEventStatus,
    ISerializable
Visual Basic (Declaration)
Public Interface IMonitorAgentGroupStatus _
    Implements IMonitorEventStatus, ISerializable
Visual C++
public interface class IMonitorAgentGroupStatus : IMonitorEventStatus,
    ISerializable

See Also

IMonitorAgentGroupStatus Members
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentGroupStatus Members

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus Members
IMonitorAgentGroupStatus Interface Methods Properties See Also Send Feedback

The IMonitorAgentGroupStatus type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

Properties

Name | Description
AgentCount | Returns the number of agents of the agent group associated with this event.
GroupID | Returns the identifier of the group.
Status | Returns the new status of this agent group.

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentGroupStatus Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus Methods
IMonitorAgentGroupStatus Interface See Also Send Feedback

The IMonitorAgentGroupStatus type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentGroupStatus Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus Properties
IMonitorAgentGroupStatus Interface See Also Send Feedback

The IMonitorAgentGroupStatus type exposes the following members.

Properties

Name | Description
AgentCount | Returns the number of agents of the agent group associated with this event.
GroupID | Returns the identifier of the group.
Status | Returns the new status of this agent group.

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


AgentCount Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus..::.AgentCount Property
IMonitorAgentGroupStatus Interface See Also Send Feedback
Returns the number of agents of the agent group associated with this event.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
int AgentCount { get; }
Visual Basic (Declaration)
ReadOnly Property AgentCount As Integer
Visual C++
property int AgentCount {
    int get ();
}

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


GroupID Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus..::.GroupID Property
IMonitorAgentGroupStatus Interface See Also Send Feedback
Returns the identifier of the group.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string GroupID { get; }
Visual Basic (Declaration)
ReadOnly Property GroupID As String
Visual C++
property String^ GroupID {
    String^ get ();
}

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


Status Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus..::.Status Property
IMonitorAgentGroupStatus Interface See Also Send Feedback
Returns the new status of this agent group.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
AgentGroupStatus Status { get; }
Visual Basic (Declaration)
ReadOnly Property Status As AgentGroupStatus
Visual C++
property AgentGroupStatus Status {
    AgentGroupStatus get ();
}

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentStatus Interface

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus Interface
Members See Also Send Feedback
Interface for Agent Status Monitoring.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IMonitorAgentStatus : IMonitorEventStatus,
    ISerializable
Visual Basic (Declaration)
Public Interface IMonitorAgentStatus _
    Implements IMonitorEventStatus, ISerializable
Visual C++
public interface class IMonitorAgentStatus : IMonitorEventStatus,
    ISerializable

See Also

IMonitorAgentStatus Members
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentStatus Members

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus Members
IMonitorAgentStatus Interface Methods Properties See Also Send Feedback

The IMonitorAgentStatus type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

Properties

Name | Description
AgentID | returns the Agent ID.
MediaCapacities | Returns the Media capacities of the agent. Only available with Statistics Extended methods.
MediaMaxCapacities | Returns the Media Maximum capacities of the agent. Only available with Statistics Extended methods.
MediaStatuses | returns the DN statuses of the agent.
PlaceID | returns the Place ID of the Agent.
Reasons | Returns the NotReady/Ready Reasons dictionary of the agent. The key is the name of the action code. The value is the code of the action code.
Status | returns the status of the agent.

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentStatus Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus Methods
IMonitorAgentStatus Interface See Also Send Feedback

The IMonitorAgentStatus type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentStatus Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus Properties
IMonitorAgentStatus Interface See Also Send Feedback

The IMonitorAgentStatus type exposes the following members.

Properties

Name | Description
AgentID | returns the Agent ID.
MediaCapacities | Returns the Media capacities of the agent. Only available with Statistics Extended methods.
MediaMaxCapacities | Returns the Media Maximum capacities of the agent. Only available with Statistics Extended methods.
MediaStatuses | returns the DN statuses of the agent.
PlaceID | returns the Place ID of the Agent.
Reasons | Returns the NotReady/Ready Reasons dictionary of the agent. The key is the name of the action code. The value is the code of the action code.
Status | returns the status of the agent.

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


AgentID Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.AgentID Property
IMonitorAgentStatus Interface See Also Send Feedback
returns the Agent ID.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string AgentID { get; }
Visual Basic (Declaration)
ReadOnly Property AgentID As String
Visual C++
property String^ AgentID {
    String^ get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


MediaCapacities Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.MediaCapacities Property
IMonitorAgentStatus Interface See Also Send Feedback
Returns the Media capacities of the agent. Only available with Statistics Extended methods.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionary<string, int> MediaCapacities { get; }
Visual Basic (Declaration)
ReadOnly Property MediaCapacities As IDictionary(Of String, Integer)
Visual C++
property IDictionary<String^, int>^ MediaCapacities {
    IDictionary<String^, int>^ get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


MediaMaxCapacities Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.MediaMaxCapacities Property
IMonitorAgentStatus Interface See Also Send Feedback
Returns the Media Maximum capacities of the agent. Only available with Statistics Extended methods.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionary<string, int> MediaMaxCapacities { get; }
Visual Basic (Declaration)
ReadOnly Property MediaMaxCapacities As IDictionary(Of String, Integer)
Visual C++
property IDictionary<String^, int>^ MediaMaxCapacities {
    IDictionary<String^, int>^ get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


MediaStatuses Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.MediaStatuses Property
IMonitorAgentStatus Interface See Also Send Feedback
returns the DN statuses of the agent.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionary<string, IMonitorMediaStatus> MediaStatuses { get; }
Visual Basic (Declaration)
ReadOnly Property MediaStatuses As IDictionary(Of String, IMonitorMediaStatus)
Visual C++
property IDictionary<String^, IMonitorMediaStatus^>^ MediaStatuses {
    IDictionary<String^, IMonitorMediaStatus^>^ get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


PlaceID Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.PlaceID Property
IMonitorAgentStatus Interface See Also Send Feedback
returns the Place ID of the Agent.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
string PlaceID { get; }
Visual Basic (Declaration)
ReadOnly Property PlaceID As String
Visual C++
property String^ PlaceID {
    String^ get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.Reasons Property
IMonitorAgentStatus Interface See Also Send Feedback
Returns the NotReady/Ready Reasons dictionary of the agent. The key is the name of the action code. The value is the code of the action code.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
IDictionary<string, string> Reasons { get; }
Visual Basic (Declaration)
ReadOnly Property Reasons As IDictionary(Of String, String)
Visual C++
property IDictionary<String^, String^>^ Reasons {
    IDictionary<String^, String^>^ get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


Status Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.Status Property
IMonitorAgentStatus Interface See Also Send Feedback
returns the status of the agent.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
AgentStatus Status { get; }
Visual Basic (Declaration)
ReadOnly Property Status As AgentStatus
Visual C++
property AgentStatus Status {
    AgentStatus get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorEventStatus Interface

[image]

Enterprise SDK 8.0 Reference API
IMonitorEventStatus Interface
Members See Also Send Feedback
Interface for Event Status Monitoring.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public interface IMonitorEventStatus : ISerializable
Visual Basic (Declaration)
Public Interface IMonitorEventStatus _
    Implements ISerializable
Visual C++
public interface class IMonitorEventStatus : ISerializable

See Also

IMonitorEventStatus Members
Genesyslab.Enterprise.Services.Model Namespace


IMonitorEventStatus Members

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorEventStatus Members
IMonitorEventStatus Interface Methods See Also Send Feedback

The IMonitorEventStatus type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IMonitorEventStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorEventStatus Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorEventStatus Methods
IMonitorEventStatus Interface See Also Send Feedback

The IMonitorEventStatus type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IMonitorEventStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


Genesyslab.Enterprise.Services.Unity Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Services.Unity Namespace
Send Feedback

Classes

Class | Description
UnityRegistrationChecker |
UnityRegistrationChecker..::.UnityExtensionWithTypeTracking |


UnityRegistrationChecker Class

[image]

Enterprise SDK 8.0 Reference API
UnityRegistrationChecker Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker"]

Namespace: Genesyslab.Enterprise.Services.Unity
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static class UnityRegistrationChecker
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class UnityRegistrationChecker
Visual C++
[ExtensionAttribute]
public ref class UnityRegistrationChecker abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Services.Unity..::.UnityRegistrationChecker

See Also

UnityRegistrationChecker Members
Genesyslab.Enterprise.Services.Unity Namespace


UnityRegistrationChecker Members

[image] [image]

Enterprise SDK 8.0 Reference API
UnityRegistrationChecker Members
UnityRegistrationChecker Class Methods See Also Send Feedback

Methods

Name | Description
CanResolve | Overloaded.

See Also

UnityRegistrationChecker Class
Genesyslab.Enterprise.Services.Unity Namespace


UnityRegistrationChecker Methods

[image] [image]

Enterprise SDK 8.0 Reference API
UnityRegistrationChecker Methods
UnityRegistrationChecker Class See Also Send Feedback

Methods

Name | Description
CanResolve | Overloaded.

See Also

UnityRegistrationChecker Class
Genesyslab.Enterprise.Services.Unity Namespace


CanResolve Method

[image] [image]

Enterprise SDK 8.0 Reference API
UnityRegistrationChecker..::.CanResolve Method
UnityRegistrationChecker Class See Also Send Feedback

Overload List

Name | Description
CanResolve<(Of <(T>)>)(IUnityContainer) |
CanResolve<(Of <(T>)>)(IUnityContainer, String) |
CanResolve(IUnityContainer, Type) |
CanResolve(IUnityContainer, Type, String) |

See Also

UnityRegistrationChecker Class
UnityRegistrationChecker Members
Genesyslab.Enterprise.Services.Unity Namespace


CanResolve(T) Method ()

[image]

Enterprise SDK 8.0 Reference API
UnityRegistrationChecker..::.CanResolve<(Of <(T>)>) Method ()
UnityRegistrationChecker Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.CanResolve``1(Microsoft.Practices.Unity.IUnityContainer)"]

Namespace: Genesyslab.Enterprise.Services.Unity
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static bool CanResolve<T>(
    this IUnityContainer container
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CanResolve(Of T) ( _
    container As IUnityContainer _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
generic<typename T>
static bool CanResolve(
    IUnityContainer^ container
)

Parameters

container
Type: IUnityContainer

[Missing <param name="container"/> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.CanResolve``1(Microsoft.Practices.Unity.IUnityContainer)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.CanResolve``1(Microsoft.Practices.Unity.IUnityContainer)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.CanResolve``1(Microsoft.Practices.Unity.IUnityContainer)"]

See Also

UnityRegistrationChecker Class
CanResolve Overload
Genesyslab.Enterprise.Services.Unity Namespace


CanResolve(T) Method (, String)

[image]

Enterprise SDK 8.0 Reference API
UnityRegistrationChecker..::.CanResolve<(Of <(T>)>) Method (, String)
UnityRegistrationChecker Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.CanResolve``1(Microsoft.Practices.Unity.IUnityContainer,System.String)"]

Namespace: Genesyslab.Enterprise.Services.Unity
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static bool CanResolve<T>(
    this IUnityContainer container,
    string name
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CanResolve(Of T) ( _
    container As IUnityContainer, _
    name As String _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
generic<typename T>
static bool CanResolve(
    IUnityContainer^ container,
    String^ name
)

Parameters

container
Type: IUnityContainer

[Missing <param name="container"/> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.CanResolve``1(Microsoft.Practices.Unity.IUnityContainer,System.String)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.CanResolve``1(Microsoft.Practices.Unity.IUnityContainer,System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.CanResolve``1(Microsoft.Practices.Unity.IUnityContainer,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.CanResolve``1(Microsoft.Practices.Unity.IUnityContainer,System.String)"]

See Also

UnityRegistrationChecker Class
CanResolve Overload
Genesyslab.Enterprise.Services.Unity Namespace


CanResolve Method (, Type)

[image]

Enterprise SDK 8.0 Reference API
UnityRegistrationChecker..::.CanResolve Method (, Type)
UnityRegistrationChecker Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.CanResolve(Microsoft.Practices.Unity.IUnityContainer,System.Type)"]

Namespace: Genesyslab.Enterprise.Services.Unity
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static bool CanResolve(
    this IUnityContainer container,
    Type v
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CanResolve ( _
    container As IUnityContainer, _
    v As Type _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool CanResolve(
    IUnityContainer^ container,
    Type^ v
)

Parameters

container
Type: IUnityContainer

[Missing <param name="container"/> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.CanResolve(Microsoft.Practices.Unity.IUnityContainer,System.Type)"]

v
Type: System..::.Type

[Missing <param name="v"/> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.CanResolve(Microsoft.Practices.Unity.IUnityContainer,System.Type)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.CanResolve(Microsoft.Practices.Unity.IUnityContainer,System.Type)"]

See Also

UnityRegistrationChecker Class
CanResolve Overload
Genesyslab.Enterprise.Services.Unity Namespace


CanResolve Method (, Type, String)

[image]

Enterprise SDK 8.0 Reference API
UnityRegistrationChecker..::.CanResolve Method (, Type, String)
UnityRegistrationChecker Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.CanResolve(Microsoft.Practices.Unity.IUnityContainer,System.Type,System.String)"]

Namespace: Genesyslab.Enterprise.Services.Unity
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public static bool CanResolve(
    this IUnityContainer container,
    Type v,
    string name
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CanResolve ( _
    container As IUnityContainer, _
    v As Type, _
    name As String _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool CanResolve(
    IUnityContainer^ container,
    Type^ v,
    String^ name
)

Parameters

container
Type: IUnityContainer

[Missing <param name="container"/> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.CanResolve(Microsoft.Practices.Unity.IUnityContainer,System.Type,System.String)"]

v
Type: System..::.Type

[Missing <param name="v"/> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.CanResolve(Microsoft.Practices.Unity.IUnityContainer,System.Type,System.String)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.CanResolve(Microsoft.Practices.Unity.IUnityContainer,System.Type,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.CanResolve(Microsoft.Practices.Unity.IUnityContainer,System.Type,System.String)"]

See Also

UnityRegistrationChecker Class
CanResolve Overload
Genesyslab.Enterprise.Services.Unity Namespace


UnityRegistrationChecker.UnityExtensionWithTypeTracking Class

[image]

Enterprise SDK 8.0 Reference API
UnityRegistrationChecker..::.UnityExtensionWithTypeTracking Class
UnityRegistrationChecker Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.UnityExtensionWithTypeTracking"]

Namespace: Genesyslab.Enterprise.Services.Unity
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public class UnityExtensionWithTypeTracking : UnityContainerExtension
Visual Basic (Declaration)
Public Class UnityExtensionWithTypeTracking _
    Inherits UnityContainerExtension
Visual C++
public ref class UnityExtensionWithTypeTracking : public UnityContainerExtension

Inheritance Hierarchy

System..::.Object
UnityContainerExtension
Genesyslab.Enterprise.Services.Unity..::.UnityRegistrationChecker..::.UnityExtensionWithTypeTracking

See Also

UnityRegistrationChecker..::.UnityExtensionWithTypeTracking Members
Genesyslab.Enterprise.Services.Unity Namespace


UnityRegistrationChecker.UnityExtensionWithTypeTracking Members

[image] [image]

Enterprise SDK 8.0 Reference API
UnityRegistrationChecker..::.UnityExtensionWithTypeTracking Members
UnityRegistrationChecker..::.UnityExtensionWithTypeTracking Class Constructors Methods Properties See Also Send Feedback

The UnityRegistrationChecker..::.UnityExtensionWithTypeTracking type exposes the following members.

Constructors

Name | Description
UnityRegistrationChecker..::.UnityExtensionWithTypeTracking |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeExtension | (Inherited from UnityContainerExtension.)
Remove | (Inherited from UnityContainerExtension.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Container | (Inherited from UnityContainerExtension.)

See Also

UnityRegistrationChecker..::.UnityExtensionWithTypeTracking Class
Genesyslab.Enterprise.Services.Unity Namespace


UnityRegistrationChecker.UnityExtensionWithTypeTracking Constructor

[image]

Enterprise SDK 8.0 Reference API
UnityRegistrationChecker..::.UnityExtensionWithTypeTracking Constructor
UnityRegistrationChecker..::.UnityExtensionWithTypeTracking Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Unity.UnityRegistrationChecker.UnityExtensionWithTypeTracking.#ctor"]

Namespace: Genesyslab.Enterprise.Services.Unity
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.100.3 (8.0.100.03)

Syntax

C#
public UnityExtensionWithTypeTracking()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UnityExtensionWithTypeTracking()

See Also

UnityRegistrationChecker..::.UnityExtensionWithTypeTracking Class
Genesyslab.Enterprise.Services.Unity Namespace


UnityRegistrationChecker.UnityExtensionWithTypeTracking Methods

[image] [image]

Enterprise SDK 8.0 Reference API
UnityRegistrationChecker..::.UnityExtensionWithTypeTracking Methods
UnityRegistrationChecker..::.UnityExtensionWithTypeTracking Class See Also Send Feedback

The UnityRegistrationChecker..::.UnityExtensionWithTypeTracking type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeExtension | (Inherited from UnityContainerExtension.)
Remove | (Inherited from UnityContainerExtension.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UnityRegistrationChecker..::.UnityExtensionWithTypeTracking Class
Genesyslab.Enterprise.Services.Unity Namespace


UnityRegistrationChecker.UnityExtensionWithTypeTracking Properties

[image] [image]

Enterprise SDK 8.0 Reference API
UnityRegistrationChecker..::.UnityExtensionWithTypeTracking Properties
UnityRegistrationChecker..::.UnityExtensionWithTypeTracking Class See Also Send Feedback

The UnityRegistrationChecker..::.UnityExtensionWithTypeTracking type exposes the following members.

Properties

Name | Description
Container | (Inherited from UnityContainerExtension.)

See Also

UnityRegistrationChecker..::.UnityExtensionWithTypeTracking Class
Genesyslab.Enterprise.Services.Unity Namespace